HeuristicLab.AdvancedOptimizationFrontend Namespace

HeuristicLab API Documentation
HeuristicLab.AdvancedOptimizationFrontend Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.AdvancedOptimizationFrontend]

Classes

Class | Description
AboutDialog |
AvailableOperatorsForm |
EditorForm |
HeuristicLabAdvancedOptimizationFrontendApplication |
HeuristicLabAdvancedOptimizationFrontendPlugin |
MainForm |
ViewForm |

Send comments on this topic to support@heuristiclab.com

(c) 2002-2008 HEAL


AboutDialog Class

AboutDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.AboutDialog]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AboutDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.AdvancedOptimizationFrontend..::.AboutDialog

See Also

AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


AboutDialog Members

[image]

HeuristicLab API Documentation
AboutDialog Members
AboutDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDialog type exposes the following members.

Constructors

Name | Description
AboutDialog |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AboutDialog Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AboutDialog Constructor

AboutDialog Constructor
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AboutDialog class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AboutDialog()

See Also

AboutDialog Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AboutDialog Methods

[image]

HeuristicLab API Documentation
AboutDialog Methods
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AboutDialog Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AboutDialog..::.AccessibilityNotifyClients Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AboutDialog..::.BeginInvoke Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Dispose Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method (Boolean)

AboutDialog..::.Dispose Method (Boolean)
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AboutDialog Class
Dispose Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AboutDialog..::.GetChildAtPoint Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Invalidate Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Invoke Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AboutDialog..::.MemberwiseClone Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AboutDialog..::.PerformLayout Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AboutDialog..::.ResumeLayout Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AboutDialog..::.RtlTranslateAlignment Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Scale Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Select Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AboutDialog..::.SetBounds Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Show Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
AboutDialog..::.ShowDialog Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AboutDialog..::.UpdateBounds Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Validate Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AboutDialog..::.ValidateChildren Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


AvailableOperatorsForm Class

AvailableOperatorsForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.AvailableOperatorsForm]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AvailableOperatorsForm : DockContent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
HeuristicLab.AdvancedOptimizationFrontend..::.AvailableOperatorsForm

See Also

AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


AvailableOperatorsForm Members

[image]

HeuristicLab API Documentation
AvailableOperatorsForm Members
AvailableOperatorsForm Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AvailableOperatorsForm type exposes the following members.

Constructors

Name | Description
AvailableOperatorsForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockHandler_DockStateChanged | (Inherited from DockContent.)
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
ShouldSerializeTabText | (Inherited from DockContent.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
m_dockHandler | (Inherited from DockContent.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AvailableOperatorsForm Constructor

AvailableOperatorsForm Constructor
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AvailableOperatorsForm class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AvailableOperatorsForm()

See Also

AvailableOperatorsForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AvailableOperatorsForm Methods

[image]

HeuristicLab API Documentation
AvailableOperatorsForm Methods
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AvailableOperatorsForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockHandler_DockStateChanged | (Inherited from DockContent.)
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
ShouldSerializeTabText | (Inherited from DockContent.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AvailableOperatorsForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.AccessibilityNotifyClients Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.BeginInvoke Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Dispose Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method (Boolean)

AvailableOperatorsForm..::.Dispose Method (Boolean)
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AvailableOperatorsForm Class
Dispose Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


DockTo Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.DockTo Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.GetChildAtPoint Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Invalidate Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Invoke Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.MemberwiseClone Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.PerformLayout Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.ResumeLayout Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.RtlTranslateAlignment Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Scale Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Select Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.SetBounds Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Show Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.ShowDialog Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.UpdateBounds Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Validate Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.ValidateChildren Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Class

EditorForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.EditorForm]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EditorForm : DockContent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
HeuristicLab.AdvancedOptimizationFrontend..::.EditorForm

See Also

EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Members

[image]

HeuristicLab API Documentation
EditorForm Members
EditorForm Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorForm type exposes the following members.

Constructors

Name | Description
EditorForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockHandler_DockStateChanged | (Inherited from DockContent.)
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
ShouldSerializeTabText | (Inherited from DockContent.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
m_dockHandler | (Inherited from DockContent.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Editor |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EditorForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Constructor

[image]

HeuristicLab API Documentation
EditorForm Constructor
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditorForm()()() |
EditorForm(IEditor) |

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Constructor

EditorForm Constructor
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EditorForm class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EditorForm()

See Also

EditorForm Class
EditorForm Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Constructor (IEditor)

EditorForm Constructor (IEditor)
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EditorForm class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EditorForm(
    IEditor editor
)

Parameters

editor
Type: HeuristicLab.Core..::.IEditor

[Missing <param> documentation for "editor"]

See Also

EditorForm Class
EditorForm Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Methods

[image]

HeuristicLab API Documentation
EditorForm Methods
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockHandler_DockStateChanged | (Inherited from DockContent.)
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
ShouldSerializeTabText | (Inherited from DockContent.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

EditorForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
EditorForm..::.AccessibilityNotifyClients Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
EditorForm..::.BeginInvoke Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
EditorForm..::.Dispose Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method (Boolean)

EditorForm..::.Dispose Method (Boolean)
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

EditorForm Class
Dispose Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


DockTo Method

[image]

HeuristicLab API Documentation
EditorForm..::.DockTo Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
EditorForm..::.GetChildAtPoint Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
EditorForm..::.Invalidate Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
EditorForm..::.Invoke Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
EditorForm..::.MemberwiseClone Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
EditorForm..::.PerformLayout Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
EditorForm..::.ResumeLayout Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
EditorForm..::.RtlTranslateAlignment Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
EditorForm..::.Scale Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
EditorForm..::.Select Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
EditorForm..::.SetBounds Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
EditorForm..::.Show Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
EditorForm..::.ShowDialog Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
EditorForm..::.UpdateBounds Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
EditorForm..::.Validate Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
EditorForm..::.ValidateChildren Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


EditorForm Properties

[image]

HeuristicLab API Documentation
EditorForm Properties
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Editor |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

EditorForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


Editor Property

EditorForm..::.Editor Property
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.AdvancedOptimizationFrontend.EditorForm.Editor]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEditor Editor { get; }

See Also

EditorForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendApplication Class

HeuristicLabAdvancedOptimizationFrontendApplication Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.HeuristicLabAdvancedOptimizationFrontendApplication]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "HeuristicLab 3.0 (dockable)", Description = "Next generation heuristic optimization environment.")]
internal class HeuristicLabAdvancedOptimizationFrontendApplication : ApplicationBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.ApplicationBase
HeuristicLab.AdvancedOptimizationFrontend..::.HeuristicLabAdvancedOptimizationFrontendApplication

See Also

HeuristicLabAdvancedOptimizationFrontendApplication Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendApplication Members

[image]

HeuristicLab API Documentation
HeuristicLabAdvancedOptimizationFrontendApplication Members
HeuristicLabAdvancedOptimizationFrontendApplication Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabAdvancedOptimizationFrontendApplication type exposes the following members.

Constructors

Name | Description
HeuristicLabAdvancedOptimizationFrontendApplication |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from ApplicationBase.)
Name | (Inherited from ApplicationBase.)
Version | (Inherited from ApplicationBase.)

See Also

HeuristicLabAdvancedOptimizationFrontendApplication Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendApplication Constructor

HeuristicLabAdvancedOptimizationFrontendApplication Constructor
HeuristicLabAdvancedOptimizationFrontendApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabAdvancedOptimizationFrontendApplication class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabAdvancedOptimizationFrontendApplication()

See Also

HeuristicLabAdvancedOptimizationFrontendApplication Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendApplication Methods

[image]

HeuristicLab API Documentation
HeuristicLabAdvancedOptimizationFrontendApplication Methods
HeuristicLabAdvancedOptimizationFrontendApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabAdvancedOptimizationFrontendApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HeuristicLabAdvancedOptimizationFrontendApplication Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


Run Method

HeuristicLabAdvancedOptimizationFrontendApplication..::.Run Method
HeuristicLabAdvancedOptimizationFrontendApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.AdvancedOptimizationFrontend.HeuristicLabAdvancedOptimizationFrontendApplication.Run]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Run()

Implements

IApplication..::.Run()()()

See Also

HeuristicLabAdvancedOptimizationFrontendApplication Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendPlugin Class

HeuristicLabAdvancedOptimizationFrontendPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.HeuristicLabAdvancedOptimizationFrontendPlugin]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "WeifenLuo.WinFormsUI.Docking.dll", Filetype = PluginFileType.Assembly)]
[PluginFileAttribute(Filename = "WeifenLuo.WinFormsUI.Docking License.txt",
    Filetype = PluginFileType.License)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[ClassInfoAttribute(Name = "HeuristicLab.AdvancedOptimizationFrontend")]
[PluginFileAttribute(Filename = "HeuristicLab.AdvancedOptimizationFrontend.dll",
    Filetype = PluginFileType.Assembly)]
public class HeuristicLabAdvancedOptimizationFrontendPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.AdvancedOptimizationFrontend..::.HeuristicLabAdvancedOptimizationFrontendPlugin

See Also

HeuristicLabAdvancedOptimizationFrontendPlugin Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabAdvancedOptimizationFrontendPlugin Members
HeuristicLabAdvancedOptimizationFrontendPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabAdvancedOptimizationFrontendPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabAdvancedOptimizationFrontendPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabAdvancedOptimizationFrontendPlugin Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLabAdvancedOptimizationFrontendPlugin Constructor

HeuristicLabAdvancedOptimizationFrontendPlugin Constructor
HeuristicLabAdvancedOptimizationFrontendPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabAdvancedOptimizationFrontendPlugin class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabAdvancedOptimizationFrontendPlugin()

See Also

HeuristicLabAdvancedOptimizationFrontendPlugin Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


MainForm Class

MainForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.MainForm]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MainForm : Form, IControlManager

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.AdvancedOptimizationFrontend..::.MainForm

See Also

MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


MainForm Members

[image]

HeuristicLab API Documentation
MainForm Members
MainForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Constructors

Name | Description
MainForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowControl |
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MainForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


MainForm Constructor

MainForm Constructor
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MainForm class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MainForm()

See Also

MainForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


MainForm Methods

[image]

HeuristicLab API Documentation
MainForm Methods
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowControl |
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

MainForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
MainForm..::.AccessibilityNotifyClients Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
MainForm..::.BeginInvoke Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
MainForm..::.Dispose Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method (Boolean)

MainForm..::.Dispose Method (Boolean)
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

MainForm Class
Dispose Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
MainForm..::.GetChildAtPoint Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
MainForm..::.Invalidate Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
MainForm..::.Invoke Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
MainForm..::.MemberwiseClone Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
MainForm..::.PerformLayout Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
MainForm..::.ResumeLayout Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
MainForm..::.RtlTranslateAlignment Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
MainForm..::.Scale Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
MainForm..::.Select Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
MainForm..::.SetBounds Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
MainForm..::.Show Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ShowControl Method

MainForm..::.ShowControl Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.AdvancedOptimizationFrontend.MainForm.ShowControl(HeuristicLab.PluginInfrastructure.IControl)]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void ShowControl(
    IControl control
)

Parameters

control
Type: HeuristicLab.PluginInfrastructure..::.IControl

[Missing <param> documentation for "control"]

Implements

IControlManager..::.ShowControl(IControl)

See Also

MainForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
MainForm..::.ShowDialog Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
MainForm..::.UpdateBounds Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
MainForm..::.Validate Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
MainForm..::.ValidateChildren Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Class

ViewForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.AdvancedOptimizationFrontend.ViewForm]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ViewForm : DockContent

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
DockContent
HeuristicLab.AdvancedOptimizationFrontend..::.ViewForm

See Also

ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Members

[image]

HeuristicLab API Documentation
ViewForm Members
ViewForm Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewForm type exposes the following members.

Constructors

Name | Description
ViewForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockHandler_DockStateChanged | (Inherited from DockContent.)
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
ShouldSerializeTabText | (Inherited from DockContent.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
m_dockHandler | (Inherited from DockContent.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
View |
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockStateChanged | (Inherited from DockContent.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ViewForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Constructor

[image]

HeuristicLab API Documentation
ViewForm Constructor
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ViewForm()()() |
ViewForm(IView) |

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Constructor

ViewForm Constructor
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ViewForm class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ViewForm()

See Also

ViewForm Class
ViewForm Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Constructor (IView)

ViewForm Constructor (IView)
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ViewForm class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ViewForm(
    IView view
)

Parameters

view
Type: HeuristicLab.Core..::.IView

[Missing <param> documentation for "view"]

See Also

ViewForm Class
ViewForm Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Methods

[image]

HeuristicLab API Documentation
ViewForm Methods
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | (Inherited from DockContent.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DockHandler_DockStateChanged | (Inherited from DockContent.)
DockTo | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
FloatAt | (Inherited from DockContent.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPersistString | (Inherited from DockContent.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | (Inherited from DockContent.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsDockStateValid | (Inherited from DockContent.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDockStateChanged | (Inherited from DockContent.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
ShouldSerializeTabText | (Inherited from DockContent.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ViewForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ViewForm..::.AccessibilityNotifyClients Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ViewForm..::.BeginInvoke Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ViewForm..::.Dispose Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Dispose Method (Boolean)

ViewForm..::.Dispose Method (Boolean)
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ViewForm Class
Dispose Overload
HeuristicLab.AdvancedOptimizationFrontend Namespace


DockTo Method

[image]

HeuristicLab API Documentation
ViewForm..::.DockTo Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DockTo(DockPanel, DockStyle) | (Inherited from DockContent.)
DockTo(DockPane, DockStyle, Int32) | (Inherited from DockContent.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ViewForm..::.GetChildAtPoint Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ViewForm..::.Invalidate Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ViewForm..::.Invoke Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ViewForm..::.MemberwiseClone Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ViewForm..::.PerformLayout Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ViewForm..::.ResumeLayout Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ViewForm..::.RtlTranslateAlignment Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
ViewForm..::.Scale Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
ViewForm..::.Select Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ViewForm..::.SetBounds Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
ViewForm..::.Show Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | (Inherited from DockContent.)
Show(DockPanel) | (Inherited from DockContent.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Show(DockPanel, DockState) | (Inherited from DockContent.)
Show(DockPanel, Rectangle) | (Inherited from DockContent.)
Show(DockPane, IDockContent) | (Inherited from DockContent.)
Show(DockPane, DockAlignment, Double) | (Inherited from DockContent.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ViewForm..::.ShowDialog Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ViewForm..::.UpdateBounds Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
ViewForm..::.Validate Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ViewForm..::.ValidateChildren Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.AdvancedOptimizationFrontend Namespace


ViewForm Properties

[image]

HeuristicLab API Documentation
ViewForm Properties
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowEndUserDocking | (Inherited from DockContent.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoHidePortion | (Inherited from DockContent.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CloseButton | (Inherited from DockContent.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockAreas | (Inherited from DockContent.)
DockHandler | (Inherited from DockContent.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DockPanel | (Inherited from DockContent.)
DockState | (Inherited from DockContent.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FloatPane | (Inherited from DockContent.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HideOnClose | (Inherited from DockContent.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsActivated | (Inherited from DockContent.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsFloat | (Inherited from DockContent.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsHidden | (Inherited from DockContent.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Pane | (Inherited from DockContent.)
PanelPane | (Inherited from DockContent.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowHint | (Inherited from DockContent.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabPageContextMenu | (Inherited from DockContent.)
TabPageContextMenuStrip | (Inherited from DockContent.)
TabStop | (Inherited from Form.)
TabText | (Inherited from DockContent.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
ToolTipText | (Inherited from DockContent.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
View |
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VisibleState | (Inherited from DockContent.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ViewForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


View Property

ViewForm..::.View Property
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.AdvancedOptimizationFrontend.ViewForm.View]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IView View { get; }

See Also

ViewForm Class
HeuristicLab.AdvancedOptimizationFrontend Namespace


HeuristicLab.BitVector Namespace

HeuristicLab.BitVector Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.BitVector]

Classes

Class | Description
BitVectorCrossoverBase |
BitVectorManipulatorBase |
FlipManipulator |
HeuristicLabBitVectorPlugin |
RandomBitVectorGenerator |
SinglePointCrossover |


BitVectorCrossoverBase Class

BitVectorCrossoverBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.BitVector.BitVectorCrossoverBase]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class BitVectorCrossoverBase : CrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.BitVector..::.BitVectorCrossoverBase
HeuristicLab.BitVector..::.SinglePointCrossover

See Also

BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


BitVectorCrossoverBase Members

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase Members
BitVectorCrossoverBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BitVectorCrossoverBase type exposes the following members.

Constructors

Name | Description
BitVectorCrossoverBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from CrossoverBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
HeuristicLab.BitVector Namespace


BitVectorCrossoverBase Constructor

BitVectorCrossoverBase Constructor
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BitVectorCrossoverBase class.

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BitVectorCrossoverBase()

See Also

BitVectorCrossoverBase Class
HeuristicLab.BitVector Namespace


BitVectorCrossoverBase Methods

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase Methods
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BitVectorCrossoverBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from CrossoverBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

BitVectorCrossoverBase Class
HeuristicLab.BitVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.AddSubOperator Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.Clone Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


Cross Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.Cross Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Boolean>[]()[], array<Boolean>[]()[]) |
Cross(IScope, IRandom, IScope, IScope, IScope) | (Overrides CrossoverBase ..::. Cross(IScope, IRandom, IScope, IScope, IScope).)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


Cross Method (IScope, IRandom, Boolean[], Boolean[])

BitVectorCrossoverBase..::.Cross Method (IScope, IRandom, array<Boolean>[]()[], array<Boolean>[]()[])
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.BitVectorCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[],System.Boolean[])]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract bool[] Cross(
    IScope scope,
    IRandom random,
    bool[] parent1,
    bool[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.BitVectorCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[],System.Boolean[])]

See Also

BitVectorCrossoverBase Class
Cross Overload
HeuristicLab.BitVector Namespace


Cross Method (IScope, IRandom, IScope, IScope, IScope)

BitVectorCrossoverBase..::.Cross Method (IScope, IRandom, IScope, IScope, IScope)
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.BitVectorCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override sealed void Cross(
    IScope scope,
    IRandom random,
    IScope parent1,
    IScope parent2,
    IScope child
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent1"]

parent2
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent2"]

child
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "child"]

See Also

BitVectorCrossoverBase Class
Cross Overload
HeuristicLab.BitVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.GetVariableValue Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.IsValid Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.TryAddSubOperator Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.TryAddVariable Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.TryAddVariableInfo Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.TryRemoveSubOperator Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.TryRemoveVariable Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
BitVectorCrossoverBase..::.TryRemoveVariableInfo Method
BitVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorCrossoverBase Class
BitVectorCrossoverBase Members
HeuristicLab.BitVector Namespace


BitVectorManipulatorBase Class

BitVectorManipulatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.BitVector.BitVectorManipulatorBase]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class BitVectorManipulatorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.BitVector..::.BitVectorManipulatorBase
HeuristicLab.BitVector..::.FlipManipulator

See Also

BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


BitVectorManipulatorBase Members

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase Members
BitVectorManipulatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BitVectorManipulatorBase type exposes the following members.

Constructors

Name | Description
BitVectorManipulatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
HeuristicLab.BitVector Namespace


BitVectorManipulatorBase Constructor

BitVectorManipulatorBase Constructor
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BitVectorManipulatorBase class.

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BitVectorManipulatorBase()

See Also

BitVectorManipulatorBase Class
HeuristicLab.BitVector Namespace


BitVectorManipulatorBase Methods

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase Methods
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BitVectorManipulatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

BitVectorManipulatorBase Class
HeuristicLab.BitVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.AddSubOperator Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


Apply Method

BitVectorManipulatorBase..::.Apply Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.BitVectorManipulatorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.BitVectorManipulatorBase.Apply(HeuristicLab.Core.IScope)]

See Also

BitVectorManipulatorBase Class
HeuristicLab.BitVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.Clone Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.GetVariableValue Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.IsValid Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


Manipulate Method

BitVectorManipulatorBase..::.Manipulate Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.BitVectorManipulatorBase.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[])]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract bool[] Manipulate(
    IScope scope,
    IRandom random,
    bool[] vector
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

vector
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "vector"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.BitVectorManipulatorBase.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[])]

See Also

BitVectorManipulatorBase Class
HeuristicLab.BitVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.TryAddSubOperator Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.TryAddVariable Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.TryAddVariableInfo Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.TryRemoveSubOperator Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.TryRemoveVariable Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
BitVectorManipulatorBase..::.TryRemoveVariableInfo Method
BitVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BitVectorManipulatorBase Class
BitVectorManipulatorBase Members
HeuristicLab.BitVector Namespace


FlipManipulator Class

FlipManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.BitVector.FlipManipulator]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FlipManipulator : BitVectorManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.BitVector..::.BitVectorManipulatorBase
HeuristicLab.BitVector..::.FlipManipulator

See Also

FlipManipulator Members
HeuristicLab.BitVector Namespace


FlipManipulator Members

[image]

HeuristicLab API Documentation
FlipManipulator Members
FlipManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FlipManipulator type exposes the following members.

Constructors

Name | Description
FlipManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides BitVectorManipulatorBase ..::. Manipulate(IScope, IRandom, array<Boolean>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
HeuristicLab.BitVector Namespace


FlipManipulator Constructor

FlipManipulator Constructor
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FlipManipulator class.

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FlipManipulator()

See Also

FlipManipulator Class
HeuristicLab.BitVector Namespace


FlipManipulator Methods

[image]

HeuristicLab API Documentation
FlipManipulator Methods
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FlipManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides BitVectorManipulatorBase ..::. Manipulate(IScope, IRandom, array<Boolean>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

FlipManipulator Class
HeuristicLab.BitVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.AddSubOperator Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


Apply Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.Apply Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from BitVectorManipulatorBase.)
Apply(IRandom, array<Boolean>[]()[]) |

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


Apply Method (IRandom, Boolean[])

FlipManipulator..::.Apply Method (IRandom, array<Boolean>[]()[])
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.FlipManipulator.Apply(HeuristicLab.Core.IRandom,System.Boolean[])]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool[] Apply(
    IRandom random,
    bool[] vector
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

vector
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "vector"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.FlipManipulator.Apply(HeuristicLab.Core.IRandom,System.Boolean[])]

See Also

FlipManipulator Class
Apply Overload
HeuristicLab.BitVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.Clone Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.GetVariableValue Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.IsValid Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


Manipulate Method

FlipManipulator..::.Manipulate Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.FlipManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[])]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool[] Manipulate(
    IScope scope,
    IRandom random,
    bool[] vector
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

vector
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "vector"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.FlipManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[])]

See Also

FlipManipulator Class
HeuristicLab.BitVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.TryAddSubOperator Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.TryAddVariable Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.TryAddVariableInfo Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.TryRemoveSubOperator Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.TryRemoveVariable Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
FlipManipulator..::.TryRemoveVariableInfo Method
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
FlipManipulator Members
HeuristicLab.BitVector Namespace


FlipManipulator Properties

[image]

HeuristicLab API Documentation
FlipManipulator Properties
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FlipManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

FlipManipulator Class
HeuristicLab.BitVector Namespace


Description Property

FlipManipulator..::.Description Property
FlipManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.BitVector.FlipManipulator.Description]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

FlipManipulator Class
HeuristicLab.BitVector Namespace


HeuristicLabBitVectorPlugin Class

HeuristicLabBitVectorPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.BitVector.HeuristicLabBitVectorPlugin]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Evolutionary")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.BitVector")]
[PluginFileAttribute(Filename = "HeuristicLab.BitVector.dll", Filetype = PluginFileType.Assembly)]
public class HeuristicLabBitVectorPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.BitVector..::.HeuristicLabBitVectorPlugin

See Also

HeuristicLabBitVectorPlugin Members
HeuristicLab.BitVector Namespace


HeuristicLabBitVectorPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabBitVectorPlugin Members
HeuristicLabBitVectorPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabBitVectorPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabBitVectorPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabBitVectorPlugin Class
HeuristicLab.BitVector Namespace


HeuristicLabBitVectorPlugin Constructor

HeuristicLabBitVectorPlugin Constructor
HeuristicLabBitVectorPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabBitVectorPlugin class.

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabBitVectorPlugin()

See Also

HeuristicLabBitVectorPlugin Class
HeuristicLab.BitVector Namespace


RandomBitVectorGenerator Class

RandomBitVectorGenerator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.BitVector.RandomBitVectorGenerator]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RandomBitVectorGenerator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.BitVector..::.RandomBitVectorGenerator

See Also

RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


RandomBitVectorGenerator Members

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator Members
RandomBitVectorGenerator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomBitVectorGenerator type exposes the following members.

Constructors

Name | Description
RandomBitVectorGenerator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
HeuristicLab.BitVector Namespace


RandomBitVectorGenerator Constructor

RandomBitVectorGenerator Constructor
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomBitVectorGenerator class.

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RandomBitVectorGenerator()

See Also

RandomBitVectorGenerator Class
HeuristicLab.BitVector Namespace


RandomBitVectorGenerator Methods

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator Methods
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomBitVectorGenerator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RandomBitVectorGenerator Class
HeuristicLab.BitVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.AddSubOperator Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


Apply Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.Apply Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Overrides OperatorBase ..::. Apply(IScope).)
Apply(IRandom, Int32) |

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


Apply Method (IScope)

RandomBitVectorGenerator..::.Apply Method (IScope)
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.RandomBitVectorGenerator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.RandomBitVectorGenerator.Apply(HeuristicLab.Core.IScope)]

See Also

RandomBitVectorGenerator Class
Apply Overload
HeuristicLab.BitVector Namespace


Apply Method (IRandom, Int32)

RandomBitVectorGenerator..::.Apply Method (IRandom, Int32)
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.RandomBitVectorGenerator.Apply(HeuristicLab.Core.IRandom,System.Int32)]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool[] Apply(
    IRandom random,
    int length
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

length
Type: System..::.Int32

[Missing <param> documentation for "length"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.RandomBitVectorGenerator.Apply(HeuristicLab.Core.IRandom,System.Int32)]

See Also

RandomBitVectorGenerator Class
Apply Overload
HeuristicLab.BitVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.Clone Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.GetVariableValue Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.IsValid Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.TryAddSubOperator Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.TryAddVariable Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.TryAddVariableInfo Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.TryRemoveSubOperator Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.TryRemoveVariable Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator..::.TryRemoveVariableInfo Method
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
RandomBitVectorGenerator Members
HeuristicLab.BitVector Namespace


RandomBitVectorGenerator Properties

[image]

HeuristicLab API Documentation
RandomBitVectorGenerator Properties
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomBitVectorGenerator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RandomBitVectorGenerator Class
HeuristicLab.BitVector Namespace


Description Property

RandomBitVectorGenerator..::.Description Property
RandomBitVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.BitVector.RandomBitVectorGenerator.Description]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RandomBitVectorGenerator Class
HeuristicLab.BitVector Namespace


SinglePointCrossover Class

SinglePointCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.BitVector.SinglePointCrossover]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SinglePointCrossover : BitVectorCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.BitVector..::.BitVectorCrossoverBase
HeuristicLab.BitVector..::.SinglePointCrossover

See Also

SinglePointCrossover Members
HeuristicLab.BitVector Namespace


SinglePointCrossover Members

[image]

HeuristicLab API Documentation
SinglePointCrossover Members
SinglePointCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossover type exposes the following members.

Constructors

Name | Description
SinglePointCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
HeuristicLab.BitVector Namespace


SinglePointCrossover Constructor

SinglePointCrossover Constructor
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SinglePointCrossover class.

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SinglePointCrossover()

See Also

SinglePointCrossover Class
HeuristicLab.BitVector Namespace


SinglePointCrossover Methods

[image]

HeuristicLab API Documentation
SinglePointCrossover Methods
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SinglePointCrossover Class
HeuristicLab.BitVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.AddSubOperator Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


Apply Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.Apply Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Boolean>[]()[], array<Boolean>[]()[]) |

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


Apply Method (IRandom, Boolean[], Boolean[])

SinglePointCrossover..::.Apply Method (IRandom, array<Boolean>[]()[], array<Boolean>[]()[])
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.SinglePointCrossover.Apply(HeuristicLab.Core.IRandom,System.Boolean[],System.Boolean[])]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool[] Apply(
    IRandom random,
    bool[] parent1,
    bool[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.SinglePointCrossover.Apply(HeuristicLab.Core.IRandom,System.Boolean[],System.Boolean[])]

See Also

SinglePointCrossover Class
Apply Overload
HeuristicLab.BitVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.Clone Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


Cross Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.Cross Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Boolean>[]()[], array<Boolean>[]()[]) | (Overrides BitVectorCrossoverBase ..::. Cross(IScope, IRandom, array<Boolean>[]()[], array<Boolean>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from BitVectorCrossoverBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


Cross Method (IScope, IRandom, Boolean[], Boolean[])

SinglePointCrossover..::.Cross Method (IScope, IRandom, array<Boolean>[]()[], array<Boolean>[]()[])
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.BitVector.SinglePointCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[],System.Boolean[])]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool[] Cross(
    IScope scope,
    IRandom random,
    bool[] parent1,
    bool[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.BitVector.SinglePointCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Boolean[],System.Boolean[])]

See Also

SinglePointCrossover Class
Cross Overload
HeuristicLab.BitVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.GetVariableValue Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.IsValid Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryAddSubOperator Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryAddVariable Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryAddVariableInfo Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryRemoveSubOperator Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryRemoveVariable Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryRemoveVariableInfo Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.BitVector Namespace


SinglePointCrossover Properties

[image]

HeuristicLab API Documentation
SinglePointCrossover Properties
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
HeuristicLab.BitVector Namespace


Description Property

SinglePointCrossover..::.Description Property
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.BitVector.SinglePointCrossover.Description]

Namespace: HeuristicLab.BitVector
Assembly: HeuristicLab.BitVector (in HeuristicLab.BitVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SinglePointCrossover Class
HeuristicLab.BitVector Namespace


HeuristicLab.Charting Namespace

HeuristicLab.Charting Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Charting]

Classes

Class | Description
Axis |
AxisPrimitiveBase |
Chart |
ChartControl |
Ellipse |
FixedSizeCircle |
FixedSizePrimitiveBase |
FixedSizeRectangle |
Group |
HeuristicLabChartingPlugin |
Line |
LinearPrimitiveBase |
PrimitiveBase |
PropertiesDialog |
Rectangle |
RectangularPrimitiveBase |
SelectionRectangle |

Structures

Structure | Description
Offset |
PointD |
SizeD |

Interfaces

Interface | Description
IChart |
IGroup |
IPrimitive |

Enumerations

Enumeration | Description
AxisType |
ChartMode |


Axis Class

Axis Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Axis]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Axis : AxisPrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.AxisPrimitiveBase
HeuristicLab.Charting..::.Axis

See Also

Axis Members
HeuristicLab.Charting Namespace


Axis Members

[image]

HeuristicLab API Documentation
Axis Members
Axis Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Axis type exposes the following members.

Constructors

Name | Description
Axis | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AxisType | (Inherited from AxisPrimitiveBase.)
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
HorizontalLabel | (Inherited from AxisPrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Point | (Inherited from AxisPrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
ShowGrid | (Inherited from AxisPrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
VerticalLabel | (Inherited from AxisPrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

Axis Class
HeuristicLab.Charting Namespace


Axis Constructor

[image]

HeuristicLab API Documentation
Axis Constructor
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Axis(IChart, PointD, AxisType) |
Axis(IChart, Double, Double, AxisType) |
Axis(IChart, PointD, AxisType, Pen, Brush) |
Axis(IChart, Double, Double, AxisType, Pen, Brush) |

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


Axis Constructor (IChart, PointD, AxisType)

Axis Constructor (IChart, PointD, AxisType)
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Axis class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Axis(
    IChart chart,
    PointD point,
    AxisType axisType
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

See Also

Axis Class
Axis Overload
HeuristicLab.Charting Namespace


Axis Constructor (IChart, Double, Double, AxisType)

Axis Constructor (IChart, Double, Double, AxisType)
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Axis class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Axis(
    IChart chart,
    double x,
    double y,
    AxisType axisType
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

See Also

Axis Class
Axis Overload
HeuristicLab.Charting Namespace


Axis Constructor (IChart, PointD, AxisType, Pen, Brush)

Axis Constructor (IChart, PointD, AxisType, Pen, Brush)
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Axis class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Axis(
    IChart chart,
    PointD point,
    AxisType axisType,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Axis Class
Axis Overload
HeuristicLab.Charting Namespace


Axis Constructor (IChart, Double, Double, AxisType, Pen, Brush)

Axis Constructor (IChart, Double, Double, AxisType, Pen, Brush)
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Axis class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Axis(
    IChart chart,
    double x,
    double y,
    AxisType axisType,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Axis Class
Axis Overload
HeuristicLab.Charting Namespace


Axis Methods

[image]

HeuristicLab API Documentation
Axis Methods
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Axis type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Axis Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
Axis..::.ContainsPoint Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Inherited from AxisPrimitiveBase.)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


Draw Method

Axis..::.Draw Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Axis.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

Axis Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Axis..::.GetCursor Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from PrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Axis..::.GetToolTipText Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Axis..::.MouseClick Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Axis..::.MouseDoubleClick Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Axis..::.MouseDrag Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Axis..::.MouseMove Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
Axis..::.Move Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from AxisPrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
Axis..::.SetPosition Method
Axis Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD) | (Inherited from AxisPrimitiveBase.)
SetPosition(Double, Double) | (Inherited from AxisPrimitiveBase.)

See Also

Axis Class
Axis Members
HeuristicLab.Charting Namespace


AxisPrimitiveBase Class

AxisPrimitiveBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.AxisPrimitiveBase]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class AxisPrimitiveBase : PrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.AxisPrimitiveBase
HeuristicLab.Charting..::.Axis

See Also

AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


AxisPrimitiveBase Members

[image]

HeuristicLab API Documentation
AxisPrimitiveBase Members
AxisPrimitiveBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AxisPrimitiveBase type exposes the following members.

Constructors

Name | Description
AxisPrimitiveBase | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AxisType |
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
HorizontalLabel |
Pen | (Inherited from PrimitiveBase.)
Point |
Selected | (Inherited from PrimitiveBase.)
ShowGrid |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
VerticalLabel |

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


AxisPrimitiveBase Constructor

[image]

HeuristicLab API Documentation
AxisPrimitiveBase Constructor
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AxisPrimitiveBase(IChart, PointD, AxisType) |
AxisPrimitiveBase(IChart, Double, Double, AxisType) |
AxisPrimitiveBase(IChart, PointD, AxisType, Pen, Brush) |
AxisPrimitiveBase(IChart, Double, Double, AxisType, Pen, Brush) |

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


AxisPrimitiveBase Constructor (IChart, PointD, AxisType)

AxisPrimitiveBase Constructor (IChart, PointD, AxisType)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AxisPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected AxisPrimitiveBase(
    IChart chart,
    PointD point,
    AxisType axisType
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Overload
HeuristicLab.Charting Namespace


AxisPrimitiveBase Constructor (IChart, Double, Double, AxisType)

AxisPrimitiveBase Constructor (IChart, Double, Double, AxisType)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AxisPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected AxisPrimitiveBase(
    IChart chart,
    double x,
    double y,
    AxisType axisType
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Overload
HeuristicLab.Charting Namespace


AxisPrimitiveBase Constructor (IChart, PointD, AxisType, Pen, Brush)

AxisPrimitiveBase Constructor (IChart, PointD, AxisType, Pen, Brush)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AxisPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected AxisPrimitiveBase(
    IChart chart,
    PointD point,
    AxisType axisType,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Overload
HeuristicLab.Charting Namespace


AxisPrimitiveBase Constructor (IChart, Double, Double, AxisType, Pen, Brush)

AxisPrimitiveBase Constructor (IChart, Double, Double, AxisType, Pen, Brush)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AxisPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected AxisPrimitiveBase(
    IChart chart,
    double x,
    double y,
    AxisType axisType,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

axisType
Type: HeuristicLab.Charting..::.AxisType

[Missing <param> documentation for "axisType"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Overload
HeuristicLab.Charting Namespace


AxisPrimitiveBase Methods

[image]

HeuristicLab API Documentation
AxisPrimitiveBase Methods
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AxisPrimitiveBase type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.ContainsPoint Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides PrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

AxisPrimitiveBase..::.ContainsPoint Method (PointD)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.AxisPrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.AxisPrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

AxisPrimitiveBase Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.GetCursor Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from PrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.GetToolTipText Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.MouseClick Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.MouseDoubleClick Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.MouseDrag Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.MouseMove Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.Move Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Overrides PrimitiveBase ..::. Move(Offset).)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method (Offset)

AxisPrimitiveBase..::.Move Method (Offset)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.AxisPrimitiveBase.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IPrimitive..::.Move(Offset)

See Also

AxisPrimitiveBase Class
Move Overload
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
AxisPrimitiveBase..::.SetPosition Method
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD) |
SetPosition(Double, Double) |

See Also

AxisPrimitiveBase Class
AxisPrimitiveBase Members
HeuristicLab.Charting Namespace


SetPosition Method (PointD)

AxisPrimitiveBase..::.SetPosition Method (PointD)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.AxisPrimitiveBase.SetPosition(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void SetPosition(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

See Also

AxisPrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


SetPosition Method (Double, Double)

AxisPrimitiveBase..::.SetPosition Method (Double, Double)
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.AxisPrimitiveBase.SetPosition(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetPosition(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

See Also

AxisPrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


AxisPrimitiveBase Properties

[image]

HeuristicLab API Documentation
AxisPrimitiveBase Properties
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AxisPrimitiveBase type exposes the following members.

Properties

Name | Description
AxisType |
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
HorizontalLabel |
Pen | (Inherited from PrimitiveBase.)
Point |
Selected | (Inherited from PrimitiveBase.)
ShowGrid |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
VerticalLabel |

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


AxisType Property

AxisPrimitiveBase..::.AxisType Property
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.AxisPrimitiveBase.AxisType]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AxisType AxisType { get; }

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


HorizontalLabel Property

AxisPrimitiveBase..::.HorizontalLabel Property
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.AxisPrimitiveBase.HorizontalLabel]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string HorizontalLabel { get; set; }

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


Point Property

AxisPrimitiveBase..::.Point Property
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.AxisPrimitiveBase.Point]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD Point { get; }

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


ShowGrid Property

AxisPrimitiveBase..::.ShowGrid Property
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.AxisPrimitiveBase.ShowGrid]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool ShowGrid { get; set; }

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


VerticalLabel Property

AxisPrimitiveBase..::.VerticalLabel Property
AxisPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.AxisPrimitiveBase.VerticalLabel]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string VerticalLabel { get; set; }

See Also

AxisPrimitiveBase Class
HeuristicLab.Charting Namespace


AxisType Enumeration

AxisType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.AxisType]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[FlagsAttribute]
public enum AxisType

Members

Member name | Description
None |
Horizontal |
Vertical |
Both |

See Also

HeuristicLab.Charting Namespace


Chart Class

Chart Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Chart]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Chart : IChart

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.Chart
HeuristicLab.Charting.Data..::.Datachart

See Also

Chart Members
HeuristicLab.Charting Namespace


Chart Members

[image]

HeuristicLab API Documentation
Chart Members
Chart Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Chart type exposes the following members.

Constructors

Name | Description
Chart | Overloaded.

Methods

Name | Description
EnforceUpdate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OnUpdate |
Render |
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformPixelToWorld | Overloaded.
TransformWorldToPixel | Overloaded.
Unzoom |
ZoomIn | Overloaded.
ZoomOut |

Properties

Name | Description
Group |
LowerLeft |
Mode |
PixelToWorldRatio |
Size |
SizeInPixels |
UpdateEnabled |
UpperRight |
WorldToPixelRatio |

Events

Name | Description
Update |

See Also

Chart Class
HeuristicLab.Charting Namespace


Chart Constructor

[image]

HeuristicLab API Documentation
Chart Constructor
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Chart(PointD, PointD) |
Chart(Double, Double, Double, Double) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


Chart Constructor (PointD, PointD)

Chart Constructor (PointD, PointD)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Chart class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Chart(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

Chart Class
Chart Overload
HeuristicLab.Charting Namespace


Chart Constructor (Double, Double, Double, Double)

Chart Constructor (Double, Double, Double, Double)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Chart class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Chart(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

Chart Class
Chart Overload
HeuristicLab.Charting Namespace


Chart Methods

[image]

HeuristicLab API Documentation
Chart Methods
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Chart type exposes the following members.

Methods

Name | Description
EnforceUpdate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OnUpdate |
Render |
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformPixelToWorld | Overloaded.
TransformWorldToPixel | Overloaded.
Unzoom |
ZoomIn | Overloaded.
ZoomOut |

See Also

Chart Class
HeuristicLab.Charting Namespace


EnforceUpdate Method

Chart..::.EnforceUpdate Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.EnforceUpdate]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void EnforceUpdate()

Implements

IChart..::.EnforceUpdate()()()

See Also

Chart Class
HeuristicLab.Charting Namespace


GetAllPrimitives Method

[image]

HeuristicLab API Documentation
Chart..::.GetAllPrimitives Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetAllPrimitives(Point) |
GetAllPrimitives(Int32, Int32) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


GetAllPrimitives Method (Point)

Chart..::.GetAllPrimitives Method (Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetAllPrimitives(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IList<IPrimitive> GetAllPrimitives(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetAllPrimitives(System.Drawing.Point)]

Implements

IChart..::.GetAllPrimitives(Point)

See Also

Chart Class
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetAllPrimitives Method (Int32, Int32)

Chart..::.GetAllPrimitives Method (Int32, Int32)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetAllPrimitives(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IPrimitive> GetAllPrimitives(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetAllPrimitives(System.Int32,System.Int32)]

Implements

IChart..::.GetAllPrimitives(Int32, Int32)

See Also

Chart Class
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Chart..::.GetCursor Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(Point) |
GetCursor(Int32, Int32) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


GetCursor Method (Point)

Chart..::.GetCursor Method (Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetCursor(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Cursor GetCursor(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetCursor(System.Drawing.Point)]

Implements

IChart..::.GetCursor(Point)

See Also

Chart Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetCursor Method (Int32, Int32)

Chart..::.GetCursor Method (Int32, Int32)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetCursor(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Cursor GetCursor(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetCursor(System.Int32,System.Int32)]

Implements

IChart..::.GetCursor(Int32, Int32)

See Also

Chart Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetPrimitive Method

[image]

HeuristicLab API Documentation
Chart..::.GetPrimitive Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPrimitive(Point) |
GetPrimitive(Int32, Int32) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


GetPrimitive Method (Point)

Chart..::.GetPrimitive Method (Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetPrimitive(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IPrimitive GetPrimitive(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetPrimitive(System.Drawing.Point)]

Implements

IChart..::.GetPrimitive(Point)

See Also

Chart Class
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetPrimitive Method (Int32, Int32)

Chart..::.GetPrimitive Method (Int32, Int32)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetPrimitive(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IPrimitive GetPrimitive(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetPrimitive(System.Int32,System.Int32)]

Implements

IChart..::.GetPrimitive(Int32, Int32)

See Also

Chart Class
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Chart..::.GetToolTipText Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(Point) |
GetToolTipText(Int32, Int32) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


GetToolTipText Method (Point)

Chart..::.GetToolTipText Method (Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetToolTipText(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual string GetToolTipText(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetToolTipText(System.Drawing.Point)]

Implements

IChart..::.GetToolTipText(Point)

See Also

Chart Class
GetToolTipText Overload
HeuristicLab.Charting Namespace


GetToolTipText Method (Int32, Int32)

Chart..::.GetToolTipText Method (Int32, Int32)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.GetToolTipText(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string GetToolTipText(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.GetToolTipText(System.Int32,System.Int32)]

Implements

IChart..::.GetToolTipText(Int32, Int32)

See Also

Chart Class
GetToolTipText Overload
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Chart..::.MouseClick Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(Point, MouseButtons) |
MouseClick(Int32, Int32, MouseButtons) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


MouseClick Method (Point, MouseButtons)

Chart..::.MouseClick Method (Point, MouseButtons)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseClick(System.Drawing.Point,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseClick(
    Point point,
    MouseButtons button
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IChart..::.MouseClick(Point, MouseButtons)

See Also

Chart Class
MouseClick Overload
HeuristicLab.Charting Namespace


MouseClick Method (Int32, Int32, MouseButtons)

Chart..::.MouseClick Method (Int32, Int32, MouseButtons)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseClick(System.Int32,System.Int32,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseClick(
    int x,
    int y,
    MouseButtons button
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IChart..::.MouseClick(Int32, Int32, MouseButtons)

See Also

Chart Class
MouseClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Chart..::.MouseDoubleClick Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(Point, MouseButtons) |
MouseDoubleClick(Int32, Int32, MouseButtons) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method (Point, MouseButtons)

Chart..::.MouseDoubleClick Method (Point, MouseButtons)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseDoubleClick(System.Drawing.Point,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseDoubleClick(
    Point point,
    MouseButtons button
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IChart..::.MouseDoubleClick(Point, MouseButtons)

See Also

Chart Class
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method (Int32, Int32, MouseButtons)

Chart..::.MouseDoubleClick Method (Int32, Int32, MouseButtons)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseDoubleClick(System.Int32,System.Int32,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseDoubleClick(
    int x,
    int y,
    MouseButtons button
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IChart..::.MouseDoubleClick(Int32, Int32, MouseButtons)

See Also

Chart Class
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Chart..::.MouseDrag Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(Point, Point, MouseButtons) |
MouseDrag(Int32, Int32, Int32, Int32, MouseButtons) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


MouseDrag Method (Point, Point, MouseButtons)

Chart..::.MouseDrag Method (Point, Point, MouseButtons)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseDrag(System.Drawing.Point,System.Drawing.Point,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseDrag(
    Point start,
    Point end,
    MouseButtons button
)

Parameters

start
Type: System.Drawing..::.Point

[Missing <param> documentation for "start"]

end
Type: System.Drawing..::.Point

[Missing <param> documentation for "end"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IChart..::.MouseDrag(Point, Point, MouseButtons)

See Also

Chart Class
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseDrag Method (Int32, Int32, Int32, Int32, MouseButtons)

Chart..::.MouseDrag Method (Int32, Int32, Int32, Int32, MouseButtons)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseDrag(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseDrag(
    int x1,
    int y1,
    int x2,
    int y2,
    MouseButtons button
)

Parameters

x1
Type: System..::.Int32

[Missing <param> documentation for "x1"]

y1
Type: System..::.Int32

[Missing <param> documentation for "y1"]

x2
Type: System..::.Int32

[Missing <param> documentation for "x2"]

y2
Type: System..::.Int32

[Missing <param> documentation for "y2"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IChart..::.MouseDrag(Int32, Int32, Int32, Int32, MouseButtons)

See Also

Chart Class
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Chart..::.MouseMove Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(Point, Point) |
MouseMove(Int32, Int32, Int32, Int32) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


MouseMove Method (Point, Point)

Chart..::.MouseMove Method (Point, Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseMove(System.Drawing.Point,System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseMove(
    Point start,
    Point end
)

Parameters

start
Type: System.Drawing..::.Point

[Missing <param> documentation for "start"]

end
Type: System.Drawing..::.Point

[Missing <param> documentation for "end"]

Implements

IChart..::.MouseMove(Point, Point)

See Also

Chart Class
MouseMove Overload
HeuristicLab.Charting Namespace


MouseMove Method (Int32, Int32, Int32, Int32)

Chart..::.MouseMove Method (Int32, Int32, Int32, Int32)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.MouseMove(System.Int32,System.Int32,System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseMove(
    int x1,
    int y1,
    int x2,
    int y2
)

Parameters

x1
Type: System..::.Int32

[Missing <param> documentation for "x1"]

y1
Type: System..::.Int32

[Missing <param> documentation for "y1"]

x2
Type: System..::.Int32

[Missing <param> documentation for "x2"]

y2
Type: System..::.Int32

[Missing <param> documentation for "y2"]

Implements

IChart..::.MouseMove(Int32, Int32, Int32, Int32)

See Also

Chart Class
MouseMove Overload
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
Chart..::.Move Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) |
Move(Double, Double) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


Move Method (Offset)

Chart..::.Move Method (Offset)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IChart..::.Move(Offset)

See Also

Chart Class
Move Overload
HeuristicLab.Charting Namespace


Move Method (Double, Double)

Chart..::.Move Method (Double, Double)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.Move(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Move(
    double dx,
    double dy
)

Parameters

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

Implements

IChart..::.Move(Double, Double)

See Also

Chart Class
Move Overload
HeuristicLab.Charting Namespace


OnUpdate Method

Chart..::.OnUpdate Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.OnUpdate]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnUpdate()

See Also

Chart Class
HeuristicLab.Charting Namespace


Render Method

Chart..::.Render Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.Render(System.Drawing.Graphics,System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Render(
    Graphics graphics,
    int width,
    int height
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

width
Type: System..::.Int32

[Missing <param> documentation for "width"]

height
Type: System..::.Int32

[Missing <param> documentation for "height"]

Implements

IChart..::.Render(Graphics, Int32, Int32)

See Also

Chart Class
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
Chart..::.SetPosition Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) |
SetPosition(Double, Double, Double, Double) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


SetPosition Method (PointD, PointD)

Chart..::.SetPosition Method (PointD, PointD)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.SetPosition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void SetPosition(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

Implements

IChart..::.SetPosition(PointD, PointD)

See Also

Chart Class
SetPosition Overload
HeuristicLab.Charting Namespace


SetPosition Method (Double, Double, Double, Double)

Chart..::.SetPosition Method (Double, Double, Double, Double)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.SetPosition(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetPosition(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

Implements

IChart..::.SetPosition(Double, Double, Double, Double)

See Also

Chart Class
SetPosition Overload
HeuristicLab.Charting Namespace


TransformPixelToWorld Method

[image]

HeuristicLab API Documentation
Chart..::.TransformPixelToWorld Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TransformPixelToWorld(Point) |
TransformPixelToWorld(Size) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


TransformPixelToWorld Method (Point)

Chart..::.TransformPixelToWorld Method (Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.TransformPixelToWorld(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PointD TransformPixelToWorld(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.TransformPixelToWorld(System.Drawing.Point)]

Implements

IChart..::.TransformPixelToWorld(Point)

See Also

Chart Class
TransformPixelToWorld Overload
HeuristicLab.Charting Namespace


TransformPixelToWorld Method (Size)

Chart..::.TransformPixelToWorld Method (Size)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.TransformPixelToWorld(System.Drawing.Size)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SizeD TransformPixelToWorld(
    Size size
)

Parameters

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.TransformPixelToWorld(System.Drawing.Size)]

Implements

IChart..::.TransformPixelToWorld(Size)

See Also

Chart Class
TransformPixelToWorld Overload
HeuristicLab.Charting Namespace


TransformWorldToPixel Method

[image]

HeuristicLab API Documentation
Chart..::.TransformWorldToPixel Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TransformWorldToPixel(PointD) |
TransformWorldToPixel(SizeD) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


TransformWorldToPixel Method (PointD)

Chart..::.TransformWorldToPixel Method (PointD)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.TransformWorldToPixel(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Point TransformWorldToPixel(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.TransformWorldToPixel(HeuristicLab.Charting.PointD)]

Implements

IChart..::.TransformWorldToPixel(PointD)

See Also

Chart Class
TransformWorldToPixel Overload
HeuristicLab.Charting Namespace


TransformWorldToPixel Method (SizeD)

Chart..::.TransformWorldToPixel Method (SizeD)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.TransformWorldToPixel(HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Size TransformWorldToPixel(
    SizeD size
)

Parameters

size
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Chart.TransformWorldToPixel(HeuristicLab.Charting.SizeD)]

Implements

IChart..::.TransformWorldToPixel(SizeD)

See Also

Chart Class
TransformWorldToPixel Overload
HeuristicLab.Charting Namespace


Unzoom Method

Chart..::.Unzoom Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.Unzoom]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Unzoom()

Implements

IChart..::.Unzoom()()()

See Also

Chart Class
HeuristicLab.Charting Namespace


ZoomIn Method

[image]

HeuristicLab API Documentation
Chart..::.ZoomIn Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ZoomIn(Point, Point) |
ZoomIn(PointD, PointD) |
ZoomIn(Double, Double, Double, Double) |
ZoomIn(Int32, Int32, Int32, Int32) |

See Also

Chart Class
Chart Members
HeuristicLab.Charting Namespace


ZoomIn Method (Point, Point)

Chart..::.ZoomIn Method (Point, Point)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.ZoomIn(System.Drawing.Point,System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void ZoomIn(
    Point lowerLeft,
    Point upperRight
)

Parameters

lowerLeft
Type: System.Drawing..::.Point

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: System.Drawing..::.Point

[Missing <param> documentation for "upperRight"]

Implements

IChart..::.ZoomIn(Point, Point)

See Also

Chart Class
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomIn Method (PointD, PointD)

Chart..::.ZoomIn Method (PointD, PointD)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.ZoomIn(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void ZoomIn(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

Implements

IChart..::.ZoomIn(PointD, PointD)

See Also

Chart Class
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomIn Method (Double, Double, Double, Double)

Chart..::.ZoomIn Method (Double, Double, Double, Double)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.ZoomIn(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void ZoomIn(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

Implements

IChart..::.ZoomIn(Double, Double, Double, Double)

See Also

Chart Class
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomIn Method (Int32, Int32, Int32, Int32)

Chart..::.ZoomIn Method (Int32, Int32, Int32, Int32)
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.ZoomIn(System.Int32,System.Int32,System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void ZoomIn(
    int x1,
    int y1,
    int x2,
    int y2
)

Parameters

x1
Type: System..::.Int32

[Missing <param> documentation for "x1"]

y1
Type: System..::.Int32

[Missing <param> documentation for "y1"]

x2
Type: System..::.Int32

[Missing <param> documentation for "x2"]

y2
Type: System..::.Int32

[Missing <param> documentation for "y2"]

Implements

IChart..::.ZoomIn(Int32, Int32, Int32, Int32)

See Also

Chart Class
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomOut Method

Chart..::.ZoomOut Method
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Chart.ZoomOut]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void ZoomOut()

Implements

IChart..::.ZoomOut()()()

See Also

Chart Class
HeuristicLab.Charting Namespace


Chart Properties

[image]

HeuristicLab API Documentation
Chart Properties
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Chart type exposes the following members.

Properties

Name | Description
Group |
LowerLeft |
Mode |
PixelToWorldRatio |
Size |
SizeInPixels |
UpdateEnabled |
UpperRight |
WorldToPixelRatio |

See Also

Chart Class
HeuristicLab.Charting Namespace


Group Property

Chart..::.Group Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.Group]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IGroup Group { get; }

Implements

IChart..::.Group

See Also

Chart Class
HeuristicLab.Charting Namespace


LowerLeft Property

Chart..::.LowerLeft Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.LowerLeft]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD LowerLeft { get; }

Implements

IChart..::.LowerLeft

See Also

Chart Class
HeuristicLab.Charting Namespace


Mode Property

Chart..::.Mode Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.Mode]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual ChartMode Mode { get; set; }

Implements

IChart..::.Mode

See Also

Chart Class
HeuristicLab.Charting Namespace


PixelToWorldRatio Property

Chart..::.PixelToWorldRatio Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.PixelToWorldRatio]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SizeD PixelToWorldRatio { get; }

Implements

IChart..::.PixelToWorldRatio

See Also

Chart Class
HeuristicLab.Charting Namespace


Size Property

Chart..::.Size Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.Size]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual SizeD Size { get; }

Implements

IChart..::.Size

See Also

Chart Class
HeuristicLab.Charting Namespace


SizeInPixels Property

Chart..::.SizeInPixels Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.SizeInPixels]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Size SizeInPixels { get; }

Implements

IChart..::.SizeInPixels

See Also

Chart Class
HeuristicLab.Charting Namespace


UpdateEnabled Property

Chart..::.UpdateEnabled Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.UpdateEnabled]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool UpdateEnabled { get; set; }

Implements

IChart..::.UpdateEnabled

See Also

Chart Class
HeuristicLab.Charting Namespace


UpperRight Property

Chart..::.UpperRight Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.UpperRight]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD UpperRight { get; }

Implements

IChart..::.UpperRight

See Also

Chart Class
HeuristicLab.Charting Namespace


WorldToPixelRatio Property

Chart..::.WorldToPixelRatio Property
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Chart.WorldToPixelRatio]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SizeD WorldToPixelRatio { get; }

Implements

IChart..::.WorldToPixelRatio

See Also

Chart Class
HeuristicLab.Charting Namespace


Chart Events

[image]

HeuristicLab API Documentation
Chart Events
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Chart type exposes the following members.

Events

Name | Description
Update |

See Also

Chart Class
HeuristicLab.Charting Namespace


Update Event

Chart..::.Update Event
Chart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Charting.Chart.Update]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Update

Implements

IChart..::.Update

See Also

Chart Class
HeuristicLab.Charting Namespace


ChartControl Class

ChartControl Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.ChartControl]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ChartControl : UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Charting..::.ChartControl
HeuristicLab.Charting.Data..::.DataChartControl

See Also

ChartControl Members
HeuristicLab.Charting Namespace


ChartControl Members

[image]

HeuristicLab API Documentation
ChartControl Members
ChartControl Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChartControl type exposes the following members.

Constructors

Name | Description
ChartControl |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
intoBackgroundToolStripMenuItem |
intoForegroundToolStripMenuItem |
moveToolStripMenuItem |
oneLayerDownToolStripMenuItem |
oneLayerUpToolStripMenuItem |
pictureBox |
pictureBoxContextMenuStrip |
propertiesToolStripMenuItem |
selectToolStripMenuItem |
toolStripMenuItem1 |
toolStripMenuItem2 |
toolTip |
zoomToolStripMenuItem |

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart |
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScaleOnResize |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ChartControl Class
HeuristicLab.Charting Namespace


ChartControl Constructor

ChartControl Constructor
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChartControl class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChartControl()

See Also

ChartControl Class
HeuristicLab.Charting Namespace


ChartControl Fields

[image]

HeuristicLab API Documentation
ChartControl Fields
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChartControl type exposes the following members.

Fields

Name | Description
intoBackgroundToolStripMenuItem |
intoForegroundToolStripMenuItem |
moveToolStripMenuItem |
oneLayerDownToolStripMenuItem |
oneLayerUpToolStripMenuItem |
pictureBox |
pictureBoxContextMenuStrip |
propertiesToolStripMenuItem |
selectToolStripMenuItem |
toolStripMenuItem1 |
toolStripMenuItem2 |
toolTip |
zoomToolStripMenuItem |

See Also

ChartControl Class
HeuristicLab.Charting Namespace


intoBackgroundToolStripMenuItem Field

ChartControl..::.intoBackgroundToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.intoBackgroundToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem intoBackgroundToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


intoForegroundToolStripMenuItem Field

ChartControl..::.intoForegroundToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.intoForegroundToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem intoForegroundToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


moveToolStripMenuItem Field

ChartControl..::.moveToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.moveToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem moveToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


oneLayerDownToolStripMenuItem Field

ChartControl..::.oneLayerDownToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.oneLayerDownToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem oneLayerDownToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


oneLayerUpToolStripMenuItem Field

ChartControl..::.oneLayerUpToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.oneLayerUpToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem oneLayerUpToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


pictureBox Field

ChartControl..::.pictureBox Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.pictureBox]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected PictureBox pictureBox

See Also

ChartControl Class
HeuristicLab.Charting Namespace


pictureBoxContextMenuStrip Field

ChartControl..::.pictureBoxContextMenuStrip Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.pictureBoxContextMenuStrip]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ContextMenuStrip pictureBoxContextMenuStrip

See Also

ChartControl Class
HeuristicLab.Charting Namespace


propertiesToolStripMenuItem Field

ChartControl..::.propertiesToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.propertiesToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem propertiesToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


selectToolStripMenuItem Field

ChartControl..::.selectToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.selectToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem selectToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


toolStripMenuItem1 Field

ChartControl..::.toolStripMenuItem1 Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.toolStripMenuItem1]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripSeparator toolStripMenuItem1

See Also

ChartControl Class
HeuristicLab.Charting Namespace


toolStripMenuItem2 Field

ChartControl..::.toolStripMenuItem2 Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.toolStripMenuItem2]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripSeparator toolStripMenuItem2

See Also

ChartControl Class
HeuristicLab.Charting Namespace


toolTip Field

ChartControl..::.toolTip Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.toolTip]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolTip toolTip

See Also

ChartControl Class
HeuristicLab.Charting Namespace


zoomToolStripMenuItem Field

ChartControl..::.zoomToolStripMenuItem Field
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.ChartControl.zoomToolStripMenuItem]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ToolStripMenuItem zoomToolStripMenuItem

See Also

ChartControl Class
HeuristicLab.Charting Namespace


ChartControl Methods

[image]

HeuristicLab API Documentation
ChartControl Methods
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChartControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ChartControl Class
HeuristicLab.Charting Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ChartControl..::.AccessibilityNotifyClients Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ChartControl..::.BeginInvoke Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ChartControl..::.Dispose Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl ..::. Dispose(Boolean).)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Dispose Method (Boolean)

ChartControl..::.Dispose Method (Boolean)
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ChartControl Class
Dispose Overload
HeuristicLab.Charting Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ChartControl..::.GetChildAtPoint Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ChartControl..::.Invalidate Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ChartControl..::.Invoke Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ChartControl..::.MemberwiseClone Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ChartControl..::.PerformLayout Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ChartControl..::.ResumeLayout Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ChartControl..::.RtlTranslateAlignment Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Scale Method

[image]

HeuristicLab API Documentation
ChartControl..::.Scale Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Select Method

[image]

HeuristicLab API Documentation
ChartControl..::.Select Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ChartControl..::.SetBounds Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ChartControl..::.UpdateBounds Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


Validate Method

[image]

HeuristicLab API Documentation
ChartControl..::.Validate Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ChartControl..::.ValidateChildren Method
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ChartControl Class
ChartControl Members
HeuristicLab.Charting Namespace


ChartControl Properties

[image]

HeuristicLab API Documentation
ChartControl Properties
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChartControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart |
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScaleOnResize |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ChartControl Class
HeuristicLab.Charting Namespace


Chart Property

ChartControl..::.Chart Property
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.ChartControl.Chart]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Chart Chart { get; set; }

See Also

ChartControl Class
HeuristicLab.Charting Namespace


ScaleOnResize Property

ChartControl..::.ScaleOnResize Property
ChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.ChartControl.ScaleOnResize]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool ScaleOnResize { get; set; }

See Also

ChartControl Class
HeuristicLab.Charting Namespace


ChartMode Enumeration

ChartMode Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.ChartMode]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public enum ChartMode

Members

Member name | Description
Move |
Zoom |
Select |

See Also

HeuristicLab.Charting Namespace


Ellipse Class

Ellipse Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Ellipse]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Ellipse : RectangularPrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.RectangularPrimitiveBase
HeuristicLab.Charting..::.Ellipse

See Also

Ellipse Members
HeuristicLab.Charting Namespace


Ellipse Members

[image]

HeuristicLab API Documentation
Ellipse Members
Ellipse Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Ellipse type exposes the following members.

Constructors

Name | Description
Ellipse | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from RectangularPrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
selectionRectangles | (Inherited from RectangularPrimitiveBase.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
LowerLeft | (Inherited from RectangularPrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size | (Inherited from RectangularPrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
UpperRight | (Inherited from RectangularPrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
HeuristicLab.Charting Namespace


Ellipse Constructor

[image]

HeuristicLab API Documentation
Ellipse Constructor
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Ellipse(IChart, PointD, PointD) |
Ellipse(IChart, PointD, PointD, Pen, Brush) |
Ellipse(IChart, Double, Double, Double, Double) |
Ellipse(IChart, Double, Double, Double, Double, Pen, Brush) |

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


Ellipse Constructor (IChart, PointD, PointD)

Ellipse Constructor (IChart, PointD, PointD)
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Ellipse class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Ellipse(
    IChart chart,
    PointD lowerLeft,
    PointD upperRight
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

Ellipse Class
Ellipse Overload
HeuristicLab.Charting Namespace


Ellipse Constructor (IChart, PointD, PointD, Pen, Brush)

Ellipse Constructor (IChart, PointD, PointD, Pen, Brush)
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Ellipse class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Ellipse(
    IChart chart,
    PointD lowerLeft,
    PointD upperRight,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Ellipse Class
Ellipse Overload
HeuristicLab.Charting Namespace


Ellipse Constructor (IChart, Double, Double, Double, Double)

Ellipse Constructor (IChart, Double, Double, Double, Double)
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Ellipse class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Ellipse(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

Ellipse Class
Ellipse Overload
HeuristicLab.Charting Namespace


Ellipse Constructor (IChart, Double, Double, Double, Double, Pen, Brush)

Ellipse Constructor (IChart, Double, Double, Double, Double, Pen, Brush)
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Ellipse class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Ellipse(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Ellipse Class
Ellipse Overload
HeuristicLab.Charting Namespace


Ellipse Methods

[image]

HeuristicLab API Documentation
Ellipse Methods
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Ellipse type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from RectangularPrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ellipse Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
Ellipse..::.ContainsPoint Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides RectangularPrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

Ellipse..::.ContainsPoint Method (PointD)
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Ellipse.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Ellipse.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

Ellipse Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


Draw Method

Ellipse..::.Draw Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Ellipse.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

Ellipse Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Ellipse..::.GetCursor Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from RectangularPrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Ellipse..::.GetToolTipText Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Ellipse..::.MouseClick Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Ellipse..::.MouseDoubleClick Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Ellipse..::.MouseDrag Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from RectangularPrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Ellipse..::.MouseMove Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
Ellipse..::.Move Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from RectangularPrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
Ellipse..::.SetPosition Method
Ellipse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) | (Inherited from RectangularPrimitiveBase.)
SetPosition(Double, Double, Double, Double) | (Inherited from RectangularPrimitiveBase.)

See Also

Ellipse Class
Ellipse Members
HeuristicLab.Charting Namespace


FixedSizeCircle Class

FixedSizeCircle Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.FixedSizeCircle]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FixedSizeCircle : FixedSizePrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.FixedSizePrimitiveBase
HeuristicLab.Charting..::.FixedSizeCircle

See Also

FixedSizeCircle Members
HeuristicLab.Charting Namespace


FixedSizeCircle Members

[image]

HeuristicLab API Documentation
FixedSizeCircle Members
FixedSizeCircle Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizeCircle type exposes the following members.

Constructors

Name | Description
FixedSizeCircle | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Point | (Inherited from FixedSizePrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size | (Inherited from FixedSizePrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
HeuristicLab.Charting Namespace


FixedSizeCircle Constructor

[image]

HeuristicLab API Documentation
FixedSizeCircle Constructor
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FixedSizeCircle(IChart, PointD, Int32) |
FixedSizeCircle(IChart, Double, Double, Int32) |
FixedSizeCircle(IChart, PointD, Int32, Pen, Brush) |
FixedSizeCircle(IChart, Double, Double, Int32, Pen, Brush) |

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


FixedSizeCircle Constructor (IChart, PointD, Int32)

FixedSizeCircle Constructor (IChart, PointD, Int32)
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeCircle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeCircle(
    IChart chart,
    PointD point,
    int diameter
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

diameter
Type: System..::.Int32

[Missing <param> documentation for "diameter"]

See Also

FixedSizeCircle Class
FixedSizeCircle Overload
HeuristicLab.Charting Namespace


FixedSizeCircle Constructor (IChart, Double, Double, Int32)

FixedSizeCircle Constructor (IChart, Double, Double, Int32)
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeCircle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeCircle(
    IChart chart,
    double x,
    double y,
    int diameter
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

diameter
Type: System..::.Int32

[Missing <param> documentation for "diameter"]

See Also

FixedSizeCircle Class
FixedSizeCircle Overload
HeuristicLab.Charting Namespace


FixedSizeCircle Constructor (IChart, PointD, Int32, Pen, Brush)

FixedSizeCircle Constructor (IChart, PointD, Int32, Pen, Brush)
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeCircle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeCircle(
    IChart chart,
    PointD point,
    int diameter,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

diameter
Type: System..::.Int32

[Missing <param> documentation for "diameter"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

FixedSizeCircle Class
FixedSizeCircle Overload
HeuristicLab.Charting Namespace


FixedSizeCircle Constructor (IChart, Double, Double, Int32, Pen, Brush)

FixedSizeCircle Constructor (IChart, Double, Double, Int32, Pen, Brush)
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeCircle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeCircle(
    IChart chart,
    double x,
    double y,
    int diameter,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

diameter
Type: System..::.Int32

[Missing <param> documentation for "diameter"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

FixedSizeCircle Class
FixedSizeCircle Overload
HeuristicLab.Charting Namespace


FixedSizeCircle Methods

[image]

HeuristicLab API Documentation
FixedSizeCircle Methods
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizeCircle type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixedSizeCircle Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.ContainsPoint Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Inherited from FixedSizePrimitiveBase.)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


Draw Method

FixedSizeCircle..::.Draw Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.FixedSizeCircle.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

FixedSizeCircle Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.GetCursor Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from PrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.GetToolTipText Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.MouseClick Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.MouseDoubleClick Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.MouseDrag Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.MouseMove Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.Move Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from FixedSizePrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
FixedSizeCircle..::.SetPosition Method
FixedSizeCircle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD) | (Inherited from FixedSizePrimitiveBase.)
SetPosition(Double, Double) | (Inherited from FixedSizePrimitiveBase.)

See Also

FixedSizeCircle Class
FixedSizeCircle Members
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Class

FixedSizePrimitiveBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.FixedSizePrimitiveBase]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class FixedSizePrimitiveBase : PrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.FixedSizePrimitiveBase
HeuristicLab.Charting..::.FixedSizeRectangle
HeuristicLab.Charting..::.FixedSizeCircle

See Also

FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Members

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase Members
FixedSizePrimitiveBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizePrimitiveBase type exposes the following members.

Constructors

Name | Description
FixedSizePrimitiveBase | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Point |
Selected | (Inherited from PrimitiveBase.)
Size |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Constructor

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase Constructor
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FixedSizePrimitiveBase(IChart, PointD, Size) |
FixedSizePrimitiveBase(IChart, Double, Double, Size) |
FixedSizePrimitiveBase(IChart, PointD, Size, Pen, Brush) |
FixedSizePrimitiveBase(IChart, Double, Double, Size, Pen, Brush) |

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Constructor (IChart, PointD, Size)

FixedSizePrimitiveBase Constructor (IChart, PointD, Size)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizePrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected FixedSizePrimitiveBase(
    IChart chart,
    PointD point,
    Size size
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Overload
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Constructor (IChart, Double, Double, Size)

FixedSizePrimitiveBase Constructor (IChart, Double, Double, Size)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizePrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected FixedSizePrimitiveBase(
    IChart chart,
    double x,
    double y,
    Size size
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Overload
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Constructor (IChart, PointD, Size, Pen, Brush)

FixedSizePrimitiveBase Constructor (IChart, PointD, Size, Pen, Brush)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizePrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected FixedSizePrimitiveBase(
    IChart chart,
    PointD point,
    Size size,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Overload
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Constructor (IChart, Double, Double, Size, Pen, Brush)

FixedSizePrimitiveBase Constructor (IChart, Double, Double, Size, Pen, Brush)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizePrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected FixedSizePrimitiveBase(
    IChart chart,
    double x,
    double y,
    Size size,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Overload
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Methods

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase Methods
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizePrimitiveBase type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixedSizePrimitiveBase Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.ContainsPoint Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides PrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

FixedSizePrimitiveBase..::.ContainsPoint Method (PointD)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.FixedSizePrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.FixedSizePrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

FixedSizePrimitiveBase Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.GetCursor Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from PrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.GetToolTipText Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.MouseClick Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.MouseDoubleClick Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.MouseDrag Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.MouseMove Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.Move Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Overrides PrimitiveBase ..::. Move(Offset).)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method (Offset)

FixedSizePrimitiveBase..::.Move Method (Offset)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.FixedSizePrimitiveBase.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IPrimitive..::.Move(Offset)

See Also

FixedSizePrimitiveBase Class
Move Overload
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase..::.SetPosition Method
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD) |
SetPosition(Double, Double) |

See Also

FixedSizePrimitiveBase Class
FixedSizePrimitiveBase Members
HeuristicLab.Charting Namespace


SetPosition Method (PointD)

FixedSizePrimitiveBase..::.SetPosition Method (PointD)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.FixedSizePrimitiveBase.SetPosition(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void SetPosition(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

See Also

FixedSizePrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


SetPosition Method (Double, Double)

FixedSizePrimitiveBase..::.SetPosition Method (Double, Double)
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.FixedSizePrimitiveBase.SetPosition(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetPosition(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

See Also

FixedSizePrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


FixedSizePrimitiveBase Properties

[image]

HeuristicLab API Documentation
FixedSizePrimitiveBase Properties
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizePrimitiveBase type exposes the following members.

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Point |
Selected | (Inherited from PrimitiveBase.)
Size |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

See Also

FixedSizePrimitiveBase Class
HeuristicLab.Charting Namespace


Point Property

FixedSizePrimitiveBase..::.Point Property
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.FixedSizePrimitiveBase.Point]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD Point { get; }

See Also

FixedSizePrimitiveBase Class
HeuristicLab.Charting Namespace


Size Property

FixedSizePrimitiveBase..::.Size Property
FixedSizePrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.FixedSizePrimitiveBase.Size]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Size Size { get; }

See Also

FixedSizePrimitiveBase Class
HeuristicLab.Charting Namespace


FixedSizeRectangle Class

FixedSizeRectangle Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.FixedSizeRectangle]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FixedSizeRectangle : FixedSizePrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.FixedSizePrimitiveBase
HeuristicLab.Charting..::.FixedSizeRectangle
HeuristicLab.Charting..::.SelectionRectangle

See Also

FixedSizeRectangle Members
HeuristicLab.Charting Namespace


FixedSizeRectangle Members

[image]

HeuristicLab API Documentation
FixedSizeRectangle Members
FixedSizeRectangle Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizeRectangle type exposes the following members.

Constructors

Name | Description
FixedSizeRectangle | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Point | (Inherited from FixedSizePrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size | (Inherited from FixedSizePrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
HeuristicLab.Charting Namespace


FixedSizeRectangle Constructor

[image]

HeuristicLab API Documentation
FixedSizeRectangle Constructor
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FixedSizeRectangle(IChart, PointD, Size) |
FixedSizeRectangle(IChart, Double, Double, Size) |
FixedSizeRectangle(IChart, PointD, Size, Pen, Brush) |
FixedSizeRectangle(IChart, Double, Double, Size, Pen, Brush) |

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


FixedSizeRectangle Constructor (IChart, PointD, Size)

FixedSizeRectangle Constructor (IChart, PointD, Size)
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeRectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeRectangle(
    IChart chart,
    PointD point,
    Size size
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

See Also

FixedSizeRectangle Class
FixedSizeRectangle Overload
HeuristicLab.Charting Namespace


FixedSizeRectangle Constructor (IChart, Double, Double, Size)

FixedSizeRectangle Constructor (IChart, Double, Double, Size)
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeRectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeRectangle(
    IChart chart,
    double x,
    double y,
    Size size
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

See Also

FixedSizeRectangle Class
FixedSizeRectangle Overload
HeuristicLab.Charting Namespace


FixedSizeRectangle Constructor (IChart, PointD, Size, Pen, Brush)

FixedSizeRectangle Constructor (IChart, PointD, Size, Pen, Brush)
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeRectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeRectangle(
    IChart chart,
    PointD point,
    Size size,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

FixedSizeRectangle Class
FixedSizeRectangle Overload
HeuristicLab.Charting Namespace


FixedSizeRectangle Constructor (IChart, Double, Double, Size, Pen, Brush)

FixedSizeRectangle Constructor (IChart, Double, Double, Size, Pen, Brush)
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FixedSizeRectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FixedSizeRectangle(
    IChart chart,
    double x,
    double y,
    Size size,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

FixedSizeRectangle Class
FixedSizeRectangle Overload
HeuristicLab.Charting Namespace


FixedSizeRectangle Methods

[image]

HeuristicLab API Documentation
FixedSizeRectangle Methods
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FixedSizeRectangle type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FixedSizeRectangle Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.ContainsPoint Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Inherited from FixedSizePrimitiveBase.)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


Draw Method

FixedSizeRectangle..::.Draw Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.FixedSizeRectangle.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

FixedSizeRectangle Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.GetCursor Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from PrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.GetToolTipText Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.MouseClick Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.MouseDoubleClick Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.MouseDrag Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.MouseMove Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.Move Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from FixedSizePrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
FixedSizeRectangle..::.SetPosition Method
FixedSizeRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD) | (Inherited from FixedSizePrimitiveBase.)
SetPosition(Double, Double) | (Inherited from FixedSizePrimitiveBase.)

See Also

FixedSizeRectangle Class
FixedSizeRectangle Members
HeuristicLab.Charting Namespace


Group Class

Group Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Group]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Group : PrimitiveBase, IGroup,
    IPrimitive

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.Group

See Also

Group Members
HeuristicLab.Charting Namespace


Group Members

[image]

HeuristicLab API Documentation
Group Members
Group Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Group type exposes the following members.

Constructors

Name | Description
Group |

Methods

Name | Description
Add |
AddRange |
Clear |
Contains |
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | Overloaded.
IntoForeground | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | Overloaded.
OneLayerUp | Overloaded.
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Primitives |
Selected | (Overrides PrimitiveBase ..::. Selected.)
SelectedPrimitives |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

Group Class
HeuristicLab.Charting Namespace


Group Constructor

Group Constructor
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Group class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Group(
    IChart chart
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

See Also

Group Class
HeuristicLab.Charting Namespace


Group Methods

[image]

HeuristicLab API Documentation
Group Methods
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Group type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
Contains |
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | Overloaded.
IntoForeground | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | Overloaded.
OneLayerUp | Overloaded.
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
Remove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Group Class
HeuristicLab.Charting Namespace


Add Method

Group..::.Add Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.Add(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Add(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Implements

IGroup..::.Add(IPrimitive)

See Also

Group Class
HeuristicLab.Charting Namespace


AddRange Method

Group..::.AddRange Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.AddRange(System.Collections.Generic.IEnumerable{HeuristicLab.Charting.IPrimitive})]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddRange(
    IEnumerable<IPrimitive> primitives
)

Parameters

primitives
Type: System.Collections.Generic..::.IEnumerable <(Of <( IPrimitive >)>)

[Missing <param> documentation for "primitives"]

Implements

IGroup..::.AddRange(IEnumerable<(Of <(IPrimitive>)>))

See Also

Group Class
HeuristicLab.Charting Namespace


Clear Method

Group..::.Clear Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.Clear]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Clear()

Implements

IGroup..::.Clear()()()

See Also

Group Class
HeuristicLab.Charting Namespace


Contains Method

Group..::.Contains Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.Contains(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool Contains(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.Contains(HeuristicLab.Charting.IPrimitive)]

Implements

IGroup..::.Contains(IPrimitive)

See Also

Group Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
Group..::.ContainsPoint Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides PrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

Group..::.ContainsPoint Method (PointD)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)
IPrimitive..::.ContainsPoint(PointD)

See Also

Group Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


Draw Method

Group..::.Draw Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)
IPrimitive..::.Draw(Graphics)

See Also

Group Class
HeuristicLab.Charting Namespace


GetAllPrimitives Method

[image]

HeuristicLab API Documentation
Group..::.GetAllPrimitives Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetAllPrimitives(PointD) |
GetAllPrimitives(Double, Double) |

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


GetAllPrimitives Method (PointD)

Group..::.GetAllPrimitives Method (PointD)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.GetAllPrimitives(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IList<IPrimitive> GetAllPrimitives(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.GetAllPrimitives(HeuristicLab.Charting.PointD)]

Implements

IGroup..::.GetAllPrimitives(PointD)

See Also

Group Class
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetAllPrimitives Method (Double, Double)

Group..::.GetAllPrimitives Method (Double, Double)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.GetAllPrimitives(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IPrimitive> GetAllPrimitives(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.GetAllPrimitives(System.Double,System.Double)]

Implements

IGroup..::.GetAllPrimitives(Double, Double)

See Also

Group Class
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Group..::.GetCursor Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Overrides PrimitiveBase ..::. GetCursor(PointD).)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


GetCursor Method (PointD)

Group..::.GetCursor Method (PointD)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.GetCursor(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Cursor GetCursor(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.GetCursor(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetCursor(PointD)
IPrimitive..::.GetCursor(PointD)

See Also

Group Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetPrimitive Method

[image]

HeuristicLab API Documentation
Group..::.GetPrimitive Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPrimitive(PointD) |
GetPrimitive(Double, Double) |

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


GetPrimitive Method (PointD)

Group..::.GetPrimitive Method (PointD)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.GetPrimitive(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IPrimitive GetPrimitive(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.GetPrimitive(HeuristicLab.Charting.PointD)]

Implements

IGroup..::.GetPrimitive(PointD)

See Also

Group Class
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetPrimitive Method (Double, Double)

Group..::.GetPrimitive Method (Double, Double)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.GetPrimitive(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IPrimitive GetPrimitive(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.GetPrimitive(System.Double,System.Double)]

Implements

IGroup..::.GetPrimitive(Double, Double)

See Also

Group Class
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Group..::.GetToolTipText Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Overrides PrimitiveBase ..::. GetToolTipText(PointD).)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


GetToolTipText Method (PointD)

Group..::.GetToolTipText Method (PointD)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.GetToolTipText(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string GetToolTipText(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.GetToolTipText(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetToolTipText(PointD)
IPrimitive..::.GetToolTipText(PointD)

See Also

Group Class
GetToolTipText Overload
HeuristicLab.Charting Namespace


IntoBackground Method

[image]

HeuristicLab API Documentation
Group..::.IntoBackground Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntoBackground()()() | (Inherited from PrimitiveBase.)
IntoBackground(IPrimitive) |

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


IntoBackground Method (IPrimitive)

Group..::.IntoBackground Method (IPrimitive)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.IntoBackground(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void IntoBackground(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Implements

IGroup..::.IntoBackground(IPrimitive)

See Also

Group Class
IntoBackground Overload
HeuristicLab.Charting Namespace


IntoForeground Method

[image]

HeuristicLab API Documentation
Group..::.IntoForeground Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntoForeground()()() | (Inherited from PrimitiveBase.)
IntoForeground(IPrimitive) |

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


IntoForeground Method (IPrimitive)

Group..::.IntoForeground Method (IPrimitive)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.IntoForeground(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void IntoForeground(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Implements

IGroup..::.IntoForeground(IPrimitive)

See Also

Group Class
IntoForeground Overload
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Group..::.MouseClick Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Group..::.MouseDoubleClick Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Group..::.MouseDrag Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Group..::.MouseMove Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
Group..::.Move Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Overrides PrimitiveBase ..::. Move(Offset).)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


Move Method (Offset)

Group..::.Move Method (Offset)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IPrimitive..::.Move(Offset)
IPrimitive..::.Move(Offset)

See Also

Group Class
Move Overload
HeuristicLab.Charting Namespace


OneLayerDown Method

[image]

HeuristicLab API Documentation
Group..::.OneLayerDown Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OneLayerDown()()() | (Inherited from PrimitiveBase.)
OneLayerDown(IPrimitive) |

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


OneLayerDown Method (IPrimitive)

Group..::.OneLayerDown Method (IPrimitive)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.OneLayerDown(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OneLayerDown(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Implements

IGroup..::.OneLayerDown(IPrimitive)

See Also

Group Class
OneLayerDown Overload
HeuristicLab.Charting Namespace


OneLayerUp Method

[image]

HeuristicLab API Documentation
Group..::.OneLayerUp Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OneLayerUp()()() | (Inherited from PrimitiveBase.)
OneLayerUp(IPrimitive) |

See Also

Group Class
Group Members
HeuristicLab.Charting Namespace


OneLayerUp Method (IPrimitive)

Group..::.OneLayerUp Method (IPrimitive)
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.OneLayerUp(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OneLayerUp(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Implements

IGroup..::.OneLayerUp(IPrimitive)

See Also

Group Class
OneLayerUp Overload
HeuristicLab.Charting Namespace


Remove Method

Group..::.Remove Method
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Group.Remove(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool Remove(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Group.Remove(HeuristicLab.Charting.IPrimitive)]

Implements

IGroup..::.Remove(IPrimitive)

See Also

Group Class
HeuristicLab.Charting Namespace


Group Properties

[image]

HeuristicLab API Documentation
Group Properties
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Group type exposes the following members.

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Primitives |
Selected | (Overrides PrimitiveBase ..::. Selected.)
SelectedPrimitives |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

See Also

Group Class
HeuristicLab.Charting Namespace


Primitives Property

Group..::.Primitives Property
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Group.Primitives]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual ReadOnlyCollection<IPrimitive> Primitives { get; }

Implements

IGroup..::.Primitives

See Also

Group Class
HeuristicLab.Charting Namespace


Selected Property

Group..::.Selected Property
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Group.Selected]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Selected { get; set; }

Implements

IPrimitive..::.Selected
IPrimitive..::.Selected

See Also

Group Class
HeuristicLab.Charting Namespace


SelectedPrimitives Property

Group..::.SelectedPrimitives Property
Group Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Group.SelectedPrimitives]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual ReadOnlyCollection<IPrimitive> SelectedPrimitives { get; }

Implements

IGroup..::.SelectedPrimitives

See Also

Group Class
HeuristicLab.Charting Namespace


HeuristicLabChartingPlugin Class

HeuristicLabChartingPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.HeuristicLabChartingPlugin]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Charting.dll", Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Charting")]
public class HeuristicLabChartingPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Charting..::.HeuristicLabChartingPlugin

See Also

HeuristicLabChartingPlugin Members
HeuristicLab.Charting Namespace


HeuristicLabChartingPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabChartingPlugin Members
HeuristicLabChartingPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabChartingPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabChartingPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabChartingPlugin Class
HeuristicLab.Charting Namespace


HeuristicLabChartingPlugin Constructor

HeuristicLabChartingPlugin Constructor
HeuristicLabChartingPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabChartingPlugin class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabChartingPlugin()

See Also

HeuristicLabChartingPlugin Class
HeuristicLab.Charting Namespace


IChart Interface

IChart Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.IChart]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IChart

See Also

IChart Members
HeuristicLab.Charting Namespace


IChart Members

[image]

HeuristicLab API Documentation
IChart Members
IChart Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IChart type exposes the following members.

Methods

Name | Description
EnforceUpdate |
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
Render |
SetPosition | Overloaded.
TransformPixelToWorld | Overloaded.
TransformWorldToPixel | Overloaded.
Unzoom |
ZoomIn | Overloaded.
ZoomOut |

Properties

Name | Description
Group |
LowerLeft |
Mode |
PixelToWorldRatio |
Size |
SizeInPixels |
UpdateEnabled |
UpperRight |
WorldToPixelRatio |

Events

Name | Description
Update |

See Also

IChart Interface
HeuristicLab.Charting Namespace


IChart Methods

[image]

HeuristicLab API Documentation
IChart Methods
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IChart type exposes the following members.

Methods

Name | Description
EnforceUpdate |
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
Render |
SetPosition | Overloaded.
TransformPixelToWorld | Overloaded.
TransformWorldToPixel | Overloaded.
Unzoom |
ZoomIn | Overloaded.
ZoomOut |

See Also

IChart Interface
HeuristicLab.Charting Namespace


EnforceUpdate Method

IChart..::.EnforceUpdate Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.EnforceUpdate]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void EnforceUpdate()

See Also

IChart Interface
HeuristicLab.Charting Namespace


GetAllPrimitives Method

[image]

HeuristicLab API Documentation
IChart..::.GetAllPrimitives Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetAllPrimitives(Point) |
GetAllPrimitives(Int32, Int32) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


GetAllPrimitives Method (Point)

IChart..::.GetAllPrimitives Method (Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetAllPrimitives(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IPrimitive> GetAllPrimitives(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetAllPrimitives(System.Drawing.Point)]

See Also

IChart Interface
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetAllPrimitives Method (Int32, Int32)

IChart..::.GetAllPrimitives Method (Int32, Int32)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetAllPrimitives(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IPrimitive> GetAllPrimitives(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetAllPrimitives(System.Int32,System.Int32)]

See Also

IChart Interface
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
IChart..::.GetCursor Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(Point) |
GetCursor(Int32, Int32) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


GetCursor Method (Point)

IChart..::.GetCursor Method (Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetCursor(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Cursor GetCursor(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetCursor(System.Drawing.Point)]

See Also

IChart Interface
GetCursor Overload
HeuristicLab.Charting Namespace


GetCursor Method (Int32, Int32)

IChart..::.GetCursor Method (Int32, Int32)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetCursor(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Cursor GetCursor(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetCursor(System.Int32,System.Int32)]

See Also

IChart Interface
GetCursor Overload
HeuristicLab.Charting Namespace


GetPrimitive Method

[image]

HeuristicLab API Documentation
IChart..::.GetPrimitive Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPrimitive(Point) |
GetPrimitive(Int32, Int32) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


GetPrimitive Method (Point)

IChart..::.GetPrimitive Method (Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetPrimitive(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IPrimitive GetPrimitive(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetPrimitive(System.Drawing.Point)]

See Also

IChart Interface
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetPrimitive Method (Int32, Int32)

IChart..::.GetPrimitive Method (Int32, Int32)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetPrimitive(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IPrimitive GetPrimitive(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetPrimitive(System.Int32,System.Int32)]

See Also

IChart Interface
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
IChart..::.GetToolTipText Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(Point) |
GetToolTipText(Int32, Int32) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


GetToolTipText Method (Point)

IChart..::.GetToolTipText Method (Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetToolTipText(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string GetToolTipText(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetToolTipText(System.Drawing.Point)]

See Also

IChart Interface
GetToolTipText Overload
HeuristicLab.Charting Namespace


GetToolTipText Method (Int32, Int32)

IChart..::.GetToolTipText Method (Int32, Int32)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.GetToolTipText(System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string GetToolTipText(
    int x,
    int y
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.GetToolTipText(System.Int32,System.Int32)]

See Also

IChart Interface
GetToolTipText Overload
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
IChart..::.MouseClick Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(Point, MouseButtons) |
MouseClick(Int32, Int32, MouseButtons) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


MouseClick Method (Point, MouseButtons)

IChart..::.MouseClick Method (Point, MouseButtons)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseClick(System.Drawing.Point,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseClick(
    Point point,
    MouseButtons button
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IChart Interface
MouseClick Overload
HeuristicLab.Charting Namespace


MouseClick Method (Int32, Int32, MouseButtons)

IChart..::.MouseClick Method (Int32, Int32, MouseButtons)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseClick(System.Int32,System.Int32,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseClick(
    int x,
    int y,
    MouseButtons button
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IChart Interface
MouseClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
IChart..::.MouseDoubleClick Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(Point, MouseButtons) |
MouseDoubleClick(Int32, Int32, MouseButtons) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method (Point, MouseButtons)

IChart..::.MouseDoubleClick Method (Point, MouseButtons)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseDoubleClick(System.Drawing.Point,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDoubleClick(
    Point point,
    MouseButtons button
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IChart Interface
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method (Int32, Int32, MouseButtons)

IChart..::.MouseDoubleClick Method (Int32, Int32, MouseButtons)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseDoubleClick(System.Int32,System.Int32,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDoubleClick(
    int x,
    int y,
    MouseButtons button
)

Parameters

x
Type: System..::.Int32

[Missing <param> documentation for "x"]

y
Type: System..::.Int32

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IChart Interface
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
IChart..::.MouseDrag Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(Point, Point, MouseButtons) |
MouseDrag(Int32, Int32, Int32, Int32, MouseButtons) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


MouseDrag Method (Point, Point, MouseButtons)

IChart..::.MouseDrag Method (Point, Point, MouseButtons)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseDrag(System.Drawing.Point,System.Drawing.Point,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDrag(
    Point start,
    Point end,
    MouseButtons button
)

Parameters

start
Type: System.Drawing..::.Point

[Missing <param> documentation for "start"]

end
Type: System.Drawing..::.Point

[Missing <param> documentation for "end"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IChart Interface
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseDrag Method (Int32, Int32, Int32, Int32, MouseButtons)

IChart..::.MouseDrag Method (Int32, Int32, Int32, Int32, MouseButtons)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseDrag(System.Int32,System.Int32,System.Int32,System.Int32,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDrag(
    int x1,
    int y1,
    int x2,
    int y2,
    MouseButtons button
)

Parameters

x1
Type: System..::.Int32

[Missing <param> documentation for "x1"]

y1
Type: System..::.Int32

[Missing <param> documentation for "y1"]

x2
Type: System..::.Int32

[Missing <param> documentation for "x2"]

y2
Type: System..::.Int32

[Missing <param> documentation for "y2"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IChart Interface
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
IChart..::.MouseMove Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(Point, Point) |
MouseMove(Int32, Int32, Int32, Int32) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


MouseMove Method (Point, Point)

IChart..::.MouseMove Method (Point, Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseMove(System.Drawing.Point,System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseMove(
    Point start,
    Point end
)

Parameters

start
Type: System.Drawing..::.Point

[Missing <param> documentation for "start"]

end
Type: System.Drawing..::.Point

[Missing <param> documentation for "end"]

See Also

IChart Interface
MouseMove Overload
HeuristicLab.Charting Namespace


MouseMove Method (Int32, Int32, Int32, Int32)

IChart..::.MouseMove Method (Int32, Int32, Int32, Int32)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.MouseMove(System.Int32,System.Int32,System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseMove(
    int x1,
    int y1,
    int x2,
    int y2
)

Parameters

x1
Type: System..::.Int32

[Missing <param> documentation for "x1"]

y1
Type: System..::.Int32

[Missing <param> documentation for "y1"]

x2
Type: System..::.Int32

[Missing <param> documentation for "x2"]

y2
Type: System..::.Int32

[Missing <param> documentation for "y2"]

See Also

IChart Interface
MouseMove Overload
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
IChart..::.Move Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) |
Move(Double, Double) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


Move Method (Offset)

IChart..::.Move Method (Offset)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

See Also

IChart Interface
Move Overload
HeuristicLab.Charting Namespace


Move Method (Double, Double)

IChart..::.Move Method (Double, Double)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.Move(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Move(
    double dx,
    double dy
)

Parameters

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

See Also

IChart Interface
Move Overload
HeuristicLab.Charting Namespace


Render Method

IChart..::.Render Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.Render(System.Drawing.Graphics,System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Render(
    Graphics graphics,
    int width,
    int height
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

width
Type: System..::.Int32

[Missing <param> documentation for "width"]

height
Type: System..::.Int32

[Missing <param> documentation for "height"]

See Also

IChart Interface
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
IChart..::.SetPosition Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) |
SetPosition(Double, Double, Double, Double) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


SetPosition Method (PointD, PointD)

IChart..::.SetPosition Method (PointD, PointD)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.SetPosition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void SetPosition(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

IChart Interface
SetPosition Overload
HeuristicLab.Charting Namespace


SetPosition Method (Double, Double, Double, Double)

IChart..::.SetPosition Method (Double, Double, Double, Double)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.SetPosition(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void SetPosition(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

IChart Interface
SetPosition Overload
HeuristicLab.Charting Namespace


TransformPixelToWorld Method

[image]

HeuristicLab API Documentation
IChart..::.TransformPixelToWorld Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TransformPixelToWorld(Point) |
TransformPixelToWorld(Size) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


TransformPixelToWorld Method (Point)

IChart..::.TransformPixelToWorld Method (Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.TransformPixelToWorld(System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
PointD TransformPixelToWorld(
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.TransformPixelToWorld(System.Drawing.Point)]

See Also

IChart Interface
TransformPixelToWorld Overload
HeuristicLab.Charting Namespace


TransformPixelToWorld Method (Size)

IChart..::.TransformPixelToWorld Method (Size)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.TransformPixelToWorld(System.Drawing.Size)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
SizeD TransformPixelToWorld(
    Size size
)

Parameters

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.TransformPixelToWorld(System.Drawing.Size)]

See Also

IChart Interface
TransformPixelToWorld Overload
HeuristicLab.Charting Namespace


TransformWorldToPixel Method

[image]

HeuristicLab API Documentation
IChart..::.TransformWorldToPixel Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TransformWorldToPixel(PointD) |
TransformWorldToPixel(SizeD) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


TransformWorldToPixel Method (PointD)

IChart..::.TransformWorldToPixel Method (PointD)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.TransformWorldToPixel(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Point TransformWorldToPixel(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.TransformWorldToPixel(HeuristicLab.Charting.PointD)]

See Also

IChart Interface
TransformWorldToPixel Overload
HeuristicLab.Charting Namespace


TransformWorldToPixel Method (SizeD)

IChart..::.TransformWorldToPixel Method (SizeD)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.TransformWorldToPixel(HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Size TransformWorldToPixel(
    SizeD size
)

Parameters

size
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IChart.TransformWorldToPixel(HeuristicLab.Charting.SizeD)]

See Also

IChart Interface
TransformWorldToPixel Overload
HeuristicLab.Charting Namespace


Unzoom Method

IChart..::.Unzoom Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.Unzoom]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Unzoom()

See Also

IChart Interface
HeuristicLab.Charting Namespace


ZoomIn Method

[image]

HeuristicLab API Documentation
IChart..::.ZoomIn Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ZoomIn(Point, Point) |
ZoomIn(PointD, PointD) |
ZoomIn(Double, Double, Double, Double) |
ZoomIn(Int32, Int32, Int32, Int32) |

See Also

IChart Interface
IChart Members
HeuristicLab.Charting Namespace


ZoomIn Method (Point, Point)

IChart..::.ZoomIn Method (Point, Point)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.ZoomIn(System.Drawing.Point,System.Drawing.Point)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ZoomIn(
    Point lowerLeft,
    Point upperRight
)

Parameters

lowerLeft
Type: System.Drawing..::.Point

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: System.Drawing..::.Point

[Missing <param> documentation for "upperRight"]

See Also

IChart Interface
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomIn Method (PointD, PointD)

IChart..::.ZoomIn Method (PointD, PointD)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.ZoomIn(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ZoomIn(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

IChart Interface
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomIn Method (Double, Double, Double, Double)

IChart..::.ZoomIn Method (Double, Double, Double, Double)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.ZoomIn(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ZoomIn(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

IChart Interface
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomIn Method (Int32, Int32, Int32, Int32)

IChart..::.ZoomIn Method (Int32, Int32, Int32, Int32)
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.ZoomIn(System.Int32,System.Int32,System.Int32,System.Int32)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ZoomIn(
    int x1,
    int y1,
    int x2,
    int y2
)

Parameters

x1
Type: System..::.Int32

[Missing <param> documentation for "x1"]

y1
Type: System..::.Int32

[Missing <param> documentation for "y1"]

x2
Type: System..::.Int32

[Missing <param> documentation for "x2"]

y2
Type: System..::.Int32

[Missing <param> documentation for "y2"]

See Also

IChart Interface
ZoomIn Overload
HeuristicLab.Charting Namespace


ZoomOut Method

IChart..::.ZoomOut Method
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IChart.ZoomOut]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ZoomOut()

See Also

IChart Interface
HeuristicLab.Charting Namespace


IChart Properties

[image]

HeuristicLab API Documentation
IChart Properties
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IChart type exposes the following members.

Properties

Name | Description
Group |
LowerLeft |
Mode |
PixelToWorldRatio |
Size |
SizeInPixels |
UpdateEnabled |
UpperRight |
WorldToPixelRatio |

See Also

IChart Interface
HeuristicLab.Charting Namespace


Group Property

IChart..::.Group Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.Group]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IGroup Group { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


LowerLeft Property

IChart..::.LowerLeft Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.LowerLeft]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
PointD LowerLeft { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


Mode Property

IChart..::.Mode Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.Mode]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ChartMode Mode { get; set; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


PixelToWorldRatio Property

IChart..::.PixelToWorldRatio Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.PixelToWorldRatio]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
SizeD PixelToWorldRatio { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


Size Property

IChart..::.Size Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.Size]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
SizeD Size { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


SizeInPixels Property

IChart..::.SizeInPixels Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.SizeInPixels]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Size SizeInPixels { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


UpdateEnabled Property

IChart..::.UpdateEnabled Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.UpdateEnabled]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool UpdateEnabled { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


UpperRight Property

IChart..::.UpperRight Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.UpperRight]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
PointD UpperRight { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


WorldToPixelRatio Property

IChart..::.WorldToPixelRatio Property
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IChart.WorldToPixelRatio]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
SizeD WorldToPixelRatio { get; }

See Also

IChart Interface
HeuristicLab.Charting Namespace


IChart Events

[image]

HeuristicLab API Documentation
IChart Events
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IChart type exposes the following members.

Events

Name | Description
Update |

See Also

IChart Interface
HeuristicLab.Charting Namespace


Update Event

IChart..::.Update Event
IChart Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Charting.IChart.Update]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Update

See Also

IChart Interface
HeuristicLab.Charting Namespace


IGroup Interface

IGroup Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.IGroup]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IGroup : IPrimitive

See Also

IGroup Members
HeuristicLab.Charting Namespace


IGroup Members

[image]

HeuristicLab API Documentation
IGroup Members
IGroup Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IGroup type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
Contains |
ContainsPoint | Overloaded.
Draw | (Inherited from IPrimitive.)
EnforceUpdate | (Inherited from IPrimitive.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
IntoBackground | Overloaded.
IntoForeground | Overloaded.
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | Overloaded.
OneLayerUp | Overloaded.
PostDraw | (Inherited from IPrimitive.)
PreDraw | (Inherited from IPrimitive.)
Remove |

Properties

Name | Description
Brush | (Inherited from IPrimitive.)
Chart | (Inherited from IPrimitive.)
Group | (Inherited from IPrimitive.)
Pen | (Inherited from IPrimitive.)
Primitives |
Selected | (Inherited from IPrimitive.)
SelectedPrimitives |
Tag | (Inherited from IPrimitive.)
ToolTipText | (Inherited from IPrimitive.)
UpdateEnabled | (Inherited from IPrimitive.)

Events

Name | Description
Update | (Inherited from IPrimitive.)

See Also

IGroup Interface
HeuristicLab.Charting Namespace


IGroup Methods

[image]

HeuristicLab API Documentation
IGroup Methods
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IGroup type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
Contains |
ContainsPoint | Overloaded.
Draw | (Inherited from IPrimitive.)
EnforceUpdate | (Inherited from IPrimitive.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
IntoBackground | Overloaded.
IntoForeground | Overloaded.
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | Overloaded.
OneLayerUp | Overloaded.
PostDraw | (Inherited from IPrimitive.)
PreDraw | (Inherited from IPrimitive.)
Remove |

See Also

IGroup Interface
HeuristicLab.Charting Namespace


Add Method

IGroup..::.Add Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.Add(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Add(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

See Also

IGroup Interface
HeuristicLab.Charting Namespace


AddRange Method

IGroup..::.AddRange Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.AddRange(System.Collections.Generic.IEnumerable{HeuristicLab.Charting.IPrimitive})]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddRange(
    IEnumerable<IPrimitive> primitives
)

Parameters

primitives
Type: System.Collections.Generic..::.IEnumerable <(Of <( IPrimitive >)>)

[Missing <param> documentation for "primitives"]

See Also

IGroup Interface
HeuristicLab.Charting Namespace


Clear Method

IGroup..::.Clear Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.Clear]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Clear()

See Also

IGroup Interface
HeuristicLab.Charting Namespace


Contains Method

IGroup..::.Contains Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.Contains(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Contains(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IGroup.Contains(HeuristicLab.Charting.IPrimitive)]

See Also

IGroup Interface
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
IGroup..::.ContainsPoint Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Inherited from IPrimitive.)
ContainsPoint(Double, Double) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


GetAllPrimitives Method

[image]

HeuristicLab API Documentation
IGroup..::.GetAllPrimitives Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetAllPrimitives(PointD) |
GetAllPrimitives(Double, Double) |

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


GetAllPrimitives Method (PointD)

IGroup..::.GetAllPrimitives Method (PointD)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.GetAllPrimitives(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IPrimitive> GetAllPrimitives(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IGroup.GetAllPrimitives(HeuristicLab.Charting.PointD)]

See Also

IGroup Interface
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetAllPrimitives Method (Double, Double)

IGroup..::.GetAllPrimitives Method (Double, Double)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.GetAllPrimitives(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IPrimitive> GetAllPrimitives(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IGroup.GetAllPrimitives(System.Double,System.Double)]

See Also

IGroup Interface
GetAllPrimitives Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
IGroup..::.GetCursor Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from IPrimitive.)
GetCursor(Double, Double) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


GetPrimitive Method

[image]

HeuristicLab API Documentation
IGroup..::.GetPrimitive Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPrimitive(PointD) |
GetPrimitive(Double, Double) |

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


GetPrimitive Method (PointD)

IGroup..::.GetPrimitive Method (PointD)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.GetPrimitive(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IPrimitive GetPrimitive(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IGroup.GetPrimitive(HeuristicLab.Charting.PointD)]

See Also

IGroup Interface
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetPrimitive Method (Double, Double)

IGroup..::.GetPrimitive Method (Double, Double)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.GetPrimitive(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IPrimitive GetPrimitive(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IGroup.GetPrimitive(System.Double,System.Double)]

See Also

IGroup Interface
GetPrimitive Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
IGroup..::.GetToolTipText Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from IPrimitive.)
GetToolTipText(Double, Double) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


IntoBackground Method

[image]

HeuristicLab API Documentation
IGroup..::.IntoBackground Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntoBackground()()() | (Inherited from IPrimitive.)
IntoBackground(IPrimitive) |

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


IntoBackground Method (IPrimitive)

IGroup..::.IntoBackground Method (IPrimitive)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.IntoBackground(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void IntoBackground(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

See Also

IGroup Interface
IntoBackground Overload
HeuristicLab.Charting Namespace


IntoForeground Method

[image]

HeuristicLab API Documentation
IGroup..::.IntoForeground Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntoForeground()()() | (Inherited from IPrimitive.)
IntoForeground(IPrimitive) |

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


IntoForeground Method (IPrimitive)

IGroup..::.IntoForeground Method (IPrimitive)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.IntoForeground(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void IntoForeground(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

See Also

IGroup Interface
IntoForeground Overload
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
IGroup..::.MouseClick Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from IPrimitive.)
MouseClick(Double, Double, MouseButtons) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
IGroup..::.MouseDoubleClick Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from IPrimitive.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
IGroup..::.MouseDrag Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from IPrimitive.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
IGroup..::.MouseMove Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from IPrimitive.)
MouseMove(Double, Double, Double, Double) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
IGroup..::.Move Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from IPrimitive.)
Move(Double, Double) | (Inherited from IPrimitive.)

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


OneLayerDown Method

[image]

HeuristicLab API Documentation
IGroup..::.OneLayerDown Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OneLayerDown()()() | (Inherited from IPrimitive.)
OneLayerDown(IPrimitive) |

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


OneLayerDown Method (IPrimitive)

IGroup..::.OneLayerDown Method (IPrimitive)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.OneLayerDown(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OneLayerDown(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

See Also

IGroup Interface
OneLayerDown Overload
HeuristicLab.Charting Namespace


OneLayerUp Method

[image]

HeuristicLab API Documentation
IGroup..::.OneLayerUp Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OneLayerUp()()() | (Inherited from IPrimitive.)
OneLayerUp(IPrimitive) |

See Also

IGroup Interface
IGroup Members
HeuristicLab.Charting Namespace


OneLayerUp Method (IPrimitive)

IGroup..::.OneLayerUp Method (IPrimitive)
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.OneLayerUp(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OneLayerUp(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

See Also

IGroup Interface
OneLayerUp Overload
HeuristicLab.Charting Namespace


Remove Method

IGroup..::.Remove Method
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IGroup.Remove(HeuristicLab.Charting.IPrimitive)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Remove(
    IPrimitive primitive
)

Parameters

primitive
Type: HeuristicLab.Charting..::.IPrimitive

[Missing <param> documentation for "primitive"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IGroup.Remove(HeuristicLab.Charting.IPrimitive)]

See Also

IGroup Interface
HeuristicLab.Charting Namespace


IGroup Properties

[image]

HeuristicLab API Documentation
IGroup Properties
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IGroup type exposes the following members.

Properties

Name | Description
Brush | (Inherited from IPrimitive.)
Chart | (Inherited from IPrimitive.)
Group | (Inherited from IPrimitive.)
Pen | (Inherited from IPrimitive.)
Primitives |
Selected | (Inherited from IPrimitive.)
SelectedPrimitives |
Tag | (Inherited from IPrimitive.)
ToolTipText | (Inherited from IPrimitive.)
UpdateEnabled | (Inherited from IPrimitive.)

See Also

IGroup Interface
HeuristicLab.Charting Namespace


Primitives Property

IGroup..::.Primitives Property
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IGroup.Primitives]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ReadOnlyCollection<IPrimitive> Primitives { get; }

See Also

IGroup Interface
HeuristicLab.Charting Namespace


SelectedPrimitives Property

IGroup..::.SelectedPrimitives Property
IGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IGroup.SelectedPrimitives]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ReadOnlyCollection<IPrimitive> SelectedPrimitives { get; }

See Also

IGroup Interface
HeuristicLab.Charting Namespace


IPrimitive Interface

IPrimitive Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.IPrimitive]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IPrimitive

See Also

IPrimitive Members
HeuristicLab.Charting Namespace


IPrimitive Members

[image]

HeuristicLab API Documentation
IPrimitive Members
IPrimitive Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPrimitive type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw |
EnforceUpdate |
GetCursor | Overloaded.
GetToolTipText | Overloaded.
IntoBackground |
IntoForeground |
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown |
OneLayerUp |
PostDraw |
PreDraw |

Properties

Name | Description
Brush |
Chart |
Group |
Pen |
Selected |
Tag |
ToolTipText |
UpdateEnabled |

Events

Name | Description
Update |

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


IPrimitive Methods

[image]

HeuristicLab API Documentation
IPrimitive Methods
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPrimitive type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw |
EnforceUpdate |
GetCursor | Overloaded.
GetToolTipText | Overloaded.
IntoBackground |
IntoForeground |
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown |
OneLayerUp |
PostDraw |
PreDraw |

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
IPrimitive..::.ContainsPoint Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) |
ContainsPoint(Double, Double) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

IPrimitive..::.ContainsPoint Method (PointD)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IPrimitive.ContainsPoint(HeuristicLab.Charting.PointD)]

See Also

IPrimitive Interface
ContainsPoint Overload
HeuristicLab.Charting Namespace


ContainsPoint Method (Double, Double)

IPrimitive..::.ContainsPoint Method (Double, Double)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.ContainsPoint(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool ContainsPoint(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IPrimitive.ContainsPoint(System.Double,System.Double)]

See Also

IPrimitive Interface
ContainsPoint Overload
HeuristicLab.Charting Namespace


Draw Method

IPrimitive..::.Draw Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


EnforceUpdate Method

IPrimitive..::.EnforceUpdate Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.EnforceUpdate]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void EnforceUpdate()

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
IPrimitive..::.GetCursor Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) |
GetCursor(Double, Double) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


GetCursor Method (PointD)

IPrimitive..::.GetCursor Method (PointD)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.GetCursor(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Cursor GetCursor(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IPrimitive.GetCursor(HeuristicLab.Charting.PointD)]

See Also

IPrimitive Interface
GetCursor Overload
HeuristicLab.Charting Namespace


GetCursor Method (Double, Double)

IPrimitive..::.GetCursor Method (Double, Double)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.GetCursor(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Cursor GetCursor(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IPrimitive.GetCursor(System.Double,System.Double)]

See Also

IPrimitive Interface
GetCursor Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
IPrimitive..::.GetToolTipText Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) |
GetToolTipText(Double, Double) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


GetToolTipText Method (PointD)

IPrimitive..::.GetToolTipText Method (PointD)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.GetToolTipText(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string GetToolTipText(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IPrimitive.GetToolTipText(HeuristicLab.Charting.PointD)]

See Also

IPrimitive Interface
GetToolTipText Overload
HeuristicLab.Charting Namespace


GetToolTipText Method (Double, Double)

IPrimitive..::.GetToolTipText Method (Double, Double)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.GetToolTipText(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string GetToolTipText(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.IPrimitive.GetToolTipText(System.Double,System.Double)]

See Also

IPrimitive Interface
GetToolTipText Overload
HeuristicLab.Charting Namespace


IntoBackground Method

IPrimitive..::.IntoBackground Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.IntoBackground]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void IntoBackground()

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


IntoForeground Method

IPrimitive..::.IntoForeground Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.IntoForeground]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void IntoForeground()

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
IPrimitive..::.MouseClick Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) |
MouseClick(Double, Double, MouseButtons) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


MouseClick Method (PointD, MouseButtons)

IPrimitive..::.MouseClick Method (PointD, MouseButtons)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseClick(HeuristicLab.Charting.PointD,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseClick(
    PointD point,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IPrimitive Interface
MouseClick Overload
HeuristicLab.Charting Namespace


MouseClick Method (Double, Double, MouseButtons)

IPrimitive..::.MouseClick Method (Double, Double, MouseButtons)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseClick(System.Double,System.Double,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseClick(
    double x,
    double y,
    MouseButtons button
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IPrimitive Interface
MouseClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
IPrimitive..::.MouseDoubleClick Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) |
MouseDoubleClick(Double, Double, MouseButtons) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method (PointD, MouseButtons)

IPrimitive..::.MouseDoubleClick Method (PointD, MouseButtons)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseDoubleClick(HeuristicLab.Charting.PointD,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDoubleClick(
    PointD point,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IPrimitive Interface
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method (Double, Double, MouseButtons)

IPrimitive..::.MouseDoubleClick Method (Double, Double, MouseButtons)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseDoubleClick(System.Double,System.Double,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDoubleClick(
    double x,
    double y,
    MouseButtons button
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IPrimitive Interface
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
IPrimitive..::.MouseDrag Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) |
MouseDrag(Double, Double, Double, Double, MouseButtons) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


MouseDrag Method (PointD, Offset, MouseButtons)

IPrimitive..::.MouseDrag Method (PointD, Offset, MouseButtons)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseDrag(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDrag(
    PointD point,
    Offset offset,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IPrimitive Interface
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseDrag Method (Double, Double, Double, Double, MouseButtons)

IPrimitive..::.MouseDrag Method (Double, Double, Double, Double, MouseButtons)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseDrag(System.Double,System.Double,System.Double,System.Double,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseDrag(
    double x,
    double y,
    double dx,
    double dy,
    MouseButtons button
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

See Also

IPrimitive Interface
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
IPrimitive..::.MouseMove Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) |
MouseMove(Double, Double, Double, Double) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


MouseMove Method (PointD, Offset)

IPrimitive..::.MouseMove Method (PointD, Offset)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseMove(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseMove(
    PointD point,
    Offset offset
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

See Also

IPrimitive Interface
MouseMove Overload
HeuristicLab.Charting Namespace


MouseMove Method (Double, Double, Double, Double)

IPrimitive..::.MouseMove Method (Double, Double, Double, Double)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.MouseMove(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void MouseMove(
    double x,
    double y,
    double dx,
    double dy
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

See Also

IPrimitive Interface
MouseMove Overload
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
IPrimitive..::.Move Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) |
Move(Double, Double) |

See Also

IPrimitive Interface
IPrimitive Members
HeuristicLab.Charting Namespace


Move Method (Offset)

IPrimitive..::.Move Method (Offset)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

See Also

IPrimitive Interface
Move Overload
HeuristicLab.Charting Namespace


Move Method (Double, Double)

IPrimitive..::.Move Method (Double, Double)
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.Move(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Move(
    double dx,
    double dy
)

Parameters

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

See Also

IPrimitive Interface
Move Overload
HeuristicLab.Charting Namespace


OneLayerDown Method

IPrimitive..::.OneLayerDown Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.OneLayerDown]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OneLayerDown()

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


OneLayerUp Method

IPrimitive..::.OneLayerUp Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.OneLayerUp]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OneLayerUp()

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


PostDraw Method

IPrimitive..::.PostDraw Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.PostDraw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void PostDraw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


PreDraw Method

IPrimitive..::.PreDraw Method
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.IPrimitive.PreDraw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void PreDraw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


IPrimitive Properties

[image]

HeuristicLab API Documentation
IPrimitive Properties
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPrimitive type exposes the following members.

Properties

Name | Description
Brush |
Chart |
Group |
Pen |
Selected |
Tag |
ToolTipText |
UpdateEnabled |

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Brush Property

IPrimitive..::.Brush Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.Brush]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Brush Brush { get; set; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Chart Property

IPrimitive..::.Chart Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.Chart]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IChart Chart { get; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Group Property

IPrimitive..::.Group Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.Group]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IGroup Group { get; set; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Pen Property

IPrimitive..::.Pen Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.Pen]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Pen Pen { get; set; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Selected Property

IPrimitive..::.Selected Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.Selected]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Selected { get; set; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Tag Property

IPrimitive..::.Tag Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.Tag]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Object Tag { get; set; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


ToolTipText Property

IPrimitive..::.ToolTipText Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.ToolTipText]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string ToolTipText { get; set; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


UpdateEnabled Property

IPrimitive..::.UpdateEnabled Property
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.IPrimitive.UpdateEnabled]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool UpdateEnabled { get; }

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


IPrimitive Events

[image]

HeuristicLab API Documentation
IPrimitive Events
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPrimitive type exposes the following members.

Events

Name | Description
Update |

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Update Event

IPrimitive..::.Update Event
IPrimitive Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Charting.IPrimitive.Update]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Update

See Also

IPrimitive Interface
HeuristicLab.Charting Namespace


Line Class

Line Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Line]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Line : LinearPrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.LinearPrimitiveBase
HeuristicLab.Charting..::.Line

See Also

Line Members
HeuristicLab.Charting Namespace


Line Members

[image]

HeuristicLab API Documentation
Line Members
Line Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Line type exposes the following members.

Constructors

Name | Description
Line | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from LinearPrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
selectionRectangles | (Inherited from LinearPrimitiveBase.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
End | (Inherited from LinearPrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Length | (Inherited from LinearPrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size | (Inherited from LinearPrimitiveBase.)
Start | (Inherited from LinearPrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

Line Class
HeuristicLab.Charting Namespace


Line Constructor

[image]

HeuristicLab API Documentation
Line Constructor
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Line(IChart, PointD, PointD) |
Line(IChart, PointD, PointD, Pen) |
Line(IChart, Double, Double, Double, Double) |
Line(IChart, Double, Double, Double, Double, Pen) |

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


Line Constructor (IChart, PointD, PointD)

Line Constructor (IChart, PointD, PointD)
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Line class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Line(
    IChart chart,
    PointD start,
    PointD end
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

start
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "start"]

end
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "end"]

See Also

Line Class
Line Overload
HeuristicLab.Charting Namespace


Line Constructor (IChart, PointD, PointD, Pen)

Line Constructor (IChart, PointD, PointD, Pen)
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Line class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Line(
    IChart chart,
    PointD start,
    PointD end,
    Pen pen
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

start
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "start"]

end
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "end"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

See Also

Line Class
Line Overload
HeuristicLab.Charting Namespace


Line Constructor (IChart, Double, Double, Double, Double)

Line Constructor (IChart, Double, Double, Double, Double)
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Line class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Line(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

Line Class
Line Overload
HeuristicLab.Charting Namespace


Line Constructor (IChart, Double, Double, Double, Double, Pen)

Line Constructor (IChart, Double, Double, Double, Double, Pen)
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Line class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Line(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2,
    Pen pen
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

See Also

Line Class
Line Overload
HeuristicLab.Charting Namespace


Line Methods

[image]

HeuristicLab API Documentation
Line Methods
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Line type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from LinearPrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
Line..::.ContainsPoint Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides LinearPrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

Line..::.ContainsPoint Method (PointD)
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Line.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Line.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

Line Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


Draw Method

Line..::.Draw Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Line.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

Line Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Line..::.GetCursor Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from LinearPrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Line..::.GetToolTipText Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Line..::.MouseClick Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Line..::.MouseDoubleClick Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Line..::.MouseDrag Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from LinearPrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Line..::.MouseMove Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
Line..::.Move Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from LinearPrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
Line..::.SetPosition Method
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) | (Inherited from LinearPrimitiveBase.)
SetPosition(Double, Double, Double, Double) | (Inherited from LinearPrimitiveBase.)

See Also

Line Class
Line Members
HeuristicLab.Charting Namespace


LinearPrimitiveBase Class

LinearPrimitiveBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.LinearPrimitiveBase]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class LinearPrimitiveBase : PrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.LinearPrimitiveBase
HeuristicLab.Charting..::.Line

See Also

LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


LinearPrimitiveBase Members

[image]

HeuristicLab API Documentation
LinearPrimitiveBase Members
LinearPrimitiveBase Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearPrimitiveBase type exposes the following members.

Constructors

Name | Description
LinearPrimitiveBase | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Overrides PrimitiveBase ..::. PostDraw(Graphics).)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
selectionRectangles |

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
End |
Group | (Inherited from PrimitiveBase.)
Length |
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size |
Start |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


LinearPrimitiveBase Constructor

[image]

HeuristicLab API Documentation
LinearPrimitiveBase Constructor
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LinearPrimitiveBase(IChart, PointD, PointD) |
LinearPrimitiveBase(IChart, PointD, PointD, Pen, Brush) |
LinearPrimitiveBase(IChart, Double, Double, Double, Double) |
LinearPrimitiveBase(IChart, Double, Double, Double, Double, Pen, Brush) |

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


LinearPrimitiveBase Constructor (IChart, PointD, PointD)

LinearPrimitiveBase Constructor (IChart, PointD, PointD)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinearPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected LinearPrimitiveBase(
    IChart chart,
    PointD start,
    PointD end
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

start
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "start"]

end
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "end"]

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Overload
HeuristicLab.Charting Namespace


LinearPrimitiveBase Constructor (IChart, PointD, PointD, Pen, Brush)

LinearPrimitiveBase Constructor (IChart, PointD, PointD, Pen, Brush)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinearPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected LinearPrimitiveBase(
    IChart chart,
    PointD start,
    PointD end,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

start
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "start"]

end
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "end"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Overload
HeuristicLab.Charting Namespace


LinearPrimitiveBase Constructor (IChart, Double, Double, Double, Double)

LinearPrimitiveBase Constructor (IChart, Double, Double, Double, Double)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinearPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected LinearPrimitiveBase(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Overload
HeuristicLab.Charting Namespace


LinearPrimitiveBase Constructor (IChart, Double, Double, Double, Double, Pen, Brush)

LinearPrimitiveBase Constructor (IChart, Double, Double, Double, Double, Pen, Brush)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinearPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected LinearPrimitiveBase(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Overload
HeuristicLab.Charting Namespace


LinearPrimitiveBase Fields

[image]

HeuristicLab API Documentation
LinearPrimitiveBase Fields
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearPrimitiveBase type exposes the following members.

Fields

Name | Description
selectionRectangles |

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


selectionRectangles Field

LinearPrimitiveBase..::.selectionRectangles Field
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.LinearPrimitiveBase.selectionRectangles]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected IGroup selectionRectangles

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


LinearPrimitiveBase Methods

[image]

HeuristicLab API Documentation
LinearPrimitiveBase Methods
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearPrimitiveBase type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Overrides PrimitiveBase ..::. PostDraw(Graphics).)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.ContainsPoint Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides PrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

LinearPrimitiveBase..::.ContainsPoint Method (PointD)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

LinearPrimitiveBase Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.GetCursor Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Overrides PrimitiveBase ..::. GetCursor(PointD).)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


GetCursor Method (PointD)

LinearPrimitiveBase..::.GetCursor Method (PointD)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.GetCursor(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Cursor GetCursor(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.GetCursor(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetCursor(PointD)

See Also

LinearPrimitiveBase Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.GetToolTipText Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.MouseClick Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.MouseDoubleClick Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.MouseDrag Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Overrides PrimitiveBase ..::. MouseDrag(PointD, Offset, MouseButtons).)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method (PointD, Offset, MouseButtons)

LinearPrimitiveBase..::.MouseDrag Method (PointD, Offset, MouseButtons)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.MouseDrag(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void MouseDrag(
    PointD point,
    Offset offset,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseDrag(PointD, Offset, MouseButtons)

See Also

LinearPrimitiveBase Class
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.MouseMove Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.Move Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Overrides PrimitiveBase ..::. Move(Offset).)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method (Offset)

LinearPrimitiveBase..::.Move Method (Offset)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IPrimitive..::.Move(Offset)

See Also

LinearPrimitiveBase Class
Move Overload
HeuristicLab.Charting Namespace


PostDraw Method

LinearPrimitiveBase..::.PostDraw Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.PostDraw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void PostDraw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.PostDraw(Graphics)

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
LinearPrimitiveBase..::.SetPosition Method
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) |
SetPosition(Double, Double, Double, Double) |

See Also

LinearPrimitiveBase Class
LinearPrimitiveBase Members
HeuristicLab.Charting Namespace


SetPosition Method (PointD, PointD)

LinearPrimitiveBase..::.SetPosition Method (PointD, PointD)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.SetPosition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void SetPosition(
    PointD start,
    PointD end
)

Parameters

start
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "start"]

end
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "end"]

See Also

LinearPrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


SetPosition Method (Double, Double, Double, Double)

LinearPrimitiveBase..::.SetPosition Method (Double, Double, Double, Double)
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.LinearPrimitiveBase.SetPosition(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetPosition(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

LinearPrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


LinearPrimitiveBase Properties

[image]

HeuristicLab API Documentation
LinearPrimitiveBase Properties
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearPrimitiveBase type exposes the following members.

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
End |
Group | (Inherited from PrimitiveBase.)
Length |
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size |
Start |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


End Property

LinearPrimitiveBase..::.End Property
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.LinearPrimitiveBase.End]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD End { get; }

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


Length Property

LinearPrimitiveBase..::.Length Property
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.LinearPrimitiveBase.Length]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual double Length { get; }

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


Size Property

LinearPrimitiveBase..::.Size Property
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.LinearPrimitiveBase.Size]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual SizeD Size { get; }

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


Start Property

LinearPrimitiveBase..::.Start Property
LinearPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.LinearPrimitiveBase.Start]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD Start { get; }

See Also

LinearPrimitiveBase Class
HeuristicLab.Charting Namespace


Offset Structure

Offset Structure
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Offset]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public struct Offset

See Also

Offset Members
HeuristicLab.Charting Namespace


Offset Members

[image]

HeuristicLab API Documentation
Offset Members
Offset Structure Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Offset type exposes the following members.

Constructors

Name | Description
Offset | Overloaded.

Methods

Name | Description
Add |
Equals | (Overrides ValueType ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Subtract |
ToString | (Overrides ValueType ..::. ToString()()().)

Operators

Name | Description
Addition |
Equality |
Explicit | Overloaded.
Inequality |
Subtraction |

Fields

Name | Description
Empty |

Properties

Name | Description
DX |
DY |
IsEmpty |
Length |

See Also

Offset Structure
HeuristicLab.Charting Namespace


Offset Constructor

[image]

HeuristicLab API Documentation
Offset Constructor
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Offset(PointD) |
Offset(SizeD) |
Offset(Double, Double) |

See Also

Offset Structure
Offset Members
HeuristicLab.Charting Namespace


Offset Constructor (PointD)

Offset Constructor (PointD)
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Offset class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Offset(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

See Also

Offset Structure
Offset Overload
HeuristicLab.Charting Namespace


Offset Constructor (SizeD)

Offset Constructor (SizeD)
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Offset class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Offset(
    SizeD size
)

Parameters

size
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size"]

See Also

Offset Structure
Offset Overload
HeuristicLab.Charting Namespace


Offset Constructor (Double, Double)

Offset Constructor (Double, Double)
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Offset class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Offset(
    double dx,
    double dy
)

Parameters

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

See Also

Offset Structure
Offset Overload
HeuristicLab.Charting Namespace


Offset Fields

[image]

HeuristicLab API Documentation
Offset Fields
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Offset type exposes the following members.

Fields

Name | Description
Empty |

See Also

Offset Structure
HeuristicLab.Charting Namespace


Empty Field

Offset..::.Empty Field
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.Offset.Empty]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static readonly Offset Empty

See Also

Offset Structure
HeuristicLab.Charting Namespace


Offset Methods

[image]

HeuristicLab API Documentation
Offset Methods
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Offset type exposes the following members.

Methods

Name | Description
Add |
Equals | (Overrides ValueType ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Subtract |
ToString | (Overrides ValueType ..::. ToString()()().)

Operators

Name | Description
Addition |
Equality |
Explicit | Overloaded.
Inequality |
Subtraction |

See Also

Offset Structure
HeuristicLab.Charting Namespace


Add Method

Offset..::.Add Method
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.Add(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Offset Add(
    Offset offset1,
    Offset offset2
)

Parameters

offset1
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset1"]

offset2
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.Add(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Addition Operator

Offset..::.Addition Operator
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.op_Addition(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Offset operator +(
    Offset offset1,
    Offset offset2
)

Parameters

offset1
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset1"]

offset2
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.op_Addition(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Equality Operator

Offset..::.Equality Operator
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.op_Equality(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool operator ==(
    Offset offset1,
    Offset offset2
)

Parameters

offset1
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset1"]

offset2
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.op_Equality(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Equals Method

Offset..::.Equals Method
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.Equals(System.Object)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.Equals(System.Object)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Explicit Method

[image]

HeuristicLab API Documentation
Offset..::.Explicit Method
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Explicit(Offset) |
Explicit(Offset) |

See Also

Offset Structure
Offset Members
HeuristicLab.Charting Namespace


Explicit Operator

Offset..::.Explicit Operator
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.op_Explicit(HeuristicLab.Charting.Offset)~HeuristicLab.Charting.SizeD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static explicit operator SizeD (
    Offset offset
)

Parameters

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.op_Explicit(HeuristicLab.Charting.Offset)~HeuristicLab.Charting.SizeD]

See Also

Offset Structure
Explicit Overload
HeuristicLab.Charting Namespace


Explicit Operator

Offset..::.Explicit Operator
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.op_Explicit(HeuristicLab.Charting.Offset)~HeuristicLab.Charting.PointD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static explicit operator PointD (
    Offset offset
)

Parameters

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.op_Explicit(HeuristicLab.Charting.Offset)~HeuristicLab.Charting.PointD]

See Also

Offset Structure
Explicit Overload
HeuristicLab.Charting Namespace


GetHashCode Method

Offset..::.GetHashCode Method
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.GetHashCode]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override int GetHashCode()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.GetHashCode]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Inequality Operator

Offset..::.Inequality Operator
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.op_Inequality(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool operator !=(
    Offset offset1,
    Offset offset2
)

Parameters

offset1
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset1"]

offset2
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.op_Inequality(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Subtract Method

Offset..::.Subtract Method
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.Subtract(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Offset Subtract(
    Offset offset1,
    Offset offset2
)

Parameters

offset1
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset1"]

offset2
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.Subtract(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Subtraction Operator

Offset..::.Subtraction Operator
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.op_Subtraction(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Offset operator -(
    Offset offset1,
    Offset offset2
)

Parameters

offset1
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset1"]

offset2
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.op_Subtraction(HeuristicLab.Charting.Offset,HeuristicLab.Charting.Offset)]

See Also

Offset Structure
HeuristicLab.Charting Namespace


ToString Method

Offset..::.ToString Method
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Offset.ToString]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Offset.ToString]

See Also

Offset Structure
HeuristicLab.Charting Namespace


Offset Properties

[image]

HeuristicLab API Documentation
Offset Properties
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Offset type exposes the following members.

Properties

Name | Description
DX |
DY |
IsEmpty |
Length |

See Also

Offset Structure
HeuristicLab.Charting Namespace


DX Property

Offset..::.DX Property
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Offset.DX]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double DX { get; set; }

See Also

Offset Structure
HeuristicLab.Charting Namespace


DY Property

Offset..::.DY Property
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Offset.DY]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double DY { get; set; }

See Also

Offset Structure
HeuristicLab.Charting Namespace


IsEmpty Property

Offset..::.IsEmpty Property
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Offset.IsEmpty]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsEmpty { get; }

See Also

Offset Structure
HeuristicLab.Charting Namespace


Length Property

Offset..::.Length Property
Offset Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Offset.Length]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Length { get; }

See Also

Offset Structure
HeuristicLab.Charting Namespace


PointD Structure

PointD Structure
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.PointD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public struct PointD

See Also

PointD Members
HeuristicLab.Charting Namespace


PointD Members

[image]

HeuristicLab API Documentation
PointD Members
PointD Structure Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PointD type exposes the following members.

Constructors

Name | Description
PointD | Overloaded.

Methods

Name | Description
Add |
Equals | (Overrides ValueType ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Subtract |
ToString | (Overrides ValueType ..::. ToString()()().)

Operators

Name | Description
Addition | Overloaded.
Equality |
Explicit | Overloaded.
Implicit | Overloaded.
Inequality |
Subtraction | Overloaded.

Fields

Name | Description
Empty |

Properties

Name | Description
IsEmpty |
X |
Y |

See Also

PointD Structure
HeuristicLab.Charting Namespace


PointD Constructor

[image]

HeuristicLab API Documentation
PointD Constructor
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PointD(Offset) |
PointD(SizeD) |
PointD(Double, Double) |

See Also

PointD Structure
PointD Members
HeuristicLab.Charting Namespace


PointD Constructor (Offset)

PointD Constructor (Offset)
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PointD class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PointD(
    Offset offset
)

Parameters

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

See Also

PointD Structure
PointD Overload
HeuristicLab.Charting Namespace


PointD Constructor (SizeD)

PointD Constructor (SizeD)
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PointD class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PointD(
    SizeD size
)

Parameters

size
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size"]

See Also

PointD Structure
PointD Overload
HeuristicLab.Charting Namespace


PointD Constructor (Double, Double)

PointD Constructor (Double, Double)
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PointD class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PointD(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

See Also

PointD Structure
PointD Overload
HeuristicLab.Charting Namespace


PointD Fields

[image]

HeuristicLab API Documentation
PointD Fields
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PointD type exposes the following members.

Fields

Name | Description
Empty |

See Also

PointD Structure
HeuristicLab.Charting Namespace


Empty Field

PointD..::.Empty Field
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.PointD.Empty]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static readonly PointD Empty

See Also

PointD Structure
HeuristicLab.Charting Namespace


PointD Methods

[image]

HeuristicLab API Documentation
PointD Methods
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PointD type exposes the following members.

Methods

Name | Description
Add |
Equals | (Overrides ValueType ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Subtract |
ToString | (Overrides ValueType ..::. ToString()()().)

Operators

Name | Description
Addition | Overloaded.
Equality |
Explicit | Overloaded.
Implicit | Overloaded.
Inequality |
Subtraction | Overloaded.

See Also

PointD Structure
HeuristicLab.Charting Namespace


Add Method

PointD..::.Add Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.Add(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static PointD Add(
    PointD point,
    Offset offset
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.Add(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

See Also

PointD Structure
HeuristicLab.Charting Namespace


Addition Method

[image]

HeuristicLab API Documentation
PointD..::.Addition Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Addition(PointD, Offset) |
Addition(PointD, PointD) |

See Also

PointD Structure
PointD Members
HeuristicLab.Charting Namespace


Addition Operator

PointD..::.Addition Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Addition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static PointD operator +(
    PointD point,
    Offset offset
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Addition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

See Also

PointD Structure
Addition Overload
HeuristicLab.Charting Namespace


Addition Operator

PointD..::.Addition Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Addition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Offset operator +(
    PointD point1,
    PointD point2
)

Parameters

point1
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point1"]

point2
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Addition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

See Also

PointD Structure
Addition Overload
HeuristicLab.Charting Namespace


Equality Operator

PointD..::.Equality Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Equality(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool operator ==(
    PointD point1,
    PointD point2
)

Parameters

point1
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point1"]

point2
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Equality(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

See Also

PointD Structure
HeuristicLab.Charting Namespace


Equals Method

PointD..::.Equals Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.Equals(System.Object)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.Equals(System.Object)]

See Also

PointD Structure
HeuristicLab.Charting Namespace


Explicit Method

[image]

HeuristicLab API Documentation
PointD..::.Explicit Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Explicit(PointD) |
Explicit(PointD) |

See Also

PointD Structure
PointD Members
HeuristicLab.Charting Namespace


Explicit Operator

PointD..::.Explicit Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Explicit(HeuristicLab.Charting.PointD)~HeuristicLab.Charting.Offset]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static explicit operator Offset (
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Explicit(HeuristicLab.Charting.PointD)~HeuristicLab.Charting.Offset]

See Also

PointD Structure
Explicit Overload
HeuristicLab.Charting Namespace


Explicit Operator

PointD..::.Explicit Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Explicit(HeuristicLab.Charting.PointD)~HeuristicLab.Charting.SizeD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static explicit operator SizeD (
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Explicit(HeuristicLab.Charting.PointD)~HeuristicLab.Charting.SizeD]

See Also

PointD Structure
Explicit Overload
HeuristicLab.Charting Namespace


GetHashCode Method

PointD..::.GetHashCode Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.GetHashCode]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override int GetHashCode()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.GetHashCode]

See Also

PointD Structure
HeuristicLab.Charting Namespace


Implicit Method

[image]

HeuristicLab API Documentation
PointD..::.Implicit Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Implicit(Point) |
Implicit(PointF) |

See Also

PointD Structure
PointD Members
HeuristicLab.Charting Namespace


Implicit Operator

PointD..::.Implicit Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Implicit(System.Drawing.Point)~HeuristicLab.Charting.PointD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static implicit operator PointD (
    Point point
)

Parameters

point
Type: System.Drawing..::.Point

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Implicit(System.Drawing.Point)~HeuristicLab.Charting.PointD]

See Also

PointD Structure
Implicit Overload
HeuristicLab.Charting Namespace


Implicit Operator

PointD..::.Implicit Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Implicit(System.Drawing.PointF)~HeuristicLab.Charting.PointD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static implicit operator PointD (
    PointF point
)

Parameters

point
Type: System.Drawing..::.PointF

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Implicit(System.Drawing.PointF)~HeuristicLab.Charting.PointD]

See Also

PointD Structure
Implicit Overload
HeuristicLab.Charting Namespace


Inequality Operator

PointD..::.Inequality Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Inequality(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool operator !=(
    PointD point1,
    PointD point2
)

Parameters

point1
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point1"]

point2
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Inequality(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

See Also

PointD Structure
HeuristicLab.Charting Namespace


Subtract Method

PointD..::.Subtract Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.Subtract(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static PointD Subtract(
    PointD point,
    Offset offset
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.Subtract(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

See Also

PointD Structure
HeuristicLab.Charting Namespace


Subtraction Method

[image]

HeuristicLab API Documentation
PointD..::.Subtraction Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Subtraction(PointD, Offset) |
Subtraction(PointD, PointD) |

See Also

PointD Structure
PointD Members
HeuristicLab.Charting Namespace


Subtraction Operator

PointD..::.Subtraction Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Subtraction(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static PointD operator -(
    PointD point,
    Offset offset
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Subtraction(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

See Also

PointD Structure
Subtraction Overload
HeuristicLab.Charting Namespace


Subtraction Operator

PointD..::.Subtraction Operator
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.op_Subtraction(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Offset operator -(
    PointD point1,
    PointD point2
)

Parameters

point1
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point1"]

point2
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.op_Subtraction(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

See Also

PointD Structure
Subtraction Overload
HeuristicLab.Charting Namespace


ToString Method

PointD..::.ToString Method
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PointD.ToString]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PointD.ToString]

See Also

PointD Structure
HeuristicLab.Charting Namespace


PointD Properties

[image]

HeuristicLab API Documentation
PointD Properties
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PointD type exposes the following members.

Properties

Name | Description
IsEmpty |
X |
Y |

See Also

PointD Structure
HeuristicLab.Charting Namespace


IsEmpty Property

PointD..::.IsEmpty Property
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PointD.IsEmpty]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsEmpty { get; }

See Also

PointD Structure
HeuristicLab.Charting Namespace


X Property

PointD..::.X Property
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PointD.X]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double X { get; set; }

See Also

PointD Structure
HeuristicLab.Charting Namespace


Y Property

PointD..::.Y Property
PointD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PointD.Y]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Y { get; set; }

See Also

PointD Structure
HeuristicLab.Charting Namespace


PrimitiveBase Class

PrimitiveBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.PrimitiveBase]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class PrimitiveBase : IPrimitive

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.RectangularPrimitiveBase
HeuristicLab.Charting..::.LinearPrimitiveBase
HeuristicLab.Charting..::.FixedSizePrimitiveBase
HeuristicLab.Charting..::.Group
HeuristicLab.Charting..::.AxisPrimitiveBase

See Also

PrimitiveBase Members
HeuristicLab.Charting Namespace


PrimitiveBase Members

[image]

HeuristicLab API Documentation
PrimitiveBase Members
PrimitiveBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PrimitiveBase type exposes the following members.

Constructors

Name | Description
PrimitiveBase | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw |
EnforceUpdate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground |
IntoForeground |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown |
OneLayerUp |
OnUpdate |
PostDraw |
PreDraw |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Brush |
Chart |
Group |
Pen |
Selected |
Tag |
ToolTipText |
UpdateEnabled |

Events

Name | Description
Update |

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


PrimitiveBase Constructor

[image]

HeuristicLab API Documentation
PrimitiveBase Constructor
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PrimitiveBase(IChart) |
PrimitiveBase(IChart, Pen, Brush) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


PrimitiveBase Constructor (IChart)

PrimitiveBase Constructor (IChart)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected PrimitiveBase(
    IChart chart
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

See Also

PrimitiveBase Class
PrimitiveBase Overload
HeuristicLab.Charting Namespace


PrimitiveBase Constructor (IChart, Pen, Brush)

PrimitiveBase Constructor (IChart, Pen, Brush)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected PrimitiveBase(
    IChart chart,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

PrimitiveBase Class
PrimitiveBase Overload
HeuristicLab.Charting Namespace


PrimitiveBase Methods

[image]

HeuristicLab API Documentation
PrimitiveBase Methods
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PrimitiveBase type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw |
EnforceUpdate |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground |
IntoForeground |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown |
OneLayerUp |
OnUpdate |
PostDraw |
PreDraw |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.ContainsPoint Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) |
ContainsPoint(Double, Double) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

PrimitiveBase..::.ContainsPoint Method (PointD)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

PrimitiveBase Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


ContainsPoint Method (Double, Double)

PrimitiveBase..::.ContainsPoint Method (Double, Double)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.ContainsPoint(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool ContainsPoint(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PrimitiveBase.ContainsPoint(System.Double,System.Double)]

Implements

IPrimitive..::.ContainsPoint(Double, Double)

See Also

PrimitiveBase Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


Draw Method

PrimitiveBase..::.Draw Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


EnforceUpdate Method

PrimitiveBase..::.EnforceUpdate Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.EnforceUpdate]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void EnforceUpdate()

Implements

IPrimitive..::.EnforceUpdate()()()

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.GetCursor Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) |
GetCursor(Double, Double) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


GetCursor Method (PointD)

PrimitiveBase..::.GetCursor Method (PointD)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetCursor(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Cursor GetCursor(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetCursor(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetCursor(PointD)

See Also

PrimitiveBase Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetCursor Method (Double, Double)

PrimitiveBase..::.GetCursor Method (Double, Double)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetCursor(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Cursor GetCursor(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetCursor(System.Double,System.Double)]

Implements

IPrimitive..::.GetCursor(Double, Double)

See Also

PrimitiveBase Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.GetToolTipText Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) |
GetToolTipText(Double, Double) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


GetToolTipText Method (PointD)

PrimitiveBase..::.GetToolTipText Method (PointD)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetToolTipText(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual string GetToolTipText(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetToolTipText(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetToolTipText(PointD)

See Also

PrimitiveBase Class
GetToolTipText Overload
HeuristicLab.Charting Namespace


GetToolTipText Method (Double, Double)

PrimitiveBase..::.GetToolTipText Method (Double, Double)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetToolTipText(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string GetToolTipText(
    double x,
    double y
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.PrimitiveBase.GetToolTipText(System.Double,System.Double)]

Implements

IPrimitive..::.GetToolTipText(Double, Double)

See Also

PrimitiveBase Class
GetToolTipText Overload
HeuristicLab.Charting Namespace


IntoBackground Method

PrimitiveBase..::.IntoBackground Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.IntoBackground]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void IntoBackground()

Implements

IPrimitive..::.IntoBackground()()()

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


IntoForeground Method

PrimitiveBase..::.IntoForeground Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.IntoForeground]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void IntoForeground()

Implements

IPrimitive..::.IntoForeground()()()

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.MouseClick Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) |
MouseClick(Double, Double, MouseButtons) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


MouseClick Method (PointD, MouseButtons)

PrimitiveBase..::.MouseClick Method (PointD, MouseButtons)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseClick(HeuristicLab.Charting.PointD,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseClick(
    PointD point,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseClick(PointD, MouseButtons)

See Also

PrimitiveBase Class
MouseClick Overload
HeuristicLab.Charting Namespace


MouseClick Method (Double, Double, MouseButtons)

PrimitiveBase..::.MouseClick Method (Double, Double, MouseButtons)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseClick(System.Double,System.Double,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseClick(
    double x,
    double y,
    MouseButtons button
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseClick(Double, Double, MouseButtons)

See Also

PrimitiveBase Class
MouseClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.MouseDoubleClick Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) |
MouseDoubleClick(Double, Double, MouseButtons) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method (PointD, MouseButtons)

PrimitiveBase..::.MouseDoubleClick Method (PointD, MouseButtons)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseDoubleClick(HeuristicLab.Charting.PointD,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseDoubleClick(
    PointD point,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseDoubleClick(PointD, MouseButtons)

See Also

PrimitiveBase Class
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDoubleClick Method (Double, Double, MouseButtons)

PrimitiveBase..::.MouseDoubleClick Method (Double, Double, MouseButtons)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseDoubleClick(System.Double,System.Double,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseDoubleClick(
    double x,
    double y,
    MouseButtons button
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseDoubleClick(Double, Double, MouseButtons)

See Also

PrimitiveBase Class
MouseDoubleClick Overload
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.MouseDrag Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) |
MouseDrag(Double, Double, Double, Double, MouseButtons) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method (PointD, Offset, MouseButtons)

PrimitiveBase..::.MouseDrag Method (PointD, Offset, MouseButtons)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseDrag(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseDrag(
    PointD point,
    Offset offset,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseDrag(PointD, Offset, MouseButtons)

See Also

PrimitiveBase Class
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseDrag Method (Double, Double, Double, Double, MouseButtons)

PrimitiveBase..::.MouseDrag Method (Double, Double, Double, Double, MouseButtons)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseDrag(System.Double,System.Double,System.Double,System.Double,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseDrag(
    double x,
    double y,
    double dx,
    double dy,
    MouseButtons button
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseDrag(Double, Double, Double, Double, MouseButtons)

See Also

PrimitiveBase Class
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.MouseMove Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) |
MouseMove(Double, Double, Double, Double) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


MouseMove Method (PointD, Offset)

PrimitiveBase..::.MouseMove Method (PointD, Offset)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseMove(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void MouseMove(
    PointD point,
    Offset offset
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

Implements

IPrimitive..::.MouseMove(PointD, Offset)

See Also

PrimitiveBase Class
MouseMove Overload
HeuristicLab.Charting Namespace


MouseMove Method (Double, Double, Double, Double)

PrimitiveBase..::.MouseMove Method (Double, Double, Double, Double)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.MouseMove(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void MouseMove(
    double x,
    double y,
    double dx,
    double dy
)

Parameters

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

Implements

IPrimitive..::.MouseMove(Double, Double, Double, Double)

See Also

PrimitiveBase Class
MouseMove Overload
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
PrimitiveBase..::.Move Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) |
Move(Double, Double) |

See Also

PrimitiveBase Class
PrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method (Offset)

PrimitiveBase..::.Move Method (Offset)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IPrimitive..::.Move(Offset)

See Also

PrimitiveBase Class
Move Overload
HeuristicLab.Charting Namespace


Move Method (Double, Double)

PrimitiveBase..::.Move Method (Double, Double)
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.Move(System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Move(
    double dx,
    double dy
)

Parameters

dx
Type: System..::.Double

[Missing <param> documentation for "dx"]

dy
Type: System..::.Double

[Missing <param> documentation for "dy"]

Implements

IPrimitive..::.Move(Double, Double)

See Also

PrimitiveBase Class
Move Overload
HeuristicLab.Charting Namespace


OneLayerDown Method

PrimitiveBase..::.OneLayerDown Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.OneLayerDown]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OneLayerDown()

Implements

IPrimitive..::.OneLayerDown()()()

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


OneLayerUp Method

PrimitiveBase..::.OneLayerUp Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.OneLayerUp]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OneLayerUp()

Implements

IPrimitive..::.OneLayerUp()()()

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


OnUpdate Method

PrimitiveBase..::.OnUpdate Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.OnUpdate]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnUpdate()

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


PostDraw Method

PrimitiveBase..::.PostDraw Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.PostDraw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void PostDraw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.PostDraw(Graphics)

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


PreDraw Method

PrimitiveBase..::.PreDraw Method
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.PrimitiveBase.PreDraw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void PreDraw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.PreDraw(Graphics)

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


PrimitiveBase Properties

[image]

HeuristicLab API Documentation
PrimitiveBase Properties
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PrimitiveBase type exposes the following members.

Properties

Name | Description
Brush |
Chart |
Group |
Pen |
Selected |
Tag |
ToolTipText |
UpdateEnabled |

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Brush Property

PrimitiveBase..::.Brush Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.Brush]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Brush Brush { get; set; }

Implements

IPrimitive..::.Brush

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Chart Property

PrimitiveBase..::.Chart Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.Chart]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IChart Chart { get; }

Implements

IPrimitive..::.Chart

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Group Property

PrimitiveBase..::.Group Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.Group]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IGroup Group { get; set; }

Implements

IPrimitive..::.Group

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Pen Property

PrimitiveBase..::.Pen Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.Pen]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Pen Pen { get; set; }

Implements

IPrimitive..::.Pen

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Selected Property

PrimitiveBase..::.Selected Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.Selected]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool Selected { get; set; }

Implements

IPrimitive..::.Selected

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Tag Property

PrimitiveBase..::.Tag Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.Tag]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Object Tag { get; set; }

Implements

IPrimitive..::.Tag

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


ToolTipText Property

PrimitiveBase..::.ToolTipText Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.ToolTipText]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string ToolTipText { get; set; }

Implements

IPrimitive..::.ToolTipText

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


UpdateEnabled Property

PrimitiveBase..::.UpdateEnabled Property
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PrimitiveBase.UpdateEnabled]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool UpdateEnabled { get; set; }

Implements

IPrimitive..::.UpdateEnabled

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


PrimitiveBase Events

[image]

HeuristicLab API Documentation
PrimitiveBase Events
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PrimitiveBase type exposes the following members.

Events

Name | Description
Update |

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


Update Event

PrimitiveBase..::.Update Event
PrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Charting.PrimitiveBase.Update]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Update

Implements

IPrimitive..::.Update

See Also

PrimitiveBase Class
HeuristicLab.Charting Namespace


PropertiesDialog Class

PropertiesDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.PropertiesDialog]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PropertiesDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Charting..::.PropertiesDialog

See Also

PropertiesDialog Members
HeuristicLab.Charting Namespace


PropertiesDialog Members

[image]

HeuristicLab API Documentation
PropertiesDialog Members
PropertiesDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertiesDialog type exposes the following members.

Constructors

Name | Description
PropertiesDialog | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Fields

Name | Description
okButton |
propertyGrid |

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedObject |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


PropertiesDialog Constructor

[image]

HeuristicLab API Documentation
PropertiesDialog Constructor
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PropertiesDialog()()() |
PropertiesDialog(Object) |

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


PropertiesDialog Constructor

PropertiesDialog Constructor
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PropertiesDialog class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PropertiesDialog()

See Also

PropertiesDialog Class
PropertiesDialog Overload
HeuristicLab.Charting Namespace


PropertiesDialog Constructor (Object)

PropertiesDialog Constructor (Object)
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PropertiesDialog class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PropertiesDialog(
    Object selectedObject
)

Parameters

selectedObject
Type: System..::.Object

[Missing <param> documentation for "selectedObject"]

See Also

PropertiesDialog Class
PropertiesDialog Overload
HeuristicLab.Charting Namespace


PropertiesDialog Fields

[image]

HeuristicLab API Documentation
PropertiesDialog Fields
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertiesDialog type exposes the following members.

Fields

Name | Description
okButton |
propertyGrid |

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


okButton Field

PropertiesDialog..::.okButton Field
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.PropertiesDialog.okButton]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button okButton

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


propertyGrid Field

PropertiesDialog..::.propertyGrid Field
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.PropertiesDialog.propertyGrid]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected PropertyGrid propertyGrid

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


PropertiesDialog Methods

[image]

HeuristicLab API Documentation
PropertiesDialog Methods
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertiesDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.AccessibilityNotifyClients Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.BeginInvoke Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Dispose Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Dispose Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Dispose Method (Boolean)

PropertiesDialog..::.Dispose Method (Boolean)
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

PropertiesDialog Class
Dispose Overload
HeuristicLab.Charting Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.GetChildAtPoint Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Invalidate Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Invoke Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Invoke Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.MemberwiseClone Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.PerformLayout Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.ResumeLayout Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.RtlTranslateAlignment Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Scale Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Scale Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Select Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Select Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.SetBounds Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Show Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Show Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.ShowDialog Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.UpdateBounds Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


Validate Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.Validate Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
PropertiesDialog..::.ValidateChildren Method
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PropertiesDialog Class
PropertiesDialog Members
HeuristicLab.Charting Namespace


PropertiesDialog Properties

[image]

HeuristicLab API Documentation
PropertiesDialog Properties
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PropertiesDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedObject |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


SelectedObject Property

PropertiesDialog..::.SelectedObject Property
PropertiesDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.PropertiesDialog.SelectedObject]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Object SelectedObject { get; set; }

See Also

PropertiesDialog Class
HeuristicLab.Charting Namespace


Rectangle Class

Rectangle Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Rectangle]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Rectangle : RectangularPrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.RectangularPrimitiveBase
HeuristicLab.Charting..::.Rectangle

See Also

Rectangle Members
HeuristicLab.Charting Namespace


Rectangle Members

[image]

HeuristicLab API Documentation
Rectangle Members
Rectangle Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Rectangle type exposes the following members.

Constructors

Name | Description
Rectangle | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from RectangularPrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
selectionRectangles | (Inherited from RectangularPrimitiveBase.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
LowerLeft | (Inherited from RectangularPrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size | (Inherited from RectangularPrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
UpperRight | (Inherited from RectangularPrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
HeuristicLab.Charting Namespace


Rectangle Constructor

[image]

HeuristicLab API Documentation
Rectangle Constructor
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Rectangle(IChart, PointD, PointD) |
Rectangle(IChart, PointD, PointD, Pen, Brush) |
Rectangle(IChart, Double, Double, Double, Double) |
Rectangle(IChart, Double, Double, Double, Double, Pen, Brush) |

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


Rectangle Constructor (IChart, PointD, PointD)

Rectangle Constructor (IChart, PointD, PointD)
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Rectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Rectangle(
    IChart chart,
    PointD lowerLeft,
    PointD upperRight
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

Rectangle Class
Rectangle Overload
HeuristicLab.Charting Namespace


Rectangle Constructor (IChart, PointD, PointD, Pen, Brush)

Rectangle Constructor (IChart, PointD, PointD, Pen, Brush)
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Rectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Rectangle(
    IChart chart,
    PointD lowerLeft,
    PointD upperRight,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Rectangle Class
Rectangle Overload
HeuristicLab.Charting Namespace


Rectangle Constructor (IChart, Double, Double, Double, Double)

Rectangle Constructor (IChart, Double, Double, Double, Double)
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Rectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Rectangle(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

Rectangle Class
Rectangle Overload
HeuristicLab.Charting Namespace


Rectangle Constructor (IChart, Double, Double, Double, Double, Pen, Brush)

Rectangle Constructor (IChart, Double, Double, Double, Double, Pen, Brush)
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Rectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Rectangle(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Rectangle Class
Rectangle Overload
HeuristicLab.Charting Namespace


Rectangle Methods

[image]

HeuristicLab API Documentation
Rectangle Methods
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Rectangle type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Overrides PrimitiveBase ..::. Draw(Graphics).)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from RectangularPrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rectangle Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
Rectangle..::.ContainsPoint Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides RectangularPrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

Rectangle..::.ContainsPoint Method (PointD)
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Rectangle.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.Rectangle.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

Rectangle Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


Draw Method

Rectangle..::.Draw Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Rectangle.Draw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Draw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.Draw(Graphics)

See Also

Rectangle Class
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Rectangle..::.GetCursor Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Inherited from RectangularPrimitiveBase.)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Rectangle..::.GetToolTipText Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Rectangle..::.MouseClick Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Rectangle..::.MouseDoubleClick Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Rectangle..::.MouseDrag Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from RectangularPrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Rectangle..::.MouseMove Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
Rectangle..::.Move Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from RectangularPrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
Rectangle..::.SetPosition Method
Rectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) | (Inherited from RectangularPrimitiveBase.)
SetPosition(Double, Double, Double, Double) | (Inherited from RectangularPrimitiveBase.)

See Also

Rectangle Class
Rectangle Members
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Class

RectangularPrimitiveBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.RectangularPrimitiveBase]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class RectangularPrimitiveBase : PrimitiveBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.RectangularPrimitiveBase
HeuristicLab.Charting..::.Ellipse
HeuristicLab.Charting..::.Rectangle

See Also

RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Members

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase Members
RectangularPrimitiveBase Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RectangularPrimitiveBase type exposes the following members.

Constructors

Name | Description
RectangularPrimitiveBase | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Overrides PrimitiveBase ..::. PostDraw(Graphics).)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
selectionRectangles |

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
LowerLeft |
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
UpperRight |

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Constructor

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase Constructor
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RectangularPrimitiveBase(IChart, PointD, PointD) |
RectangularPrimitiveBase(IChart, PointD, PointD, Pen, Brush) |
RectangularPrimitiveBase(IChart, Double, Double, Double, Double) |
RectangularPrimitiveBase(IChart, Double, Double, Double, Double, Pen, Brush) |

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Constructor (IChart, PointD, PointD)

RectangularPrimitiveBase Constructor (IChart, PointD, PointD)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RectangularPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected RectangularPrimitiveBase(
    IChart chart,
    PointD lowerLeft,
    PointD upperRight
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Overload
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Constructor (IChart, PointD, PointD, Pen, Brush)

RectangularPrimitiveBase Constructor (IChart, PointD, PointD, Pen, Brush)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RectangularPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected RectangularPrimitiveBase(
    IChart chart,
    PointD lowerLeft,
    PointD upperRight,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Overload
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Constructor (IChart, Double, Double, Double, Double)

RectangularPrimitiveBase Constructor (IChart, Double, Double, Double, Double)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RectangularPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected RectangularPrimitiveBase(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Overload
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Constructor (IChart, Double, Double, Double, Double, Pen, Brush)

RectangularPrimitiveBase Constructor (IChart, Double, Double, Double, Double, Pen, Brush)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RectangularPrimitiveBase class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected RectangularPrimitiveBase(
    IChart chart,
    double x1,
    double y1,
    double x2,
    double y2,
    Pen pen,
    Brush brush
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Overload
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Fields

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase Fields
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RectangularPrimitiveBase type exposes the following members.

Fields

Name | Description
selectionRectangles |

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


selectionRectangles Field

RectangularPrimitiveBase..::.selectionRectangles Field
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.RectangularPrimitiveBase.selectionRectangles]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected IGroup selectionRectangles

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Methods

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase Methods
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RectangularPrimitiveBase type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from PrimitiveBase.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Overrides PrimitiveBase ..::. PostDraw(Graphics).)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.ContainsPoint Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Overrides PrimitiveBase ..::. ContainsPoint(PointD).)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


ContainsPoint Method (PointD)

RectangularPrimitiveBase..::.ContainsPoint Method (PointD)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool ContainsPoint(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.ContainsPoint(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.ContainsPoint(PointD)

See Also

RectangularPrimitiveBase Class
ContainsPoint Overload
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.GetCursor Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Overrides PrimitiveBase ..::. GetCursor(PointD).)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


GetCursor Method (PointD)

RectangularPrimitiveBase..::.GetCursor Method (PointD)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.GetCursor(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Cursor GetCursor(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.GetCursor(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetCursor(PointD)

See Also

RectangularPrimitiveBase Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.GetToolTipText Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.MouseClick Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.MouseDoubleClick Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.MouseDrag Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Overrides PrimitiveBase ..::. MouseDrag(PointD, Offset, MouseButtons).)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


MouseDrag Method (PointD, Offset, MouseButtons)

RectangularPrimitiveBase..::.MouseDrag Method (PointD, Offset, MouseButtons)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.MouseDrag(HeuristicLab.Charting.PointD,HeuristicLab.Charting.Offset,System.Windows.Forms.MouseButtons)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void MouseDrag(
    PointD point,
    Offset offset,
    MouseButtons button
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

button
Type: System.Windows.Forms..::.MouseButtons

[Missing <param> documentation for "button"]

Implements

IPrimitive..::.MouseDrag(PointD, Offset, MouseButtons)

See Also

RectangularPrimitiveBase Class
MouseDrag Overload
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.MouseMove Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.Move Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Overrides PrimitiveBase ..::. Move(Offset).)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


Move Method (Offset)

RectangularPrimitiveBase..::.Move Method (Offset)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.Move(HeuristicLab.Charting.Offset)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Move(
    Offset delta
)

Parameters

delta
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "delta"]

Implements

IPrimitive..::.Move(Offset)

See Also

RectangularPrimitiveBase Class
Move Overload
HeuristicLab.Charting Namespace


PostDraw Method

RectangularPrimitiveBase..::.PostDraw Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.PostDraw(System.Drawing.Graphics)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void PostDraw(
    Graphics graphics
)

Parameters

graphics
Type: System.Drawing..::.Graphics

[Missing <param> documentation for "graphics"]

Implements

IPrimitive..::.PostDraw(Graphics)

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase..::.SetPosition Method
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) |
SetPosition(Double, Double, Double, Double) |

See Also

RectangularPrimitiveBase Class
RectangularPrimitiveBase Members
HeuristicLab.Charting Namespace


SetPosition Method (PointD, PointD)

RectangularPrimitiveBase..::.SetPosition Method (PointD, PointD)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.SetPosition(HeuristicLab.Charting.PointD,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void SetPosition(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

RectangularPrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


SetPosition Method (Double, Double, Double, Double)

RectangularPrimitiveBase..::.SetPosition Method (Double, Double, Double, Double)
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.RectangularPrimitiveBase.SetPosition(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetPosition(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

RectangularPrimitiveBase Class
SetPosition Overload
HeuristicLab.Charting Namespace


RectangularPrimitiveBase Properties

[image]

HeuristicLab API Documentation
RectangularPrimitiveBase Properties
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RectangularPrimitiveBase type exposes the following members.

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
LowerLeft |
Pen | (Inherited from PrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size |
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)
UpperRight |

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


LowerLeft Property

RectangularPrimitiveBase..::.LowerLeft Property
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.RectangularPrimitiveBase.LowerLeft]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD LowerLeft { get; }

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


Size Property

RectangularPrimitiveBase..::.Size Property
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.RectangularPrimitiveBase.Size]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual SizeD Size { get; }

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


UpperRight Property

RectangularPrimitiveBase..::.UpperRight Property
RectangularPrimitiveBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.RectangularPrimitiveBase.UpperRight]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual PointD UpperRight { get; }

See Also

RectangularPrimitiveBase Class
HeuristicLab.Charting Namespace


SelectionRectangle Class

SelectionRectangle Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.SelectionRectangle]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SelectionRectangle : FixedSizeRectangle

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.PrimitiveBase
HeuristicLab.Charting..::.FixedSizePrimitiveBase
HeuristicLab.Charting..::.FixedSizeRectangle
HeuristicLab.Charting..::.SelectionRectangle

See Also

SelectionRectangle Members
HeuristicLab.Charting Namespace


SelectionRectangle Members

[image]

HeuristicLab API Documentation
SelectionRectangle Members
SelectionRectangle Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectionRectangle type exposes the following members.

Constructors

Name | Description
SelectionRectangle | Overloaded.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from FixedSizeRectangle.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Brush | (Inherited from PrimitiveBase.)
Chart | (Inherited from PrimitiveBase.)
Group | (Inherited from PrimitiveBase.)
Pen | (Inherited from PrimitiveBase.)
Point | (Inherited from FixedSizePrimitiveBase.)
Selected | (Inherited from PrimitiveBase.)
Size | (Inherited from FixedSizePrimitiveBase.)
Tag | (Inherited from PrimitiveBase.)
ToolTipText | (Inherited from PrimitiveBase.)
UpdateEnabled | (Inherited from PrimitiveBase.)

Events

Name | Description
Update | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
HeuristicLab.Charting Namespace


SelectionRectangle Constructor

[image]

HeuristicLab API Documentation
SelectionRectangle Constructor
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SelectionRectangle(IChart, PointD, Cursor) |
SelectionRectangle(IChart, Double, Double, Cursor) |

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


SelectionRectangle Constructor (IChart, PointD, Cursor)

SelectionRectangle Constructor (IChart, PointD, Cursor)
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SelectionRectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SelectionRectangle(
    IChart chart,
    PointD point,
    Cursor cursor
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

cursor
Type: System.Windows.Forms..::.Cursor

[Missing <param> documentation for "cursor"]

See Also

SelectionRectangle Class
SelectionRectangle Overload
HeuristicLab.Charting Namespace


SelectionRectangle Constructor (IChart, Double, Double, Cursor)

SelectionRectangle Constructor (IChart, Double, Double, Cursor)
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SelectionRectangle class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SelectionRectangle(
    IChart chart,
    double x,
    double y,
    Cursor cursor
)

Parameters

chart
Type: HeuristicLab.Charting..::.IChart

[Missing <param> documentation for "chart"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

cursor
Type: System.Windows.Forms..::.Cursor

[Missing <param> documentation for "cursor"]

See Also

SelectionRectangle Class
SelectionRectangle Overload
HeuristicLab.Charting Namespace


SelectionRectangle Methods

[image]

HeuristicLab API Documentation
SelectionRectangle Methods
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectionRectangle type exposes the following members.

Methods

Name | Description
ContainsPoint | Overloaded.
Draw | (Inherited from FixedSizeRectangle.)
EnforceUpdate | (Inherited from PrimitiveBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IntoBackground | (Inherited from PrimitiveBase.)
IntoForeground | (Inherited from PrimitiveBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OneLayerDown | (Inherited from PrimitiveBase.)
OneLayerUp | (Inherited from PrimitiveBase.)
OnUpdate | (Inherited from PrimitiveBase.)
PostDraw | (Inherited from PrimitiveBase.)
PreDraw | (Inherited from PrimitiveBase.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionRectangle Class
HeuristicLab.Charting Namespace


ContainsPoint Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.ContainsPoint Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ContainsPoint(PointD) | (Inherited from FixedSizePrimitiveBase.)
ContainsPoint(Double, Double) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.GetCursor Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(PointD) | (Overrides PrimitiveBase ..::. GetCursor(PointD).)
GetCursor(Double, Double) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


GetCursor Method (PointD)

SelectionRectangle..::.GetCursor Method (PointD)
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SelectionRectangle.GetCursor(HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Cursor GetCursor(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SelectionRectangle.GetCursor(HeuristicLab.Charting.PointD)]

Implements

IPrimitive..::.GetCursor(PointD)

See Also

SelectionRectangle Class
GetCursor Overload
HeuristicLab.Charting Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.GetToolTipText Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(PointD) | (Inherited from PrimitiveBase.)
GetToolTipText(Double, Double) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.MouseClick Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.MouseDoubleClick Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(PointD, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDoubleClick(Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.MouseDrag Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(PointD, Offset, MouseButtons) | (Inherited from PrimitiveBase.)
MouseDrag(Double, Double, Double, Double, MouseButtons) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.MouseMove Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(PointD, Offset) | (Inherited from PrimitiveBase.)
MouseMove(Double, Double, Double, Double) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


Move Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.Move Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from FixedSizePrimitiveBase.)
Move(Double, Double) | (Inherited from PrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
SelectionRectangle..::.SetPosition Method
SelectionRectangle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD) | (Inherited from FixedSizePrimitiveBase.)
SetPosition(Double, Double) | (Inherited from FixedSizePrimitiveBase.)

See Also

SelectionRectangle Class
SelectionRectangle Members
HeuristicLab.Charting Namespace


SizeD Structure

SizeD Structure
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.SizeD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public struct SizeD

See Also

SizeD Members
HeuristicLab.Charting Namespace


SizeD Members

[image]

HeuristicLab API Documentation
SizeD Members
SizeD Structure Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SizeD type exposes the following members.

Constructors

Name | Description
SizeD | Overloaded.

Methods

Name | Description
Add |
Equals | (Overrides ValueType ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Subtract |
ToString | (Overrides ValueType ..::. ToString()()().)

Operators

Name | Description
Addition |
Equality |
Explicit | Overloaded.
Implicit | Overloaded.
Inequality |
Subtraction |

Fields

Name | Description
Empty |

Properties

Name | Description
Height |
IsEmpty |
Width |

See Also

SizeD Structure
HeuristicLab.Charting Namespace


SizeD Constructor

[image]

HeuristicLab API Documentation
SizeD Constructor
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SizeD(Offset) |
SizeD(PointD) |
SizeD(Double, Double) |

See Also

SizeD Structure
SizeD Members
HeuristicLab.Charting Namespace


SizeD Constructor (Offset)

SizeD Constructor (Offset)
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SizeD class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SizeD(
    Offset offset
)

Parameters

offset
Type: HeuristicLab.Charting..::.Offset

[Missing <param> documentation for "offset"]

See Also

SizeD Structure
SizeD Overload
HeuristicLab.Charting Namespace


SizeD Constructor (PointD)

SizeD Constructor (PointD)
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SizeD class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SizeD(
    PointD point
)

Parameters

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

See Also

SizeD Structure
SizeD Overload
HeuristicLab.Charting Namespace


SizeD Constructor (Double, Double)

SizeD Constructor (Double, Double)
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SizeD class.

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SizeD(
    double width,
    double height
)

Parameters

width
Type: System..::.Double

[Missing <param> documentation for "width"]

height
Type: System..::.Double

[Missing <param> documentation for "height"]

See Also

SizeD Structure
SizeD Overload
HeuristicLab.Charting Namespace


SizeD Fields

[image]

HeuristicLab API Documentation
SizeD Fields
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SizeD type exposes the following members.

Fields

Name | Description
Empty |

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Empty Field

SizeD..::.Empty Field
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.SizeD.Empty]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static readonly SizeD Empty

See Also

SizeD Structure
HeuristicLab.Charting Namespace


SizeD Methods

[image]

HeuristicLab API Documentation
SizeD Methods
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SizeD type exposes the following members.

Methods

Name | Description
Add |
Equals | (Overrides ValueType ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Subtract |
ToString | (Overrides ValueType ..::. ToString()()().)

Operators

Name | Description
Addition |
Equality |
Explicit | Overloaded.
Implicit | Overloaded.
Inequality |
Subtraction |

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Add Method

SizeD..::.Add Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.Add(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static SizeD Add(
    SizeD size1,
    SizeD size2
)

Parameters

size1
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size1"]

size2
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.Add(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Addition Operator

SizeD..::.Addition Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Addition(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static SizeD operator +(
    SizeD size1,
    SizeD size2
)

Parameters

size1
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size1"]

size2
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Addition(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Equality Operator

SizeD..::.Equality Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Equality(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool operator ==(
    SizeD size1,
    SizeD size2
)

Parameters

size1
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size1"]

size2
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Equality(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Equals Method

SizeD..::.Equals Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.Equals(System.Object)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.Equals(System.Object)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Explicit Method

[image]

HeuristicLab API Documentation
SizeD..::.Explicit Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Explicit(SizeD) |
Explicit(SizeD) |

See Also

SizeD Structure
SizeD Members
HeuristicLab.Charting Namespace


Explicit Operator

SizeD..::.Explicit Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Explicit(HeuristicLab.Charting.SizeD)~HeuristicLab.Charting.PointD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static explicit operator PointD (
    SizeD size
)

Parameters

size
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Explicit(HeuristicLab.Charting.SizeD)~HeuristicLab.Charting.PointD]

See Also

SizeD Structure
Explicit Overload
HeuristicLab.Charting Namespace


Explicit Operator

SizeD..::.Explicit Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Explicit(HeuristicLab.Charting.SizeD)~HeuristicLab.Charting.Offset]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static explicit operator Offset (
    SizeD size
)

Parameters

size
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Explicit(HeuristicLab.Charting.SizeD)~HeuristicLab.Charting.Offset]

See Also

SizeD Structure
Explicit Overload
HeuristicLab.Charting Namespace


GetHashCode Method

SizeD..::.GetHashCode Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.GetHashCode]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override int GetHashCode()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.GetHashCode]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Implicit Method

[image]

HeuristicLab API Documentation
SizeD..::.Implicit Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Implicit(Size) |
Implicit(SizeF) |

See Also

SizeD Structure
SizeD Members
HeuristicLab.Charting Namespace


Implicit Operator

SizeD..::.Implicit Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Implicit(System.Drawing.Size)~HeuristicLab.Charting.SizeD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static implicit operator SizeD (
    Size size
)

Parameters

size
Type: System.Drawing..::.Size

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Implicit(System.Drawing.Size)~HeuristicLab.Charting.SizeD]

See Also

SizeD Structure
Implicit Overload
HeuristicLab.Charting Namespace


Implicit Operator

SizeD..::.Implicit Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Implicit(System.Drawing.SizeF)~HeuristicLab.Charting.SizeD]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static implicit operator SizeD (
    SizeF size
)

Parameters

size
Type: System.Drawing..::.SizeF

[Missing <param> documentation for "size"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Implicit(System.Drawing.SizeF)~HeuristicLab.Charting.SizeD]

See Also

SizeD Structure
Implicit Overload
HeuristicLab.Charting Namespace


Inequality Operator

SizeD..::.Inequality Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Inequality(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static bool operator !=(
    SizeD size1,
    SizeD size2
)

Parameters

size1
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size1"]

size2
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Inequality(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Subtract Method

SizeD..::.Subtract Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.Subtract(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static SizeD Subtract(
    SizeD size1,
    SizeD size2
)

Parameters

size1
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size1"]

size2
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.Subtract(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Subtraction Operator

SizeD..::.Subtraction Operator
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.op_Subtraction(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static SizeD operator -(
    SizeD size1,
    SizeD size2
)

Parameters

size1
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size1"]

size2
Type: HeuristicLab.Charting..::.SizeD

[Missing <param> documentation for "size2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.op_Subtraction(HeuristicLab.Charting.SizeD,HeuristicLab.Charting.SizeD)]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


ToString Method

SizeD..::.ToString Method
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.SizeD.ToString]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Charting.SizeD.ToString]

See Also

SizeD Structure
HeuristicLab.Charting Namespace


SizeD Properties

[image]

HeuristicLab API Documentation
SizeD Properties
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SizeD type exposes the following members.

Properties

Name | Description
Height |
IsEmpty |
Width |

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Height Property

SizeD..::.Height Property
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.SizeD.Height]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Height { get; set; }

See Also

SizeD Structure
HeuristicLab.Charting Namespace


IsEmpty Property

SizeD..::.IsEmpty Property
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.SizeD.IsEmpty]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsEmpty { get; }

See Also

SizeD Structure
HeuristicLab.Charting Namespace


Width Property

SizeD..::.Width Property
SizeD Structure See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.SizeD.Width]

Namespace: HeuristicLab.Charting
Assembly: HeuristicLab.Charting (in HeuristicLab.Charting.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Width { get; set; }

See Also

SizeD Structure
HeuristicLab.Charting Namespace


HeuristicLab.Charting.Data Namespace

HeuristicLab.Charting.Data Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Charting.Data]

Classes

Class | Description
Datachart |
DataChartControl |
HeuristicLabChartingDataPlugin |

Enumerations

Enumeration | Description
DataRowType |


Datachart Class

Datachart Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Data.Datachart]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Datachart : Chart

Inheritance Hierarchy

System..::.Object
HeuristicLab.Charting..::.Chart
HeuristicLab.Charting.Data..::.Datachart

See Also

Datachart Members
HeuristicLab.Charting.Data Namespace


Datachart Members

[image]

HeuristicLab API Documentation
Datachart Members
Datachart Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Datachart type exposes the following members.

Constructors

Name | Description
Datachart | Overloaded.

Methods

Name | Description
AddDataPoint | Overloaded.
AddDataRow |
EnforceUpdate | (Inherited from Chart.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OnUpdate | (Inherited from Chart.)
RemoveDataRow |
Render | (Inherited from Chart.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformPixelToWorld | Overloaded.
TransformWorldToPixel | Overloaded.
Unzoom | (Inherited from Chart.)
ZoomIn | Overloaded.
ZoomOut | (Inherited from Chart.)

Properties

Name | Description
Group | (Inherited from Chart.)
LowerLeft | (Inherited from Chart.)
Mode | (Inherited from Chart.)
PixelToWorldRatio | (Inherited from Chart.)
Size | (Inherited from Chart.)
SizeInPixels | (Inherited from Chart.)
Title |
UpdateEnabled | (Inherited from Chart.)
UpperRight | (Inherited from Chart.)
WorldToPixelRatio | (Inherited from Chart.)

Events

Name | Description
Update | (Inherited from Chart.)

See Also

Datachart Class
HeuristicLab.Charting.Data Namespace


Datachart Constructor

[image]

HeuristicLab API Documentation
Datachart Constructor
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Datachart(PointD, PointD) |
Datachart(Double, Double, Double, Double) |

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


Datachart Constructor (PointD, PointD)

Datachart Constructor (PointD, PointD)
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Datachart class.

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Datachart(
    PointD lowerLeft,
    PointD upperRight
)

Parameters

lowerLeft
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "lowerLeft"]

upperRight
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "upperRight"]

See Also

Datachart Class
Datachart Overload
HeuristicLab.Charting.Data Namespace


Datachart Constructor (Double, Double, Double, Double)

Datachart Constructor (Double, Double, Double, Double)
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Datachart class.

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Datachart(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

See Also

Datachart Class
Datachart Overload
HeuristicLab.Charting.Data Namespace


Datachart Methods

[image]

HeuristicLab API Documentation
Datachart Methods
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Datachart type exposes the following members.

Methods

Name | Description
AddDataPoint | Overloaded.
AddDataRow |
EnforceUpdate | (Inherited from Chart.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllPrimitives | Overloaded.
GetCursor | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPrimitive | Overloaded.
GetToolTipText | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
MouseDoubleClick | Overloaded.
MouseDrag | Overloaded.
MouseMove | Overloaded.
Move | Overloaded.
OnUpdate | (Inherited from Chart.)
RemoveDataRow |
Render | (Inherited from Chart.)
SetPosition | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformPixelToWorld | Overloaded.
TransformWorldToPixel | Overloaded.
Unzoom | (Inherited from Chart.)
ZoomIn | Overloaded.
ZoomOut | (Inherited from Chart.)

See Also

Datachart Class
HeuristicLab.Charting.Data Namespace


AddDataPoint Method

[image]

HeuristicLab API Documentation
Datachart..::.AddDataPoint Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddDataPoint(Int32, PointD) |
AddDataPoint(Int32, Double, Double) |

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


AddDataPoint Method (Int32, PointD)

Datachart..::.AddDataPoint Method (Int32, PointD)
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Data.Datachart.AddDataPoint(System.Int32,HeuristicLab.Charting.PointD)]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddDataPoint(
    int dataRowIndex,
    PointD point
)

Parameters

dataRowIndex
Type: System..::.Int32

[Missing <param> documentation for "dataRowIndex"]

point
Type: HeuristicLab.Charting..::.PointD

[Missing <param> documentation for "point"]

See Also

Datachart Class
AddDataPoint Overload
HeuristicLab.Charting.Data Namespace


AddDataPoint Method (Int32, Double, Double)

Datachart..::.AddDataPoint Method (Int32, Double, Double)
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Data.Datachart.AddDataPoint(System.Int32,System.Double,System.Double)]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddDataPoint(
    int dataRowIndex,
    double x,
    double y
)

Parameters

dataRowIndex
Type: System..::.Int32

[Missing <param> documentation for "dataRowIndex"]

x
Type: System..::.Double

[Missing <param> documentation for "x"]

y
Type: System..::.Double

[Missing <param> documentation for "y"]

See Also

Datachart Class
AddDataPoint Overload
HeuristicLab.Charting.Data Namespace


AddDataRow Method

Datachart..::.AddDataRow Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Data.Datachart.AddDataRow(HeuristicLab.Charting.Data.DataRowType,System.Drawing.Pen,System.Drawing.Brush)]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddDataRow(
    DataRowType dataRowType,
    Pen pen,
    Brush brush
)

Parameters

dataRowType
Type: HeuristicLab.Charting.Data..::.DataRowType

[Missing <param> documentation for "dataRowType"]

pen
Type: System.Drawing..::.Pen

[Missing <param> documentation for "pen"]

brush
Type: System.Drawing..::.Brush

[Missing <param> documentation for "brush"]

See Also

Datachart Class
HeuristicLab.Charting.Data Namespace


GetAllPrimitives Method

[image]

HeuristicLab API Documentation
Datachart..::.GetAllPrimitives Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetAllPrimitives(Point) | (Inherited from Chart.)
GetAllPrimitives(Int32, Int32) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


GetCursor Method

[image]

HeuristicLab API Documentation
Datachart..::.GetCursor Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetCursor(Point) | (Inherited from Chart.)
GetCursor(Int32, Int32) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


GetPrimitive Method

[image]

HeuristicLab API Documentation
Datachart..::.GetPrimitive Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPrimitive(Point) | (Inherited from Chart.)
GetPrimitive(Int32, Int32) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


GetToolTipText Method

[image]

HeuristicLab API Documentation
Datachart..::.GetToolTipText Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTipText(Point) | (Inherited from Chart.)
GetToolTipText(Int32, Int32) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


MouseClick Method

[image]

HeuristicLab API Documentation
Datachart..::.MouseClick Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseClick(Point, MouseButtons) | (Inherited from Chart.)
MouseClick(Int32, Int32, MouseButtons) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


MouseDoubleClick Method

[image]

HeuristicLab API Documentation
Datachart..::.MouseDoubleClick Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDoubleClick(Point, MouseButtons) | (Inherited from Chart.)
MouseDoubleClick(Int32, Int32, MouseButtons) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


MouseDrag Method

[image]

HeuristicLab API Documentation
Datachart..::.MouseDrag Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseDrag(Point, Point, MouseButtons) | (Inherited from Chart.)
MouseDrag(Int32, Int32, Int32, Int32, MouseButtons) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


MouseMove Method

[image]

HeuristicLab API Documentation
Datachart..::.MouseMove Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MouseMove(Point, Point) | (Inherited from Chart.)
MouseMove(Int32, Int32, Int32, Int32) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


Move Method

[image]

HeuristicLab API Documentation
Datachart..::.Move Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Move(Offset) | (Inherited from Chart.)
Move(Double, Double) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


RemoveDataRow Method

Datachart..::.RemoveDataRow Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Charting.Data.Datachart.RemoveDataRow(System.Int32)]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveDataRow(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

Datachart Class
HeuristicLab.Charting.Data Namespace


SetPosition Method

[image]

HeuristicLab API Documentation
Datachart..::.SetPosition Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetPosition(PointD, PointD) | (Inherited from Chart.)
SetPosition(Double, Double, Double, Double) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


TransformPixelToWorld Method

[image]

HeuristicLab API Documentation
Datachart..::.TransformPixelToWorld Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TransformPixelToWorld(Point) | (Inherited from Chart.)
TransformPixelToWorld(Size) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


TransformWorldToPixel Method

[image]

HeuristicLab API Documentation
Datachart..::.TransformWorldToPixel Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TransformWorldToPixel(PointD) | (Inherited from Chart.)
TransformWorldToPixel(SizeD) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


ZoomIn Method

[image]

HeuristicLab API Documentation
Datachart..::.ZoomIn Method
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ZoomIn(Point, Point) | (Inherited from Chart.)
ZoomIn(PointD, PointD) | (Inherited from Chart.)
ZoomIn(Double, Double, Double, Double) | (Inherited from Chart.)
ZoomIn(Int32, Int32, Int32, Int32) | (Inherited from Chart.)

See Also

Datachart Class
Datachart Members
HeuristicLab.Charting.Data Namespace


Datachart Properties

[image]

HeuristicLab API Documentation
Datachart Properties
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Datachart type exposes the following members.

Properties

Name | Description
Group | (Inherited from Chart.)
LowerLeft | (Inherited from Chart.)
Mode | (Inherited from Chart.)
PixelToWorldRatio | (Inherited from Chart.)
Size | (Inherited from Chart.)
SizeInPixels | (Inherited from Chart.)
Title |
UpdateEnabled | (Inherited from Chart.)
UpperRight | (Inherited from Chart.)
WorldToPixelRatio | (Inherited from Chart.)

See Also

Datachart Class
HeuristicLab.Charting.Data Namespace


Title Property

Datachart..::.Title Property
Datachart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Data.Datachart.Title]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Title { get; set; }

See Also

Datachart Class
HeuristicLab.Charting.Data Namespace


DataChartControl Class

DataChartControl Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Data.DataChartControl]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DataChartControl : ChartControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Charting..::.ChartControl
HeuristicLab.Charting.Data..::.DataChartControl

See Also

DataChartControl Members
HeuristicLab.Charting.Data Namespace


DataChartControl Members

[image]

HeuristicLab API Documentation
DataChartControl Members
DataChartControl Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataChartControl type exposes the following members.

Constructors

Name | Description
DataChartControl |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
intoBackgroundToolStripMenuItem | (Inherited from ChartControl.)
intoForegroundToolStripMenuItem | (Inherited from ChartControl.)
moveToolStripMenuItem | (Inherited from ChartControl.)
oneLayerDownToolStripMenuItem | (Inherited from ChartControl.)
oneLayerUpToolStripMenuItem | (Inherited from ChartControl.)
pictureBox | (Inherited from ChartControl.)
pictureBoxContextMenuStrip | (Inherited from ChartControl.)
propertiesToolStripMenuItem | (Inherited from ChartControl.)
selectToolStripMenuItem | (Inherited from ChartControl.)
titleLabel |
toolStripMenuItem1 | (Inherited from ChartControl.)
toolStripMenuItem2 | (Inherited from ChartControl.)
toolTip | (Inherited from ChartControl.)
zoomToolStripMenuItem | (Inherited from ChartControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart |
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScaleOnResize | (Inherited from ChartControl.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


DataChartControl Constructor

DataChartControl Constructor
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DataChartControl class.

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DataChartControl()

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


DataChartControl Fields

[image]

HeuristicLab API Documentation
DataChartControl Fields
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataChartControl type exposes the following members.

Fields

Name | Description
intoBackgroundToolStripMenuItem | (Inherited from ChartControl.)
intoForegroundToolStripMenuItem | (Inherited from ChartControl.)
moveToolStripMenuItem | (Inherited from ChartControl.)
oneLayerDownToolStripMenuItem | (Inherited from ChartControl.)
oneLayerUpToolStripMenuItem | (Inherited from ChartControl.)
pictureBox | (Inherited from ChartControl.)
pictureBoxContextMenuStrip | (Inherited from ChartControl.)
propertiesToolStripMenuItem | (Inherited from ChartControl.)
selectToolStripMenuItem | (Inherited from ChartControl.)
titleLabel |
toolStripMenuItem1 | (Inherited from ChartControl.)
toolStripMenuItem2 | (Inherited from ChartControl.)
toolTip | (Inherited from ChartControl.)
zoomToolStripMenuItem | (Inherited from ChartControl.)

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


titleLabel Field

DataChartControl..::.titleLabel Field
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Charting.Data.DataChartControl.titleLabel]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Label titleLabel

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


DataChartControl Methods

[image]

HeuristicLab API Documentation
DataChartControl Methods
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataChartControl type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DataChartControl..::.AccessibilityNotifyClients Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DataChartControl..::.BeginInvoke Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DataChartControl..::.Dispose Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ChartControl ..::. Dispose(Boolean).)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Dispose Method (Boolean)

DataChartControl..::.Dispose Method (Boolean)
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DataChartControl Class
Dispose Overload
HeuristicLab.Charting.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DataChartControl..::.GetChildAtPoint Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DataChartControl..::.Invalidate Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DataChartControl..::.Invoke Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DataChartControl..::.MemberwiseClone Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DataChartControl..::.PerformLayout Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DataChartControl..::.ResumeLayout Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DataChartControl..::.RtlTranslateAlignment Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
DataChartControl..::.Scale Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
DataChartControl..::.Select Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DataChartControl..::.SetBounds Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DataChartControl..::.UpdateBounds Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
DataChartControl..::.Validate Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DataChartControl..::.ValidateChildren Method
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DataChartControl Class
DataChartControl Members
HeuristicLab.Charting.Data Namespace


DataChartControl Properties

[image]

HeuristicLab API Documentation
DataChartControl Properties
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataChartControl type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Chart |
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ScaleOnResize | (Inherited from ChartControl.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


Chart Property

DataChartControl..::.Chart Property
DataChartControl Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Charting.Data.DataChartControl.Chart]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Datachart Chart { get; set; }

See Also

DataChartControl Class
HeuristicLab.Charting.Data Namespace


DataRowType Enumeration

DataRowType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Data.DataRowType]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public enum DataRowType

Members

Member name | Description
Lines |
Bars |
Points |

See Also

HeuristicLab.Charting.Data Namespace


HeuristicLabChartingDataPlugin Class

HeuristicLabChartingDataPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Charting.Data.HeuristicLabChartingDataPlugin]

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Charting")]
[PluginFileAttribute(Filename = "HeuristicLab.Charting.Data.dll", Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Charting.Data")]
public class HeuristicLabChartingDataPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Charting.Data..::.HeuristicLabChartingDataPlugin

See Also

HeuristicLabChartingDataPlugin Members
HeuristicLab.Charting.Data Namespace


HeuristicLabChartingDataPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabChartingDataPlugin Members
HeuristicLabChartingDataPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabChartingDataPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabChartingDataPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabChartingDataPlugin Class
HeuristicLab.Charting.Data Namespace


HeuristicLabChartingDataPlugin Constructor

HeuristicLabChartingDataPlugin Constructor
HeuristicLabChartingDataPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabChartingDataPlugin class.

Namespace: HeuristicLab.Charting.Data
Assembly: HeuristicLab.Charting.Data (in HeuristicLab.Charting.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabChartingDataPlugin()

See Also

HeuristicLabChartingDataPlugin Class
HeuristicLab.Charting.Data Namespace


HeuristicLab.Constraints Namespace

HeuristicLab.Constraints Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Constraints]

Classes

Class | Description
AllSubOperatorsTypeConstraint |
AllSubOperatorsTypeConstraintView |
AndConstraint |
AndConstraintView |
ConstraintBase |
ConstraintVisitorBase |
DoubleBoundedConstraint |
DoubleBoundedConstraintView |
FalseConstraint |
FalseConstraintView |
HeuristicLabConstraintsPlugin |
IntBoundedConstraint |
IntBoundedConstraintView |
IsIntegerConstraint |
ItemTypeConstraint |
ItemTypeConstraintView |
NotConstraint |
NotConstraintView |
NumberOfSubOperatorsConstraint |
NumberOfSubOperatorsConstraintView |
OrConstraint |
OrConstraintView |
SubOperatorsConstraintAnalyser |
SubOperatorsTypeConstraintView |
SubOperatorTypeConstraint |
TrueConstraint |
TrueConstraintView |
VariableComparisonConstraint |
VariableComparisonConstraintView |

Interfaces

Interface | Description
IConstraintVisitor |


AllSubOperatorsTypeConstraint Class

AllSubOperatorsTypeConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AllSubOperatorsTypeConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraint

See Also

AllSubOperatorsTypeConstraint Members
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraint Members

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraint Members
AllSubOperatorsTypeConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AllSubOperatorsTypeConstraint type exposes the following members.

Constructors

Name | Description
AllSubOperatorsTypeConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
AddOperator |
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
ToString | (Inherited from ItemBase.)

Properties

Name | Description
AllowedSubOperators |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraint Constructor

AllSubOperatorsTypeConstraint Constructor
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AllSubOperatorsTypeConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AllSubOperatorsTypeConstraint()

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraint Methods

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraint Methods
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AllSubOperatorsTypeConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
AddOperator |
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
ToString | (Inherited from ItemBase.)

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

AllSubOperatorsTypeConstraint..::.Accept Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


AddOperator Method

AllSubOperatorsTypeConstraint..::.AddOperator Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


Check Method

AllSubOperatorsTypeConstraint..::.Check Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraint..::.Clone Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

AllSubOperatorsTypeConstraint Class
AllSubOperatorsTypeConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

AllSubOperatorsTypeConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

AllSubOperatorsTypeConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

AllSubOperatorsTypeConstraint..::.CreateView Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

AllSubOperatorsTypeConstraint..::.GetXmlNode Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

AllSubOperatorsTypeConstraint..::.Populate Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


RemoveOperator Method

AllSubOperatorsTypeConstraint..::.RemoveOperator Method
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.RemoveOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraint Properties

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraint Properties
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AllSubOperatorsTypeConstraint type exposes the following members.

Properties

Name | Description
AllowedSubOperators |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


AllowedSubOperators Property

AllSubOperatorsTypeConstraint..::.AllowedSubOperators Property
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.AllowedSubOperators]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IOperator> AllowedSubOperators { get; }

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


Description Property

AllSubOperatorsTypeConstraint..::.Description Property
AllSubOperatorsTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.AllSubOperatorsTypeConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

AllSubOperatorsTypeConstraint Class
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Class

AllSubOperatorsTypeConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.AllSubOperatorsTypeConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AllSubOperatorsTypeConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraintView

See Also

AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Members

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView Members
AllSubOperatorsTypeConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AllSubOperatorsTypeConstraintView type exposes the following members.

Constructors

Name | Description
AllSubOperatorsTypeConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Constraint |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Constructor

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView Constructor
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AllSubOperatorsTypeConstraintView()()() |
AllSubOperatorsTypeConstraintView(SubOperatorTypeConstraint) |

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Constructor

AllSubOperatorsTypeConstraintView Constructor
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AllSubOperatorsTypeConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AllSubOperatorsTypeConstraintView()

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Overload
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Constructor (SubOperatorTypeConstraint)

AllSubOperatorsTypeConstraintView Constructor (SubOperatorTypeConstraint)
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AllSubOperatorsTypeConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AllSubOperatorsTypeConstraintView(
    SubOperatorTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.SubOperatorTypeConstraint

[Missing <param> documentation for "constraint"]

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Overload
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Methods

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView Methods
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AllSubOperatorsTypeConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

AllSubOperatorsTypeConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.AccessibilityNotifyClients Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.BeginInvoke Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.Dispose Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

AllSubOperatorsTypeConstraintView..::.Dispose Method (Boolean)
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AllSubOperatorsTypeConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.GetChildAtPoint Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.Invalidate Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.Invoke Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.MemberwiseClone Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.PerformLayout Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.ResumeLayout Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.RtlTranslateAlignment Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.Scale Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.Select Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.SetBounds Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.UpdateBounds Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.Validate Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView..::.ValidateChildren Method
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

AllSubOperatorsTypeConstraintView Class
AllSubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


AllSubOperatorsTypeConstraintView Properties

[image]

HeuristicLab API Documentation
AllSubOperatorsTypeConstraintView Properties
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AllSubOperatorsTypeConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Constraint |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

AllSubOperatorsTypeConstraintView Class
HeuristicLab.Constraints Namespace


Constraint Property

AllSubOperatorsTypeConstraintView..::.Constraint Property
AllSubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.AllSubOperatorsTypeConstraintView.Constraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubOperatorTypeConstraint Constraint { get; set; }

See Also

AllSubOperatorsTypeConstraintView Class
HeuristicLab.Constraints Namespace


AndConstraint Class

AndConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.AndConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AndConstraint : ConstraintBase, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.AndConstraint

See Also

AndConstraint Members
HeuristicLab.Constraints Namespace


AndConstraint Members

[image]

HeuristicLab API Documentation
AndConstraint Members
AndConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AndConstraint type exposes the following members.

Constructors

Name | Description
AndConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Clauses |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


AndConstraint Constructor

AndConstraint Constructor
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AndConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AndConstraint()

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


AndConstraint Methods

[image]

HeuristicLab API Documentation
AndConstraint Methods
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AndConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

AndConstraint..::.Accept Method
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


Check Method

AndConstraint..::.Check Method
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AndConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
AndConstraint..::.Clone Method
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

AndConstraint Class
AndConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

AndConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AndConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

AndConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

AndConstraint..::.CreateView Method
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AndConstraint.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

AndConstraint..::.GetXmlNode Method
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.AndConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

AndConstraint..::.Populate Method
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


AndConstraint Properties

[image]

HeuristicLab API Documentation
AndConstraint Properties
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AndConstraint type exposes the following members.

Properties

Name | Description
Clauses |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


Clauses Property

AndConstraint..::.Clauses Property
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.AndConstraint.Clauses]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Clauses { get; set; }

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


Description Property

AndConstraint..::.Description Property
AndConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.AndConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

AndConstraint Class
HeuristicLab.Constraints Namespace


AndConstraintView Class

AndConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.AndConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AndConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.AndConstraintView

See Also

AndConstraintView Members
HeuristicLab.Constraints Namespace


AndConstraintView Members

[image]

HeuristicLab API Documentation
AndConstraintView Members
AndConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AndConstraintView type exposes the following members.

Constructors

Name | Description
AndConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AndConstraint |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


AndConstraintView Constructor

[image]

HeuristicLab API Documentation
AndConstraintView Constructor
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AndConstraintView()()() |
AndConstraintView(AndConstraint) |

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


AndConstraintView Constructor

AndConstraintView Constructor
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AndConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AndConstraintView()

See Also

AndConstraintView Class
AndConstraintView Overload
HeuristicLab.Constraints Namespace


AndConstraintView Constructor (AndConstraint)

AndConstraintView Constructor (AndConstraint)
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AndConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AndConstraintView(
    AndConstraint andConstraint
)

Parameters

andConstraint
Type: HeuristicLab.Constraints..::.AndConstraint

[Missing <param> documentation for "andConstraint"]

See Also

AndConstraintView Class
AndConstraintView Overload
HeuristicLab.Constraints Namespace


AndConstraintView Methods

[image]

HeuristicLab API Documentation
AndConstraintView Methods
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AndConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.AccessibilityNotifyClients Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

AndConstraintView..::.AddItemEvents Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.BeginInvoke Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.Dispose Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

AndConstraintView..::.Dispose Method (Boolean)
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AndConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.GetChildAtPoint Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.Invalidate Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.Invoke Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.MemberwiseClone Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.PerformLayout Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

AndConstraintView..::.RemoveItemEvents Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.ResumeLayout Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.RtlTranslateAlignment Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.Scale Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.Select Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.SetBounds Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.UpdateBounds Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

AndConstraintView..::.UpdateControls Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.AndConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.Validate Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AndConstraintView..::.ValidateChildren Method
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

AndConstraintView Class
AndConstraintView Members
HeuristicLab.Constraints Namespace


AndConstraintView Properties

[image]

HeuristicLab API Documentation
AndConstraintView Properties
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AndConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AndConstraint |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


AndConstraint Property

AndConstraintView..::.AndConstraint Property
AndConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.AndConstraintView.AndConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AndConstraint AndConstraint { get; set; }

See Also

AndConstraintView Class
HeuristicLab.Constraints Namespace


ConstraintBase Class

ConstraintBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.ConstraintBase]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ConstraintBase : ItemBase, IConstraint,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.TrueConstraint
HeuristicLab.Constraints..::.NotConstraint
HeuristicLab.Constraints..::.ItemTypeConstraint
HeuristicLab.Constraints..::.IsIntegerConstraint
HeuristicLab.Constraints..::.SubOperatorTypeConstraint
HeuristicLab.Constraints..::.IntBoundedConstraint
HeuristicLab.Constraints..::.FalseConstraint
HeuristicLab.Constraints..::.DoubleBoundedConstraint
HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraint
HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraint
HeuristicLab.Constraints..::.VariableComparisonConstraint
HeuristicLab.Constraints..::.OrConstraint
HeuristicLab.Constraints..::.AndConstraint

See Also

ConstraintBase Members
HeuristicLab.Constraints Namespace


ConstraintBase Members

[image]

HeuristicLab API Documentation
ConstraintBase Members
ConstraintBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintBase type exposes the following members.

Constructors

Name | Description
ConstraintBase |

Methods

Name | Description
Accept |
Check |
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


ConstraintBase Constructor

ConstraintBase Constructor
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstraintBase class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ConstraintBase()

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


ConstraintBase Methods

[image]

HeuristicLab API Documentation
ConstraintBase Methods
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintBase type exposes the following members.

Methods

Name | Description
Accept |
Check |
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


Accept Method

ConstraintBase..::.Accept Method
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintBase.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


Check Method

ConstraintBase..::.Check Method
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintBase.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.ConstraintBase.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConstraintBase..::.Clone Method
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from StorableBase.)

See Also

ConstraintBase Class
ConstraintBase Members
HeuristicLab.Constraints Namespace


ConstraintBase Properties

[image]

HeuristicLab API Documentation
ConstraintBase Properties
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintBase type exposes the following members.

Properties

Name | Description
Description |
Guid | (Inherited from StorableBase.)

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


Description Property

ConstraintBase..::.Description Property
ConstraintBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.ConstraintBase.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual string Description { get; }

Implements

IConstraint..::.Description

See Also

ConstraintBase Class
HeuristicLab.Constraints Namespace


ConstraintVisitorBase Class

ConstraintVisitorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.ConstraintVisitorBase]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstraintVisitorBase : IConstraintVisitor

Inheritance Hierarchy

System..::.Object
HeuristicLab.Constraints..::.ConstraintVisitorBase
GetAllowedOperatorsVisitor

See Also

ConstraintVisitorBase Members
HeuristicLab.Constraints Namespace


ConstraintVisitorBase Members

[image]

HeuristicLab API Documentation
ConstraintVisitorBase Members
ConstraintVisitorBase Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintVisitorBase type exposes the following members.

Constructors

Name | Description
ConstraintVisitorBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Visit | Overloaded.

See Also

ConstraintVisitorBase Class
HeuristicLab.Constraints Namespace


ConstraintVisitorBase Constructor

ConstraintVisitorBase Constructor
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstraintVisitorBase class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstraintVisitorBase()

See Also

ConstraintVisitorBase Class
HeuristicLab.Constraints Namespace


ConstraintVisitorBase Methods

[image]

HeuristicLab API Documentation
ConstraintVisitorBase Methods
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintVisitorBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Visit | Overloaded.

See Also

ConstraintVisitorBase Class
HeuristicLab.Constraints Namespace


Visit Method

[image]

HeuristicLab API Documentation
ConstraintVisitorBase..::.Visit Method
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Visit(AllSubOperatorsTypeConstraint) |
Visit(AndConstraint) |
Visit(DoubleBoundedConstraint) |
Visit(FalseConstraint) |
Visit(IntBoundedConstraint) |
Visit(IsIntegerConstraint) |
Visit(ItemTypeConstraint) |
Visit(NotConstraint) |
Visit(NumberOfSubOperatorsConstraint) |
Visit(OrConstraint) |
Visit(SubOperatorTypeConstraint) |
Visit(TrueConstraint) |

See Also

ConstraintVisitorBase Class
ConstraintVisitorBase Members
HeuristicLab.Constraints Namespace


Visit Method (AllSubOperatorsTypeConstraint)

ConstraintVisitorBase..::.Visit Method (AllSubOperatorsTypeConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.AllSubOperatorsTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    AllSubOperatorsTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(AllSubOperatorsTypeConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (AndConstraint)

ConstraintVisitorBase..::.Visit Method (AndConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.AndConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    AndConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.AndConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(AndConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (DoubleBoundedConstraint)

ConstraintVisitorBase..::.Visit Method (DoubleBoundedConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.DoubleBoundedConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    DoubleBoundedConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.DoubleBoundedConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(DoubleBoundedConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (FalseConstraint)

ConstraintVisitorBase..::.Visit Method (FalseConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.FalseConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    FalseConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.FalseConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(FalseConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (IntBoundedConstraint)

ConstraintVisitorBase..::.Visit Method (IntBoundedConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.IntBoundedConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    IntBoundedConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.IntBoundedConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(IntBoundedConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (IsIntegerConstraint)

ConstraintVisitorBase..::.Visit Method (IsIntegerConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.IsIntegerConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    IsIntegerConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.IsIntegerConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(IsIntegerConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (ItemTypeConstraint)

ConstraintVisitorBase..::.Visit Method (ItemTypeConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.ItemTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    ItemTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.ItemTypeConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(ItemTypeConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (NotConstraint)

ConstraintVisitorBase..::.Visit Method (NotConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.NotConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    NotConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.NotConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(NotConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (NumberOfSubOperatorsConstraint)

ConstraintVisitorBase..::.Visit Method (NumberOfSubOperatorsConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.NumberOfSubOperatorsConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    NumberOfSubOperatorsConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(NumberOfSubOperatorsConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (OrConstraint)

ConstraintVisitorBase..::.Visit Method (OrConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.OrConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    OrConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.OrConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(OrConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (SubOperatorTypeConstraint)

ConstraintVisitorBase..::.Visit Method (SubOperatorTypeConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.SubOperatorTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    SubOperatorTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.SubOperatorTypeConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(SubOperatorTypeConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (TrueConstraint)

ConstraintVisitorBase..::.Visit Method (TrueConstraint)
ConstraintVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ConstraintVisitorBase.Visit(HeuristicLab.Constraints.TrueConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    TrueConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.TrueConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(TrueConstraint)

See Also

ConstraintVisitorBase Class
Visit Overload
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Class

DoubleBoundedConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.DoubleBoundedConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleBoundedConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.DoubleBoundedConstraint

See Also

DoubleBoundedConstraint Members
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Members

[image]

HeuristicLab API Documentation
DoubleBoundedConstraint Members
DoubleBoundedConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleBoundedConstraint type exposes the following members.

Constructors

Name | Description
DoubleBoundedConstraint | Overloaded.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LowerBound |
LowerBoundEnabled |
LowerBoundIncluded |
UpperBound |
UpperBoundEnabled |
UpperBoundIncluded |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Constructor

[image]

HeuristicLab API Documentation
DoubleBoundedConstraint Constructor
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleBoundedConstraint()()() |
DoubleBoundedConstraint(Double, Double) |
DoubleBoundedConstraint(Double, Boolean, Double, Boolean) |

See Also

DoubleBoundedConstraint Class
DoubleBoundedConstraint Members
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Constructor

DoubleBoundedConstraint Constructor
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleBoundedConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleBoundedConstraint()

See Also

DoubleBoundedConstraint Class
DoubleBoundedConstraint Overload
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Constructor (Double, Double)

DoubleBoundedConstraint Constructor (Double, Double)
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleBoundedConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleBoundedConstraint(
    double lowerBound,
    double upperBound
)

Parameters

lowerBound
Type: System..::.Double

[Missing <param> documentation for "lowerBound"]

upperBound
Type: System..::.Double

[Missing <param> documentation for "upperBound"]

See Also

DoubleBoundedConstraint Class
DoubleBoundedConstraint Overload
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Constructor (Double, Boolean, Double, Boolean)

DoubleBoundedConstraint Constructor (Double, Boolean, Double, Boolean)
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleBoundedConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleBoundedConstraint(
    double lowerBound,
    bool lowerBoundIncluded,
    double upperBound,
    bool upperBoundIncluded
)

Parameters

lowerBound
Type: System..::.Double

[Missing <param> documentation for "lowerBound"]

lowerBoundIncluded
Type: System..::.Boolean

[Missing <param> documentation for "lowerBoundIncluded"]

upperBound
Type: System..::.Double

[Missing <param> documentation for "upperBound"]

upperBoundIncluded
Type: System..::.Boolean

[Missing <param> documentation for "upperBoundIncluded"]

See Also

DoubleBoundedConstraint Class
DoubleBoundedConstraint Overload
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Methods

[image]

HeuristicLab API Documentation
DoubleBoundedConstraint Methods
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleBoundedConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

DoubleBoundedConstraint..::.Accept Method
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


Check Method

DoubleBoundedConstraint..::.Check Method
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraint..::.Clone Method
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

DoubleBoundedConstraint Class
DoubleBoundedConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

DoubleBoundedConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

DoubleBoundedConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

DoubleBoundedConstraint..::.CreateView Method
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

DoubleBoundedConstraint..::.GetXmlNode Method
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

DoubleBoundedConstraint..::.Populate Method
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Properties

[image]

HeuristicLab API Documentation
DoubleBoundedConstraint Properties
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleBoundedConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LowerBound |
LowerBoundEnabled |
LowerBoundIncluded |
UpperBound |
UpperBoundEnabled |
UpperBoundIncluded |

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


Description Property

DoubleBoundedConstraint..::.Description Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


LowerBound Property

DoubleBoundedConstraint..::.LowerBound Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.LowerBound]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double LowerBound { get; set; }

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


LowerBoundEnabled Property

DoubleBoundedConstraint..::.LowerBoundEnabled Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.LowerBoundEnabled]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool LowerBoundEnabled { get; set; }

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


LowerBoundIncluded Property

DoubleBoundedConstraint..::.LowerBoundIncluded Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.LowerBoundIncluded]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool LowerBoundIncluded { get; set; }

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


UpperBound Property

DoubleBoundedConstraint..::.UpperBound Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.UpperBound]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double UpperBound { get; set; }

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


UpperBoundEnabled Property

DoubleBoundedConstraint..::.UpperBoundEnabled Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.UpperBoundEnabled]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool UpperBoundEnabled { get; set; }

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


UpperBoundIncluded Property

DoubleBoundedConstraint..::.UpperBoundIncluded Property
DoubleBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraint.UpperBoundIncluded]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool UpperBoundIncluded { get; set; }

See Also

DoubleBoundedConstraint Class
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Class

DoubleBoundedConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.DoubleBoundedConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleBoundedConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.DoubleBoundedConstraintView

See Also

DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Members

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView Members
DoubleBoundedConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleBoundedConstraintView type exposes the following members.

Constructors

Name | Description
DoubleBoundedConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBoundedConstraint |
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Constructor

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView Constructor
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleBoundedConstraintView()()() |
DoubleBoundedConstraintView(DoubleBoundedConstraint) |

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Constructor

DoubleBoundedConstraintView Constructor
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleBoundedConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleBoundedConstraintView()

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Overload
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Constructor (DoubleBoundedConstraint)

DoubleBoundedConstraintView Constructor (DoubleBoundedConstraint)
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleBoundedConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleBoundedConstraintView(
    DoubleBoundedConstraint doubleBoundedConstraint
)

Parameters

doubleBoundedConstraint
Type: HeuristicLab.Constraints..::.DoubleBoundedConstraint

[Missing <param> documentation for "doubleBoundedConstraint"]

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Overload
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Methods

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView Methods
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleBoundedConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.AccessibilityNotifyClients Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

DoubleBoundedConstraintView..::.AddItemEvents Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.BeginInvoke Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.Dispose Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

DoubleBoundedConstraintView..::.Dispose Method (Boolean)
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DoubleBoundedConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.GetChildAtPoint Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.Invalidate Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.Invoke Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.MemberwiseClone Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.PerformLayout Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

DoubleBoundedConstraintView..::.RemoveItemEvents Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.ResumeLayout Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.RtlTranslateAlignment Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.Scale Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.Select Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.SetBounds Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.UpdateBounds Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

DoubleBoundedConstraintView..::.UpdateControls Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.DoubleBoundedConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.Validate Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView..::.ValidateChildren Method
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DoubleBoundedConstraintView Class
DoubleBoundedConstraintView Members
HeuristicLab.Constraints Namespace


DoubleBoundedConstraintView Properties

[image]

HeuristicLab API Documentation
DoubleBoundedConstraintView Properties
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleBoundedConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBoundedConstraint |
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


DoubleBoundedConstraint Property

DoubleBoundedConstraintView..::.DoubleBoundedConstraint Property
DoubleBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.DoubleBoundedConstraintView.DoubleBoundedConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleBoundedConstraint DoubleBoundedConstraint { get; set; }

See Also

DoubleBoundedConstraintView Class
HeuristicLab.Constraints Namespace


FalseConstraint Class

FalseConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.FalseConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FalseConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.FalseConstraint

See Also

FalseConstraint Members
HeuristicLab.Constraints Namespace


FalseConstraint Members

[image]

HeuristicLab API Documentation
FalseConstraint Members
FalseConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FalseConstraint type exposes the following members.

Constructors

Name | Description
FalseConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


FalseConstraint Constructor

FalseConstraint Constructor
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FalseConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FalseConstraint()

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


FalseConstraint Methods

[image]

HeuristicLab API Documentation
FalseConstraint Methods
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FalseConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

FalseConstraint..::.Accept Method
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.FalseConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


Check Method

FalseConstraint..::.Check Method
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.FalseConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.FalseConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
FalseConstraint..::.Clone Method
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

FalseConstraint Class
FalseConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

FalseConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.FalseConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.FalseConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

FalseConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

FalseConstraint..::.CreateView Method
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.FalseConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.FalseConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


FalseConstraint Properties

[image]

HeuristicLab API Documentation
FalseConstraint Properties
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FalseConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


Description Property

FalseConstraint..::.Description Property
FalseConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.FalseConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

FalseConstraint Class
HeuristicLab.Constraints Namespace


FalseConstraintView Class

FalseConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.FalseConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FalseConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.FalseConstraintView

See Also

FalseConstraintView Members
HeuristicLab.Constraints Namespace


FalseConstraintView Members

[image]

HeuristicLab API Documentation
FalseConstraintView Members
FalseConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FalseConstraintView type exposes the following members.

Constructors

Name | Description
FalseConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FalseConstraint |
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FalseConstraintView Class
HeuristicLab.Constraints Namespace


FalseConstraintView Constructor

[image]

HeuristicLab API Documentation
FalseConstraintView Constructor
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FalseConstraintView()()() |
FalseConstraintView(FalseConstraint) |

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


FalseConstraintView Constructor

FalseConstraintView Constructor
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FalseConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FalseConstraintView()

See Also

FalseConstraintView Class
FalseConstraintView Overload
HeuristicLab.Constraints Namespace


FalseConstraintView Constructor (FalseConstraint)

FalseConstraintView Constructor (FalseConstraint)
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FalseConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FalseConstraintView(
    FalseConstraint falseConstraint
)

Parameters

falseConstraint
Type: HeuristicLab.Constraints..::.FalseConstraint

[Missing <param> documentation for "falseConstraint"]

See Also

FalseConstraintView Class
FalseConstraintView Overload
HeuristicLab.Constraints Namespace


FalseConstraintView Methods

[image]

HeuristicLab API Documentation
FalseConstraintView Methods
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FalseConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

FalseConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.AccessibilityNotifyClients Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.BeginInvoke Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.Dispose Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

FalseConstraintView..::.Dispose Method (Boolean)
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

FalseConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.GetChildAtPoint Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.Invalidate Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.Invoke Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.MemberwiseClone Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.PerformLayout Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.ResumeLayout Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.RtlTranslateAlignment Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.Scale Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.Select Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.SetBounds Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.UpdateBounds Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.Validate Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
FalseConstraintView..::.ValidateChildren Method
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

FalseConstraintView Class
FalseConstraintView Members
HeuristicLab.Constraints Namespace


FalseConstraintView Properties

[image]

HeuristicLab API Documentation
FalseConstraintView Properties
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FalseConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
FalseConstraint |
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

FalseConstraintView Class
HeuristicLab.Constraints Namespace


FalseConstraint Property

FalseConstraintView..::.FalseConstraint Property
FalseConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.FalseConstraintView.FalseConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FalseConstraint FalseConstraint { get; set; }

See Also

FalseConstraintView Class
HeuristicLab.Constraints Namespace


HeuristicLabConstraintsPlugin Class

HeuristicLabConstraintsPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.HeuristicLabConstraintsPlugin]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "HeuristicLab.Constraints")]
[PluginFileAttribute(Filename = "HeuristicLab.Constraints.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
public class HeuristicLabConstraintsPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Constraints..::.HeuristicLabConstraintsPlugin

See Also

HeuristicLabConstraintsPlugin Members
HeuristicLab.Constraints Namespace


HeuristicLabConstraintsPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabConstraintsPlugin Members
HeuristicLabConstraintsPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabConstraintsPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabConstraintsPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabConstraintsPlugin Class
HeuristicLab.Constraints Namespace


HeuristicLabConstraintsPlugin Constructor

HeuristicLabConstraintsPlugin Constructor
HeuristicLabConstraintsPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabConstraintsPlugin class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabConstraintsPlugin()

See Also

HeuristicLabConstraintsPlugin Class
HeuristicLab.Constraints Namespace


IConstraintVisitor Interface

IConstraintVisitor Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.IConstraintVisitor]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IConstraintVisitor

See Also

IConstraintVisitor Members
HeuristicLab.Constraints Namespace


IConstraintVisitor Members

[image]

HeuristicLab API Documentation
IConstraintVisitor Members
IConstraintVisitor Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Methods

Name | Description
Visit | Overloaded.

See Also

IConstraintVisitor Interface
HeuristicLab.Constraints Namespace


IConstraintVisitor Methods

[image]

HeuristicLab API Documentation
IConstraintVisitor Methods
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Methods

Name | Description
Visit | Overloaded.

See Also

IConstraintVisitor Interface
HeuristicLab.Constraints Namespace


Visit Method

[image]

HeuristicLab API Documentation
IConstraintVisitor..::.Visit Method
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Visit(AllSubOperatorsTypeConstraint) |
Visit(AndConstraint) |
Visit(DoubleBoundedConstraint) |
Visit(FalseConstraint) |
Visit(IntBoundedConstraint) |
Visit(IsIntegerConstraint) |
Visit(ItemTypeConstraint) |
Visit(NotConstraint) |
Visit(NumberOfSubOperatorsConstraint) |
Visit(OrConstraint) |
Visit(SubOperatorTypeConstraint) |
Visit(TrueConstraint) |

See Also

IConstraintVisitor Interface
IConstraintVisitor Members
HeuristicLab.Constraints Namespace


Visit Method (AllSubOperatorsTypeConstraint)

IConstraintVisitor..::.Visit Method (AllSubOperatorsTypeConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.AllSubOperatorsTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    AllSubOperatorsTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (AndConstraint)

IConstraintVisitor..::.Visit Method (AndConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.AndConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    AndConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.AndConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (DoubleBoundedConstraint)

IConstraintVisitor..::.Visit Method (DoubleBoundedConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.DoubleBoundedConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    DoubleBoundedConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.DoubleBoundedConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (FalseConstraint)

IConstraintVisitor..::.Visit Method (FalseConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.FalseConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    FalseConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.FalseConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (IntBoundedConstraint)

IConstraintVisitor..::.Visit Method (IntBoundedConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.IntBoundedConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IntBoundedConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.IntBoundedConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (IsIntegerConstraint)

IConstraintVisitor..::.Visit Method (IsIntegerConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.IsIntegerConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IsIntegerConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.IsIntegerConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (ItemTypeConstraint)

IConstraintVisitor..::.Visit Method (ItemTypeConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.ItemTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    ItemTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.ItemTypeConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (NotConstraint)

IConstraintVisitor..::.Visit Method (NotConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.NotConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    NotConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.NotConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (NumberOfSubOperatorsConstraint)

IConstraintVisitor..::.Visit Method (NumberOfSubOperatorsConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.NumberOfSubOperatorsConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    NumberOfSubOperatorsConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (OrConstraint)

IConstraintVisitor..::.Visit Method (OrConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.OrConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    OrConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.OrConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (SubOperatorTypeConstraint)

IConstraintVisitor..::.Visit Method (SubOperatorTypeConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.SubOperatorTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    SubOperatorTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.SubOperatorTypeConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


Visit Method (TrueConstraint)

IConstraintVisitor..::.Visit Method (TrueConstraint)
IConstraintVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IConstraintVisitor.Visit(HeuristicLab.Constraints.TrueConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    TrueConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.TrueConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstraintVisitor Interface
Visit Overload
HeuristicLab.Constraints Namespace


IntBoundedConstraint Class

IntBoundedConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.IntBoundedConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntBoundedConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.IntBoundedConstraint

See Also

IntBoundedConstraint Members
HeuristicLab.Constraints Namespace


IntBoundedConstraint Members

[image]

HeuristicLab API Documentation
IntBoundedConstraint Members
IntBoundedConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntBoundedConstraint type exposes the following members.

Constructors

Name | Description
IntBoundedConstraint | Overloaded.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LowerBound |
LowerBoundEnabled |
LowerBoundIncluded |
UpperBound |
UpperBoundEnabled |
UpperBoundIncluded |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


IntBoundedConstraint Constructor

[image]

HeuristicLab API Documentation
IntBoundedConstraint Constructor
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntBoundedConstraint()()() |
IntBoundedConstraint(Int32, Int32) |

See Also

IntBoundedConstraint Class
IntBoundedConstraint Members
HeuristicLab.Constraints Namespace


IntBoundedConstraint Constructor

IntBoundedConstraint Constructor
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntBoundedConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntBoundedConstraint()

See Also

IntBoundedConstraint Class
IntBoundedConstraint Overload
HeuristicLab.Constraints Namespace


IntBoundedConstraint Constructor (Int32, Int32)

IntBoundedConstraint Constructor (Int32, Int32)
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntBoundedConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntBoundedConstraint(
    int low,
    int high
)

Parameters

low
Type: System..::.Int32

[Missing <param> documentation for "low"]

high
Type: System..::.Int32

[Missing <param> documentation for "high"]

See Also

IntBoundedConstraint Class
IntBoundedConstraint Overload
HeuristicLab.Constraints Namespace


IntBoundedConstraint Methods

[image]

HeuristicLab API Documentation
IntBoundedConstraint Methods
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntBoundedConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

IntBoundedConstraint..::.Accept Method
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


Check Method

IntBoundedConstraint..::.Check Method
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
IntBoundedConstraint..::.Clone Method
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

IntBoundedConstraint Class
IntBoundedConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

IntBoundedConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

IntBoundedConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

IntBoundedConstraint..::.CreateView Method
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

IntBoundedConstraint..::.GetXmlNode Method
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

IntBoundedConstraint..::.Populate Method
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


IntBoundedConstraint Properties

[image]

HeuristicLab API Documentation
IntBoundedConstraint Properties
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntBoundedConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LowerBound |
LowerBoundEnabled |
LowerBoundIncluded |
UpperBound |
UpperBoundEnabled |
UpperBoundIncluded |

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


Description Property

IntBoundedConstraint..::.Description Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


LowerBound Property

IntBoundedConstraint..::.LowerBound Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.LowerBound]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int LowerBound { get; set; }

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


LowerBoundEnabled Property

IntBoundedConstraint..::.LowerBoundEnabled Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.LowerBoundEnabled]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool LowerBoundEnabled { get; set; }

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


LowerBoundIncluded Property

IntBoundedConstraint..::.LowerBoundIncluded Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.LowerBoundIncluded]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool LowerBoundIncluded { get; set; }

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


UpperBound Property

IntBoundedConstraint..::.UpperBound Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.UpperBound]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int UpperBound { get; set; }

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


UpperBoundEnabled Property

IntBoundedConstraint..::.UpperBoundEnabled Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.UpperBoundEnabled]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool UpperBoundEnabled { get; set; }

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


UpperBoundIncluded Property

IntBoundedConstraint..::.UpperBoundIncluded Property
IntBoundedConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraint.UpperBoundIncluded]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool UpperBoundIncluded { get; set; }

See Also

IntBoundedConstraint Class
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Class

IntBoundedConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.IntBoundedConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntBoundedConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.IntBoundedConstraintView

See Also

IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Members

[image]

HeuristicLab API Documentation
IntBoundedConstraintView Members
IntBoundedConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntBoundedConstraintView type exposes the following members.

Constructors

Name | Description
IntBoundedConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntBoundedConstraint |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Constructor

[image]

HeuristicLab API Documentation
IntBoundedConstraintView Constructor
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntBoundedConstraintView()()() |
IntBoundedConstraintView(IntBoundedConstraint) |

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Constructor

IntBoundedConstraintView Constructor
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntBoundedConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntBoundedConstraintView()

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Overload
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Constructor (IntBoundedConstraint)

IntBoundedConstraintView Constructor (IntBoundedConstraint)
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntBoundedConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntBoundedConstraintView(
    IntBoundedConstraint intBoundedConstraint
)

Parameters

intBoundedConstraint
Type: HeuristicLab.Constraints..::.IntBoundedConstraint

[Missing <param> documentation for "intBoundedConstraint"]

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Overload
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Methods

[image]

HeuristicLab API Documentation
IntBoundedConstraintView Methods
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntBoundedConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.AccessibilityNotifyClients Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

IntBoundedConstraintView..::.AddItemEvents Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.BeginInvoke Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.Dispose Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

IntBoundedConstraintView..::.Dispose Method (Boolean)
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

IntBoundedConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.GetChildAtPoint Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.Invalidate Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.Invoke Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.MemberwiseClone Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.PerformLayout Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

IntBoundedConstraintView..::.RemoveItemEvents Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.ResumeLayout Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.RtlTranslateAlignment Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.Scale Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.Select Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.SetBounds Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.UpdateBounds Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

IntBoundedConstraintView..::.UpdateControls Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IntBoundedConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.Validate Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
IntBoundedConstraintView..::.ValidateChildren Method
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

IntBoundedConstraintView Class
IntBoundedConstraintView Members
HeuristicLab.Constraints Namespace


IntBoundedConstraintView Properties

[image]

HeuristicLab API Documentation
IntBoundedConstraintView Properties
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntBoundedConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntBoundedConstraint |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


IntBoundedConstraint Property

IntBoundedConstraintView..::.IntBoundedConstraint Property
IntBoundedConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IntBoundedConstraintView.IntBoundedConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntBoundedConstraint IntBoundedConstraint { get; set; }

See Also

IntBoundedConstraintView Class
HeuristicLab.Constraints Namespace


IsIntegerConstraint Class

IsIntegerConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.IsIntegerConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IsIntegerConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.IsIntegerConstraint

See Also

IsIntegerConstraint Members
HeuristicLab.Constraints Namespace


IsIntegerConstraint Members

[image]

HeuristicLab API Documentation
IsIntegerConstraint Members
IsIntegerConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IsIntegerConstraint type exposes the following members.

Constructors

Name | Description
IsIntegerConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


IsIntegerConstraint Constructor

IsIntegerConstraint Constructor
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IsIntegerConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IsIntegerConstraint()

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


IsIntegerConstraint Methods

[image]

HeuristicLab API Documentation
IsIntegerConstraint Methods
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IsIntegerConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

IsIntegerConstraint..::.Accept Method
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IsIntegerConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


Check Method

IsIntegerConstraint..::.Check Method
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.IsIntegerConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.IsIntegerConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
IsIntegerConstraint..::.Clone Method
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from StorableBase.)

See Also

IsIntegerConstraint Class
IsIntegerConstraint Members
HeuristicLab.Constraints Namespace


IsIntegerConstraint Properties

[image]

HeuristicLab API Documentation
IsIntegerConstraint Properties
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IsIntegerConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


Description Property

IsIntegerConstraint..::.Description Property
IsIntegerConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.IsIntegerConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

IsIntegerConstraint Class
HeuristicLab.Constraints Namespace


ItemTypeConstraint Class

ItemTypeConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.ItemTypeConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemTypeConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.ItemTypeConstraint

See Also

ItemTypeConstraint Members
HeuristicLab.Constraints Namespace


ItemTypeConstraint Members

[image]

HeuristicLab API Documentation
ItemTypeConstraint Members
ItemTypeConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemTypeConstraint type exposes the following members.

Constructors

Name | Description
ItemTypeConstraint | Overloaded.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Type |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


ItemTypeConstraint Constructor

[image]

HeuristicLab API Documentation
ItemTypeConstraint Constructor
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ItemTypeConstraint()()() |
ItemTypeConstraint(Type) |

See Also

ItemTypeConstraint Class
ItemTypeConstraint Members
HeuristicLab.Constraints Namespace


ItemTypeConstraint Constructor

ItemTypeConstraint Constructor
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemTypeConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemTypeConstraint()

See Also

ItemTypeConstraint Class
ItemTypeConstraint Overload
HeuristicLab.Constraints Namespace


ItemTypeConstraint Constructor (Type)

ItemTypeConstraint Constructor (Type)
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemTypeConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemTypeConstraint(
    Type type
)

Parameters

type
Type: System..::.Type

[Missing <param> documentation for "type"]

See Also

ItemTypeConstraint Class
ItemTypeConstraint Overload
HeuristicLab.Constraints Namespace


ItemTypeConstraint Methods

[image]

HeuristicLab API Documentation
ItemTypeConstraint Methods
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemTypeConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

ItemTypeConstraint..::.Accept Method
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


Check Method

ItemTypeConstraint..::.Check Method
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
ItemTypeConstraint..::.Clone Method
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ItemTypeConstraint Class
ItemTypeConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

ItemTypeConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ItemTypeConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

ItemTypeConstraint..::.CreateView Method
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

ItemTypeConstraint..::.GetXmlNode Method
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

ItemTypeConstraint..::.Populate Method
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


ItemTypeConstraint Properties

[image]

HeuristicLab API Documentation
ItemTypeConstraint Properties
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemTypeConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Type |

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


Description Property

ItemTypeConstraint..::.Description Property
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.ItemTypeConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


Type Property

ItemTypeConstraint..::.Type Property
ItemTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.ItemTypeConstraint.Type]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Type Type { get; set; }

See Also

ItemTypeConstraint Class
HeuristicLab.Constraints Namespace


ItemTypeConstraintView Class

ItemTypeConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.ItemTypeConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemTypeConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.ItemTypeConstraintView

See Also

ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


ItemTypeConstraintView Members

[image]

HeuristicLab API Documentation
ItemTypeConstraintView Members
ItemTypeConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemTypeConstraintView type exposes the following members.

Constructors

Name | Description
ItemTypeConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
HeuristicLab.Constraints Namespace


ItemTypeConstraintView Constructor

[image]

HeuristicLab API Documentation
ItemTypeConstraintView Constructor
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ItemTypeConstraintView()()() |
ItemTypeConstraintView(ItemTypeConstraint) |

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


ItemTypeConstraintView Constructor

ItemTypeConstraintView Constructor
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemTypeConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemTypeConstraintView()

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Overload
HeuristicLab.Constraints Namespace


ItemTypeConstraintView Constructor (ItemTypeConstraint)

ItemTypeConstraintView Constructor (ItemTypeConstraint)
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemTypeConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemTypeConstraintView(
    ItemTypeConstraint itemTypeConstraint
)

Parameters

itemTypeConstraint
Type: HeuristicLab.Constraints..::.ItemTypeConstraint

[Missing <param> documentation for "itemTypeConstraint"]

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Overload
HeuristicLab.Constraints Namespace


ItemTypeConstraintView Methods

[image]

HeuristicLab API Documentation
ItemTypeConstraintView Methods
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemTypeConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ItemTypeConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.AccessibilityNotifyClients Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

ItemTypeConstraintView..::.AddItemEvents Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ItemTypeConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.BeginInvoke Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.Dispose Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

ItemTypeConstraintView..::.Dispose Method (Boolean)
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ItemTypeConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.GetChildAtPoint Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.Invalidate Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.Invoke Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.MemberwiseClone Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.PerformLayout Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

ItemTypeConstraintView..::.RemoveItemEvents Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ItemTypeConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.ResumeLayout Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.RtlTranslateAlignment Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.Scale Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.Select Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.SetBounds Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.UpdateBounds Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

ItemTypeConstraintView..::.UpdateControls Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.ItemTypeConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ItemTypeConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.Validate Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ItemTypeConstraintView..::.ValidateChildren Method
ItemTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ItemTypeConstraintView Class
ItemTypeConstraintView Members
HeuristicLab.Constraints Namespace


NotConstraint Class

NotConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.NotConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NotConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.NotConstraint

See Also

NotConstraint Members
HeuristicLab.Constraints Namespace


NotConstraint Members

[image]

HeuristicLab API Documentation
NotConstraint Members
NotConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NotConstraint type exposes the following members.

Constructors

Name | Description
NotConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
SubConstraint |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


NotConstraint Constructor

NotConstraint Constructor
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NotConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NotConstraint()

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


NotConstraint Methods

[image]

HeuristicLab API Documentation
NotConstraint Methods
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NotConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

NotConstraint..::.Accept Method
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


Check Method

NotConstraint..::.Check Method
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NotConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
NotConstraint..::.Clone Method
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

NotConstraint Class
NotConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

NotConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NotConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

NotConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

NotConstraint..::.CreateView Method
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NotConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

NotConstraint..::.GetXmlNode Method
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NotConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

NotConstraint..::.Populate Method
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


NotConstraint Properties

[image]

HeuristicLab API Documentation
NotConstraint Properties
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NotConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
SubConstraint |

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


Description Property

NotConstraint..::.Description Property
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.NotConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


SubConstraint Property

NotConstraint..::.SubConstraint Property
NotConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.NotConstraint.SubConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstraintBase SubConstraint { get; set; }

See Also

NotConstraint Class
HeuristicLab.Constraints Namespace


NotConstraintView Class

NotConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.NotConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NotConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.NotConstraintView

See Also

NotConstraintView Members
HeuristicLab.Constraints Namespace


NotConstraintView Members

[image]

HeuristicLab API Documentation
NotConstraintView Members
NotConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NotConstraintView type exposes the following members.

Constructors

Name | Description
NotConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
NotConstraint |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


NotConstraintView Constructor

[image]

HeuristicLab API Documentation
NotConstraintView Constructor
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
NotConstraintView()()() |
NotConstraintView(NotConstraint) |

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


NotConstraintView Constructor

NotConstraintView Constructor
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NotConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NotConstraintView()

See Also

NotConstraintView Class
NotConstraintView Overload
HeuristicLab.Constraints Namespace


NotConstraintView Constructor (NotConstraint)

NotConstraintView Constructor (NotConstraint)
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NotConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NotConstraintView(
    NotConstraint notConstraint
)

Parameters

notConstraint
Type: HeuristicLab.Constraints..::.NotConstraint

[Missing <param> documentation for "notConstraint"]

See Also

NotConstraintView Class
NotConstraintView Overload
HeuristicLab.Constraints Namespace


NotConstraintView Methods

[image]

HeuristicLab API Documentation
NotConstraintView Methods
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NotConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.AccessibilityNotifyClients Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

NotConstraintView..::.AddItemEvents Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.BeginInvoke Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.Dispose Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

NotConstraintView..::.Dispose Method (Boolean)
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

NotConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.GetChildAtPoint Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.Invalidate Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.Invoke Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.MemberwiseClone Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.PerformLayout Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

NotConstraintView..::.RemoveItemEvents Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.ResumeLayout Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.RtlTranslateAlignment Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.Scale Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.Select Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.SetBounds Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.UpdateBounds Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

NotConstraintView..::.UpdateControls Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NotConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.Validate Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
NotConstraintView..::.ValidateChildren Method
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

NotConstraintView Class
NotConstraintView Members
HeuristicLab.Constraints Namespace


NotConstraintView Properties

[image]

HeuristicLab API Documentation
NotConstraintView Properties
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NotConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
NotConstraint |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


NotConstraint Property

NotConstraintView..::.NotConstraint Property
NotConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.NotConstraintView.NotConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NotConstraint NotConstraint { get; set; }

See Also

NotConstraintView Class
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Class

NumberOfSubOperatorsConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NumberOfSubOperatorsConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraint

See Also

NumberOfSubOperatorsConstraint Members
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Members

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraint Members
NumberOfSubOperatorsConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NumberOfSubOperatorsConstraint type exposes the following members.

Constructors

Name | Description
NumberOfSubOperatorsConstraint | Overloaded.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
MaxOperators |
MinOperators |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Constructor

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraint Constructor
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
NumberOfSubOperatorsConstraint()()() |
NumberOfSubOperatorsConstraint(Int32, Int32) |

See Also

NumberOfSubOperatorsConstraint Class
NumberOfSubOperatorsConstraint Members
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Constructor

NumberOfSubOperatorsConstraint Constructor
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NumberOfSubOperatorsConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NumberOfSubOperatorsConstraint()

See Also

NumberOfSubOperatorsConstraint Class
NumberOfSubOperatorsConstraint Overload
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Constructor (Int32, Int32)

NumberOfSubOperatorsConstraint Constructor (Int32, Int32)
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NumberOfSubOperatorsConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NumberOfSubOperatorsConstraint(
    int min,
    int max
)

Parameters

min
Type: System..::.Int32

[Missing <param> documentation for "min"]

max
Type: System..::.Int32

[Missing <param> documentation for "max"]

See Also

NumberOfSubOperatorsConstraint Class
NumberOfSubOperatorsConstraint Overload
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Methods

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraint Methods
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NumberOfSubOperatorsConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

NumberOfSubOperatorsConstraint..::.Accept Method
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


Check Method

NumberOfSubOperatorsConstraint..::.Check Method
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraint..::.Clone Method
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

NumberOfSubOperatorsConstraint Class
NumberOfSubOperatorsConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

NumberOfSubOperatorsConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

NumberOfSubOperatorsConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

NumberOfSubOperatorsConstraint..::.CreateView Method
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

NumberOfSubOperatorsConstraint..::.GetXmlNode Method
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

NumberOfSubOperatorsConstraint..::.Populate Method
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraint Properties

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraint Properties
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NumberOfSubOperatorsConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
MaxOperators |
MinOperators |

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


Description Property

NumberOfSubOperatorsConstraint..::.Description Property
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


MaxOperators Property

NumberOfSubOperatorsConstraint..::.MaxOperators Property
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.MaxOperators]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData MaxOperators { get; }

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


MinOperators Property

NumberOfSubOperatorsConstraint..::.MinOperators Property
NumberOfSubOperatorsConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.NumberOfSubOperatorsConstraint.MinOperators]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData MinOperators { get; }

See Also

NumberOfSubOperatorsConstraint Class
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraintView Class

NumberOfSubOperatorsConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.NumberOfSubOperatorsConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NumberOfSubOperatorsConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraintView

See Also

NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraintView Members

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView Members
NumberOfSubOperatorsConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NumberOfSubOperatorsConstraintView type exposes the following members.

Constructors

Name | Description
NumberOfSubOperatorsConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraintView Constructor

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView Constructor
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
NumberOfSubOperatorsConstraintView()()() |
NumberOfSubOperatorsConstraintView(NumberOfSubOperatorsConstraint) |

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraintView Constructor

NumberOfSubOperatorsConstraintView Constructor
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NumberOfSubOperatorsConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NumberOfSubOperatorsConstraintView()

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Overload
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraintView Constructor (NumberOfSubOperatorsConstraint)

NumberOfSubOperatorsConstraintView Constructor (NumberOfSubOperatorsConstraint)
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NumberOfSubOperatorsConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NumberOfSubOperatorsConstraintView(
    NumberOfSubOperatorsConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraint

[Missing <param> documentation for "constraint"]

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Overload
HeuristicLab.Constraints Namespace


NumberOfSubOperatorsConstraintView Methods

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView Methods
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NumberOfSubOperatorsConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

NumberOfSubOperatorsConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.AccessibilityNotifyClients Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.BeginInvoke Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.Dispose Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

NumberOfSubOperatorsConstraintView..::.Dispose Method (Boolean)
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

NumberOfSubOperatorsConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.GetChildAtPoint Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.Invalidate Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.Invoke Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.MemberwiseClone Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.PerformLayout Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.ResumeLayout Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.RtlTranslateAlignment Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.Scale Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.Select Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.SetBounds Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.UpdateBounds Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.Validate Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
NumberOfSubOperatorsConstraintView..::.ValidateChildren Method
NumberOfSubOperatorsConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

NumberOfSubOperatorsConstraintView Class
NumberOfSubOperatorsConstraintView Members
HeuristicLab.Constraints Namespace


OrConstraint Class

OrConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.OrConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OrConstraint : ConstraintBase, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.OrConstraint

See Also

OrConstraint Members
HeuristicLab.Constraints Namespace


OrConstraint Members

[image]

HeuristicLab API Documentation
OrConstraint Members
OrConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrConstraint type exposes the following members.

Constructors

Name | Description
OrConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Clauses |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


OrConstraint Constructor

OrConstraint Constructor
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OrConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OrConstraint()

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


OrConstraint Methods

[image]

HeuristicLab API Documentation
OrConstraint Methods
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

OrConstraint..::.Accept Method
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


Check Method

OrConstraint..::.Check Method
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.OrConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
OrConstraint..::.Clone Method
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

OrConstraint Class
OrConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

OrConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.OrConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

OrConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

OrConstraint..::.CreateView Method
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.OrConstraint.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

OrConstraint..::.GetXmlNode Method
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.OrConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

OrConstraint..::.Populate Method
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


OrConstraint Properties

[image]

HeuristicLab API Documentation
OrConstraint Properties
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrConstraint type exposes the following members.

Properties

Name | Description
Clauses |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


Clauses Property

OrConstraint..::.Clauses Property
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.OrConstraint.Clauses]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Clauses { get; set; }

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


Description Property

OrConstraint..::.Description Property
OrConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.OrConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

OrConstraint Class
HeuristicLab.Constraints Namespace


OrConstraintView Class

OrConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.OrConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OrConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.OrConstraintView

See Also

OrConstraintView Members
HeuristicLab.Constraints Namespace


OrConstraintView Members

[image]

HeuristicLab API Documentation
OrConstraintView Members
OrConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrConstraintView type exposes the following members.

Constructors

Name | Description
OrConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OrConstraintView Class
HeuristicLab.Constraints Namespace


OrConstraintView Constructor

[image]

HeuristicLab API Documentation
OrConstraintView Constructor
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OrConstraintView()()() |
OrConstraintView(OrConstraint) |

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


OrConstraintView Constructor

OrConstraintView Constructor
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OrConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OrConstraintView()

See Also

OrConstraintView Class
OrConstraintView Overload
HeuristicLab.Constraints Namespace


OrConstraintView Constructor (OrConstraint)

OrConstraintView Constructor (OrConstraint)
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OrConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OrConstraintView(
    OrConstraint orConstraint
)

Parameters

orConstraint
Type: HeuristicLab.Constraints..::.OrConstraint

[Missing <param> documentation for "orConstraint"]

See Also

OrConstraintView Class
OrConstraintView Overload
HeuristicLab.Constraints Namespace


OrConstraintView Methods

[image]

HeuristicLab API Documentation
OrConstraintView Methods
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OrConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.AccessibilityNotifyClients Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

OrConstraintView..::.AddItemEvents Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

OrConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.BeginInvoke Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.Dispose Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

OrConstraintView..::.Dispose Method (Boolean)
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OrConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.GetChildAtPoint Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.Invalidate Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.Invoke Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.MemberwiseClone Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.PerformLayout Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

OrConstraintView..::.RemoveItemEvents Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

OrConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.ResumeLayout Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.RtlTranslateAlignment Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.Scale Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.Select Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.SetBounds Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.UpdateBounds Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

OrConstraintView..::.UpdateControls Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.OrConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OrConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.Validate Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OrConstraintView..::.ValidateChildren Method
OrConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OrConstraintView Class
OrConstraintView Members
HeuristicLab.Constraints Namespace


SubOperatorsConstraintAnalyser Class

SubOperatorsConstraintAnalyser Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubOperatorsConstraintAnalyser

Inheritance Hierarchy

System..::.Object
HeuristicLab.Constraints..::.SubOperatorsConstraintAnalyser

See Also

SubOperatorsConstraintAnalyser Members
HeuristicLab.Constraints Namespace


SubOperatorsConstraintAnalyser Members

[image]

HeuristicLab API Documentation
SubOperatorsConstraintAnalyser Members
SubOperatorsConstraintAnalyser Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorsConstraintAnalyser type exposes the following members.

Constructors

Name | Description
SubOperatorsConstraintAnalyser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllowedOperators |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllPossibleOperators |

See Also

SubOperatorsConstraintAnalyser Class
HeuristicLab.Constraints Namespace


SubOperatorsConstraintAnalyser Constructor

SubOperatorsConstraintAnalyser Constructor
SubOperatorsConstraintAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubOperatorsConstraintAnalyser class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubOperatorsConstraintAnalyser()

See Also

SubOperatorsConstraintAnalyser Class
HeuristicLab.Constraints Namespace


SubOperatorsConstraintAnalyser Methods

[image]

HeuristicLab API Documentation
SubOperatorsConstraintAnalyser Methods
SubOperatorsConstraintAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorsConstraintAnalyser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllowedOperators |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubOperatorsConstraintAnalyser Class
HeuristicLab.Constraints Namespace


GetAllowedOperators Method

SubOperatorsConstraintAnalyser..::.GetAllowedOperators Method
SubOperatorsConstraintAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperators(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IOperator> GetAllowedOperators(
    IOperator op,
    int childIndex
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

childIndex
Type: System..::.Int32

[Missing <param> documentation for "childIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperators(HeuristicLab.Core.IOperator,System.Int32)]

See Also

SubOperatorsConstraintAnalyser Class
HeuristicLab.Constraints Namespace


SubOperatorsConstraintAnalyser Properties

[image]

HeuristicLab API Documentation
SubOperatorsConstraintAnalyser Properties
SubOperatorsConstraintAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorsConstraintAnalyser type exposes the following members.

Properties

Name | Description
AllPossibleOperators |

See Also

SubOperatorsConstraintAnalyser Class
HeuristicLab.Constraints Namespace


AllPossibleOperators Property

SubOperatorsConstraintAnalyser..::.AllPossibleOperators Property
SubOperatorsConstraintAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.AllPossibleOperators]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IOperator> AllPossibleOperators { get; set; }

See Also

SubOperatorsConstraintAnalyser Class
HeuristicLab.Constraints Namespace


SubOperatorsTypeConstraintView Class

SubOperatorsTypeConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.SubOperatorsTypeConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubOperatorsTypeConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.SubOperatorsTypeConstraintView

See Also

SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


SubOperatorsTypeConstraintView Members

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView Members
SubOperatorsTypeConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorsTypeConstraintView type exposes the following members.

Constructors

Name | Description
SubOperatorsTypeConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
HeuristicLab.Constraints Namespace


SubOperatorsTypeConstraintView Constructor

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView Constructor
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SubOperatorsTypeConstraintView()()() |
SubOperatorsTypeConstraintView(SubOperatorTypeConstraint) |

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


SubOperatorsTypeConstraintView Constructor

SubOperatorsTypeConstraintView Constructor
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubOperatorsTypeConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubOperatorsTypeConstraintView()

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Overload
HeuristicLab.Constraints Namespace


SubOperatorsTypeConstraintView Constructor (SubOperatorTypeConstraint)

SubOperatorsTypeConstraintView Constructor (SubOperatorTypeConstraint)
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubOperatorsTypeConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubOperatorsTypeConstraintView(
    SubOperatorTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.SubOperatorTypeConstraint

[Missing <param> documentation for "constraint"]

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Overload
HeuristicLab.Constraints Namespace


SubOperatorsTypeConstraintView Methods

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView Methods
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorsTypeConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

SubOperatorsTypeConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.AccessibilityNotifyClients Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.BeginInvoke Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.Dispose Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

SubOperatorsTypeConstraintView..::.Dispose Method (Boolean)
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SubOperatorsTypeConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.GetChildAtPoint Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.Invalidate Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.Invoke Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.MemberwiseClone Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.PerformLayout Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.ResumeLayout Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.RtlTranslateAlignment Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.Scale Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.Select Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.SetBounds Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.UpdateBounds Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.Validate Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
SubOperatorsTypeConstraintView..::.ValidateChildren Method
SubOperatorsTypeConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SubOperatorsTypeConstraintView Class
SubOperatorsTypeConstraintView Members
HeuristicLab.Constraints Namespace


SubOperatorTypeConstraint Class

SubOperatorTypeConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.SubOperatorTypeConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubOperatorTypeConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.SubOperatorTypeConstraint

See Also

SubOperatorTypeConstraint Members
HeuristicLab.Constraints Namespace


SubOperatorTypeConstraint Members

[image]

HeuristicLab API Documentation
SubOperatorTypeConstraint Members
SubOperatorTypeConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorTypeConstraint type exposes the following members.

Constructors

Name | Description
SubOperatorTypeConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
AddOperator |
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
ToString | (Inherited from ItemBase.)

Properties

Name | Description
AllowedSubOperators |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
SubOperatorIndex |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


SubOperatorTypeConstraint Constructor

SubOperatorTypeConstraint Constructor
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubOperatorTypeConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubOperatorTypeConstraint()

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


SubOperatorTypeConstraint Methods

[image]

HeuristicLab API Documentation
SubOperatorTypeConstraint Methods
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorTypeConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
AddOperator |
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
ToString | (Inherited from ItemBase.)

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

SubOperatorTypeConstraint..::.Accept Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


AddOperator Method

SubOperatorTypeConstraint..::.AddOperator Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


Check Method

SubOperatorTypeConstraint..::.Check Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
SubOperatorTypeConstraint..::.Clone Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

SubOperatorTypeConstraint Class
SubOperatorTypeConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

SubOperatorTypeConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

SubOperatorTypeConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

SubOperatorTypeConstraint..::.CreateView Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

SubOperatorTypeConstraint..::.GetXmlNode Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

SubOperatorTypeConstraint..::.Populate Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


RemoveOperator Method

SubOperatorTypeConstraint..::.RemoveOperator Method
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorTypeConstraint.RemoveOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


SubOperatorTypeConstraint Properties

[image]

HeuristicLab API Documentation
SubOperatorTypeConstraint Properties
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubOperatorTypeConstraint type exposes the following members.

Properties

Name | Description
AllowedSubOperators |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
SubOperatorIndex |

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


AllowedSubOperators Property

SubOperatorTypeConstraint..::.AllowedSubOperators Property
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.SubOperatorTypeConstraint.AllowedSubOperators]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IOperator> AllowedSubOperators { get; }

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


Description Property

SubOperatorTypeConstraint..::.Description Property
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.SubOperatorTypeConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


SubOperatorIndex Property

SubOperatorTypeConstraint..::.SubOperatorIndex Property
SubOperatorTypeConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.SubOperatorTypeConstraint.SubOperatorIndex]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData SubOperatorIndex { get; }

See Also

SubOperatorTypeConstraint Class
HeuristicLab.Constraints Namespace


TrueConstraint Class

TrueConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.TrueConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TrueConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.TrueConstraint

See Also

TrueConstraint Members
HeuristicLab.Constraints Namespace


TrueConstraint Members

[image]

HeuristicLab API Documentation
TrueConstraint Members
TrueConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TrueConstraint type exposes the following members.

Constructors

Name | Description
TrueConstraint |

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


TrueConstraint Constructor

TrueConstraint Constructor
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TrueConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TrueConstraint()

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


TrueConstraint Methods

[image]

HeuristicLab API Documentation
TrueConstraint Methods
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TrueConstraint type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstraintBase ..::. Accept(IConstraintVisitor).)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Inherited from ItemBase.)

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


Accept Method

TrueConstraint..::.Accept Method
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.TrueConstraint.Accept(HeuristicLab.Constraints.IConstraintVisitor)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IConstraintVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Constraints..::.IConstraintVisitor

[Missing <param> documentation for "visitor"]

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


Check Method

TrueConstraint..::.Check Method
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.TrueConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.TrueConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
TrueConstraint..::.Clone Method
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

TrueConstraint Class
TrueConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

TrueConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.TrueConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.TrueConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

TrueConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

TrueConstraint..::.CreateView Method
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.TrueConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.TrueConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


TrueConstraint Properties

[image]

HeuristicLab API Documentation
TrueConstraint Properties
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TrueConstraint type exposes the following members.

Properties

Name | Description
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


Description Property

TrueConstraint..::.Description Property
TrueConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.TrueConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

TrueConstraint Class
HeuristicLab.Constraints Namespace


TrueConstraintView Class

TrueConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.TrueConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TrueConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.TrueConstraintView

See Also

TrueConstraintView Members
HeuristicLab.Constraints Namespace


TrueConstraintView Members

[image]

HeuristicLab API Documentation
TrueConstraintView Members
TrueConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TrueConstraintView type exposes the following members.

Constructors

Name | Description
TrueConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TrueConstraint |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TrueConstraintView Class
HeuristicLab.Constraints Namespace


TrueConstraintView Constructor

[image]

HeuristicLab API Documentation
TrueConstraintView Constructor
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TrueConstraintView()()() |
TrueConstraintView(TrueConstraint) |

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


TrueConstraintView Constructor

TrueConstraintView Constructor
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TrueConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TrueConstraintView()

See Also

TrueConstraintView Class
TrueConstraintView Overload
HeuristicLab.Constraints Namespace


TrueConstraintView Constructor (TrueConstraint)

TrueConstraintView Constructor (TrueConstraint)
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TrueConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TrueConstraintView(
    TrueConstraint trueConstraint
)

Parameters

trueConstraint
Type: HeuristicLab.Constraints..::.TrueConstraint

[Missing <param> documentation for "trueConstraint"]

See Also

TrueConstraintView Class
TrueConstraintView Overload
HeuristicLab.Constraints Namespace


TrueConstraintView Methods

[image]

HeuristicLab API Documentation
TrueConstraintView Methods
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TrueConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

TrueConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.AccessibilityNotifyClients Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.BeginInvoke Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.Dispose Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

TrueConstraintView..::.Dispose Method (Boolean)
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

TrueConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.GetChildAtPoint Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.Invalidate Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.Invoke Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.MemberwiseClone Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.PerformLayout Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.ResumeLayout Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.RtlTranslateAlignment Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.Scale Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.Select Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.SetBounds Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.UpdateBounds Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.Validate Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
TrueConstraintView..::.ValidateChildren Method
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

TrueConstraintView Class
TrueConstraintView Members
HeuristicLab.Constraints Namespace


TrueConstraintView Properties

[image]

HeuristicLab API Documentation
TrueConstraintView Properties
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TrueConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TrueConstraint |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TrueConstraintView Class
HeuristicLab.Constraints Namespace


TrueConstraint Property

TrueConstraintView..::.TrueConstraint Property
TrueConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.TrueConstraintView.TrueConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TrueConstraint TrueConstraint { get; set; }

See Also

TrueConstraintView Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraint Class

VariableComparisonConstraint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.VariableComparisonConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableComparisonConstraint : ConstraintBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Constraints..::.VariableComparisonConstraint

See Also

VariableComparisonConstraint Members
HeuristicLab.Constraints Namespace


VariableComparisonConstraint Members

[image]

HeuristicLab API Documentation
VariableComparisonConstraint Members
VariableComparisonConstraint Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableComparisonConstraint type exposes the following members.

Constructors

Name | Description
VariableComparisonConstraint |

Methods

Name | Description
Accept | (Inherited from ConstraintBase.)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Comparer |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LeftVarName |
RightVarName |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraint Constructor

VariableComparisonConstraint Constructor
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableComparisonConstraint class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableComparisonConstraint()

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraint Methods

[image]

HeuristicLab API Documentation
VariableComparisonConstraint Methods
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableComparisonConstraint type exposes the following members.

Methods

Name | Description
Accept | (Inherited from ConstraintBase.)
Check | (Overrides ConstraintBase ..::. Check(IItem).)
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


Check Method

VariableComparisonConstraint..::.Check Method
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.Check(HeuristicLab.Core.IItem)]

Implements

IConstraint..::.Check(IItem)

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


Clone Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraint..::.Clone Method
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

VariableComparisonConstraint Class
VariableComparisonConstraint Members
HeuristicLab.Constraints Namespace


Clone Method (IDictionary(Guid, Object))

VariableComparisonConstraint..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

VariableComparisonConstraint Class
Clone Overload
HeuristicLab.Constraints Namespace


CreateView Method

VariableComparisonConstraint..::.CreateView Method
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.CreateView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


GetXmlNode Method

VariableComparisonConstraint..::.GetXmlNode Method
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


Populate Method

VariableComparisonConstraint..::.Populate Method
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraint.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraint Properties

[image]

HeuristicLab API Documentation
VariableComparisonConstraint Properties
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableComparisonConstraint type exposes the following members.

Properties

Name | Description
Comparer |
Description | (Overrides ConstraintBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LeftVarName |
RightVarName |

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


Comparer Property

VariableComparisonConstraint..::.Comparer Property
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.VariableComparisonConstraint.Comparer]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData Comparer { get; set; }

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


Description Property

VariableComparisonConstraint..::.Description Property
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.VariableComparisonConstraint.Description]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IConstraint..::.Description

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


LeftVarName Property

VariableComparisonConstraint..::.LeftVarName Property
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.VariableComparisonConstraint.LeftVarName]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringData LeftVarName { get; set; }

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


RightVarName Property

VariableComparisonConstraint..::.RightVarName Property
VariableComparisonConstraint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.VariableComparisonConstraint.RightVarName]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringData RightVarName { get; set; }

See Also

VariableComparisonConstraint Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Class

VariableComparisonConstraintView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Constraints.VariableComparisonConstraintView]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableComparisonConstraintView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.VariableComparisonConstraintView

See Also

VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Members

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView Members
VariableComparisonConstraintView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableComparisonConstraintView type exposes the following members.

Constructors

Name | Description
VariableComparisonConstraintView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableComparisonConstraint |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Constructor

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView Constructor
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
VariableComparisonConstraintView()()() |
VariableComparisonConstraintView(VariableComparisonConstraint) |

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Constructor

VariableComparisonConstraintView Constructor
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableComparisonConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableComparisonConstraintView()

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Overload
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Constructor (VariableComparisonConstraint)

VariableComparisonConstraintView Constructor (VariableComparisonConstraint)
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableComparisonConstraintView class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableComparisonConstraintView(
    VariableComparisonConstraint variableComparisonConstraint
)

Parameters

variableComparisonConstraint
Type: HeuristicLab.Constraints..::.VariableComparisonConstraint

[Missing <param> documentation for "variableComparisonConstraint"]

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Overload
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Methods

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView Methods
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableComparisonConstraintView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.AccessibilityNotifyClients Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


AddItemEvents Method

VariableComparisonConstraintView..::.AddItemEvents Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraintView.AddItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.BeginInvoke Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.Dispose Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


Dispose Method (Boolean)

VariableComparisonConstraintView..::.Dispose Method (Boolean)
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VariableComparisonConstraintView Class
Dispose Overload
HeuristicLab.Constraints Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.GetChildAtPoint Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.Invalidate Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


Invoke Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.Invoke Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.MemberwiseClone Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.PerformLayout Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


RemoveItemEvents Method

VariableComparisonConstraintView..::.RemoveItemEvents Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraintView.RemoveItemEvents]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.ResumeLayout Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.RtlTranslateAlignment Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


Scale Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.Scale Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


Select Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.Select Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.SetBounds Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.UpdateBounds Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


UpdateControls Method

VariableComparisonConstraintView..::.UpdateControls Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.VariableComparisonConstraintView.UpdateControls]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


Validate Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.Validate Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView..::.ValidateChildren Method
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

VariableComparisonConstraintView Class
VariableComparisonConstraintView Members
HeuristicLab.Constraints Namespace


VariableComparisonConstraintView Properties

[image]

HeuristicLab API Documentation
VariableComparisonConstraintView Properties
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableComparisonConstraintView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableComparisonConstraint |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


VariableComparisonConstraint Property

VariableComparisonConstraintView..::.VariableComparisonConstraint Property
VariableComparisonConstraintView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.VariableComparisonConstraintView.VariableComparisonConstraint]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableComparisonConstraint VariableComparisonConstraint { get; set; }

See Also

VariableComparisonConstraintView Class
HeuristicLab.Constraints Namespace


HeuristicLab.Core Namespace

HeuristicLab.Core Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

HeuristicLab.Core Namespace Summary (... to be continued ...)

Classes

Class | Description
AtomicOperation |
Auxiliary |
ChooseItemDialog |
ChooseOperatorDialog |
ChooseTypeDialog |
CompositeOperation |
ConstrainedItemBase |
ConstrainedItemBaseView |
ConstraintEventArgs |
EditorBase |
EngineBase |
EngineBaseEditor |
ExceptionEventArgs |
HeuristicLabCorePlugin |
ItemBase |
ItemBaseView |
ItemEventArgs |
ItemIndexEventArgs |
NameChangingEventArgs |
OperationEventArgs |
OperatorBase |
OperatorBaseDescriptionView |
OperatorBaseVariableInfosView |
OperatorBaseVariablesView |
OperatorBaseView |
OperatorEventArgs |
OperatorGraph |
OperatorGraphView |
OperatorGroup |
OperatorIndexEventArgs |
OperatorLibrary |
OperatorLibraryEditor |
PersistenceManager |
Scope |
ScopeEventArgs |
ScopeIndexEventArgs |
ScopeView |
StorableBase |
Variable |
VariableEventArgs |
VariableInfo |
VariableInfoEventArgs |
VariableInfoView |
VariablesScopeView |
VariableView |
ViewBase |

Interfaces

Interface | Description
IConstrainedItem |
IConstraint |
IEditable |
IEditor |
IEngine |
IItem |
IOperation |
IOperator |
IOperatorGraph |
IOperatorGroup |
IOperatorLibrary |
IRandom |
IScope |
IStorable |
IVariable |
IVariableInfo |
IView |
IViewable |
IVisualizationItem |

Enumerations

Enumeration | Description
VariableKind |


AtomicOperation Class

AtomicOperation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.AtomicOperation]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AtomicOperation : ItemBase, IOperation,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.AtomicOperation

See Also

AtomicOperation Members
HeuristicLab.Core Namespace


AtomicOperation Members

[image]

HeuristicLab API Documentation
AtomicOperation Members
AtomicOperation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AtomicOperation type exposes the following members.

Constructors

Name | Description
AtomicOperation | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Operator |
Scope |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


AtomicOperation Constructor

[image]

HeuristicLab API Documentation
AtomicOperation Constructor
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AtomicOperation()()() |
AtomicOperation(IOperator, IScope) |

See Also

AtomicOperation Class
AtomicOperation Members
HeuristicLab.Core Namespace


AtomicOperation Constructor

AtomicOperation Constructor
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AtomicOperation class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AtomicOperation()

See Also

AtomicOperation Class
AtomicOperation Overload
HeuristicLab.Core Namespace


AtomicOperation Constructor (IOperator, IScope)

AtomicOperation Constructor (IOperator, IScope)
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AtomicOperation class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AtomicOperation(
    IOperator op,
    IScope scope
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

AtomicOperation Class
AtomicOperation Overload
HeuristicLab.Core Namespace


AtomicOperation Methods

[image]

HeuristicLab API Documentation
AtomicOperation Methods
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AtomicOperation type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
AtomicOperation..::.Clone Method
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

AtomicOperation Class
AtomicOperation Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

AtomicOperation..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.AtomicOperation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.AtomicOperation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

AtomicOperation Class
Clone Overload
HeuristicLab.Core Namespace


GetXmlNode Method

AtomicOperation..::.GetXmlNode Method
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.AtomicOperation.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.AtomicOperation.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


Populate Method

AtomicOperation..::.Populate Method
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.AtomicOperation.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


AtomicOperation Properties

[image]

HeuristicLab API Documentation
AtomicOperation Properties
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AtomicOperation type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Operator |
Scope |

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


Operator Property

AtomicOperation..::.Operator Property
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.AtomicOperation.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; }

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


Scope Property

AtomicOperation..::.Scope Property
AtomicOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.AtomicOperation.Scope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope Scope { get; }

See Also

AtomicOperation Class
HeuristicLab.Core Namespace


Auxiliary Class

Auxiliary Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.Auxiliary]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static class Auxiliary

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.Auxiliary

See Also

Auxiliary Members
HeuristicLab.Core Namespace


Auxiliary Members

[image]

HeuristicLab API Documentation
Auxiliary Members
Auxiliary Class Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Auxiliary type exposes the following members.

Methods

Name | Description
Clone |
ShowConstraintViolationMessageBox |
ShowErrorMessageBox | Overloaded.
ShowIgnoreConstraintViolationMessageBox |

See Also

Auxiliary Class
HeuristicLab.Core Namespace


Auxiliary Methods

[image]

HeuristicLab API Documentation
Auxiliary Methods
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Auxiliary type exposes the following members.

Methods

Name | Description
Clone |
ShowConstraintViolationMessageBox |
ShowErrorMessageBox | Overloaded.
ShowIgnoreConstraintViolationMessageBox |

See Also

Auxiliary Class
HeuristicLab.Core Namespace


Clone Method

Auxiliary..::.Clone Method
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Auxiliary.Clone(HeuristicLab.Core.IStorable,System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static Object Clone(
    IStorable obj,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

obj
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "obj"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Auxiliary.Clone(HeuristicLab.Core.IStorable,System.Collections.Generic.IDictionary{System.Guid,System.Object})]

See Also

Auxiliary Class
HeuristicLab.Core Namespace


ShowConstraintViolationMessageBox Method

Auxiliary..::.ShowConstraintViolationMessageBox Method
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Auxiliary.ShowConstraintViolationMessageBox(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static void ShowConstraintViolationMessageBox(
    ICollection<IConstraint> violatedConstraints
)

Parameters

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>)

[Missing <param> documentation for "violatedConstraints"]

See Also

Auxiliary Class
HeuristicLab.Core Namespace


ShowErrorMessageBox Method

[image]

HeuristicLab API Documentation
Auxiliary..::.ShowErrorMessageBox Method
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowErrorMessageBox(Exception) |
ShowErrorMessageBox(String) |

See Also

Auxiliary Class
Auxiliary Members
HeuristicLab.Core Namespace


ShowErrorMessageBox Method (Exception)

Auxiliary..::.ShowErrorMessageBox Method (Exception)
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Auxiliary.ShowErrorMessageBox(System.Exception)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static void ShowErrorMessageBox(
    Exception ex
)

Parameters

ex
Type: System..::.Exception

[Missing <param> documentation for "ex"]

See Also

Auxiliary Class
ShowErrorMessageBox Overload
HeuristicLab.Core Namespace


ShowErrorMessageBox Method (String)

Auxiliary..::.ShowErrorMessageBox Method (String)
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Auxiliary.ShowErrorMessageBox(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static void ShowErrorMessageBox(
    string message
)

Parameters

message
Type: System..::.String

[Missing <param> documentation for "message"]

See Also

Auxiliary Class
ShowErrorMessageBox Overload
HeuristicLab.Core Namespace


ShowIgnoreConstraintViolationMessageBox Method

Auxiliary..::.ShowIgnoreConstraintViolationMessageBox Method
Auxiliary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Auxiliary.ShowIgnoreConstraintViolationMessageBox(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static DialogResult ShowIgnoreConstraintViolationMessageBox(
    ICollection<IConstraint> violatedConstraints
)

Parameters

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>)

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Auxiliary.ShowIgnoreConstraintViolationMessageBox(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint})]

See Also

Auxiliary Class
HeuristicLab.Core Namespace


ChooseItemDialog Class

ChooseItemDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ChooseItemDialog]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ChooseItemDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Core..::.ChooseItemDialog

See Also

ChooseItemDialog Members
HeuristicLab.Core Namespace


ChooseItemDialog Members

[image]

HeuristicLab API Documentation
ChooseItemDialog Members
ChooseItemDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseItemDialog type exposes the following members.

Constructors

Name | Description
ChooseItemDialog | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption |
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Item |
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ChooseItemDialog Class
HeuristicLab.Core Namespace


ChooseItemDialog Constructor

[image]

HeuristicLab API Documentation
ChooseItemDialog Constructor
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ChooseItemDialog()()() |
ChooseItemDialog(Type) |

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


ChooseItemDialog Constructor

ChooseItemDialog Constructor
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChooseItemDialog class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChooseItemDialog()

See Also

ChooseItemDialog Class
ChooseItemDialog Overload
HeuristicLab.Core Namespace


ChooseItemDialog Constructor (Type)

ChooseItemDialog Constructor (Type)
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChooseItemDialog class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChooseItemDialog(
    Type itemType
)

Parameters

itemType
Type: System..::.Type

[Missing <param> documentation for "itemType"]

See Also

ChooseItemDialog Class
ChooseItemDialog Overload
HeuristicLab.Core Namespace


ChooseItemDialog Methods

[image]

HeuristicLab API Documentation
ChooseItemDialog Methods
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseItemDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ChooseItemDialog Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.AccessibilityNotifyClients Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.BeginInvoke Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Dispose Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ChooseItemDialog..::.Dispose Method (Boolean)
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ChooseItemDialog Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.GetChildAtPoint Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Invalidate Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Invoke Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.MemberwiseClone Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.PerformLayout Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.ResumeLayout Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.RtlTranslateAlignment Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Scale Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Select Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.SetBounds Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Show Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Show Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.ShowDialog Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.UpdateBounds Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.Validate Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ChooseItemDialog..::.ValidateChildren Method
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ChooseItemDialog Class
ChooseItemDialog Members
HeuristicLab.Core Namespace


ChooseItemDialog Properties

[image]

HeuristicLab API Documentation
ChooseItemDialog Properties
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseItemDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption |
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Item |
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ChooseItemDialog Class
HeuristicLab.Core Namespace


Caption Property

ChooseItemDialog..::.Caption Property
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ChooseItemDialog.Caption]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Caption { get; set; }

See Also

ChooseItemDialog Class
HeuristicLab.Core Namespace


Item Property

ChooseItemDialog..::.Item Property
ChooseItemDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ChooseItemDialog.Item]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem Item { get; }

See Also

ChooseItemDialog Class
HeuristicLab.Core Namespace


ChooseOperatorDialog Class

ChooseOperatorDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ChooseOperatorDialog]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ChooseOperatorDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Core..::.ChooseOperatorDialog

See Also

ChooseOperatorDialog Members
HeuristicLab.Core Namespace


ChooseOperatorDialog Members

[image]

HeuristicLab API Documentation
ChooseOperatorDialog Members
ChooseOperatorDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseOperatorDialog type exposes the following members.

Constructors

Name | Description
ChooseOperatorDialog |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Operator |
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
HeuristicLab.Core Namespace


ChooseOperatorDialog Constructor

ChooseOperatorDialog Constructor
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChooseOperatorDialog class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChooseOperatorDialog()

See Also

ChooseOperatorDialog Class
HeuristicLab.Core Namespace


ChooseOperatorDialog Methods

[image]

HeuristicLab API Documentation
ChooseOperatorDialog Methods
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseOperatorDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ChooseOperatorDialog Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.AccessibilityNotifyClients Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.BeginInvoke Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Dispose Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ChooseOperatorDialog..::.Dispose Method (Boolean)
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ChooseOperatorDialog Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.GetChildAtPoint Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Invalidate Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Invoke Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.MemberwiseClone Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.PerformLayout Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.ResumeLayout Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.RtlTranslateAlignment Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Scale Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Select Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.SetBounds Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Show Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Show Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.ShowDialog Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.UpdateBounds Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.Validate Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ChooseOperatorDialog..::.ValidateChildren Method
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ChooseOperatorDialog Class
ChooseOperatorDialog Members
HeuristicLab.Core Namespace


ChooseOperatorDialog Properties

[image]

HeuristicLab API Documentation
ChooseOperatorDialog Properties
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseOperatorDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Operator |
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ChooseOperatorDialog Class
HeuristicLab.Core Namespace


Operator Property

ChooseOperatorDialog..::.Operator Property
ChooseOperatorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ChooseOperatorDialog.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; }

See Also

ChooseOperatorDialog Class
HeuristicLab.Core Namespace


ChooseTypeDialog Class

ChooseTypeDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ChooseTypeDialog]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ChooseTypeDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Core..::.ChooseTypeDialog

See Also

ChooseTypeDialog Members
HeuristicLab.Core Namespace


ChooseTypeDialog Members

[image]

HeuristicLab API Documentation
ChooseTypeDialog Members
ChooseTypeDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseTypeDialog type exposes the following members.

Constructors

Name | Description
ChooseTypeDialog | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption |
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Type |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ChooseTypeDialog Class
HeuristicLab.Core Namespace


ChooseTypeDialog Constructor

[image]

HeuristicLab API Documentation
ChooseTypeDialog Constructor
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ChooseTypeDialog()()() |
ChooseTypeDialog(Type) |

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


ChooseTypeDialog Constructor

ChooseTypeDialog Constructor
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChooseTypeDialog class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChooseTypeDialog()

See Also

ChooseTypeDialog Class
ChooseTypeDialog Overload
HeuristicLab.Core Namespace


ChooseTypeDialog Constructor (Type)

ChooseTypeDialog Constructor (Type)
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChooseTypeDialog class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChooseTypeDialog(
    Type baseType
)

Parameters

baseType
Type: System..::.Type

[Missing <param> documentation for "baseType"]

See Also

ChooseTypeDialog Class
ChooseTypeDialog Overload
HeuristicLab.Core Namespace


ChooseTypeDialog Methods

[image]

HeuristicLab API Documentation
ChooseTypeDialog Methods
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseTypeDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ChooseTypeDialog Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.AccessibilityNotifyClients Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.BeginInvoke Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Dispose Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ChooseTypeDialog..::.Dispose Method (Boolean)
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ChooseTypeDialog Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.GetChildAtPoint Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Invalidate Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Invoke Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.MemberwiseClone Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.PerformLayout Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.ResumeLayout Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.RtlTranslateAlignment Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Scale Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Select Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.SetBounds Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Show Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Show Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.ShowDialog Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.UpdateBounds Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.Validate Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ChooseTypeDialog..::.ValidateChildren Method
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ChooseTypeDialog Class
ChooseTypeDialog Members
HeuristicLab.Core Namespace


ChooseTypeDialog Properties

[image]

HeuristicLab API Documentation
ChooseTypeDialog Properties
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChooseTypeDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption |
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Type |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ChooseTypeDialog Class
HeuristicLab.Core Namespace


Caption Property

ChooseTypeDialog..::.Caption Property
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ChooseTypeDialog.Caption]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Caption { get; set; }

See Also

ChooseTypeDialog Class
HeuristicLab.Core Namespace


Type Property

ChooseTypeDialog..::.Type Property
ChooseTypeDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ChooseTypeDialog.Type]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Type Type { get; }

See Also

ChooseTypeDialog Class
HeuristicLab.Core Namespace


CompositeOperation Class

CompositeOperation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.CompositeOperation]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CompositeOperation : ItemBase, IOperation,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.CompositeOperation

See Also

CompositeOperation Members
HeuristicLab.Core Namespace


CompositeOperation Members

[image]

HeuristicLab API Documentation
CompositeOperation Members
CompositeOperation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CompositeOperation type exposes the following members.

Constructors

Name | Description
CompositeOperation |

Methods

Name | Description
AddOperation |
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperation |
ToString | (Inherited from ItemBase.)

Properties

Name | Description
ExecuteInParallel |
Guid | (Inherited from StorableBase.)
Operations |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


CompositeOperation Constructor

CompositeOperation Constructor
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CompositeOperation class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CompositeOperation()

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


CompositeOperation Methods

[image]

HeuristicLab API Documentation
CompositeOperation Methods
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CompositeOperation type exposes the following members.

Methods

Name | Description
AddOperation |
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperation |
ToString | (Inherited from ItemBase.)

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


AddOperation Method

CompositeOperation..::.AddOperation Method
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.CompositeOperation.AddOperation(HeuristicLab.Core.IOperation)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddOperation(
    IOperation operation
)

Parameters

operation
Type: HeuristicLab.Core..::.IOperation

[Missing <param> documentation for "operation"]

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
CompositeOperation..::.Clone Method
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

CompositeOperation Class
CompositeOperation Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

CompositeOperation..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.CompositeOperation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.CompositeOperation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

CompositeOperation Class
Clone Overload
HeuristicLab.Core Namespace


GetXmlNode Method

CompositeOperation..::.GetXmlNode Method
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.CompositeOperation.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.CompositeOperation.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


Populate Method

CompositeOperation..::.Populate Method
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.CompositeOperation.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


RemoveOperation Method

CompositeOperation..::.RemoveOperation Method
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.CompositeOperation.RemoveOperation(HeuristicLab.Core.IOperation)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveOperation(
    IOperation operation
)

Parameters

operation
Type: HeuristicLab.Core..::.IOperation

[Missing <param> documentation for "operation"]

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


CompositeOperation Properties

[image]

HeuristicLab API Documentation
CompositeOperation Properties
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CompositeOperation type exposes the following members.

Properties

Name | Description
ExecuteInParallel |
Guid | (Inherited from StorableBase.)
Operations |

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


ExecuteInParallel Property

CompositeOperation..::.ExecuteInParallel Property
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.CompositeOperation.ExecuteInParallel]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool ExecuteInParallel { get; set; }

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


Operations Property

CompositeOperation..::.Operations Property
CompositeOperation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.CompositeOperation.Operations]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IOperation> Operations { get; }

See Also

CompositeOperation Class
HeuristicLab.Core Namespace


ConstrainedItemBase Class

ConstrainedItemBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ConstrainedItemBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ConstrainedItemBase : ItemBase, IConstrainedItem,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Data..::.ConstrainedObjectData
HeuristicLab.Data..::.ConstrainedItemList

See Also

ConstrainedItemBase Members
HeuristicLab.Core Namespace


ConstrainedItemBase Members

[image]

HeuristicLab API Documentation
ConstrainedItemBase Members
ConstrainedItemBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBase type exposes the following members.

Constructors

Name | Description
ConstrainedItemBase |

Methods

Name | Description
AddConstraint |
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded |
OnConstraintRemoved |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint |
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Constraints |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ConstraintAdded |
ConstraintRemoved |

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstrainedItemBase Constructor

ConstrainedItemBase Constructor
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedItemBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ConstrainedItemBase()

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstrainedItemBase Methods

[image]

HeuristicLab API Documentation
ConstrainedItemBase Methods
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBase type exposes the following members.

Methods

Name | Description
AddConstraint |
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded |
OnConstraintRemoved |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint |
ToString | (Inherited from ItemBase.)

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


AddConstraint Method

ConstrainedItemBase..::.AddConstraint Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.AddConstraint(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddConstraint(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstrainedItem..::.AddConstraint(IConstraint)

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConstrainedItemBase..::.Clone Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ConstrainedItemBase Class
ConstrainedItemBase Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

ConstrainedItemBase..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ConstrainedItemBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ConstrainedItemBase Class
Clone Overload
HeuristicLab.Core Namespace


CreateView Method

ConstrainedItemBase..::.CreateView Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ConstrainedItemBase.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


GetXmlNode Method

ConstrainedItemBase..::.GetXmlNode Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ConstrainedItemBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConstrainedItemBase..::.IsValid Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() |
IsValid(ICollection<(Of <(IConstraint>)>)%) |

See Also

ConstrainedItemBase Class
ConstrainedItemBase Members
HeuristicLab.Core Namespace


IsValid Method

ConstrainedItemBase..::.IsValid Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.IsValid]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsValid()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ConstrainedItemBase.IsValid]

Implements

IConstrainedItem..::.IsValid()()()

See Also

ConstrainedItemBase Class
IsValid Overload
HeuristicLab.Core Namespace


IsValid Method ( ICollection(IConstraint) )

ConstrainedItemBase..::.IsValid Method ( ICollection<(Of <(IConstraint>)>) %)
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.IsValid(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsValid(
    out ICollection<IConstraint> violatedConstraints
)

Parameters

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ConstrainedItemBase.IsValid(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IConstrainedItem..::.IsValid(ICollection<(Of <(IConstraint>)>)%)

See Also

ConstrainedItemBase Class
IsValid Overload
HeuristicLab.Core Namespace


OnConstraintAdded Method

ConstrainedItemBase..::.OnConstraintAdded Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.OnConstraintAdded(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnConstraintAdded(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


OnConstraintRemoved Method

ConstrainedItemBase..::.OnConstraintRemoved Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.OnConstraintRemoved(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnConstraintRemoved(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


Populate Method

ConstrainedItemBase..::.Populate Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


RemoveConstraint Method

ConstrainedItemBase..::.RemoveConstraint Method
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBase.RemoveConstraint(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void RemoveConstraint(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstrainedItem..::.RemoveConstraint(IConstraint)

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstrainedItemBase Properties

[image]

HeuristicLab API Documentation
ConstrainedItemBase Properties
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBase type exposes the following members.

Properties

Name | Description
Constraints |
Guid | (Inherited from StorableBase.)

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


Constraints Property

ConstrainedItemBase..::.Constraints Property
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ConstrainedItemBase.Constraints]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual ICollection<IConstraint> Constraints { get; }

Implements

IConstrainedItem..::.Constraints

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstrainedItemBase Events

[image]

HeuristicLab API Documentation
ConstrainedItemBase Events
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBase type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
ConstraintAdded |
ConstraintRemoved |

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstraintAdded Event

ConstrainedItemBase..::.ConstraintAdded Event
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.ConstrainedItemBase.ConstraintAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ConstraintEventArgs> ConstraintAdded

Implements

IConstrainedItem..::.ConstraintAdded

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstraintRemoved Event

ConstrainedItemBase..::.ConstraintRemoved Event
ConstrainedItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.ConstrainedItemBase.ConstraintRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ConstraintEventArgs> ConstraintRemoved

Implements

IConstrainedItem..::.ConstraintRemoved

See Also

ConstrainedItemBase Class
HeuristicLab.Core Namespace


ConstrainedItemBaseView Class

ConstrainedItemBaseView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ConstrainedItemBaseView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedItemBaseView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.ConstrainedItemBaseView

See Also

ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


ConstrainedItemBaseView Members

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView Members
ConstrainedItemBaseView Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBaseView type exposes the following members.

Constructors

Name | Description
ConstrainedItemBaseView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
addConstraintButton |
constraintDetailsGroupBox |
constraintsGroupBox |
constraintsListView |
removeConstraintButton |
splitContainer |

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedItem |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


ConstrainedItemBaseView Constructor

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView Constructor
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConstrainedItemBaseView()()() |
ConstrainedItemBaseView(IConstrainedItem) |

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


ConstrainedItemBaseView Constructor

ConstrainedItemBaseView Constructor
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedItemBaseView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedItemBaseView()

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Overload
HeuristicLab.Core Namespace


ConstrainedItemBaseView Constructor (IConstrainedItem)

ConstrainedItemBaseView Constructor (IConstrainedItem)
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedItemBaseView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedItemBaseView(
    IConstrainedItem constraintItem
)

Parameters

constraintItem
Type: HeuristicLab.Core..::.IConstrainedItem

[Missing <param> documentation for "constraintItem"]

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Overload
HeuristicLab.Core Namespace


ConstrainedItemBaseView Fields

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView Fields
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBaseView type exposes the following members.

Fields

Name | Description
addConstraintButton |
constraintDetailsGroupBox |
constraintsGroupBox |
constraintsListView |
removeConstraintButton |
splitContainer |

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


addConstraintButton Field

ConstrainedItemBaseView..::.addConstraintButton Field
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.ConstrainedItemBaseView.addConstraintButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button addConstraintButton

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


constraintDetailsGroupBox Field

ConstrainedItemBaseView..::.constraintDetailsGroupBox Field
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.ConstrainedItemBaseView.constraintDetailsGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox constraintDetailsGroupBox

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


constraintsGroupBox Field

ConstrainedItemBaseView..::.constraintsGroupBox Field
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.ConstrainedItemBaseView.constraintsGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox constraintsGroupBox

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


constraintsListView Field

ConstrainedItemBaseView..::.constraintsListView Field
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.ConstrainedItemBaseView.constraintsListView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ListView constraintsListView

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


removeConstraintButton Field

ConstrainedItemBaseView..::.removeConstraintButton Field
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.ConstrainedItemBaseView.removeConstraintButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button removeConstraintButton

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


splitContainer Field

ConstrainedItemBaseView..::.splitContainer Field
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.ConstrainedItemBaseView.splitContainer]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected SplitContainer splitContainer

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


ConstrainedItemBaseView Methods

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView Methods
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBaseView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.AccessibilityNotifyClients Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


AddItemEvents Method

ConstrainedItemBaseView..::.AddItemEvents Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBaseView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.BeginInvoke Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.Dispose Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ConstrainedItemBaseView..::.Dispose Method (Boolean)
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ConstrainedItemBaseView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.GetChildAtPoint Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.Invalidate Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.Invoke Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.MemberwiseClone Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.PerformLayout Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

ConstrainedItemBaseView..::.RemoveItemEvents Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBaseView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.ResumeLayout Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.RtlTranslateAlignment Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.Scale Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.Select Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.SetBounds Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.UpdateBounds Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


UpdateControls Method

ConstrainedItemBaseView..::.UpdateControls Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ConstrainedItemBaseView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.Validate Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView..::.ValidateChildren Method
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ConstrainedItemBaseView Class
ConstrainedItemBaseView Members
HeuristicLab.Core Namespace


ConstrainedItemBaseView Properties

[image]

HeuristicLab API Documentation
ConstrainedItemBaseView Properties
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemBaseView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedItem |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


ConstrainedItem Property

ConstrainedItemBaseView..::.ConstrainedItem Property
ConstrainedItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ConstrainedItemBaseView.ConstrainedItem]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IConstrainedItem ConstrainedItem { get; set; }

See Also

ConstrainedItemBaseView Class
HeuristicLab.Core Namespace


ConstraintEventArgs Class

ConstraintEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ConstraintEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstraintEventArgs : ItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.ConstraintEventArgs

See Also

ConstraintEventArgs Members
HeuristicLab.Core Namespace


ConstraintEventArgs Members

[image]

HeuristicLab API Documentation
ConstraintEventArgs Members
ConstraintEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintEventArgs type exposes the following members.

Constructors

Name | Description
ConstraintEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Constraint |
Item | (Inherited from ItemEventArgs.)

See Also

ConstraintEventArgs Class
HeuristicLab.Core Namespace


ConstraintEventArgs Constructor

ConstraintEventArgs Constructor
ConstraintEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstraintEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstraintEventArgs(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

See Also

ConstraintEventArgs Class
HeuristicLab.Core Namespace


ConstraintEventArgs Properties

[image]

HeuristicLab API Documentation
ConstraintEventArgs Properties
ConstraintEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstraintEventArgs type exposes the following members.

Properties

Name | Description
Constraint |
Item | (Inherited from ItemEventArgs.)

See Also

ConstraintEventArgs Class
HeuristicLab.Core Namespace


Constraint Property

ConstraintEventArgs..::.Constraint Property
ConstraintEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ConstraintEventArgs.Constraint]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IConstraint Constraint { get; }

See Also

ConstraintEventArgs Class
HeuristicLab.Core Namespace


EditorBase Class

EditorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.EditorBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EditorBase : ViewBase, IEditor,
    IView, IControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.EngineBaseEditor
HeuristicLab.Core..::.OperatorLibraryEditor
HeuristicLab.SGA..::.SGAEditor
HeuristicLab.StructureIdentification..::.GPOperatorLibraryEditor

See Also

EditorBase Members
HeuristicLab.Core Namespace


EditorBase Members

[image]

HeuristicLab API Documentation
EditorBase Members
EditorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorBase type exposes the following members.

Constructors

Name | Description
EditorBase |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged |
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename |
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged |
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EditorBase Class
HeuristicLab.Core Namespace


EditorBase Constructor

EditorBase Constructor
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EditorBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EditorBase()

See Also

EditorBase Class
HeuristicLab.Core Namespace


EditorBase Methods

[image]

HeuristicLab API Documentation
EditorBase Methods
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorBase type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged |
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

EditorBase Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
EditorBase..::.AccessibilityNotifyClients Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
EditorBase..::.BeginInvoke Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
EditorBase..::.Dispose Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

EditorBase..::.Dispose Method (Boolean)
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

EditorBase Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
EditorBase..::.GetChildAtPoint Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
EditorBase..::.Invalidate Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
EditorBase..::.Invoke Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
EditorBase..::.MemberwiseClone Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


OnFilenameChanged Method

EditorBase..::.OnFilenameChanged Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EditorBase.OnFilenameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnFilenameChanged()

See Also

EditorBase Class
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
EditorBase..::.PerformLayout Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
EditorBase..::.ResumeLayout Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
EditorBase..::.RtlTranslateAlignment Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
EditorBase..::.Scale Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
EditorBase..::.Select Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
EditorBase..::.SetBounds Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
EditorBase..::.UpdateBounds Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


UpdateControls Method

EditorBase..::.UpdateControls Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EditorBase.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

EditorBase Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
EditorBase..::.Validate Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
EditorBase..::.ValidateChildren Method
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

EditorBase Class
EditorBase Members
HeuristicLab.Core Namespace


EditorBase Properties

[image]

HeuristicLab API Documentation
EditorBase Properties
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorBase type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename |
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

EditorBase Class
HeuristicLab.Core Namespace


Filename Property

EditorBase..::.Filename Property
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EditorBase.Filename]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Filename { get; set; }

Implements

IEditor..::.Filename

See Also

EditorBase Class
HeuristicLab.Core Namespace


EditorBase Events

[image]

HeuristicLab API Documentation
EditorBase Events
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorBase type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged |
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EditorBase Class
HeuristicLab.Core Namespace


FilenameChanged Event

EditorBase..::.FilenameChanged Event
EditorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.EditorBase.FilenameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler FilenameChanged

Implements

IEditor..::.FilenameChanged

See Also

EditorBase Class
HeuristicLab.Core Namespace


EngineBase Class

EngineBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.EngineBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class EngineBase : ItemBase, IEngine,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.EngineBase
HeuristicLab.DistributedEngine..::.DistributedEngine
HeuristicLab.Grid..::.ProcessingEngine
HeuristicLab.SequentialEngine..::.SequentialEngine
HeuristicLab.ThreadParallelEngine..::.ThreadParallelEngine

See Also

EngineBase Members
HeuristicLab.Core Namespace


EngineBase Members

[image]

HeuristicLab API Documentation
EngineBase Members
EngineBase Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBase type exposes the following members.

Constructors

Name | Description
EngineBase |

Methods

Name | Description
Abort |
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
ExecuteStep |
ExecuteSteps |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred |
OnExecutionTimeChanged |
OnFinished |
OnInitialized |
OnOperationExecuted |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation |
Reset |
ToString | (Inherited from ItemBase.)

Fields

Name | Description
myCanceled |
myExecutionStack |
myGlobalScope |
myOperatorGraph |
myRunning |

Properties

Name | Description
Canceled |
ExecutionStack |
ExecutionTime |
GlobalScope |
Guid | (Inherited from StorableBase.)
OperatorGraph |
Running |
Terminated |

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred |
ExecutionTimeChanged |
Finished |
Initialized |
OperationExecuted |

See Also

EngineBase Class
HeuristicLab.Core Namespace


EngineBase Constructor

EngineBase Constructor
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EngineBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected EngineBase()

See Also

EngineBase Class
HeuristicLab.Core Namespace


EngineBase Fields

[image]

HeuristicLab API Documentation
EngineBase Fields
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBase type exposes the following members.

Fields

Name | Description
myCanceled |
myExecutionStack |
myGlobalScope |
myOperatorGraph |
myRunning |

See Also

EngineBase Class
HeuristicLab.Core Namespace


myCanceled Field

EngineBase..::.myCanceled Field
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBase.myCanceled]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected bool myCanceled

See Also

EngineBase Class
HeuristicLab.Core Namespace


myExecutionStack Field

EngineBase..::.myExecutionStack Field
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBase.myExecutionStack]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Stack<IOperation> myExecutionStack

See Also

EngineBase Class
HeuristicLab.Core Namespace


myGlobalScope Field

EngineBase..::.myGlobalScope Field
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBase.myGlobalScope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected IScope myGlobalScope

See Also

EngineBase Class
HeuristicLab.Core Namespace


myOperatorGraph Field

EngineBase..::.myOperatorGraph Field
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBase.myOperatorGraph]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected IOperatorGraph myOperatorGraph

See Also

EngineBase Class
HeuristicLab.Core Namespace


myRunning Field

EngineBase..::.myRunning Field
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBase.myRunning]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected bool myRunning

See Also

EngineBase Class
HeuristicLab.Core Namespace


EngineBase Methods

[image]

HeuristicLab API Documentation
EngineBase Methods
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBase type exposes the following members.

Methods

Name | Description
Abort |
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
ExecuteStep |
ExecuteSteps |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred |
OnExecutionTimeChanged |
OnFinished |
OnInitialized |
OnOperationExecuted |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation |
Reset |
ToString | (Inherited from ItemBase.)

See Also

EngineBase Class
HeuristicLab.Core Namespace


Abort Method

EngineBase..::.Abort Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.Abort]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Abort()

Implements

IEngine..::.Abort()()()

See Also

EngineBase Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
EngineBase..::.Clone Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

EngineBase Class
EngineBase Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

EngineBase..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.EngineBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

EngineBase Class
Clone Overload
HeuristicLab.Core Namespace


Execute Method

EngineBase..::.Execute Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.Execute]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Execute()

Implements

IEngine..::.Execute()()()

See Also

EngineBase Class
HeuristicLab.Core Namespace


ExecuteStep Method

EngineBase..::.ExecuteStep Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.ExecuteStep]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void ExecuteStep()

Implements

IEngine..::.ExecuteStep()()()

See Also

EngineBase Class
HeuristicLab.Core Namespace


ExecuteSteps Method

EngineBase..::.ExecuteSteps Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.ExecuteSteps(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void ExecuteSteps(
    int steps
)

Parameters

steps
Type: System..::.Int32

[Missing <param> documentation for "steps"]

Implements

IEngine..::.ExecuteSteps(Int32)

See Also

EngineBase Class
HeuristicLab.Core Namespace


GetXmlNode Method

EngineBase..::.GetXmlNode Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.EngineBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

EngineBase Class
HeuristicLab.Core Namespace


OnExceptionOccurred Method

EngineBase..::.OnExceptionOccurred Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.OnExceptionOccurred(System.Exception)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnExceptionOccurred(
    Exception exception
)

Parameters

exception
Type: System..::.Exception

[Missing <param> documentation for "exception"]

See Also

EngineBase Class
HeuristicLab.Core Namespace


OnExecutionTimeChanged Method

EngineBase..::.OnExecutionTimeChanged Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.OnExecutionTimeChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnExecutionTimeChanged()

See Also

EngineBase Class
HeuristicLab.Core Namespace


OnFinished Method

EngineBase..::.OnFinished Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.OnFinished]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnFinished()

See Also

EngineBase Class
HeuristicLab.Core Namespace


OnInitialized Method

EngineBase..::.OnInitialized Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.OnInitialized]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnInitialized()

See Also

EngineBase Class
HeuristicLab.Core Namespace


OnOperationExecuted Method

EngineBase..::.OnOperationExecuted Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.OnOperationExecuted(HeuristicLab.Core.IOperation)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnOperationExecuted(
    IOperation operation
)

Parameters

operation
Type: HeuristicLab.Core..::.IOperation

[Missing <param> documentation for "operation"]

See Also

EngineBase Class
HeuristicLab.Core Namespace


Populate Method

EngineBase..::.Populate Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

EngineBase Class
HeuristicLab.Core Namespace


ProcessNextOperation Method

EngineBase..::.ProcessNextOperation Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.ProcessNextOperation]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract void ProcessNextOperation()

See Also

EngineBase Class
HeuristicLab.Core Namespace


Reset Method

EngineBase..::.Reset Method
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBase.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Reset()

Implements

IEngine..::.Reset()()()

See Also

EngineBase Class
HeuristicLab.Core Namespace


EngineBase Properties

[image]

HeuristicLab API Documentation
EngineBase Properties
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBase type exposes the following members.

Properties

Name | Description
Canceled |
ExecutionStack |
ExecutionTime |
GlobalScope |
Guid | (Inherited from StorableBase.)
OperatorGraph |
Running |
Terminated |

See Also

EngineBase Class
HeuristicLab.Core Namespace


Canceled Property

EngineBase..::.Canceled Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.Canceled]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Canceled { get; }

Implements

IEngine..::.Canceled

See Also

EngineBase Class
HeuristicLab.Core Namespace


ExecutionStack Property

EngineBase..::.ExecutionStack Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.ExecutionStack]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Stack<IOperation> ExecutionStack { get; }

See Also

EngineBase Class
HeuristicLab.Core Namespace


ExecutionTime Property

EngineBase..::.ExecutionTime Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.ExecutionTime]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TimeSpan ExecutionTime { get; protected set; }

Implements

IEngine..::.ExecutionTime

See Also

EngineBase Class
HeuristicLab.Core Namespace


GlobalScope Property

EngineBase..::.GlobalScope Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.GlobalScope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope GlobalScope { get; }

Implements

IEngine..::.GlobalScope

See Also

EngineBase Class
HeuristicLab.Core Namespace


OperatorGraph Property

EngineBase..::.OperatorGraph Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.OperatorGraph]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorGraph OperatorGraph { get; }

Implements

IEngine..::.OperatorGraph

See Also

EngineBase Class
HeuristicLab.Core Namespace


Running Property

EngineBase..::.Running Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.Running]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Running { get; }

Implements

IEngine..::.Running

See Also

EngineBase Class
HeuristicLab.Core Namespace


Terminated Property

EngineBase..::.Terminated Property
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBase.Terminated]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool Terminated { get; }

Implements

IEngine..::.Terminated

See Also

EngineBase Class
HeuristicLab.Core Namespace


EngineBase Events

[image]

HeuristicLab API Documentation
EngineBase Events
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBase type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred |
ExecutionTimeChanged |
Finished |
Initialized |
OperationExecuted |

See Also

EngineBase Class
HeuristicLab.Core Namespace


ExceptionOccurred Event

EngineBase..::.ExceptionOccurred Event
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.EngineBase.ExceptionOccurred]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ExceptionEventArgs> ExceptionOccurred

Implements

IEngine..::.ExceptionOccurred

See Also

EngineBase Class
HeuristicLab.Core Namespace


ExecutionTimeChanged Event

EngineBase..::.ExecutionTimeChanged Event
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.EngineBase.ExecutionTimeChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ExecutionTimeChanged

Implements

IEngine..::.ExecutionTimeChanged

See Also

EngineBase Class
HeuristicLab.Core Namespace


Finished Event

EngineBase..::.Finished Event
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.EngineBase.Finished]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Finished

Implements

IEngine..::.Finished

See Also

EngineBase Class
HeuristicLab.Core Namespace


Initialized Event

EngineBase..::.Initialized Event
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.EngineBase.Initialized]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Initialized

Implements

IEngine..::.Initialized

See Also

EngineBase Class
HeuristicLab.Core Namespace


OperationExecuted Event

EngineBase..::.OperationExecuted Event
EngineBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.EngineBase.OperationExecuted]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<OperationEventArgs> OperationExecuted

Implements

IEngine..::.OperationExecuted

See Also

EngineBase Class
HeuristicLab.Core Namespace


EngineBaseEditor Class

EngineBaseEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.EngineBaseEditor]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EngineBaseEditor : EditorBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.EngineBaseEditor
HeuristicLab.DistributedEngine..::.DistributedEngineEditor
HeuristicLab.SequentialEngine..::.SequentialEngineEditor
HeuristicLab.ThreadParallelEngine..::.ThreadParallelEngineEditor

See Also

EngineBaseEditor Members
HeuristicLab.Core Namespace


EngineBaseEditor Members

[image]

HeuristicLab API Documentation
EngineBaseEditor Members
EngineBaseEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBaseEditor type exposes the following members.

Constructors

Name | Description
EngineBaseEditor |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EditorBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
abortButton |
executeButton |
executionTimeLabel |
executionTimeTextBox |
globalScopeGroupBox |
operatorGraphGroupBox |
operatorGraphView |
resetButton |
scopeView |
splitContainer1 |

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine |
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


EngineBaseEditor Constructor

EngineBaseEditor Constructor
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EngineBaseEditor class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EngineBaseEditor()

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


EngineBaseEditor Fields

[image]

HeuristicLab API Documentation
EngineBaseEditor Fields
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBaseEditor type exposes the following members.

Fields

Name | Description
abortButton |
executeButton |
executionTimeLabel |
executionTimeTextBox |
globalScopeGroupBox |
operatorGraphGroupBox |
operatorGraphView |
resetButton |
scopeView |
splitContainer1 |

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


abortButton Field

EngineBaseEditor..::.abortButton Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.abortButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button abortButton

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


executeButton Field

EngineBaseEditor..::.executeButton Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.executeButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button executeButton

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


executionTimeLabel Field

EngineBaseEditor..::.executionTimeLabel Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.executionTimeLabel]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Label executionTimeLabel

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


executionTimeTextBox Field

EngineBaseEditor..::.executionTimeTextBox Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.executionTimeTextBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected TextBox executionTimeTextBox

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


globalScopeGroupBox Field

EngineBaseEditor..::.globalScopeGroupBox Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.globalScopeGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox globalScopeGroupBox

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


operatorGraphGroupBox Field

EngineBaseEditor..::.operatorGraphGroupBox Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.operatorGraphGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox operatorGraphGroupBox

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


operatorGraphView Field

EngineBaseEditor..::.operatorGraphView Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.operatorGraphView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected OperatorGraphView operatorGraphView

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


resetButton Field

EngineBaseEditor..::.resetButton Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.resetButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button resetButton

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


scopeView Field

EngineBaseEditor..::.scopeView Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.scopeView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ScopeView scopeView

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


splitContainer1 Field

EngineBaseEditor..::.splitContainer1 Field
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.EngineBaseEditor.splitContainer1]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected SplitContainer splitContainer1

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


EngineBaseEditor Methods

[image]

HeuristicLab API Documentation
EngineBaseEditor Methods
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBaseEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EditorBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.AccessibilityNotifyClients Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


AddItemEvents Method

EngineBaseEditor..::.AddItemEvents Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBaseEditor.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.BeginInvoke Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.Dispose Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EditorBase ..::. Dispose(Boolean).)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

EngineBaseEditor..::.Dispose Method (Boolean)
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

EngineBaseEditor Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.GetChildAtPoint Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.Invalidate Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.Invoke Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.MemberwiseClone Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.PerformLayout Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

EngineBaseEditor..::.RemoveItemEvents Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBaseEditor.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.ResumeLayout Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.RtlTranslateAlignment Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.Scale Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.Select Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.SetBounds Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.UpdateBounds Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


UpdateControls Method

EngineBaseEditor..::.UpdateControls Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.EngineBaseEditor.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.Validate Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
EngineBaseEditor..::.ValidateChildren Method
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

EngineBaseEditor Class
EngineBaseEditor Members
HeuristicLab.Core Namespace


EngineBaseEditor Properties

[image]

HeuristicLab API Documentation
EngineBaseEditor Properties
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineBaseEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine |
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


Engine Property

EngineBaseEditor..::.Engine Property
EngineBaseEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.EngineBaseEditor.Engine]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEngine Engine { get; set; }

See Also

EngineBaseEditor Class
HeuristicLab.Core Namespace


ExceptionEventArgs Class

ExceptionEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ExceptionEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ExceptionEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ExceptionEventArgs

See Also

ExceptionEventArgs Members
HeuristicLab.Core Namespace


ExceptionEventArgs Members

[image]

HeuristicLab API Documentation
ExceptionEventArgs Members
ExceptionEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExceptionEventArgs type exposes the following members.

Constructors

Name | Description
ExceptionEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Exception |

See Also

ExceptionEventArgs Class
HeuristicLab.Core Namespace


ExceptionEventArgs Constructor

ExceptionEventArgs Constructor
ExceptionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ExceptionEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ExceptionEventArgs(
    Exception exception
)

Parameters

exception
Type: System..::.Exception

[Missing <param> documentation for "exception"]

See Also

ExceptionEventArgs Class
HeuristicLab.Core Namespace


ExceptionEventArgs Properties

[image]

HeuristicLab API Documentation
ExceptionEventArgs Properties
ExceptionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ExceptionEventArgs type exposes the following members.

Properties

Name | Description
Exception |

See Also

ExceptionEventArgs Class
HeuristicLab.Core Namespace


Exception Property

ExceptionEventArgs..::.Exception Property
ExceptionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ExceptionEventArgs.Exception]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Exception Exception { get; }

See Also

ExceptionEventArgs Class
HeuristicLab.Core Namespace


HeuristicLabCorePlugin Class

HeuristicLabCorePlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.HeuristicLabCorePlugin]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Core.dll", Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Core")]
public class HeuristicLabCorePlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Core..::.HeuristicLabCorePlugin

See Also

HeuristicLabCorePlugin Members
HeuristicLab.Core Namespace


HeuristicLabCorePlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabCorePlugin Members
HeuristicLabCorePlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabCorePlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabCorePlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabCorePlugin Class
HeuristicLab.Core Namespace


HeuristicLabCorePlugin Constructor

HeuristicLabCorePlugin Constructor
HeuristicLabCorePlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabCorePlugin class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabCorePlugin()

See Also

HeuristicLabCorePlugin Class
HeuristicLab.Core Namespace


IConstrainedItem Interface

IConstrainedItem Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IConstrainedItem]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IConstrainedItem : IItem,
    IStorable, IViewable

See Also

IConstrainedItem Members
HeuristicLab.Core Namespace


IConstrainedItem Members

[image]

HeuristicLab API Documentation
IConstrainedItem Members
IConstrainedItem Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstrainedItem type exposes the following members.

Methods

Name | Description
AddConstraint |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
IsValid | Overloaded.
Populate | (Inherited from IStorable.)
RemoveConstraint |

Properties

Name | Description
Constraints |
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)
ConstraintAdded |
ConstraintRemoved |

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


IConstrainedItem Methods

[image]

HeuristicLab API Documentation
IConstrainedItem Methods
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstrainedItem type exposes the following members.

Methods

Name | Description
AddConstraint |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
IsValid | Overloaded.
Populate | (Inherited from IStorable.)
RemoveConstraint |

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


AddConstraint Method

IConstrainedItem..::.AddConstraint Method
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IConstrainedItem.AddConstraint(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddConstraint(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IConstrainedItem..::.Clone Method
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IConstrainedItem Interface
IConstrainedItem Members
HeuristicLab.Core Namespace


IsValid Method

[image]

HeuristicLab API Documentation
IConstrainedItem..::.IsValid Method
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() |
IsValid(ICollection<(Of <(IConstraint>)>)%) |

See Also

IConstrainedItem Interface
IConstrainedItem Members
HeuristicLab.Core Namespace


IsValid Method

IConstrainedItem..::.IsValid Method
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IConstrainedItem.IsValid]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool IsValid()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IConstrainedItem.IsValid]

See Also

IConstrainedItem Interface
IsValid Overload
HeuristicLab.Core Namespace


IsValid Method ( ICollection(IConstraint) )

IConstrainedItem..::.IsValid Method ( ICollection<(Of <(IConstraint>)>) %)
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IConstrainedItem.IsValid(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool IsValid(
    out ICollection<IConstraint> violatedConstraints
)

Parameters

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IConstrainedItem.IsValid(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IConstrainedItem Interface
IsValid Overload
HeuristicLab.Core Namespace


RemoveConstraint Method

IConstrainedItem..::.RemoveConstraint Method
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IConstrainedItem.RemoveConstraint(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveConstraint(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


IConstrainedItem Properties

[image]

HeuristicLab API Documentation
IConstrainedItem Properties
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstrainedItem type exposes the following members.

Properties

Name | Description
Constraints |
Guid | (Inherited from IStorable.)

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


Constraints Property

IConstrainedItem..::.Constraints Property
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IConstrainedItem.Constraints]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IConstraint> Constraints { get; }

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


IConstrainedItem Events

[image]

HeuristicLab API Documentation
IConstrainedItem Events
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstrainedItem type exposes the following members.

Events

Name | Description
Changed | (Inherited from IItem.)
ConstraintAdded |
ConstraintRemoved |

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


ConstraintAdded Event

IConstrainedItem..::.ConstraintAdded Event
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IConstrainedItem.ConstraintAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<ConstraintEventArgs> ConstraintAdded

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


ConstraintRemoved Event

IConstrainedItem..::.ConstraintRemoved Event
IConstrainedItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IConstrainedItem.ConstraintRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<ConstraintEventArgs> ConstraintRemoved

See Also

IConstrainedItem Interface
HeuristicLab.Core Namespace


IConstraint Interface

IConstraint Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IConstraint]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IConstraint : IItem,
    IStorable, IViewable

See Also

IConstraint Members
HeuristicLab.Core Namespace


IConstraint Members

[image]

HeuristicLab API Documentation
IConstraint Members
IConstraint Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstraint type exposes the following members.

Methods

Name | Description
Check |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Description |
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)

See Also

IConstraint Interface
HeuristicLab.Core Namespace


IConstraint Methods

[image]

HeuristicLab API Documentation
IConstraint Methods
IConstraint Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstraint type exposes the following members.

Methods

Name | Description
Check |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

See Also

IConstraint Interface
HeuristicLab.Core Namespace


Check Method

IConstraint..::.Check Method
IConstraint Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IConstraint.Check(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Check(
    IItem data
)

Parameters

data
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IConstraint.Check(HeuristicLab.Core.IItem)]

See Also

IConstraint Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IConstraint..::.Clone Method
IConstraint Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IConstraint Interface
IConstraint Members
HeuristicLab.Core Namespace


IConstraint Properties

[image]

HeuristicLab API Documentation
IConstraint Properties
IConstraint Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IConstraint type exposes the following members.

Properties

Name | Description
Description |
Guid | (Inherited from IStorable.)

See Also

IConstraint Interface
HeuristicLab.Core Namespace


Description Property

IConstraint..::.Description Property
IConstraint Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IConstraint.Description]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Description { get; }

See Also

IConstraint Interface
HeuristicLab.Core Namespace


IEditable Interface

IEditable Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IEditable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IEditable : IViewable

See Also

IEditable Members
HeuristicLab.Core Namespace


IEditable Members

[image]

HeuristicLab API Documentation
IEditable Members
IEditable Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEditable type exposes the following members.

Methods

Name | Description
CreateEditor |
CreateView | (Inherited from IViewable.)

See Also

IEditable Interface
HeuristicLab.Core Namespace


IEditable Methods

[image]

HeuristicLab API Documentation
IEditable Methods
IEditable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEditable type exposes the following members.

Methods

Name | Description
CreateEditor |
CreateView | (Inherited from IViewable.)

See Also

IEditable Interface
HeuristicLab.Core Namespace


CreateEditor Method

IEditable..::.CreateEditor Method
IEditable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IEditable.CreateEditor]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IEditable.CreateEditor]

See Also

IEditable Interface
HeuristicLab.Core Namespace


IEditor Interface

IEditor Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IEditor]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IEditor : IView,
    IControl

See Also

IEditor Members
HeuristicLab.Core Namespace


IEditor Members

[image]

HeuristicLab API Documentation
IEditor Members
IEditor Interface Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEditor type exposes the following members.

Properties

Name | Description
Caption | (Inherited from IView.)
Filename |
Item | (Inherited from IView.)

Events

Name | Description
CaptionChanged | (Inherited from IView.)
FilenameChanged |
ItemChanged | (Inherited from IView.)

See Also

IEditor Interface
HeuristicLab.Core Namespace


IEditor Properties

[image]

HeuristicLab API Documentation
IEditor Properties
IEditor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEditor type exposes the following members.

Properties

Name | Description
Caption | (Inherited from IView.)
Filename |
Item | (Inherited from IView.)

See Also

IEditor Interface
HeuristicLab.Core Namespace


Filename Property

IEditor..::.Filename Property
IEditor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEditor.Filename]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Filename { get; set; }

See Also

IEditor Interface
HeuristicLab.Core Namespace


IEditor Events

[image]

HeuristicLab API Documentation
IEditor Events
IEditor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEditor type exposes the following members.

Events

Name | Description
CaptionChanged | (Inherited from IView.)
FilenameChanged |
ItemChanged | (Inherited from IView.)

See Also

IEditor Interface
HeuristicLab.Core Namespace


FilenameChanged Event

IEditor..::.FilenameChanged Event
IEditor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IEditor.FilenameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler FilenameChanged

See Also

IEditor Interface
HeuristicLab.Core Namespace


IEngine Interface

IEngine Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IEngine]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IEngine : IItem,
    IStorable, IViewable

See Also

IEngine Members
HeuristicLab.Core Namespace


IEngine Members

[image]

HeuristicLab API Documentation
IEngine Members
IEngine Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEngine type exposes the following members.

Methods

Name | Description
Abort |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
Execute |
ExecuteStep |
ExecuteSteps |
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
Reset |

Properties

Name | Description
Canceled |
ExecutionTime |
GlobalScope |
Guid | (Inherited from IStorable.)
OperatorGraph |
Running |
Terminated |

Events

Name | Description
Changed | (Inherited from IItem.)
ExceptionOccurred |
ExecutionTimeChanged |
Finished |
Initialized |
OperationExecuted |

See Also

IEngine Interface
HeuristicLab.Core Namespace


IEngine Methods

[image]

HeuristicLab API Documentation
IEngine Methods
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEngine type exposes the following members.

Methods

Name | Description
Abort |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
Execute |
ExecuteStep |
ExecuteSteps |
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
Reset |

See Also

IEngine Interface
HeuristicLab.Core Namespace


Abort Method

IEngine..::.Abort Method
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IEngine.Abort]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Abort()

See Also

IEngine Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IEngine..::.Clone Method
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IEngine Interface
IEngine Members
HeuristicLab.Core Namespace


Execute Method

IEngine..::.Execute Method
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IEngine.Execute]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Execute()

See Also

IEngine Interface
HeuristicLab.Core Namespace


ExecuteStep Method

IEngine..::.ExecuteStep Method
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IEngine.ExecuteStep]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ExecuteStep()

See Also

IEngine Interface
HeuristicLab.Core Namespace


ExecuteSteps Method

IEngine..::.ExecuteSteps Method
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IEngine.ExecuteSteps(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ExecuteSteps(
    int steps
)

Parameters

steps
Type: System..::.Int32

[Missing <param> documentation for "steps"]

See Also

IEngine Interface
HeuristicLab.Core Namespace


Reset Method

IEngine..::.Reset Method
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IEngine.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Reset()

See Also

IEngine Interface
HeuristicLab.Core Namespace


IEngine Properties

[image]

HeuristicLab API Documentation
IEngine Properties
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEngine type exposes the following members.

Properties

Name | Description
Canceled |
ExecutionTime |
GlobalScope |
Guid | (Inherited from IStorable.)
OperatorGraph |
Running |
Terminated |

See Also

IEngine Interface
HeuristicLab.Core Namespace


Canceled Property

IEngine..::.Canceled Property
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEngine.Canceled]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Canceled { get; }

See Also

IEngine Interface
HeuristicLab.Core Namespace


ExecutionTime Property

IEngine..::.ExecutionTime Property
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEngine.ExecutionTime]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
TimeSpan ExecutionTime { get; }

See Also

IEngine Interface
HeuristicLab.Core Namespace


GlobalScope Property

IEngine..::.GlobalScope Property
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEngine.GlobalScope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IScope GlobalScope { get; }

See Also

IEngine Interface
HeuristicLab.Core Namespace


OperatorGraph Property

IEngine..::.OperatorGraph Property
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEngine.OperatorGraph]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IOperatorGraph OperatorGraph { get; }

See Also

IEngine Interface
HeuristicLab.Core Namespace


Running Property

IEngine..::.Running Property
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEngine.Running]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Running { get; }

See Also

IEngine Interface
HeuristicLab.Core Namespace


Terminated Property

IEngine..::.Terminated Property
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IEngine.Terminated]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Terminated { get; }

See Also

IEngine Interface
HeuristicLab.Core Namespace


IEngine Events

[image]

HeuristicLab API Documentation
IEngine Events
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEngine type exposes the following members.

Events

Name | Description
Changed | (Inherited from IItem.)
ExceptionOccurred |
ExecutionTimeChanged |
Finished |
Initialized |
OperationExecuted |

See Also

IEngine Interface
HeuristicLab.Core Namespace


ExceptionOccurred Event

IEngine..::.ExceptionOccurred Event
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IEngine.ExceptionOccurred]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<ExceptionEventArgs> ExceptionOccurred

See Also

IEngine Interface
HeuristicLab.Core Namespace


ExecutionTimeChanged Event

IEngine..::.ExecutionTimeChanged Event
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IEngine.ExecutionTimeChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler ExecutionTimeChanged

See Also

IEngine Interface
HeuristicLab.Core Namespace


Finished Event

IEngine..::.Finished Event
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IEngine.Finished]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Finished

See Also

IEngine Interface
HeuristicLab.Core Namespace


Initialized Event

IEngine..::.Initialized Event
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IEngine.Initialized]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Initialized

See Also

IEngine Interface
HeuristicLab.Core Namespace


OperationExecuted Event

IEngine..::.OperationExecuted Event
IEngine Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IEngine.OperationExecuted]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<OperationEventArgs> OperationExecuted

See Also

IEngine Interface
HeuristicLab.Core Namespace


IItem Interface

IItem Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IItem]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IItem : IStorable, IViewable

See Also

IItem Members
HeuristicLab.Core Namespace


IItem Members

[image]

HeuristicLab API Documentation
IItem Members
IItem Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IItem type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged |
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed |

See Also

IItem Interface
HeuristicLab.Core Namespace


IItem Methods

[image]

HeuristicLab API Documentation
IItem Methods
IItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IItem type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged |
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

See Also

IItem Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IItem..::.Clone Method
IItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IItem Interface
IItem Members
HeuristicLab.Core Namespace


FireChanged Method

IItem..::.FireChanged Method
IItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IItem.FireChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void FireChanged()

See Also

IItem Interface
HeuristicLab.Core Namespace


IItem Events

[image]

HeuristicLab API Documentation
IItem Events
IItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IItem type exposes the following members.

Events

Name | Description
Changed |

See Also

IItem Interface
HeuristicLab.Core Namespace


Changed Event

IItem..::.Changed Event
IItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IItem.Changed]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Changed

See Also

IItem Interface
HeuristicLab.Core Namespace


IOperation Interface

IOperation Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IOperation]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IOperation : IItem,
    IStorable, IViewable

See Also

IOperation Members
HeuristicLab.Core Namespace


IOperation Members

[image]

HeuristicLab API Documentation
IOperation Members
IOperation Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperation type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)

See Also

IOperation Interface
HeuristicLab.Core Namespace


IOperator Interface

IOperator Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IOperator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IOperator : IConstrainedItem,
    IItem, IStorable, IViewable

See Also

IOperator Members
HeuristicLab.Core Namespace


IOperator Members

[image]

HeuristicLab API Documentation
IOperator Members
IOperator Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperator type exposes the following members.

Methods

Name | Description
Abort |
AddConstraint | (Inherited from IConstrainedItem.)
AddSubOperator | Overloaded.
AddVariable |
AddVariableInfo |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
Execute |
FireChanged | (Inherited from IItem.)
GetVariable |
GetVariableInfo |
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from IStorable.)
IsValid | Overloaded.
Populate | (Inherited from IStorable.)
RemoveConstraint | (Inherited from IConstrainedItem.)
RemoveSubOperator |
RemoveVariable |
RemoveVariableInfo |
Reset |
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint |
Canceled |
Constraints | (Inherited from IConstrainedItem.)
Description |
Guid | (Inherited from IStorable.)
Name |
SubOperators |
VariableInfos |
Variables |

Events

Name | Description
BreakpointChanged |
Changed | (Inherited from IItem.)
ConstraintAdded | (Inherited from IConstrainedItem.)
ConstraintRemoved | (Inherited from IConstrainedItem.)
Executed |
Initialized |
NameChanged |
SubOperatorAdded |
SubOperatorRemoved |
VariableAdded |
VariableInfoAdded |
VariableInfoRemoved |
VariableRemoved |

See Also

IOperator Interface
HeuristicLab.Core Namespace


IOperator Methods

[image]

HeuristicLab API Documentation
IOperator Methods
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperator type exposes the following members.

Methods

Name | Description
Abort |
AddConstraint | (Inherited from IConstrainedItem.)
AddSubOperator | Overloaded.
AddVariable |
AddVariableInfo |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
Execute |
FireChanged | (Inherited from IItem.)
GetVariable |
GetVariableInfo |
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from IStorable.)
IsValid | Overloaded.
Populate | (Inherited from IStorable.)
RemoveConstraint | (Inherited from IConstrainedItem.)
RemoveSubOperator |
RemoveVariable |
RemoveVariableInfo |
Reset |
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

IOperator Interface
HeuristicLab.Core Namespace


Abort Method

IOperator..::.Abort Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.Abort]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Abort()

See Also

IOperator Interface
HeuristicLab.Core Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
IOperator..::.AddSubOperator Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) |
AddSubOperator(IOperator, Int32) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


AddSubOperator Method (IOperator)

IOperator..::.AddSubOperator Method (IOperator)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.AddSubOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddSubOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

IOperator Interface
AddSubOperator Overload
HeuristicLab.Core Namespace


AddSubOperator Method (IOperator, Int32)

IOperator..::.AddSubOperator Method (IOperator, Int32)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.AddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddSubOperator(
    IOperator op,
    int index
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

IOperator Interface
AddSubOperator Overload
HeuristicLab.Core Namespace


AddVariable Method

IOperator..::.AddVariable Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.AddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

IOperator Interface
HeuristicLab.Core Namespace


AddVariableInfo Method

IOperator..::.AddVariableInfo Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.AddVariableInfo(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddVariableInfo(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

See Also

IOperator Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IOperator..::.Clone Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


Execute Method

IOperator..::.Execute Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.Execute(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IOperation Execute(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.Execute(HeuristicLab.Core.IScope)]

See Also

IOperator Interface
HeuristicLab.Core Namespace


GetVariable Method

IOperator..::.GetVariable Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.GetVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IVariable GetVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.GetVariable(System.String)]

See Also

IOperator Interface
HeuristicLab.Core Namespace


GetVariableInfo Method

IOperator..::.GetVariableInfo Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.GetVariableInfo(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IVariableInfo GetVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.GetVariableInfo(System.String)]

See Also

IOperator Interface
HeuristicLab.Core Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
IOperator..::.GetVariableValue Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue(String, IScope, Boolean) |
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) |
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) |
GetVariableValue(String, IScope, Boolean, Boolean) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


GetVariableValue Method (String, IScope, Boolean)

IOperator..::.GetVariableValue Method (String, IScope, Boolean)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IItem GetVariableValue(
    string formalName,
    IScope scope,
    bool recursiveLookup
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean)]

See Also

IOperator Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, IScope, Boolean)

IOperator..::.GetVariableValue<(Of <(T>)>) Method (String, IScope, Boolean)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
T GetVariableValue<T>(
    string formalName,
    IScope scope,
    bool recursiveLookup
) where T : class, IItem

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean)]

See Also

IOperator Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, IScope, Boolean, Boolean)

IOperator..::.GetVariableValue<(Of <(T>)>) Method (String, IScope, Boolean, Boolean)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
T GetVariableValue<T>(
    string formalName,
    IScope scope,
    bool recursiveLookup,
    bool throwOnError
) where T : class, IItem

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

See Also

IOperator Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue Method (String, IScope, Boolean, Boolean)

IOperator..::.GetVariableValue Method (String, IScope, Boolean, Boolean)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IItem GetVariableValue(
    string formalName,
    IScope scope,
    bool recursiveLookup,
    bool throwOnError
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

See Also

IOperator Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


IsValid Method

[image]

HeuristicLab API Documentation
IOperator..::.IsValid Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from IConstrainedItem.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from IConstrainedItem.)

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


RemoveSubOperator Method

IOperator..::.RemoveSubOperator Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.RemoveSubOperator(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveSubOperator(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

IOperator Interface
HeuristicLab.Core Namespace


RemoveVariable Method

IOperator..::.RemoveVariable Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.RemoveVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

See Also

IOperator Interface
HeuristicLab.Core Namespace


RemoveVariableInfo Method

IOperator..::.RemoveVariableInfo Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.RemoveVariableInfo(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

See Also

IOperator Interface
HeuristicLab.Core Namespace


Reset Method

IOperator..::.Reset Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Reset()

See Also

IOperator Interface
HeuristicLab.Core Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
IOperator..::.TryAddSubOperator Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) |
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) |
TryAddSubOperator(IOperator, Int32) |
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator)

IOperator..::.TryAddSubOperator Method (IOperator)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddSubOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator)]

See Also

IOperator Interface
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator, ICollection(IConstraint) )

IOperator..::.TryAddSubOperator Method (IOperator, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddSubOperator(
    IOperator op,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator, Int32)

IOperator..::.TryAddSubOperator Method (IOperator, Int32)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddSubOperator(
    IOperator op,
    int index
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

See Also

IOperator Interface
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator, Int32, ICollection(IConstraint) )

IOperator..::.TryAddSubOperator Method (IOperator, Int32, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddSubOperator(
    IOperator op,
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
IOperator..::.TryAddVariable Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) |
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


TryAddVariable Method (IVariable)

IOperator..::.TryAddVariable Method (IVariable)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddVariable(HeuristicLab.Core.IVariable)]

See Also

IOperator Interface
TryAddVariable Overload
HeuristicLab.Core Namespace


TryAddVariable Method (IVariable, ICollection(IConstraint) )

IOperator..::.TryAddVariable Method (IVariable, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddVariable(HeuristicLab.Core.IVariable,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddVariable(
    IVariable variable,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddVariable(HeuristicLab.Core.IVariable,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryAddVariable Overload
HeuristicLab.Core Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
IOperator..::.TryAddVariableInfo Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) |
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


TryAddVariableInfo Method (IVariableInfo)

IOperator..::.TryAddVariableInfo Method (IVariableInfo)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddVariableInfo(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo)]

See Also

IOperator Interface
TryAddVariableInfo Overload
HeuristicLab.Core Namespace


TryAddVariableInfo Method (IVariableInfo, ICollection(IConstraint) )

IOperator..::.TryAddVariableInfo Method (IVariableInfo, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryAddVariableInfo(
    IVariableInfo variableInfo,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryAddVariableInfo Overload
HeuristicLab.Core Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
IOperator..::.TryRemoveSubOperator Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) |
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


TryRemoveSubOperator Method (Int32)

IOperator..::.TryRemoveSubOperator Method (Int32)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryRemoveSubOperator(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryRemoveSubOperator(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryRemoveSubOperator(System.Int32)]

See Also

IOperator Interface
TryRemoveSubOperator Overload
HeuristicLab.Core Namespace


TryRemoveSubOperator Method (Int32, ICollection(IConstraint) )

IOperator..::.TryRemoveSubOperator Method (Int32, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryRemoveSubOperator(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryRemoveSubOperator(
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryRemoveSubOperator(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryRemoveSubOperator Overload
HeuristicLab.Core Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
IOperator..::.TryRemoveVariable Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) |
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


TryRemoveVariable Method (String)

IOperator..::.TryRemoveVariable Method (String)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryRemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariable(System.String)]

See Also

IOperator Interface
TryRemoveVariable Overload
HeuristicLab.Core Namespace


TryRemoveVariable Method (String, ICollection(IConstraint) )

IOperator..::.TryRemoveVariable Method (String, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariable(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryRemoveVariable(
    string name,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariable(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryRemoveVariable Overload
HeuristicLab.Core Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
IOperator..::.TryRemoveVariableInfo Method
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) |
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) |

See Also

IOperator Interface
IOperator Members
HeuristicLab.Core Namespace


TryRemoveVariableInfo Method (String)

IOperator..::.TryRemoveVariableInfo Method (String)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariableInfo(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryRemoveVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariableInfo(System.String)]

See Also

IOperator Interface
TryRemoveVariableInfo Overload
HeuristicLab.Core Namespace


TryRemoveVariableInfo Method (String, ICollection(IConstraint) )

IOperator..::.TryRemoveVariableInfo Method (String, ICollection<(Of <(IConstraint>)>) %)
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariableInfo(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool TryRemoveVariableInfo(
    string formalName,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperator.TryRemoveVariableInfo(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

IOperator Interface
TryRemoveVariableInfo Overload
HeuristicLab.Core Namespace


IOperator Properties

[image]

HeuristicLab API Documentation
IOperator Properties
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperator type exposes the following members.

Properties

Name | Description
Breakpoint |
Canceled |
Constraints | (Inherited from IConstrainedItem.)
Description |
Guid | (Inherited from IStorable.)
Name |
SubOperators |
VariableInfos |
Variables |

See Also

IOperator Interface
HeuristicLab.Core Namespace


Breakpoint Property

IOperator..::.Breakpoint Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.Breakpoint]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Breakpoint { get; set; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


Canceled Property

IOperator..::.Canceled Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.Canceled]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Canceled { get; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


Description Property

IOperator..::.Description Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.Description]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Description { get; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


Name Property

IOperator..::.Name Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Name { get; set; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


SubOperators Property

IOperator..::.SubOperators Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.SubOperators]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IOperator> SubOperators { get; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


VariableInfos Property

IOperator..::.VariableInfos Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.VariableInfos]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IVariableInfo> VariableInfos { get; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


Variables Property

IOperator..::.Variables Property
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperator.Variables]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IVariable> Variables { get; }

See Also

IOperator Interface
HeuristicLab.Core Namespace


IOperator Events

[image]

HeuristicLab API Documentation
IOperator Events
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperator type exposes the following members.

Events

Name | Description
BreakpointChanged |
Changed | (Inherited from IItem.)
ConstraintAdded | (Inherited from IConstrainedItem.)
ConstraintRemoved | (Inherited from IConstrainedItem.)
Executed |
Initialized |
NameChanged |
SubOperatorAdded |
SubOperatorRemoved |
VariableAdded |
VariableInfoAdded |
VariableInfoRemoved |
VariableRemoved |

See Also

IOperator Interface
HeuristicLab.Core Namespace


BreakpointChanged Event

IOperator..::.BreakpointChanged Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.BreakpointChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler BreakpointChanged

See Also

IOperator Interface
HeuristicLab.Core Namespace


Executed Event

IOperator..::.Executed Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.Executed]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Executed

See Also

IOperator Interface
HeuristicLab.Core Namespace


Initialized Event

IOperator..::.Initialized Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.Initialized]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler Initialized

See Also

IOperator Interface
HeuristicLab.Core Namespace


NameChanged Event

IOperator..::.NameChanged Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.NameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler NameChanged

See Also

IOperator Interface
HeuristicLab.Core Namespace


SubOperatorAdded Event

IOperator..::.SubOperatorAdded Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.SubOperatorAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<OperatorIndexEventArgs> SubOperatorAdded

See Also

IOperator Interface
HeuristicLab.Core Namespace


SubOperatorRemoved Event

IOperator..::.SubOperatorRemoved Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.SubOperatorRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<OperatorIndexEventArgs> SubOperatorRemoved

See Also

IOperator Interface
HeuristicLab.Core Namespace


VariableAdded Event

IOperator..::.VariableAdded Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.VariableAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<VariableEventArgs> VariableAdded

See Also

IOperator Interface
HeuristicLab.Core Namespace


VariableInfoAdded Event

IOperator..::.VariableInfoAdded Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.VariableInfoAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<VariableInfoEventArgs> VariableInfoAdded

See Also

IOperator Interface
HeuristicLab.Core Namespace


VariableInfoRemoved Event

IOperator..::.VariableInfoRemoved Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.VariableInfoRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<VariableInfoEventArgs> VariableInfoRemoved

See Also

IOperator Interface
HeuristicLab.Core Namespace


VariableRemoved Event

IOperator..::.VariableRemoved Event
IOperator Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperator.VariableRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<VariableEventArgs> VariableRemoved

See Also

IOperator Interface
HeuristicLab.Core Namespace


IOperatorGraph Interface

IOperatorGraph Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IOperatorGraph]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IOperatorGraph : IItem,
    IStorable, IViewable

See Also

IOperatorGraph Members
HeuristicLab.Core Namespace


IOperatorGraph Members

[image]

HeuristicLab API Documentation
IOperatorGraph Members
IOperatorGraph Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGraph type exposes the following members.

Methods

Name | Description
AddOperator |
Clear |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetOperator |
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
RemoveOperator |
Reset |

Properties

Name | Description
Guid | (Inherited from IStorable.)
InitialOperator |
Operators |

Events

Name | Description
Changed | (Inherited from IItem.)
InitialOperatorChanged |
OperatorAdded |
OperatorRemoved |

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


IOperatorGraph Methods

[image]

HeuristicLab API Documentation
IOperatorGraph Methods
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGraph type exposes the following members.

Methods

Name | Description
AddOperator |
Clear |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetOperator |
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
RemoveOperator |
Reset |

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


AddOperator Method

IOperatorGraph..::.AddOperator Method
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGraph.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


Clear Method

IOperatorGraph..::.Clear Method
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGraph.Clear]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Clear()

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IOperatorGraph..::.Clone Method
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IOperatorGraph Interface
IOperatorGraph Members
HeuristicLab.Core Namespace


GetOperator Method

IOperatorGraph..::.GetOperator Method
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGraph.GetOperator(System.Guid)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IOperator GetOperator(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IOperatorGraph.GetOperator(System.Guid)]

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


RemoveOperator Method

IOperatorGraph..::.RemoveOperator Method
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGraph.RemoveOperator(System.Guid)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveOperator(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


Reset Method

IOperatorGraph..::.Reset Method
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGraph.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Reset()

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


IOperatorGraph Properties

[image]

HeuristicLab API Documentation
IOperatorGraph Properties
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGraph type exposes the following members.

Properties

Name | Description
Guid | (Inherited from IStorable.)
InitialOperator |
Operators |

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


InitialOperator Property

IOperatorGraph..::.InitialOperator Property
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperatorGraph.InitialOperator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IOperator InitialOperator { get; set; }

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


Operators Property

IOperatorGraph..::.Operators Property
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperatorGraph.Operators]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IOperator> Operators { get; }

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


IOperatorGraph Events

[image]

HeuristicLab API Documentation
IOperatorGraph Events
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGraph type exposes the following members.

Events

Name | Description
Changed | (Inherited from IItem.)
InitialOperatorChanged |
OperatorAdded |
OperatorRemoved |

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


InitialOperatorChanged Event

IOperatorGraph..::.InitialOperatorChanged Event
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperatorGraph.InitialOperatorChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler InitialOperatorChanged

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


OperatorAdded Event

IOperatorGraph..::.OperatorAdded Event
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperatorGraph.OperatorAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<OperatorEventArgs> OperatorAdded

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


OperatorRemoved Event

IOperatorGraph..::.OperatorRemoved Event
IOperatorGraph Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperatorGraph.OperatorRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<OperatorEventArgs> OperatorRemoved

See Also

IOperatorGraph Interface
HeuristicLab.Core Namespace


IOperatorGroup Interface

IOperatorGroup Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IOperatorGroup]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IOperatorGroup : IStorable

See Also

IOperatorGroup Members
HeuristicLab.Core Namespace


IOperatorGroup Members

[image]

HeuristicLab API Documentation
IOperatorGroup Members
IOperatorGroup Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGroup type exposes the following members.

Methods

Name | Description
AddOperator |
AddSubGroup |
Clone | Overloaded.
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
RemoveOperator |
RemoveSubGroup |

Properties

Name | Description
Guid | (Inherited from IStorable.)
Name |
Operators |
SubGroups |

Events

Name | Description
NameChanged |

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


IOperatorGroup Methods

[image]

HeuristicLab API Documentation
IOperatorGroup Methods
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGroup type exposes the following members.

Methods

Name | Description
AddOperator |
AddSubGroup |
Clone | Overloaded.
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
RemoveOperator |
RemoveSubGroup |

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


AddOperator Method

IOperatorGroup..::.AddOperator Method
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGroup.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


AddSubGroup Method

IOperatorGroup..::.AddSubGroup Method
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGroup.AddSubGroup(HeuristicLab.Core.IOperatorGroup)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddSubGroup(
    IOperatorGroup group
)

Parameters

group
Type: HeuristicLab.Core..::.IOperatorGroup

[Missing <param> documentation for "group"]

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IOperatorGroup..::.Clone Method
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IOperatorGroup Interface
IOperatorGroup Members
HeuristicLab.Core Namespace


RemoveOperator Method

IOperatorGroup..::.RemoveOperator Method
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGroup.RemoveOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


RemoveSubGroup Method

IOperatorGroup..::.RemoveSubGroup Method
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IOperatorGroup.RemoveSubGroup(HeuristicLab.Core.IOperatorGroup)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveSubGroup(
    IOperatorGroup group
)

Parameters

group
Type: HeuristicLab.Core..::.IOperatorGroup

[Missing <param> documentation for "group"]

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


IOperatorGroup Properties

[image]

HeuristicLab API Documentation
IOperatorGroup Properties
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGroup type exposes the following members.

Properties

Name | Description
Guid | (Inherited from IStorable.)
Name |
Operators |
SubGroups |

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


Name Property

IOperatorGroup..::.Name Property
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperatorGroup.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Name { get; set; }

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


Operators Property

IOperatorGroup..::.Operators Property
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperatorGroup.Operators]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IOperator> Operators { get; }

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


SubGroups Property

IOperatorGroup..::.SubGroups Property
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperatorGroup.SubGroups]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IOperatorGroup> SubGroups { get; }

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


IOperatorGroup Events

[image]

HeuristicLab API Documentation
IOperatorGroup Events
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorGroup type exposes the following members.

Events

Name | Description
NameChanged |

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


NameChanged Event

IOperatorGroup..::.NameChanged Event
IOperatorGroup Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IOperatorGroup.NameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler NameChanged

See Also

IOperatorGroup Interface
HeuristicLab.Core Namespace


IOperatorLibrary Interface

IOperatorLibrary Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IOperatorLibrary]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IOperatorLibrary : IItem,
    IStorable, IViewable

See Also

IOperatorLibrary Members
HeuristicLab.Core Namespace


IOperatorLibrary Members

[image]

HeuristicLab API Documentation
IOperatorLibrary Members
IOperatorLibrary Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorLibrary type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Group |
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)

See Also

IOperatorLibrary Interface
HeuristicLab.Core Namespace


IOperatorLibrary Properties

[image]

HeuristicLab API Documentation
IOperatorLibrary Properties
IOperatorLibrary Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IOperatorLibrary type exposes the following members.

Properties

Name | Description
Group |
Guid | (Inherited from IStorable.)

See Also

IOperatorLibrary Interface
HeuristicLab.Core Namespace


Group Property

IOperatorLibrary..::.Group Property
IOperatorLibrary Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IOperatorLibrary.Group]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IOperatorGroup Group { get; }

See Also

IOperatorLibrary Interface
HeuristicLab.Core Namespace


IRandom Interface

IRandom Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IRandom]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IRandom : IItem,
    IStorable, IViewable

See Also

IRandom Members
HeuristicLab.Core Namespace


IRandom Members

[image]

HeuristicLab API Documentation
IRandom Members
IRandom Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IRandom type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Next | Overloaded.
NextDouble |
Populate | (Inherited from IStorable.)
Reset | Overloaded.

Properties

Name | Description
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)

See Also

IRandom Interface
HeuristicLab.Core Namespace


IRandom Methods

[image]

HeuristicLab API Documentation
IRandom Methods
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IRandom type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Next | Overloaded.
NextDouble |
Populate | (Inherited from IStorable.)
Reset | Overloaded.

See Also

IRandom Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IRandom..::.Clone Method
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IRandom Interface
IRandom Members
HeuristicLab.Core Namespace


Next Method

[image]

HeuristicLab API Documentation
IRandom..::.Next Method
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Next()()() |
Next(Int32) |
Next(Int32, Int32) |

See Also

IRandom Interface
IRandom Members
HeuristicLab.Core Namespace


Next Method

IRandom..::.Next Method
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IRandom.Next]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
int Next()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IRandom.Next]

See Also

IRandom Interface
Next Overload
HeuristicLab.Core Namespace


Next Method (Int32)

IRandom..::.Next Method (Int32)
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IRandom.Next(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
int Next(
    int maxVal
)

Parameters

maxVal
Type: System..::.Int32

[Missing <param> documentation for "maxVal"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IRandom.Next(System.Int32)]

See Also

IRandom Interface
Next Overload
HeuristicLab.Core Namespace


Next Method (Int32, Int32)

IRandom..::.Next Method (Int32, Int32)
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IRandom.Next(System.Int32,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
int Next(
    int minVal,
    int maxVal
)

Parameters

minVal
Type: System..::.Int32

[Missing <param> documentation for "minVal"]

maxVal
Type: System..::.Int32

[Missing <param> documentation for "maxVal"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IRandom.Next(System.Int32,System.Int32)]

See Also

IRandom Interface
Next Overload
HeuristicLab.Core Namespace


NextDouble Method

IRandom..::.NextDouble Method
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IRandom.NextDouble]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
double NextDouble()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IRandom.NextDouble]

See Also

IRandom Interface
HeuristicLab.Core Namespace


Reset Method

[image]

HeuristicLab API Documentation
IRandom..::.Reset Method
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reset()()() |
Reset(Int32) |

See Also

IRandom Interface
IRandom Members
HeuristicLab.Core Namespace


Reset Method

IRandom..::.Reset Method
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IRandom.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Reset()

See Also

IRandom Interface
Reset Overload
HeuristicLab.Core Namespace


Reset Method (Int32)

IRandom..::.Reset Method (Int32)
IRandom Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IRandom.Reset(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Reset(
    int seed
)

Parameters

seed
Type: System..::.Int32

[Missing <param> documentation for "seed"]

See Also

IRandom Interface
Reset Overload
HeuristicLab.Core Namespace


IScope Interface

IScope Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IScope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IScope : IItem, IStorable,
    IViewable

See Also

IScope Members
HeuristicLab.Core Namespace


IScope Members

[image]

HeuristicLab API Documentation
IScope Members
IScope Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IScope type exposes the following members.

Methods

Name | Description
AddSubScope |
AddVariable |
Clear |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetScope | Overloaded.
GetVariable |
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
RemoveSubScope |
RemoveVariable |
ReorderSubScopes |
SetParent |

Properties

Name | Description
Guid | (Inherited from IStorable.)
Name |
SubScopes |
Variables |

Events

Name | Description
Changed | (Inherited from IItem.)
SubScopeAdded |
SubScopeRemoved |
SubScopesReordered |
VariableAdded |
VariableRemoved |

See Also

IScope Interface
HeuristicLab.Core Namespace


IScope Methods

[image]

HeuristicLab API Documentation
IScope Methods
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IScope type exposes the following members.

Methods

Name | Description
AddSubScope |
AddVariable |
Clear |
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetScope | Overloaded.
GetVariable |
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)
RemoveSubScope |
RemoveVariable |
ReorderSubScopes |
SetParent |

See Also

IScope Interface
HeuristicLab.Core Namespace


AddSubScope Method

IScope..::.AddSubScope Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.AddSubScope(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddSubScope(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

IScope Interface
HeuristicLab.Core Namespace


AddVariable Method

IScope..::.AddVariable Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.AddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void AddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

IScope Interface
HeuristicLab.Core Namespace


Clear Method

IScope..::.Clear Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.Clear]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Clear()

See Also

IScope Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IScope..::.Clone Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IScope Interface
IScope Members
HeuristicLab.Core Namespace


GetScope Method

[image]

HeuristicLab API Documentation
IScope..::.GetScope Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetScope(Guid) |
GetScope(String) |

See Also

IScope Interface
IScope Members
HeuristicLab.Core Namespace


GetScope Method (Guid)

IScope..::.GetScope Method (Guid)
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetScope(System.Guid)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IScope GetScope(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetScope(System.Guid)]

See Also

IScope Interface
GetScope Overload
HeuristicLab.Core Namespace


GetScope Method (String)

IScope..::.GetScope Method (String)
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetScope(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IScope GetScope(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetScope(System.String)]

See Also

IScope Interface
GetScope Overload
HeuristicLab.Core Namespace


GetVariable Method

IScope..::.GetVariable Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IVariable GetVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetVariable(System.String)]

See Also

IScope Interface
HeuristicLab.Core Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
IScope..::.GetVariableValue Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, Boolean) |
GetVariableValue(String, Boolean) |
GetVariableValue(String, Boolean, Boolean) |
GetVariableValue<(Of <(T>)>)(String, Boolean, Boolean) |

See Also

IScope Interface
IScope Members
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, Boolean)

IScope..::.GetVariableValue<(Of <(T>)>) Method (String, Boolean)
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetVariableValue``1(System.String,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
T GetVariableValue<T>(
    string name,
    bool recursiveLookup
) where T : class, IItem

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetVariableValue``1(System.String,System.Boolean)]

See Also

IScope Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue Method (String, Boolean)

IScope..::.GetVariableValue Method (String, Boolean)
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetVariableValue(System.String,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IItem GetVariableValue(
    string name,
    bool recursiveLookup
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetVariableValue(System.String,System.Boolean)]

See Also

IScope Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue Method (String, Boolean, Boolean)

IScope..::.GetVariableValue Method (String, Boolean, Boolean)
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetVariableValue(System.String,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IItem GetVariableValue(
    string name,
    bool recursiveLookup,
    bool throwOnError
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetVariableValue(System.String,System.Boolean,System.Boolean)]

See Also

IScope Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, Boolean, Boolean)

IScope..::.GetVariableValue<(Of <(T>)>) Method (String, Boolean, Boolean)
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.GetVariableValue``1(System.String,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
T GetVariableValue<T>(
    string name,
    bool recursiveLookup,
    bool throwOnError
) where T : class, IItem

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IScope.GetVariableValue``1(System.String,System.Boolean,System.Boolean)]

See Also

IScope Interface
GetVariableValue Overload
HeuristicLab.Core Namespace


RemoveSubScope Method

IScope..::.RemoveSubScope Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.RemoveSubScope(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveSubScope(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

IScope Interface
HeuristicLab.Core Namespace


RemoveVariable Method

IScope..::.RemoveVariable Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.RemoveVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void RemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

See Also

IScope Interface
HeuristicLab.Core Namespace


ReorderSubScopes Method

IScope..::.ReorderSubScopes Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.ReorderSubScopes(System.Int32[])]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ReorderSubScopes(
    int[] sequence
)

Parameters

sequence
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "sequence"]

See Also

IScope Interface
HeuristicLab.Core Namespace


SetParent Method

IScope..::.SetParent Method
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IScope.SetParent(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void SetParent(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

IScope Interface
HeuristicLab.Core Namespace


IScope Properties

[image]

HeuristicLab API Documentation
IScope Properties
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IScope type exposes the following members.

Properties

Name | Description
Guid | (Inherited from IStorable.)
Name |
SubScopes |
Variables |

See Also

IScope Interface
HeuristicLab.Core Namespace


Name Property

IScope..::.Name Property
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IScope.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Name { get; }

See Also

IScope Interface
HeuristicLab.Core Namespace


SubScopes Property

IScope..::.SubScopes Property
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IScope.SubScopes]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IScope> SubScopes { get; }

See Also

IScope Interface
HeuristicLab.Core Namespace


Variables Property

IScope..::.Variables Property
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IScope.Variables]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IVariable> Variables { get; }

See Also

IScope Interface
HeuristicLab.Core Namespace


IScope Events

[image]

HeuristicLab API Documentation
IScope Events
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IScope type exposes the following members.

Events

Name | Description
Changed | (Inherited from IItem.)
SubScopeAdded |
SubScopeRemoved |
SubScopesReordered |
VariableAdded |
VariableRemoved |

See Also

IScope Interface
HeuristicLab.Core Namespace


SubScopeAdded Event

IScope..::.SubScopeAdded Event
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IScope.SubScopeAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<ScopeIndexEventArgs> SubScopeAdded

See Also

IScope Interface
HeuristicLab.Core Namespace


SubScopeRemoved Event

IScope..::.SubScopeRemoved Event
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IScope.SubScopeRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<ScopeIndexEventArgs> SubScopeRemoved

See Also

IScope Interface
HeuristicLab.Core Namespace


SubScopesReordered Event

IScope..::.SubScopesReordered Event
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IScope.SubScopesReordered]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler SubScopesReordered

See Also

IScope Interface
HeuristicLab.Core Namespace


VariableAdded Event

IScope..::.VariableAdded Event
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IScope.VariableAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<VariableEventArgs> VariableAdded

See Also

IScope Interface
HeuristicLab.Core Namespace


VariableRemoved Event

IScope..::.VariableRemoved Event
IScope Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IScope.VariableRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<VariableEventArgs> VariableRemoved

See Also

IScope Interface
HeuristicLab.Core Namespace


IStorable Interface

IStorable Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IStorable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IStorable

See Also

IStorable Members
HeuristicLab.Core Namespace


IStorable Members

[image]

HeuristicLab API Documentation
IStorable Members
IStorable Interface Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IStorable type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
GetXmlNode |
Populate |

Properties

Name | Description
Guid |

See Also

IStorable Interface
HeuristicLab.Core Namespace


IStorable Methods

[image]

HeuristicLab API Documentation
IStorable Methods
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IStorable type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
GetXmlNode |
Populate |

See Also

IStorable Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IStorable..::.Clone Method
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() |
Clone(IDictionary<(Of <(Guid, Object>)>)) |

See Also

IStorable Interface
IStorable Members
HeuristicLab.Core Namespace


Clone Method

IStorable..::.Clone Method
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IStorable.Clone]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Object Clone()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IStorable.Clone]

See Also

IStorable Interface
Clone Overload
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

IStorable..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IStorable.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IStorable.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

See Also

IStorable Interface
Clone Overload
HeuristicLab.Core Namespace


GetXmlNode Method

IStorable..::.GetXmlNode Method
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IStorable.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IStorable.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

See Also

IStorable Interface
HeuristicLab.Core Namespace


Populate Method

IStorable..::.Populate Method
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IStorable.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

See Also

IStorable Interface
HeuristicLab.Core Namespace


IStorable Properties

[image]

HeuristicLab API Documentation
IStorable Properties
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IStorable type exposes the following members.

Properties

Name | Description
Guid |

See Also

IStorable Interface
HeuristicLab.Core Namespace


Guid Property

IStorable..::.Guid Property
IStorable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IStorable.Guid]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Guid Guid { get; }

See Also

IStorable Interface
HeuristicLab.Core Namespace


ItemBase Class

ItemBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ItemBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ItemBase : StorableBase, IItem,
    IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Constraints..::.ConstraintBase
HeuristicLab.Core..::.CompositeOperation
HeuristicLab.Core..::.Variable
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.Scope
HeuristicLab.Core..::.OperatorGraph
HeuristicLab.Core..::.OperatorLibrary
HeuristicLab.Core..::.AtomicOperation
HeuristicLab.Core..::.VariableInfo
HeuristicLab.Core..::.EngineBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ItemList
HeuristicLab.DataAnalysis..::.Dataset
HeuristicLab.Logging..::.Log
HeuristicLab.Logging..::.Linechart
HeuristicLab.Random..::.NormalDistributedRandom
HeuristicLab.Random..::.MersenneTwister
HeuristicLab.Routing.TSP..::.TSPTour
HeuristicLab.Scheduling.JSSP..::.Schedule
HeuristicLab.Scheduling.JSSP..::.Operation
HeuristicLab.SGA..::.SGA
HeuristicLab.StructureIdentification..::.GPOperatorLibrary

See Also

ItemBase Members
HeuristicLab.Core Namespace


ItemBase Members

[image]

HeuristicLab API Documentation
ItemBase Members
ItemBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemBase type exposes the following members.

Constructors

Name | Description
ItemBase |

Methods

Name | Description
Clone | Overloaded.
CreateView |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged |
Populate | (Inherited from StorableBase.)
ToString | (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed |

See Also

ItemBase Class
HeuristicLab.Core Namespace


ItemBase Constructor

ItemBase Constructor
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ItemBase()

See Also

ItemBase Class
HeuristicLab.Core Namespace


ItemBase Methods

[image]

HeuristicLab API Documentation
ItemBase Methods
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemBase type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged |
Populate | (Inherited from StorableBase.)
ToString | (Overrides Object ..::. ToString()()().)

See Also

ItemBase Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
ItemBase..::.Clone Method
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from StorableBase.)

See Also

ItemBase Class
ItemBase Members
HeuristicLab.Core Namespace


CreateView Method

ItemBase..::.CreateView Method
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ItemBase.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ItemBase.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

ItemBase Class
HeuristicLab.Core Namespace


FireChanged Method

ItemBase..::.FireChanged Method
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ItemBase.FireChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void FireChanged()

Implements

IItem..::.FireChanged()()()

See Also

ItemBase Class
HeuristicLab.Core Namespace


OnChanged Method

ItemBase..::.OnChanged Method
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ItemBase.OnChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnChanged()

See Also

ItemBase Class
HeuristicLab.Core Namespace


ToString Method

ItemBase..::.ToString Method
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ItemBase.ToString]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ItemBase.ToString]

See Also

ItemBase Class
HeuristicLab.Core Namespace


ItemBase Events

[image]

HeuristicLab API Documentation
ItemBase Events
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemBase type exposes the following members.

Events

Name | Description
Changed |

See Also

ItemBase Class
HeuristicLab.Core Namespace


Changed Event

ItemBase..::.Changed Event
ItemBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.ItemBase.Changed]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Changed

Implements

IItem..::.Changed

See Also

ItemBase Class
HeuristicLab.Core Namespace


ItemBaseView Class

ItemBaseView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ItemBaseView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemBaseView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.ItemBaseView

See Also

ItemBaseView Members
HeuristicLab.Core Namespace


ItemBaseView Members

[image]

HeuristicLab API Documentation
ItemBaseView Members
ItemBaseView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemBaseView type exposes the following members.

Constructors

Name | Description
ItemBaseView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ItemBaseView Class
HeuristicLab.Core Namespace


ItemBaseView Constructor

[image]

HeuristicLab API Documentation
ItemBaseView Constructor
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ItemBaseView()()() |
ItemBaseView(IItem) |

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


ItemBaseView Constructor

ItemBaseView Constructor
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemBaseView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemBaseView()

See Also

ItemBaseView Class
ItemBaseView Overload
HeuristicLab.Core Namespace


ItemBaseView Constructor (IItem)

ItemBaseView Constructor (IItem)
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemBaseView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemBaseView(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

See Also

ItemBaseView Class
ItemBaseView Overload
HeuristicLab.Core Namespace


ItemBaseView Methods

[image]

HeuristicLab API Documentation
ItemBaseView Methods
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemBaseView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ViewBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ItemBaseView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.AccessibilityNotifyClients Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.BeginInvoke Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.Dispose Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ItemBaseView..::.Dispose Method (Boolean)
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ItemBaseView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.GetChildAtPoint Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.Invalidate Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.Invoke Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.MemberwiseClone Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.PerformLayout Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.ResumeLayout Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.RtlTranslateAlignment Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.Scale Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.Select Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.SetBounds Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.UpdateBounds Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.Validate Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ItemBaseView..::.ValidateChildren Method
ItemBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ItemBaseView Class
ItemBaseView Members
HeuristicLab.Core Namespace


ItemEventArgs Class

ItemEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ItemEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.ScopeEventArgs
HeuristicLab.Core..::.OperatorEventArgs
HeuristicLab.Core..::.VariableEventArgs
HeuristicLab.Core..::.ConstraintEventArgs
HeuristicLab.Core..::.ItemIndexEventArgs
HeuristicLab.Core..::.VariableInfoEventArgs

See Also

ItemEventArgs Members
HeuristicLab.Core Namespace


ItemEventArgs Members

[image]

HeuristicLab API Documentation
ItemEventArgs Members
ItemEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemEventArgs type exposes the following members.

Constructors

Name | Description
ItemEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

See Also

ItemEventArgs Class
HeuristicLab.Core Namespace


ItemEventArgs Constructor

ItemEventArgs Constructor
ItemEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemEventArgs(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

See Also

ItemEventArgs Class
HeuristicLab.Core Namespace


ItemEventArgs Properties

[image]

HeuristicLab API Documentation
ItemEventArgs Properties
ItemEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemEventArgs type exposes the following members.

Properties

Name | Description
Item |

See Also

ItemEventArgs Class
HeuristicLab.Core Namespace


Item Property

ItemEventArgs..::.Item Property
ItemEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ItemEventArgs.Item]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem Item { get; }

See Also

ItemEventArgs Class
HeuristicLab.Core Namespace


ItemIndexEventArgs Class

ItemIndexEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ItemIndexEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemIndexEventArgs : ItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.ItemIndexEventArgs
HeuristicLab.Core..::.OperatorIndexEventArgs
HeuristicLab.Core..::.ScopeIndexEventArgs

See Also

ItemIndexEventArgs Members
HeuristicLab.Core Namespace


ItemIndexEventArgs Members

[image]

HeuristicLab API Documentation
ItemIndexEventArgs Members
ItemIndexEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemIndexEventArgs type exposes the following members.

Constructors

Name | Description
ItemIndexEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index |
Item | (Inherited from ItemEventArgs.)

See Also

ItemIndexEventArgs Class
HeuristicLab.Core Namespace


ItemIndexEventArgs Constructor

ItemIndexEventArgs Constructor
ItemIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemIndexEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemIndexEventArgs(
    IItem item,
    int index
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

ItemIndexEventArgs Class
HeuristicLab.Core Namespace


ItemIndexEventArgs Properties

[image]

HeuristicLab API Documentation
ItemIndexEventArgs Properties
ItemIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemIndexEventArgs type exposes the following members.

Properties

Name | Description
Index |
Item | (Inherited from ItemEventArgs.)

See Also

ItemIndexEventArgs Class
HeuristicLab.Core Namespace


Index Property

ItemIndexEventArgs..::.Index Property
ItemIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ItemIndexEventArgs.Index]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Index { get; }

See Also

ItemIndexEventArgs Class
HeuristicLab.Core Namespace


IVariable Interface

IVariable Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IVariable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IVariable : IItem,
    IStorable, IViewable

See Also

IVariable Members
HeuristicLab.Core Namespace


IVariable Members

[image]

HeuristicLab API Documentation
IVariable Members
IVariable Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariable type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetValue<(Of <(T>)>) |
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Guid | (Inherited from IStorable.)
Name |
Value |

Events

Name | Description
Changed | (Inherited from IItem.)
NameChanged |
NameChanging |
ValueChanged |

See Also

IVariable Interface
HeuristicLab.Core Namespace


IVariable Methods

[image]

HeuristicLab API Documentation
IVariable Methods
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariable type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetValue<(Of <(T>)>) |
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

See Also

IVariable Interface
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
IVariable..::.Clone Method
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IVariable Interface
IVariable Members
HeuristicLab.Core Namespace


GetValue(T) Method

IVariable..::.GetValue<(Of <(T>)>) Method
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IVariable.GetValue``1]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
T GetValue<T>() where T : class, IItem

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IVariable.GetValue``1]

See Also

IVariable Interface
HeuristicLab.Core Namespace


IVariable Properties

[image]

HeuristicLab API Documentation
IVariable Properties
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariable type exposes the following members.

Properties

Name | Description
Guid | (Inherited from IStorable.)
Name |
Value |

See Also

IVariable Interface
HeuristicLab.Core Namespace


Name Property

IVariable..::.Name Property
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariable.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Name { get; set; }

See Also

IVariable Interface
HeuristicLab.Core Namespace


Value Property

IVariable..::.Value Property
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariable.Value]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IItem Value { get; set; }

See Also

IVariable Interface
HeuristicLab.Core Namespace


IVariable Events

[image]

HeuristicLab API Documentation
IVariable Events
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariable type exposes the following members.

Events

Name | Description
Changed | (Inherited from IItem.)
NameChanged |
NameChanging |
ValueChanged |

See Also

IVariable Interface
HeuristicLab.Core Namespace


NameChanged Event

IVariable..::.NameChanged Event
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IVariable.NameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler NameChanged

See Also

IVariable Interface
HeuristicLab.Core Namespace


NameChanging Event

IVariable..::.NameChanging Event
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IVariable.NameChanging]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler<NameChangingEventArgs> NameChanging

See Also

IVariable Interface
HeuristicLab.Core Namespace


ValueChanged Event

IVariable..::.ValueChanged Event
IVariable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IVariable.ValueChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler ValueChanged

See Also

IVariable Interface
HeuristicLab.Core Namespace


IVariableInfo Interface

IVariableInfo Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IVariableInfo]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IVariableInfo : IItem,
    IStorable, IViewable

See Also

IVariableInfo Members
HeuristicLab.Core Namespace


IVariableInfo Members

[image]

HeuristicLab API Documentation
IVariableInfo Members
IVariableInfo Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariableInfo type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
ActualName |
DataType |
Description |
FormalName |
Guid | (Inherited from IStorable.)
Kind |
Local |

Events

Name | Description
ActualNameChanged |
Changed | (Inherited from IItem.)
LocalChanged |

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


IVariableInfo Properties

[image]

HeuristicLab API Documentation
IVariableInfo Properties
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariableInfo type exposes the following members.

Properties

Name | Description
ActualName |
DataType |
Description |
FormalName |
Guid | (Inherited from IStorable.)
Kind |
Local |

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


ActualName Property

IVariableInfo..::.ActualName Property
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariableInfo.ActualName]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string ActualName { get; set; }

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


DataType Property

IVariableInfo..::.DataType Property
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariableInfo.DataType]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Type DataType { get; }

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


Description Property

IVariableInfo..::.Description Property
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariableInfo.Description]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Description { get; }

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


FormalName Property

IVariableInfo..::.FormalName Property
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariableInfo.FormalName]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string FormalName { get; }

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


Kind Property

IVariableInfo..::.Kind Property
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariableInfo.Kind]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
VariableKind Kind { get; }

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


Local Property

IVariableInfo..::.Local Property
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IVariableInfo.Local]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
bool Local { get; set; }

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


IVariableInfo Events

[image]

HeuristicLab API Documentation
IVariableInfo Events
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVariableInfo type exposes the following members.

Events

Name | Description
ActualNameChanged |
Changed | (Inherited from IItem.)
LocalChanged |

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


ActualNameChanged Event

IVariableInfo..::.ActualNameChanged Event
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IVariableInfo.ActualNameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler ActualNameChanged

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


LocalChanged Event

IVariableInfo..::.LocalChanged Event
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IVariableInfo.LocalChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler LocalChanged

See Also

IVariableInfo Interface
HeuristicLab.Core Namespace


IView Interface

IView Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IView : IControl

See Also

IView Members
HeuristicLab.Core Namespace


IView Members

[image]

HeuristicLab API Documentation
IView Members
IView Interface Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IView type exposes the following members.

Properties

Name | Description
Caption |
Item |

Events

Name | Description
CaptionChanged |
ItemChanged |

See Also

IView Interface
HeuristicLab.Core Namespace


IView Properties

[image]

HeuristicLab API Documentation
IView Properties
IView Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IView type exposes the following members.

Properties

Name | Description
Caption |
Item |

See Also

IView Interface
HeuristicLab.Core Namespace


Caption Property

IView..::.Caption Property
IView Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IView.Caption]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Caption { get; set; }

See Also

IView Interface
HeuristicLab.Core Namespace


Item Property

IView..::.Item Property
IView Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.IView.Item]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IItem Item { get; }

See Also

IView Interface
HeuristicLab.Core Namespace


IView Events

[image]

HeuristicLab API Documentation
IView Events
IView Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IView type exposes the following members.

Events

Name | Description
CaptionChanged |
ItemChanged |

See Also

IView Interface
HeuristicLab.Core Namespace


CaptionChanged Event

IView..::.CaptionChanged Event
IView Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IView.CaptionChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler CaptionChanged

See Also

IView Interface
HeuristicLab.Core Namespace


ItemChanged Event

IView..::.ItemChanged Event
IView Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.IView.ItemChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
event EventHandler ItemChanged

See Also

IView Interface
HeuristicLab.Core Namespace


IViewable Interface

IViewable Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IViewable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IViewable

See Also

IViewable Members
HeuristicLab.Core Namespace


IViewable Members

[image]

HeuristicLab API Documentation
IViewable Members
IViewable Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IViewable type exposes the following members.

Methods

Name | Description
CreateView |

See Also

IViewable Interface
HeuristicLab.Core Namespace


IViewable Methods

[image]

HeuristicLab API Documentation
IViewable Methods
IViewable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IViewable type exposes the following members.

Methods

Name | Description
CreateView |

See Also

IViewable Interface
HeuristicLab.Core Namespace


CreateView Method

IViewable..::.CreateView Method
IViewable Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.IViewable.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.IViewable.CreateView]

See Also

IViewable Interface
HeuristicLab.Core Namespace


IVisualizationItem Interface

IVisualizationItem Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.IVisualizationItem]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IVisualizationItem : IItem,
    IStorable, IViewable

See Also

IVisualizationItem Members
HeuristicLab.Core Namespace


IVisualizationItem Members

[image]

HeuristicLab API Documentation
IVisualizationItem Members
IVisualizationItem Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IVisualizationItem type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)

See Also

IVisualizationItem Interface
HeuristicLab.Core Namespace


NameChangingEventArgs Class

NameChangingEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.NameChangingEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NameChangingEventArgs : CancelEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
HeuristicLab.Core..::.NameChangingEventArgs

See Also

NameChangingEventArgs Members
HeuristicLab.Core Namespace


NameChangingEventArgs Members

[image]

HeuristicLab API Documentation
NameChangingEventArgs Members
NameChangingEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NameChangingEventArgs type exposes the following members.

Constructors

Name | Description
NameChangingEventArgs | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Name |

See Also

NameChangingEventArgs Class
HeuristicLab.Core Namespace


NameChangingEventArgs Constructor

[image]

HeuristicLab API Documentation
NameChangingEventArgs Constructor
NameChangingEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
NameChangingEventArgs(String) |
NameChangingEventArgs(String, Boolean) |

See Also

NameChangingEventArgs Class
NameChangingEventArgs Members
HeuristicLab.Core Namespace


NameChangingEventArgs Constructor (String)

NameChangingEventArgs Constructor (String)
NameChangingEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NameChangingEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NameChangingEventArgs(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

See Also

NameChangingEventArgs Class
NameChangingEventArgs Overload
HeuristicLab.Core Namespace


NameChangingEventArgs Constructor (String, Boolean)

NameChangingEventArgs Constructor (String, Boolean)
NameChangingEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NameChangingEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NameChangingEventArgs(
    string name,
    bool cancel
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

cancel
Type: System..::.Boolean

[Missing <param> documentation for "cancel"]

See Also

NameChangingEventArgs Class
NameChangingEventArgs Overload
HeuristicLab.Core Namespace


NameChangingEventArgs Properties

[image]

HeuristicLab API Documentation
NameChangingEventArgs Properties
NameChangingEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NameChangingEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Name |

See Also

NameChangingEventArgs Class
HeuristicLab.Core Namespace


Name Property

NameChangingEventArgs..::.Name Property
NameChangingEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.NameChangingEventArgs.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; }

See Also

NameChangingEventArgs Class
HeuristicLab.Core Namespace


OperationEventArgs Class

OperationEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperationEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperationEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.OperationEventArgs

See Also

OperationEventArgs Members
HeuristicLab.Core Namespace


OperationEventArgs Members

[image]

HeuristicLab API Documentation
OperationEventArgs Members
OperationEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationEventArgs type exposes the following members.

Constructors

Name | Description
OperationEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Operation |

See Also

OperationEventArgs Class
HeuristicLab.Core Namespace


OperationEventArgs Constructor

OperationEventArgs Constructor
OperationEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperationEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperationEventArgs(
    IOperation operation
)

Parameters

operation
Type: HeuristicLab.Core..::.IOperation

[Missing <param> documentation for "operation"]

See Also

OperationEventArgs Class
HeuristicLab.Core Namespace


OperationEventArgs Properties

[image]

HeuristicLab API Documentation
OperationEventArgs Properties
OperationEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationEventArgs type exposes the following members.

Properties

Name | Description
Operation |

See Also

OperationEventArgs Class
HeuristicLab.Core Namespace


Operation Property

OperationEventArgs..::.Operation Property
OperationEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperationEventArgs.Operation]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperation Operation { get; }

See Also

OperationEventArgs Class
HeuristicLab.Core Namespace


OperatorBase Class

OperatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class OperatorBase : ConstrainedItemBase, IOperator,
    IConstrainedItem, IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.BitVector..::.BitVectorManipulatorBase
HeuristicLab.BitVector..::.RandomBitVectorGenerator
HeuristicLab.Evolutionary..::.SuccessRuleMutationStrengthAdjuster
HeuristicLab.Evolutionary..::.UnidirectionalRingMigrator
HeuristicLab.Evolutionary..::.SubScopesStorer
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Evolutionary..::.SASEGASAReunificator
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Logging..::.BestAverageWorstQualityCalculator
HeuristicLab.Logging..::.LinechartInjector
HeuristicLab.Logging..::.QualityLogger
HeuristicLab.Operators..::.SequentialSubScopesProcessor
HeuristicLab.Operators..::.SubScopesMixer
HeuristicLab.Operators..::.StochasticBranch
HeuristicLab.Operators..::.CombinedOperator
HeuristicLab.Operators..::.SubScopesCreater
HeuristicLab.Operators..::.SequentialProcessor
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.ParallelSubScopesProcessor
HeuristicLab.Operators..::.EmptyOperator
HeuristicLab.Operators..::.Counter
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.Operators..::.DataCollector
HeuristicLab.Operators..::.VariableInjector
HeuristicLab.Operators..::.UniformSequentialSubScopesProcessor
HeuristicLab.Operators..::.OperatorExtractor
HeuristicLab.Operators..::.UniformParallelSubScopesProcessor
HeuristicLab.Operators..::.Sorter
HeuristicLab.Operators..::.ConditionalBranch
HeuristicLab.Operators..::.ParallelProcessor
HeuristicLab.Operators.Programmable..::.ProgrammableOperator
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.RandomPermutationGenerator
HeuristicLab.Random..::.NormalRandomAdder
HeuristicLab.Random..::.NormalRandomizer
HeuristicLab.Random..::.UniformRandomAdder
HeuristicLab.Random..::.RandomInjector
HeuristicLab.Random..::.UniformRandomizer
HeuristicLab.RealVector..::.RealVectorManipulatorBase
HeuristicLab.RealVector..::.UniformRandomRealVectorGenerator
HeuristicLab.Routing.TSP..::.TSPTourInjector
HeuristicLab.Routing.TSP..::.TSPDistanceMatrixInjectorBase
HeuristicLab.Routing.TSP..::.TSPInjector
HeuristicLab.Scheduling.JSSP..::.ItemListIndexer
HeuristicLab.Scheduling.JSSP..::.OperationScoreBase
HeuristicLab.Scheduling.JSSP..::.OperationScheduler
HeuristicLab.Scheduling.JSSP..::.IsSchedulable
HeuristicLab.Scheduling.JSSP..::.CopyVariableFromSubScope
HeuristicLab.Scheduling.JSSP..::.ScheduleInjector
HeuristicLab.Scheduling.JSSP..::.OperationUpdater
HeuristicLab.Scheduling.JSSP..::.JSSPInjector
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.ReducerBase
HeuristicLab.Selection.OffspringSelection..::.OffspringSelector
HeuristicLab.Selection.OffspringSelection..::.OffspringAnalyzer
HeuristicLab.StructureIdentification..::.StructIdProblemInjector
HeuristicLab.StructureIdentification..::.SubstituteSubTreeManipulation
HeuristicLab.StructureIdentification..::.FunctionEvaluator
HeuristicLab.StructureIdentification..::.CutOutNodeManipulation
HeuristicLab.StructureIdentification..::.OnePointShaker
HeuristicLab.StructureIdentification..::.PopulationAnalyser
HeuristicLab.StructureIdentification..::.ChangeNodeTypeManipulation
HeuristicLab.StructureIdentification..::.DeleteSubTreeManipulation
HeuristicLab.StructureIdentification..::.RandomTreeCreator
HeuristicLab.StructureIdentification..::.MeanSquaredErrorEvaluator
HeuristicLab.StructureIdentification..::.CoefficientOfDeterminationEvaluator
HeuristicLab.StructureIdentification..::.FullTreeShaker
HeuristicLab.StructureIdentification..::.SinglePointCrossOver
HeuristicLab.StructureIdentification..::.VarianceAccountedForEvaluator

See Also

OperatorBase Members
HeuristicLab.Core Namespace


OperatorBase Members

[image]

HeuristicLab API Documentation
OperatorBase Members
OperatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBase type exposes the following members.

Constructors

Name | Description
OperatorBase |

Methods

Name | Description
Abort |
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable |
AddVariableInfo |
Apply |
Clone | Overloaded.
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable |
GetVariableInfo |
GetVariableValue | Overloaded.
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged |
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted |
OnInitialized |
OnNameChanged |
OnSubOperatorAdded |
OnSubOperatorRemoved |
OnVariableAdded |
OnVariableInfoAdded |
OnVariableInfoRemoved |
OnVariableRemoved |
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator |
RemoveVariable |
RemoveVariableInfo |
Reset |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint |
Canceled |
Constraints | (Inherited from ConstrainedItemBase.)
Description |
Guid | (Inherited from StorableBase.)
Name |
SubOperators |
VariableInfos |
Variables |

Events

Name | Description
BreakpointChanged |
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed |
Initialized |
NameChanged |
SubOperatorAdded |
SubOperatorRemoved |
VariableAdded |
VariableInfoAdded |
VariableInfoRemoved |
VariableRemoved |

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OperatorBase Constructor

OperatorBase Constructor
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected OperatorBase()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OperatorBase Methods

[image]

HeuristicLab API Documentation
OperatorBase Methods
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBase type exposes the following members.

Methods

Name | Description
Abort |
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable |
AddVariableInfo |
Apply |
Clone | Overloaded.
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable |
GetVariableInfo |
GetVariableValue | Overloaded.
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged |
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted |
OnInitialized |
OnNameChanged |
OnSubOperatorAdded |
OnSubOperatorRemoved |
OnVariableAdded |
OnVariableInfoAdded |
OnVariableInfoRemoved |
OnVariableRemoved |
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator |
RemoveVariable |
RemoveVariableInfo |
Reset |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Abort Method

OperatorBase..::.Abort Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.Abort]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Abort()

Implements

IOperator..::.Abort()()()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OperatorBase..::.AddSubOperator Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) |
AddSubOperator(IOperator, Int32) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


AddSubOperator Method (IOperator)

OperatorBase..::.AddSubOperator Method (IOperator)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.AddSubOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddSubOperator(
    IOperator subOperator
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

Implements

IOperator..::.AddSubOperator(IOperator)

See Also

OperatorBase Class
AddSubOperator Overload
HeuristicLab.Core Namespace


AddSubOperator Method (IOperator, Int32)

OperatorBase..::.AddSubOperator Method (IOperator, Int32)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.AddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddSubOperator(
    IOperator subOperator,
    int index
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Implements

IOperator..::.AddSubOperator(IOperator, Int32)

See Also

OperatorBase Class
AddSubOperator Overload
HeuristicLab.Core Namespace


AddVariable Method

OperatorBase..::.AddVariable Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.AddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

Implements

IOperator..::.AddVariable(IVariable)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


AddVariableInfo Method

OperatorBase..::.AddVariableInfo Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.AddVariableInfo(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddVariableInfo(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

Implements

IOperator..::.AddVariableInfo(IVariableInfo)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Apply Method

OperatorBase..::.Apply Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.Apply(HeuristicLab.Core.IScope)]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperatorBase..::.Clone Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ConstrainedItemBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

OperatorBase..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

OperatorBase Class
Clone Overload
HeuristicLab.Core Namespace


CreateView Method

OperatorBase..::.CreateView Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Execute Method

OperatorBase..::.Execute Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.Execute(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IOperation Execute(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.Execute(HeuristicLab.Core.IScope)]

Implements

IOperator..::.Execute(IScope)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


GetVariable Method

OperatorBase..::.GetVariable Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IVariable GetVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetVariable(System.String)]

Implements

IOperator..::.GetVariable(String)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


GetVariableInfo Method

OperatorBase..::.GetVariableInfo Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableInfo(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IVariableInfo GetVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableInfo(System.String)]

Implements

IOperator..::.GetVariableInfo(String)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OperatorBase..::.GetVariableValue Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue(String, IScope, Boolean) |
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) |
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) |
GetVariableValue(String, IScope, Boolean, Boolean) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


GetVariableValue Method (String, IScope, Boolean)

OperatorBase..::.GetVariableValue Method (String, IScope, Boolean)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem GetVariableValue(
    string formalName,
    IScope scope,
    bool recursiveLookup
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean)]

See Also

OperatorBase Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, IScope, Boolean)

OperatorBase..::.GetVariableValue<(Of <(T>)>) Method (String, IScope, Boolean)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public T GetVariableValue<T>(
    string formalName,
    IScope scope,
    bool recursiveLookup
) where T : class, IItem

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean)]

See Also

OperatorBase Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, IScope, Boolean, Boolean)

OperatorBase..::.GetVariableValue<(Of <(T>)>) Method (String, IScope, Boolean, Boolean)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public T GetVariableValue<T>(
    string formalName,
    IScope scope,
    bool recursiveLookup,
    bool throwOnError
) where T : class, IItem

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue``1(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

See Also

OperatorBase Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue Method (String, IScope, Boolean, Boolean)

OperatorBase..::.GetVariableValue Method (String, IScope, Boolean, Boolean)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IItem GetVariableValue(
    string formalName,
    IScope scope,
    bool recursiveLookup,
    bool throwOnError
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

See Also

OperatorBase Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetXmlNode Method

OperatorBase..::.GetXmlNode Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorBase Class
HeuristicLab.Core Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OperatorBase..::.IsValid Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


OnBreakpointChanged Method

OperatorBase..::.OnBreakpointChanged Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnBreakpointChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnBreakpointChanged()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnExecuted Method

OperatorBase..::.OnExecuted Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnExecuted]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnExecuted()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnInitialized Method

OperatorBase..::.OnInitialized Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnInitialized]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnInitialized()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnNameChanged Method

OperatorBase..::.OnNameChanged Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnNameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnNameChanged()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnSubOperatorAdded Method

OperatorBase..::.OnSubOperatorAdded Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnSubOperatorAdded(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnSubOperatorAdded(
    IOperator subOperator,
    int index
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnSubOperatorRemoved Method

OperatorBase..::.OnSubOperatorRemoved Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnSubOperatorRemoved(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnSubOperatorRemoved(
    IOperator subOperator,
    int index
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnVariableAdded Method

OperatorBase..::.OnVariableAdded Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnVariableAdded(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnVariableAdded(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnVariableInfoAdded Method

OperatorBase..::.OnVariableInfoAdded Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnVariableInfoAdded(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnVariableInfoAdded(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnVariableInfoRemoved Method

OperatorBase..::.OnVariableInfoRemoved Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnVariableInfoRemoved(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnVariableInfoRemoved(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OnVariableRemoved Method

OperatorBase..::.OnVariableRemoved Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.OnVariableRemoved(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnVariableRemoved(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Populate Method

OperatorBase..::.Populate Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorBase Class
HeuristicLab.Core Namespace


RemoveSubOperator Method

OperatorBase..::.RemoveSubOperator Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.RemoveSubOperator(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void RemoveSubOperator(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Implements

IOperator..::.RemoveSubOperator(Int32)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


RemoveVariable Method

OperatorBase..::.RemoveVariable Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.RemoveVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void RemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Implements

IOperator..::.RemoveVariable(String)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


RemoveVariableInfo Method

OperatorBase..::.RemoveVariableInfo Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.RemoveVariableInfo(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void RemoveVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

Implements

IOperator..::.RemoveVariableInfo(String)

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Reset Method

OperatorBase..::.Reset Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Reset()

Implements

IOperator..::.Reset()()()

See Also

OperatorBase Class
HeuristicLab.Core Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OperatorBase..::.TryAddSubOperator Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) |
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) |
TryAddSubOperator(IOperator, Int32) |
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator)

OperatorBase..::.TryAddSubOperator Method (IOperator)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddSubOperator(
    IOperator subOperator
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator)]

Implements

IOperator..::.TryAddSubOperator(IOperator)

See Also

OperatorBase Class
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator, ICollection(IConstraint) )

OperatorBase..::.TryAddSubOperator Method (IOperator, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddSubOperator(
    IOperator subOperator,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator, Int32)

OperatorBase..::.TryAddSubOperator Method (IOperator, Int32)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddSubOperator(
    IOperator subOperator,
    int index
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Implements

IOperator..::.TryAddSubOperator(IOperator, Int32)

See Also

OperatorBase Class
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddSubOperator Method (IOperator, Int32, ICollection(IConstraint) )

OperatorBase..::.TryAddSubOperator Method (IOperator, Int32, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddSubOperator(
    IOperator subOperator,
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryAddSubOperator Overload
HeuristicLab.Core Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OperatorBase..::.TryAddVariable Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) |
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


TryAddVariable Method (IVariable)

OperatorBase..::.TryAddVariable Method (IVariable)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariable(HeuristicLab.Core.IVariable)]

Implements

IOperator..::.TryAddVariable(IVariable)

See Also

OperatorBase Class
TryAddVariable Overload
HeuristicLab.Core Namespace


TryAddVariable Method (IVariable, ICollection(IConstraint) )

OperatorBase..::.TryAddVariable Method (IVariable, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariable(HeuristicLab.Core.IVariable,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddVariable(
    IVariable variable,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariable(HeuristicLab.Core.IVariable,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryAddVariable Overload
HeuristicLab.Core Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OperatorBase..::.TryAddVariableInfo Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) |
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


TryAddVariableInfo Method (IVariableInfo)

OperatorBase..::.TryAddVariableInfo Method (IVariableInfo)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddVariableInfo(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo)]

Implements

IOperator..::.TryAddVariableInfo(IVariableInfo)

See Also

OperatorBase Class
TryAddVariableInfo Overload
HeuristicLab.Core Namespace


TryAddVariableInfo Method (IVariableInfo, ICollection(IConstraint) )

OperatorBase..::.TryAddVariableInfo Method (IVariableInfo, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryAddVariableInfo(
    IVariableInfo variableInfo,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryAddVariableInfo(HeuristicLab.Core.IVariableInfo,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryAddVariableInfo Overload
HeuristicLab.Core Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OperatorBase..::.TryRemoveSubOperator Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) |
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


TryRemoveSubOperator Method (Int32)

OperatorBase..::.TryRemoveSubOperator Method (Int32)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveSubOperator(System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryRemoveSubOperator(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveSubOperator(System.Int32)]

Implements

IOperator..::.TryRemoveSubOperator(Int32)

See Also

OperatorBase Class
TryRemoveSubOperator Overload
HeuristicLab.Core Namespace


TryRemoveSubOperator Method (Int32, ICollection(IConstraint) )

OperatorBase..::.TryRemoveSubOperator Method (Int32, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveSubOperator(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryRemoveSubOperator(
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveSubOperator(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryRemoveSubOperator Overload
HeuristicLab.Core Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OperatorBase..::.TryRemoveVariable Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) |
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


TryRemoveVariable Method (String)

OperatorBase..::.TryRemoveVariable Method (String)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryRemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariable(System.String)]

Implements

IOperator..::.TryRemoveVariable(String)

See Also

OperatorBase Class
TryRemoveVariable Overload
HeuristicLab.Core Namespace


TryRemoveVariable Method (String, ICollection(IConstraint) )

OperatorBase..::.TryRemoveVariable Method (String, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariable(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryRemoveVariable(
    string name,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariable(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryRemoveVariable Overload
HeuristicLab.Core Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OperatorBase..::.TryRemoveVariableInfo Method
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) |
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) |

See Also

OperatorBase Class
OperatorBase Members
HeuristicLab.Core Namespace


TryRemoveVariableInfo Method (String)

OperatorBase..::.TryRemoveVariableInfo Method (String)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariableInfo(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryRemoveVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariableInfo(System.String)]

Implements

IOperator..::.TryRemoveVariableInfo(String)

See Also

OperatorBase Class
TryRemoveVariableInfo Overload
HeuristicLab.Core Namespace


TryRemoveVariableInfo Method (String, ICollection(IConstraint) )

OperatorBase..::.TryRemoveVariableInfo Method (String, ICollection<(Of <(IConstraint>)>) %)
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariableInfo(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TryRemoveVariableInfo(
    string formalName,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorBase.TryRemoveVariableInfo(System.String,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%)

See Also

OperatorBase Class
TryRemoveVariableInfo Overload
HeuristicLab.Core Namespace


OperatorBase Properties

[image]

HeuristicLab API Documentation
OperatorBase Properties
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBase type exposes the following members.

Properties

Name | Description
Breakpoint |
Canceled |
Constraints | (Inherited from ConstrainedItemBase.)
Description |
Guid | (Inherited from StorableBase.)
Name |
SubOperators |
VariableInfos |
Variables |

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Breakpoint Property

OperatorBase..::.Breakpoint Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.Breakpoint]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Breakpoint { get; set; }

Implements

IOperator..::.Breakpoint

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Canceled Property

OperatorBase..::.Canceled Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.Canceled]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Canceled { get; }

Implements

IOperator..::.Canceled

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Description Property

OperatorBase..::.Description Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.Description]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual string Description { get; }

Implements

IOperator..::.Description

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Name Property

OperatorBase..::.Name Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

Implements

IOperator..::.Name

See Also

OperatorBase Class
HeuristicLab.Core Namespace


SubOperators Property

OperatorBase..::.SubOperators Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.SubOperators]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IList<IOperator> SubOperators { get; }

Implements

IOperator..::.SubOperators

See Also

OperatorBase Class
HeuristicLab.Core Namespace


VariableInfos Property

OperatorBase..::.VariableInfos Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.VariableInfos]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual ICollection<IVariableInfo> VariableInfos { get; }

Implements

IOperator..::.VariableInfos

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Variables Property

OperatorBase..::.Variables Property
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBase.Variables]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual ICollection<IVariable> Variables { get; }

Implements

IOperator..::.Variables

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OperatorBase Events

[image]

HeuristicLab API Documentation
OperatorBase Events
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBase type exposes the following members.

Events

Name | Description
BreakpointChanged |
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed |
Initialized |
NameChanged |
SubOperatorAdded |
SubOperatorRemoved |
VariableAdded |
VariableInfoAdded |
VariableInfoRemoved |
VariableRemoved |

See Also

OperatorBase Class
HeuristicLab.Core Namespace


BreakpointChanged Event

OperatorBase..::.BreakpointChanged Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.BreakpointChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler BreakpointChanged

Implements

IOperator..::.BreakpointChanged

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Executed Event

OperatorBase..::.Executed Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.Executed]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Executed

Implements

IOperator..::.Executed

See Also

OperatorBase Class
HeuristicLab.Core Namespace


Initialized Event

OperatorBase..::.Initialized Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.Initialized]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Initialized

Implements

IOperator..::.Initialized

See Also

OperatorBase Class
HeuristicLab.Core Namespace


NameChanged Event

OperatorBase..::.NameChanged Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.NameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler NameChanged

Implements

IOperator..::.NameChanged

See Also

OperatorBase Class
HeuristicLab.Core Namespace


SubOperatorAdded Event

OperatorBase..::.SubOperatorAdded Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.SubOperatorAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<OperatorIndexEventArgs> SubOperatorAdded

Implements

IOperator..::.SubOperatorAdded

See Also

OperatorBase Class
HeuristicLab.Core Namespace


SubOperatorRemoved Event

OperatorBase..::.SubOperatorRemoved Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.SubOperatorRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<OperatorIndexEventArgs> SubOperatorRemoved

Implements

IOperator..::.SubOperatorRemoved

See Also

OperatorBase Class
HeuristicLab.Core Namespace


VariableAdded Event

OperatorBase..::.VariableAdded Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.VariableAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<VariableEventArgs> VariableAdded

Implements

IOperator..::.VariableAdded

See Also

OperatorBase Class
HeuristicLab.Core Namespace


VariableInfoAdded Event

OperatorBase..::.VariableInfoAdded Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.VariableInfoAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<VariableInfoEventArgs> VariableInfoAdded

Implements

IOperator..::.VariableInfoAdded

See Also

OperatorBase Class
HeuristicLab.Core Namespace


VariableInfoRemoved Event

OperatorBase..::.VariableInfoRemoved Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.VariableInfoRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<VariableInfoEventArgs> VariableInfoRemoved

Implements

IOperator..::.VariableInfoRemoved

See Also

OperatorBase Class
HeuristicLab.Core Namespace


VariableRemoved Event

OperatorBase..::.VariableRemoved Event
OperatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBase.VariableRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<VariableEventArgs> VariableRemoved

Implements

IOperator..::.VariableRemoved

See Also

OperatorBase Class
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Class

OperatorBaseDescriptionView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorBaseDescriptionView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorBaseDescriptionView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.OperatorBaseDescriptionView

See Also

OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Members

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView Members
OperatorBaseDescriptionView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseDescriptionView type exposes the following members.

Constructors

Name | Description
OperatorBaseDescriptionView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Constructor

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView Constructor
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperatorBaseDescriptionView()()() |
OperatorBaseDescriptionView(IOperator) |

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Constructor

OperatorBaseDescriptionView Constructor
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseDescriptionView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseDescriptionView()

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Overload
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Constructor (IOperator)

OperatorBaseDescriptionView Constructor (IOperator)
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseDescriptionView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseDescriptionView(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Overload
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Methods

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView Methods
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseDescriptionView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperatorBaseDescriptionView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.AccessibilityNotifyClients Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.BeginInvoke Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.Dispose Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

OperatorBaseDescriptionView..::.Dispose Method (Boolean)
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperatorBaseDescriptionView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.GetChildAtPoint Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.Invalidate Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.Invoke Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.MemberwiseClone Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.PerformLayout Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.ResumeLayout Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.RtlTranslateAlignment Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.Scale Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.Select Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.SetBounds Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.UpdateBounds Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


UpdateControls Method

OperatorBaseDescriptionView..::.UpdateControls Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseDescriptionView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperatorBaseDescriptionView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.Validate Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView..::.ValidateChildren Method
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperatorBaseDescriptionView Class
OperatorBaseDescriptionView Members
HeuristicLab.Core Namespace


OperatorBaseDescriptionView Properties

[image]

HeuristicLab API Documentation
OperatorBaseDescriptionView Properties
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseDescriptionView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperatorBaseDescriptionView Class
HeuristicLab.Core Namespace


Operator Property

OperatorBaseDescriptionView..::.Operator Property
OperatorBaseDescriptionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBaseDescriptionView.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; set; }

See Also

OperatorBaseDescriptionView Class
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Class

OperatorBaseVariableInfosView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorBaseVariableInfosView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorBaseVariableInfosView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.OperatorBaseVariableInfosView

See Also

OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Members

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView Members
OperatorBaseVariableInfosView Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariableInfosView type exposes the following members.

Constructors

Name | Description
OperatorBaseVariableInfosView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSelectedVariableInfosChanged |
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
splitContainer |
variableInfoDetailsGroupBox |
variableInfosGroupBox |
variableInfosListView |

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedVariableInfos |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SelectedVariableInfosChanged |
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Constructor

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView Constructor
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperatorBaseVariableInfosView()()() |
OperatorBaseVariableInfosView(IOperator) |

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Constructor

OperatorBaseVariableInfosView Constructor
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseVariableInfosView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseVariableInfosView()

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Overload
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Constructor (IOperator)

OperatorBaseVariableInfosView Constructor (IOperator)
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseVariableInfosView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseVariableInfosView(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Overload
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Fields

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView Fields
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariableInfosView type exposes the following members.

Fields

Name | Description
splitContainer |
variableInfoDetailsGroupBox |
variableInfosGroupBox |
variableInfosListView |

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


splitContainer Field

OperatorBaseVariableInfosView..::.splitContainer Field
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariableInfosView.splitContainer]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected SplitContainer splitContainer

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


variableInfoDetailsGroupBox Field

OperatorBaseVariableInfosView..::.variableInfoDetailsGroupBox Field
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariableInfosView.variableInfoDetailsGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox variableInfoDetailsGroupBox

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


variableInfosGroupBox Field

OperatorBaseVariableInfosView..::.variableInfosGroupBox Field
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariableInfosView.variableInfosGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox variableInfosGroupBox

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


variableInfosListView Field

OperatorBaseVariableInfosView..::.variableInfosListView Field
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariableInfosView.variableInfosListView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ListView variableInfosListView

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Methods

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView Methods
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariableInfosView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSelectedVariableInfosChanged |
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.AccessibilityNotifyClients Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


AddItemEvents Method

OperatorBaseVariableInfosView..::.AddItemEvents Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariableInfosView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.BeginInvoke Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.Dispose Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

OperatorBaseVariableInfosView..::.Dispose Method (Boolean)
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperatorBaseVariableInfosView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.GetChildAtPoint Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.Invalidate Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.Invoke Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.MemberwiseClone Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


OnSelectedVariableInfosChanged Method

OperatorBaseVariableInfosView..::.OnSelectedVariableInfosChanged Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariableInfosView.OnSelectedVariableInfosChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnSelectedVariableInfosChanged()

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.PerformLayout Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

OperatorBaseVariableInfosView..::.RemoveItemEvents Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariableInfosView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.ResumeLayout Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.RtlTranslateAlignment Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.Scale Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.Select Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.SetBounds Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.UpdateBounds Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


UpdateControls Method

OperatorBaseVariableInfosView..::.UpdateControls Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariableInfosView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.Validate Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView..::.ValidateChildren Method
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperatorBaseVariableInfosView Class
OperatorBaseVariableInfosView Members
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Properties

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView Properties
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariableInfosView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SelectedVariableInfos |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


Operator Property

OperatorBaseVariableInfosView..::.Operator Property
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBaseVariableInfosView.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; set; }

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


SelectedVariableInfos Property

OperatorBaseVariableInfosView..::.SelectedVariableInfos Property
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBaseVariableInfosView.SelectedVariableInfos]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IVariableInfo> SelectedVariableInfos { get; }

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


OperatorBaseVariableInfosView Events

[image]

HeuristicLab API Documentation
OperatorBaseVariableInfosView Events
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariableInfosView type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SelectedVariableInfosChanged |
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


SelectedVariableInfosChanged Event

OperatorBaseVariableInfosView..::.SelectedVariableInfosChanged Event
OperatorBaseVariableInfosView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorBaseVariableInfosView.SelectedVariableInfosChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler SelectedVariableInfosChanged

See Also

OperatorBaseVariableInfosView Class
HeuristicLab.Core Namespace


OperatorBaseVariablesView Class

OperatorBaseVariablesView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorBaseVariablesView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorBaseVariablesView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.OperatorBaseVariablesView

See Also

OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


OperatorBaseVariablesView Members

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView Members
OperatorBaseVariablesView Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariablesView type exposes the following members.

Constructors

Name | Description
OperatorBaseVariablesView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
addVariableButton |
removeVariableButton |
splitContainer |
variableDetailsGroupBox |
variablesGroupBox |
variablesListView |

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


OperatorBaseVariablesView Constructor

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView Constructor
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperatorBaseVariablesView()()() |
OperatorBaseVariablesView(IOperator) |

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


OperatorBaseVariablesView Constructor

OperatorBaseVariablesView Constructor
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseVariablesView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseVariablesView()

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Overload
HeuristicLab.Core Namespace


OperatorBaseVariablesView Constructor (IOperator)

OperatorBaseVariablesView Constructor (IOperator)
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseVariablesView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseVariablesView(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Overload
HeuristicLab.Core Namespace


OperatorBaseVariablesView Fields

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView Fields
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariablesView type exposes the following members.

Fields

Name | Description
addVariableButton |
removeVariableButton |
splitContainer |
variableDetailsGroupBox |
variablesGroupBox |
variablesListView |

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


addVariableButton Field

OperatorBaseVariablesView..::.addVariableButton Field
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariablesView.addVariableButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button addVariableButton

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


removeVariableButton Field

OperatorBaseVariablesView..::.removeVariableButton Field
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariablesView.removeVariableButton]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected Button removeVariableButton

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


splitContainer Field

OperatorBaseVariablesView..::.splitContainer Field
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariablesView.splitContainer]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected SplitContainer splitContainer

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


variableDetailsGroupBox Field

OperatorBaseVariablesView..::.variableDetailsGroupBox Field
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariablesView.variableDetailsGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox variableDetailsGroupBox

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


variablesGroupBox Field

OperatorBaseVariablesView..::.variablesGroupBox Field
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariablesView.variablesGroupBox]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected GroupBox variablesGroupBox

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


variablesListView Field

OperatorBaseVariablesView..::.variablesListView Field
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseVariablesView.variablesListView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ListView variablesListView

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


OperatorBaseVariablesView Methods

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView Methods
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariablesView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.AccessibilityNotifyClients Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


AddItemEvents Method

OperatorBaseVariablesView..::.AddItemEvents Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariablesView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.BeginInvoke Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.Dispose Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

OperatorBaseVariablesView..::.Dispose Method (Boolean)
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperatorBaseVariablesView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.GetChildAtPoint Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.Invalidate Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.Invoke Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.MemberwiseClone Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.PerformLayout Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

OperatorBaseVariablesView..::.RemoveItemEvents Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariablesView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.ResumeLayout Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.RtlTranslateAlignment Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.Scale Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.Select Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.SetBounds Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.UpdateBounds Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


UpdateControls Method

OperatorBaseVariablesView..::.UpdateControls Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseVariablesView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.Validate Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView..::.ValidateChildren Method
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperatorBaseVariablesView Class
OperatorBaseVariablesView Members
HeuristicLab.Core Namespace


OperatorBaseVariablesView Properties

[image]

HeuristicLab API Documentation
OperatorBaseVariablesView Properties
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseVariablesView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


Operator Property

OperatorBaseVariablesView..::.Operator Property
OperatorBaseVariablesView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBaseVariablesView.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; set; }

See Also

OperatorBaseVariablesView Class
HeuristicLab.Core Namespace


OperatorBaseView Class

OperatorBaseView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorBaseView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorBaseView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.OperatorBaseView
HeuristicLab.Operators..::.VariableInjectorView

See Also

OperatorBaseView Members
HeuristicLab.Core Namespace


OperatorBaseView Members

[image]

HeuristicLab API Documentation
OperatorBaseView Members
OperatorBaseView Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseView type exposes the following members.

Constructors

Name | Description
OperatorBaseView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
constrainedItemBaseView |
operatorBaseVariableInfosView |
operatorBaseVariablesView |
tabControl |
variableInfosTabPage |
variablesTabPage |

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


OperatorBaseView Constructor

[image]

HeuristicLab API Documentation
OperatorBaseView Constructor
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperatorBaseView()()() |
OperatorBaseView(IOperator) |

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


OperatorBaseView Constructor

OperatorBaseView Constructor
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseView()

See Also

OperatorBaseView Class
OperatorBaseView Overload
HeuristicLab.Core Namespace


OperatorBaseView Constructor (IOperator)

OperatorBaseView Constructor (IOperator)
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorBaseView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorBaseView(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorBaseView Class
OperatorBaseView Overload
HeuristicLab.Core Namespace


OperatorBaseView Fields

[image]

HeuristicLab API Documentation
OperatorBaseView Fields
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseView type exposes the following members.

Fields

Name | Description
constrainedItemBaseView |
operatorBaseVariableInfosView |
operatorBaseVariablesView |
tabControl |
variableInfosTabPage |
variablesTabPage |

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


constrainedItemBaseView Field

OperatorBaseView..::.constrainedItemBaseView Field
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseView.constrainedItemBaseView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ConstrainedItemBaseView constrainedItemBaseView

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


operatorBaseVariableInfosView Field

OperatorBaseView..::.operatorBaseVariableInfosView Field
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseView.operatorBaseVariableInfosView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected OperatorBaseVariableInfosView operatorBaseVariableInfosView

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


operatorBaseVariablesView Field

OperatorBaseView..::.operatorBaseVariablesView Field
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseView.operatorBaseVariablesView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected OperatorBaseVariablesView operatorBaseVariablesView

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


tabControl Field

OperatorBaseView..::.tabControl Field
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseView.tabControl]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected TabControl tabControl

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


variableInfosTabPage Field

OperatorBaseView..::.variableInfosTabPage Field
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseView.variableInfosTabPage]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected TabPage variableInfosTabPage

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


variablesTabPage Field

OperatorBaseView..::.variablesTabPage Field
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Core.OperatorBaseView.variablesTabPage]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected TabPage variablesTabPage

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


OperatorBaseView Methods

[image]

HeuristicLab API Documentation
OperatorBaseView Methods
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.AccessibilityNotifyClients Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


AddItemEvents Method

OperatorBaseView..::.AddItemEvents Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.BeginInvoke Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.Dispose Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

OperatorBaseView..::.Dispose Method (Boolean)
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperatorBaseView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.GetChildAtPoint Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.Invalidate Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.Invoke Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.MemberwiseClone Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.PerformLayout Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

OperatorBaseView..::.RemoveItemEvents Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.ResumeLayout Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.RtlTranslateAlignment Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.Scale Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.Select Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.SetBounds Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.UpdateBounds Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


UpdateControls Method

OperatorBaseView..::.UpdateControls Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorBaseView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.Validate Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperatorBaseView..::.ValidateChildren Method
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperatorBaseView Class
OperatorBaseView Members
HeuristicLab.Core Namespace


OperatorBaseView Properties

[image]

HeuristicLab API Documentation
OperatorBaseView Properties
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorBaseView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


Operator Property

OperatorBaseView..::.Operator Property
OperatorBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorBaseView.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; set; }

See Also

OperatorBaseView Class
HeuristicLab.Core Namespace


OperatorEventArgs Class

OperatorEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorEventArgs : ItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.OperatorEventArgs

See Also

OperatorEventArgs Members
HeuristicLab.Core Namespace


OperatorEventArgs Members

[image]

HeuristicLab API Documentation
OperatorEventArgs Members
OperatorEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorEventArgs type exposes the following members.

Constructors

Name | Description
OperatorEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
Operator |

See Also

OperatorEventArgs Class
HeuristicLab.Core Namespace


OperatorEventArgs Constructor

OperatorEventArgs Constructor
OperatorEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorEventArgs(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorEventArgs Class
HeuristicLab.Core Namespace


OperatorEventArgs Properties

[image]

HeuristicLab API Documentation
OperatorEventArgs Properties
OperatorEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorEventArgs type exposes the following members.

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
Operator |

See Also

OperatorEventArgs Class
HeuristicLab.Core Namespace


Operator Property

OperatorEventArgs..::.Operator Property
OperatorEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorEventArgs.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; }

See Also

OperatorEventArgs Class
HeuristicLab.Core Namespace


OperatorGraph Class

OperatorGraph Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorGraph]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorGraph : ItemBase, IOperatorGraph,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.OperatorGraph

See Also

OperatorGraph Members
HeuristicLab.Core Namespace


OperatorGraph Members

[image]

HeuristicLab API Documentation
OperatorGraph Members
OperatorGraph Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraph type exposes the following members.

Constructors

Name | Description
OperatorGraph |

Methods

Name | Description
AddOperator |
Clear |
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOperator |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnInitialOperatorChanged |
OnOperatorAdded |
OnOperatorRemoved |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
Reset |
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
InitialOperator |
Operators |

Events

Name | Description
Changed | (Inherited from ItemBase.)
InitialOperatorChanged |
OperatorAdded |
OperatorRemoved |

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorGraph Constructor

OperatorGraph Constructor
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorGraph class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorGraph()

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorGraph Methods

[image]

HeuristicLab API Documentation
OperatorGraph Methods
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraph type exposes the following members.

Methods

Name | Description
AddOperator |
Clear |
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOperator |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnInitialOperatorChanged |
OnOperatorAdded |
OnOperatorRemoved |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
Reset |
ToString | (Inherited from ItemBase.)

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


AddOperator Method

OperatorGraph..::.AddOperator Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

Implements

IOperatorGraph..::.AddOperator(IOperator)

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


Clear Method

OperatorGraph..::.Clear Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.Clear]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Clear()

Implements

IOperatorGraph..::.Clear()()()

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperatorGraph..::.Clone Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

OperatorGraph Class
OperatorGraph Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

OperatorGraph..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorGraph.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

OperatorGraph Class
Clone Overload
HeuristicLab.Core Namespace


CreateView Method

OperatorGraph..::.CreateView Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorGraph.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


GetOperator Method

OperatorGraph..::.GetOperator Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.GetOperator(System.Guid)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator GetOperator(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorGraph.GetOperator(System.Guid)]

Implements

IOperatorGraph..::.GetOperator(Guid)

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


GetXmlNode Method

OperatorGraph..::.GetXmlNode Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorGraph.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OnInitialOperatorChanged Method

OperatorGraph..::.OnInitialOperatorChanged Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.OnInitialOperatorChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnInitialOperatorChanged()

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OnOperatorAdded Method

OperatorGraph..::.OnOperatorAdded Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.OnOperatorAdded(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnOperatorAdded(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OnOperatorRemoved Method

OperatorGraph..::.OnOperatorRemoved Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.OnOperatorRemoved(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnOperatorRemoved(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


Populate Method

OperatorGraph..::.Populate Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


RemoveOperator Method

OperatorGraph..::.RemoveOperator Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.RemoveOperator(System.Guid)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveOperator(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Implements

IOperatorGraph..::.RemoveOperator(Guid)

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


Reset Method

OperatorGraph..::.Reset Method
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraph.Reset]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset()

Implements

IOperatorGraph..::.Reset()()()

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorGraph Properties

[image]

HeuristicLab API Documentation
OperatorGraph Properties
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraph type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
InitialOperator |
Operators |

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


InitialOperator Property

OperatorGraph..::.InitialOperator Property
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorGraph.InitialOperator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator InitialOperator { get; set; }

Implements

IOperatorGraph..::.InitialOperator

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


Operators Property

OperatorGraph..::.Operators Property
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorGraph.Operators]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IOperator> Operators { get; }

Implements

IOperatorGraph..::.Operators

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorGraph Events

[image]

HeuristicLab API Documentation
OperatorGraph Events
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraph type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
InitialOperatorChanged |
OperatorAdded |
OperatorRemoved |

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


InitialOperatorChanged Event

OperatorGraph..::.InitialOperatorChanged Event
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorGraph.InitialOperatorChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler InitialOperatorChanged

Implements

IOperatorGraph..::.InitialOperatorChanged

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorAdded Event

OperatorGraph..::.OperatorAdded Event
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorGraph.OperatorAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<OperatorEventArgs> OperatorAdded

Implements

IOperatorGraph..::.OperatorAdded

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorRemoved Event

OperatorGraph..::.OperatorRemoved Event
OperatorGraph Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorGraph.OperatorRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<OperatorEventArgs> OperatorRemoved

Implements

IOperatorGraph..::.OperatorRemoved

See Also

OperatorGraph Class
HeuristicLab.Core Namespace


OperatorGraphView Class

OperatorGraphView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorGraphView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorGraphView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.OperatorGraphView

See Also

OperatorGraphView Members
HeuristicLab.Core Namespace


OperatorGraphView Members

[image]

HeuristicLab API Documentation
OperatorGraphView Members
OperatorGraphView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraphView type exposes the following members.

Constructors

Name | Description
OperatorGraphView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OperatorGraph |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


OperatorGraphView Constructor

[image]

HeuristicLab API Documentation
OperatorGraphView Constructor
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperatorGraphView()()() |
OperatorGraphView(IOperatorGraph) |

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


OperatorGraphView Constructor

OperatorGraphView Constructor
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorGraphView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorGraphView()

See Also

OperatorGraphView Class
OperatorGraphView Overload
HeuristicLab.Core Namespace


OperatorGraphView Constructor (IOperatorGraph)

OperatorGraphView Constructor (IOperatorGraph)
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorGraphView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorGraphView(
    IOperatorGraph operatorGraph
)

Parameters

operatorGraph
Type: HeuristicLab.Core..::.IOperatorGraph

[Missing <param> documentation for "operatorGraph"]

See Also

OperatorGraphView Class
OperatorGraphView Overload
HeuristicLab.Core Namespace


OperatorGraphView Methods

[image]

HeuristicLab API Documentation
OperatorGraphView Methods
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraphView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.AccessibilityNotifyClients Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


AddItemEvents Method

OperatorGraphView..::.AddItemEvents Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraphView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.BeginInvoke Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.Dispose Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

OperatorGraphView..::.Dispose Method (Boolean)
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperatorGraphView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.GetChildAtPoint Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.Invalidate Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.Invoke Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.MemberwiseClone Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.PerformLayout Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

OperatorGraphView..::.RemoveItemEvents Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraphView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.ResumeLayout Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.RtlTranslateAlignment Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.Scale Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.Select Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.SetBounds Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.UpdateBounds Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


UpdateControls Method

OperatorGraphView..::.UpdateControls Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGraphView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.Validate Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperatorGraphView..::.ValidateChildren Method
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperatorGraphView Class
OperatorGraphView Members
HeuristicLab.Core Namespace


OperatorGraphView Properties

[image]

HeuristicLab API Documentation
OperatorGraphView Properties
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGraphView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OperatorGraph |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


OperatorGraph Property

OperatorGraphView..::.OperatorGraph Property
OperatorGraphView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorGraphView.OperatorGraph]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorGraph OperatorGraph { get; set; }

See Also

OperatorGraphView Class
HeuristicLab.Core Namespace


OperatorGroup Class

OperatorGroup Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorGroup]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorGroup : StorableBase, IOperatorGroup,
    IStorable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.OperatorGroup
HeuristicLab.StructureIdentification..::.GPOperatorGroup

See Also

OperatorGroup Members
HeuristicLab.Core Namespace


OperatorGroup Members

[image]

HeuristicLab API Documentation
OperatorGroup Members
OperatorGroup Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGroup type exposes the following members.

Constructors

Name | Description
OperatorGroup |

Methods

Name | Description
AddOperator |
AddSubGroup |
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnNameChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
RemoveSubGroup |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name |
Operators |
SubGroups |

Events

Name | Description
NameChanged |

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


OperatorGroup Constructor

OperatorGroup Constructor
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorGroup class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorGroup()

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


OperatorGroup Methods

[image]

HeuristicLab API Documentation
OperatorGroup Methods
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGroup type exposes the following members.

Methods

Name | Description
AddOperator |
AddSubGroup |
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnNameChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveOperator |
RemoveSubGroup |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


AddOperator Method

OperatorGroup..::.AddOperator Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

Implements

IOperatorGroup..::.AddOperator(IOperator)

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


AddSubGroup Method

OperatorGroup..::.AddSubGroup Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.AddSubGroup(HeuristicLab.Core.IOperatorGroup)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void AddSubGroup(
    IOperatorGroup group
)

Parameters

group
Type: HeuristicLab.Core..::.IOperatorGroup

[Missing <param> documentation for "group"]

Implements

IOperatorGroup..::.AddSubGroup(IOperatorGroup)

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperatorGroup..::.Clone Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

OperatorGroup Class
OperatorGroup Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

OperatorGroup..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorGroup.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

OperatorGroup Class
Clone Overload
HeuristicLab.Core Namespace


GetXmlNode Method

OperatorGroup..::.GetXmlNode Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorGroup.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


OnNameChanged Method

OperatorGroup..::.OnNameChanged Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.OnNameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnNameChanged()

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


Populate Method

OperatorGroup..::.Populate Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


RemoveOperator Method

OperatorGroup..::.RemoveOperator Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.RemoveOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void RemoveOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

Implements

IOperatorGroup..::.RemoveOperator(IOperator)

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


RemoveSubGroup Method

OperatorGroup..::.RemoveSubGroup Method
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorGroup.RemoveSubGroup(HeuristicLab.Core.IOperatorGroup)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void RemoveSubGroup(
    IOperatorGroup group
)

Parameters

group
Type: HeuristicLab.Core..::.IOperatorGroup

[Missing <param> documentation for "group"]

Implements

IOperatorGroup..::.RemoveSubGroup(IOperatorGroup)

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


OperatorGroup Properties

[image]

HeuristicLab API Documentation
OperatorGroup Properties
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGroup type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name |
Operators |
SubGroups |

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


Name Property

OperatorGroup..::.Name Property
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorGroup.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

Implements

IOperatorGroup..::.Name

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


Operators Property

OperatorGroup..::.Operators Property
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorGroup.Operators]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IOperator> Operators { get; }

Implements

IOperatorGroup..::.Operators

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


SubGroups Property

OperatorGroup..::.SubGroups Property
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorGroup.SubGroups]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IOperatorGroup> SubGroups { get; }

Implements

IOperatorGroup..::.SubGroups

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


OperatorGroup Events

[image]

HeuristicLab API Documentation
OperatorGroup Events
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorGroup type exposes the following members.

Events

Name | Description
NameChanged |

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


NameChanged Event

OperatorGroup..::.NameChanged Event
OperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.OperatorGroup.NameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler NameChanged

Implements

IOperatorGroup..::.NameChanged

See Also

OperatorGroup Class
HeuristicLab.Core Namespace


OperatorIndexEventArgs Class

OperatorIndexEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorIndexEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorIndexEventArgs : ItemIndexEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.ItemIndexEventArgs
HeuristicLab.Core..::.OperatorIndexEventArgs

See Also

OperatorIndexEventArgs Members
HeuristicLab.Core Namespace


OperatorIndexEventArgs Members

[image]

HeuristicLab API Documentation
OperatorIndexEventArgs Members
OperatorIndexEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorIndexEventArgs type exposes the following members.

Constructors

Name | Description
OperatorIndexEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index | (Inherited from ItemIndexEventArgs.)
Item | (Inherited from ItemEventArgs.)
Operator |

See Also

OperatorIndexEventArgs Class
HeuristicLab.Core Namespace


OperatorIndexEventArgs Constructor

OperatorIndexEventArgs Constructor
OperatorIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorIndexEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorIndexEventArgs(
    IOperator op,
    int index
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

OperatorIndexEventArgs Class
HeuristicLab.Core Namespace


OperatorIndexEventArgs Properties

[image]

HeuristicLab API Documentation
OperatorIndexEventArgs Properties
OperatorIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorIndexEventArgs type exposes the following members.

Properties

Name | Description
Index | (Inherited from ItemIndexEventArgs.)
Item | (Inherited from ItemEventArgs.)
Operator |

See Also

OperatorIndexEventArgs Class
HeuristicLab.Core Namespace


Operator Property

OperatorIndexEventArgs..::.Operator Property
OperatorIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorIndexEventArgs.Operator]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Operator { get; }

See Also

OperatorIndexEventArgs Class
HeuristicLab.Core Namespace


OperatorLibrary Class

OperatorLibrary Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorLibrary]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorLibrary : ItemBase, IOperatorLibrary,
    IItem, IStorable, IEditable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.OperatorLibrary

See Also

OperatorLibrary Members
HeuristicLab.Core Namespace


OperatorLibrary Members

[image]

HeuristicLab API Documentation
OperatorLibrary Members
OperatorLibrary Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorLibrary type exposes the following members.

Constructors

Name | Description
OperatorLibrary |

Methods

Name | Description
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Group |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


OperatorLibrary Constructor

OperatorLibrary Constructor
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorLibrary class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorLibrary()

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


OperatorLibrary Methods

[image]

HeuristicLab API Documentation
OperatorLibrary Methods
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorLibrary type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperatorLibrary..::.Clone Method
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

OperatorLibrary Class
OperatorLibrary Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

OperatorLibrary..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibrary.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorLibrary.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

OperatorLibrary Class
Clone Overload
HeuristicLab.Core Namespace


CreateEditor Method

OperatorLibrary..::.CreateEditor Method
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibrary.CreateEditor]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorLibrary.CreateEditor]

Implements

IEditable..::.CreateEditor()()()

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


CreateView Method

OperatorLibrary..::.CreateView Method
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibrary.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorLibrary.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


GetXmlNode Method

OperatorLibrary..::.GetXmlNode Method
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibrary.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorLibrary.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


Populate Method

OperatorLibrary..::.Populate Method
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibrary.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


OperatorLibrary Properties

[image]

HeuristicLab API Documentation
OperatorLibrary Properties
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorLibrary type exposes the following members.

Properties

Name | Description
Group |
Guid | (Inherited from StorableBase.)

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


Group Property

OperatorLibrary..::.Group Property
OperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorLibrary.Group]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorGroup Group { get; }

Implements

IOperatorLibrary..::.Group

See Also

OperatorLibrary Class
HeuristicLab.Core Namespace


OperatorLibraryEditor Class

OperatorLibraryEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.OperatorLibraryEditor]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorLibraryEditor : EditorBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.OperatorLibraryEditor

See Also

OperatorLibraryEditor Members
HeuristicLab.Core Namespace


OperatorLibraryEditor Members

[image]

HeuristicLab API Documentation
OperatorLibraryEditor Members
OperatorLibraryEditor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorLibraryEditor type exposes the following members.

Constructors

Name | Description
OperatorLibraryEditor | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EditorBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OperatorLibrary |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
HeuristicLab.Core Namespace


OperatorLibraryEditor Constructor

[image]

HeuristicLab API Documentation
OperatorLibraryEditor Constructor
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperatorLibraryEditor()()() |
OperatorLibraryEditor(IOperatorLibrary) |

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


OperatorLibraryEditor Constructor

OperatorLibraryEditor Constructor
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorLibraryEditor class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorLibraryEditor()

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Overload
HeuristicLab.Core Namespace


OperatorLibraryEditor Constructor (IOperatorLibrary)

OperatorLibraryEditor Constructor (IOperatorLibrary)
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorLibraryEditor class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorLibraryEditor(
    IOperatorLibrary operatorLibrary
)

Parameters

operatorLibrary
Type: HeuristicLab.Core..::.IOperatorLibrary

[Missing <param> documentation for "operatorLibrary"]

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Overload
HeuristicLab.Core Namespace


OperatorLibraryEditor Methods

[image]

HeuristicLab API Documentation
OperatorLibraryEditor Methods
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorLibraryEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EditorBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperatorLibraryEditor Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.AccessibilityNotifyClients Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.BeginInvoke Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.Dispose Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EditorBase ..::. Dispose(Boolean).)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

OperatorLibraryEditor..::.Dispose Method (Boolean)
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperatorLibraryEditor Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.GetChildAtPoint Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.Invalidate Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.Invoke Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.MemberwiseClone Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.PerformLayout Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.ResumeLayout Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.RtlTranslateAlignment Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.Scale Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.Select Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.SetBounds Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.UpdateBounds Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


UpdateControls Method

OperatorLibraryEditor..::.UpdateControls Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibraryEditor.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperatorLibraryEditor Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.Validate Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperatorLibraryEditor..::.ValidateChildren Method
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperatorLibraryEditor Class
OperatorLibraryEditor Members
HeuristicLab.Core Namespace


OperatorLibraryEditor Properties

[image]

HeuristicLab API Documentation
OperatorLibraryEditor Properties
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorLibraryEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OperatorLibrary |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperatorLibraryEditor Class
HeuristicLab.Core Namespace


OperatorLibrary Property

OperatorLibraryEditor..::.OperatorLibrary Property
OperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.OperatorLibraryEditor.OperatorLibrary]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorLibrary OperatorLibrary { get; set; }

See Also

OperatorLibraryEditor Class
HeuristicLab.Core Namespace


PersistenceManager Class

PersistenceManager Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.PersistenceManager]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static class PersistenceManager

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.PersistenceManager

See Also

PersistenceManager Members
HeuristicLab.Core Namespace


PersistenceManager Members

[image]

HeuristicLab API Documentation
PersistenceManager Members
PersistenceManager Class Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PersistenceManager type exposes the following members.

Methods

Name | Description
CreateXmlDocument |
Load | Overloaded.
Persist | Overloaded.
Restore |
Save | Overloaded.

See Also

PersistenceManager Class
HeuristicLab.Core Namespace


PersistenceManager Methods

[image]

HeuristicLab API Documentation
PersistenceManager Methods
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PersistenceManager type exposes the following members.

Methods

Name | Description
CreateXmlDocument |
Load | Overloaded.
Persist | Overloaded.
Restore |
Save | Overloaded.

See Also

PersistenceManager Class
HeuristicLab.Core Namespace


CreateXmlDocument Method

PersistenceManager..::.CreateXmlDocument Method
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.CreateXmlDocument]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static XmlDocument CreateXmlDocument()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.PersistenceManager.CreateXmlDocument]

See Also

PersistenceManager Class
HeuristicLab.Core Namespace


Load Method

[image]

HeuristicLab API Documentation
PersistenceManager..::.Load Method
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Load(Stream) |
Load(String) |

See Also

PersistenceManager Class
PersistenceManager Members
HeuristicLab.Core Namespace


Load Method (Stream)

PersistenceManager..::.Load Method (Stream)
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Load(System.IO.Stream)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static IStorable Load(
    Stream stream
)

Parameters

stream
Type: System.IO..::.Stream

[Missing <param> documentation for "stream"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.PersistenceManager.Load(System.IO.Stream)]

See Also

PersistenceManager Class
Load Overload
HeuristicLab.Core Namespace


Load Method (String)

PersistenceManager..::.Load Method (String)
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Load(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static IStorable Load(
    string filename
)

Parameters

filename
Type: System..::.String

[Missing <param> documentation for "filename"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.PersistenceManager.Load(System.String)]

See Also

PersistenceManager Class
Load Overload
HeuristicLab.Core Namespace


Persist Method

[image]

HeuristicLab API Documentation
PersistenceManager..::.Persist Method
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Persist(IStorable, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)) |
Persist(String, IStorable, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)) |

See Also

PersistenceManager Class
PersistenceManager Members
HeuristicLab.Core Namespace


Persist Method (IStorable, XmlDocument, IDictionary(Guid, IStorable))

PersistenceManager..::.Persist Method (IStorable, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Persist(HeuristicLab.Core.IStorable,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static XmlNode Persist(
    IStorable instance,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

instance
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "instance"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.PersistenceManager.Persist(HeuristicLab.Core.IStorable,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

See Also

PersistenceManager Class
Persist Overload
HeuristicLab.Core Namespace


Persist Method (String, IStorable, XmlDocument, IDictionary(Guid, IStorable))

PersistenceManager..::.Persist Method (String, IStorable, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Persist(System.String,HeuristicLab.Core.IStorable,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static XmlNode Persist(
    string name,
    IStorable instance,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

instance
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "instance"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.PersistenceManager.Persist(System.String,HeuristicLab.Core.IStorable,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

See Also

PersistenceManager Class
Persist Overload
HeuristicLab.Core Namespace


Restore Method

PersistenceManager..::.Restore Method
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Restore(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static IStorable Restore(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.PersistenceManager.Restore(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

See Also

PersistenceManager Class
HeuristicLab.Core Namespace


Save Method

[image]

HeuristicLab API Documentation
PersistenceManager..::.Save Method
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Save(IStorable, Stream) |
Save(IStorable, String) |

See Also

PersistenceManager Class
PersistenceManager Members
HeuristicLab.Core Namespace


Save Method (IStorable, Stream)

PersistenceManager..::.Save Method (IStorable, Stream)
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Save(HeuristicLab.Core.IStorable,System.IO.Stream)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static void Save(
    IStorable instance,
    Stream stream
)

Parameters

instance
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "instance"]

stream
Type: System.IO..::.Stream

[Missing <param> documentation for "stream"]

See Also

PersistenceManager Class
Save Overload
HeuristicLab.Core Namespace


Save Method (IStorable, String)

PersistenceManager..::.Save Method (IStorable, String)
PersistenceManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.PersistenceManager.Save(HeuristicLab.Core.IStorable,System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static void Save(
    IStorable instance,
    string filename
)

Parameters

instance
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "instance"]

filename
Type: System..::.String

[Missing <param> documentation for "filename"]

See Also

PersistenceManager Class
Save Overload
HeuristicLab.Core Namespace


Scope Class

Scope Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.Scope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Scope : ItemBase, IScope,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.Scope

See Also

Scope Members
HeuristicLab.Core Namespace


Scope Members

[image]

HeuristicLab API Documentation
Scope Members
Scope Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Scope type exposes the following members.

Constructors

Name | Description
Scope | Overloaded.

Methods

Name | Description
AddSubScope |
AddVariable |
Clear |
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetScope | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable |
GetVariableValue | Overloaded.
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnSubScopeAdded |
OnSubScopeRemoved |
OnSubScopesReordered |
OnVariableAdded |
OnVariableRemoved |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveSubScope |
RemoveVariable |
ReorderSubScopes |
SetParent |
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name |
SubScopes |
Variables |

Events

Name | Description
Changed | (Inherited from ItemBase.)
SubScopeAdded |
SubScopeRemoved |
SubScopesReordered |
VariableAdded |
VariableRemoved |

See Also

Scope Class
HeuristicLab.Core Namespace


Scope Constructor

[image]

HeuristicLab API Documentation
Scope Constructor
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scope()()() |
Scope(String) |

See Also

Scope Class
Scope Members
HeuristicLab.Core Namespace


Scope Constructor

Scope Constructor
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Scope class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Scope()

See Also

Scope Class
Scope Overload
HeuristicLab.Core Namespace


Scope Constructor (String)

Scope Constructor (String)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Scope class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Scope(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

See Also

Scope Class
Scope Overload
HeuristicLab.Core Namespace


Scope Methods

[image]

HeuristicLab API Documentation
Scope Methods
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Scope type exposes the following members.

Methods

Name | Description
AddSubScope |
AddVariable |
Clear |
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetScope | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable |
GetVariableValue | Overloaded.
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnSubScopeAdded |
OnSubScopeRemoved |
OnSubScopesReordered |
OnVariableAdded |
OnVariableRemoved |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveSubScope |
RemoveVariable |
ReorderSubScopes |
SetParent |
ToString | (Inherited from ItemBase.)

See Also

Scope Class
HeuristicLab.Core Namespace


AddSubScope Method

Scope..::.AddSubScope Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.AddSubScope(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddSubScope(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Implements

IScope..::.AddSubScope(IScope)

See Also

Scope Class
HeuristicLab.Core Namespace


AddVariable Method

Scope..::.AddVariable Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.AddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

Implements

IScope..::.AddVariable(IVariable)

See Also

Scope Class
HeuristicLab.Core Namespace


Clear Method

Scope..::.Clear Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.Clear]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Clear()

Implements

IScope..::.Clear()()()

See Also

Scope Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
Scope..::.Clone Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Scope Class
Scope Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

Scope..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Scope Class
Clone Overload
HeuristicLab.Core Namespace


CreateView Method

Scope..::.CreateView Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

Scope Class
HeuristicLab.Core Namespace


GetScope Method

[image]

HeuristicLab API Documentation
Scope..::.GetScope Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetScope(Guid) |
GetScope(String) |

See Also

Scope Class
Scope Members
HeuristicLab.Core Namespace


GetScope Method (Guid)

Scope..::.GetScope Method (Guid)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetScope(System.Guid)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope GetScope(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetScope(System.Guid)]

Implements

IScope..::.GetScope(Guid)

See Also

Scope Class
GetScope Overload
HeuristicLab.Core Namespace


GetScope Method (String)

Scope..::.GetScope Method (String)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetScope(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope GetScope(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetScope(System.String)]

Implements

IScope..::.GetScope(String)

See Also

Scope Class
GetScope Overload
HeuristicLab.Core Namespace


GetVariable Method

Scope..::.GetVariable Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IVariable GetVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetVariable(System.String)]

Implements

IScope..::.GetVariable(String)

See Also

Scope Class
HeuristicLab.Core Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Scope..::.GetVariableValue Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue(String, Boolean) |
GetVariableValue<(Of <(T>)>)(String, Boolean) |
GetVariableValue<(Of <(T>)>)(String, Boolean, Boolean) |
GetVariableValue(String, Boolean, Boolean) |

See Also

Scope Class
Scope Members
HeuristicLab.Core Namespace


GetVariableValue Method (String, Boolean)

Scope..::.GetVariableValue Method (String, Boolean)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetVariableValue(System.String,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem GetVariableValue(
    string name,
    bool recursiveLookup
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetVariableValue(System.String,System.Boolean)]

See Also

Scope Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, Boolean)

Scope..::.GetVariableValue<(Of <(T>)>) Method (String, Boolean)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetVariableValue``1(System.String,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public T GetVariableValue<T>(
    string name,
    bool recursiveLookup
) where T : class, IItem

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetVariableValue``1(System.String,System.Boolean)]

See Also

Scope Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue(T) Method (String, Boolean, Boolean)

Scope..::.GetVariableValue<(Of <(T>)>) Method (String, Boolean, Boolean)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetVariableValue``1(System.String,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public T GetVariableValue<T>(
    string name,
    bool recursiveLookup,
    bool throwOnError
) where T : class, IItem

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetVariableValue``1(System.String,System.Boolean,System.Boolean)]

See Also

Scope Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetVariableValue Method (String, Boolean, Boolean)

Scope..::.GetVariableValue Method (String, Boolean, Boolean)
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetVariableValue(System.String,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem GetVariableValue(
    string name,
    bool recursiveLookup,
    bool throwOnError
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetVariableValue(System.String,System.Boolean,System.Boolean)]

See Also

Scope Class
GetVariableValue Overload
HeuristicLab.Core Namespace


GetXmlNode Method

Scope..::.GetXmlNode Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Scope.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Scope Class
HeuristicLab.Core Namespace


OnSubScopeAdded Method

Scope..::.OnSubScopeAdded Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.OnSubScopeAdded(HeuristicLab.Core.IScope,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnSubScopeAdded(
    IScope scope,
    int index
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

Scope Class
HeuristicLab.Core Namespace


OnSubScopeRemoved Method

Scope..::.OnSubScopeRemoved Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.OnSubScopeRemoved(HeuristicLab.Core.IScope,System.Int32)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnSubScopeRemoved(
    IScope scope,
    int index
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

Scope Class
HeuristicLab.Core Namespace


OnSubScopesReordered Method

Scope..::.OnSubScopesReordered Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.OnSubScopesReordered]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnSubScopesReordered()

See Also

Scope Class
HeuristicLab.Core Namespace


OnVariableAdded Method

Scope..::.OnVariableAdded Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.OnVariableAdded(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnVariableAdded(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

Scope Class
HeuristicLab.Core Namespace


OnVariableRemoved Method

Scope..::.OnVariableRemoved Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.OnVariableRemoved(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnVariableRemoved(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

Scope Class
HeuristicLab.Core Namespace


Populate Method

Scope..::.Populate Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Scope Class
HeuristicLab.Core Namespace


RemoveSubScope Method

Scope..::.RemoveSubScope Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.RemoveSubScope(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveSubScope(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Implements

IScope..::.RemoveSubScope(IScope)

See Also

Scope Class
HeuristicLab.Core Namespace


RemoveVariable Method

Scope..::.RemoveVariable Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.RemoveVariable(System.String)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Implements

IScope..::.RemoveVariable(String)

See Also

Scope Class
HeuristicLab.Core Namespace


ReorderSubScopes Method

Scope..::.ReorderSubScopes Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.ReorderSubScopes(System.Int32[])]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void ReorderSubScopes(
    int[] sequence
)

Parameters

sequence
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "sequence"]

Implements

IScope..::.ReorderSubScopes(array<Int32>[]()[])

See Also

Scope Class
HeuristicLab.Core Namespace


SetParent Method

Scope..::.SetParent Method
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Scope.SetParent(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetParent(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Implements

IScope..::.SetParent(IScope)

See Also

Scope Class
HeuristicLab.Core Namespace


Scope Properties

[image]

HeuristicLab API Documentation
Scope Properties
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Scope type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name |
SubScopes |
Variables |

See Also

Scope Class
HeuristicLab.Core Namespace


Name Property

Scope..::.Name Property
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.Scope.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; }

Implements

IScope..::.Name

See Also

Scope Class
HeuristicLab.Core Namespace


SubScopes Property

Scope..::.SubScopes Property
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.Scope.SubScopes]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IScope> SubScopes { get; }

Implements

IScope..::.SubScopes

See Also

Scope Class
HeuristicLab.Core Namespace


Variables Property

Scope..::.Variables Property
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.Scope.Variables]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IVariable> Variables { get; }

Implements

IScope..::.Variables

See Also

Scope Class
HeuristicLab.Core Namespace


Scope Events

[image]

HeuristicLab API Documentation
Scope Events
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Scope type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
SubScopeAdded |
SubScopeRemoved |
SubScopesReordered |
VariableAdded |
VariableRemoved |

See Also

Scope Class
HeuristicLab.Core Namespace


SubScopeAdded Event

Scope..::.SubScopeAdded Event
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Scope.SubScopeAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ScopeIndexEventArgs> SubScopeAdded

Implements

IScope..::.SubScopeAdded

See Also

Scope Class
HeuristicLab.Core Namespace


SubScopeRemoved Event

Scope..::.SubScopeRemoved Event
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Scope.SubScopeRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ScopeIndexEventArgs> SubScopeRemoved

Implements

IScope..::.SubScopeRemoved

See Also

Scope Class
HeuristicLab.Core Namespace


SubScopesReordered Event

Scope..::.SubScopesReordered Event
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Scope.SubScopesReordered]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler SubScopesReordered

Implements

IScope..::.SubScopesReordered

See Also

Scope Class
HeuristicLab.Core Namespace


VariableAdded Event

Scope..::.VariableAdded Event
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Scope.VariableAdded]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<VariableEventArgs> VariableAdded

Implements

IScope..::.VariableAdded

See Also

Scope Class
HeuristicLab.Core Namespace


VariableRemoved Event

Scope..::.VariableRemoved Event
Scope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Scope.VariableRemoved]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<VariableEventArgs> VariableRemoved

Implements

IScope..::.VariableRemoved

See Also

Scope Class
HeuristicLab.Core Namespace


ScopeEventArgs Class

ScopeEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ScopeEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScopeEventArgs : ItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.ScopeEventArgs

See Also

ScopeEventArgs Members
HeuristicLab.Core Namespace


ScopeEventArgs Members

[image]

HeuristicLab API Documentation
ScopeEventArgs Members
ScopeEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeEventArgs type exposes the following members.

Constructors

Name | Description
ScopeEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
Scope |

See Also

ScopeEventArgs Class
HeuristicLab.Core Namespace


ScopeEventArgs Constructor

ScopeEventArgs Constructor
ScopeEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScopeEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScopeEventArgs(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

ScopeEventArgs Class
HeuristicLab.Core Namespace


ScopeEventArgs Properties

[image]

HeuristicLab API Documentation
ScopeEventArgs Properties
ScopeEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeEventArgs type exposes the following members.

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
Scope |

See Also

ScopeEventArgs Class
HeuristicLab.Core Namespace


Scope Property

ScopeEventArgs..::.Scope Property
ScopeEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ScopeEventArgs.Scope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope Scope { get; }

See Also

ScopeEventArgs Class
HeuristicLab.Core Namespace


ScopeIndexEventArgs Class

ScopeIndexEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ScopeIndexEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScopeIndexEventArgs : ItemIndexEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.ItemIndexEventArgs
HeuristicLab.Core..::.ScopeIndexEventArgs

See Also

ScopeIndexEventArgs Members
HeuristicLab.Core Namespace


ScopeIndexEventArgs Members

[image]

HeuristicLab API Documentation
ScopeIndexEventArgs Members
ScopeIndexEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeIndexEventArgs type exposes the following members.

Constructors

Name | Description
ScopeIndexEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index | (Inherited from ItemIndexEventArgs.)
Item | (Inherited from ItemEventArgs.)
Scope |

See Also

ScopeIndexEventArgs Class
HeuristicLab.Core Namespace


ScopeIndexEventArgs Constructor

ScopeIndexEventArgs Constructor
ScopeIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScopeIndexEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScopeIndexEventArgs(
    IScope scope,
    int index
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

ScopeIndexEventArgs Class
HeuristicLab.Core Namespace


ScopeIndexEventArgs Properties

[image]

HeuristicLab API Documentation
ScopeIndexEventArgs Properties
ScopeIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeIndexEventArgs type exposes the following members.

Properties

Name | Description
Index | (Inherited from ItemIndexEventArgs.)
Item | (Inherited from ItemEventArgs.)
Scope |

See Also

ScopeIndexEventArgs Class
HeuristicLab.Core Namespace


Scope Property

ScopeIndexEventArgs..::.Scope Property
ScopeIndexEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ScopeIndexEventArgs.Scope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope Scope { get; }

See Also

ScopeIndexEventArgs Class
HeuristicLab.Core Namespace


ScopeView Class

ScopeView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ScopeView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScopeView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.ScopeView

See Also

ScopeView Members
HeuristicLab.Core Namespace


ScopeView Members

[image]

HeuristicLab API Documentation
ScopeView Members
ScopeView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeView type exposes the following members.

Constructors

Name | Description
ScopeView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutomaticUpdating |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scope |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ScopeView Class
HeuristicLab.Core Namespace


ScopeView Constructor

[image]

HeuristicLab API Documentation
ScopeView Constructor
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ScopeView()()() |
ScopeView(IScope) |

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


ScopeView Constructor

ScopeView Constructor
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScopeView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScopeView()

See Also

ScopeView Class
ScopeView Overload
HeuristicLab.Core Namespace


ScopeView Constructor (IScope)

ScopeView Constructor (IScope)
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScopeView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScopeView(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

ScopeView Class
ScopeView Overload
HeuristicLab.Core Namespace


ScopeView Methods

[image]

HeuristicLab API Documentation
ScopeView Methods
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ScopeView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ScopeView..::.AccessibilityNotifyClients Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ScopeView..::.BeginInvoke Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ScopeView..::.Dispose Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ScopeView..::.Dispose Method (Boolean)
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ScopeView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ScopeView..::.GetChildAtPoint Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ScopeView..::.Invalidate Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ScopeView..::.Invoke Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ScopeView..::.MemberwiseClone Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ScopeView..::.PerformLayout Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ScopeView..::.ResumeLayout Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ScopeView..::.RtlTranslateAlignment Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ScopeView..::.Scale Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ScopeView..::.Select Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ScopeView..::.SetBounds Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ScopeView..::.UpdateBounds Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


UpdateControls Method

ScopeView..::.UpdateControls Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ScopeView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ScopeView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ScopeView..::.Validate Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ScopeView..::.ValidateChildren Method
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ScopeView Class
ScopeView Members
HeuristicLab.Core Namespace


ScopeView Properties

[image]

HeuristicLab API Documentation
ScopeView Properties
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScopeView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutomaticUpdating |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scope |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ScopeView Class
HeuristicLab.Core Namespace


AutomaticUpdating Property

ScopeView..::.AutomaticUpdating Property
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ScopeView.AutomaticUpdating]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool AutomaticUpdating { get; }

See Also

ScopeView Class
HeuristicLab.Core Namespace


Scope Property

ScopeView..::.Scope Property
ScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ScopeView.Scope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope Scope { get; set; }

See Also

ScopeView Class
HeuristicLab.Core Namespace


StorableBase Class

StorableBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.StorableBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class StorableBase : IStorable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.OperatorGroup
HeuristicLab.Scheduling.JSSP..::.ScheduleTree

See Also

StorableBase Members
HeuristicLab.Core Namespace


StorableBase Members

[image]

HeuristicLab API Documentation
StorableBase Members
StorableBase Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StorableBase type exposes the following members.

Constructors

Name | Description
StorableBase |

Methods

Name | Description
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Populate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Guid |

See Also

StorableBase Class
HeuristicLab.Core Namespace


StorableBase Constructor

StorableBase Constructor
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StorableBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected StorableBase()

See Also

StorableBase Class
HeuristicLab.Core Namespace


StorableBase Methods

[image]

HeuristicLab API Documentation
StorableBase Methods
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StorableBase type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Populate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StorableBase Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
StorableBase..::.Clone Method
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() |
Clone(IDictionary<(Of <(Guid, Object>)>)) |

See Also

StorableBase Class
StorableBase Members
HeuristicLab.Core Namespace


Clone Method

StorableBase..::.Clone Method
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.StorableBase.Clone]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Object Clone()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.StorableBase.Clone]

Implements

IStorable..::.Clone()()()

See Also

StorableBase Class
Clone Overload
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

StorableBase..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.StorableBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.StorableBase.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

StorableBase Class
Clone Overload
HeuristicLab.Core Namespace


GetXmlNode Method

StorableBase..::.GetXmlNode Method
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.StorableBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.StorableBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

StorableBase Class
HeuristicLab.Core Namespace


Populate Method

StorableBase..::.Populate Method
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.StorableBase.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

StorableBase Class
HeuristicLab.Core Namespace


StorableBase Properties

[image]

HeuristicLab API Documentation
StorableBase Properties
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StorableBase type exposes the following members.

Properties

Name | Description
Guid |

See Also

StorableBase Class
HeuristicLab.Core Namespace


Guid Property

StorableBase..::.Guid Property
StorableBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.StorableBase.Guid]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Guid Guid { get; }

Implements

IStorable..::.Guid

See Also

StorableBase Class
HeuristicLab.Core Namespace


Variable Class

Variable Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.Variable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Variable : ItemBase, IVariable,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.Variable

See Also

Variable Members
HeuristicLab.Core Namespace


Variable Members

[image]

HeuristicLab API Documentation
Variable Members
Variable Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Constructors

Name | Description
Variable | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue<(Of <(T>)>) |
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnNameChanged |
OnNameChanging |
OnValueChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ItemBase ..::. ToString()()().)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name |
Value |

Events

Name | Description
Changed | (Inherited from ItemBase.)
NameChanged |
NameChanging |
ValueChanged |

See Also

Variable Class
HeuristicLab.Core Namespace


Variable Constructor

[image]

HeuristicLab API Documentation
Variable Constructor
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Variable()()() |
Variable(String, IItem) |

See Also

Variable Class
Variable Members
HeuristicLab.Core Namespace


Variable Constructor

Variable Constructor
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Variable class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Variable()

See Also

Variable Class
Variable Overload
HeuristicLab.Core Namespace


Variable Constructor (String, IItem)

Variable Constructor (String, IItem)
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Variable class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Variable(
    string name,
    IItem value
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

value
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "value"]

See Also

Variable Class
Variable Overload
HeuristicLab.Core Namespace


Variable Methods

[image]

HeuristicLab API Documentation
Variable Methods
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue<(Of <(T>)>) |
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnNameChanged |
OnNameChanging |
OnValueChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ItemBase ..::. ToString()()().)

See Also

Variable Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
Variable..::.Clone Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Variable Class
Variable Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

Variable..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Variable.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Variable Class
Clone Overload
HeuristicLab.Core Namespace


CreateView Method

Variable..::.CreateView Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Variable.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

Variable Class
HeuristicLab.Core Namespace


GetValue(T) Method

Variable..::.GetValue<(Of <(T>)>) Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.GetValue``1]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public T GetValue<T>() where T : class, IItem

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Variable.GetValue``1]

See Also

Variable Class
HeuristicLab.Core Namespace


GetXmlNode Method

Variable..::.GetXmlNode Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Variable.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Variable Class
HeuristicLab.Core Namespace


OnNameChanged Method

Variable..::.OnNameChanged Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.OnNameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnNameChanged()

See Also

Variable Class
HeuristicLab.Core Namespace


OnNameChanging Method

Variable..::.OnNameChanging Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.OnNameChanging(HeuristicLab.Core.NameChangingEventArgs)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnNameChanging(
    NameChangingEventArgs e
)

Parameters

e
Type: HeuristicLab.Core..::.NameChangingEventArgs

[Missing <param> documentation for "e"]

See Also

Variable Class
HeuristicLab.Core Namespace


OnValueChanged Method

Variable..::.OnValueChanged Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.OnValueChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnValueChanged()

See Also

Variable Class
HeuristicLab.Core Namespace


Populate Method

Variable..::.Populate Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Variable Class
HeuristicLab.Core Namespace


ToString Method

Variable..::.ToString Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.Variable.ToString]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.Variable.ToString]

See Also

Variable Class
HeuristicLab.Core Namespace


Variable Properties

[image]

HeuristicLab API Documentation
Variable Properties
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name |
Value |

See Also

Variable Class
HeuristicLab.Core Namespace


Name Property

Variable..::.Name Property
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.Variable.Name]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

Implements

IVariable..::.Name

See Also

Variable Class
HeuristicLab.Core Namespace


Value Property

Variable..::.Value Property
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.Variable.Value]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem Value { get; set; }

Implements

IVariable..::.Value

See Also

Variable Class
HeuristicLab.Core Namespace


Variable Events

[image]

HeuristicLab API Documentation
Variable Events
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
NameChanged |
NameChanging |
ValueChanged |

See Also

Variable Class
HeuristicLab.Core Namespace


NameChanged Event

Variable..::.NameChanged Event
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Variable.NameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler NameChanged

Implements

IVariable..::.NameChanged

See Also

Variable Class
HeuristicLab.Core Namespace


NameChanging Event

Variable..::.NameChanging Event
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Variable.NameChanging]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<NameChangingEventArgs> NameChanging

Implements

IVariable..::.NameChanging

See Also

Variable Class
HeuristicLab.Core Namespace


ValueChanged Event

Variable..::.ValueChanged Event
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.Variable.ValueChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ValueChanged

Implements

IVariable..::.ValueChanged

See Also

Variable Class
HeuristicLab.Core Namespace


VariableEventArgs Class

VariableEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariableEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableEventArgs : ItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.VariableEventArgs

See Also

VariableEventArgs Members
HeuristicLab.Core Namespace


VariableEventArgs Members

[image]

HeuristicLab API Documentation
VariableEventArgs Members
VariableEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableEventArgs type exposes the following members.

Constructors

Name | Description
VariableEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
Variable |

See Also

VariableEventArgs Class
HeuristicLab.Core Namespace


VariableEventArgs Constructor

VariableEventArgs Constructor
VariableEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableEventArgs(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

VariableEventArgs Class
HeuristicLab.Core Namespace


VariableEventArgs Properties

[image]

HeuristicLab API Documentation
VariableEventArgs Properties
VariableEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableEventArgs type exposes the following members.

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
Variable |

See Also

VariableEventArgs Class
HeuristicLab.Core Namespace


Variable Property

VariableEventArgs..::.Variable Property
VariableEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableEventArgs.Variable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IVariable Variable { get; }

See Also

VariableEventArgs Class
HeuristicLab.Core Namespace


VariableInfo Class

VariableInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariableInfo]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableInfo : ItemBase, IVariableInfo,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.VariableInfo

See Also

VariableInfo Members
HeuristicLab.Core Namespace


VariableInfo Members

[image]

HeuristicLab API Documentation
VariableInfo Members
VariableInfo Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfo type exposes the following members.

Constructors

Name | Description
VariableInfo | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnActualNameChanged |
OnChanged | (Inherited from ItemBase.)
OnLocalChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
ActualName |
DataType |
Description |
FormalName |
Guid | (Inherited from StorableBase.)
Kind |
Local |

Events

Name | Description
ActualNameChanged |
Changed | (Inherited from ItemBase.)
LocalChanged |

See Also

VariableInfo Class
HeuristicLab.Core Namespace


VariableInfo Constructor

[image]

HeuristicLab API Documentation
VariableInfo Constructor
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
VariableInfo()()() |
VariableInfo(String, String, Type, VariableKind) |

See Also

VariableInfo Class
VariableInfo Members
HeuristicLab.Core Namespace


VariableInfo Constructor

VariableInfo Constructor
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInfo class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInfo()

See Also

VariableInfo Class
VariableInfo Overload
HeuristicLab.Core Namespace


VariableInfo Constructor (String, String, Type, VariableKind)

VariableInfo Constructor (String, String, Type, VariableKind)
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInfo class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInfo(
    string formalName,
    string description,
    Type dataType,
    VariableKind kind
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

description
Type: System..::.String

[Missing <param> documentation for "description"]

dataType
Type: System..::.Type

[Missing <param> documentation for "dataType"]

kind
Type: HeuristicLab.Core..::.VariableKind

[Missing <param> documentation for "kind"]

See Also

VariableInfo Class
VariableInfo Overload
HeuristicLab.Core Namespace


VariableInfo Methods

[image]

HeuristicLab API Documentation
VariableInfo Methods
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfo type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnActualNameChanged |
OnChanged | (Inherited from ItemBase.)
OnLocalChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

VariableInfo Class
HeuristicLab.Core Namespace


Clone Method

[image]

HeuristicLab API Documentation
VariableInfo..::.Clone Method
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

VariableInfo Class
VariableInfo Members
HeuristicLab.Core Namespace


Clone Method (IDictionary(Guid, Object))

VariableInfo..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfo.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.VariableInfo.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

VariableInfo Class
Clone Overload
HeuristicLab.Core Namespace


CreateView Method

VariableInfo..::.CreateView Method
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfo.CreateView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.VariableInfo.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

VariableInfo Class
HeuristicLab.Core Namespace


GetXmlNode Method

VariableInfo..::.GetXmlNode Method
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfo.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.VariableInfo.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

VariableInfo Class
HeuristicLab.Core Namespace


OnActualNameChanged Method

VariableInfo..::.OnActualNameChanged Method
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfo.OnActualNameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnActualNameChanged()

See Also

VariableInfo Class
HeuristicLab.Core Namespace


OnLocalChanged Method

VariableInfo..::.OnLocalChanged Method
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfo.OnLocalChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnLocalChanged()

See Also

VariableInfo Class
HeuristicLab.Core Namespace


Populate Method

VariableInfo..::.Populate Method
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfo.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

VariableInfo Class
HeuristicLab.Core Namespace


VariableInfo Properties

[image]

HeuristicLab API Documentation
VariableInfo Properties
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfo type exposes the following members.

Properties

Name | Description
ActualName |
DataType |
Description |
FormalName |
Guid | (Inherited from StorableBase.)
Kind |
Local |

See Also

VariableInfo Class
HeuristicLab.Core Namespace


ActualName Property

VariableInfo..::.ActualName Property
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfo.ActualName]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string ActualName { get; set; }

Implements

IVariableInfo..::.ActualName

See Also

VariableInfo Class
HeuristicLab.Core Namespace


DataType Property

VariableInfo..::.DataType Property
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfo.DataType]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Type DataType { get; }

Implements

IVariableInfo..::.DataType

See Also

VariableInfo Class
HeuristicLab.Core Namespace


Description Property

VariableInfo..::.Description Property
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfo.Description]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Description { get; }

Implements

IVariableInfo..::.Description

See Also

VariableInfo Class
HeuristicLab.Core Namespace


FormalName Property

VariableInfo..::.FormalName Property
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfo.FormalName]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string FormalName { get; }

Implements

IVariableInfo..::.FormalName

See Also

VariableInfo Class
HeuristicLab.Core Namespace


Kind Property

VariableInfo..::.Kind Property
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfo.Kind]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableKind Kind { get; }

Implements

IVariableInfo..::.Kind

See Also

VariableInfo Class
HeuristicLab.Core Namespace


Local Property

VariableInfo..::.Local Property
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfo.Local]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Local { get; set; }

Implements

IVariableInfo..::.Local

See Also

VariableInfo Class
HeuristicLab.Core Namespace


VariableInfo Events

[image]

HeuristicLab API Documentation
VariableInfo Events
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfo type exposes the following members.

Events

Name | Description
ActualNameChanged |
Changed | (Inherited from ItemBase.)
LocalChanged |

See Also

VariableInfo Class
HeuristicLab.Core Namespace


ActualNameChanged Event

VariableInfo..::.ActualNameChanged Event
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.VariableInfo.ActualNameChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ActualNameChanged

Implements

IVariableInfo..::.ActualNameChanged

See Also

VariableInfo Class
HeuristicLab.Core Namespace


LocalChanged Event

VariableInfo..::.LocalChanged Event
VariableInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.VariableInfo.LocalChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler LocalChanged

Implements

IVariableInfo..::.LocalChanged

See Also

VariableInfo Class
HeuristicLab.Core Namespace


VariableInfoEventArgs Class

VariableInfoEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariableInfoEventArgs]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableInfoEventArgs : ItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.Core..::.ItemEventArgs
HeuristicLab.Core..::.VariableInfoEventArgs

See Also

VariableInfoEventArgs Members
HeuristicLab.Core Namespace


VariableInfoEventArgs Members

[image]

HeuristicLab API Documentation
VariableInfoEventArgs Members
VariableInfoEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfoEventArgs type exposes the following members.

Constructors

Name | Description
VariableInfoEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
VariableInfo |

See Also

VariableInfoEventArgs Class
HeuristicLab.Core Namespace


VariableInfoEventArgs Constructor

VariableInfoEventArgs Constructor
VariableInfoEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInfoEventArgs class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInfoEventArgs(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

See Also

VariableInfoEventArgs Class
HeuristicLab.Core Namespace


VariableInfoEventArgs Properties

[image]

HeuristicLab API Documentation
VariableInfoEventArgs Properties
VariableInfoEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfoEventArgs type exposes the following members.

Properties

Name | Description
Item | (Inherited from ItemEventArgs.)
VariableInfo |

See Also

VariableInfoEventArgs Class
HeuristicLab.Core Namespace


VariableInfo Property

VariableInfoEventArgs..::.VariableInfo Property
VariableInfoEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfoEventArgs.VariableInfo]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IVariableInfo VariableInfo { get; }

See Also

VariableInfoEventArgs Class
HeuristicLab.Core Namespace


VariableInfoView Class

VariableInfoView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariableInfoView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableInfoView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.VariableInfoView

See Also

VariableInfoView Members
HeuristicLab.Core Namespace


VariableInfoView Members

[image]

HeuristicLab API Documentation
VariableInfoView Members
VariableInfoView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfoView type exposes the following members.

Constructors

Name | Description
VariableInfoView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableInfo |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


VariableInfoView Constructor

[image]

HeuristicLab API Documentation
VariableInfoView Constructor
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
VariableInfoView()()() |
VariableInfoView(IVariableInfo) |

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


VariableInfoView Constructor

VariableInfoView Constructor
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInfoView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInfoView()

See Also

VariableInfoView Class
VariableInfoView Overload
HeuristicLab.Core Namespace


VariableInfoView Constructor (IVariableInfo)

VariableInfoView Constructor (IVariableInfo)
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInfoView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInfoView(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

See Also

VariableInfoView Class
VariableInfoView Overload
HeuristicLab.Core Namespace


VariableInfoView Methods

[image]

HeuristicLab API Documentation
VariableInfoView Methods
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfoView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.AccessibilityNotifyClients Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


AddItemEvents Method

VariableInfoView..::.AddItemEvents Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfoView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.BeginInvoke Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.Dispose Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

VariableInfoView..::.Dispose Method (Boolean)
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VariableInfoView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.GetChildAtPoint Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.Invalidate Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.Invoke Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.MemberwiseClone Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.PerformLayout Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

VariableInfoView..::.RemoveItemEvents Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfoView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.ResumeLayout Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.RtlTranslateAlignment Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.Scale Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.Select Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.SetBounds Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.UpdateBounds Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


UpdateControls Method

VariableInfoView..::.UpdateControls Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableInfoView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.Validate Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
VariableInfoView..::.ValidateChildren Method
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

VariableInfoView Class
VariableInfoView Members
HeuristicLab.Core Namespace


VariableInfoView Properties

[image]

HeuristicLab API Documentation
VariableInfoView Properties
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInfoView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableInfo |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


VariableInfo Property

VariableInfoView..::.VariableInfo Property
VariableInfoView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableInfoView.VariableInfo]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IVariableInfo VariableInfo { get; set; }

See Also

VariableInfoView Class
HeuristicLab.Core Namespace


VariableKind Enumeration

VariableKind Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariableKind]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[FlagsAttribute]
public enum VariableKind

Members

Member name | Description
None |
New |
Out |
In |
Deleted |

See Also

HeuristicLab.Core Namespace


VariablesScopeView Class

VariablesScopeView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariablesScopeView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariablesScopeView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.VariablesScopeView

See Also

VariablesScopeView Members
HeuristicLab.Core Namespace


VariablesScopeView Members

[image]

HeuristicLab API Documentation
VariablesScopeView Members
VariablesScopeView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariablesScopeView type exposes the following members.

Constructors

Name | Description
VariablesScopeView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scope |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


VariablesScopeView Constructor

[image]

HeuristicLab API Documentation
VariablesScopeView Constructor
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
VariablesScopeView()()() |
VariablesScopeView(IScope) |

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


VariablesScopeView Constructor

VariablesScopeView Constructor
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariablesScopeView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariablesScopeView()

See Also

VariablesScopeView Class
VariablesScopeView Overload
HeuristicLab.Core Namespace


VariablesScopeView Constructor (IScope)

VariablesScopeView Constructor (IScope)
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariablesScopeView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariablesScopeView(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

See Also

VariablesScopeView Class
VariablesScopeView Overload
HeuristicLab.Core Namespace


VariablesScopeView Methods

[image]

HeuristicLab API Documentation
VariablesScopeView Methods
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariablesScopeView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.AccessibilityNotifyClients Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


AddItemEvents Method

VariablesScopeView..::.AddItemEvents Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariablesScopeView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.BeginInvoke Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.Dispose Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

VariablesScopeView..::.Dispose Method (Boolean)
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VariablesScopeView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.GetChildAtPoint Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.Invalidate Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.Invoke Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.MemberwiseClone Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.PerformLayout Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

VariablesScopeView..::.RemoveItemEvents Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariablesScopeView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.ResumeLayout Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.RtlTranslateAlignment Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.Scale Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.Select Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.SetBounds Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.UpdateBounds Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


UpdateControls Method

VariablesScopeView..::.UpdateControls Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariablesScopeView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.Validate Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
VariablesScopeView..::.ValidateChildren Method
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

VariablesScopeView Class
VariablesScopeView Members
HeuristicLab.Core Namespace


VariablesScopeView Properties

[image]

HeuristicLab API Documentation
VariablesScopeView Properties
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariablesScopeView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Scope |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


Scope Property

VariablesScopeView..::.Scope Property
VariablesScopeView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariablesScopeView.Scope]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IScope Scope { get; set; }

See Also

VariablesScopeView Class
HeuristicLab.Core Namespace


VariableView Class

VariableView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.VariableView]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.VariableView

See Also

VariableView Members
HeuristicLab.Core Namespace


VariableView Members

[image]

HeuristicLab API Documentation
VariableView Members
VariableView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableView type exposes the following members.

Constructors

Name | Description
VariableView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Variable |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VariableView Class
HeuristicLab.Core Namespace


VariableView Constructor

[image]

HeuristicLab API Documentation
VariableView Constructor
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
VariableView()()() |
VariableView(IVariable) |

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


VariableView Constructor

VariableView Constructor
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableView()

See Also

VariableView Class
VariableView Overload
HeuristicLab.Core Namespace


VariableView Constructor (IVariable)

VariableView Constructor (IVariable)
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableView class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableView(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

VariableView Class
VariableView Overload
HeuristicLab.Core Namespace


VariableView Methods

[image]

HeuristicLab API Documentation
VariableView Methods
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

VariableView Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
VariableView..::.AccessibilityNotifyClients Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


AddItemEvents Method

VariableView..::.AddItemEvents Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableView.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

VariableView Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
VariableView..::.BeginInvoke Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
VariableView..::.Dispose Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

VariableView..::.Dispose Method (Boolean)
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VariableView Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
VariableView..::.GetChildAtPoint Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
VariableView..::.Invalidate Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
VariableView..::.Invoke Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
VariableView..::.MemberwiseClone Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
VariableView..::.PerformLayout Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


RemoveItemEvents Method

VariableView..::.RemoveItemEvents Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableView.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

VariableView Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
VariableView..::.ResumeLayout Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
VariableView..::.RtlTranslateAlignment Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
VariableView..::.Scale Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
VariableView..::.Select Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
VariableView..::.SetBounds Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
VariableView..::.UpdateBounds Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


UpdateControls Method

VariableView..::.UpdateControls Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.VariableView.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

VariableView Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
VariableView..::.Validate Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
VariableView..::.ValidateChildren Method
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

VariableView Class
VariableView Members
HeuristicLab.Core Namespace


VariableView Properties

[image]

HeuristicLab API Documentation
VariableView Properties
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Variable |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

VariableView Class
HeuristicLab.Core Namespace


Variable Property

VariableView..::.Variable Property
VariableView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.VariableView.Variable]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IVariable Variable { get; set; }

See Also

VariableView Class
HeuristicLab.Core Namespace


ViewBase Class

ViewBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Core.ViewBase]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ViewBase : UserControl, IView,
    IControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Constraints..::.SubOperatorsTypeConstraintView
HeuristicLab.Constraints..::.AndConstraintView
HeuristicLab.Constraints..::.NumberOfSubOperatorsConstraintView
HeuristicLab.Constraints..::.OrConstraintView
HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraintView
HeuristicLab.Constraints..::.VariableComparisonConstraintView
HeuristicLab.Constraints..::.ItemTypeConstraintView
HeuristicLab.Constraints..::.NotConstraintView
HeuristicLab.Constraints..::.IntBoundedConstraintView
HeuristicLab.Constraints..::.DoubleBoundedConstraintView
HeuristicLab.Constraints..::.TrueConstraintView
HeuristicLab.Constraints..::.FalseConstraintView
HeuristicLab.Core..::.ScopeView
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.VariableInfoView
HeuristicLab.Core..::.OperatorGraphView
HeuristicLab.Core..::.OperatorBaseVariableInfosView
HeuristicLab.Core..::.VariableView
HeuristicLab.Core..::.OperatorBaseDescriptionView
HeuristicLab.Core..::.ConstrainedItemBaseView
HeuristicLab.Core..::.ItemBaseView
HeuristicLab.Core..::.OperatorBaseView
HeuristicLab.Core..::.OperatorBaseVariablesView
HeuristicLab.Core..::.VariablesScopeView
HeuristicLab.Data..::.StringDataView
HeuristicLab.Data..::.ConstrainedIntDataView
HeuristicLab.Data..::.ItemListView
HeuristicLab.Data..::.ArrayDataBaseView
HeuristicLab.Data..::.IntDataView
HeuristicLab.Data..::.MatrixDataBaseView
HeuristicLab.Data..::.ConstrainedDoubleDataView
HeuristicLab.Data..::.ConstrainedItemListView
HeuristicLab.Data..::.BoolDataView
HeuristicLab.Data..::.DoubleDataView
HeuristicLab.DataAnalysis..::.DatasetView
HeuristicLab.Functions..::.FunctionView
HeuristicLab.Logging..::.LogView
HeuristicLab.Logging..::.LinechartView
HeuristicLab.Operators..::.CombinedOperatorView
HeuristicLab.Operators.Programmable..::.ProgrammableOperatorView
HeuristicLab.Routing.TSP..::.TSPInjectorView
HeuristicLab.Routing.TSP..::.TSPTourView
HeuristicLab.Scheduling.JSSP..::.JSSPInjectorView
HeuristicLab.Scheduling.JSSP..::.OperationView
HeuristicLab.StructureIdentification..::.StructIdProblemInjectorView

See Also

ViewBase Members
HeuristicLab.Core Namespace


ViewBase Members

[image]

HeuristicLab API Documentation
ViewBase Members
ViewBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewBase type exposes the following members.

Constructors

Name | Description
ViewBase |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents |
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged |
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged |
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Overrides Control ..::. Refresh()()().)
RemoveItemEvents |
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls |
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption |
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item |
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged |
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged |
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ViewBase Class
HeuristicLab.Core Namespace


ViewBase Constructor

ViewBase Constructor
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ViewBase class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ViewBase()

See Also

ViewBase Class
HeuristicLab.Core Namespace


ViewBase Methods

[image]

HeuristicLab API Documentation
ViewBase Methods
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewBase type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents |
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged |
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged |
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Overrides Control ..::. Refresh()()().)
RemoveItemEvents |
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls |
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ViewBase Class
HeuristicLab.Core Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ViewBase..::.AccessibilityNotifyClients Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


AddItemEvents Method

ViewBase..::.AddItemEvents Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.AddItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void AddItemEvents()

See Also

ViewBase Class
HeuristicLab.Core Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ViewBase..::.BeginInvoke Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ViewBase..::.Dispose Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl ..::. Dispose(Boolean).)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Dispose Method (Boolean)

ViewBase..::.Dispose Method (Boolean)
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ViewBase Class
Dispose Overload
HeuristicLab.Core Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ViewBase..::.GetChildAtPoint Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ViewBase..::.Invalidate Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ViewBase..::.Invoke Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) |
Invoke(Delegate, array<Object>[]()[]) |

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Invoke Method (Delegate)

ViewBase..::.Invoke Method (Delegate)
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.Invoke(System.Delegate)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected void Invoke(
    Delegate method
)

Parameters

method
Type: System..::.Delegate

[Missing <param> documentation for "method"]

See Also

ViewBase Class
Invoke Overload
HeuristicLab.Core Namespace


Invoke Method (Delegate, Object[])

ViewBase..::.Invoke Method (Delegate, array<Object>[]()[])
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.Invoke(System.Delegate,System.Object[])]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected void Invoke(
    Delegate method,
    params Object[] args
)

Parameters

method
Type: System..::.Delegate

[Missing <param> documentation for "method"]

args
Type: array< System..::.Object >[]()[]

[Missing <param> documentation for "args"]

See Also

ViewBase Class
Invoke Overload
HeuristicLab.Core Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ViewBase..::.MemberwiseClone Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


OnCaptionChanged Method

ViewBase..::.OnCaptionChanged Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.OnCaptionChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnCaptionChanged()

See Also

ViewBase Class
HeuristicLab.Core Namespace


OnItemChanged Method

ViewBase..::.OnItemChanged Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.OnItemChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemChanged()

See Also

ViewBase Class
HeuristicLab.Core Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ViewBase..::.PerformLayout Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Refresh Method

ViewBase..::.Refresh Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.Refresh]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Refresh()

See Also

ViewBase Class
HeuristicLab.Core Namespace


RemoveItemEvents Method

ViewBase..::.RemoveItemEvents Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.RemoveItemEvents]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void RemoveItemEvents()

See Also

ViewBase Class
HeuristicLab.Core Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ViewBase..::.ResumeLayout Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ViewBase..::.RtlTranslateAlignment Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Scale Method

[image]

HeuristicLab API Documentation
ViewBase..::.Scale Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


Select Method

[image]

HeuristicLab API Documentation
ViewBase..::.Select Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ViewBase..::.SetBounds Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ViewBase..::.UpdateBounds Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


UpdateControls Method

ViewBase..::.UpdateControls Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ViewBase.UpdateControls]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void UpdateControls()

See Also

ViewBase Class
HeuristicLab.Core Namespace


Validate Method

[image]

HeuristicLab API Documentation
ViewBase..::.Validate Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ViewBase..::.ValidateChildren Method
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ViewBase Class
ViewBase Members
HeuristicLab.Core Namespace


ViewBase Properties

[image]

HeuristicLab API Documentation
ViewBase Properties
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewBase type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption |
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item |
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ViewBase Class
HeuristicLab.Core Namespace


Caption Property

ViewBase..::.Caption Property
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ViewBase.Caption]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Caption { get; set; }

Implements

IView..::.Caption

See Also

ViewBase Class
HeuristicLab.Core Namespace


Item Property

ViewBase..::.Item Property
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Core.ViewBase.Item]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem Item { get; protected set; }

Implements

IView..::.Item

See Also

ViewBase Class
HeuristicLab.Core Namespace


ViewBase Events

[image]

HeuristicLab API Documentation
ViewBase Events
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewBase type exposes the following members.

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged |
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged |
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ViewBase Class
HeuristicLab.Core Namespace


CaptionChanged Event

ViewBase..::.CaptionChanged Event
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.ViewBase.CaptionChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler CaptionChanged

Implements

IView..::.CaptionChanged

See Also

ViewBase Class
HeuristicLab.Core Namespace


ItemChanged Event

ViewBase..::.ItemChanged Event
ViewBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Core.ViewBase.ItemChanged]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ItemChanged

Implements

IView..::.ItemChanged

See Also

ViewBase Class
HeuristicLab.Core Namespace


HeuristicLab.Data Namespace

HeuristicLab.Data Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

HeuristicLab.Data Namespace Summary (... to be continued ...)

Classes

Class | Description
ArrayDataBase |
ArrayDataBaseView |
BoolArrayData |
BoolArrayDataView |
BoolData |
BoolDataView |
BoolMatrixData |
BoolMatrixDataView |
ConstrainedDoubleData |
ConstrainedDoubleDataView |
ConstrainedIntData |
ConstrainedIntDataView |
ConstrainedItemList |
ConstrainedItemListView |
ConstrainedObjectData |
DoubleArrayData |
DoubleArrayDataView |
DoubleData |
DoubleDataView |
DoubleMatrixData |
DoubleMatrixDataView |
HeuristicLabDataPlugin |
IntArrayData |
IntArrayDataView |
IntData |
IntDataView |
IntMatrixData |
IntMatrixDataView |
ItemList |
ItemListView |
MatrixDataBaseView |
ObjectData |
ObjectDataVisitorBase |
StringData |
StringDataView |

Interfaces

Interface | Description
IObjectData |
IObjectDataVisitor |


ArrayDataBase Class

ArrayDataBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ArrayDataBase]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ArrayDataBase : ObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.IntArrayData
HeuristicLab.Data..::.BoolMatrixData
HeuristicLab.Data..::.DoubleMatrixData
HeuristicLab.Data..::.DoubleArrayData
HeuristicLab.Data..::.BoolArrayData
HeuristicLab.Data..::.IntMatrixData

See Also

ArrayDataBase Members
HeuristicLab.Data Namespace


ArrayDataBase Members

[image]

HeuristicLab API Documentation
ArrayDataBase Members
ArrayDataBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ArrayDataBase type exposes the following members.

Constructors

Name | Description
ArrayDataBase |

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Overrides ObjectData ..::. ToString()()().)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

ArrayDataBase Class
HeuristicLab.Data Namespace


ArrayDataBase Constructor

ArrayDataBase Constructor
ArrayDataBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ArrayDataBase class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ArrayDataBase()

See Also

ArrayDataBase Class
HeuristicLab.Data Namespace


ArrayDataBase Methods

[image]

HeuristicLab API Documentation
ArrayDataBase Methods
ArrayDataBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ArrayDataBase type exposes the following members.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Overrides ObjectData ..::. ToString()()().)

See Also

ArrayDataBase Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ArrayDataBase..::.Clone Method
ArrayDataBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

ArrayDataBase Class
ArrayDataBase Members
HeuristicLab.Data Namespace


ToString Method

ArrayDataBase..::.ToString Method
ArrayDataBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ArrayDataBase.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ArrayDataBase.ToString]

See Also

ArrayDataBase Class
HeuristicLab.Data Namespace


ArrayDataBase Properties

[image]

HeuristicLab API Documentation
ArrayDataBase Properties
ArrayDataBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ArrayDataBase type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

ArrayDataBase Class
HeuristicLab.Data Namespace


Data Property

ArrayDataBase..::.Data Property
ArrayDataBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ArrayDataBase.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Array Data { get; set; }

See Also

ArrayDataBase Class
HeuristicLab.Data Namespace


ArrayDataBaseView Class

ArrayDataBaseView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ArrayDataBaseView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ArrayDataBaseView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ArrayDataBaseView
HeuristicLab.Data..::.IntArrayDataView
HeuristicLab.Data..::.DoubleArrayDataView
HeuristicLab.Data..::.BoolArrayDataView

See Also

ArrayDataBaseView Members
HeuristicLab.Data Namespace


ArrayDataBaseView Members

[image]

HeuristicLab API Documentation
ArrayDataBaseView Members
ArrayDataBaseView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ArrayDataBaseView type exposes the following members.

Constructors

Name | Description
ArrayDataBaseView |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement |
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData |
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


ArrayDataBaseView Constructor

ArrayDataBaseView Constructor
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ArrayDataBaseView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ArrayDataBaseView()

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


ArrayDataBaseView Methods

[image]

HeuristicLab API Documentation
ArrayDataBaseView Methods
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ArrayDataBaseView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement |
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData |
WndProc | (Inherited from UserControl.)

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.AccessibilityNotifyClients Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


AddItemEvents Method

ArrayDataBaseView..::.AddItemEvents Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ArrayDataBaseView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.BeginInvoke Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.Dispose Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

ArrayDataBaseView..::.Dispose Method (Boolean)
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ArrayDataBaseView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.GetChildAtPoint Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.Invalidate Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.Invoke Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.MemberwiseClone Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.PerformLayout Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

ArrayDataBaseView..::.RemoveItemEvents Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ArrayDataBaseView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.ResumeLayout Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.RtlTranslateAlignment Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.Scale Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.Select Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


SetArrayElement Method

ArrayDataBaseView..::.SetArrayElement Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ArrayDataBaseView.SetArrayElement(System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void SetArrayElement(
    int index,
    string element
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.SetBounds Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.UpdateBounds Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


UpdateControls Method

ArrayDataBaseView..::.UpdateControls Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ArrayDataBaseView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.Validate Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ArrayDataBaseView..::.ValidateChildren Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ArrayDataBaseView Class
ArrayDataBaseView Members
HeuristicLab.Data Namespace


ValidateData Method

ArrayDataBaseView..::.ValidateData Method
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ArrayDataBaseView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ArrayDataBaseView.ValidateData(System.String)]

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


ArrayDataBaseView Properties

[image]

HeuristicLab API Documentation
ArrayDataBaseView Properties
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ArrayDataBaseView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


ArrayDataBase Property

ArrayDataBaseView..::.ArrayDataBase Property
ArrayDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ArrayDataBaseView.ArrayDataBase]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ArrayDataBase ArrayDataBase { get; protected set; }

See Also

ArrayDataBaseView Class
HeuristicLab.Data Namespace


BoolArrayData Class

BoolArrayData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.BoolArrayData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BoolArrayData : ArrayDataBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.BoolArrayData

See Also

BoolArrayData Members
HeuristicLab.Data Namespace


BoolArrayData Members

[image]

HeuristicLab API Documentation
BoolArrayData Members
BoolArrayData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolArrayData type exposes the following members.

Constructors

Name | Description
BoolArrayData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ArrayDataBase.)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


BoolArrayData Constructor

[image]

HeuristicLab API Documentation
BoolArrayData Constructor
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BoolArrayData()()() |
BoolArrayData(array<Boolean>[]()[]) |

See Also

BoolArrayData Class
BoolArrayData Members
HeuristicLab.Data Namespace


BoolArrayData Constructor

BoolArrayData Constructor
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolArrayData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolArrayData()

See Also

BoolArrayData Class
BoolArrayData Overload
HeuristicLab.Data Namespace


BoolArrayData Constructor (Boolean[])

BoolArrayData Constructor (array<Boolean>[]()[])
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolArrayData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolArrayData(
    bool[] data
)

Parameters

data
Type: array< System..::.Boolean >[]()[]

[Missing <param> documentation for "data"]

See Also

BoolArrayData Class
BoolArrayData Overload
HeuristicLab.Data Namespace


BoolArrayData Methods

[image]

HeuristicLab API Documentation
BoolArrayData Methods
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolArrayData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ArrayDataBase.)

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


Accept Method

BoolArrayData..::.Accept Method
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolArrayData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
BoolArrayData..::.Clone Method
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

BoolArrayData Class
BoolArrayData Members
HeuristicLab.Data Namespace


CreateView Method

BoolArrayData..::.CreateView Method
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolArrayData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolArrayData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


GetXmlNode Method

BoolArrayData..::.GetXmlNode Method
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolArrayData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolArrayData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


Populate Method

BoolArrayData..::.Populate Method
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolArrayData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


BoolArrayData Properties

[image]

HeuristicLab API Documentation
BoolArrayData Properties
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolArrayData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


Data Property

BoolArrayData..::.Data Property
BoolArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.BoolArrayData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool[] Data { get; set; }

See Also

BoolArrayData Class
HeuristicLab.Data Namespace


BoolArrayDataView Class

BoolArrayDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.BoolArrayDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BoolArrayDataView : ArrayDataBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ArrayDataBaseView
HeuristicLab.Data..::.BoolArrayDataView

See Also

BoolArrayDataView Members
HeuristicLab.Data Namespace


BoolArrayDataView Members

[image]

HeuristicLab API Documentation
BoolArrayDataView Members
BoolArrayDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolArrayDataView type exposes the following members.

Constructors

Name | Description
BoolArrayDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ArrayDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ArrayDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides ArrayDataBaseView ..::. SetArrayElement(Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ArrayDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides ArrayDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from ArrayDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BoolArrayData |
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BoolArrayDataView Class
HeuristicLab.Data Namespace


BoolArrayDataView Constructor

[image]

HeuristicLab API Documentation
BoolArrayDataView Constructor
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BoolArrayDataView()()() |
BoolArrayDataView(BoolArrayData) |

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


BoolArrayDataView Constructor

BoolArrayDataView Constructor
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolArrayDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolArrayDataView()

See Also

BoolArrayDataView Class
BoolArrayDataView Overload
HeuristicLab.Data Namespace


BoolArrayDataView Constructor (BoolArrayData)

BoolArrayDataView Constructor (BoolArrayData)
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolArrayDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolArrayDataView(
    BoolArrayData boolArrayData
)

Parameters

boolArrayData
Type: HeuristicLab.Data..::.BoolArrayData

[Missing <param> documentation for "boolArrayData"]

See Also

BoolArrayDataView Class
BoolArrayDataView Overload
HeuristicLab.Data Namespace


BoolArrayDataView Methods

[image]

HeuristicLab API Documentation
BoolArrayDataView Methods
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolArrayDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ArrayDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ArrayDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides ArrayDataBaseView ..::. SetArrayElement(Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ArrayDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides ArrayDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

See Also

BoolArrayDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.AccessibilityNotifyClients Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.BeginInvoke Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.Dispose Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ArrayDataBaseView ..::. Dispose(Boolean).)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

BoolArrayDataView..::.Dispose Method (Boolean)
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

BoolArrayDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.GetChildAtPoint Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.Invalidate Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.Invoke Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.MemberwiseClone Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.PerformLayout Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.ResumeLayout Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.RtlTranslateAlignment Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.Scale Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.Select Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


SetArrayElement Method

BoolArrayDataView..::.SetArrayElement Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolArrayDataView.SetArrayElement(System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void SetArrayElement(
    int index,
    string element
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

BoolArrayDataView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.SetBounds Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.UpdateBounds Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.Validate Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
BoolArrayDataView..::.ValidateChildren Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

BoolArrayDataView Class
BoolArrayDataView Members
HeuristicLab.Data Namespace


ValidateData Method

BoolArrayDataView..::.ValidateData Method
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolArrayDataView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolArrayDataView.ValidateData(System.String)]

See Also

BoolArrayDataView Class
HeuristicLab.Data Namespace


BoolArrayDataView Properties

[image]

HeuristicLab API Documentation
BoolArrayDataView Properties
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolArrayDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from ArrayDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BoolArrayData |
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

BoolArrayDataView Class
HeuristicLab.Data Namespace


BoolArrayData Property

BoolArrayDataView..::.BoolArrayData Property
BoolArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.BoolArrayDataView.BoolArrayData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolArrayData BoolArrayData { get; set; }

See Also

BoolArrayDataView Class
HeuristicLab.Data Namespace


BoolData Class

BoolData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.BoolData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BoolData : ObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.BoolData

See Also

BoolData Members
HeuristicLab.Data Namespace


BoolData Members

[image]

HeuristicLab API Documentation
BoolData Members
BoolData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolData type exposes the following members.

Constructors

Name | Description
BoolData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ObjectData.)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

BoolData Class
HeuristicLab.Data Namespace


BoolData Constructor

[image]

HeuristicLab API Documentation
BoolData Constructor
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BoolData()()() |
BoolData(Boolean) |

See Also

BoolData Class
BoolData Members
HeuristicLab.Data Namespace


BoolData Constructor

BoolData Constructor
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolData()

See Also

BoolData Class
BoolData Overload
HeuristicLab.Data Namespace


BoolData Constructor (Boolean)

BoolData Constructor (Boolean)
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolData(
    bool data
)

Parameters

data
Type: System..::.Boolean

[Missing <param> documentation for "data"]

See Also

BoolData Class
BoolData Overload
HeuristicLab.Data Namespace


BoolData Methods

[image]

HeuristicLab API Documentation
BoolData Methods
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ObjectData.)

See Also

BoolData Class
HeuristicLab.Data Namespace


Accept Method

BoolData..::.Accept Method
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

BoolData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
BoolData..::.Clone Method
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

BoolData Class
BoolData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

BoolData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

BoolData Class
Clone Overload
HeuristicLab.Data Namespace


CreateView Method

BoolData..::.CreateView Method
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

BoolData Class
HeuristicLab.Data Namespace


GetXmlNode Method

BoolData..::.GetXmlNode Method
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

BoolData Class
HeuristicLab.Data Namespace


Populate Method

BoolData..::.Populate Method
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

BoolData Class
HeuristicLab.Data Namespace


BoolData Properties

[image]

HeuristicLab API Documentation
BoolData Properties
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

BoolData Class
HeuristicLab.Data Namespace


Data Property

BoolData..::.Data Property
BoolData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.BoolData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Data { get; set; }

See Also

BoolData Class
HeuristicLab.Data Namespace


BoolDataView Class

BoolDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.BoolDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BoolDataView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.BoolDataView

See Also

BoolDataView Members
HeuristicLab.Data Namespace


BoolDataView Members

[image]

HeuristicLab API Documentation
BoolDataView Members
BoolDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolDataView type exposes the following members.

Constructors

Name | Description
BoolDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BoolData |
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BoolDataView Class
HeuristicLab.Data Namespace


BoolDataView Constructor

[image]

HeuristicLab API Documentation
BoolDataView Constructor
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BoolDataView()()() |
BoolDataView(BoolData) |

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


BoolDataView Constructor

BoolDataView Constructor
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolDataView()

See Also

BoolDataView Class
BoolDataView Overload
HeuristicLab.Data Namespace


BoolDataView Constructor (BoolData)

BoolDataView Constructor (BoolData)
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolDataView(
    BoolData boolData
)

Parameters

boolData
Type: HeuristicLab.Data..::.BoolData

[Missing <param> documentation for "boolData"]

See Also

BoolDataView Class
BoolDataView Overload
HeuristicLab.Data Namespace


BoolDataView Methods

[image]

HeuristicLab API Documentation
BoolDataView Methods
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

BoolDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
BoolDataView..::.AccessibilityNotifyClients Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


AddItemEvents Method

BoolDataView..::.AddItemEvents Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolDataView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

BoolDataView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
BoolDataView..::.BeginInvoke Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
BoolDataView..::.Dispose Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

BoolDataView..::.Dispose Method (Boolean)
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

BoolDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
BoolDataView..::.GetChildAtPoint Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
BoolDataView..::.Invalidate Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
BoolDataView..::.Invoke Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
BoolDataView..::.MemberwiseClone Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
BoolDataView..::.PerformLayout Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

BoolDataView..::.RemoveItemEvents Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolDataView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

BoolDataView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
BoolDataView..::.ResumeLayout Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
BoolDataView..::.RtlTranslateAlignment Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
BoolDataView..::.Scale Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
BoolDataView..::.Select Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
BoolDataView..::.SetBounds Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
BoolDataView..::.UpdateBounds Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


UpdateControls Method

BoolDataView..::.UpdateControls Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolDataView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

BoolDataView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
BoolDataView..::.Validate Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
BoolDataView..::.ValidateChildren Method
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

BoolDataView Class
BoolDataView Members
HeuristicLab.Data Namespace


BoolDataView Properties

[image]

HeuristicLab API Documentation
BoolDataView Properties
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BoolData |
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

BoolDataView Class
HeuristicLab.Data Namespace


BoolData Property

BoolDataView..::.BoolData Property
BoolDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.BoolDataView.BoolData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolData BoolData { get; set; }

See Also

BoolDataView Class
HeuristicLab.Data Namespace


BoolMatrixData Class

BoolMatrixData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.BoolMatrixData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BoolMatrixData : ArrayDataBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.BoolMatrixData

See Also

BoolMatrixData Members
HeuristicLab.Data Namespace


BoolMatrixData Members

[image]

HeuristicLab API Documentation
BoolMatrixData Members
BoolMatrixData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolMatrixData type exposes the following members.

Constructors

Name | Description
BoolMatrixData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ArrayDataBase ..::. ToString()()().)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


BoolMatrixData Constructor

[image]

HeuristicLab API Documentation
BoolMatrixData Constructor
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BoolMatrixData()()() |
BoolMatrixData(array<Boolean,2>[,](,)[,]) |

See Also

BoolMatrixData Class
BoolMatrixData Members
HeuristicLab.Data Namespace


BoolMatrixData Constructor

BoolMatrixData Constructor
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolMatrixData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolMatrixData()

See Also

BoolMatrixData Class
BoolMatrixData Overload
HeuristicLab.Data Namespace


BoolMatrixData Constructor (Boolean[,])

BoolMatrixData Constructor (array<Boolean,2>[,](,)[,])
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolMatrixData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolMatrixData(
    bool[,] data
)

Parameters

data
Type: array< System..::.Boolean ,2>[,](,)[,]

[Missing <param> documentation for "data"]

See Also

BoolMatrixData Class
BoolMatrixData Overload
HeuristicLab.Data Namespace


BoolMatrixData Methods

[image]

HeuristicLab API Documentation
BoolMatrixData Methods
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolMatrixData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ArrayDataBase ..::. ToString()()().)

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


Accept Method

BoolMatrixData..::.Accept Method
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
BoolMatrixData..::.Clone Method
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

BoolMatrixData Class
BoolMatrixData Members
HeuristicLab.Data Namespace


CreateView Method

BoolMatrixData..::.CreateView Method
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolMatrixData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


GetXmlNode Method

BoolMatrixData..::.GetXmlNode Method
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolMatrixData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


Populate Method

BoolMatrixData..::.Populate Method
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


ToString Method

BoolMatrixData..::.ToString Method
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixData.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolMatrixData.ToString]

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


BoolMatrixData Properties

[image]

HeuristicLab API Documentation
BoolMatrixData Properties
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolMatrixData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


Data Property

BoolMatrixData..::.Data Property
BoolMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.BoolMatrixData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool[,] Data { get; set; }

See Also

BoolMatrixData Class
HeuristicLab.Data Namespace


BoolMatrixDataView Class

BoolMatrixDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.BoolMatrixDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BoolMatrixDataView : MatrixDataBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.MatrixDataBaseView
HeuristicLab.Data..::.BoolMatrixDataView

See Also

BoolMatrixDataView Members
HeuristicLab.Data Namespace


BoolMatrixDataView Members

[image]

HeuristicLab API Documentation
BoolMatrixDataView Members
BoolMatrixDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolMatrixDataView type exposes the following members.

Constructors

Name | Description
BoolMatrixDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from MatrixDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from MatrixDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides MatrixDataBaseView ..::. SetArrayElement(Int32, Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from MatrixDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides MatrixDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from MatrixDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BoolMatrixData |
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

BoolMatrixDataView Class
HeuristicLab.Data Namespace


BoolMatrixDataView Constructor

[image]

HeuristicLab API Documentation
BoolMatrixDataView Constructor
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BoolMatrixDataView()()() |
BoolMatrixDataView(BoolMatrixData) |

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


BoolMatrixDataView Constructor

BoolMatrixDataView Constructor
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolMatrixDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolMatrixDataView()

See Also

BoolMatrixDataView Class
BoolMatrixDataView Overload
HeuristicLab.Data Namespace


BoolMatrixDataView Constructor (BoolMatrixData)

BoolMatrixDataView Constructor (BoolMatrixData)
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BoolMatrixDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolMatrixDataView(
    BoolMatrixData boolMatrixData
)

Parameters

boolMatrixData
Type: HeuristicLab.Data..::.BoolMatrixData

[Missing <param> documentation for "boolMatrixData"]

See Also

BoolMatrixDataView Class
BoolMatrixDataView Overload
HeuristicLab.Data Namespace


BoolMatrixDataView Methods

[image]

HeuristicLab API Documentation
BoolMatrixDataView Methods
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolMatrixDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from MatrixDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from MatrixDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides MatrixDataBaseView ..::. SetArrayElement(Int32, Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from MatrixDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides MatrixDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

See Also

BoolMatrixDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.AccessibilityNotifyClients Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.BeginInvoke Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.Dispose Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides MatrixDataBaseView ..::. Dispose(Boolean).)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

BoolMatrixDataView..::.Dispose Method (Boolean)
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

BoolMatrixDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.GetChildAtPoint Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.Invalidate Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.Invoke Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.MemberwiseClone Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.PerformLayout Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.ResumeLayout Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.RtlTranslateAlignment Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.Scale Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.Select Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


SetArrayElement Method

BoolMatrixDataView..::.SetArrayElement Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixDataView.SetArrayElement(System.Int32,System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void SetArrayElement(
    int row,
    int column,
    string element
)

Parameters

row
Type: System..::.Int32

[Missing <param> documentation for "row"]

column
Type: System..::.Int32

[Missing <param> documentation for "column"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

BoolMatrixDataView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.SetBounds Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.UpdateBounds Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.Validate Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
BoolMatrixDataView..::.ValidateChildren Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

BoolMatrixDataView Class
BoolMatrixDataView Members
HeuristicLab.Data Namespace


ValidateData Method

BoolMatrixDataView..::.ValidateData Method
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.BoolMatrixDataView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.BoolMatrixDataView.ValidateData(System.String)]

See Also

BoolMatrixDataView Class
HeuristicLab.Data Namespace


BoolMatrixDataView Properties

[image]

HeuristicLab API Documentation
BoolMatrixDataView Properties
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BoolMatrixDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from MatrixDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BoolMatrixData |
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

BoolMatrixDataView Class
HeuristicLab.Data Namespace


BoolMatrixData Property

BoolMatrixDataView..::.BoolMatrixData Property
BoolMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.BoolMatrixDataView.BoolMatrixData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BoolMatrixData BoolMatrixData { get; set; }

See Also

BoolMatrixDataView Class
HeuristicLab.Data Namespace


ConstrainedDoubleData Class

ConstrainedDoubleData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedDoubleData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedDoubleData : ConstrainedObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Data..::.ConstrainedObjectData
HeuristicLab.Data..::.ConstrainedDoubleData

See Also

ConstrainedDoubleData Members
HeuristicLab.Data Namespace


ConstrainedDoubleData Members

[image]

HeuristicLab API Documentation
ConstrainedDoubleData Members
ConstrainedDoubleData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedDoubleData type exposes the following members.

Constructors

Name | Description
ConstrainedDoubleData | Overloaded.

Methods

Name | Description
Accept | (Overrides ConstrainedObjectData ..::. Accept(IObjectDataVisitor).)
AddConstraint | (Inherited from ConstrainedItemBase.)
Clone | Overloaded.
CompareTo | (Inherited from ConstrainedObjectData.)
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Inherited from ConstrainedObjectData.)
TrySetData | Overloaded.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


ConstrainedDoubleData Constructor

[image]

HeuristicLab API Documentation
ConstrainedDoubleData Constructor
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConstrainedDoubleData()()() |
ConstrainedDoubleData(Double) |

See Also

ConstrainedDoubleData Class
ConstrainedDoubleData Members
HeuristicLab.Data Namespace


ConstrainedDoubleData Constructor

ConstrainedDoubleData Constructor
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedDoubleData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedDoubleData()

See Also

ConstrainedDoubleData Class
ConstrainedDoubleData Overload
HeuristicLab.Data Namespace


ConstrainedDoubleData Constructor (Double)

ConstrainedDoubleData Constructor (Double)
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedDoubleData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedDoubleData(
    double data
)

Parameters

data
Type: System..::.Double

[Missing <param> documentation for "data"]

See Also

ConstrainedDoubleData Class
ConstrainedDoubleData Overload
HeuristicLab.Data Namespace


ConstrainedDoubleData Methods

[image]

HeuristicLab API Documentation
ConstrainedDoubleData Methods
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedDoubleData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstrainedObjectData ..::. Accept(IObjectDataVisitor).)
AddConstraint | (Inherited from ConstrainedItemBase.)
Clone | Overloaded.
CompareTo | (Inherited from ConstrainedObjectData.)
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Inherited from ConstrainedObjectData.)
TrySetData | Overloaded.

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


Accept Method

ConstrainedDoubleData..::.Accept Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleData..::.Clone Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ConstrainedObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ConstrainedDoubleData Class
ConstrainedDoubleData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

ConstrainedDoubleData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ConstrainedDoubleData Class
Clone Overload
HeuristicLab.Data Namespace


CreateView Method

ConstrainedDoubleData..::.CreateView Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


GetXmlNode Method

ConstrainedDoubleData..::.GetXmlNode Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleData..::.IsValid Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedDoubleData Class
ConstrainedDoubleData Members
HeuristicLab.Data Namespace


Populate Method

ConstrainedDoubleData..::.Populate Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


TrySetData Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleData..::.TrySetData Method
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TrySetData(Double) |
TrySetData(Object) | (Inherited from ConstrainedObjectData.)
TrySetData(Double, ICollection<(Of <(IConstraint>)>)%) |
TrySetData(Object, ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedObjectData.)

See Also

ConstrainedDoubleData Class
ConstrainedDoubleData Members
HeuristicLab.Data Namespace


TrySetData Method (Double)

ConstrainedDoubleData..::.TrySetData Method (Double)
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.TrySetData(System.Double)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TrySetData(
    double data
)

Parameters

data
Type: System..::.Double

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.TrySetData(System.Double)]

See Also

ConstrainedDoubleData Class
TrySetData Overload
HeuristicLab.Data Namespace


TrySetData Method (Double, ICollection(IConstraint) )

ConstrainedDoubleData..::.TrySetData Method (Double, ICollection<(Of <(IConstraint>)>) %)
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.TrySetData(System.Double,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TrySetData(
    double data,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

data
Type: System..::.Double

[Missing <param> documentation for "data"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedDoubleData.TrySetData(System.Double,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedDoubleData Class
TrySetData Overload
HeuristicLab.Data Namespace


ConstrainedDoubleData Properties

[image]

HeuristicLab API Documentation
ConstrainedDoubleData Properties
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedDoubleData type exposes the following members.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Data |
Guid | (Inherited from StorableBase.)

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


Data Property

ConstrainedDoubleData..::.Data Property
ConstrainedDoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedDoubleData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Data { get; set; }

See Also

ConstrainedDoubleData Class
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Class

ConstrainedDoubleDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedDoubleDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedDoubleDataView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ConstrainedDoubleDataView

See Also

ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Members

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView Members
ConstrainedDoubleDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedDoubleDataView type exposes the following members.

Constructors

Name | Description
ConstrainedDoubleDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedDoubleData |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Constructor

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView Constructor
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConstrainedDoubleDataView()()() |
ConstrainedDoubleDataView(ConstrainedDoubleData) |

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Constructor

ConstrainedDoubleDataView Constructor
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedDoubleDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedDoubleDataView()

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Overload
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Constructor (ConstrainedDoubleData)

ConstrainedDoubleDataView Constructor (ConstrainedDoubleData)
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedDoubleDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedDoubleDataView(
    ConstrainedDoubleData constraintDoubleData
)

Parameters

constraintDoubleData
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "constraintDoubleData"]

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Overload
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Methods

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView Methods
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedDoubleDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.AccessibilityNotifyClients Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


AddItemEvents Method

ConstrainedDoubleDataView..::.AddItemEvents Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleDataView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.BeginInvoke Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.Dispose Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

ConstrainedDoubleDataView..::.Dispose Method (Boolean)
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ConstrainedDoubleDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.GetChildAtPoint Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.Invalidate Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.Invoke Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.MemberwiseClone Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.PerformLayout Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

ConstrainedDoubleDataView..::.RemoveItemEvents Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleDataView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.ResumeLayout Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.RtlTranslateAlignment Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.Scale Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.Select Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.SetBounds Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.UpdateBounds Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


UpdateControls Method

ConstrainedDoubleDataView..::.UpdateControls Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedDoubleDataView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.Validate Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView..::.ValidateChildren Method
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ConstrainedDoubleDataView Class
ConstrainedDoubleDataView Members
HeuristicLab.Data Namespace


ConstrainedDoubleDataView Properties

[image]

HeuristicLab API Documentation
ConstrainedDoubleDataView Properties
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedDoubleDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedDoubleData |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


ConstrainedDoubleData Property

ConstrainedDoubleDataView..::.ConstrainedDoubleData Property
ConstrainedDoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedDoubleDataView.ConstrainedDoubleData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedDoubleData ConstrainedDoubleData { get; set; }

See Also

ConstrainedDoubleDataView Class
HeuristicLab.Data Namespace


ConstrainedIntData Class

ConstrainedIntData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedIntData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedIntData : ConstrainedObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Data..::.ConstrainedObjectData
HeuristicLab.Data..::.ConstrainedIntData

See Also

ConstrainedIntData Members
HeuristicLab.Data Namespace


ConstrainedIntData Members

[image]

HeuristicLab API Documentation
ConstrainedIntData Members
ConstrainedIntData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedIntData type exposes the following members.

Constructors

Name | Description
ConstrainedIntData | Overloaded.

Methods

Name | Description
Accept | (Overrides ConstrainedObjectData ..::. Accept(IObjectDataVisitor).)
AddConstraint | (Inherited from ConstrainedItemBase.)
Clone | Overloaded.
CompareTo | (Inherited from ConstrainedObjectData.)
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Inherited from ConstrainedObjectData.)
TrySetData | Overloaded.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


ConstrainedIntData Constructor

[image]

HeuristicLab API Documentation
ConstrainedIntData Constructor
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConstrainedIntData()()() |
ConstrainedIntData(Int32) |

See Also

ConstrainedIntData Class
ConstrainedIntData Members
HeuristicLab.Data Namespace


ConstrainedIntData Constructor

ConstrainedIntData Constructor
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedIntData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedIntData()

See Also

ConstrainedIntData Class
ConstrainedIntData Overload
HeuristicLab.Data Namespace


ConstrainedIntData Constructor (Int32)

ConstrainedIntData Constructor (Int32)
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedIntData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedIntData(
    int data
)

Parameters

data
Type: System..::.Int32

[Missing <param> documentation for "data"]

See Also

ConstrainedIntData Class
ConstrainedIntData Overload
HeuristicLab.Data Namespace


ConstrainedIntData Methods

[image]

HeuristicLab API Documentation
ConstrainedIntData Methods
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedIntData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ConstrainedObjectData ..::. Accept(IObjectDataVisitor).)
AddConstraint | (Inherited from ConstrainedItemBase.)
Clone | Overloaded.
CompareTo | (Inherited from ConstrainedObjectData.)
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Inherited from ConstrainedObjectData.)
TrySetData | Overloaded.

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


Accept Method

ConstrainedIntData..::.Accept Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConstrainedIntData..::.Clone Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ConstrainedObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ConstrainedIntData Class
ConstrainedIntData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

ConstrainedIntData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedIntData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ConstrainedIntData Class
Clone Overload
HeuristicLab.Data Namespace


CreateView Method

ConstrainedIntData..::.CreateView Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedIntData.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


GetXmlNode Method

ConstrainedIntData..::.GetXmlNode Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedIntData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConstrainedIntData..::.IsValid Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedIntData Class
ConstrainedIntData Members
HeuristicLab.Data Namespace


Populate Method

ConstrainedIntData..::.Populate Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


TrySetData Method

[image]

HeuristicLab API Documentation
ConstrainedIntData..::.TrySetData Method
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TrySetData(Int32) |
TrySetData(Object) | (Inherited from ConstrainedObjectData.)
TrySetData(Int32, ICollection<(Of <(IConstraint>)>)%) |
TrySetData(Object, ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedObjectData.)

See Also

ConstrainedIntData Class
ConstrainedIntData Members
HeuristicLab.Data Namespace


TrySetData Method (Int32)

ConstrainedIntData..::.TrySetData Method (Int32)
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.TrySetData(System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TrySetData(
    int data
)

Parameters

data
Type: System..::.Int32

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedIntData.TrySetData(System.Int32)]

See Also

ConstrainedIntData Class
TrySetData Overload
HeuristicLab.Data Namespace


TrySetData Method (Int32, ICollection(IConstraint) )

ConstrainedIntData..::.TrySetData Method (Int32, ICollection<(Of <(IConstraint>)>) %)
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntData.TrySetData(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TrySetData(
    int data,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

data
Type: System..::.Int32

[Missing <param> documentation for "data"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedIntData.TrySetData(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedIntData Class
TrySetData Overload
HeuristicLab.Data Namespace


ConstrainedIntData Properties

[image]

HeuristicLab API Documentation
ConstrainedIntData Properties
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedIntData type exposes the following members.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Data |
Guid | (Inherited from StorableBase.)

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


Data Property

ConstrainedIntData..::.Data Property
ConstrainedIntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedIntData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Data { get; set; }

See Also

ConstrainedIntData Class
HeuristicLab.Data Namespace


ConstrainedIntDataView Class

ConstrainedIntDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedIntDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedIntDataView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ConstrainedIntDataView

See Also

ConstrainedIntDataView Members
HeuristicLab.Data Namespace


ConstrainedIntDataView Members

[image]

HeuristicLab API Documentation
ConstrainedIntDataView Members
ConstrainedIntDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedIntDataView type exposes the following members.

Constructors

Name | Description
ConstrainedIntDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedIntData |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


ConstrainedIntDataView Constructor

[image]

HeuristicLab API Documentation
ConstrainedIntDataView Constructor
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConstrainedIntDataView()()() |
ConstrainedIntDataView(ConstrainedIntData) |

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


ConstrainedIntDataView Constructor

ConstrainedIntDataView Constructor
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedIntDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedIntDataView()

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Overload
HeuristicLab.Data Namespace


ConstrainedIntDataView Constructor (ConstrainedIntData)

ConstrainedIntDataView Constructor (ConstrainedIntData)
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedIntDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedIntDataView(
    ConstrainedIntData constraintIntData
)

Parameters

constraintIntData
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "constraintIntData"]

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Overload
HeuristicLab.Data Namespace


ConstrainedIntDataView Methods

[image]

HeuristicLab API Documentation
ConstrainedIntDataView Methods
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedIntDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.AccessibilityNotifyClients Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


AddItemEvents Method

ConstrainedIntDataView..::.AddItemEvents Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntDataView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.BeginInvoke Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.Dispose Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

ConstrainedIntDataView..::.Dispose Method (Boolean)
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ConstrainedIntDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.GetChildAtPoint Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.Invalidate Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.Invoke Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.MemberwiseClone Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.PerformLayout Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

ConstrainedIntDataView..::.RemoveItemEvents Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntDataView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.ResumeLayout Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.RtlTranslateAlignment Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.Scale Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.Select Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.SetBounds Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.UpdateBounds Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


UpdateControls Method

ConstrainedIntDataView..::.UpdateControls Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedIntDataView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.Validate Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ConstrainedIntDataView..::.ValidateChildren Method
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ConstrainedIntDataView Class
ConstrainedIntDataView Members
HeuristicLab.Data Namespace


ConstrainedIntDataView Properties

[image]

HeuristicLab API Documentation
ConstrainedIntDataView Properties
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedIntDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedIntData |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


ConstrainedIntData Property

ConstrainedIntDataView..::.ConstrainedIntData Property
ConstrainedIntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedIntDataView.ConstrainedIntData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedIntData ConstrainedIntData { get; set; }

See Also

ConstrainedIntDataView Class
HeuristicLab.Data Namespace


ConstrainedItemList Class

ConstrainedItemList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedItemList]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedItemList : ConstrainedItemBase, IEnumerable<IItem>,
    IEnumerable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Data..::.ConstrainedItemList

See Also

ConstrainedItemList Members
HeuristicLab.Data Namespace


ConstrainedItemList Members

[image]

HeuristicLab API Documentation
ConstrainedItemList Members
ConstrainedItemList Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemList type exposes the following members.

Constructors

Name | Description
ConstrainedItemList |

Methods

Name | Description
AddConstraint | (Inherited from ConstrainedItemBase.)
BeginCombinedOperation |
Clear |
Clone | Overloaded.
Contains |
CopyTo |
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
EndCombinedOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IndexOf |
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnCleared |
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnItemAdded |
OnItemRemoved |
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Overrides ItemBase ..::. ToString()()().)
TryAdd |
TryInsert |
TryRemove |
TryRemoveAt |
TrySetAt |

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Count |
Guid | (Inherited from StorableBase.)
IsReadOnly |
Item |

Events

Name | Description
Changed | (Inherited from ItemBase.)
Cleared |
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
ItemAdded |
ItemRemoved |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ConstrainedItemList Constructor

ConstrainedItemList Constructor
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedItemList class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedItemList()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ConstrainedItemList Methods

[image]

HeuristicLab API Documentation
ConstrainedItemList Methods
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemList type exposes the following members.

Methods

Name | Description
AddConstraint | (Inherited from ConstrainedItemBase.)
BeginCombinedOperation |
Clear |
Clone | Overloaded.
Contains |
CopyTo |
CreateView | (Overrides ConstrainedItemBase ..::. CreateView()()().)
EndCombinedOperation |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides ConstrainedItemBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IndexOf |
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnCleared |
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnItemAdded |
OnItemRemoved |
Populate | (Overrides ConstrainedItemBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Overrides ItemBase ..::. ToString()()().)
TryAdd |
TryInsert |
TryRemove |
TryRemoveAt |
TrySetAt |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


BeginCombinedOperation Method

ConstrainedItemList..::.BeginCombinedOperation Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.BeginCombinedOperation]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void BeginCombinedOperation()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


Clear Method

ConstrainedItemList..::.Clear Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.Clear]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Clear()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConstrainedItemList..::.Clone Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ConstrainedItemBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ConstrainedItemList Class
ConstrainedItemList Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

ConstrainedItemList..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ConstrainedItemList Class
Clone Overload
HeuristicLab.Data Namespace


Contains Method

ConstrainedItemList..::.Contains Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.Contains(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Contains(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.Contains(HeuristicLab.Core.IItem)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


CopyTo Method

ConstrainedItemList..::.CopyTo Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.CopyTo(HeuristicLab.Core.IItem[],System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void CopyTo(
    IItem[] array,
    int arrayIndex
)

Parameters

array
Type: array< HeuristicLab.Core..::.IItem >[]()[]

[Missing <param> documentation for "array"]

arrayIndex
Type: System..::.Int32

[Missing <param> documentation for "arrayIndex"]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


CreateView Method

ConstrainedItemList..::.CreateView Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


EndCombinedOperation Method

ConstrainedItemList..::.EndCombinedOperation Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.EndCombinedOperation(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool EndCombinedOperation(
    out ICollection<IConstraint> violatedConstraints
)

Parameters

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.EndCombinedOperation(System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


GetEnumerator Method

ConstrainedItemList..::.GetEnumerator Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.GetEnumerator]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEnumerator<IItem> GetEnumerator()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.GetEnumerator]

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


IEnumerable.GetEnumerator Method

ConstrainedItemList..::.IEnumerable..::.GetEnumerator Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.System#Collections#IEnumerable#GetEnumerator]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.System#Collections#IEnumerable#GetEnumerator]

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


GetXmlNode Method

ConstrainedItemList..::.GetXmlNode Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


IndexOf Method

ConstrainedItemList..::.IndexOf Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.IndexOf(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int IndexOf(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.IndexOf(HeuristicLab.Core.IItem)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConstrainedItemList..::.IsValid Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedItemList Class
ConstrainedItemList Members
HeuristicLab.Data Namespace


OnCleared Method

ConstrainedItemList..::.OnCleared Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.OnCleared]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnCleared()

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


OnItemAdded Method

ConstrainedItemList..::.OnItemAdded Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.OnItemAdded(HeuristicLab.Core.IItem,System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemAdded(
    IItem item,
    int index
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


OnItemRemoved Method

ConstrainedItemList..::.OnItemRemoved Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.OnItemRemoved(HeuristicLab.Core.IItem,System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemRemoved(
    IItem item,
    int index
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


Populate Method

ConstrainedItemList..::.Populate Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ToString Method

ConstrainedItemList..::.ToString Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.ToString]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


TryAdd Method

ConstrainedItemList..::.TryAdd Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryAdd(HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool TryAdd(
    IItem item,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryAdd(HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


TryInsert Method

ConstrainedItemList..::.TryInsert Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryInsert(System.Int32,HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool TryInsert(
    int index,
    IItem item,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryInsert(System.Int32,HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


TryRemove Method

ConstrainedItemList..::.TryRemove Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryRemove(HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool TryRemove(
    IItem item,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryRemove(HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


TryRemoveAt Method

ConstrainedItemList..::.TryRemoveAt Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryRemoveAt(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool TryRemoveAt(
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.TryRemoveAt(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


TrySetAt Method

ConstrainedItemList..::.TrySetAt Method
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemList.TrySetAt(System.Int32,HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool TrySetAt(
    int index,
    IItem item,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedItemList.TrySetAt(System.Int32,HeuristicLab.Core.IItem,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ConstrainedItemList Properties

[image]

HeuristicLab API Documentation
ConstrainedItemList Properties
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemList type exposes the following members.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Count |
Guid | (Inherited from StorableBase.)
IsReadOnly |
Item |

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


Count Property

ConstrainedItemList..::.Count Property
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedItemList.Count]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Count { get; }

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


IsReadOnly Property

ConstrainedItemList..::.IsReadOnly Property
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedItemList.IsReadOnly]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsReadOnly { get; }

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


Item Property

ConstrainedItemList..::.Item Property
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedItemList.Item(System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem this[
    int index
] { get; }

Parameters

index
Type: System..::.Int32

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ConstrainedItemList Events

[image]

HeuristicLab API Documentation
ConstrainedItemList Events
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemList type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
Cleared |
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
ItemAdded |
ItemRemoved |

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


Cleared Event

ConstrainedItemList..::.Cleared Event
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ConstrainedItemList.Cleared]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Cleared

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ItemAdded Event

ConstrainedItemList..::.ItemAdded Event
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ConstrainedItemList.ItemAdded]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ItemIndexEventArgs> ItemAdded

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ItemRemoved Event

ConstrainedItemList..::.ItemRemoved Event
ConstrainedItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ConstrainedItemList.ItemRemoved]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ItemIndexEventArgs> ItemRemoved

See Also

ConstrainedItemList Class
HeuristicLab.Data Namespace


ConstrainedItemListView Class

ConstrainedItemListView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedItemListView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedItemListView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ConstrainedItemListView

See Also

ConstrainedItemListView Members
HeuristicLab.Data Namespace


ConstrainedItemListView Members

[image]

HeuristicLab API Documentation
ConstrainedItemListView Members
ConstrainedItemListView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemListView type exposes the following members.

Constructors

Name | Description
ConstrainedItemListView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedItemList |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


ConstrainedItemListView Constructor

[image]

HeuristicLab API Documentation
ConstrainedItemListView Constructor
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConstrainedItemListView()()() |
ConstrainedItemListView(ConstrainedItemList) |

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


ConstrainedItemListView Constructor

ConstrainedItemListView Constructor
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedItemListView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedItemListView()

See Also

ConstrainedItemListView Class
ConstrainedItemListView Overload
HeuristicLab.Data Namespace


ConstrainedItemListView Constructor (ConstrainedItemList)

ConstrainedItemListView Constructor (ConstrainedItemList)
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedItemListView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedItemListView(
    ConstrainedItemList constrainedItemList
)

Parameters

constrainedItemList
Type: HeuristicLab.Data..::.ConstrainedItemList

[Missing <param> documentation for "constrainedItemList"]

See Also

ConstrainedItemListView Class
ConstrainedItemListView Overload
HeuristicLab.Data Namespace


ConstrainedItemListView Methods

[image]

HeuristicLab API Documentation
ConstrainedItemListView Methods
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemListView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.AccessibilityNotifyClients Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


AddItemEvents Method

ConstrainedItemListView..::.AddItemEvents Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemListView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.BeginInvoke Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.Dispose Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

ConstrainedItemListView..::.Dispose Method (Boolean)
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ConstrainedItemListView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.GetChildAtPoint Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.Invalidate Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.Invoke Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.MemberwiseClone Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.PerformLayout Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

ConstrainedItemListView..::.RemoveItemEvents Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemListView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.ResumeLayout Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.RtlTranslateAlignment Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.Scale Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.Select Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.SetBounds Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.UpdateBounds Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


UpdateControls Method

ConstrainedItemListView..::.UpdateControls Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedItemListView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.Validate Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ConstrainedItemListView..::.ValidateChildren Method
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ConstrainedItemListView Class
ConstrainedItemListView Members
HeuristicLab.Data Namespace


ConstrainedItemListView Properties

[image]

HeuristicLab API Documentation
ConstrainedItemListView Properties
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedItemListView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
ConstrainedItemList |
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


ConstrainedItemList Property

ConstrainedItemListView..::.ConstrainedItemList Property
ConstrainedItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedItemListView.ConstrainedItemList]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedItemList ConstrainedItemList { get; set; }

See Also

ConstrainedItemListView Class
HeuristicLab.Data Namespace


ConstrainedObjectData Class

ConstrainedObjectData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ConstrainedObjectData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConstrainedObjectData : ConstrainedItemBase, IObjectData,
    IItem, IStorable, IViewable, IComparable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Data..::.ConstrainedObjectData
HeuristicLab.Data..::.ConstrainedIntData
HeuristicLab.Data..::.ConstrainedDoubleData

See Also

ConstrainedObjectData Members
HeuristicLab.Data Namespace


ConstrainedObjectData Members

[image]

HeuristicLab API Documentation
ConstrainedObjectData Members
ConstrainedObjectData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedObjectData type exposes the following members.

Constructors

Name | Description
ConstrainedObjectData |

Methods

Name | Description
Accept |
AddConstraint | (Inherited from ConstrainedItemBase.)
Clone | Overloaded.
CompareTo |
CreateView | (Inherited from ConstrainedItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from ConstrainedItemBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
Populate | (Inherited from ConstrainedItemBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Overrides ItemBase ..::. ToString()()().)
TrySetData | Overloaded.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


ConstrainedObjectData Constructor

ConstrainedObjectData Constructor
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConstrainedObjectData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedObjectData()

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


ConstrainedObjectData Methods

[image]

HeuristicLab API Documentation
ConstrainedObjectData Methods
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedObjectData type exposes the following members.

Methods

Name | Description
Accept |
AddConstraint | (Inherited from ConstrainedItemBase.)
Clone | Overloaded.
CompareTo |
CreateView | (Inherited from ConstrainedItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from ConstrainedItemBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
Populate | (Inherited from ConstrainedItemBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
ToString | (Overrides ItemBase ..::. ToString()()().)
TrySetData | Overloaded.

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


Accept Method

ConstrainedObjectData..::.Accept Method
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedObjectData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConstrainedObjectData..::.Clone Method
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ConstrainedItemBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ConstrainedObjectData Class
ConstrainedObjectData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

ConstrainedObjectData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedObjectData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedObjectData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ConstrainedObjectData Class
Clone Overload
HeuristicLab.Data Namespace


CompareTo Method

ConstrainedObjectData..::.CompareTo Method
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedObjectData.CompareTo(System.Object)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedObjectData.CompareTo(System.Object)]

Implements

IComparable..::.CompareTo(Object)

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConstrainedObjectData..::.IsValid Method
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ConstrainedObjectData Class
ConstrainedObjectData Members
HeuristicLab.Data Namespace


ToString Method

ConstrainedObjectData..::.ToString Method
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedObjectData.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedObjectData.ToString]

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


TrySetData Method

[image]

HeuristicLab API Documentation
ConstrainedObjectData..::.TrySetData Method
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TrySetData(Object) |
TrySetData(Object, ICollection<(Of <(IConstraint>)>)%) |

See Also

ConstrainedObjectData Class
ConstrainedObjectData Members
HeuristicLab.Data Namespace


TrySetData Method (Object)

ConstrainedObjectData..::.TrySetData Method (Object)
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedObjectData.TrySetData(System.Object)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TrySetData(
    Object data
)

Parameters

data
Type: System..::.Object

[Missing <param> documentation for "data"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedObjectData.TrySetData(System.Object)]

See Also

ConstrainedObjectData Class
TrySetData Overload
HeuristicLab.Data Namespace


TrySetData Method (Object, ICollection(IConstraint) )

ConstrainedObjectData..::.TrySetData Method (Object, ICollection<(Of <(IConstraint>)>) %)
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ConstrainedObjectData.TrySetData(System.Object,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual bool TrySetData(
    Object data,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

data
Type: System..::.Object

[Missing <param> documentation for "data"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ConstrainedObjectData.TrySetData(System.Object,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

See Also

ConstrainedObjectData Class
TrySetData Overload
HeuristicLab.Data Namespace


ConstrainedObjectData Properties

[image]

HeuristicLab API Documentation
ConstrainedObjectData Properties
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConstrainedObjectData type exposes the following members.

Properties

Name | Description
Constraints | (Inherited from ConstrainedItemBase.)
Data |
Guid | (Inherited from StorableBase.)

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


Data Property

ConstrainedObjectData..::.Data Property
ConstrainedObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ConstrainedObjectData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Object Data { get; set; }

Implements

IObjectData..::.Data

See Also

ConstrainedObjectData Class
HeuristicLab.Data Namespace


DoubleArrayData Class

DoubleArrayData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.DoubleArrayData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleArrayData : ArrayDataBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.DoubleArrayData

See Also

DoubleArrayData Members
HeuristicLab.Data Namespace


DoubleArrayData Members

[image]

HeuristicLab API Documentation
DoubleArrayData Members
DoubleArrayData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleArrayData type exposes the following members.

Constructors

Name | Description
DoubleArrayData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ArrayDataBase.)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


DoubleArrayData Constructor

[image]

HeuristicLab API Documentation
DoubleArrayData Constructor
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleArrayData()()() |
DoubleArrayData(array<Double>[]()[]) |

See Also

DoubleArrayData Class
DoubleArrayData Members
HeuristicLab.Data Namespace


DoubleArrayData Constructor

DoubleArrayData Constructor
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleArrayData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleArrayData()

See Also

DoubleArrayData Class
DoubleArrayData Overload
HeuristicLab.Data Namespace


DoubleArrayData Constructor (Double[])

DoubleArrayData Constructor (array<Double>[]()[])
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleArrayData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleArrayData(
    double[] data
)

Parameters

data
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "data"]

See Also

DoubleArrayData Class
DoubleArrayData Overload
HeuristicLab.Data Namespace


DoubleArrayData Methods

[image]

HeuristicLab API Documentation
DoubleArrayData Methods
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleArrayData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ArrayDataBase.)

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


Accept Method

DoubleArrayData..::.Accept Method
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleArrayData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
DoubleArrayData..::.Clone Method
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

DoubleArrayData Class
DoubleArrayData Members
HeuristicLab.Data Namespace


CreateView Method

DoubleArrayData..::.CreateView Method
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleArrayData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleArrayData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


GetXmlNode Method

DoubleArrayData..::.GetXmlNode Method
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleArrayData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleArrayData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


Populate Method

DoubleArrayData..::.Populate Method
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleArrayData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


DoubleArrayData Properties

[image]

HeuristicLab API Documentation
DoubleArrayData Properties
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleArrayData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


Data Property

DoubleArrayData..::.Data Property
DoubleArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.DoubleArrayData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double[] Data { get; set; }

See Also

DoubleArrayData Class
HeuristicLab.Data Namespace


DoubleArrayDataView Class

DoubleArrayDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.DoubleArrayDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleArrayDataView : ArrayDataBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ArrayDataBaseView
HeuristicLab.Data..::.DoubleArrayDataView

See Also

DoubleArrayDataView Members
HeuristicLab.Data Namespace


DoubleArrayDataView Members

[image]

HeuristicLab API Documentation
DoubleArrayDataView Members
DoubleArrayDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleArrayDataView type exposes the following members.

Constructors

Name | Description
DoubleArrayDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ArrayDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ArrayDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides ArrayDataBaseView ..::. SetArrayElement(Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ArrayDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides ArrayDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from ArrayDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleArrayData |
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DoubleArrayDataView Class
HeuristicLab.Data Namespace


DoubleArrayDataView Constructor

[image]

HeuristicLab API Documentation
DoubleArrayDataView Constructor
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleArrayDataView()()() |
DoubleArrayDataView(DoubleArrayData) |

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


DoubleArrayDataView Constructor

DoubleArrayDataView Constructor
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleArrayDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleArrayDataView()

See Also

DoubleArrayDataView Class
DoubleArrayDataView Overload
HeuristicLab.Data Namespace


DoubleArrayDataView Constructor (DoubleArrayData)

DoubleArrayDataView Constructor (DoubleArrayData)
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleArrayDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleArrayDataView(
    DoubleArrayData doubleArrayData
)

Parameters

doubleArrayData
Type: HeuristicLab.Data..::.DoubleArrayData

[Missing <param> documentation for "doubleArrayData"]

See Also

DoubleArrayDataView Class
DoubleArrayDataView Overload
HeuristicLab.Data Namespace


DoubleArrayDataView Methods

[image]

HeuristicLab API Documentation
DoubleArrayDataView Methods
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleArrayDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ArrayDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ArrayDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides ArrayDataBaseView ..::. SetArrayElement(Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ArrayDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides ArrayDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

See Also

DoubleArrayDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.AccessibilityNotifyClients Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.BeginInvoke Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.Dispose Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ArrayDataBaseView ..::. Dispose(Boolean).)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

DoubleArrayDataView..::.Dispose Method (Boolean)
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DoubleArrayDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.GetChildAtPoint Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.Invalidate Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.Invoke Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.MemberwiseClone Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.PerformLayout Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.ResumeLayout Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.RtlTranslateAlignment Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.Scale Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.Select Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


SetArrayElement Method

DoubleArrayDataView..::.SetArrayElement Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleArrayDataView.SetArrayElement(System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void SetArrayElement(
    int index,
    string element
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

DoubleArrayDataView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.SetBounds Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.UpdateBounds Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.Validate Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DoubleArrayDataView..::.ValidateChildren Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DoubleArrayDataView Class
DoubleArrayDataView Members
HeuristicLab.Data Namespace


ValidateData Method

DoubleArrayDataView..::.ValidateData Method
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleArrayDataView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleArrayDataView.ValidateData(System.String)]

See Also

DoubleArrayDataView Class
HeuristicLab.Data Namespace


DoubleArrayDataView Properties

[image]

HeuristicLab API Documentation
DoubleArrayDataView Properties
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleArrayDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from ArrayDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleArrayData |
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DoubleArrayDataView Class
HeuristicLab.Data Namespace


DoubleArrayData Property

DoubleArrayDataView..::.DoubleArrayData Property
DoubleArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.DoubleArrayDataView.DoubleArrayData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleArrayData DoubleArrayData { get; set; }

See Also

DoubleArrayDataView Class
HeuristicLab.Data Namespace


DoubleData Class

DoubleData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.DoubleData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleData : ObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.DoubleData

See Also

DoubleData Members
HeuristicLab.Data Namespace


DoubleData Members

[image]

HeuristicLab API Documentation
DoubleData Members
DoubleData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleData type exposes the following members.

Constructors

Name | Description
DoubleData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ObjectData.)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

DoubleData Class
HeuristicLab.Data Namespace


DoubleData Constructor

[image]

HeuristicLab API Documentation
DoubleData Constructor
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleData()()() |
DoubleData(Double) |

See Also

DoubleData Class
DoubleData Members
HeuristicLab.Data Namespace


DoubleData Constructor

DoubleData Constructor
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleData()

See Also

DoubleData Class
DoubleData Overload
HeuristicLab.Data Namespace


DoubleData Constructor (Double)

DoubleData Constructor (Double)
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleData(
    double data
)

Parameters

data
Type: System..::.Double

[Missing <param> documentation for "data"]

See Also

DoubleData Class
DoubleData Overload
HeuristicLab.Data Namespace


DoubleData Methods

[image]

HeuristicLab API Documentation
DoubleData Methods
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ObjectData.)

See Also

DoubleData Class
HeuristicLab.Data Namespace


Accept Method

DoubleData..::.Accept Method
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

DoubleData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
DoubleData..::.Clone Method
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

DoubleData Class
DoubleData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

DoubleData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

DoubleData Class
Clone Overload
HeuristicLab.Data Namespace


CreateView Method

DoubleData..::.CreateView Method
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

DoubleData Class
HeuristicLab.Data Namespace


GetXmlNode Method

DoubleData..::.GetXmlNode Method
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleData Class
HeuristicLab.Data Namespace


Populate Method

DoubleData..::.Populate Method
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleData Class
HeuristicLab.Data Namespace


DoubleData Properties

[image]

HeuristicLab API Documentation
DoubleData Properties
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

DoubleData Class
HeuristicLab.Data Namespace


Data Property

DoubleData..::.Data Property
DoubleData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.DoubleData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Data { get; set; }

See Also

DoubleData Class
HeuristicLab.Data Namespace


DoubleDataView Class

DoubleDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.DoubleDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleDataView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.DoubleDataView

See Also

DoubleDataView Members
HeuristicLab.Data Namespace


DoubleDataView Members

[image]

HeuristicLab API Documentation
DoubleDataView Members
DoubleDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleDataView type exposes the following members.

Constructors

Name | Description
DoubleDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DoubleData |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


DoubleDataView Constructor

[image]

HeuristicLab API Documentation
DoubleDataView Constructor
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleDataView()()() |
DoubleDataView(DoubleData) |

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


DoubleDataView Constructor

DoubleDataView Constructor
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleDataView()

See Also

DoubleDataView Class
DoubleDataView Overload
HeuristicLab.Data Namespace


DoubleDataView Constructor (DoubleData)

DoubleDataView Constructor (DoubleData)
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleDataView(
    DoubleData doubleData
)

Parameters

doubleData
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "doubleData"]

See Also

DoubleDataView Class
DoubleDataView Overload
HeuristicLab.Data Namespace


DoubleDataView Methods

[image]

HeuristicLab API Documentation
DoubleDataView Methods
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.AccessibilityNotifyClients Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


AddItemEvents Method

DoubleDataView..::.AddItemEvents Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleDataView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.BeginInvoke Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.Dispose Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

DoubleDataView..::.Dispose Method (Boolean)
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DoubleDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.GetChildAtPoint Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.Invalidate Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.Invoke Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.MemberwiseClone Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.PerformLayout Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

DoubleDataView..::.RemoveItemEvents Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleDataView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.ResumeLayout Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.RtlTranslateAlignment Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.Scale Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.Select Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.SetBounds Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.UpdateBounds Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


UpdateControls Method

DoubleDataView..::.UpdateControls Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleDataView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.Validate Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DoubleDataView..::.ValidateChildren Method
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DoubleDataView Class
DoubleDataView Members
HeuristicLab.Data Namespace


DoubleDataView Properties

[image]

HeuristicLab API Documentation
DoubleDataView Properties
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DoubleData |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


DoubleData Property

DoubleDataView..::.DoubleData Property
DoubleDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.DoubleDataView.DoubleData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleData DoubleData { get; set; }

See Also

DoubleDataView Class
HeuristicLab.Data Namespace


DoubleMatrixData Class

DoubleMatrixData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.DoubleMatrixData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleMatrixData : ArrayDataBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.DoubleMatrixData

See Also

DoubleMatrixData Members
HeuristicLab.Data Namespace


DoubleMatrixData Members

[image]

HeuristicLab API Documentation
DoubleMatrixData Members
DoubleMatrixData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleMatrixData type exposes the following members.

Constructors

Name | Description
DoubleMatrixData | Overloaded.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ArrayDataBase ..::. ToString()()().)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


DoubleMatrixData Constructor

[image]

HeuristicLab API Documentation
DoubleMatrixData Constructor
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleMatrixData()()() |
DoubleMatrixData(array<Double,2>[,](,)[,]) |

See Also

DoubleMatrixData Class
DoubleMatrixData Members
HeuristicLab.Data Namespace


DoubleMatrixData Constructor

DoubleMatrixData Constructor
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleMatrixData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleMatrixData()

See Also

DoubleMatrixData Class
DoubleMatrixData Overload
HeuristicLab.Data Namespace


DoubleMatrixData Constructor (Double[,])

DoubleMatrixData Constructor (array<Double,2>[,](,)[,])
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleMatrixData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleMatrixData(
    double[,] data
)

Parameters

data
Type: array< System..::.Double ,2>[,](,)[,]

[Missing <param> documentation for "data"]

See Also

DoubleMatrixData Class
DoubleMatrixData Overload
HeuristicLab.Data Namespace


DoubleMatrixData Methods

[image]

HeuristicLab API Documentation
DoubleMatrixData Methods
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleMatrixData type exposes the following members.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ArrayDataBase ..::. ToString()()().)

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
DoubleMatrixData..::.Clone Method
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

DoubleMatrixData Class
DoubleMatrixData Members
HeuristicLab.Data Namespace


CreateView Method

DoubleMatrixData..::.CreateView Method
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleMatrixData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleMatrixData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


GetXmlNode Method

DoubleMatrixData..::.GetXmlNode Method
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleMatrixData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleMatrixData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


Populate Method

DoubleMatrixData..::.Populate Method
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleMatrixData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


ToString Method

DoubleMatrixData..::.ToString Method
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleMatrixData.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleMatrixData.ToString]

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


DoubleMatrixData Properties

[image]

HeuristicLab API Documentation
DoubleMatrixData Properties
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleMatrixData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


Data Property

DoubleMatrixData..::.Data Property
DoubleMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.DoubleMatrixData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double[,] Data { get; set; }

See Also

DoubleMatrixData Class
HeuristicLab.Data Namespace


DoubleMatrixDataView Class

DoubleMatrixDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.DoubleMatrixDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DoubleMatrixDataView : MatrixDataBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.MatrixDataBaseView
HeuristicLab.Data..::.DoubleMatrixDataView

See Also

DoubleMatrixDataView Members
HeuristicLab.Data Namespace


DoubleMatrixDataView Members

[image]

HeuristicLab API Documentation
DoubleMatrixDataView Members
DoubleMatrixDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleMatrixDataView type exposes the following members.

Constructors

Name | Description
DoubleMatrixDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from MatrixDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from MatrixDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides MatrixDataBaseView ..::. SetArrayElement(Int32, Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from MatrixDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides MatrixDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from MatrixDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DoubleMatrixData |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
HeuristicLab.Data Namespace


DoubleMatrixDataView Constructor

[image]

HeuristicLab API Documentation
DoubleMatrixDataView Constructor
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DoubleMatrixDataView()()() |
DoubleMatrixDataView(DoubleMatrixData) |

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


DoubleMatrixDataView Constructor

DoubleMatrixDataView Constructor
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleMatrixDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleMatrixDataView()

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Overload
HeuristicLab.Data Namespace


DoubleMatrixDataView Constructor (DoubleMatrixData)

DoubleMatrixDataView Constructor (DoubleMatrixData)
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DoubleMatrixDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleMatrixDataView(
    DoubleMatrixData doubleMatrixData
)

Parameters

doubleMatrixData
Type: HeuristicLab.Data..::.DoubleMatrixData

[Missing <param> documentation for "doubleMatrixData"]

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Overload
HeuristicLab.Data Namespace


DoubleMatrixDataView Methods

[image]

HeuristicLab API Documentation
DoubleMatrixDataView Methods
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleMatrixDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from MatrixDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from MatrixDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides MatrixDataBaseView ..::. SetArrayElement(Int32, Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from MatrixDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides MatrixDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

See Also

DoubleMatrixDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.AccessibilityNotifyClients Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.BeginInvoke Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.Dispose Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides MatrixDataBaseView ..::. Dispose(Boolean).)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

DoubleMatrixDataView..::.Dispose Method (Boolean)
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DoubleMatrixDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.GetChildAtPoint Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.Invalidate Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.Invoke Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.MemberwiseClone Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.PerformLayout Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.ResumeLayout Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.RtlTranslateAlignment Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.Scale Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.Select Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


SetArrayElement Method

DoubleMatrixDataView..::.SetArrayElement Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleMatrixDataView.SetArrayElement(System.Int32,System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void SetArrayElement(
    int row,
    int column,
    string element
)

Parameters

row
Type: System..::.Int32

[Missing <param> documentation for "row"]

column
Type: System..::.Int32

[Missing <param> documentation for "column"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

DoubleMatrixDataView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.SetBounds Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.UpdateBounds Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.Validate Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DoubleMatrixDataView..::.ValidateChildren Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DoubleMatrixDataView Class
DoubleMatrixDataView Members
HeuristicLab.Data Namespace


ValidateData Method

DoubleMatrixDataView..::.ValidateData Method
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.DoubleMatrixDataView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.DoubleMatrixDataView.ValidateData(System.String)]

See Also

DoubleMatrixDataView Class
HeuristicLab.Data Namespace


DoubleMatrixDataView Properties

[image]

HeuristicLab API Documentation
DoubleMatrixDataView Properties
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DoubleMatrixDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from MatrixDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
DoubleMatrixData |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DoubleMatrixDataView Class
HeuristicLab.Data Namespace


DoubleMatrixData Property

DoubleMatrixDataView..::.DoubleMatrixData Property
DoubleMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.DoubleMatrixDataView.DoubleMatrixData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleMatrixData DoubleMatrixData { get; set; }

See Also

DoubleMatrixDataView Class
HeuristicLab.Data Namespace


HeuristicLabDataPlugin Class

HeuristicLabDataPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.HeuristicLabDataPlugin]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[PluginFileAttribute(Filename = "HeuristicLab.Data.dll", Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Data")]
public class HeuristicLabDataPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Data..::.HeuristicLabDataPlugin

See Also

HeuristicLabDataPlugin Members
HeuristicLab.Data Namespace


HeuristicLabDataPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabDataPlugin Members
HeuristicLabDataPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabDataPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabDataPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabDataPlugin Class
HeuristicLab.Data Namespace


HeuristicLabDataPlugin Constructor

HeuristicLabDataPlugin Constructor
HeuristicLabDataPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabDataPlugin class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabDataPlugin()

See Also

HeuristicLabDataPlugin Class
HeuristicLab.Data Namespace


IntArrayData Class

IntArrayData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IntArrayData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntArrayData : ArrayDataBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.IntArrayData
HeuristicLab.Permutation..::.Permutation

See Also

IntArrayData Members
HeuristicLab.Data Namespace


IntArrayData Members

[image]

HeuristicLab API Documentation
IntArrayData Members
IntArrayData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntArrayData type exposes the following members.

Constructors

Name | Description
IntArrayData | Overloaded.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ArrayDataBase.)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

IntArrayData Class
HeuristicLab.Data Namespace


IntArrayData Constructor

[image]

HeuristicLab API Documentation
IntArrayData Constructor
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntArrayData()()() |
IntArrayData(array<Int32>[]()[]) |

See Also

IntArrayData Class
IntArrayData Members
HeuristicLab.Data Namespace


IntArrayData Constructor

IntArrayData Constructor
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntArrayData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntArrayData()

See Also

IntArrayData Class
IntArrayData Overload
HeuristicLab.Data Namespace


IntArrayData Constructor (Int32[])

IntArrayData Constructor (array<Int32>[]()[])
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntArrayData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntArrayData(
    int[] data
)

Parameters

data
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "data"]

See Also

IntArrayData Class
IntArrayData Overload
HeuristicLab.Data Namespace


IntArrayData Methods

[image]

HeuristicLab API Documentation
IntArrayData Methods
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntArrayData type exposes the following members.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ArrayDataBase.)

See Also

IntArrayData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
IntArrayData..::.Clone Method
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

IntArrayData Class
IntArrayData Members
HeuristicLab.Data Namespace


CreateView Method

IntArrayData..::.CreateView Method
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntArrayData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntArrayData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

IntArrayData Class
HeuristicLab.Data Namespace


GetXmlNode Method

IntArrayData..::.GetXmlNode Method
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntArrayData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntArrayData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntArrayData Class
HeuristicLab.Data Namespace


Populate Method

IntArrayData..::.Populate Method
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntArrayData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntArrayData Class
HeuristicLab.Data Namespace


IntArrayData Properties

[image]

HeuristicLab API Documentation
IntArrayData Properties
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntArrayData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

IntArrayData Class
HeuristicLab.Data Namespace


Data Property

IntArrayData..::.Data Property
IntArrayData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IntArrayData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int[] Data { get; set; }

See Also

IntArrayData Class
HeuristicLab.Data Namespace


IntArrayDataView Class

IntArrayDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IntArrayDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntArrayDataView : ArrayDataBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ArrayDataBaseView
HeuristicLab.Data..::.IntArrayDataView

See Also

IntArrayDataView Members
HeuristicLab.Data Namespace


IntArrayDataView Members

[image]

HeuristicLab API Documentation
IntArrayDataView Members
IntArrayDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntArrayDataView type exposes the following members.

Constructors

Name | Description
IntArrayDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ArrayDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ArrayDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides ArrayDataBaseView ..::. SetArrayElement(Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ArrayDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides ArrayDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from ArrayDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntArrayData |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

IntArrayDataView Class
HeuristicLab.Data Namespace


IntArrayDataView Constructor

[image]

HeuristicLab API Documentation
IntArrayDataView Constructor
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntArrayDataView()()() |
IntArrayDataView(IntArrayData) |

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


IntArrayDataView Constructor

IntArrayDataView Constructor
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntArrayDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntArrayDataView()

See Also

IntArrayDataView Class
IntArrayDataView Overload
HeuristicLab.Data Namespace


IntArrayDataView Constructor (IntArrayData)

IntArrayDataView Constructor (IntArrayData)
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntArrayDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntArrayDataView(
    IntArrayData intArrayData
)

Parameters

intArrayData
Type: HeuristicLab.Data..::.IntArrayData

[Missing <param> documentation for "intArrayData"]

See Also

IntArrayDataView Class
IntArrayDataView Overload
HeuristicLab.Data Namespace


IntArrayDataView Methods

[image]

HeuristicLab API Documentation
IntArrayDataView Methods
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntArrayDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ArrayDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ArrayDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides ArrayDataBaseView ..::. SetArrayElement(Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from ArrayDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides ArrayDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

See Also

IntArrayDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.AccessibilityNotifyClients Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.BeginInvoke Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.Dispose Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ArrayDataBaseView ..::. Dispose(Boolean).)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

IntArrayDataView..::.Dispose Method (Boolean)
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

IntArrayDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.GetChildAtPoint Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.Invalidate Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.Invoke Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.MemberwiseClone Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.PerformLayout Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.ResumeLayout Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.RtlTranslateAlignment Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.Scale Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.Select Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


SetArrayElement Method

IntArrayDataView..::.SetArrayElement Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntArrayDataView.SetArrayElement(System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void SetArrayElement(
    int index,
    string element
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

IntArrayDataView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.SetBounds Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.UpdateBounds Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.Validate Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
IntArrayDataView..::.ValidateChildren Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

IntArrayDataView Class
IntArrayDataView Members
HeuristicLab.Data Namespace


ValidateData Method

IntArrayDataView..::.ValidateData Method
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntArrayDataView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntArrayDataView.ValidateData(System.String)]

See Also

IntArrayDataView Class
HeuristicLab.Data Namespace


IntArrayDataView Properties

[image]

HeuristicLab API Documentation
IntArrayDataView Properties
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntArrayDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from ArrayDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntArrayData |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

IntArrayDataView Class
HeuristicLab.Data Namespace


IntArrayData Property

IntArrayDataView..::.IntArrayData Property
IntArrayDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IntArrayDataView.IntArrayData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntArrayData IntArrayData { get; set; }

See Also

IntArrayDataView Class
HeuristicLab.Data Namespace


IntData Class

IntData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IntData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntData : ObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.IntData

See Also

IntData Members
HeuristicLab.Data Namespace


IntData Members

[image]

HeuristicLab API Documentation
IntData Members
IntData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntData type exposes the following members.

Constructors

Name | Description
IntData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ObjectData.)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

IntData Class
HeuristicLab.Data Namespace


IntData Constructor

[image]

HeuristicLab API Documentation
IntData Constructor
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntData()()() |
IntData(Int32) |

See Also

IntData Class
IntData Members
HeuristicLab.Data Namespace


IntData Constructor

IntData Constructor
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData()

See Also

IntData Class
IntData Overload
HeuristicLab.Data Namespace


IntData Constructor (Int32)

IntData Constructor (Int32)
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData(
    int data
)

Parameters

data
Type: System..::.Int32

[Missing <param> documentation for "data"]

See Also

IntData Class
IntData Overload
HeuristicLab.Data Namespace


IntData Methods

[image]

HeuristicLab API Documentation
IntData Methods
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ObjectData.)

See Also

IntData Class
HeuristicLab.Data Namespace


Accept Method

IntData..::.Accept Method
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

IntData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
IntData..::.Clone Method
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

IntData Class
IntData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

IntData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

IntData Class
Clone Overload
HeuristicLab.Data Namespace


CreateView Method

IntData..::.CreateView Method
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

IntData Class
HeuristicLab.Data Namespace


GetXmlNode Method

IntData..::.GetXmlNode Method
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntData Class
HeuristicLab.Data Namespace


Populate Method

IntData..::.Populate Method
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntData Class
HeuristicLab.Data Namespace


IntData Properties

[image]

HeuristicLab API Documentation
IntData Properties
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

IntData Class
HeuristicLab.Data Namespace


Data Property

IntData..::.Data Property
IntData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IntData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Data { get; set; }

See Also

IntData Class
HeuristicLab.Data Namespace


IntDataView Class

IntDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IntDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntDataView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.IntDataView

See Also

IntDataView Members
HeuristicLab.Data Namespace


IntDataView Members

[image]

HeuristicLab API Documentation
IntDataView Members
IntDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntDataView type exposes the following members.

Constructors

Name | Description
IntDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntData |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

IntDataView Class
HeuristicLab.Data Namespace


IntDataView Constructor

[image]

HeuristicLab API Documentation
IntDataView Constructor
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntDataView()()() |
IntDataView(IntData) |

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


IntDataView Constructor

IntDataView Constructor
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntDataView()

See Also

IntDataView Class
IntDataView Overload
HeuristicLab.Data Namespace


IntDataView Constructor (IntData)

IntDataView Constructor (IntData)
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntDataView(
    IntData intData
)

Parameters

intData
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "intData"]

See Also

IntDataView Class
IntDataView Overload
HeuristicLab.Data Namespace


IntDataView Methods

[image]

HeuristicLab API Documentation
IntDataView Methods
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

IntDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
IntDataView..::.AccessibilityNotifyClients Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


AddItemEvents Method

IntDataView..::.AddItemEvents Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntDataView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

IntDataView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
IntDataView..::.BeginInvoke Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
IntDataView..::.Dispose Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

IntDataView..::.Dispose Method (Boolean)
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

IntDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
IntDataView..::.GetChildAtPoint Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
IntDataView..::.Invalidate Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
IntDataView..::.Invoke Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
IntDataView..::.MemberwiseClone Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
IntDataView..::.PerformLayout Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

IntDataView..::.RemoveItemEvents Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntDataView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

IntDataView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
IntDataView..::.ResumeLayout Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
IntDataView..::.RtlTranslateAlignment Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
IntDataView..::.Scale Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
IntDataView..::.Select Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
IntDataView..::.SetBounds Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
IntDataView..::.UpdateBounds Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


UpdateControls Method

IntDataView..::.UpdateControls Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntDataView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

IntDataView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
IntDataView..::.Validate Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
IntDataView..::.ValidateChildren Method
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

IntDataView Class
IntDataView Members
HeuristicLab.Data Namespace


IntDataView Properties

[image]

HeuristicLab API Documentation
IntDataView Properties
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntData |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

IntDataView Class
HeuristicLab.Data Namespace


IntData Property

IntDataView..::.IntData Property
IntDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IntDataView.IntData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntData IntData { get; set; }

See Also

IntDataView Class
HeuristicLab.Data Namespace


IntMatrixData Class

IntMatrixData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IntMatrixData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntMatrixData : ArrayDataBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.IntMatrixData

See Also

IntMatrixData Members
HeuristicLab.Data Namespace


IntMatrixData Members

[image]

HeuristicLab API Documentation
IntMatrixData Members
IntMatrixData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntMatrixData type exposes the following members.

Constructors

Name | Description
IntMatrixData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ArrayDataBase ..::. ToString()()().)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


IntMatrixData Constructor

[image]

HeuristicLab API Documentation
IntMatrixData Constructor
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntMatrixData()()() |
IntMatrixData(array<Int32,2>[,](,)[,]) |

See Also

IntMatrixData Class
IntMatrixData Members
HeuristicLab.Data Namespace


IntMatrixData Constructor

IntMatrixData Constructor
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntMatrixData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntMatrixData()

See Also

IntMatrixData Class
IntMatrixData Overload
HeuristicLab.Data Namespace


IntMatrixData Constructor (Int32[,])

IntMatrixData Constructor (array<Int32,2>[,](,)[,])
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntMatrixData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntMatrixData(
    int[,] data
)

Parameters

data
Type: array< System..::.Int32 ,2>[,](,)[,]

[Missing <param> documentation for "data"]

See Also

IntMatrixData Class
IntMatrixData Overload
HeuristicLab.Data Namespace


IntMatrixData Methods

[image]

HeuristicLab API Documentation
IntMatrixData Methods
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntMatrixData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ArrayDataBase ..::. ToString()()().)

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


Accept Method

IntMatrixData..::.Accept Method
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
IntMatrixData..::.Clone Method
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from ObjectData.)

See Also

IntMatrixData Class
IntMatrixData Members
HeuristicLab.Data Namespace


CreateView Method

IntMatrixData..::.CreateView Method
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntMatrixData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


GetXmlNode Method

IntMatrixData..::.GetXmlNode Method
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntMatrixData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


Populate Method

IntMatrixData..::.Populate Method
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


ToString Method

IntMatrixData..::.ToString Method
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixData.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntMatrixData.ToString]

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


IntMatrixData Properties

[image]

HeuristicLab API Documentation
IntMatrixData Properties
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntMatrixData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


Data Property

IntMatrixData..::.Data Property
IntMatrixData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IntMatrixData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int[,] Data { get; set; }

See Also

IntMatrixData Class
HeuristicLab.Data Namespace


IntMatrixDataView Class

IntMatrixDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IntMatrixDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IntMatrixDataView : MatrixDataBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.MatrixDataBaseView
HeuristicLab.Data..::.IntMatrixDataView

See Also

IntMatrixDataView Members
HeuristicLab.Data Namespace


IntMatrixDataView Members

[image]

HeuristicLab API Documentation
IntMatrixDataView Members
IntMatrixDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntMatrixDataView type exposes the following members.

Constructors

Name | Description
IntMatrixDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from MatrixDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from MatrixDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides MatrixDataBaseView ..::. SetArrayElement(Int32, Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from MatrixDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides MatrixDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from MatrixDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntMatrixData |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

IntMatrixDataView Class
HeuristicLab.Data Namespace


IntMatrixDataView Constructor

[image]

HeuristicLab API Documentation
IntMatrixDataView Constructor
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IntMatrixDataView()()() |
IntMatrixDataView(IntMatrixData) |

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


IntMatrixDataView Constructor

IntMatrixDataView Constructor
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntMatrixDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntMatrixDataView()

See Also

IntMatrixDataView Class
IntMatrixDataView Overload
HeuristicLab.Data Namespace


IntMatrixDataView Constructor (IntMatrixData)

IntMatrixDataView Constructor (IntMatrixData)
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IntMatrixDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntMatrixDataView(
    IntMatrixData intMatrixData
)

Parameters

intMatrixData
Type: HeuristicLab.Data..::.IntMatrixData

[Missing <param> documentation for "intMatrixData"]

See Also

IntMatrixDataView Class
IntMatrixDataView Overload
HeuristicLab.Data Namespace


IntMatrixDataView Methods

[image]

HeuristicLab API Documentation
IntMatrixDataView Methods
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntMatrixDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from MatrixDataBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from MatrixDataBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement | (Overrides MatrixDataBaseView ..::. SetArrayElement(Int32, Int32, String).)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from MatrixDataBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData | (Overrides MatrixDataBaseView ..::. ValidateData(String).)
WndProc | (Inherited from UserControl.)

See Also

IntMatrixDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.AccessibilityNotifyClients Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.BeginInvoke Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.Dispose Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides MatrixDataBaseView ..::. Dispose(Boolean).)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

IntMatrixDataView..::.Dispose Method (Boolean)
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

IntMatrixDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.GetChildAtPoint Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.Invalidate Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.Invoke Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.MemberwiseClone Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.PerformLayout Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.ResumeLayout Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.RtlTranslateAlignment Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.Scale Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.Select Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


SetArrayElement Method

IntMatrixDataView..::.SetArrayElement Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixDataView.SetArrayElement(System.Int32,System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void SetArrayElement(
    int row,
    int column,
    string element
)

Parameters

row
Type: System..::.Int32

[Missing <param> documentation for "row"]

column
Type: System..::.Int32

[Missing <param> documentation for "column"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

IntMatrixDataView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.SetBounds Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.UpdateBounds Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.Validate Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
IntMatrixDataView..::.ValidateChildren Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

IntMatrixDataView Class
IntMatrixDataView Members
HeuristicLab.Data Namespace


ValidateData Method

IntMatrixDataView..::.ValidateData Method
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IntMatrixDataView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.IntMatrixDataView.ValidateData(System.String)]

See Also

IntMatrixDataView Class
HeuristicLab.Data Namespace


IntMatrixDataView Properties

[image]

HeuristicLab API Documentation
IntMatrixDataView Properties
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IntMatrixDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase | (Inherited from MatrixDataBaseView.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
IntMatrixData |
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

IntMatrixDataView Class
HeuristicLab.Data Namespace


IntMatrixData Property

IntMatrixDataView..::.IntMatrixData Property
IntMatrixDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IntMatrixDataView.IntMatrixData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IntMatrixData IntMatrixData { get; set; }

See Also

IntMatrixDataView Class
HeuristicLab.Data Namespace


IObjectData Interface

IObjectData Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IObjectData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IObjectData : IItem,
    IStorable, IViewable, IComparable

See Also

IObjectData Members
HeuristicLab.Data Namespace


IObjectData Members

[image]

HeuristicLab API Documentation
IObjectData Members
IObjectData Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IObjectData type exposes the following members.

Methods

Name | Description
Accept |
Clone | Overloaded.
CompareTo | Compares the current instance with another object of the same type. (Inherited from IComparable.)
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

Properties

Name | Description
Data |
Guid | (Inherited from IStorable.)

Events

Name | Description
Changed | (Inherited from IItem.)

See Also

IObjectData Interface
HeuristicLab.Data Namespace


IObjectData Methods

[image]

HeuristicLab API Documentation
IObjectData Methods
IObjectData Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IObjectData type exposes the following members.

Methods

Name | Description
Accept |
Clone | Overloaded.
CompareTo | Compares the current instance with another object of the same type. (Inherited from IComparable.)
CreateView | (Inherited from IViewable.)
FireChanged | (Inherited from IItem.)
GetXmlNode | (Inherited from IStorable.)
Populate | (Inherited from IStorable.)

See Also

IObjectData Interface
HeuristicLab.Data Namespace


Accept Method

IObjectData..::.Accept Method
IObjectData Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

See Also

IObjectData Interface
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
IObjectData..::.Clone Method
IObjectData Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IObjectData Interface
IObjectData Members
HeuristicLab.Data Namespace


IObjectData Properties

[image]

HeuristicLab API Documentation
IObjectData Properties
IObjectData Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IObjectData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from IStorable.)

See Also

IObjectData Interface
HeuristicLab.Data Namespace


Data Property

IObjectData..::.Data Property
IObjectData Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.IObjectData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Object Data { get; set; }

See Also

IObjectData Interface
HeuristicLab.Data Namespace


IObjectDataVisitor Interface

IObjectDataVisitor Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.IObjectDataVisitor]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IObjectDataVisitor

See Also

IObjectDataVisitor Members
HeuristicLab.Data Namespace


IObjectDataVisitor Members

[image]

HeuristicLab API Documentation
IObjectDataVisitor Members
IObjectDataVisitor Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Methods

Name | Description
Visit | Overloaded.

See Also

IObjectDataVisitor Interface
HeuristicLab.Data Namespace


IObjectDataVisitor Methods

[image]

HeuristicLab API Documentation
IObjectDataVisitor Methods
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Methods

Name | Description
Visit | Overloaded.

See Also

IObjectDataVisitor Interface
HeuristicLab.Data Namespace


Visit Method

[image]

HeuristicLab API Documentation
IObjectDataVisitor..::.Visit Method
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Visit(BoolArrayData) |
Visit(BoolData) |
Visit(BoolMatrixData) |
Visit(ConstrainedDoubleData) |
Visit(ConstrainedIntData) |
Visit(ConstrainedObjectData) |
Visit(DoubleArrayData) |
Visit(DoubleData) |
Visit(DoubleMatrixData) |
Visit(IntArrayData) |
Visit(IntData) |
Visit(IntMatrixData) |
Visit(ObjectData) |
Visit(StringData) |

See Also

IObjectDataVisitor Interface
IObjectDataVisitor Members
HeuristicLab.Data Namespace


Visit Method (BoolArrayData)

IObjectDataVisitor..::.Visit Method (BoolArrayData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.BoolArrayData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    BoolArrayData data
)

Parameters

data
Type: HeuristicLab.Data..::.BoolArrayData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (BoolData)

IObjectDataVisitor..::.Visit Method (BoolData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.BoolData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    BoolData data
)

Parameters

data
Type: HeuristicLab.Data..::.BoolData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (BoolMatrixData)

IObjectDataVisitor..::.Visit Method (BoolMatrixData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.BoolMatrixData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    BoolMatrixData data
)

Parameters

data
Type: HeuristicLab.Data..::.BoolMatrixData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ConstrainedDoubleData)

IObjectDataVisitor..::.Visit Method (ConstrainedDoubleData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.ConstrainedDoubleData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    ConstrainedDoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ConstrainedIntData)

IObjectDataVisitor..::.Visit Method (ConstrainedIntData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.ConstrainedIntData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    ConstrainedIntData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ConstrainedObjectData)

IObjectDataVisitor..::.Visit Method (ConstrainedObjectData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.ConstrainedObjectData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    ConstrainedObjectData constrainedObjectData
)

Parameters

constrainedObjectData
Type: HeuristicLab.Data..::.ConstrainedObjectData

[Missing <param> documentation for "constrainedObjectData"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (DoubleArrayData)

IObjectDataVisitor..::.Visit Method (DoubleArrayData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.DoubleArrayData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    DoubleArrayData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleArrayData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (DoubleData)

IObjectDataVisitor..::.Visit Method (DoubleData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.DoubleData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    DoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (DoubleMatrixData)

IObjectDataVisitor..::.Visit Method (DoubleMatrixData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.DoubleMatrixData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    DoubleMatrixData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleMatrixData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (IntArrayData)

IObjectDataVisitor..::.Visit Method (IntArrayData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.IntArrayData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IntArrayData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntArrayData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (IntData)

IObjectDataVisitor..::.Visit Method (IntData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.IntData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IntData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (IntMatrixData)

IObjectDataVisitor..::.Visit Method (IntMatrixData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.IntMatrixData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IntMatrixData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntMatrixData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ObjectData)

IObjectDataVisitor..::.Visit Method (ObjectData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.ObjectData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    ObjectData objectData
)

Parameters

objectData
Type: HeuristicLab.Data..::.ObjectData

[Missing <param> documentation for "objectData"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


Visit Method (StringData)

IObjectDataVisitor..::.Visit Method (StringData)
IObjectDataVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.IObjectDataVisitor.Visit(HeuristicLab.Data.StringData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    StringData data
)

Parameters

data
Type: HeuristicLab.Data..::.StringData

[Missing <param> documentation for "data"]

See Also

IObjectDataVisitor Interface
Visit Overload
HeuristicLab.Data Namespace


ItemList Class

ItemList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ItemList]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemList : ItemBase, IList<IItem>,
    ICollection<IItem>, IEnumerable<IItem>, IEnumerable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ItemList

See Also

ItemList Members
HeuristicLab.Data Namespace


ItemList Members

[image]

HeuristicLab API Documentation
ItemList Members
ItemList Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemList type exposes the following members.

Constructors

Name | Description
ItemList |

Methods

Name | Description
Add |
Clear |
Clone | Overloaded.
Contains |
CopyTo |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IndexOf |
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnCleared |
OnItemAdded |
OnItemRemoved |
OnItemTypeChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
Remove |
RemoveAt |
ToString | (Overrides ItemBase ..::. ToString()()().)

Properties

Name | Description
Count |
Guid | (Inherited from StorableBase.)
IsReadOnly |
Item |
ItemType |

Events

Name | Description
Changed | (Inherited from ItemBase.)
Cleared |
ItemAdded |
ItemRemoved |
ItemTypeChanged |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemList Constructor

ItemList Constructor
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemList class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList()

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemList Methods

[image]

HeuristicLab API Documentation
ItemList Methods
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemList type exposes the following members.

Methods

Name | Description
Add |
Clear |
Clone | Overloaded.
Contains |
CopyTo |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IndexOf |
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnCleared |
OnItemAdded |
OnItemRemoved |
OnItemTypeChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
Remove |
RemoveAt |
ToString | (Overrides ItemBase ..::. ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

ItemList Class
HeuristicLab.Data Namespace


Add Method

ItemList..::.Add Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Add(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Add(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ItemList Class
HeuristicLab.Data Namespace


Clear Method

ItemList..::.Clear Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Clear]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ItemList Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ItemList..::.Clone Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ItemList Class
ItemList Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

ItemList..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ItemList Class
Clone Overload
HeuristicLab.Data Namespace


Contains Method

ItemList..::.Contains Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Contains(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Contains(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.Contains(HeuristicLab.Core.IItem)]

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ItemList Class
HeuristicLab.Data Namespace


CopyTo Method

ItemList..::.CopyTo Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.CopyTo(HeuristicLab.Core.IItem[],System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void CopyTo(
    IItem[] array,
    int arrayIndex
)

Parameters

array
Type: array< HeuristicLab.Core..::.IItem >[]()[]

[Missing <param> documentation for "array"]

arrayIndex
Type: System..::.Int32

[Missing <param> documentation for "arrayIndex"]

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ItemList Class
HeuristicLab.Data Namespace


CreateView Method

ItemList..::.CreateView Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

ItemList Class
HeuristicLab.Data Namespace


GetEnumerator Method

ItemList..::.GetEnumerator Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.GetEnumerator]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEnumerator<IItem> GetEnumerator()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.GetEnumerator]

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ItemList Class
HeuristicLab.Data Namespace


IEnumerable.GetEnumerator Method

ItemList..::.IEnumerable..::.GetEnumerator Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.System#Collections#IEnumerable#GetEnumerator]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.System#Collections#IEnumerable#GetEnumerator]

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ItemList Class
HeuristicLab.Data Namespace


GetXmlNode Method

ItemList..::.GetXmlNode Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ItemList Class
HeuristicLab.Data Namespace


IndexOf Method

ItemList..::.IndexOf Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.IndexOf(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int IndexOf(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.IndexOf(HeuristicLab.Core.IItem)]

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

ItemList Class
HeuristicLab.Data Namespace


Insert Method

ItemList..::.Insert Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Insert(System.Int32,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Insert(
    int index,
    IItem item
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ItemList Class
HeuristicLab.Data Namespace


OnCleared Method

ItemList..::.OnCleared Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.OnCleared]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnCleared()

See Also

ItemList Class
HeuristicLab.Data Namespace


OnItemAdded Method

ItemList..::.OnItemAdded Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.OnItemAdded(HeuristicLab.Core.IItem,System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemAdded(
    IItem item,
    int index
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

ItemList Class
HeuristicLab.Data Namespace


OnItemRemoved Method

ItemList..::.OnItemRemoved Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.OnItemRemoved(HeuristicLab.Core.IItem,System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemRemoved(
    IItem item,
    int index
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

See Also

ItemList Class
HeuristicLab.Data Namespace


OnItemTypeChanged Method

ItemList..::.OnItemTypeChanged Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.OnItemTypeChanged]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemTypeChanged()

See Also

ItemList Class
HeuristicLab.Data Namespace


Populate Method

ItemList..::.Populate Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ItemList Class
HeuristicLab.Data Namespace


Remove Method

ItemList..::.Remove Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.Remove(HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Remove(
    IItem item
)

Parameters

item
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "item"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.Remove(HeuristicLab.Core.IItem)]

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ItemList Class
HeuristicLab.Data Namespace


RemoveAt Method

ItemList..::.RemoveAt Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.RemoveAt(System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

ItemList Class
HeuristicLab.Data Namespace


ToString Method

ItemList..::.ToString Method
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemList.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ItemList.ToString]

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemList Properties

[image]

HeuristicLab API Documentation
ItemList Properties
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemList type exposes the following members.

Properties

Name | Description
Count |
Guid | (Inherited from StorableBase.)
IsReadOnly |
Item |
ItemType |

See Also

ItemList Class
HeuristicLab.Data Namespace


Count Property

ItemList..::.Count Property
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ItemList.Count]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Count { get; }

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ItemList Class
HeuristicLab.Data Namespace


IsReadOnly Property

ItemList..::.IsReadOnly Property
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ItemList.IsReadOnly]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsReadOnly { get; }

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ItemList Class
HeuristicLab.Data Namespace


Item Property

ItemList..::.Item Property
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ItemList.Item(System.Int32)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IItem this[
    int index
] { get; set; }

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemType Property

ItemList..::.ItemType Property
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ItemList.ItemType]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Type ItemType { get; set; }

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemList Events

[image]

HeuristicLab API Documentation
ItemList Events
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemList type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
Cleared |
ItemAdded |
ItemRemoved |
ItemTypeChanged |

See Also

ItemList Class
HeuristicLab.Data Namespace


Cleared Event

ItemList..::.Cleared Event
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ItemList.Cleared]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler Cleared

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemAdded Event

ItemList..::.ItemAdded Event
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ItemList.ItemAdded]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ItemIndexEventArgs> ItemAdded

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemRemoved Event

ItemList..::.ItemRemoved Event
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ItemList.ItemRemoved]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler<ItemIndexEventArgs> ItemRemoved

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemTypeChanged Event

ItemList..::.ItemTypeChanged Event
ItemList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Data.ItemList.ItemTypeChanged]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ItemTypeChanged

See Also

ItemList Class
HeuristicLab.Data Namespace


ItemListView Class

ItemListView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ItemListView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ItemListView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.ItemListView

See Also

ItemListView Members
HeuristicLab.Data Namespace


ItemListView Members

[image]

HeuristicLab API Documentation
ItemListView Members
ItemListView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemListView type exposes the following members.

Constructors

Name | Description
ItemListView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
ItemList |
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ItemListView Class
HeuristicLab.Data Namespace


ItemListView Constructor

[image]

HeuristicLab API Documentation
ItemListView Constructor
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ItemListView()()() |
ItemListView(ItemList) |

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


ItemListView Constructor

ItemListView Constructor
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemListView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemListView()

See Also

ItemListView Class
ItemListView Overload
HeuristicLab.Data Namespace


ItemListView Constructor (ItemList)

ItemListView Constructor (ItemList)
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemListView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemListView(
    ItemList itemList
)

Parameters

itemList
Type: HeuristicLab.Data..::.ItemList

[Missing <param> documentation for "itemList"]

See Also

ItemListView Class
ItemListView Overload
HeuristicLab.Data Namespace


ItemListView Methods

[image]

HeuristicLab API Documentation
ItemListView Methods
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemListView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ItemListView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ItemListView..::.AccessibilityNotifyClients Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


AddItemEvents Method

ItemListView..::.AddItemEvents Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemListView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ItemListView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ItemListView..::.BeginInvoke Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ItemListView..::.Dispose Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

ItemListView..::.Dispose Method (Boolean)
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ItemListView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ItemListView..::.GetChildAtPoint Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ItemListView..::.Invalidate Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ItemListView..::.Invoke Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ItemListView..::.MemberwiseClone Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ItemListView..::.PerformLayout Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

ItemListView..::.RemoveItemEvents Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemListView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ItemListView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ItemListView..::.ResumeLayout Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ItemListView..::.RtlTranslateAlignment Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
ItemListView..::.Scale Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
ItemListView..::.Select Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ItemListView..::.SetBounds Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ItemListView..::.UpdateBounds Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


UpdateControls Method

ItemListView..::.UpdateControls Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ItemListView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ItemListView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
ItemListView..::.Validate Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ItemListView..::.ValidateChildren Method
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ItemListView Class
ItemListView Members
HeuristicLab.Data Namespace


ItemListView Properties

[image]

HeuristicLab API Documentation
ItemListView Properties
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemListView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
ItemList |
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ItemListView Class
HeuristicLab.Data Namespace


ItemList Property

ItemListView..::.ItemList Property
ItemListView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ItemListView.ItemList]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList ItemList { get; set; }

See Also

ItemListView Class
HeuristicLab.Data Namespace


MatrixDataBaseView Class

MatrixDataBaseView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.MatrixDataBaseView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MatrixDataBaseView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.MatrixDataBaseView
HeuristicLab.Data..::.DoubleMatrixDataView
HeuristicLab.Data..::.IntMatrixDataView
HeuristicLab.Data..::.BoolMatrixDataView

See Also

MatrixDataBaseView Members
HeuristicLab.Data Namespace


MatrixDataBaseView Members

[image]

HeuristicLab API Documentation
MatrixDataBaseView Members
MatrixDataBaseView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixDataBaseView type exposes the following members.

Constructors

Name | Description
MatrixDataBaseView |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement |
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData |
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


MatrixDataBaseView Constructor

MatrixDataBaseView Constructor
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MatrixDataBaseView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MatrixDataBaseView()

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


MatrixDataBaseView Methods

[image]

HeuristicLab API Documentation
MatrixDataBaseView Methods
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixDataBaseView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetArrayElement |
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
ValidateData |
WndProc | (Inherited from UserControl.)

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.AccessibilityNotifyClients Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


AddItemEvents Method

MatrixDataBaseView..::.AddItemEvents Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.MatrixDataBaseView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.BeginInvoke Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.Dispose Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

MatrixDataBaseView..::.Dispose Method (Boolean)
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

MatrixDataBaseView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.GetChildAtPoint Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.Invalidate Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.Invoke Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.MemberwiseClone Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.PerformLayout Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

MatrixDataBaseView..::.RemoveItemEvents Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.MatrixDataBaseView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.ResumeLayout Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.RtlTranslateAlignment Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.Scale Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.Select Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


SetArrayElement Method

MatrixDataBaseView..::.SetArrayElement Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.MatrixDataBaseView.SetArrayElement(System.Int32,System.Int32,System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void SetArrayElement(
    int row,
    int column,
    string element
)

Parameters

row
Type: System..::.Int32

[Missing <param> documentation for "row"]

column
Type: System..::.Int32

[Missing <param> documentation for "column"]

element
Type: System..::.String

[Missing <param> documentation for "element"]

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.SetBounds Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.UpdateBounds Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


UpdateControls Method

MatrixDataBaseView..::.UpdateControls Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.MatrixDataBaseView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.Validate Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
MatrixDataBaseView..::.ValidateChildren Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

MatrixDataBaseView Class
MatrixDataBaseView Members
HeuristicLab.Data Namespace


ValidateData Method

MatrixDataBaseView..::.ValidateData Method
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.MatrixDataBaseView.ValidateData(System.String)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual bool ValidateData(
    string element
)

Parameters

element
Type: System..::.String

[Missing <param> documentation for "element"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.MatrixDataBaseView.ValidateData(System.String)]

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


MatrixDataBaseView Properties

[image]

HeuristicLab API Documentation
MatrixDataBaseView Properties
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixDataBaseView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
ArrayDataBase |
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


ArrayDataBase Property

MatrixDataBaseView..::.ArrayDataBase Property
MatrixDataBaseView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.MatrixDataBaseView.ArrayDataBase]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ArrayDataBase ArrayDataBase { get; protected set; }

See Also

MatrixDataBaseView Class
HeuristicLab.Data Namespace


ObjectData Class

ObjectData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ObjectData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ObjectData : ItemBase, IObjectData,
    IItem, IStorable, IViewable, IComparable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.StringData
HeuristicLab.Data..::.IntData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.DoubleData
HeuristicLab.Data..::.BoolData

See Also

ObjectData Members
HeuristicLab.Data Namespace


ObjectData Members

[image]

HeuristicLab API Documentation
ObjectData Members
ObjectData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ObjectData type exposes the following members.

Constructors

Name | Description
ObjectData |

Methods

Name | Description
Accept |
Clone | Overloaded.
CompareTo |
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Overrides ItemBase ..::. ToString()()().)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

ObjectData Class
HeuristicLab.Data Namespace


ObjectData Constructor

ObjectData Constructor
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ObjectData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ObjectData()

See Also

ObjectData Class
HeuristicLab.Data Namespace


ObjectData Methods

[image]

HeuristicLab API Documentation
ObjectData Methods
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ObjectData type exposes the following members.

Methods

Name | Description
Accept |
Clone | Overloaded.
CompareTo |
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from StorableBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from StorableBase.)
ToString | (Overrides ItemBase ..::. ToString()()().)

See Also

ObjectData Class
HeuristicLab.Data Namespace


Accept Method

ObjectData..::.Accept Method
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

ObjectData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
ObjectData..::.Clone Method
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ObjectData Class
ObjectData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

ObjectData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ObjectData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ObjectData Class
Clone Overload
HeuristicLab.Data Namespace


CompareTo Method

ObjectData..::.CompareTo Method
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectData.CompareTo(System.Object)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ObjectData.CompareTo(System.Object)]

Implements

IComparable..::.CompareTo(Object)

See Also

ObjectData Class
HeuristicLab.Data Namespace


ToString Method

ObjectData..::.ToString Method
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectData.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.ObjectData.ToString]

See Also

ObjectData Class
HeuristicLab.Data Namespace


ObjectData Properties

[image]

HeuristicLab API Documentation
ObjectData Properties
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ObjectData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

ObjectData Class
HeuristicLab.Data Namespace


Data Property

ObjectData..::.Data Property
ObjectData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.ObjectData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual Object Data { get; set; }

Implements

IObjectData..::.Data

See Also

ObjectData Class
HeuristicLab.Data Namespace


ObjectDataVisitorBase Class

ObjectDataVisitorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.ObjectDataVisitorBase]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ObjectDataVisitorBase : IObjectDataVisitor

Inheritance Hierarchy

System..::.Object
HeuristicLab.Data..::.ObjectDataVisitorBase
RandomAdderVisitor
RandomizerVisitor
RandomAdderVisitor
RandomVisitor

See Also

ObjectDataVisitorBase Members
HeuristicLab.Data Namespace


ObjectDataVisitorBase Members

[image]

HeuristicLab API Documentation
ObjectDataVisitorBase Members
ObjectDataVisitorBase Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ObjectDataVisitorBase type exposes the following members.

Constructors

Name | Description
ObjectDataVisitorBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Visit | Overloaded.

See Also

ObjectDataVisitorBase Class
HeuristicLab.Data Namespace


ObjectDataVisitorBase Constructor

ObjectDataVisitorBase Constructor
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ObjectDataVisitorBase class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ObjectDataVisitorBase()

See Also

ObjectDataVisitorBase Class
HeuristicLab.Data Namespace


ObjectDataVisitorBase Methods

[image]

HeuristicLab API Documentation
ObjectDataVisitorBase Methods
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ObjectDataVisitorBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Visit | Overloaded.

See Also

ObjectDataVisitorBase Class
HeuristicLab.Data Namespace


Visit Method

[image]

HeuristicLab API Documentation
ObjectDataVisitorBase..::.Visit Method
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Visit(BoolArrayData) |
Visit(BoolData) |
Visit(BoolMatrixData) |
Visit(ConstrainedDoubleData) |
Visit(ConstrainedIntData) |
Visit(ConstrainedObjectData) |
Visit(DoubleArrayData) |
Visit(DoubleData) |
Visit(DoubleMatrixData) |
Visit(IntArrayData) |
Visit(IntData) |
Visit(IntMatrixData) |
Visit(ObjectData) |
Visit(StringData) |

See Also

ObjectDataVisitorBase Class
ObjectDataVisitorBase Members
HeuristicLab.Data Namespace


Visit Method (BoolArrayData)

ObjectDataVisitorBase..::.Visit Method (BoolArrayData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.BoolArrayData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    BoolArrayData data
)

Parameters

data
Type: HeuristicLab.Data..::.BoolArrayData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(BoolArrayData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (BoolData)

ObjectDataVisitorBase..::.Visit Method (BoolData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.BoolData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    BoolData data
)

Parameters

data
Type: HeuristicLab.Data..::.BoolData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(BoolData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (BoolMatrixData)

ObjectDataVisitorBase..::.Visit Method (BoolMatrixData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.BoolMatrixData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    BoolMatrixData data
)

Parameters

data
Type: HeuristicLab.Data..::.BoolMatrixData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(BoolMatrixData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ConstrainedDoubleData)

ObjectDataVisitorBase..::.Visit Method (ConstrainedDoubleData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.ConstrainedDoubleData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    ConstrainedDoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedDoubleData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ConstrainedIntData)

ObjectDataVisitorBase..::.Visit Method (ConstrainedIntData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.ConstrainedIntData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    ConstrainedIntData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedIntData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ConstrainedObjectData)

ObjectDataVisitorBase..::.Visit Method (ConstrainedObjectData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.ConstrainedObjectData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    ConstrainedObjectData constrainedObjectData
)

Parameters

constrainedObjectData
Type: HeuristicLab.Data..::.ConstrainedObjectData

[Missing <param> documentation for "constrainedObjectData"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedObjectData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (DoubleArrayData)

ObjectDataVisitorBase..::.Visit Method (DoubleArrayData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.DoubleArrayData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    DoubleArrayData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleArrayData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleArrayData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (DoubleData)

ObjectDataVisitorBase..::.Visit Method (DoubleData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.DoubleData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    DoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (DoubleMatrixData)

ObjectDataVisitorBase..::.Visit Method (DoubleMatrixData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.DoubleMatrixData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    DoubleMatrixData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleMatrixData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleMatrixData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (IntArrayData)

ObjectDataVisitorBase..::.Visit Method (IntArrayData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.IntArrayData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    IntArrayData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntArrayData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntArrayData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (IntData)

ObjectDataVisitorBase..::.Visit Method (IntData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.IntData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    IntData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (IntMatrixData)

ObjectDataVisitorBase..::.Visit Method (IntMatrixData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.IntMatrixData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    IntMatrixData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntMatrixData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntMatrixData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (ObjectData)

ObjectDataVisitorBase..::.Visit Method (ObjectData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.ObjectData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    ObjectData objectData
)

Parameters

objectData
Type: HeuristicLab.Data..::.ObjectData

[Missing <param> documentation for "objectData"]

Implements

IObjectDataVisitor..::.Visit(ObjectData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


Visit Method (StringData)

ObjectDataVisitorBase..::.Visit Method (StringData)
ObjectDataVisitorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.ObjectDataVisitorBase.Visit(HeuristicLab.Data.StringData)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Visit(
    StringData data
)

Parameters

data
Type: HeuristicLab.Data..::.StringData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(StringData)

See Also

ObjectDataVisitorBase Class
Visit Overload
HeuristicLab.Data Namespace


StringData Class

StringData Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.StringData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class StringData : ObjectData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.StringData

See Also

StringData Members
HeuristicLab.Data Namespace


StringData Members

[image]

HeuristicLab API Documentation
StringData Members
StringData Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StringData type exposes the following members.

Constructors

Name | Description
StringData | Overloaded.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ObjectData ..::. ToString()()().)

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

StringData Class
HeuristicLab.Data Namespace


StringData Constructor

[image]

HeuristicLab API Documentation
StringData Constructor
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
StringData()()() |
StringData(String) |

See Also

StringData Class
StringData Members
HeuristicLab.Data Namespace


StringData Constructor

StringData Constructor
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StringData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringData()

See Also

StringData Class
StringData Overload
HeuristicLab.Data Namespace


StringData Constructor (String)

StringData Constructor (String)
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StringData class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringData(
    string data
)

Parameters

data
Type: System..::.String

[Missing <param> documentation for "data"]

See Also

StringData Class
StringData Overload
HeuristicLab.Data Namespace


StringData Methods

[image]

HeuristicLab API Documentation
StringData Methods
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StringData type exposes the following members.

Methods

Name | Description
Accept | (Overrides ObjectData ..::. Accept(IObjectDataVisitor).)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ObjectData ..::. ToString()()().)

See Also

StringData Class
HeuristicLab.Data Namespace


Accept Method

StringData..::.Accept Method
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringData.Accept(HeuristicLab.Data.IObjectDataVisitor)]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IObjectDataVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Data..::.IObjectDataVisitor

[Missing <param> documentation for "visitor"]

Implements

IObjectData..::.Accept(IObjectDataVisitor)

See Also

StringData Class
HeuristicLab.Data Namespace


Clone Method

[image]

HeuristicLab API Documentation
StringData..::.Clone Method
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

StringData Class
StringData Members
HeuristicLab.Data Namespace


Clone Method (IDictionary(Guid, Object))

StringData..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.StringData.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

StringData Class
Clone Overload
HeuristicLab.Data Namespace


CreateView Method

StringData..::.CreateView Method
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringData.CreateView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.StringData.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

StringData Class
HeuristicLab.Data Namespace


GetXmlNode Method

StringData..::.GetXmlNode Method
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.StringData.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

StringData Class
HeuristicLab.Data Namespace


Populate Method

StringData..::.Populate Method
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringData.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

StringData Class
HeuristicLab.Data Namespace


ToString Method

StringData..::.ToString Method
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringData.ToString]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Data.StringData.ToString]

See Also

StringData Class
HeuristicLab.Data Namespace


StringData Properties

[image]

HeuristicLab API Documentation
StringData Properties
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StringData type exposes the following members.

Properties

Name | Description
Data |
Guid | (Inherited from StorableBase.)

See Also

StringData Class
HeuristicLab.Data Namespace


Data Property

StringData..::.Data Property
StringData Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.StringData.Data]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Data { get; set; }

See Also

StringData Class
HeuristicLab.Data Namespace


StringDataView Class

StringDataView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Data.StringDataView]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class StringDataView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Data..::.StringDataView

See Also

StringDataView Members
HeuristicLab.Data Namespace


StringDataView Members

[image]

HeuristicLab API Documentation
StringDataView Members
StringDataView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StringDataView type exposes the following members.

Constructors

Name | Description
StringDataView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
StringData |
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

StringDataView Class
HeuristicLab.Data Namespace


StringDataView Constructor

[image]

HeuristicLab API Documentation
StringDataView Constructor
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
StringDataView()()() |
StringDataView(StringData) |

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


StringDataView Constructor

StringDataView Constructor
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StringDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringDataView()

See Also

StringDataView Class
StringDataView Overload
HeuristicLab.Data Namespace


StringDataView Constructor (StringData)

StringDataView Constructor (StringData)
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StringDataView class.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringDataView(
    StringData stringData
)

Parameters

stringData
Type: HeuristicLab.Data..::.StringData

[Missing <param> documentation for "stringData"]

See Also

StringDataView Class
StringDataView Overload
HeuristicLab.Data Namespace


StringDataView Methods

[image]

HeuristicLab API Documentation
StringDataView Methods
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StringDataView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

StringDataView Class
HeuristicLab.Data Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
StringDataView..::.AccessibilityNotifyClients Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


AddItemEvents Method

StringDataView..::.AddItemEvents Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringDataView.AddItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

StringDataView Class
HeuristicLab.Data Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
StringDataView..::.BeginInvoke Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


Dispose Method

[image]

HeuristicLab API Documentation
StringDataView..::.Dispose Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


Dispose Method (Boolean)

StringDataView..::.Dispose Method (Boolean)
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

StringDataView Class
Dispose Overload
HeuristicLab.Data Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
StringDataView..::.GetChildAtPoint Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
StringDataView..::.Invalidate Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


Invoke Method

[image]

HeuristicLab API Documentation
StringDataView..::.Invoke Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
StringDataView..::.MemberwiseClone Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
StringDataView..::.PerformLayout Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


RemoveItemEvents Method

StringDataView..::.RemoveItemEvents Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringDataView.RemoveItemEvents]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

StringDataView Class
HeuristicLab.Data Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
StringDataView..::.ResumeLayout Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
StringDataView..::.RtlTranslateAlignment Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


Scale Method

[image]

HeuristicLab API Documentation
StringDataView..::.Scale Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


Select Method

[image]

HeuristicLab API Documentation
StringDataView..::.Select Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
StringDataView..::.SetBounds Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
StringDataView..::.UpdateBounds Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


UpdateControls Method

StringDataView..::.UpdateControls Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Data.StringDataView.UpdateControls]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

StringDataView Class
HeuristicLab.Data Namespace


Validate Method

[image]

HeuristicLab API Documentation
StringDataView..::.Validate Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
StringDataView..::.ValidateChildren Method
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

StringDataView Class
StringDataView Members
HeuristicLab.Data Namespace


StringDataView Properties

[image]

HeuristicLab API Documentation
StringDataView Properties
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StringDataView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
StringData |
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

StringDataView Class
HeuristicLab.Data Namespace


StringData Property

StringDataView..::.StringData Property
StringDataView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Data.StringDataView.StringData]

Namespace: HeuristicLab.Data
Assembly: HeuristicLab.Data (in HeuristicLab.Data.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StringData StringData { get; set; }

See Also

StringDataView Class
HeuristicLab.Data Namespace


HeuristicLab.DataAnalysis Namespace

HeuristicLab.DataAnalysis Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.DataAnalysis]

Classes

Class | Description
Dataset |
DatasetParser |
DatasetParser..::.Token |
DatasetView |
HeuristicLabDataAnalysisPlugin |
LinearStatistics |
Statistics |

Enumerations

Enumeration | Description
DatasetParser..::.TokenTypeEnum |


Dataset Class

Dataset Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.Dataset]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Dataset : ItemBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.DataAnalysis..::.Dataset

See Also

Dataset Members
HeuristicLab.DataAnalysis Namespace


Dataset Members

[image]

HeuristicLab API Documentation
Dataset Members
Dataset Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Dataset type exposes the following members.

Constructors

Name | Description
Dataset |

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMean |
GetRange |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue |
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
SetValue |
ToString | (Overrides ItemBase ..::. ToString()()().)

Properties

Name | Description
Columns |
Guid | (Inherited from StorableBase.)
Name |
Rows |
Samples |
VariableNames |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Dataset Constructor

Dataset Constructor
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Dataset class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Dataset()

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Dataset Methods

[image]

HeuristicLab API Documentation
Dataset Methods
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Dataset type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMean |
GetRange |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue |
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
SetValue |
ToString | (Overrides ItemBase ..::. ToString()()().)

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Clone Method

[image]

HeuristicLab API Documentation
Dataset..::.Clone Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Dataset Class
Dataset Members
HeuristicLab.DataAnalysis Namespace


Clone Method (IDictionary(Guid, Object))

Dataset..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Dataset Class
Clone Overload
HeuristicLab.DataAnalysis Namespace


CreateView Method

Dataset..::.CreateView Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.CreateView]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


GetMean Method

Dataset..::.GetMean Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetMean(System.Int32,System.Int32,System.Int32)]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double GetMean(
    int column,
    int from,
    int to
)

Parameters

column
Type: System..::.Int32

[Missing <param> documentation for "column"]

from
Type: System..::.Int32

[Missing <param> documentation for "from"]

to
Type: System..::.Int32

[Missing <param> documentation for "to"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetMean(System.Int32,System.Int32,System.Int32)]

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


GetRange Method

Dataset..::.GetRange Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetRange(System.Int32,System.Int32,System.Int32)]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double GetRange(
    int column,
    int from,
    int to
)

Parameters

column
Type: System..::.Int32

[Missing <param> documentation for "column"]

from
Type: System..::.Int32

[Missing <param> documentation for "from"]

to
Type: System..::.Int32

[Missing <param> documentation for "to"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetRange(System.Int32,System.Int32,System.Int32)]

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


GetValue Method

Dataset..::.GetValue Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetValue(System.Int32,System.Int32)]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double GetValue(
    int i,
    int j
)

Parameters

i
Type: System..::.Int32

[Missing <param> documentation for "i"]

j
Type: System..::.Int32

[Missing <param> documentation for "j"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetValue(System.Int32,System.Int32)]

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


GetXmlNode Method

Dataset..::.GetXmlNode Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Populate Method

Dataset..::.Populate Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


SetValue Method

Dataset..::.SetValue Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.SetValue(System.Int32,System.Int32,System.Double)]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetValue(
    int i,
    int j,
    double v
)

Parameters

i
Type: System..::.Int32

[Missing <param> documentation for "i"]

j
Type: System..::.Int32

[Missing <param> documentation for "j"]

v
Type: System..::.Double

[Missing <param> documentation for "v"]

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


ToString Method

Dataset..::.ToString Method
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Dataset.ToString]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Dataset.ToString]

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Dataset Properties

[image]

HeuristicLab API Documentation
Dataset Properties
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Dataset type exposes the following members.

Properties

Name | Description
Columns |
Guid | (Inherited from StorableBase.)
Name |
Rows |
Samples |
VariableNames |

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Columns Property

Dataset..::.Columns Property
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.Dataset.Columns]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Columns { get; set; }

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Name Property

Dataset..::.Name Property
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.Dataset.Name]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Rows Property

Dataset..::.Rows Property
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.Dataset.Rows]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Rows { get; set; }

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


Samples Property

Dataset..::.Samples Property
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.Dataset.Samples]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double[] Samples { get; set; }

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


VariableNames Property

Dataset..::.VariableNames Property
Dataset Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.Dataset.VariableNames]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string[] VariableNames { get; set; }

See Also

Dataset Class
HeuristicLab.DataAnalysis Namespace


DatasetParser Class

DatasetParser Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.DatasetParser]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DatasetParser

Inheritance Hierarchy

System..::.Object
HeuristicLab.DataAnalysis..::.DatasetParser

See Also

DatasetParser Members
HeuristicLab.DataAnalysis Namespace


DatasetParser Members

[image]

HeuristicLab API Documentation
DatasetParser Members
DatasetParser Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetParser type exposes the following members.

Constructors

Name | Description
DatasetParser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Import |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Columns |
MaxTreeHeight |
MaxTreeSize |
ProblemName |
Rows |
Samples |
TargetVariable |
TrainingSamplesEnd |
TrainingSamplesStart |
VariableNames |

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


DatasetParser Constructor

DatasetParser Constructor
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DatasetParser class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DatasetParser()

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


DatasetParser Methods

[image]

HeuristicLab API Documentation
DatasetParser Methods
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetParser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Import |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


Import Method

DatasetParser..::.Import Method
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Import(System.String,System.Boolean)]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Import(
    string importFileName,
    bool strict
)

Parameters

importFileName
Type: System..::.String

[Missing <param> documentation for "importFileName"]

strict
Type: System..::.Boolean

[Missing <param> documentation for "strict"]

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


DatasetParser Properties

[image]

HeuristicLab API Documentation
DatasetParser Properties
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetParser type exposes the following members.

Properties

Name | Description
Columns |
MaxTreeHeight |
MaxTreeSize |
ProblemName |
Rows |
Samples |
TargetVariable |
TrainingSamplesEnd |
TrainingSamplesStart |
VariableNames |

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


Columns Property

DatasetParser..::.Columns Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.Columns]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Columns { get; set; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


MaxTreeHeight Property

DatasetParser..::.MaxTreeHeight Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.MaxTreeHeight]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int MaxTreeHeight { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


MaxTreeSize Property

DatasetParser..::.MaxTreeSize Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.MaxTreeSize]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int MaxTreeSize { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


ProblemName Property

DatasetParser..::.ProblemName Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.ProblemName]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string ProblemName { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


Rows Property

DatasetParser..::.Rows Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.Rows]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Rows { get; set; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


Samples Property

DatasetParser..::.Samples Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.Samples]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double[] Samples { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


TargetVariable Property

DatasetParser..::.TargetVariable Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.TargetVariable]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int TargetVariable { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


TrainingSamplesEnd Property

DatasetParser..::.TrainingSamplesEnd Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.TrainingSamplesEnd]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int TrainingSamplesEnd { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


TrainingSamplesStart Property

DatasetParser..::.TrainingSamplesStart Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.TrainingSamplesStart]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int TrainingSamplesStart { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


VariableNames Property

DatasetParser..::.VariableNames Property
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.VariableNames]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string[] VariableNames { get; }

See Also

DatasetParser Class
HeuristicLab.DataAnalysis Namespace


DatasetParser.Token Class

DatasetParser..::.Token Class
DatasetParser Class Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.DatasetParser.Token]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class Token

Inheritance Hierarchy

System..::.Object
HeuristicLab.DataAnalysis..::.DatasetParser..::.Token

See Also

DatasetParser..::.Token Members
HeuristicLab.DataAnalysis Namespace


DatasetParser.Token Members

[image]

HeuristicLab API Documentation
DatasetParser..::.Token Members
DatasetParser..::.Token Class Constructors Methods Fields See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetParser..::.Token type exposes the following members.

Constructors

Name | Description
DatasetParser..::.Token |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)

Fields

Name | Description
doubleValue |
intValue |
stringValue |
type |

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


DatasetParser.Token Constructor

DatasetParser..::.Token Constructor
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Token class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Token(
    DatasetParser..::.TokenTypeEnum type,
    string value
)

Parameters

type
Type: HeuristicLab.DataAnalysis..::.DatasetParser..::.TokenTypeEnum

[Missing <param> documentation for "type"]

value
Type: System..::.String

[Missing <param> documentation for "value"]

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


DatasetParser.Token Fields

[image]

HeuristicLab API Documentation
DatasetParser..::.Token Fields
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetParser..::.Token type exposes the following members.

Fields

Name | Description
doubleValue |
intValue |
stringValue |
type |

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


doubleValue Field

DatasetParser..::.Token..::.doubleValue Field
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Token.doubleValue]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double doubleValue

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


intValue Field

DatasetParser..::.Token..::.intValue Field
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Token.intValue]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int intValue

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


stringValue Field

DatasetParser..::.Token..::.stringValue Field
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Token.stringValue]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string stringValue

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


type Field

DatasetParser..::.Token..::.type Field
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Token.type]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DatasetParser..::.TokenTypeEnum type

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


DatasetParser.Token Methods

[image]

HeuristicLab API Documentation
DatasetParser..::.Token Methods
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetParser..::.Token type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


ToString Method

DatasetParser..::.Token..::.ToString Method
DatasetParser..::.Token Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Token.ToString]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Token.ToString]

See Also

DatasetParser..::.Token Class
HeuristicLab.DataAnalysis Namespace


DatasetParser.TokenTypeEnum Enumeration

DatasetParser..::.TokenTypeEnum Enumeration
DatasetParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.DatasetParser.TokenTypeEnum]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal enum TokenTypeEnum

Members

Member name | Description
At |
Assign |
NewLine |
String |
Double |
Int |

See Also

HeuristicLab.DataAnalysis Namespace


DatasetView Class

DatasetView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.DatasetView]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DatasetView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.DataAnalysis..::.DatasetView

See Also

DatasetView Members
HeuristicLab.DataAnalysis Namespace


DatasetView Members

[image]

HeuristicLab API Documentation
DatasetView Members
DatasetView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetView type exposes the following members.

Constructors

Name | Description
DatasetView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Dataset |
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DatasetView Class
HeuristicLab.DataAnalysis Namespace


DatasetView Constructor

[image]

HeuristicLab API Documentation
DatasetView Constructor
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DatasetView()()() |
DatasetView(Dataset) |

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


DatasetView Constructor

DatasetView Constructor
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DatasetView class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DatasetView()

See Also

DatasetView Class
DatasetView Overload
HeuristicLab.DataAnalysis Namespace


DatasetView Constructor (Dataset)

DatasetView Constructor (Dataset)
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DatasetView class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DatasetView(
    Dataset dataset
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

See Also

DatasetView Class
DatasetView Overload
HeuristicLab.DataAnalysis Namespace


DatasetView Methods

[image]

HeuristicLab API Documentation
DatasetView Methods
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DatasetView Class
HeuristicLab.DataAnalysis Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DatasetView..::.AccessibilityNotifyClients Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DatasetView..::.BeginInvoke Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DatasetView..::.Dispose Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


Dispose Method (Boolean)

DatasetView..::.Dispose Method (Boolean)
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DatasetView Class
Dispose Overload
HeuristicLab.DataAnalysis Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DatasetView..::.GetChildAtPoint Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DatasetView..::.Invalidate Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DatasetView..::.Invoke Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DatasetView..::.MemberwiseClone Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DatasetView..::.PerformLayout Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DatasetView..::.ResumeLayout Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DatasetView..::.RtlTranslateAlignment Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


Scale Method

[image]

HeuristicLab API Documentation
DatasetView..::.Scale Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


Select Method

[image]

HeuristicLab API Documentation
DatasetView..::.Select Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DatasetView..::.SetBounds Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DatasetView..::.UpdateBounds Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


UpdateControls Method

DatasetView..::.UpdateControls Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.DatasetView.UpdateControls]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

DatasetView Class
HeuristicLab.DataAnalysis Namespace


Validate Method

[image]

HeuristicLab API Documentation
DatasetView..::.Validate Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DatasetView..::.ValidateChildren Method
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DatasetView Class
DatasetView Members
HeuristicLab.DataAnalysis Namespace


DatasetView Properties

[image]

HeuristicLab API Documentation
DatasetView Properties
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DatasetView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Dataset |
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DatasetView Class
HeuristicLab.DataAnalysis Namespace


Dataset Property

DatasetView..::.Dataset Property
DatasetView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetView.Dataset]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Dataset Dataset { get; set; }

See Also

DatasetView Class
HeuristicLab.DataAnalysis Namespace


HeuristicLabDataAnalysisPlugin Class

HeuristicLabDataAnalysisPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.HeuristicLabDataAnalysisPlugin]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.DataAnalysis.dll", Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.DataAnalysis")]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
public class HeuristicLabDataAnalysisPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.DataAnalysis..::.HeuristicLabDataAnalysisPlugin

See Also

HeuristicLabDataAnalysisPlugin Members
HeuristicLab.DataAnalysis Namespace


HeuristicLabDataAnalysisPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabDataAnalysisPlugin Members
HeuristicLabDataAnalysisPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabDataAnalysisPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabDataAnalysisPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabDataAnalysisPlugin Class
HeuristicLab.DataAnalysis Namespace


HeuristicLabDataAnalysisPlugin Constructor

HeuristicLabDataAnalysisPlugin Constructor
HeuristicLabDataAnalysisPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabDataAnalysisPlugin class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabDataAnalysisPlugin()

See Also

HeuristicLabDataAnalysisPlugin Class
HeuristicLab.DataAnalysis Namespace


LinearStatistics Class

LinearStatistics Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.LinearStatistics]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LinearStatistics

Inheritance Hierarchy

System..::.Object
HeuristicLab.DataAnalysis..::.LinearStatistics

See Also

LinearStatistics Members
HeuristicLab.DataAnalysis Namespace


LinearStatistics Members

[image]

HeuristicLab API Documentation
LinearStatistics Members
LinearStatistics Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearStatistics type exposes the following members.

Constructors

Name | Description
LinearStatistics |

Methods

Name | Description
AdjustedCoefficientOfDetermination |
CoefficientOfDetermination | In statistics, the coefficient of determination (R-squared) is the proportion of a sample variance of a response variable that is "explained" by the predictor (explanatory) variables when regression is done.
CorrelationCoefficient |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LinearRegression | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearStatistics Class
HeuristicLab.DataAnalysis Namespace


LinearStatistics Constructor

LinearStatistics Constructor
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinearStatistics class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LinearStatistics()

See Also

LinearStatistics Class
HeuristicLab.DataAnalysis Namespace


LinearStatistics Methods

[image]

HeuristicLab API Documentation
LinearStatistics Methods
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearStatistics type exposes the following members.

Methods

Name | Description
AdjustedCoefficientOfDetermination |
CoefficientOfDetermination | In statistics, the coefficient of determination (R-squared) is the proportion of a sample variance of a response variable that is "explained" by the predictor (explanatory) variables when regression is done.
CorrelationCoefficient |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LinearRegression | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearStatistics Class
HeuristicLab.DataAnalysis Namespace


AdjustedCoefficientOfDetermination Method

LinearStatistics..::.AdjustedCoefficientOfDetermination Method
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.LinearStatistics.AdjustedCoefficientOfDetermination(System.Double[],System.Double[],System.Int32)]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double AdjustedCoefficientOfDetermination(
    double[] originalValues,
    double[] residuals,
    int numberOfExplanatoryTerms
)

Parameters

originalValues
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "originalValues"]

residuals
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "residuals"]

numberOfExplanatoryTerms
Type: System..::.Int32

[Missing <param> documentation for "numberOfExplanatoryTerms"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.LinearStatistics.AdjustedCoefficientOfDetermination(System.Double[],System.Double[],System.Int32)]

See Also

LinearStatistics Class
HeuristicLab.DataAnalysis Namespace


CoefficientOfDetermination Method

LinearStatistics..::.CoefficientOfDetermination Method
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

In statistics, the coefficient of determination (R-squared) is the proportion of a sample variance of a response variable that is "explained" by the predictor (explanatory) variables when regression is done.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double CoefficientOfDetermination(
    double[] originalValues,
    double[] residuals
)

Parameters

originalValues
Type: array< System..::.Double >[]()[]
The original values for which a model shall be created.
residuals
Type: array< System..::.Double >[]()[]
The errors between original and predicted values.

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.LinearStatistics.CoefficientOfDetermination(System.Double[],System.Double[])]

See Also

LinearStatistics Class
HeuristicLab.DataAnalysis Namespace


CorrelationCoefficient Method

LinearStatistics..::.CorrelationCoefficient Method
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.LinearStatistics.CorrelationCoefficient(System.Double[],System.Double[])]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double CorrelationCoefficient(
    double[] xValues,
    double[] yValues
)

Parameters

xValues
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "xValues"]

yValues
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "yValues"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.LinearStatistics.CorrelationCoefficient(System.Double[],System.Double[])]

See Also

LinearStatistics Class
HeuristicLab.DataAnalysis Namespace


LinearRegression Method

[image]

HeuristicLab API Documentation
LinearStatistics..::.LinearRegression Method
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LinearRegression(array<Double>[]()[]) | Calculates linear regression for the given data. The result is given as regression values, which are returned, as well as the characteristic coefficients a and b.
LinearRegression(array<Double>[]()[], Double%, Double%) | Calculates linear regression for the given data. The result is given as regression values, which are returned, as well as the characteristic coefficients a and b.

See Also

LinearStatistics Class
LinearStatistics Members
HeuristicLab.DataAnalysis Namespace


LinearRegression Method (Double[])

LinearStatistics..::.LinearRegression Method (array<Double>[]()[])
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates linear regression for the given data. The result is given as regression values, which are returned, as well as the characteristic coefficients a and b.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double[] LinearRegression(
    double[] data
)

Parameters

data
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "data"]

Return Value

Calculated linear regression values.

See Also

LinearStatistics Class
LinearRegression Overload
HeuristicLab.DataAnalysis Namespace


LinearRegression Method (Double[], Double , Double )

LinearStatistics..::.LinearRegression Method (array<Double>[]()[], Double %, Double %)
LinearStatistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates linear regression for the given data. The result is given as regression values, which are returned, as well as the characteristic coefficients a and b.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double[] LinearRegression(
    double[] data,
    out double a,
    out double b
)

Parameters

data
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "data"]

a
Type: System..::.Double %
Regression coefficient 'a' (output parameter).
b
Type: System..::.Double %
Regression coefficient 'b' (output parameter).

Return Value

Calculated linear regression values.

See Also

LinearStatistics Class
LinearRegression Overload
HeuristicLab.DataAnalysis Namespace


Statistics Class

Statistics Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DataAnalysis.Statistics]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Statistics

Inheritance Hierarchy

System..::.Object
HeuristicLab.DataAnalysis..::.Statistics

See Also

Statistics Members
HeuristicLab.DataAnalysis Namespace


Statistics Members

[image]

HeuristicLab API Documentation
Statistics Members
Statistics Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Statistics type exposes the following members.

Constructors

Name | Description
Statistics |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Maximum<(Of <(T>)>) | Maximum returns the largest entry of values. Throws an exception if values is empty.
Mean | Overloaded.
Median | Calculates the median of the values.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimum<(Of <(T>)>) | Minimum returns the smalles entry of values. Throws and exception if values is empty.
Range | Overloaded.
StandardDeviation | Calculates the standard deviation of values.
Sum | calculates the sum of all values.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Variance | Overloaded.

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Statistics Constructor

Statistics Constructor
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Statistics class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Statistics()

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Statistics Methods

[image]

HeuristicLab API Documentation
Statistics Methods
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Statistics type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Maximum<(Of <(T>)>) | Maximum returns the largest entry of values. Throws an exception if values is empty.
Mean | Overloaded.
Median | Calculates the median of the values.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimum<(Of <(T>)>) | Minimum returns the smalles entry of values. Throws and exception if values is empty.
Range | Overloaded.
StandardDeviation | Calculates the standard deviation of values.
Sum | calculates the sum of all values.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Variance | Overloaded.

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Maximum(T) Method

Statistics..::.Maximum<(Of <(T>)>) Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Maximum returns the largest entry of values. Throws an exception if values is empty.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static T Maximum<T>(
    IEnumerable<T> values
) where T : struct, new(), IComparable, IComparable<T>

Parameters

values
Type: System.Collections.Generic..::.IEnumerable <(Of <(T>)>)

[Missing <param> documentation for "values"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Maximum``1(System.Collections.Generic.IEnumerable{``0})]

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Mean Method

[image]

HeuristicLab API Documentation
Statistics..::.Mean Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Mean(List<(Of <(Double>)>)) | Calculates the mean of all values.
Mean(array<Double>[]()[]) |
Mean(array<Double>[]()[], Int32, Int32) | Calculates the mean of the values between start and end.

See Also

Statistics Class
Statistics Members
HeuristicLab.DataAnalysis Namespace


Mean Method (List(Double))

Statistics..::.Mean Method (List<(Of <(Double>)>))
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates the mean of all values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Mean(
    List<double> values
)

Parameters

values
Type: System.Collections.Generic..::.List <(Of <( Double >)>)

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Mean(System.Collections.Generic.List{System.Double})]

See Also

Statistics Class
Mean Overload
HeuristicLab.DataAnalysis Namespace


Mean Method (Double[])

Statistics..::.Mean Method (array<Double>[]()[])
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.Statistics.Mean(System.Double[])]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Mean(
    double[] values
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Mean(System.Double[])]

See Also

Statistics Class
Mean Overload
HeuristicLab.DataAnalysis Namespace


Mean Method (Double[], Int32, Int32)

Statistics..::.Mean Method (array<Double>[]()[], Int32, Int32)
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates the mean of the values between start and end.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Mean(
    double[] values,
    int start,
    int end
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

start
Type: System..::.Int32
start index (inclusive)
end
Type: System..::.Int32
end index(exclusive)

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Mean(System.Double[],System.Int32,System.Int32)]

See Also

Statistics Class
Mean Overload
HeuristicLab.DataAnalysis Namespace


Median Method

Statistics..::.Median Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates the median of the values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Median(
    double[] values
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Median(System.Double[])]

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Minimum(T) Method

Statistics..::.Minimum<(Of <(T>)>) Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Minimum returns the smalles entry of values. Throws and exception if values is empty.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static T Minimum<T>(
    IEnumerable<T> values
) where T : struct, new(), IComparable, IComparable<T>

Parameters

values
Type: System.Collections.Generic..::.IEnumerable <(Of <(T>)>)

[Missing <param> documentation for "values"]

Type Parameters

T

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Minimum``1(System.Collections.Generic.IEnumerable{``0})]

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Range Method

[image]

HeuristicLab API Documentation
Statistics..::.Range Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Range(List<(Of <(Double>)>)) | Range calculates the difference between the larges and smallest entry of values.
Range(array<Double>[]()[]) | Range calculates the difference between the larges and smallest entry of values.
Range(array<Double>[]()[], Int32, Int32) | Range calculates the difference between the largest and smallest entry of values between start and end.

See Also

Statistics Class
Statistics Members
HeuristicLab.DataAnalysis Namespace


Range Method (List(Double))

Statistics..::.Range Method (List<(Of <(Double>)>))
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Range calculates the difference between the larges and smallest entry of values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Range(
    List<double> values
)

Parameters

values
Type: System.Collections.Generic..::.List <(Of <( Double >)>)

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Range(System.Collections.Generic.List{System.Double})]

See Also

Statistics Class
Range Overload
HeuristicLab.DataAnalysis Namespace


Range Method (Double[])

Statistics..::.Range Method (array<Double>[]()[])
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Range calculates the difference between the larges and smallest entry of values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Range(
    double[] values
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Range(System.Double[])]

See Also

Statistics Class
Range Overload
HeuristicLab.DataAnalysis Namespace


Range Method (Double[], Int32, Int32)

Statistics..::.Range Method (array<Double>[]()[], Int32, Int32)
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Range calculates the difference between the largest and smallest entry of values between start and end.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Range(
    double[] values,
    int start,
    int end
)

Parameters

values
Type: array< System..::.Double >[]()[]
collection of values
start
Type: System..::.Int32
start index (inclusive)
end
Type: System..::.Int32
end index (exclusive)

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Range(System.Double[],System.Int32,System.Int32)]

See Also

Statistics Class
Range Overload
HeuristicLab.DataAnalysis Namespace


StandardDeviation Method

Statistics..::.StandardDeviation Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates the standard deviation of values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double StandardDeviation(
    double[] values
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.StandardDeviation(System.Double[])]

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Sum Method

Statistics..::.Sum Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

calculates the sum of all values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Sum(
    double[] values
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Sum(System.Double[])]

See Also

Statistics Class
HeuristicLab.DataAnalysis Namespace


Variance Method

[image]

HeuristicLab API Documentation
Statistics..::.Variance Method
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Variance(array<Double>[]()[]) | Calculates the variance of values.
Variance(array<Double>[]()[], Int32, Int32) | Calculates the variance of the entries of values between start and end.

See Also

Statistics Class
Statistics Members
HeuristicLab.DataAnalysis Namespace


Variance Method (Double[])

Statistics..::.Variance Method (array<Double>[]()[])
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates the variance of values.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Variance(
    double[] values
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Variance(System.Double[])]

See Also

Statistics Class
Variance Overload
HeuristicLab.DataAnalysis Namespace


Variance Method (Double[], Int32, Int32)

Statistics..::.Variance Method (array<Double>[]()[], Int32, Int32)
Statistics Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates the variance of the entries of values between start and end.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double Variance(
    double[] values,
    int start,
    int end
)

Parameters

values
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "values"]

start
Type: System..::.Int32
start index (inclusive)
end
Type: System..::.Int32
end index (exclusive)

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.Statistics.Variance(System.Double[],System.Int32,System.Int32)]

See Also

Statistics Class
Variance Overload
HeuristicLab.DataAnalysis Namespace


HeuristicLab.DistributedEngine Namespace

HeuristicLab.DistributedEngine Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.DistributedEngine]

Classes

Class | Description
DistributedEngine |
DistributedEngineEditor |
HeuristicLabDistributedEnginePlugin |


DistributedEngine Class

DistributedEngine Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DistributedEngine.DistributedEngine]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DistributedEngine : EngineBase, IEditable,
    IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.EngineBase
HeuristicLab.DistributedEngine..::.DistributedEngine

See Also

DistributedEngine Members
HeuristicLab.DistributedEngine Namespace


DistributedEngine Members

[image]

HeuristicLab API Documentation
DistributedEngine Members
DistributedEngine Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistributedEngine type exposes the following members.

Constructors

Name | Description
DistributedEngine |

Methods

Name | Description
Abort | (Overrides EngineBase ..::. Abort()()().)
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Overrides EngineBase ..::. Execute()()().)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Overrides EngineBase ..::. ExecuteSteps(Int32).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides EngineBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
Populate | (Overrides EngineBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

Fields

Name | Description
myCanceled | (Inherited from EngineBase.)
myExecutionStack | (Inherited from EngineBase.)
myGlobalScope | (Inherited from EngineBase.)
myOperatorGraph | (Inherited from EngineBase.)
myRunning | (Inherited from EngineBase.)

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
ServerAddress |
Terminated | (Inherited from EngineBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred | (Inherited from EngineBase.)
ExecutionTimeChanged | (Inherited from EngineBase.)
Finished | (Inherited from EngineBase.)
Initialized | (Inherited from EngineBase.)
OperationExecuted | (Inherited from EngineBase.)

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


DistributedEngine Constructor

DistributedEngine Constructor
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedEngine class.

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DistributedEngine()

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


DistributedEngine Methods

[image]

HeuristicLab API Documentation
DistributedEngine Methods
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistributedEngine type exposes the following members.

Methods

Name | Description
Abort | (Overrides EngineBase ..::. Abort()()().)
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Overrides EngineBase ..::. Execute()()().)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Overrides EngineBase ..::. ExecuteSteps(Int32).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides EngineBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
Populate | (Overrides EngineBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


Abort Method

DistributedEngine..::.Abort Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.Abort]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Abort()

Implements

IEngine..::.Abort()()()

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


Clone Method

[image]

HeuristicLab API Documentation
DistributedEngine..::.Clone Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides EngineBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

DistributedEngine Class
DistributedEngine Members
HeuristicLab.DistributedEngine Namespace


Clone Method (IDictionary(Guid, Object))

DistributedEngine..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

DistributedEngine Class
Clone Overload
HeuristicLab.DistributedEngine Namespace


CreateEditor Method

DistributedEngine..::.CreateEditor Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.CreateEditor]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.CreateEditor]

Implements

IEditable..::.CreateEditor()()()

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


CreateView Method

DistributedEngine..::.CreateView Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.CreateView]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


Execute Method

DistributedEngine..::.Execute Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.Execute]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Execute()

Implements

IEngine..::.Execute()()()

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


ExecuteSteps Method

DistributedEngine..::.ExecuteSteps Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.ExecuteSteps(System.Int32)]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void ExecuteSteps(
    int steps
)

Parameters

steps
Type: System..::.Int32

[Missing <param> documentation for "steps"]

Implements

IEngine..::.ExecuteSteps(Int32)

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


GetXmlNode Method

DistributedEngine..::.GetXmlNode Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


Populate Method

DistributedEngine..::.Populate Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


ProcessNextOperation Method

DistributedEngine..::.ProcessNextOperation Method
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngine.ProcessNextOperation]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void ProcessNextOperation()

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


DistributedEngine Properties

[image]

HeuristicLab API Documentation
DistributedEngine Properties
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistributedEngine type exposes the following members.

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
ServerAddress |
Terminated | (Inherited from EngineBase.)

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


ServerAddress Property

DistributedEngine..::.ServerAddress Property
DistributedEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DistributedEngine.DistributedEngine.ServerAddress]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string ServerAddress { get; set; }

See Also

DistributedEngine Class
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Class

DistributedEngineEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DistributedEngine.DistributedEngineEditor]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DistributedEngineEditor : EngineBaseEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.EngineBaseEditor
HeuristicLab.DistributedEngine..::.DistributedEngineEditor

See Also

DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Members

[image]

HeuristicLab API Documentation
DistributedEngineEditor Members
DistributedEngineEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistributedEngineEditor type exposes the following members.

Constructors

Name | Description
DistributedEngineEditor | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from EngineBaseEditor.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from EngineBaseEditor.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EngineBaseEditor ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
abortButton | (Inherited from EngineBaseEditor.)
executeButton | (Inherited from EngineBaseEditor.)
executionTimeLabel | (Inherited from EngineBaseEditor.)
executionTimeTextBox | (Inherited from EngineBaseEditor.)
globalScopeGroupBox | (Inherited from EngineBaseEditor.)
operatorGraphGroupBox | (Inherited from EngineBaseEditor.)
operatorGraphView | (Inherited from EngineBaseEditor.)
resetButton | (Inherited from EngineBaseEditor.)
scopeView | (Inherited from EngineBaseEditor.)
splitContainer1 | (Inherited from EngineBaseEditor.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
DistributedEngine |
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine | (Inherited from EngineBaseEditor.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DistributedEngineEditor Class
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Constructor

[image]

HeuristicLab API Documentation
DistributedEngineEditor Constructor
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DistributedEngineEditor()()() |
DistributedEngineEditor(DistributedEngine) |

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Constructor

DistributedEngineEditor Constructor
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedEngineEditor class.

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DistributedEngineEditor()

See Also

DistributedEngineEditor Class
DistributedEngineEditor Overload
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Constructor (DistributedEngine)

DistributedEngineEditor Constructor (DistributedEngine)
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistributedEngineEditor class.

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DistributedEngineEditor(
    DistributedEngine distributedEngine
)

Parameters

distributedEngine
Type: HeuristicLab.DistributedEngine..::.DistributedEngine

[Missing <param> documentation for "distributedEngine"]

See Also

DistributedEngineEditor Class
DistributedEngineEditor Overload
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Methods

[image]

HeuristicLab API Documentation
DistributedEngineEditor Methods
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistributedEngineEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from EngineBaseEditor.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from EngineBaseEditor.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EngineBaseEditor ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

DistributedEngineEditor Class
HeuristicLab.DistributedEngine Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.AccessibilityNotifyClients Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.BeginInvoke Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.Dispose Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EngineBaseEditor ..::. Dispose(Boolean).)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


Dispose Method (Boolean)

DistributedEngineEditor..::.Dispose Method (Boolean)
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DistributedEngineEditor Class
Dispose Overload
HeuristicLab.DistributedEngine Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.GetChildAtPoint Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.Invalidate Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.Invoke Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.MemberwiseClone Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.PerformLayout Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.ResumeLayout Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.RtlTranslateAlignment Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


Scale Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.Scale Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


Select Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.Select Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.SetBounds Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.UpdateBounds Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


UpdateControls Method

DistributedEngineEditor..::.UpdateControls Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DistributedEngine.DistributedEngineEditor.UpdateControls]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

DistributedEngineEditor Class
HeuristicLab.DistributedEngine Namespace


Validate Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.Validate Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DistributedEngineEditor..::.ValidateChildren Method
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

DistributedEngineEditor Class
DistributedEngineEditor Members
HeuristicLab.DistributedEngine Namespace


DistributedEngineEditor Properties

[image]

HeuristicLab API Documentation
DistributedEngineEditor Properties
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistributedEngineEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
DistributedEngine |
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine | (Inherited from EngineBaseEditor.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

DistributedEngineEditor Class
HeuristicLab.DistributedEngine Namespace


DistributedEngine Property

DistributedEngineEditor..::.DistributedEngine Property
DistributedEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DistributedEngine.DistributedEngineEditor.DistributedEngine]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DistributedEngine DistributedEngine { get; set; }

See Also

DistributedEngineEditor Class
HeuristicLab.DistributedEngine Namespace


HeuristicLabDistributedEnginePlugin Class

HeuristicLabDistributedEnginePlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.DistributedEngine.HeuristicLabDistributedEnginePlugin]

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Grid")]
[ClassInfoAttribute(Name = "HeuristicLab.DistributedEngine")]
[PluginFileAttribute(Filename = "HeuristicLab.DistributedEngine.dll",
    Filetype = PluginFileType.Assembly)]
public class HeuristicLabDistributedEnginePlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.DistributedEngine..::.HeuristicLabDistributedEnginePlugin

See Also

HeuristicLabDistributedEnginePlugin Members
HeuristicLab.DistributedEngine Namespace


HeuristicLabDistributedEnginePlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabDistributedEnginePlugin Members
HeuristicLabDistributedEnginePlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabDistributedEnginePlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabDistributedEnginePlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabDistributedEnginePlugin Class
HeuristicLab.DistributedEngine Namespace


HeuristicLabDistributedEnginePlugin Constructor

HeuristicLabDistributedEnginePlugin Constructor
HeuristicLabDistributedEnginePlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabDistributedEnginePlugin class.

Namespace: HeuristicLab.DistributedEngine
Assembly: HeuristicLab.DistributedEngine (in HeuristicLab.DistributedEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabDistributedEnginePlugin()

See Also

HeuristicLabDistributedEnginePlugin Class
HeuristicLab.DistributedEngine Namespace


HeuristicLab.Evolutionary Namespace

HeuristicLab.Evolutionary Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Evolutionary]

Classes

Class | Description
CrossoverBase |
HeuristicLabEvolutionaryPlugin |
SASEGASAReunificator |
SubScopesStorer |
SuccessRuleMutationStrengthAdjuster |
UnidirectionalRingMigrator |


CrossoverBase Class

CrossoverBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Evolutionary.CrossoverBase]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class CrossoverBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.BitVector..::.BitVectorCrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.RealVector..::.RealVectorCrossoverBase

See Also

CrossoverBase Members
HeuristicLab.Evolutionary Namespace


CrossoverBase Members

[image]

HeuristicLab API Documentation
CrossoverBase Members
CrossoverBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CrossoverBase type exposes the following members.

Constructors

Name | Description
CrossoverBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
HeuristicLab.Evolutionary Namespace


CrossoverBase Constructor

CrossoverBase Constructor
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CrossoverBase class.

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CrossoverBase()

See Also

CrossoverBase Class
HeuristicLab.Evolutionary Namespace


CrossoverBase Methods

[image]

HeuristicLab API Documentation
CrossoverBase Methods
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CrossoverBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CrossoverBase Class
HeuristicLab.Evolutionary Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.AddSubOperator Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


Apply Method

CrossoverBase..::.Apply Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Evolutionary.CrossoverBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Evolutionary.CrossoverBase.Apply(HeuristicLab.Core.IScope)]

See Also

CrossoverBase Class
HeuristicLab.Evolutionary Namespace


Clone Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.Clone Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


Cross Method

CrossoverBase..::.Cross Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Evolutionary.CrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract void Cross(
    IScope scope,
    IRandom random,
    IScope parent1,
    IScope parent2,
    IScope child
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent1"]

parent2
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent2"]

child
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "child"]

See Also

CrossoverBase Class
HeuristicLab.Evolutionary Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.GetVariableValue Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.IsValid Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.TryAddSubOperator Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.TryAddVariable Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.TryAddVariableInfo Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.TryRemoveSubOperator Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.TryRemoveVariable Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CrossoverBase..::.TryRemoveVariableInfo Method
CrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CrossoverBase Class
CrossoverBase Members
HeuristicLab.Evolutionary Namespace


HeuristicLabEvolutionaryPlugin Class

HeuristicLabEvolutionaryPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Evolutionary.HeuristicLabEvolutionaryPlugin]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.Evolutionary")]
[PluginFileAttribute(Filename = "HeuristicLab.Evolutionary.dll", Filetype = PluginFileType.Assembly)]
public class HeuristicLabEvolutionaryPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Evolutionary..::.HeuristicLabEvolutionaryPlugin

See Also

HeuristicLabEvolutionaryPlugin Members
HeuristicLab.Evolutionary Namespace


HeuristicLabEvolutionaryPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabEvolutionaryPlugin Members
HeuristicLabEvolutionaryPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabEvolutionaryPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabEvolutionaryPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabEvolutionaryPlugin Class
HeuristicLab.Evolutionary Namespace


HeuristicLabEvolutionaryPlugin Constructor

HeuristicLabEvolutionaryPlugin Constructor
HeuristicLabEvolutionaryPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabEvolutionaryPlugin class.

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabEvolutionaryPlugin()

See Also

HeuristicLabEvolutionaryPlugin Class
HeuristicLab.Evolutionary Namespace


SASEGASAReunificator Class

SASEGASAReunificator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Evolutionary.SASEGASAReunificator]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SASEGASAReunificator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.SASEGASAReunificator

See Also

SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


SASEGASAReunificator Members

[image]

HeuristicLab API Documentation
SASEGASAReunificator Members
SASEGASAReunificator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SASEGASAReunificator type exposes the following members.

Constructors

Name | Description
SASEGASAReunificator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
HeuristicLab.Evolutionary Namespace


SASEGASAReunificator Constructor

SASEGASAReunificator Constructor
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SASEGASAReunificator class.

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SASEGASAReunificator()

See Also

SASEGASAReunificator Class
HeuristicLab.Evolutionary Namespace


SASEGASAReunificator Methods

[image]

HeuristicLab API Documentation
SASEGASAReunificator Methods
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SASEGASAReunificator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SASEGASAReunificator Class
HeuristicLab.Evolutionary Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.AddSubOperator Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


Apply Method

SASEGASAReunificator..::.Apply Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Evolutionary.SASEGASAReunificator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Evolutionary.SASEGASAReunificator.Apply(HeuristicLab.Core.IScope)]

See Also

SASEGASAReunificator Class
HeuristicLab.Evolutionary Namespace


Clone Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.Clone Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.GetVariableValue Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.IsValid Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.TryAddSubOperator Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.TryAddVariable Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.TryAddVariableInfo Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.TryRemoveSubOperator Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.TryRemoveVariable Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SASEGASAReunificator..::.TryRemoveVariableInfo Method
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
SASEGASAReunificator Members
HeuristicLab.Evolutionary Namespace


SASEGASAReunificator Properties

[image]

HeuristicLab API Documentation
SASEGASAReunificator Properties
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SASEGASAReunificator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SASEGASAReunificator Class
HeuristicLab.Evolutionary Namespace


Description Property

SASEGASAReunificator..::.Description Property
SASEGASAReunificator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Evolutionary.SASEGASAReunificator.Description]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SASEGASAReunificator Class
HeuristicLab.Evolutionary Namespace


SubScopesStorer Class

SubScopesStorer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Evolutionary.SubScopesStorer]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubScopesStorer : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.SubScopesStorer

See Also

SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


SubScopesStorer Members

[image]

HeuristicLab API Documentation
SubScopesStorer Members
SubScopesStorer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesStorer type exposes the following members.

Constructors

Name | Description
SubScopesStorer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
HeuristicLab.Evolutionary Namespace


SubScopesStorer Constructor

SubScopesStorer Constructor
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubScopesStorer class.

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubScopesStorer()

See Also

SubScopesStorer Class
HeuristicLab.Evolutionary Namespace


SubScopesStorer Methods

[image]

HeuristicLab API Documentation
SubScopesStorer Methods
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesStorer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SubScopesStorer Class
HeuristicLab.Evolutionary Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.AddSubOperator Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


Apply Method

SubScopesStorer..::.Apply Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Evolutionary.SubScopesStorer.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Evolutionary.SubScopesStorer.Apply(HeuristicLab.Core.IScope)]

See Also

SubScopesStorer Class
HeuristicLab.Evolutionary Namespace


Clone Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.Clone Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.GetVariableValue Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.IsValid Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.TryAddSubOperator Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.TryAddVariable Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.TryAddVariableInfo Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.TryRemoveSubOperator Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.TryRemoveVariable Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SubScopesStorer..::.TryRemoveVariableInfo Method
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
SubScopesStorer Members
HeuristicLab.Evolutionary Namespace


SubScopesStorer Properties

[image]

HeuristicLab API Documentation
SubScopesStorer Properties
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesStorer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SubScopesStorer Class
HeuristicLab.Evolutionary Namespace


Description Property

SubScopesStorer..::.Description Property
SubScopesStorer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Evolutionary.SubScopesStorer.Description]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SubScopesStorer Class
HeuristicLab.Evolutionary Namespace


SuccessRuleMutationStrengthAdjuster Class

SuccessRuleMutationStrengthAdjuster Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Evolutionary.SuccessRuleMutationStrengthAdjuster]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SuccessRuleMutationStrengthAdjuster : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.SuccessRuleMutationStrengthAdjuster

See Also

SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


SuccessRuleMutationStrengthAdjuster Members

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster Members
SuccessRuleMutationStrengthAdjuster Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SuccessRuleMutationStrengthAdjuster type exposes the following members.

Constructors

Name | Description
SuccessRuleMutationStrengthAdjuster |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
HeuristicLab.Evolutionary Namespace


SuccessRuleMutationStrengthAdjuster Constructor

SuccessRuleMutationStrengthAdjuster Constructor
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SuccessRuleMutationStrengthAdjuster class.

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SuccessRuleMutationStrengthAdjuster()

See Also

SuccessRuleMutationStrengthAdjuster Class
HeuristicLab.Evolutionary Namespace


SuccessRuleMutationStrengthAdjuster Methods

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster Methods
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SuccessRuleMutationStrengthAdjuster type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SuccessRuleMutationStrengthAdjuster Class
HeuristicLab.Evolutionary Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.AddSubOperator Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


Apply Method

SuccessRuleMutationStrengthAdjuster..::.Apply Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Evolutionary.SuccessRuleMutationStrengthAdjuster.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Evolutionary.SuccessRuleMutationStrengthAdjuster.Apply(HeuristicLab.Core.IScope)]

See Also

SuccessRuleMutationStrengthAdjuster Class
HeuristicLab.Evolutionary Namespace


Clone Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.Clone Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.GetVariableValue Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.IsValid Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.TryAddSubOperator Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.TryAddVariable Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.TryAddVariableInfo Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.TryRemoveSubOperator Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.TryRemoveVariable Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster..::.TryRemoveVariableInfo Method
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
SuccessRuleMutationStrengthAdjuster Members
HeuristicLab.Evolutionary Namespace


SuccessRuleMutationStrengthAdjuster Properties

[image]

HeuristicLab API Documentation
SuccessRuleMutationStrengthAdjuster Properties
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SuccessRuleMutationStrengthAdjuster type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SuccessRuleMutationStrengthAdjuster Class
HeuristicLab.Evolutionary Namespace


Description Property

SuccessRuleMutationStrengthAdjuster..::.Description Property
SuccessRuleMutationStrengthAdjuster Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Evolutionary.SuccessRuleMutationStrengthAdjuster.Description]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SuccessRuleMutationStrengthAdjuster Class
HeuristicLab.Evolutionary Namespace


UnidirectionalRingMigrator Class

UnidirectionalRingMigrator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Evolutionary.UnidirectionalRingMigrator]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UnidirectionalRingMigrator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.UnidirectionalRingMigrator

See Also

UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


UnidirectionalRingMigrator Members

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator Members
UnidirectionalRingMigrator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UnidirectionalRingMigrator type exposes the following members.

Constructors

Name | Description
UnidirectionalRingMigrator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
HeuristicLab.Evolutionary Namespace


UnidirectionalRingMigrator Constructor

UnidirectionalRingMigrator Constructor
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UnidirectionalRingMigrator class.

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UnidirectionalRingMigrator()

See Also

UnidirectionalRingMigrator Class
HeuristicLab.Evolutionary Namespace


UnidirectionalRingMigrator Methods

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator Methods
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UnidirectionalRingMigrator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UnidirectionalRingMigrator Class
HeuristicLab.Evolutionary Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.AddSubOperator Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


Apply Method

UnidirectionalRingMigrator..::.Apply Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Evolutionary.UnidirectionalRingMigrator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Evolutionary.UnidirectionalRingMigrator.Apply(HeuristicLab.Core.IScope)]

See Also

UnidirectionalRingMigrator Class
HeuristicLab.Evolutionary Namespace


Clone Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.Clone Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.GetVariableValue Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.IsValid Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.TryAddSubOperator Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.TryAddVariable Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.TryAddVariableInfo Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.TryRemoveSubOperator Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.TryRemoveVariable Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator..::.TryRemoveVariableInfo Method
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
UnidirectionalRingMigrator Members
HeuristicLab.Evolutionary Namespace


UnidirectionalRingMigrator Properties

[image]

HeuristicLab API Documentation
UnidirectionalRingMigrator Properties
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UnidirectionalRingMigrator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UnidirectionalRingMigrator Class
HeuristicLab.Evolutionary Namespace


Description Property

UnidirectionalRingMigrator..::.Description Property
UnidirectionalRingMigrator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Evolutionary.UnidirectionalRingMigrator.Description]

Namespace: HeuristicLab.Evolutionary
Assembly: HeuristicLab.Evolutionary (in HeuristicLab.Evolutionary.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UnidirectionalRingMigrator Class
HeuristicLab.Evolutionary Namespace


HeuristicLab.Functions Namespace

HeuristicLab.Functions Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Functions]

Classes

Class | Description
Addition |
And |
Average |
Constant |
Cosinus |
Division |
Equal |
Exponential |
FunctionBase |
FunctionView |
HeuristicLabFunctionsPlugin |
IfThenElse |
LessThan |
Logarithm |
Multiplication |
Not |
Or |
Power |
Signum |
Sinus |
Sqrt |
Substraction |
Tangens |
Variable |
Xor |

Interfaces

Interface | Description
IFunction |
IFunctionVisitor |


Addition Class

Addition Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Addition]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Addition : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Addition

See Also

Addition Members
HeuristicLab.Functions Namespace


Addition Members

[image]

HeuristicLab API Documentation
Addition Members
Addition Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Addition type exposes the following members.

Constructors

Name | Description
Addition | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Addition Class
HeuristicLab.Functions Namespace


Addition Constructor

[image]

HeuristicLab API Documentation
Addition Constructor
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Addition()()() |
Addition(Addition, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


Addition Constructor

Addition Constructor
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Addition class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Addition()

See Also

Addition Class
Addition Overload
HeuristicLab.Functions Namespace


Addition Constructor (Addition, IDictionary(Guid, Object))

Addition Constructor (Addition, IDictionary<(Of <(Guid, Object>)>))
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Addition class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Addition(
    Addition source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Addition

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Addition Class
Addition Overload
HeuristicLab.Functions Namespace


Addition Methods

[image]

HeuristicLab API Documentation
Addition Methods
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Addition type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Addition Class
HeuristicLab.Functions Namespace


Accept Method

Addition..::.Accept Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Addition.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Addition Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Addition..::.AddSubOperator Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Addition..::.Clone Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Addition..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Addition.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Addition.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Addition Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Addition..::.Evaluate Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Addition.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Addition.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Addition Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Addition..::.GetVariableValue Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Addition..::.IsValid Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Addition..::.TryAddSubOperator Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Addition..::.TryAddVariable Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Addition..::.TryAddVariableInfo Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Addition..::.TryRemoveSubOperator Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Addition..::.TryRemoveVariable Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Addition..::.TryRemoveVariableInfo Method
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Addition Class
Addition Members
HeuristicLab.Functions Namespace


Addition Properties

[image]

HeuristicLab API Documentation
Addition Properties
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Addition type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Addition Class
HeuristicLab.Functions Namespace


Description Property

Addition..::.Description Property
Addition Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Addition.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Addition Class
HeuristicLab.Functions Namespace


And Class

And Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.And]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class And : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.And

See Also

And Members
HeuristicLab.Functions Namespace


And Members

[image]

HeuristicLab API Documentation
And Members
And Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The And type exposes the following members.

Constructors

Name | Description
And | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

And Class
HeuristicLab.Functions Namespace


And Constructor

[image]

HeuristicLab API Documentation
And Constructor
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
And()()() |
And(And, IDictionary<(Of <(Guid, Object>)>)) |

See Also

And Class
And Members
HeuristicLab.Functions Namespace


And Constructor

And Constructor
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the And class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public And()

See Also

And Class
And Overload
HeuristicLab.Functions Namespace


And Constructor (And, IDictionary(Guid, Object))

And Constructor (And, IDictionary<(Of <(Guid, Object>)>))
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the And class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public And(
    And source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.And

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

And Class
And Overload
HeuristicLab.Functions Namespace


And Methods

[image]

HeuristicLab API Documentation
And Methods
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The And type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

And Class
HeuristicLab.Functions Namespace


Accept Method

And..::.Accept Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.And.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

And Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
And..::.AddSubOperator Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
And..::.Clone Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

And..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.And.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.And.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

And Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

And..::.Evaluate Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.And.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.And.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

And Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
And..::.GetVariableValue Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
And..::.IsValid Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
And..::.TryAddSubOperator Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
And..::.TryAddVariable Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
And..::.TryAddVariableInfo Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
And..::.TryRemoveSubOperator Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
And..::.TryRemoveVariable Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
And..::.TryRemoveVariableInfo Method
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

And Class
And Members
HeuristicLab.Functions Namespace


And Properties

[image]

HeuristicLab API Documentation
And Properties
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The And type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

And Class
HeuristicLab.Functions Namespace


Description Property

And..::.Description Property
And Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.And.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

And Class
HeuristicLab.Functions Namespace


Average Class

Average Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Average]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Average : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Average

See Also

Average Members
HeuristicLab.Functions Namespace


Average Members

[image]

HeuristicLab API Documentation
Average Members
Average Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Average type exposes the following members.

Constructors

Name | Description
Average | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Average Class
HeuristicLab.Functions Namespace


Average Constructor

[image]

HeuristicLab API Documentation
Average Constructor
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Average()()() |
Average(Average, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


Average Constructor

Average Constructor
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Average class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Average()

See Also

Average Class
Average Overload
HeuristicLab.Functions Namespace


Average Constructor (Average, IDictionary(Guid, Object))

Average Constructor (Average, IDictionary<(Of <(Guid, Object>)>))
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Average class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Average(
    Average source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Average

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Average Class
Average Overload
HeuristicLab.Functions Namespace


Average Methods

[image]

HeuristicLab API Documentation
Average Methods
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Average type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Average Class
HeuristicLab.Functions Namespace


Accept Method

Average..::.Accept Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Average.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Average Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Average..::.AddSubOperator Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Average..::.Clone Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Average..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Average.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Average.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Average Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Average..::.Evaluate Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Average.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Average.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Average Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Average..::.GetVariableValue Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Average..::.IsValid Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Average..::.TryAddSubOperator Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Average..::.TryAddVariable Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Average..::.TryAddVariableInfo Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Average..::.TryRemoveSubOperator Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Average..::.TryRemoveVariable Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Average..::.TryRemoveVariableInfo Method
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Average Class
Average Members
HeuristicLab.Functions Namespace


Average Properties

[image]

HeuristicLab API Documentation
Average Properties
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Average type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Average Class
HeuristicLab.Functions Namespace


Description Property

Average..::.Description Property
Average Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Average.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Average Class
HeuristicLab.Functions Namespace


Constant Class

Constant Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Constant]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Constant : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Constant

See Also

Constant Members
HeuristicLab.Functions Namespace


Constant Members

[image]

HeuristicLab API Documentation
Constant Members
Constant Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Constant type exposes the following members.

Constructors

Name | Description
Constant | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides FunctionBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
Value |
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Constant Class
HeuristicLab.Functions Namespace


Constant Constructor

[image]

HeuristicLab API Documentation
Constant Constructor
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Constant()()() |
Constant(Constant, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


Constant Constructor

Constant Constructor
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Constant class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Constant()

See Also

Constant Class
Constant Overload
HeuristicLab.Functions Namespace


Constant Constructor (Constant, IDictionary(Guid, Object))

Constant Constructor (Constant, IDictionary<(Of <(Guid, Object>)>))
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Constant class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Constant(
    Constant source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Constant

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Constant Class
Constant Overload
HeuristicLab.Functions Namespace


Constant Methods

[image]

HeuristicLab API Documentation
Constant Methods
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Constant type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides FunctionBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Constant Class
HeuristicLab.Functions Namespace


Accept Method

Constant..::.Accept Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Constant.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Constant Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Constant..::.AddSubOperator Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Constant..::.Clone Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Constant..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Constant.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Constant.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Constant Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Constant..::.Evaluate Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Constant.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Constant.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Constant Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Constant..::.GetVariableValue Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Constant..::.IsValid Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


Populate Method

Constant..::.Populate Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Constant.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Constant Class
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Constant..::.TryAddSubOperator Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Constant..::.TryAddVariable Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Constant..::.TryAddVariableInfo Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Constant..::.TryRemoveSubOperator Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Constant..::.TryRemoveVariable Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Constant..::.TryRemoveVariableInfo Method
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Constant Class
Constant Members
HeuristicLab.Functions Namespace


Constant Properties

[image]

HeuristicLab API Documentation
Constant Properties
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Constant type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
Value |
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Constant Class
HeuristicLab.Functions Namespace


Description Property

Constant..::.Description Property
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Constant.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Constant Class
HeuristicLab.Functions Namespace


Value Property

Constant..::.Value Property
Constant Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Constant.Value]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConstrainedDoubleData Value { get; }

See Also

Constant Class
HeuristicLab.Functions Namespace


Cosinus Class

Cosinus Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Cosinus]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Cosinus : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Cosinus

See Also

Cosinus Members
HeuristicLab.Functions Namespace


Cosinus Members

[image]

HeuristicLab API Documentation
Cosinus Members
Cosinus Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Cosinus type exposes the following members.

Constructors

Name | Description
Cosinus | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Cosinus Class
HeuristicLab.Functions Namespace


Cosinus Constructor

[image]

HeuristicLab API Documentation
Cosinus Constructor
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cosinus()()() |
Cosinus(Cosinus, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


Cosinus Constructor

Cosinus Constructor
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Cosinus class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Cosinus()

See Also

Cosinus Class
Cosinus Overload
HeuristicLab.Functions Namespace


Cosinus Constructor (Cosinus, IDictionary(Guid, Object))

Cosinus Constructor (Cosinus, IDictionary<(Of <(Guid, Object>)>))
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Cosinus class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Cosinus(
    Cosinus source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Cosinus

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Cosinus Class
Cosinus Overload
HeuristicLab.Functions Namespace


Cosinus Methods

[image]

HeuristicLab API Documentation
Cosinus Methods
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Cosinus type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Cosinus Class
HeuristicLab.Functions Namespace


Accept Method

Cosinus..::.Accept Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Cosinus.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Cosinus Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Cosinus..::.AddSubOperator Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Cosinus..::.Clone Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Cosinus..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Cosinus.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Cosinus.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Cosinus Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Cosinus..::.Evaluate Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Cosinus.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Cosinus.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Cosinus Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Cosinus..::.GetVariableValue Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Cosinus..::.IsValid Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Cosinus..::.TryAddSubOperator Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Cosinus..::.TryAddVariable Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Cosinus..::.TryAddVariableInfo Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Cosinus..::.TryRemoveSubOperator Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Cosinus..::.TryRemoveVariable Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Cosinus..::.TryRemoveVariableInfo Method
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Cosinus Class
Cosinus Members
HeuristicLab.Functions Namespace


Cosinus Properties

[image]

HeuristicLab API Documentation
Cosinus Properties
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Cosinus type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Cosinus Class
HeuristicLab.Functions Namespace


Description Property

Cosinus..::.Description Property
Cosinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Cosinus.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Cosinus Class
HeuristicLab.Functions Namespace


Division Class

Division Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Division]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Division : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Division

See Also

Division Members
HeuristicLab.Functions Namespace


Division Members

[image]

HeuristicLab API Documentation
Division Members
Division Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Division type exposes the following members.

Constructors

Name | Description
Division | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Division Class
HeuristicLab.Functions Namespace


Division Constructor

[image]

HeuristicLab API Documentation
Division Constructor
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Division()()() |
Division(Division, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


Division Constructor

Division Constructor
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Division class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Division()

See Also

Division Class
Division Overload
HeuristicLab.Functions Namespace


Division Constructor (Division, IDictionary(Guid, Object))

Division Constructor (Division, IDictionary<(Of <(Guid, Object>)>))
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Division class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Division(
    Division source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Division

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Division Class
Division Overload
HeuristicLab.Functions Namespace


Division Methods

[image]

HeuristicLab API Documentation
Division Methods
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Division type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Division Class
HeuristicLab.Functions Namespace


Accept Method

Division..::.Accept Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Division.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Division Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Division..::.AddSubOperator Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Division..::.Clone Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Division..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Division.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Division.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Division Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Division..::.Evaluate Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Division.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Division.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Division Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Division..::.GetVariableValue Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Division..::.IsValid Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Division..::.TryAddSubOperator Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Division..::.TryAddVariable Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Division..::.TryAddVariableInfo Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Division..::.TryRemoveSubOperator Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Division..::.TryRemoveVariable Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Division..::.TryRemoveVariableInfo Method
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Division Class
Division Members
HeuristicLab.Functions Namespace


Division Properties

[image]

HeuristicLab API Documentation
Division Properties
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Division type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Division Class
HeuristicLab.Functions Namespace


Description Property

Division..::.Description Property
Division Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Division.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Division Class
HeuristicLab.Functions Namespace


Equal Class

Equal Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Equal]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Equal : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Equal

See Also

Equal Members
HeuristicLab.Functions Namespace


Equal Members

[image]

HeuristicLab API Documentation
Equal Members
Equal Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Equal type exposes the following members.

Constructors

Name | Description
Equal | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Equal Class
HeuristicLab.Functions Namespace


Equal Constructor

[image]

HeuristicLab API Documentation
Equal Constructor
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equal()()() |
Equal(Equal, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


Equal Constructor

Equal Constructor
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Equal class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Equal()

See Also

Equal Class
Equal Overload
HeuristicLab.Functions Namespace


Equal Constructor (Equal, IDictionary(Guid, Object))

Equal Constructor (Equal, IDictionary<(Of <(Guid, Object>)>))
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Equal class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Equal(
    Equal source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Equal

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Equal Class
Equal Overload
HeuristicLab.Functions Namespace


Equal Methods

[image]

HeuristicLab API Documentation
Equal Methods
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Equal type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Equal Class
HeuristicLab.Functions Namespace


Accept Method

Equal..::.Accept Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Equal.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Equal Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Equal..::.AddSubOperator Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Equal..::.Clone Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Equal..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Equal.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Equal.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Equal Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Equal..::.Evaluate Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Equal.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Equal.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Equal Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Equal..::.GetVariableValue Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Equal..::.IsValid Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Equal..::.TryAddSubOperator Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Equal..::.TryAddVariable Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Equal..::.TryAddVariableInfo Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Equal..::.TryRemoveSubOperator Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Equal..::.TryRemoveVariable Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Equal..::.TryRemoveVariableInfo Method
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Equal Class
Equal Members
HeuristicLab.Functions Namespace


Equal Properties

[image]

HeuristicLab API Documentation
Equal Properties
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Equal type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Equal Class
HeuristicLab.Functions Namespace


Description Property

Equal..::.Description Property
Equal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Equal.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Equal Class
HeuristicLab.Functions Namespace


Exponential Class

Exponential Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Exponential]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Exponential : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Exponential

See Also

Exponential Members
HeuristicLab.Functions Namespace


Exponential Members

[image]

HeuristicLab API Documentation
Exponential Members
Exponential Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Exponential type exposes the following members.

Constructors

Name | Description
Exponential | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Exponential Class
HeuristicLab.Functions Namespace


Exponential Constructor

[image]

HeuristicLab API Documentation
Exponential Constructor
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Exponential()()() |
Exponential(Exponential, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


Exponential Constructor

Exponential Constructor
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exponential class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Exponential()

See Also

Exponential Class
Exponential Overload
HeuristicLab.Functions Namespace


Exponential Constructor (Exponential, IDictionary(Guid, Object))

Exponential Constructor (Exponential, IDictionary<(Of <(Guid, Object>)>))
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Exponential class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Exponential(
    Exponential source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Exponential

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Exponential Class
Exponential Overload
HeuristicLab.Functions Namespace


Exponential Methods

[image]

HeuristicLab API Documentation
Exponential Methods
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Exponential type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Exponential Class
HeuristicLab.Functions Namespace


Accept Method

Exponential..::.Accept Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Exponential.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Exponential Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Exponential..::.AddSubOperator Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Exponential..::.Clone Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Exponential..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Exponential.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Exponential.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Exponential Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Exponential..::.Evaluate Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Exponential.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Exponential.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Exponential Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Exponential..::.GetVariableValue Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Exponential..::.IsValid Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Exponential..::.TryAddSubOperator Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Exponential..::.TryAddVariable Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Exponential..::.TryAddVariableInfo Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Exponential..::.TryRemoveSubOperator Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Exponential..::.TryRemoveVariable Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Exponential..::.TryRemoveVariableInfo Method
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Exponential Class
Exponential Members
HeuristicLab.Functions Namespace


Exponential Properties

[image]

HeuristicLab API Documentation
Exponential Properties
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Exponential type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Exponential Class
HeuristicLab.Functions Namespace


Description Property

Exponential..::.Description Property
Exponential Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Exponential.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Exponential Class
HeuristicLab.Functions Namespace


FunctionBase Class

FunctionBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.FunctionBase]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class FunctionBase : OperatorBase, IFunction,
    IOperator, IConstrainedItem, IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Constant
HeuristicLab.Functions..::.Or
HeuristicLab.Functions..::.Power
HeuristicLab.Functions..::.Not
HeuristicLab.Functions..::.Logarithm
HeuristicLab.Functions..::.IfThenElse
HeuristicLab.Functions..::.Variable
HeuristicLab.Functions..::.LessThan
HeuristicLab.Functions..::.Sinus
HeuristicLab.Functions..::.Signum
HeuristicLab.Functions..::.Substraction
HeuristicLab.Functions..::.Equal
HeuristicLab.Functions..::.Multiplication
HeuristicLab.Functions..::.Xor
HeuristicLab.Functions..::.Division
HeuristicLab.Functions..::.Exponential
HeuristicLab.Functions..::.And
HeuristicLab.Functions..::.Cosinus
HeuristicLab.Functions..::.Addition
HeuristicLab.Functions..::.Tangens
HeuristicLab.Functions..::.Sqrt
HeuristicLab.Functions..::.Average

See Also

FunctionBase Members
HeuristicLab.Functions Namespace


FunctionBase Members

[image]

HeuristicLab API Documentation
FunctionBase Members
FunctionBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionBase type exposes the following members.

Constructors

Name | Description
FunctionBase | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept |
AddConstraint | (Overrides ConstrainedItemBase ..::. AddConstraint(IConstraint).)
AddLocalVariable |
AddSubOperator | Overloaded.
AddVariable | (Overrides OperatorBase ..::. AddVariable(IVariable).)
AddVariableInfo | (Overrides OperatorBase ..::. AddVariableInfo(IVariableInfo).)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate |
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Overrides OperatorBase ..::. GetVariable(String).)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Overrides ConstrainedItemBase ..::. RemoveConstraint(IConstraint).)
RemoveSubOperator | (Overrides OperatorBase ..::. RemoveSubOperator(Int32).)
RemoveVariable | (Overrides OperatorBase ..::. RemoveVariable(String).)
RemoveVariableInfo | (Overrides OperatorBase ..::. RemoveVariableInfo(String).)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Overrides ConstrainedItemBase ..::. Constraints.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
LocalVariables |
MetaObject |
Name | (Inherited from OperatorBase.)
SubFunctions |
SubOperators | (Overrides OperatorBase ..::. SubOperators.)
VariableInfos | (Overrides OperatorBase ..::. VariableInfos.)
Variables | (Overrides OperatorBase ..::. Variables.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


FunctionBase Constructor

[image]

HeuristicLab API Documentation
FunctionBase Constructor
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FunctionBase()()() |
FunctionBase(FunctionBase, IDictionary<(Of <(Guid, Object>)>)) |

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


FunctionBase Constructor

FunctionBase Constructor
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FunctionBase class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FunctionBase()

See Also

FunctionBase Class
FunctionBase Overload
HeuristicLab.Functions Namespace


FunctionBase Constructor (FunctionBase, IDictionary(Guid, Object))

FunctionBase Constructor (FunctionBase, IDictionary<(Of <(Guid, Object>)>))
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FunctionBase class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FunctionBase(
    FunctionBase source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.FunctionBase

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

FunctionBase Class
FunctionBase Overload
HeuristicLab.Functions Namespace


FunctionBase Methods

[image]

HeuristicLab API Documentation
FunctionBase Methods
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept |
AddConstraint | (Overrides ConstrainedItemBase ..::. AddConstraint(IConstraint).)
AddLocalVariable |
AddSubOperator | Overloaded.
AddVariable | (Overrides OperatorBase ..::. AddVariable(IVariable).)
AddVariableInfo | (Overrides OperatorBase ..::. AddVariableInfo(IVariableInfo).)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate |
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Overrides OperatorBase ..::. GetVariable(String).)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Overrides ConstrainedItemBase ..::. RemoveConstraint(IConstraint).)
RemoveSubOperator | (Overrides OperatorBase ..::. RemoveSubOperator(Int32).)
RemoveVariable | (Overrides OperatorBase ..::. RemoveVariable(String).)
RemoveVariableInfo | (Overrides OperatorBase ..::. RemoveVariableInfo(String).)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


Accept Method

FunctionBase..::.Accept Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


AddConstraint Method

FunctionBase..::.AddConstraint Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.AddConstraint(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddConstraint(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstrainedItem..::.AddConstraint(IConstraint)
IConstrainedItem..::.AddConstraint(IConstraint)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


AddLocalVariable Method

FunctionBase..::.AddLocalVariable Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.AddLocalVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AddLocalVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
FunctionBase..::.AddSubOperator Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Overrides OperatorBase ..::. AddSubOperator(IOperator).)
AddSubOperator(IOperator, Int32) | (Overrides OperatorBase ..::. AddSubOperator(IOperator, Int32).)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


AddSubOperator Method (IOperator)

FunctionBase..::.AddSubOperator Method (IOperator)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.AddSubOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddSubOperator(
    IOperator subOperator
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

Implements

IOperator..::.AddSubOperator(IOperator)
IOperator..::.AddSubOperator(IOperator)

See Also

FunctionBase Class
AddSubOperator Overload
HeuristicLab.Functions Namespace


AddSubOperator Method (IOperator, Int32)

FunctionBase..::.AddSubOperator Method (IOperator, Int32)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.AddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddSubOperator(
    IOperator subOperator,
    int index
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Implements

IOperator..::.AddSubOperator(IOperator, Int32)
IOperator..::.AddSubOperator(IOperator, Int32)

See Also

FunctionBase Class
AddSubOperator Overload
HeuristicLab.Functions Namespace


AddVariable Method

FunctionBase..::.AddVariable Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.AddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

Implements

IOperator..::.AddVariable(IVariable)
IOperator..::.AddVariable(IVariable)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


AddVariableInfo Method

FunctionBase..::.AddVariableInfo Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.AddVariableInfo(HeuristicLab.Core.IVariableInfo)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddVariableInfo(
    IVariableInfo variableInfo
)

Parameters

variableInfo
Type: HeuristicLab.Core..::.IVariableInfo

[Missing <param> documentation for "variableInfo"]

Implements

IOperator..::.AddVariableInfo(IVariableInfo)
IOperator..::.AddVariableInfo(IVariableInfo)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


Apply Method

FunctionBase..::.Apply Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.Apply(HeuristicLab.Core.IScope)]

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
FunctionBase..::.Clone Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


CreateView Method

FunctionBase..::.CreateView Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.CreateView]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


Evaluate Method

FunctionBase..::.Evaluate Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


GetVariable Method

FunctionBase..::.GetVariable Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.GetVariable(System.String)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IVariable GetVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.GetVariable(System.String)]

Implements

IOperator..::.GetVariable(String)
IOperator..::.GetVariable(String)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
FunctionBase..::.GetVariableValue Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Overrides OperatorBase ..::. GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean).)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


GetVariableValue Method (String, IScope, Boolean, Boolean)

FunctionBase..::.GetVariableValue Method (String, IScope, Boolean, Boolean)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IItem GetVariableValue(
    string formalName,
    IScope scope,
    bool recursiveLookup,
    bool throwOnError
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

recursiveLookup
Type: System..::.Boolean

[Missing <param> documentation for "recursiveLookup"]

throwOnError
Type: System..::.Boolean

[Missing <param> documentation for "throwOnError"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.GetVariableValue(System.String,HeuristicLab.Core.IScope,System.Boolean,System.Boolean)]

See Also

FunctionBase Class
GetVariableValue Overload
HeuristicLab.Functions Namespace


GetXmlNode Method

FunctionBase..::.GetXmlNode Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
FunctionBase..::.IsValid Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


Populate Method

FunctionBase..::.Populate Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


RemoveConstraint Method

FunctionBase..::.RemoveConstraint Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.RemoveConstraint(HeuristicLab.Core.IConstraint)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveConstraint(
    IConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Core..::.IConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstrainedItem..::.RemoveConstraint(IConstraint)
IConstrainedItem..::.RemoveConstraint(IConstraint)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


RemoveSubOperator Method

FunctionBase..::.RemoveSubOperator Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.RemoveSubOperator(System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveSubOperator(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Implements

IOperator..::.RemoveSubOperator(Int32)
IOperator..::.RemoveSubOperator(Int32)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


RemoveVariable Method

FunctionBase..::.RemoveVariable Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.RemoveVariable(System.String)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Implements

IOperator..::.RemoveVariable(String)
IOperator..::.RemoveVariable(String)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


RemoveVariableInfo Method

FunctionBase..::.RemoveVariableInfo Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.RemoveVariableInfo(System.String)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveVariableInfo(
    string formalName
)

Parameters

formalName
Type: System..::.String

[Missing <param> documentation for "formalName"]

Implements

IOperator..::.RemoveVariableInfo(String)
IOperator..::.RemoveVariableInfo(String)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
FunctionBase..::.TryAddSubOperator Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Overrides OperatorBase ..::. TryAddSubOperator(IOperator).)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Overrides OperatorBase ..::. TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%).)
TryAddSubOperator(IOperator, Int32) | (Overrides OperatorBase ..::. TryAddSubOperator(IOperator, Int32).)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Overrides OperatorBase ..::. TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%).)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method (IOperator)

FunctionBase..::.TryAddSubOperator Method (IOperator)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool TryAddSubOperator(
    IOperator subOperator
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator)]

Implements

IOperator..::.TryAddSubOperator(IOperator)
IOperator..::.TryAddSubOperator(IOperator)

See Also

FunctionBase Class
TryAddSubOperator Overload
HeuristicLab.Functions Namespace


TryAddSubOperator Method (IOperator, ICollection(IConstraint) )

FunctionBase..::.TryAddSubOperator Method (IOperator, ICollection<(Of <(IConstraint>)>) %)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool TryAddSubOperator(
    IOperator subOperator,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%)
IOperator..::.TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%)

See Also

FunctionBase Class
TryAddSubOperator Overload
HeuristicLab.Functions Namespace


TryAddSubOperator Method (IOperator, Int32)

FunctionBase..::.TryAddSubOperator Method (IOperator, Int32)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool TryAddSubOperator(
    IOperator subOperator,
    int index
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32)]

Implements

IOperator..::.TryAddSubOperator(IOperator, Int32)
IOperator..::.TryAddSubOperator(IOperator, Int32)

See Also

FunctionBase Class
TryAddSubOperator Overload
HeuristicLab.Functions Namespace


TryAddSubOperator Method (IOperator, Int32, ICollection(IConstraint) )

FunctionBase..::.TryAddSubOperator Method (IOperator, Int32, ICollection<(Of <(IConstraint>)>) %)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool TryAddSubOperator(
    IOperator subOperator,
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

subOperator
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "subOperator"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.TryAddSubOperator(HeuristicLab.Core.IOperator,System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%)
IOperator..::.TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%)

See Also

FunctionBase Class
TryAddSubOperator Overload
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
FunctionBase..::.TryAddVariable Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
FunctionBase..::.TryAddVariableInfo Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
FunctionBase..::.TryRemoveSubOperator Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Overrides OperatorBase ..::. TryRemoveSubOperator(Int32).)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Overrides OperatorBase ..::. TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%).)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method (Int32)

FunctionBase..::.TryRemoveSubOperator Method (Int32)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.TryRemoveSubOperator(System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool TryRemoveSubOperator(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.TryRemoveSubOperator(System.Int32)]

Implements

IOperator..::.TryRemoveSubOperator(Int32)
IOperator..::.TryRemoveSubOperator(Int32)

See Also

FunctionBase Class
TryRemoveSubOperator Overload
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method (Int32, ICollection(IConstraint) )

FunctionBase..::.TryRemoveSubOperator Method (Int32, ICollection<(Of <(IConstraint>)>) %)
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionBase.TryRemoveSubOperator(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool TryRemoveSubOperator(
    int index,
    out ICollection<IConstraint> violatedConstraints
)

Parameters

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

violatedConstraints
Type: System.Collections.Generic..::.ICollection <(Of <( IConstraint >)>) %

[Missing <param> documentation for "violatedConstraints"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.FunctionBase.TryRemoveSubOperator(System.Int32,System.Collections.Generic.ICollection{HeuristicLab.Core.IConstraint}@)]

Implements

IOperator..::.TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%)
IOperator..::.TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%)

See Also

FunctionBase Class
TryRemoveSubOperator Overload
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
FunctionBase..::.TryRemoveVariable Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
FunctionBase..::.TryRemoveVariableInfo Method
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionBase Class
FunctionBase Members
HeuristicLab.Functions Namespace


FunctionBase Properties

[image]

HeuristicLab API Documentation
FunctionBase Properties
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionBase type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Overrides ConstrainedItemBase ..::. Constraints.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
LocalVariables |
MetaObject |
Name | (Inherited from OperatorBase.)
SubFunctions |
SubOperators | (Overrides OperatorBase ..::. SubOperators.)
VariableInfos | (Overrides OperatorBase ..::. VariableInfos.)
Variables | (Overrides OperatorBase ..::. Variables.)

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


Constraints Property

FunctionBase..::.Constraints Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.Constraints]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override ICollection<IConstraint> Constraints { get; }

Implements

IConstrainedItem..::.Constraints
IConstrainedItem..::.Constraints

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


LocalVariables Property

FunctionBase..::.LocalVariables Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.LocalVariables]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<IVariable> LocalVariables { get; }

Implements

IFunction..::.LocalVariables

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


MetaObject Property

FunctionBase..::.MetaObject Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.MetaObject]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IFunction MetaObject { get; }

Implements

IFunction..::.MetaObject

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


SubFunctions Property

FunctionBase..::.SubFunctions Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.SubFunctions]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IFunction> SubFunctions { get; }

Implements

IFunction..::.SubFunctions

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


SubOperators Property

FunctionBase..::.SubOperators Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.SubOperators]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IList<IOperator> SubOperators { get; }

Implements

IOperator..::.SubOperators
IOperator..::.SubOperators

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


VariableInfos Property

FunctionBase..::.VariableInfos Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.VariableInfos]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override ICollection<IVariableInfo> VariableInfos { get; }

Implements

IOperator..::.VariableInfos
IOperator..::.VariableInfos

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


Variables Property

FunctionBase..::.Variables Property
FunctionBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionBase.Variables]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override ICollection<IVariable> Variables { get; }

Implements

IOperator..::.Variables
IOperator..::.Variables

See Also

FunctionBase Class
HeuristicLab.Functions Namespace


FunctionView Class

FunctionView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.FunctionView]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FunctionView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Functions..::.FunctionView

See Also

FunctionView Members
HeuristicLab.Functions Namespace


FunctionView Members

[image]

HeuristicLab API Documentation
FunctionView Members
FunctionView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionView type exposes the following members.

Constructors

Name | Description
FunctionView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

FunctionView Class
HeuristicLab.Functions Namespace


FunctionView Constructor

[image]

HeuristicLab API Documentation
FunctionView Constructor
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FunctionView()()() |
FunctionView(IFunction) |

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


FunctionView Constructor

FunctionView Constructor
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FunctionView class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FunctionView()

See Also

FunctionView Class
FunctionView Overload
HeuristicLab.Functions Namespace


FunctionView Constructor (IFunction)

FunctionView Constructor (IFunction)
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FunctionView class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FunctionView(
    IFunction function
)

Parameters

function
Type: HeuristicLab.Functions..::.IFunction

[Missing <param> documentation for "function"]

See Also

FunctionView Class
FunctionView Overload
HeuristicLab.Functions Namespace


FunctionView Methods

[image]

HeuristicLab API Documentation
FunctionView Methods
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

FunctionView Class
HeuristicLab.Functions Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
FunctionView..::.AccessibilityNotifyClients Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
FunctionView..::.BeginInvoke Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


Dispose Method

[image]

HeuristicLab API Documentation
FunctionView..::.Dispose Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


Dispose Method (Boolean)

FunctionView..::.Dispose Method (Boolean)
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

FunctionView Class
Dispose Overload
HeuristicLab.Functions Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
FunctionView..::.GetChildAtPoint Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
FunctionView..::.Invalidate Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


Invoke Method

[image]

HeuristicLab API Documentation
FunctionView..::.Invoke Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
FunctionView..::.MemberwiseClone Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
FunctionView..::.PerformLayout Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
FunctionView..::.ResumeLayout Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
FunctionView..::.RtlTranslateAlignment Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


Scale Method

[image]

HeuristicLab API Documentation
FunctionView..::.Scale Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


Select Method

[image]

HeuristicLab API Documentation
FunctionView..::.Select Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
FunctionView..::.SetBounds Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
FunctionView..::.UpdateBounds Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


UpdateControls Method

FunctionView..::.UpdateControls Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.UpdateControls]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

FunctionView Class
HeuristicLab.Functions Namespace


Validate Method

[image]

HeuristicLab API Documentation
FunctionView..::.Validate Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
FunctionView..::.ValidateChildren Method
FunctionView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

FunctionView Class
FunctionView Members
HeuristicLab.Functions Namespace


HeuristicLabFunctionsPlugin Class

HeuristicLabFunctionsPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.HeuristicLabFunctionsPlugin]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Functions.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[ClassInfoAttribute(Name = "HeuristicLab.Functions")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[DependencyAttribute(Dependency = "HeuristicLab.DataAnalysis")]
[DependencyAttribute(Dependency = "HeuristicLab.Constraints")]
public class HeuristicLabFunctionsPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Functions..::.HeuristicLabFunctionsPlugin

See Also

HeuristicLabFunctionsPlugin Members
HeuristicLab.Functions Namespace


HeuristicLabFunctionsPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabFunctionsPlugin Members
HeuristicLabFunctionsPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabFunctionsPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabFunctionsPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabFunctionsPlugin Class
HeuristicLab.Functions Namespace


HeuristicLabFunctionsPlugin Constructor

HeuristicLabFunctionsPlugin Constructor
HeuristicLabFunctionsPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabFunctionsPlugin class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabFunctionsPlugin()

See Also

HeuristicLabFunctionsPlugin Class
HeuristicLab.Functions Namespace


IfThenElse Class

IfThenElse Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.IfThenElse]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IfThenElse : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.IfThenElse

See Also

IfThenElse Members
HeuristicLab.Functions Namespace


IfThenElse Members

[image]

HeuristicLab API Documentation
IfThenElse Members
IfThenElse Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IfThenElse type exposes the following members.

Constructors

Name | Description
IfThenElse | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

IfThenElse Class
HeuristicLab.Functions Namespace


IfThenElse Constructor

[image]

HeuristicLab API Documentation
IfThenElse Constructor
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IfThenElse()()() |
IfThenElse(IfThenElse, IDictionary<(Of <(Guid, Object>)>)) |

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


IfThenElse Constructor

IfThenElse Constructor
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IfThenElse class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IfThenElse()

See Also

IfThenElse Class
IfThenElse Overload
HeuristicLab.Functions Namespace


IfThenElse Constructor (IfThenElse, IDictionary(Guid, Object))

IfThenElse Constructor (IfThenElse, IDictionary<(Of <(Guid, Object>)>))
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IfThenElse class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IfThenElse(
    IfThenElse source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.IfThenElse

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

IfThenElse Class
IfThenElse Overload
HeuristicLab.Functions Namespace


IfThenElse Methods

[image]

HeuristicLab API Documentation
IfThenElse Methods
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IfThenElse type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

IfThenElse Class
HeuristicLab.Functions Namespace


Accept Method

IfThenElse..::.Accept Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IfThenElse.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

IfThenElse Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
IfThenElse..::.AddSubOperator Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
IfThenElse..::.Clone Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

IfThenElse..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IfThenElse.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.IfThenElse.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

IfThenElse Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

IfThenElse..::.Evaluate Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IfThenElse.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.IfThenElse.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

IfThenElse Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
IfThenElse..::.GetVariableValue Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
IfThenElse..::.IsValid Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
IfThenElse..::.TryAddSubOperator Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
IfThenElse..::.TryAddVariable Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
IfThenElse..::.TryAddVariableInfo Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
IfThenElse..::.TryRemoveSubOperator Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
IfThenElse..::.TryRemoveVariable Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
IfThenElse..::.TryRemoveVariableInfo Method
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IfThenElse Class
IfThenElse Members
HeuristicLab.Functions Namespace


IfThenElse Properties

[image]

HeuristicLab API Documentation
IfThenElse Properties
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IfThenElse type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

IfThenElse Class
HeuristicLab.Functions Namespace


Description Property

IfThenElse..::.Description Property
IfThenElse Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.IfThenElse.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

IfThenElse Class
HeuristicLab.Functions Namespace


IFunction Interface

IFunction Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.IFunction]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IFunction : IOperator,
    IConstrainedItem, IItem, IStorable, IViewable

See Also

IFunction Members
HeuristicLab.Functions Namespace


IFunction Members

[image]

HeuristicLab API Documentation
IFunction Members
IFunction Interface Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IFunction type exposes the following members.

Methods

Name | Description
Abort | (Inherited from IOperator.)
Accept |
AddConstraint | (Inherited from IConstrainedItem.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from IOperator.)
AddVariableInfo | (Inherited from IOperator.)
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
Evaluate |
Execute | (Inherited from IOperator.)
FireChanged | (Inherited from IItem.)
GetVariable | (Inherited from IOperator.)
GetVariableInfo | (Inherited from IOperator.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from IStorable.)
IsValid | Overloaded.
Populate | (Inherited from IStorable.)
RemoveConstraint | (Inherited from IConstrainedItem.)
RemoveSubOperator | (Inherited from IOperator.)
RemoveVariable | (Inherited from IOperator.)
RemoveVariableInfo | (Inherited from IOperator.)
Reset | (Inherited from IOperator.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from IOperator.)
Canceled | (Inherited from IOperator.)
Constraints | (Inherited from IConstrainedItem.)
Description | (Inherited from IOperator.)
Guid | (Inherited from IStorable.)
LocalVariables |
MetaObject |
Name | (Inherited from IOperator.)
SubFunctions |
SubOperators | (Inherited from IOperator.)
VariableInfos | (Inherited from IOperator.)
Variables | (Inherited from IOperator.)

Events

Name | Description
BreakpointChanged | (Inherited from IOperator.)
Changed | (Inherited from IItem.)
ConstraintAdded | (Inherited from IConstrainedItem.)
ConstraintRemoved | (Inherited from IConstrainedItem.)
Executed | (Inherited from IOperator.)
Initialized | (Inherited from IOperator.)
NameChanged | (Inherited from IOperator.)
SubOperatorAdded | (Inherited from IOperator.)
SubOperatorRemoved | (Inherited from IOperator.)
VariableAdded | (Inherited from IOperator.)
VariableInfoAdded | (Inherited from IOperator.)
VariableInfoRemoved | (Inherited from IOperator.)
VariableRemoved | (Inherited from IOperator.)

See Also

IFunction Interface
HeuristicLab.Functions Namespace


IFunction Methods

[image]

HeuristicLab API Documentation
IFunction Methods
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IFunction type exposes the following members.

Methods

Name | Description
Abort | (Inherited from IOperator.)
Accept |
AddConstraint | (Inherited from IConstrainedItem.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from IOperator.)
AddVariableInfo | (Inherited from IOperator.)
Clone | Overloaded.
CreateView | (Inherited from IViewable.)
Evaluate |
Execute | (Inherited from IOperator.)
FireChanged | (Inherited from IItem.)
GetVariable | (Inherited from IOperator.)
GetVariableInfo | (Inherited from IOperator.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from IStorable.)
IsValid | Overloaded.
Populate | (Inherited from IStorable.)
RemoveConstraint | (Inherited from IConstrainedItem.)
RemoveSubOperator | (Inherited from IOperator.)
RemoveVariable | (Inherited from IOperator.)
RemoveVariableInfo | (Inherited from IOperator.)
Reset | (Inherited from IOperator.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

IFunction Interface
HeuristicLab.Functions Namespace


Accept Method

IFunction..::.Accept Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunction.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

See Also

IFunction Interface
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
IFunction..::.AddSubOperator Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from IOperator.)
AddSubOperator(IOperator, Int32) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
IFunction..::.Clone Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


Evaluate Method

IFunction..::.Evaluate Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunction.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.IFunction.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

See Also

IFunction Interface
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
IFunction..::.GetVariableValue Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue(String, IScope, Boolean) | (Inherited from IOperator.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from IOperator.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from IOperator.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
IFunction..::.IsValid Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from IConstrainedItem.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from IConstrainedItem.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
IFunction..::.TryAddSubOperator Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from IOperator.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)
TryAddSubOperator(IOperator, Int32) | (Inherited from IOperator.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
IFunction..::.TryAddVariable Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from IOperator.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
IFunction..::.TryAddVariableInfo Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from IOperator.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
IFunction..::.TryRemoveSubOperator Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from IOperator.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
IFunction..::.TryRemoveVariable Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from IOperator.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
IFunction..::.TryRemoveVariableInfo Method
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from IOperator.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from IOperator.)

See Also

IFunction Interface
IFunction Members
HeuristicLab.Functions Namespace


IFunction Properties

[image]

HeuristicLab API Documentation
IFunction Properties
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IFunction type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from IOperator.)
Canceled | (Inherited from IOperator.)
Constraints | (Inherited from IConstrainedItem.)
Description | (Inherited from IOperator.)
Guid | (Inherited from IStorable.)
LocalVariables |
MetaObject |
Name | (Inherited from IOperator.)
SubFunctions |
SubOperators | (Inherited from IOperator.)
VariableInfos | (Inherited from IOperator.)
Variables | (Inherited from IOperator.)

See Also

IFunction Interface
HeuristicLab.Functions Namespace


LocalVariables Property

IFunction..::.LocalVariables Property
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.IFunction.LocalVariables]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
ICollection<IVariable> LocalVariables { get; }

See Also

IFunction Interface
HeuristicLab.Functions Namespace


MetaObject Property

IFunction..::.MetaObject Property
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.IFunction.MetaObject]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IFunction MetaObject { get; }

See Also

IFunction Interface
HeuristicLab.Functions Namespace


SubFunctions Property

IFunction..::.SubFunctions Property
IFunction Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.IFunction.SubFunctions]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
IList<IFunction> SubFunctions { get; }

See Also

IFunction Interface
HeuristicLab.Functions Namespace


IFunctionVisitor Interface

IFunctionVisitor Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.IFunctionVisitor]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IFunctionVisitor

See Also

IFunctionVisitor Members
HeuristicLab.Functions Namespace


IFunctionVisitor Members

[image]

HeuristicLab API Documentation
IFunctionVisitor Members
IFunctionVisitor Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Methods

Name | Description
Visit | Overloaded.

See Also

IFunctionVisitor Interface
HeuristicLab.Functions Namespace


IFunctionVisitor Methods

[image]

HeuristicLab API Documentation
IFunctionVisitor Methods
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Methods

Name | Description
Visit | Overloaded.

See Also

IFunctionVisitor Interface
HeuristicLab.Functions Namespace


Visit Method

[image]

HeuristicLab API Documentation
IFunctionVisitor..::.Visit Method
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Visit(Addition) |
Visit(And) |
Visit(Average) |
Visit(Constant) |
Visit(Cosinus) |
Visit(Division) |
Visit(Equal) |
Visit(Exponential) |
Visit(IfThenElse) |
Visit(IFunction) |
Visit(LessThan) |
Visit(Logarithm) |
Visit(Multiplication) |
Visit(Not) |
Visit(Or) |
Visit(Power) |
Visit(Signum) |
Visit(Sinus) |
Visit(Sqrt) |
Visit(Substraction) |
Visit(Tangens) |
Visit(Variable) |
Visit(Xor) |

See Also

IFunctionVisitor Interface
IFunctionVisitor Members
HeuristicLab.Functions Namespace


Visit Method (Addition)

IFunctionVisitor..::.Visit Method (Addition)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Addition)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Addition addition
)

Parameters

addition
Type: HeuristicLab.Functions..::.Addition

[Missing <param> documentation for "addition"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (And)

IFunctionVisitor..::.Visit Method (And)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.And)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    And and
)

Parameters

and
Type: HeuristicLab.Functions..::.And

[Missing <param> documentation for "and"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Average)

IFunctionVisitor..::.Visit Method (Average)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Average)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Average average
)

Parameters

average
Type: HeuristicLab.Functions..::.Average

[Missing <param> documentation for "average"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Constant)

IFunctionVisitor..::.Visit Method (Constant)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Constant)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Constant constant
)

Parameters

constant
Type: HeuristicLab.Functions..::.Constant

[Missing <param> documentation for "constant"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Cosinus)

IFunctionVisitor..::.Visit Method (Cosinus)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Cosinus)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Cosinus cosinus
)

Parameters

cosinus
Type: HeuristicLab.Functions..::.Cosinus

[Missing <param> documentation for "cosinus"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Division)

IFunctionVisitor..::.Visit Method (Division)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Division)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Division division
)

Parameters

division
Type: HeuristicLab.Functions..::.Division

[Missing <param> documentation for "division"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Equal)

IFunctionVisitor..::.Visit Method (Equal)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Equal)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Equal equal
)

Parameters

equal
Type: HeuristicLab.Functions..::.Equal

[Missing <param> documentation for "equal"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Exponential)

IFunctionVisitor..::.Visit Method (Exponential)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Exponential)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Exponential exponential
)

Parameters

exponential
Type: HeuristicLab.Functions..::.Exponential

[Missing <param> documentation for "exponential"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (IfThenElse)

IFunctionVisitor..::.Visit Method (IfThenElse)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.IfThenElse)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IfThenElse ifThenElse
)

Parameters

ifThenElse
Type: HeuristicLab.Functions..::.IfThenElse

[Missing <param> documentation for "ifThenElse"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (IFunction)

IFunctionVisitor..::.Visit Method (IFunction)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.IFunction)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    IFunction function
)

Parameters

function
Type: HeuristicLab.Functions..::.IFunction

[Missing <param> documentation for "function"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (LessThan)

IFunctionVisitor..::.Visit Method (LessThan)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.LessThan)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    LessThan lessThan
)

Parameters

lessThan
Type: HeuristicLab.Functions..::.LessThan

[Missing <param> documentation for "lessThan"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Logarithm)

IFunctionVisitor..::.Visit Method (Logarithm)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Logarithm)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Logarithm logarithm
)

Parameters

logarithm
Type: HeuristicLab.Functions..::.Logarithm

[Missing <param> documentation for "logarithm"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Multiplication)

IFunctionVisitor..::.Visit Method (Multiplication)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Multiplication)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Multiplication multiplication
)

Parameters

multiplication
Type: HeuristicLab.Functions..::.Multiplication

[Missing <param> documentation for "multiplication"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Not)

IFunctionVisitor..::.Visit Method (Not)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Not)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Not not
)

Parameters

not
Type: HeuristicLab.Functions..::.Not

[Missing <param> documentation for "not"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Or)

IFunctionVisitor..::.Visit Method (Or)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Or)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Or or
)

Parameters

or
Type: HeuristicLab.Functions..::.Or

[Missing <param> documentation for "or"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Power)

IFunctionVisitor..::.Visit Method (Power)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Power)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Power power
)

Parameters

power
Type: HeuristicLab.Functions..::.Power

[Missing <param> documentation for "power"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Signum)

IFunctionVisitor..::.Visit Method (Signum)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Signum)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Signum signum
)

Parameters

signum
Type: HeuristicLab.Functions..::.Signum

[Missing <param> documentation for "signum"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Sinus)

IFunctionVisitor..::.Visit Method (Sinus)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Sinus)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Sinus sinus
)

Parameters

sinus
Type: HeuristicLab.Functions..::.Sinus

[Missing <param> documentation for "sinus"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Sqrt)

IFunctionVisitor..::.Visit Method (Sqrt)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Sqrt)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Sqrt sqrt
)

Parameters

sqrt
Type: HeuristicLab.Functions..::.Sqrt

[Missing <param> documentation for "sqrt"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Substraction)

IFunctionVisitor..::.Visit Method (Substraction)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Substraction)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Substraction substraction
)

Parameters

substraction
Type: HeuristicLab.Functions..::.Substraction

[Missing <param> documentation for "substraction"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Tangens)

IFunctionVisitor..::.Visit Method (Tangens)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Tangens)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Tangens tangens
)

Parameters

tangens
Type: HeuristicLab.Functions..::.Tangens

[Missing <param> documentation for "tangens"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Variable)

IFunctionVisitor..::.Visit Method (Variable)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Variable)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Variable variable
)

Parameters

variable
Type: HeuristicLab.Functions..::.Variable

[Missing <param> documentation for "variable"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


Visit Method (Xor)

IFunctionVisitor..::.Visit Method (Xor)
IFunctionVisitor Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.IFunctionVisitor.Visit(HeuristicLab.Functions.Xor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Visit(
    Xor xor
)

Parameters

xor
Type: HeuristicLab.Functions..::.Xor

[Missing <param> documentation for "xor"]

See Also

IFunctionVisitor Interface
Visit Overload
HeuristicLab.Functions Namespace


LessThan Class

LessThan Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.LessThan]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LessThan : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.LessThan

See Also

LessThan Members
HeuristicLab.Functions Namespace


LessThan Members

[image]

HeuristicLab API Documentation
LessThan Members
LessThan Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessThan type exposes the following members.

Constructors

Name | Description
LessThan | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LessThan Class
HeuristicLab.Functions Namespace


LessThan Constructor

[image]

HeuristicLab API Documentation
LessThan Constructor
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LessThan()()() |
LessThan(LessThan, IDictionary<(Of <(Guid, Object>)>)) |

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


LessThan Constructor

LessThan Constructor
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LessThan class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LessThan()

See Also

LessThan Class
LessThan Overload
HeuristicLab.Functions Namespace


LessThan Constructor (LessThan, IDictionary(Guid, Object))

LessThan Constructor (LessThan, IDictionary<(Of <(Guid, Object>)>))
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LessThan class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LessThan(
    LessThan source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.LessThan

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

LessThan Class
LessThan Overload
HeuristicLab.Functions Namespace


LessThan Methods

[image]

HeuristicLab API Documentation
LessThan Methods
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessThan type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LessThan Class
HeuristicLab.Functions Namespace


Accept Method

LessThan..::.Accept Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.LessThan.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

LessThan Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LessThan..::.AddSubOperator Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
LessThan..::.Clone Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

LessThan..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.LessThan.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.LessThan.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

LessThan Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

LessThan..::.Evaluate Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.LessThan.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.LessThan.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

LessThan Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LessThan..::.GetVariableValue Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LessThan..::.IsValid Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LessThan..::.TryAddSubOperator Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LessThan..::.TryAddVariable Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LessThan..::.TryAddVariableInfo Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LessThan..::.TryRemoveSubOperator Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LessThan..::.TryRemoveVariable Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LessThan..::.TryRemoveVariableInfo Method
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThan Class
LessThan Members
HeuristicLab.Functions Namespace


LessThan Properties

[image]

HeuristicLab API Documentation
LessThan Properties
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessThan type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

LessThan Class
HeuristicLab.Functions Namespace


Description Property

LessThan..::.Description Property
LessThan Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.LessThan.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LessThan Class
HeuristicLab.Functions Namespace


Logarithm Class

Logarithm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Logarithm]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Logarithm : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Logarithm

See Also

Logarithm Members
HeuristicLab.Functions Namespace


Logarithm Members

[image]

HeuristicLab API Documentation
Logarithm Members
Logarithm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Logarithm type exposes the following members.

Constructors

Name | Description
Logarithm | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Logarithm Class
HeuristicLab.Functions Namespace


Logarithm Constructor

[image]

HeuristicLab API Documentation
Logarithm Constructor
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Logarithm()()() |
Logarithm(Logarithm, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


Logarithm Constructor

Logarithm Constructor
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Logarithm class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Logarithm()

See Also

Logarithm Class
Logarithm Overload
HeuristicLab.Functions Namespace


Logarithm Constructor (Logarithm, IDictionary(Guid, Object))

Logarithm Constructor (Logarithm, IDictionary<(Of <(Guid, Object>)>))
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Logarithm class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Logarithm(
    Logarithm source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Logarithm

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Logarithm Class
Logarithm Overload
HeuristicLab.Functions Namespace


Logarithm Methods

[image]

HeuristicLab API Documentation
Logarithm Methods
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Logarithm type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Logarithm Class
HeuristicLab.Functions Namespace


Accept Method

Logarithm..::.Accept Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Logarithm.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Logarithm Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Logarithm..::.AddSubOperator Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Logarithm..::.Clone Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Logarithm..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Logarithm.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Logarithm.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Logarithm Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Logarithm..::.Evaluate Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Logarithm.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Logarithm.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Logarithm Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Logarithm..::.GetVariableValue Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Logarithm..::.IsValid Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Logarithm..::.TryAddSubOperator Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Logarithm..::.TryAddVariable Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Logarithm..::.TryAddVariableInfo Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Logarithm..::.TryRemoveSubOperator Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Logarithm..::.TryRemoveVariable Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Logarithm..::.TryRemoveVariableInfo Method
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Logarithm Class
Logarithm Members
HeuristicLab.Functions Namespace


Logarithm Properties

[image]

HeuristicLab API Documentation
Logarithm Properties
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Logarithm type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Logarithm Class
HeuristicLab.Functions Namespace


Description Property

Logarithm..::.Description Property
Logarithm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Logarithm.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Logarithm Class
HeuristicLab.Functions Namespace


Multiplication Class

Multiplication Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Multiplication]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Multiplication : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Multiplication

See Also

Multiplication Members
HeuristicLab.Functions Namespace


Multiplication Members

[image]

HeuristicLab API Documentation
Multiplication Members
Multiplication Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Multiplication type exposes the following members.

Constructors

Name | Description
Multiplication | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Multiplication Class
HeuristicLab.Functions Namespace


Multiplication Constructor

[image]

HeuristicLab API Documentation
Multiplication Constructor
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Multiplication()()() |
Multiplication(Multiplication, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


Multiplication Constructor

Multiplication Constructor
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Multiplication class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Multiplication()

See Also

Multiplication Class
Multiplication Overload
HeuristicLab.Functions Namespace


Multiplication Constructor (Multiplication, IDictionary(Guid, Object))

Multiplication Constructor (Multiplication, IDictionary<(Of <(Guid, Object>)>))
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Multiplication class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Multiplication(
    Multiplication source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Multiplication

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Multiplication Class
Multiplication Overload
HeuristicLab.Functions Namespace


Multiplication Methods

[image]

HeuristicLab API Documentation
Multiplication Methods
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Multiplication type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Multiplication Class
HeuristicLab.Functions Namespace


Accept Method

Multiplication..::.Accept Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Multiplication.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Multiplication Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Multiplication..::.AddSubOperator Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Multiplication..::.Clone Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Multiplication..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Multiplication.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Multiplication.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Multiplication Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Multiplication..::.Evaluate Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Multiplication.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Multiplication.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Multiplication Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Multiplication..::.GetVariableValue Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Multiplication..::.IsValid Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Multiplication..::.TryAddSubOperator Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Multiplication..::.TryAddVariable Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Multiplication..::.TryAddVariableInfo Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Multiplication..::.TryRemoveSubOperator Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Multiplication..::.TryRemoveVariable Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Multiplication..::.TryRemoveVariableInfo Method
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Multiplication Class
Multiplication Members
HeuristicLab.Functions Namespace


Multiplication Properties

[image]

HeuristicLab API Documentation
Multiplication Properties
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Multiplication type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Multiplication Class
HeuristicLab.Functions Namespace


Description Property

Multiplication..::.Description Property
Multiplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Multiplication.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Multiplication Class
HeuristicLab.Functions Namespace


Not Class

Not Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Not]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Not : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Not

See Also

Not Members
HeuristicLab.Functions Namespace


Not Members

[image]

HeuristicLab API Documentation
Not Members
Not Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Not type exposes the following members.

Constructors

Name | Description
Not | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Not Class
HeuristicLab.Functions Namespace


Not Constructor

[image]

HeuristicLab API Documentation
Not Constructor
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Not()()() |
Not(Not, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


Not Constructor

Not Constructor
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Not class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Not()

See Also

Not Class
Not Overload
HeuristicLab.Functions Namespace


Not Constructor (Not, IDictionary(Guid, Object))

Not Constructor (Not, IDictionary<(Of <(Guid, Object>)>))
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Not class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Not(
    Not source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Not

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Not Class
Not Overload
HeuristicLab.Functions Namespace


Not Methods

[image]

HeuristicLab API Documentation
Not Methods
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Not type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Not Class
HeuristicLab.Functions Namespace


Accept Method

Not..::.Accept Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Not.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Not Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Not..::.AddSubOperator Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Not..::.Clone Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Not..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Not.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Not.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Not Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Not..::.Evaluate Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Not.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Not.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Not Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Not..::.GetVariableValue Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Not..::.IsValid Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Not..::.TryAddSubOperator Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Not..::.TryAddVariable Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Not..::.TryAddVariableInfo Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Not..::.TryRemoveSubOperator Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Not..::.TryRemoveVariable Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Not..::.TryRemoveVariableInfo Method
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Not Class
Not Members
HeuristicLab.Functions Namespace


Not Properties

[image]

HeuristicLab API Documentation
Not Properties
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Not type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Not Class
HeuristicLab.Functions Namespace


Description Property

Not..::.Description Property
Not Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Not.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Not Class
HeuristicLab.Functions Namespace


Or Class

Or Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Or]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Or : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Or

See Also

Or Members
HeuristicLab.Functions Namespace


Or Members

[image]

HeuristicLab API Documentation
Or Members
Or Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Or type exposes the following members.

Constructors

Name | Description
Or | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Or Class
HeuristicLab.Functions Namespace


Or Constructor

[image]

HeuristicLab API Documentation
Or Constructor
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Or()()() |
Or(Or, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


Or Constructor

Or Constructor
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Or class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Or()

See Also

Or Class
Or Overload
HeuristicLab.Functions Namespace


Or Constructor (Or, IDictionary(Guid, Object))

Or Constructor (Or, IDictionary<(Of <(Guid, Object>)>))
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Or class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Or(
    Or source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Or

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Or Class
Or Overload
HeuristicLab.Functions Namespace


Or Methods

[image]

HeuristicLab API Documentation
Or Methods
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Or type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Or Class
HeuristicLab.Functions Namespace


Accept Method

Or..::.Accept Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Or.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Or Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Or..::.AddSubOperator Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Or..::.Clone Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Or..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Or.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Or.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Or Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Or..::.Evaluate Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Or.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Or.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Or Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Or..::.GetVariableValue Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Or..::.IsValid Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Or..::.TryAddSubOperator Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Or..::.TryAddVariable Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Or..::.TryAddVariableInfo Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Or..::.TryRemoveSubOperator Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Or..::.TryRemoveVariable Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Or..::.TryRemoveVariableInfo Method
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Or Class
Or Members
HeuristicLab.Functions Namespace


Or Properties

[image]

HeuristicLab API Documentation
Or Properties
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Or type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Or Class
HeuristicLab.Functions Namespace


Description Property

Or..::.Description Property
Or Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Or.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Or Class
HeuristicLab.Functions Namespace


Power Class

Power Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Power]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Power : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Power

See Also

Power Members
HeuristicLab.Functions Namespace


Power Members

[image]

HeuristicLab API Documentation
Power Members
Power Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Power type exposes the following members.

Constructors

Name | Description
Power | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Power Class
HeuristicLab.Functions Namespace


Power Constructor

[image]

HeuristicLab API Documentation
Power Constructor
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Power()()() |
Power(Power, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


Power Constructor

Power Constructor
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Power class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Power()

See Also

Power Class
Power Overload
HeuristicLab.Functions Namespace


Power Constructor (Power, IDictionary(Guid, Object))

Power Constructor (Power, IDictionary<(Of <(Guid, Object>)>))
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Power class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Power(
    Power source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Power

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Power Class
Power Overload
HeuristicLab.Functions Namespace


Power Methods

[image]

HeuristicLab API Documentation
Power Methods
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Power type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Power Class
HeuristicLab.Functions Namespace


Accept Method

Power..::.Accept Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Power.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Power Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Power..::.AddSubOperator Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Power..::.Clone Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Power..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Power.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Power.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Power Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Power..::.Evaluate Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Power.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Power.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Power Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Power..::.GetVariableValue Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Power..::.IsValid Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Power..::.TryAddSubOperator Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Power..::.TryAddVariable Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Power..::.TryAddVariableInfo Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Power..::.TryRemoveSubOperator Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Power..::.TryRemoveVariable Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Power..::.TryRemoveVariableInfo Method
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Power Class
Power Members
HeuristicLab.Functions Namespace


Power Properties

[image]

HeuristicLab API Documentation
Power Properties
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Power type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Power Class
HeuristicLab.Functions Namespace


Description Property

Power..::.Description Property
Power Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Power.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Power Class
HeuristicLab.Functions Namespace


Signum Class

Signum Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Signum]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Signum : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Signum

See Also

Signum Members
HeuristicLab.Functions Namespace


Signum Members

[image]

HeuristicLab API Documentation
Signum Members
Signum Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Signum type exposes the following members.

Constructors

Name | Description
Signum | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Signum Class
HeuristicLab.Functions Namespace


Signum Constructor

[image]

HeuristicLab API Documentation
Signum Constructor
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Signum()()() |
Signum(Signum, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


Signum Constructor

Signum Constructor
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Signum class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Signum()

See Also

Signum Class
Signum Overload
HeuristicLab.Functions Namespace


Signum Constructor (Signum, IDictionary(Guid, Object))

Signum Constructor (Signum, IDictionary<(Of <(Guid, Object>)>))
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Signum class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Signum(
    Signum source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Signum

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Signum Class
Signum Overload
HeuristicLab.Functions Namespace


Signum Methods

[image]

HeuristicLab API Documentation
Signum Methods
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Signum type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Signum Class
HeuristicLab.Functions Namespace


Accept Method

Signum..::.Accept Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Signum.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Signum Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Signum..::.AddSubOperator Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Signum..::.Clone Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Signum..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Signum.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Signum.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Signum Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Signum..::.Evaluate Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Signum.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Signum.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Signum Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Signum..::.GetVariableValue Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Signum..::.IsValid Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Signum..::.TryAddSubOperator Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Signum..::.TryAddVariable Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Signum..::.TryAddVariableInfo Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Signum..::.TryRemoveSubOperator Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Signum..::.TryRemoveVariable Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Signum..::.TryRemoveVariableInfo Method
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Signum Class
Signum Members
HeuristicLab.Functions Namespace


Signum Properties

[image]

HeuristicLab API Documentation
Signum Properties
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Signum type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Signum Class
HeuristicLab.Functions Namespace


Description Property

Signum..::.Description Property
Signum Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Signum.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Signum Class
HeuristicLab.Functions Namespace


Sinus Class

Sinus Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Sinus]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Sinus : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Sinus

See Also

Sinus Members
HeuristicLab.Functions Namespace


Sinus Members

[image]

HeuristicLab API Documentation
Sinus Members
Sinus Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sinus type exposes the following members.

Constructors

Name | Description
Sinus | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Sinus Class
HeuristicLab.Functions Namespace


Sinus Constructor

[image]

HeuristicLab API Documentation
Sinus Constructor
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sinus()()() |
Sinus(Sinus, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


Sinus Constructor

Sinus Constructor
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Sinus class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Sinus()

See Also

Sinus Class
Sinus Overload
HeuristicLab.Functions Namespace


Sinus Constructor (Sinus, IDictionary(Guid, Object))

Sinus Constructor (Sinus, IDictionary<(Of <(Guid, Object>)>))
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Sinus class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Sinus(
    Sinus source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Sinus

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Sinus Class
Sinus Overload
HeuristicLab.Functions Namespace


Sinus Methods

[image]

HeuristicLab API Documentation
Sinus Methods
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sinus type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Sinus Class
HeuristicLab.Functions Namespace


Accept Method

Sinus..::.Accept Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Sinus.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Sinus Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Sinus..::.AddSubOperator Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Sinus..::.Clone Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Sinus..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Sinus.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Sinus.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Sinus Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Sinus..::.Evaluate Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Sinus.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Sinus.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Sinus Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Sinus..::.GetVariableValue Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Sinus..::.IsValid Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Sinus..::.TryAddSubOperator Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Sinus..::.TryAddVariable Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Sinus..::.TryAddVariableInfo Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Sinus..::.TryRemoveSubOperator Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Sinus..::.TryRemoveVariable Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Sinus..::.TryRemoveVariableInfo Method
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sinus Class
Sinus Members
HeuristicLab.Functions Namespace


Sinus Properties

[image]

HeuristicLab API Documentation
Sinus Properties
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sinus type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Sinus Class
HeuristicLab.Functions Namespace


Description Property

Sinus..::.Description Property
Sinus Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Sinus.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Sinus Class
HeuristicLab.Functions Namespace


Sqrt Class

Sqrt Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Sqrt]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Sqrt : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Sqrt

See Also

Sqrt Members
HeuristicLab.Functions Namespace


Sqrt Members

[image]

HeuristicLab API Documentation
Sqrt Members
Sqrt Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sqrt type exposes the following members.

Constructors

Name | Description
Sqrt | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Sqrt Class
HeuristicLab.Functions Namespace


Sqrt Constructor

[image]

HeuristicLab API Documentation
Sqrt Constructor
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sqrt()()() |
Sqrt(Sqrt, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


Sqrt Constructor

Sqrt Constructor
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Sqrt class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Sqrt()

See Also

Sqrt Class
Sqrt Overload
HeuristicLab.Functions Namespace


Sqrt Constructor (Sqrt, IDictionary(Guid, Object))

Sqrt Constructor (Sqrt, IDictionary<(Of <(Guid, Object>)>))
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Sqrt class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Sqrt(
    Sqrt source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Sqrt

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Sqrt Class
Sqrt Overload
HeuristicLab.Functions Namespace


Sqrt Methods

[image]

HeuristicLab API Documentation
Sqrt Methods
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sqrt type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Sqrt Class
HeuristicLab.Functions Namespace


Accept Method

Sqrt..::.Accept Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Sqrt.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Sqrt Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Sqrt..::.AddSubOperator Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Sqrt..::.Clone Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Sqrt..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Sqrt.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Sqrt.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Sqrt Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Sqrt..::.Evaluate Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Sqrt.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Sqrt.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Sqrt Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Sqrt..::.GetVariableValue Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Sqrt..::.IsValid Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Sqrt..::.TryAddSubOperator Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Sqrt..::.TryAddVariable Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Sqrt..::.TryAddVariableInfo Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Sqrt..::.TryRemoveSubOperator Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Sqrt..::.TryRemoveVariable Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Sqrt..::.TryRemoveVariableInfo Method
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sqrt Class
Sqrt Members
HeuristicLab.Functions Namespace


Sqrt Properties

[image]

HeuristicLab API Documentation
Sqrt Properties
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sqrt type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Sqrt Class
HeuristicLab.Functions Namespace


Description Property

Sqrt..::.Description Property
Sqrt Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Sqrt.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Sqrt Class
HeuristicLab.Functions Namespace


Substraction Class

Substraction Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Substraction]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Substraction : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Substraction

See Also

Substraction Members
HeuristicLab.Functions Namespace


Substraction Members

[image]

HeuristicLab API Documentation
Substraction Members
Substraction Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Substraction type exposes the following members.

Constructors

Name | Description
Substraction | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Substraction Class
HeuristicLab.Functions Namespace


Substraction Constructor

[image]

HeuristicLab API Documentation
Substraction Constructor
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Substraction()()() |
Substraction(Substraction, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


Substraction Constructor

Substraction Constructor
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Substraction class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Substraction()

See Also

Substraction Class
Substraction Overload
HeuristicLab.Functions Namespace


Substraction Constructor (Substraction, IDictionary(Guid, Object))

Substraction Constructor (Substraction, IDictionary<(Of <(Guid, Object>)>))
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Substraction class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Substraction(
    Substraction source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Substraction

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Substraction Class
Substraction Overload
HeuristicLab.Functions Namespace


Substraction Methods

[image]

HeuristicLab API Documentation
Substraction Methods
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Substraction type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Substraction Class
HeuristicLab.Functions Namespace


Accept Method

Substraction..::.Accept Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Substraction.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Substraction Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Substraction..::.AddSubOperator Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Substraction..::.Clone Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Substraction..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Substraction.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Substraction.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Substraction Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Substraction..::.Evaluate Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Substraction.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Substraction.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Substraction Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Substraction..::.GetVariableValue Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Substraction..::.IsValid Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Substraction..::.TryAddSubOperator Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Substraction..::.TryAddVariable Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Substraction..::.TryAddVariableInfo Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Substraction..::.TryRemoveSubOperator Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Substraction..::.TryRemoveVariable Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Substraction..::.TryRemoveVariableInfo Method
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Substraction Class
Substraction Members
HeuristicLab.Functions Namespace


Substraction Properties

[image]

HeuristicLab API Documentation
Substraction Properties
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Substraction type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Substraction Class
HeuristicLab.Functions Namespace


Description Property

Substraction..::.Description Property
Substraction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Substraction.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Substraction Class
HeuristicLab.Functions Namespace


Tangens Class

Tangens Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Tangens]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Tangens : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Tangens

See Also

Tangens Members
HeuristicLab.Functions Namespace


Tangens Members

[image]

HeuristicLab API Documentation
Tangens Members
Tangens Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tangens type exposes the following members.

Constructors

Name | Description
Tangens | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Tangens Class
HeuristicLab.Functions Namespace


Tangens Constructor

[image]

HeuristicLab API Documentation
Tangens Constructor
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Tangens()()() |
Tangens(Tangens, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


Tangens Constructor

Tangens Constructor
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Tangens class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Tangens()

See Also

Tangens Class
Tangens Overload
HeuristicLab.Functions Namespace


Tangens Constructor (Tangens, IDictionary(Guid, Object))

Tangens Constructor (Tangens, IDictionary<(Of <(Guid, Object>)>))
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Tangens class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Tangens(
    Tangens source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Tangens

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Tangens Class
Tangens Overload
HeuristicLab.Functions Namespace


Tangens Methods

[image]

HeuristicLab API Documentation
Tangens Methods
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tangens type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Tangens Class
HeuristicLab.Functions Namespace


Accept Method

Tangens..::.Accept Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Tangens.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Tangens Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Tangens..::.AddSubOperator Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Tangens..::.Clone Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Tangens..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Tangens.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Tangens.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Tangens Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Tangens..::.Evaluate Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Tangens.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Tangens.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Tangens Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Tangens..::.GetVariableValue Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Tangens..::.IsValid Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Tangens..::.TryAddSubOperator Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Tangens..::.TryAddVariable Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Tangens..::.TryAddVariableInfo Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Tangens..::.TryRemoveSubOperator Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Tangens..::.TryRemoveVariable Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Tangens..::.TryRemoveVariableInfo Method
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Tangens Class
Tangens Members
HeuristicLab.Functions Namespace


Tangens Properties

[image]

HeuristicLab API Documentation
Tangens Properties
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tangens type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Tangens Class
HeuristicLab.Functions Namespace


Description Property

Tangens..::.Description Property
Tangens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Tangens.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Tangens Class
HeuristicLab.Functions Namespace


Variable Class

Variable Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Variable]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Variable : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Variable

See Also

Variable Members
HeuristicLab.Functions Namespace


Variable Members

[image]

HeuristicLab API Documentation
Variable Members
Variable Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Constructors

Name | Description
Variable | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides FunctionBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SampleOffset |
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableIndex |
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)
Weight |

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Variable Class
HeuristicLab.Functions Namespace


Variable Constructor

[image]

HeuristicLab API Documentation
Variable Constructor
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Variable()()() |
Variable(Variable, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


Variable Constructor

Variable Constructor
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Variable class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Variable()

See Also

Variable Class
Variable Overload
HeuristicLab.Functions Namespace


Variable Constructor (Variable, IDictionary(Guid, Object))

Variable Constructor (Variable, IDictionary<(Of <(Guid, Object>)>))
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Variable class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Variable(
    Variable source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Variable

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Variable Class
Variable Overload
HeuristicLab.Functions Namespace


Variable Methods

[image]

HeuristicLab API Documentation
Variable Methods
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides FunctionBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Variable Class
HeuristicLab.Functions Namespace


Accept Method

Variable..::.Accept Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Variable.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Variable Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Variable..::.AddSubOperator Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Variable..::.Clone Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Variable..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Variable.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Variable.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Variable Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Variable..::.Evaluate Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Variable.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Variable.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Variable Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Variable..::.GetVariableValue Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Variable..::.IsValid Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


Populate Method

Variable..::.Populate Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Variable.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Variable Class
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Variable..::.TryAddSubOperator Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Variable..::.TryAddVariable Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Variable..::.TryAddVariableInfo Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Variable..::.TryRemoveSubOperator Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Variable..::.TryRemoveVariable Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Variable..::.TryRemoveVariableInfo Method
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Variable Class
Variable Members
HeuristicLab.Functions Namespace


Variable Properties

[image]

HeuristicLab API Documentation
Variable Properties
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variable type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SampleOffset |
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableIndex |
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)
Weight |

See Also

Variable Class
HeuristicLab.Functions Namespace


Description Property

Variable..::.Description Property
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Variable.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Variable Class
HeuristicLab.Functions Namespace


SampleOffset Property

Variable..::.SampleOffset Property
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Variable.SampleOffset]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double SampleOffset { get; }

See Also

Variable Class
HeuristicLab.Functions Namespace


VariableIndex Property

Variable..::.VariableIndex Property
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Variable.VariableIndex]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int VariableIndex { get; }

See Also

Variable Class
HeuristicLab.Functions Namespace


Weight Property

Variable..::.Weight Property
Variable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Variable.Weight]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Weight { get; }

See Also

Variable Class
HeuristicLab.Functions Namespace


Xor Class

Xor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Functions.Xor]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Xor : FunctionBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Functions..::.FunctionBase
HeuristicLab.Functions..::.Xor

See Also

Xor Members
HeuristicLab.Functions Namespace


Xor Members

[image]

HeuristicLab API Documentation
Xor Members
Xor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Xor type exposes the following members.

Constructors

Name | Description
Xor | Overloaded.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Xor Class
HeuristicLab.Functions Namespace


Xor Constructor

[image]

HeuristicLab API Documentation
Xor Constructor
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Xor()()() |
Xor(Xor, IDictionary<(Of <(Guid, Object>)>)) |

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


Xor Constructor

Xor Constructor
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Xor class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Xor()

See Also

Xor Class
Xor Overload
HeuristicLab.Functions Namespace


Xor Constructor (Xor, IDictionary(Guid, Object))

Xor Constructor (Xor, IDictionary<(Of <(Guid, Object>)>))
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Xor class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Xor(
    Xor source,
    IDictionary<Guid, Object> clonedObjects
)

Parameters

source
Type: HeuristicLab.Functions..::.Xor

[Missing <param> documentation for "source"]

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

See Also

Xor Class
Xor Overload
HeuristicLab.Functions Namespace


Xor Methods

[image]

HeuristicLab API Documentation
Xor Methods
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Xor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
Accept | (Overrides FunctionBase ..::. Accept(IFunctionVisitor).)
AddConstraint | (Inherited from FunctionBase.)
AddLocalVariable | (Inherited from FunctionBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from FunctionBase.)
AddVariableInfo | (Inherited from FunctionBase.)
Apply | (Inherited from FunctionBase.)
Clone | Overloaded.
CreateView | (Inherited from FunctionBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides FunctionBase ..::. Evaluate(Dataset, Int32).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from FunctionBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from FunctionBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from FunctionBase.)
RemoveConstraint | (Inherited from FunctionBase.)
RemoveSubOperator | (Inherited from FunctionBase.)
RemoveVariable | (Inherited from FunctionBase.)
RemoveVariableInfo | (Inherited from FunctionBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Xor Class
HeuristicLab.Functions Namespace


Accept Method

Xor..::.Accept Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Xor.Accept(HeuristicLab.Functions.IFunctionVisitor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Accept(
    IFunctionVisitor visitor
)

Parameters

visitor
Type: HeuristicLab.Functions..::.IFunctionVisitor

[Missing <param> documentation for "visitor"]

Implements

IFunction..::.Accept(IFunctionVisitor)

See Also

Xor Class
HeuristicLab.Functions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Xor..::.AddSubOperator Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from FunctionBase.)
AddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


Clone Method

[image]

HeuristicLab API Documentation
Xor..::.Clone Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


Clone Method (IDictionary(Guid, Object))

Xor..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Xor.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Xor.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Xor Class
Clone Overload
HeuristicLab.Functions Namespace


Evaluate Method

Xor..::.Evaluate Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.Xor.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double Evaluate(
    Dataset dataset,
    int sampleIndex
)

Parameters

dataset
Type: HeuristicLab.DataAnalysis..::.Dataset

[Missing <param> documentation for "dataset"]

sampleIndex
Type: System..::.Int32

[Missing <param> documentation for "sampleIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Functions.Xor.Evaluate(HeuristicLab.DataAnalysis.Dataset,System.Int32)]

Implements

IFunction..::.Evaluate(Dataset, Int32)

See Also

Xor Class
HeuristicLab.Functions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Xor..::.GetVariableValue Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue(String, IScope, Boolean, Boolean) | (Inherited from FunctionBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Xor..::.IsValid Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Xor..::.TryAddSubOperator Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from FunctionBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Xor..::.TryAddVariable Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Xor..::.TryAddVariableInfo Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Xor..::.TryRemoveSubOperator Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from FunctionBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from FunctionBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Xor..::.TryRemoveVariable Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Xor..::.TryRemoveVariableInfo Method
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Xor Class
Xor Members
HeuristicLab.Functions Namespace


Xor Properties

[image]

HeuristicLab API Documentation
Xor Properties
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Xor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from FunctionBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
LocalVariables | (Inherited from FunctionBase.)
MetaObject | (Inherited from FunctionBase.)
Name | (Inherited from OperatorBase.)
SubFunctions | (Inherited from FunctionBase.)
SubOperators | (Inherited from FunctionBase.)
VariableInfos | (Inherited from FunctionBase.)
Variables | (Inherited from FunctionBase.)

See Also

Xor Class
HeuristicLab.Functions Namespace


Description Property

Xor..::.Description Property
Xor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.Xor.Description]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Xor Class
HeuristicLab.Functions Namespace


HeuristicLab.Grid Namespace

HeuristicLab.Grid Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Grid]

Classes

Class | Description
ClientForm |
EngineStore |
GridClientApplication |
GridServer |
GridServerApplication |
HeuristicLabGridPlugin |
ProcessingEngine |
ServerForm |

Interfaces

Interface | Description
IEngineStore |
IGridServer |


ClientForm Class

ClientForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.ClientForm]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ClientForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Grid..::.ClientForm

See Also

ClientForm Members
HeuristicLab.Grid Namespace


ClientForm Members

[image]

HeuristicLab API Documentation
ClientForm Members
ClientForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ClientForm type exposes the following members.

Constructors

Name | Description
ClientForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ClientForm Class
HeuristicLab.Grid Namespace


ClientForm Constructor

ClientForm Constructor
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClientForm class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ClientForm()

See Also

ClientForm Class
HeuristicLab.Grid Namespace


ClientForm Methods

[image]

HeuristicLab API Documentation
ClientForm Methods
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ClientForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ClientForm Class
HeuristicLab.Grid Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ClientForm..::.AccessibilityNotifyClients Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ClientForm..::.BeginInvoke Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ClientForm..::.Dispose Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Dispose Method (Boolean)

ClientForm..::.Dispose Method (Boolean)
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ClientForm Class
Dispose Overload
HeuristicLab.Grid Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ClientForm..::.GetChildAtPoint Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ClientForm..::.Invalidate Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ClientForm..::.Invoke Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ClientForm..::.MemberwiseClone Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ClientForm..::.PerformLayout Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ClientForm..::.ResumeLayout Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ClientForm..::.RtlTranslateAlignment Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Scale Method

[image]

HeuristicLab API Documentation
ClientForm..::.Scale Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Select Method

[image]

HeuristicLab API Documentation
ClientForm..::.Select Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ClientForm..::.SetBounds Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Show Method

[image]

HeuristicLab API Documentation
ClientForm..::.Show Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ClientForm..::.ShowDialog Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ClientForm..::.UpdateBounds Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


Validate Method

[image]

HeuristicLab API Documentation
ClientForm..::.Validate Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ClientForm..::.ValidateChildren Method
ClientForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ClientForm Class
ClientForm Members
HeuristicLab.Grid Namespace


EngineStore Class

EngineStore Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.EngineStore]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, ConcurrencyMode = ConcurrencyMode.Multiple,
    UseSynchronizationContext = false)]
public class EngineStore : IEngineStore

Inheritance Hierarchy

System..::.Object
HeuristicLab.Grid..::.EngineStore

See Also

EngineStore Members
HeuristicLab.Grid Namespace


EngineStore Members

[image]

HeuristicLab API Documentation
EngineStore Members
EngineStore Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineStore type exposes the following members.

Constructors

Name | Description
EngineStore |

Methods

Name | Description
AddEngine |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetResult |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveResult |
StoreResult |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryTakeEngine |

Properties

Name | Description
RunningJobs |
WaitingJobs |
WaitingResults |

See Also

EngineStore Class
HeuristicLab.Grid Namespace


EngineStore Constructor

EngineStore Constructor
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EngineStore class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EngineStore()

See Also

EngineStore Class
HeuristicLab.Grid Namespace


EngineStore Methods

[image]

HeuristicLab API Documentation
EngineStore Methods
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineStore type exposes the following members.

Methods

Name | Description
AddEngine |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetResult |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveResult |
StoreResult |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryTakeEngine |

See Also

EngineStore Class
HeuristicLab.Grid Namespace


AddEngine Method

EngineStore..::.AddEngine Method
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.EngineStore.AddEngine(System.Guid,System.Byte[])]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void AddEngine(
    Guid guid,
    byte[] engine
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

engine
Type: array< System..::.Byte >[]()[]

[Missing <param> documentation for "engine"]

See Also

EngineStore Class
HeuristicLab.Grid Namespace


GetResult Method

EngineStore..::.GetResult Method
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.EngineStore.GetResult(System.Guid)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal byte[] GetResult(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.EngineStore.GetResult(System.Guid)]

See Also

EngineStore Class
HeuristicLab.Grid Namespace


RemoveResult Method

EngineStore..::.RemoveResult Method
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.EngineStore.RemoveResult(System.Guid)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal byte[] RemoveResult(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.EngineStore.RemoveResult(System.Guid)]

See Also

EngineStore Class
HeuristicLab.Grid Namespace


StoreResult Method

EngineStore..::.StoreResult Method
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.EngineStore.StoreResult(System.Guid,System.Byte[])]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void StoreResult(
    Guid guid,
    byte[] result
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

result
Type: array< System..::.Byte >[]()[]

[Missing <param> documentation for "result"]

Implements

IEngineStore..::.StoreResult(Guid, array<Byte>[]()[])

See Also

EngineStore Class
HeuristicLab.Grid Namespace


TryTakeEngine Method

EngineStore..::.TryTakeEngine Method
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.EngineStore.TryTakeEngine(System.Guid@,System.Byte[]@)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool TryTakeEngine(
    out Guid guid,
    out byte[] engine
)

Parameters

guid
Type: System..::.Guid %

[Missing <param> documentation for "guid"]

engine
Type: array< System..::.Byte >[]()[] %

[Missing <param> documentation for "engine"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.EngineStore.TryTakeEngine(System.Guid@,System.Byte[]@)]

Implements

IEngineStore..::.TryTakeEngine(Guid%, array<Byte>[]()[]%)

See Also

EngineStore Class
HeuristicLab.Grid Namespace


EngineStore Properties

[image]

HeuristicLab API Documentation
EngineStore Properties
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EngineStore type exposes the following members.

Properties

Name | Description
RunningJobs |
WaitingJobs |
WaitingResults |

See Also

EngineStore Class
HeuristicLab.Grid Namespace


RunningJobs Property

EngineStore..::.RunningJobs Property
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Grid.EngineStore.RunningJobs]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int RunningJobs { get; }

See Also

EngineStore Class
HeuristicLab.Grid Namespace


WaitingJobs Property

EngineStore..::.WaitingJobs Property
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Grid.EngineStore.WaitingJobs]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int WaitingJobs { get; }

See Also

EngineStore Class
HeuristicLab.Grid Namespace


WaitingResults Property

EngineStore..::.WaitingResults Property
EngineStore Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Grid.EngineStore.WaitingResults]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int WaitingResults { get; }

See Also

EngineStore Class
HeuristicLab.Grid Namespace


GridClientApplication Class

GridClientApplication Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.GridClientApplication]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "Grid Client", Description = "Client application for the distributed engine grid.")]
internal class GridClientApplication : ApplicationBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.ApplicationBase
HeuristicLab.Grid..::.GridClientApplication

See Also

GridClientApplication Members
HeuristicLab.Grid Namespace


GridClientApplication Members

[image]

HeuristicLab API Documentation
GridClientApplication Members
GridClientApplication Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GridClientApplication type exposes the following members.

Constructors

Name | Description
GridClientApplication |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from ApplicationBase.)
Name | (Inherited from ApplicationBase.)
Version | (Inherited from ApplicationBase.)

See Also

GridClientApplication Class
HeuristicLab.Grid Namespace


GridClientApplication Constructor

GridClientApplication Constructor
GridClientApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GridClientApplication class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GridClientApplication()

See Also

GridClientApplication Class
HeuristicLab.Grid Namespace


GridClientApplication Methods

[image]

HeuristicLab API Documentation
GridClientApplication Methods
GridClientApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GridClientApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridClientApplication Class
HeuristicLab.Grid Namespace


Run Method

GridClientApplication..::.Run Method
GridClientApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.GridClientApplication.Run]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Run()

Implements

IApplication..::.Run()()()

See Also

GridClientApplication Class
HeuristicLab.Grid Namespace


GridServer Class

GridServer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.GridServer]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, ConcurrencyMode = ConcurrencyMode.Multiple,
    UseSynchronizationContext = false)]
public class GridServer : IGridServer

Inheritance Hierarchy

System..::.Object
HeuristicLab.Grid..::.GridServer

See Also

GridServer Members
HeuristicLab.Grid Namespace


GridServer Members

[image]

HeuristicLab API Documentation
GridServer Members
GridServer Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GridServer type exposes the following members.

Constructors

Name | Description
GridServer |

Methods

Name | Description
AbortEngine |
BeginExecuteEngine |
EndExecuteEngine |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridServer Class
HeuristicLab.Grid Namespace


GridServer Constructor

GridServer Constructor
GridServer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GridServer class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GridServer(
    EngineStore engineStore
)

Parameters

engineStore
Type: HeuristicLab.Grid..::.EngineStore

[Missing <param> documentation for "engineStore"]

See Also

GridServer Class
HeuristicLab.Grid Namespace


GridServer Methods

[image]

HeuristicLab API Documentation
GridServer Methods
GridServer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GridServer type exposes the following members.

Methods

Name | Description
AbortEngine |
BeginExecuteEngine |
EndExecuteEngine |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridServer Class
HeuristicLab.Grid Namespace


AbortEngine Method

GridServer..::.AbortEngine Method
GridServer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.GridServer.AbortEngine(System.Guid)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void AbortEngine(
    Guid engine
)

Parameters

engine
Type: System..::.Guid

[Missing <param> documentation for "engine"]

Implements

IGridServer..::.AbortEngine(Guid)

See Also

GridServer Class
HeuristicLab.Grid Namespace


BeginExecuteEngine Method

GridServer..::.BeginExecuteEngine Method
GridServer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.GridServer.BeginExecuteEngine(System.Byte[])]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Guid BeginExecuteEngine(
    byte[] engine
)

Parameters

engine
Type: array< System..::.Byte >[]()[]

[Missing <param> documentation for "engine"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.GridServer.BeginExecuteEngine(System.Byte[])]

Implements

IGridServer..::.BeginExecuteEngine(array<Byte>[]()[])

See Also

GridServer Class
HeuristicLab.Grid Namespace


EndExecuteEngine Method

GridServer..::.EndExecuteEngine Method
GridServer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.GridServer.EndExecuteEngine(System.Guid)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public byte[] EndExecuteEngine(
    Guid guid
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.GridServer.EndExecuteEngine(System.Guid)]

Implements

IGridServer..::.EndExecuteEngine(Guid)

See Also

GridServer Class
HeuristicLab.Grid Namespace


GridServerApplication Class

GridServerApplication Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.GridServerApplication]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "Grid Server", Description = "Server application for the distributed engine grid.")]
internal class GridServerApplication : ApplicationBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.ApplicationBase
HeuristicLab.Grid..::.GridServerApplication

See Also

GridServerApplication Members
HeuristicLab.Grid Namespace


GridServerApplication Members

[image]

HeuristicLab API Documentation
GridServerApplication Members
GridServerApplication Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GridServerApplication type exposes the following members.

Constructors

Name | Description
GridServerApplication |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from ApplicationBase.)
Name | (Inherited from ApplicationBase.)
Version | (Inherited from ApplicationBase.)

See Also

GridServerApplication Class
HeuristicLab.Grid Namespace


GridServerApplication Constructor

GridServerApplication Constructor
GridServerApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GridServerApplication class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GridServerApplication()

See Also

GridServerApplication Class
HeuristicLab.Grid Namespace


GridServerApplication Methods

[image]

HeuristicLab API Documentation
GridServerApplication Methods
GridServerApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GridServerApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridServerApplication Class
HeuristicLab.Grid Namespace


Run Method

GridServerApplication..::.Run Method
GridServerApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.GridServerApplication.Run]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Run()

Implements

IApplication..::.Run()()()

See Also

GridServerApplication Class
HeuristicLab.Grid Namespace


HeuristicLabGridPlugin Class

HeuristicLabGridPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.HeuristicLabGridPlugin]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Grid.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[ClassInfoAttribute(Name = "HeuristicLab.Grid")]
public class HeuristicLabGridPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Grid..::.HeuristicLabGridPlugin

See Also

HeuristicLabGridPlugin Members
HeuristicLab.Grid Namespace


HeuristicLabGridPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabGridPlugin Members
HeuristicLabGridPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabGridPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabGridPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabGridPlugin Class
HeuristicLab.Grid Namespace


HeuristicLabGridPlugin Constructor

HeuristicLabGridPlugin Constructor
HeuristicLabGridPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabGridPlugin class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabGridPlugin()

See Also

HeuristicLabGridPlugin Class
HeuristicLab.Grid Namespace


IEngineStore Interface

IEngineStore Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.IEngineStore]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ServiceContractAttribute(Namespace = "http://HeuristicLab.Grid")]
internal interface IEngineStore

See Also

IEngineStore Members
HeuristicLab.Grid Namespace


IEngineStore Members

[image]

HeuristicLab API Documentation
IEngineStore Members
IEngineStore Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEngineStore type exposes the following members.

Methods

Name | Description
StoreResult |
TryTakeEngine |

See Also

IEngineStore Interface
HeuristicLab.Grid Namespace


IEngineStore Methods

[image]

HeuristicLab API Documentation
IEngineStore Methods
IEngineStore Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IEngineStore type exposes the following members.

Methods

Name | Description
StoreResult |
TryTakeEngine |

See Also

IEngineStore Interface
HeuristicLab.Grid Namespace


StoreResult Method

IEngineStore..::.StoreResult Method
IEngineStore Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.IEngineStore.StoreResult(System.Guid,System.Byte[])]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[OperationContractAttribute]
void StoreResult(
    Guid guid,
    byte[] result
)

Parameters

guid
Type: System..::.Guid

[Missing <param> documentation for "guid"]

result
Type: array< System..::.Byte >[]()[]

[Missing <param> documentation for "result"]

See Also

IEngineStore Interface
HeuristicLab.Grid Namespace


TryTakeEngine Method

IEngineStore..::.TryTakeEngine Method
IEngineStore Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.IEngineStore.TryTakeEngine(System.Guid@,System.Byte[]@)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[OperationContractAttribute]
bool TryTakeEngine(
    out Guid guid,
    out byte[] engine
)

Parameters

guid
Type: System..::.Guid %

[Missing <param> documentation for "guid"]

engine
Type: array< System..::.Byte >[]()[] %

[Missing <param> documentation for "engine"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.IEngineStore.TryTakeEngine(System.Guid@,System.Byte[]@)]

See Also

IEngineStore Interface
HeuristicLab.Grid Namespace


IGridServer Interface

IGridServer Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.IGridServer]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ServiceContractAttribute(Namespace = "http://HeuristicLab.Grid")]
public interface IGridServer

See Also

IGridServer Members
HeuristicLab.Grid Namespace


IGridServer Members

[image]

HeuristicLab API Documentation
IGridServer Members
IGridServer Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IGridServer type exposes the following members.

Methods

Name | Description
AbortEngine |
BeginExecuteEngine |
EndExecuteEngine |

See Also

IGridServer Interface
HeuristicLab.Grid Namespace


IGridServer Methods

[image]

HeuristicLab API Documentation
IGridServer Methods
IGridServer Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IGridServer type exposes the following members.

Methods

Name | Description
AbortEngine |
BeginExecuteEngine |
EndExecuteEngine |

See Also

IGridServer Interface
HeuristicLab.Grid Namespace


AbortEngine Method

IGridServer..::.AbortEngine Method
IGridServer Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.IGridServer.AbortEngine(System.Guid)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[OperationContractAttribute]
void AbortEngine(
    Guid engineGuid
)

Parameters

engineGuid
Type: System..::.Guid

[Missing <param> documentation for "engineGuid"]

See Also

IGridServer Interface
HeuristicLab.Grid Namespace


BeginExecuteEngine Method

IGridServer..::.BeginExecuteEngine Method
IGridServer Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.IGridServer.BeginExecuteEngine(System.Byte[])]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[OperationContractAttribute]
Guid BeginExecuteEngine(
    byte[] engine
)

Parameters

engine
Type: array< System..::.Byte >[]()[]

[Missing <param> documentation for "engine"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.IGridServer.BeginExecuteEngine(System.Byte[])]

See Also

IGridServer Interface
HeuristicLab.Grid Namespace


EndExecuteEngine Method

IGridServer..::.EndExecuteEngine Method
IGridServer Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.IGridServer.EndExecuteEngine(System.Guid)]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[OperationContractAttribute]
byte[] EndExecuteEngine(
    Guid engineGuid
)

Parameters

engineGuid
Type: System..::.Guid

[Missing <param> documentation for "engineGuid"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.IGridServer.EndExecuteEngine(System.Guid)]

See Also

IGridServer Interface
HeuristicLab.Grid Namespace


ProcessingEngine Class

ProcessingEngine Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.ProcessingEngine]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ProcessingEngine : EngineBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.EngineBase
HeuristicLab.Grid..::.ProcessingEngine

See Also

ProcessingEngine Members
HeuristicLab.Grid Namespace


ProcessingEngine Members

[image]

HeuristicLab API Documentation
ProcessingEngine Members
ProcessingEngine Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProcessingEngine type exposes the following members.

Constructors

Name | Description
ProcessingEngine | Overloaded.

Methods

Name | Description
Abort | (Inherited from EngineBase.)
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from EngineBase.)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Inherited from EngineBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides EngineBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
Populate | (Overrides EngineBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

Fields

Name | Description
myCanceled | (Inherited from EngineBase.)
myExecutionStack | (Inherited from EngineBase.)
myGlobalScope | (Inherited from EngineBase.)
myOperatorGraph | (Inherited from EngineBase.)
myRunning | (Inherited from EngineBase.)

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
InitialOperation |
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
Terminated | (Inherited from EngineBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred | (Inherited from EngineBase.)
ExecutionTimeChanged | (Inherited from EngineBase.)
Finished | (Inherited from EngineBase.)
Initialized | (Inherited from EngineBase.)
OperationExecuted | (Inherited from EngineBase.)

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


ProcessingEngine Constructor

[image]

HeuristicLab API Documentation
ProcessingEngine Constructor
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ProcessingEngine()()() |
ProcessingEngine(IOperatorGraph, IScope, AtomicOperation) |

See Also

ProcessingEngine Class
ProcessingEngine Members
HeuristicLab.Grid Namespace


ProcessingEngine Constructor

ProcessingEngine Constructor
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProcessingEngine class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProcessingEngine()

See Also

ProcessingEngine Class
ProcessingEngine Overload
HeuristicLab.Grid Namespace


ProcessingEngine Constructor (IOperatorGraph, IScope, AtomicOperation)

ProcessingEngine Constructor (IOperatorGraph, IScope, AtomicOperation)
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProcessingEngine class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProcessingEngine(
    IOperatorGraph graph,
    IScope globalScope,
    AtomicOperation initialOperation
)

Parameters

graph
Type: HeuristicLab.Core..::.IOperatorGraph

[Missing <param> documentation for "graph"]

globalScope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "globalScope"]

initialOperation
Type: HeuristicLab.Core..::.AtomicOperation

[Missing <param> documentation for "initialOperation"]

See Also

ProcessingEngine Class
ProcessingEngine Overload
HeuristicLab.Grid Namespace


ProcessingEngine Methods

[image]

HeuristicLab API Documentation
ProcessingEngine Methods
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProcessingEngine type exposes the following members.

Methods

Name | Description
Abort | (Inherited from EngineBase.)
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from EngineBase.)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Inherited from EngineBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides EngineBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
Populate | (Overrides EngineBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


Clone Method

[image]

HeuristicLab API Documentation
ProcessingEngine..::.Clone Method
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from EngineBase.)

See Also

ProcessingEngine Class
ProcessingEngine Members
HeuristicLab.Grid Namespace


GetXmlNode Method

ProcessingEngine..::.GetXmlNode Method
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.ProcessingEngine.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Grid.ProcessingEngine.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


Populate Method

ProcessingEngine..::.Populate Method
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.ProcessingEngine.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


ProcessNextOperation Method

ProcessingEngine..::.ProcessNextOperation Method
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Grid.ProcessingEngine.ProcessNextOperation]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void ProcessNextOperation()

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


ProcessingEngine Properties

[image]

HeuristicLab API Documentation
ProcessingEngine Properties
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProcessingEngine type exposes the following members.

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
InitialOperation |
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
Terminated | (Inherited from EngineBase.)

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


InitialOperation Property

ProcessingEngine..::.InitialOperation Property
ProcessingEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Grid.ProcessingEngine.InitialOperation]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AtomicOperation InitialOperation { get; }

See Also

ProcessingEngine Class
HeuristicLab.Grid Namespace


ServerForm Class

ServerForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Grid.ServerForm]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ServerForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Grid..::.ServerForm

See Also

ServerForm Members
HeuristicLab.Grid Namespace


ServerForm Members

[image]

HeuristicLab API Documentation
ServerForm Members
ServerForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ServerForm type exposes the following members.

Constructors

Name | Description
ServerForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ServerForm Class
HeuristicLab.Grid Namespace


ServerForm Constructor

ServerForm Constructor
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ServerForm class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ServerForm()

See Also

ServerForm Class
HeuristicLab.Grid Namespace


ServerForm Methods

[image]

HeuristicLab API Documentation
ServerForm Methods
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ServerForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ServerForm Class
HeuristicLab.Grid Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ServerForm..::.AccessibilityNotifyClients Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ServerForm..::.BeginInvoke Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ServerForm..::.Dispose Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Dispose Method (Boolean)

ServerForm..::.Dispose Method (Boolean)
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ServerForm Class
Dispose Overload
HeuristicLab.Grid Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ServerForm..::.GetChildAtPoint Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ServerForm..::.Invalidate Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ServerForm..::.Invoke Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ServerForm..::.MemberwiseClone Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ServerForm..::.PerformLayout Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ServerForm..::.ResumeLayout Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ServerForm..::.RtlTranslateAlignment Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Scale Method

[image]

HeuristicLab API Documentation
ServerForm..::.Scale Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Select Method

[image]

HeuristicLab API Documentation
ServerForm..::.Select Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ServerForm..::.SetBounds Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Show Method

[image]

HeuristicLab API Documentation
ServerForm..::.Show Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ServerForm..::.ShowDialog Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ServerForm..::.UpdateBounds Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


Validate Method

[image]

HeuristicLab API Documentation
ServerForm..::.Validate Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ServerForm..::.ValidateChildren Method
ServerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ServerForm Class
ServerForm Members
HeuristicLab.Grid Namespace


HeuristicLab.Logging Namespace

HeuristicLab.Logging Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Logging]

Classes

Class | Description
BestAverageWorstQualityCalculator |
HeuristicLabLoggingPlugin |
Linechart |
LinechartInjector |
LinechartView |
Log |
LogView |
QualityLogger |


BestAverageWorstQualityCalculator Class

BestAverageWorstQualityCalculator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.BestAverageWorstQualityCalculator]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class BestAverageWorstQualityCalculator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Logging..::.BestAverageWorstQualityCalculator

See Also

BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


BestAverageWorstQualityCalculator Members

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator Members
BestAverageWorstQualityCalculator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BestAverageWorstQualityCalculator type exposes the following members.

Constructors

Name | Description
BestAverageWorstQualityCalculator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
HeuristicLab.Logging Namespace


BestAverageWorstQualityCalculator Constructor

BestAverageWorstQualityCalculator Constructor
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the BestAverageWorstQualityCalculator class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public BestAverageWorstQualityCalculator()

See Also

BestAverageWorstQualityCalculator Class
HeuristicLab.Logging Namespace


BestAverageWorstQualityCalculator Methods

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator Methods
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BestAverageWorstQualityCalculator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

BestAverageWorstQualityCalculator Class
HeuristicLab.Logging Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.AddSubOperator Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


Apply Method

BestAverageWorstQualityCalculator..::.Apply Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.BestAverageWorstQualityCalculator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.BestAverageWorstQualityCalculator.Apply(HeuristicLab.Core.IScope)]

See Also

BestAverageWorstQualityCalculator Class
HeuristicLab.Logging Namespace


Clone Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.Clone Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.GetVariableValue Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


IsValid Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.IsValid Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.TryAddSubOperator Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.TryAddVariable Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.TryAddVariableInfo Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.TryRemoveSubOperator Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.TryRemoveVariable Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator..::.TryRemoveVariableInfo Method
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
BestAverageWorstQualityCalculator Members
HeuristicLab.Logging Namespace


BestAverageWorstQualityCalculator Properties

[image]

HeuristicLab API Documentation
BestAverageWorstQualityCalculator Properties
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The BestAverageWorstQualityCalculator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

BestAverageWorstQualityCalculator Class
HeuristicLab.Logging Namespace


Description Property

BestAverageWorstQualityCalculator..::.Description Property
BestAverageWorstQualityCalculator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.BestAverageWorstQualityCalculator.Description]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

BestAverageWorstQualityCalculator Class
HeuristicLab.Logging Namespace


HeuristicLabLoggingPlugin Class

HeuristicLabLoggingPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.HeuristicLabLoggingPlugin]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[ClassInfoAttribute(Name = "HeuristicLab.Logging")]
[PluginFileAttribute(Filename = "HeuristicLab.Logging.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Charting")]
[DependencyAttribute(Dependency = "HeuristicLab.Charting.Data")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
public class HeuristicLabLoggingPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Logging..::.HeuristicLabLoggingPlugin

See Also

HeuristicLabLoggingPlugin Members
HeuristicLab.Logging Namespace


HeuristicLabLoggingPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabLoggingPlugin Members
HeuristicLabLoggingPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabLoggingPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabLoggingPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabLoggingPlugin Class
HeuristicLab.Logging Namespace


HeuristicLabLoggingPlugin Constructor

HeuristicLabLoggingPlugin Constructor
HeuristicLabLoggingPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabLoggingPlugin class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabLoggingPlugin()

See Also

HeuristicLabLoggingPlugin Class
HeuristicLab.Logging Namespace


Linechart Class

Linechart Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.Linechart]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Linechart : ItemBase, IVisualizationItem,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Logging..::.Linechart

See Also

Linechart Members
HeuristicLab.Logging Namespace


Linechart Members

[image]

HeuristicLab API Documentation
Linechart Members
Linechart Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linechart type exposes the following members.

Constructors

Name | Description
Linechart | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnNumberOfLinesChanged |
OnValuesChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
NumberOfLines |
Values |

Events

Name | Description
Changed | (Inherited from ItemBase.)
NumberOfLinesChanged |
ValuesChanged |

See Also

Linechart Class
HeuristicLab.Logging Namespace


Linechart Constructor

[image]

HeuristicLab API Documentation
Linechart Constructor
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Linechart()()() |
Linechart(Int32, ItemList) |

See Also

Linechart Class
Linechart Members
HeuristicLab.Logging Namespace


Linechart Constructor

Linechart Constructor
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Linechart class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Linechart()

See Also

Linechart Class
Linechart Overload
HeuristicLab.Logging Namespace


Linechart Constructor (Int32, ItemList)

Linechart Constructor (Int32, ItemList)
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Linechart class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Linechart(
    int numberOfLines,
    ItemList values
)

Parameters

numberOfLines
Type: System..::.Int32

[Missing <param> documentation for "numberOfLines"]

values
Type: HeuristicLab.Data..::.ItemList

[Missing <param> documentation for "values"]

See Also

Linechart Class
Linechart Overload
HeuristicLab.Logging Namespace


Linechart Methods

[image]

HeuristicLab API Documentation
Linechart Methods
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linechart type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnNumberOfLinesChanged |
OnValuesChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

Linechart Class
HeuristicLab.Logging Namespace


Clone Method

[image]

HeuristicLab API Documentation
Linechart..::.Clone Method
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Linechart Class
Linechart Members
HeuristicLab.Logging Namespace


Clone Method (IDictionary(Guid, Object))

Linechart..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Linechart.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.Linechart.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Linechart Class
Clone Overload
HeuristicLab.Logging Namespace


CreateView Method

Linechart..::.CreateView Method
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Linechart.CreateView]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.Linechart.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

Linechart Class
HeuristicLab.Logging Namespace


GetXmlNode Method

Linechart..::.GetXmlNode Method
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Linechart.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.Linechart.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Linechart Class
HeuristicLab.Logging Namespace


OnNumberOfLinesChanged Method

Linechart..::.OnNumberOfLinesChanged Method
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Linechart.OnNumberOfLinesChanged]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnNumberOfLinesChanged()

See Also

Linechart Class
HeuristicLab.Logging Namespace


OnValuesChanged Method

Linechart..::.OnValuesChanged Method
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Linechart.OnValuesChanged]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnValuesChanged()

See Also

Linechart Class
HeuristicLab.Logging Namespace


Populate Method

Linechart..::.Populate Method
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Linechart.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Linechart Class
HeuristicLab.Logging Namespace


Linechart Properties

[image]

HeuristicLab API Documentation
Linechart Properties
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linechart type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
NumberOfLines |
Values |

See Also

Linechart Class
HeuristicLab.Logging Namespace


NumberOfLines Property

Linechart..::.NumberOfLines Property
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.Linechart.NumberOfLines]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int NumberOfLines { get; set; }

See Also

Linechart Class
HeuristicLab.Logging Namespace


Values Property

Linechart..::.Values Property
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.Linechart.Values]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Values { get; set; }

See Also

Linechart Class
HeuristicLab.Logging Namespace


Linechart Events

[image]

HeuristicLab API Documentation
Linechart Events
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linechart type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
NumberOfLinesChanged |
ValuesChanged |

See Also

Linechart Class
HeuristicLab.Logging Namespace


NumberOfLinesChanged Event

Linechart..::.NumberOfLinesChanged Event
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Logging.Linechart.NumberOfLinesChanged]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler NumberOfLinesChanged

See Also

Linechart Class
HeuristicLab.Logging Namespace


ValuesChanged Event

Linechart..::.ValuesChanged Event
Linechart Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Logging.Linechart.ValuesChanged]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ValuesChanged

See Also

Linechart Class
HeuristicLab.Logging Namespace


LinechartInjector Class

LinechartInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.LinechartInjector]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LinechartInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Logging..::.LinechartInjector

See Also

LinechartInjector Members
HeuristicLab.Logging Namespace


LinechartInjector Members

[image]

HeuristicLab API Documentation
LinechartInjector Members
LinechartInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinechartInjector type exposes the following members.

Constructors

Name | Description
LinechartInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
HeuristicLab.Logging Namespace


LinechartInjector Constructor

LinechartInjector Constructor
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinechartInjector class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LinechartInjector()

See Also

LinechartInjector Class
HeuristicLab.Logging Namespace


LinechartInjector Methods

[image]

HeuristicLab API Documentation
LinechartInjector Methods
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinechartInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LinechartInjector Class
HeuristicLab.Logging Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.AddSubOperator Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


Apply Method

LinechartInjector..::.Apply Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LinechartInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.LinechartInjector.Apply(HeuristicLab.Core.IScope)]

See Also

LinechartInjector Class
HeuristicLab.Logging Namespace


Clone Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.Clone Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.GetVariableValue Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.IsValid Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.TryAddSubOperator Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.TryAddVariable Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.TryAddVariableInfo Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.TryRemoveSubOperator Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.TryRemoveVariable Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LinechartInjector..::.TryRemoveVariableInfo Method
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
LinechartInjector Members
HeuristicLab.Logging Namespace


LinechartInjector Properties

[image]

HeuristicLab API Documentation
LinechartInjector Properties
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinechartInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

LinechartInjector Class
HeuristicLab.Logging Namespace


Description Property

LinechartInjector..::.Description Property
LinechartInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.LinechartInjector.Description]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LinechartInjector Class
HeuristicLab.Logging Namespace


LinechartView Class

LinechartView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.LinechartView]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LinechartView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Logging..::.LinechartView

See Also

LinechartView Members
HeuristicLab.Logging Namespace


LinechartView Members

[image]

HeuristicLab API Documentation
LinechartView Members
LinechartView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinechartView type exposes the following members.

Constructors

Name | Description
LinechartView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Linechart |
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

LinechartView Class
HeuristicLab.Logging Namespace


LinechartView Constructor

[image]

HeuristicLab API Documentation
LinechartView Constructor
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LinechartView()()() |
LinechartView(Linechart) |

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


LinechartView Constructor

LinechartView Constructor
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinechartView class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LinechartView()

See Also

LinechartView Class
LinechartView Overload
HeuristicLab.Logging Namespace


LinechartView Constructor (Linechart)

LinechartView Constructor (Linechart)
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinechartView class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LinechartView(
    Linechart linechart
)

Parameters

linechart
Type: HeuristicLab.Logging..::.Linechart

[Missing <param> documentation for "linechart"]

See Also

LinechartView Class
LinechartView Overload
HeuristicLab.Logging Namespace


LinechartView Methods

[image]

HeuristicLab API Documentation
LinechartView Methods
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinechartView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

LinechartView Class
HeuristicLab.Logging Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
LinechartView..::.AccessibilityNotifyClients Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


AddItemEvents Method

LinechartView..::.AddItemEvents Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LinechartView.AddItemEvents]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

LinechartView Class
HeuristicLab.Logging Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
LinechartView..::.BeginInvoke Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


Dispose Method

[image]

HeuristicLab API Documentation
LinechartView..::.Dispose Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


Dispose Method (Boolean)

LinechartView..::.Dispose Method (Boolean)
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

LinechartView Class
Dispose Overload
HeuristicLab.Logging Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
LinechartView..::.GetChildAtPoint Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
LinechartView..::.Invalidate Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


Invoke Method

[image]

HeuristicLab API Documentation
LinechartView..::.Invoke Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
LinechartView..::.MemberwiseClone Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
LinechartView..::.PerformLayout Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


RemoveItemEvents Method

LinechartView..::.RemoveItemEvents Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LinechartView.RemoveItemEvents]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

LinechartView Class
HeuristicLab.Logging Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
LinechartView..::.ResumeLayout Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
LinechartView..::.RtlTranslateAlignment Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


Scale Method

[image]

HeuristicLab API Documentation
LinechartView..::.Scale Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


Select Method

[image]

HeuristicLab API Documentation
LinechartView..::.Select Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
LinechartView..::.SetBounds Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
LinechartView..::.UpdateBounds Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


UpdateControls Method

LinechartView..::.UpdateControls Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LinechartView.UpdateControls]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

LinechartView Class
HeuristicLab.Logging Namespace


Validate Method

[image]

HeuristicLab API Documentation
LinechartView..::.Validate Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
LinechartView..::.ValidateChildren Method
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

LinechartView Class
LinechartView Members
HeuristicLab.Logging Namespace


LinechartView Properties

[image]

HeuristicLab API Documentation
LinechartView Properties
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinechartView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Linechart |
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

LinechartView Class
HeuristicLab.Logging Namespace


Linechart Property

LinechartView..::.Linechart Property
LinechartView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.LinechartView.Linechart]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Linechart Linechart { get; set; }

See Also

LinechartView Class
HeuristicLab.Logging Namespace


Log Class

Log Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.Log]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Log : ItemBase, IVisualizationItem, IItem,
    IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Logging..::.Log

See Also

Log Members
HeuristicLab.Logging Namespace


Log Members

[image]

HeuristicLab API Documentation
Log Members
Log Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Log type exposes the following members.

Constructors

Name | Description
Log | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnItemsChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Items |

Events

Name | Description
Changed | (Inherited from ItemBase.)
ItemsChanged |

See Also

Log Class
HeuristicLab.Logging Namespace


Log Constructor

[image]

HeuristicLab API Documentation
Log Constructor
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Log()()() |
Log(ItemList) |

See Also

Log Class
Log Members
HeuristicLab.Logging Namespace


Log Constructor

Log Constructor
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Log class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Log()

See Also

Log Class
Log Overload
HeuristicLab.Logging Namespace


Log Constructor (ItemList)

Log Constructor (ItemList)
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Log class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Log(
    ItemList items
)

Parameters

items
Type: HeuristicLab.Data..::.ItemList

[Missing <param> documentation for "items"]

See Also

Log Class
Log Overload
HeuristicLab.Logging Namespace


Log Methods

[image]

HeuristicLab API Documentation
Log Methods
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Log type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnItemsChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

Log Class
HeuristicLab.Logging Namespace


Clone Method

[image]

HeuristicLab API Documentation
Log..::.Clone Method
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Log Class
Log Members
HeuristicLab.Logging Namespace


Clone Method (IDictionary(Guid, Object))

Log..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Log.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.Log.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Log Class
Clone Overload
HeuristicLab.Logging Namespace


CreateView Method

Log..::.CreateView Method
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Log.CreateView]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.Log.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

Log Class
HeuristicLab.Logging Namespace


GetXmlNode Method

Log..::.GetXmlNode Method
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Log.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.Log.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Log Class
HeuristicLab.Logging Namespace


OnItemsChanged Method

Log..::.OnItemsChanged Method
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Log.OnItemsChanged]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnItemsChanged()

See Also

Log Class
HeuristicLab.Logging Namespace


Populate Method

Log..::.Populate Method
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.Log.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Log Class
HeuristicLab.Logging Namespace


Log Properties

[image]

HeuristicLab API Documentation
Log Properties
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Log type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Items |

See Also

Log Class
HeuristicLab.Logging Namespace


Items Property

Log..::.Items Property
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.Log.Items]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Items { get; set; }

See Also

Log Class
HeuristicLab.Logging Namespace


Log Events

[image]

HeuristicLab API Documentation
Log Events
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Log type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
ItemsChanged |

See Also

Log Class
HeuristicLab.Logging Namespace


ItemsChanged Event

Log..::.ItemsChanged Event
Log Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Logging.Log.ItemsChanged]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler ItemsChanged

See Also

Log Class
HeuristicLab.Logging Namespace


LogView Class

LogView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.LogView]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LogView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Logging..::.LogView

See Also

LogView Members
HeuristicLab.Logging Namespace


LogView Members

[image]

HeuristicLab API Documentation
LogView Members
LogView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LogView type exposes the following members.

Constructors

Name | Description
LogView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Log |
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

LogView Class
HeuristicLab.Logging Namespace


LogView Constructor

[image]

HeuristicLab API Documentation
LogView Constructor
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LogView()()() |
LogView(Log) |

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


LogView Constructor

LogView Constructor
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LogView class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LogView()

See Also

LogView Class
LogView Overload
HeuristicLab.Logging Namespace


LogView Constructor (Log)

LogView Constructor (Log)
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LogView class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LogView(
    Log log
)

Parameters

log
Type: HeuristicLab.Logging..::.Log

[Missing <param> documentation for "log"]

See Also

LogView Class
LogView Overload
HeuristicLab.Logging Namespace


LogView Methods

[image]

HeuristicLab API Documentation
LogView Methods
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LogView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

LogView Class
HeuristicLab.Logging Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
LogView..::.AccessibilityNotifyClients Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


AddItemEvents Method

LogView..::.AddItemEvents Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LogView.AddItemEvents]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

LogView Class
HeuristicLab.Logging Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
LogView..::.BeginInvoke Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


Dispose Method

[image]

HeuristicLab API Documentation
LogView..::.Dispose Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


Dispose Method (Boolean)

LogView..::.Dispose Method (Boolean)
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

LogView Class
Dispose Overload
HeuristicLab.Logging Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
LogView..::.GetChildAtPoint Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
LogView..::.Invalidate Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


Invoke Method

[image]

HeuristicLab API Documentation
LogView..::.Invoke Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
LogView..::.MemberwiseClone Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
LogView..::.PerformLayout Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


RemoveItemEvents Method

LogView..::.RemoveItemEvents Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LogView.RemoveItemEvents]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

LogView Class
HeuristicLab.Logging Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
LogView..::.ResumeLayout Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
LogView..::.RtlTranslateAlignment Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


Scale Method

[image]

HeuristicLab API Documentation
LogView..::.Scale Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


Select Method

[image]

HeuristicLab API Documentation
LogView..::.Select Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
LogView..::.SetBounds Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
LogView..::.UpdateBounds Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


UpdateControls Method

LogView..::.UpdateControls Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.LogView.UpdateControls]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

LogView Class
HeuristicLab.Logging Namespace


Validate Method

[image]

HeuristicLab API Documentation
LogView..::.Validate Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
LogView..::.ValidateChildren Method
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

LogView Class
LogView Members
HeuristicLab.Logging Namespace


LogView Properties

[image]

HeuristicLab API Documentation
LogView Properties
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LogView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Log |
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

LogView Class
HeuristicLab.Logging Namespace


Log Property

LogView..::.Log Property
LogView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.LogView.Log]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Log Log { get; set; }

See Also

LogView Class
HeuristicLab.Logging Namespace


QualityLogger Class

QualityLogger Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Logging.QualityLogger]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class QualityLogger : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Logging..::.QualityLogger

See Also

QualityLogger Members
HeuristicLab.Logging Namespace


QualityLogger Members

[image]

HeuristicLab API Documentation
QualityLogger Members
QualityLogger Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The QualityLogger type exposes the following members.

Constructors

Name | Description
QualityLogger |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

QualityLogger Class
HeuristicLab.Logging Namespace


QualityLogger Constructor

QualityLogger Constructor
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the QualityLogger class.

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public QualityLogger()

See Also

QualityLogger Class
HeuristicLab.Logging Namespace


QualityLogger Methods

[image]

HeuristicLab API Documentation
QualityLogger Methods
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The QualityLogger type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

QualityLogger Class
HeuristicLab.Logging Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
QualityLogger..::.AddSubOperator Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


Apply Method

QualityLogger..::.Apply Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Logging.QualityLogger.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Logging.QualityLogger.Apply(HeuristicLab.Core.IScope)]

See Also

QualityLogger Class
HeuristicLab.Logging Namespace


Clone Method

[image]

HeuristicLab API Documentation
QualityLogger..::.Clone Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
QualityLogger..::.GetVariableValue Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


IsValid Method

[image]

HeuristicLab API Documentation
QualityLogger..::.IsValid Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
QualityLogger..::.TryAddSubOperator Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
QualityLogger..::.TryAddVariable Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
QualityLogger..::.TryAddVariableInfo Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
QualityLogger..::.TryRemoveSubOperator Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
QualityLogger..::.TryRemoveVariable Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
QualityLogger..::.TryRemoveVariableInfo Method
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

QualityLogger Class
QualityLogger Members
HeuristicLab.Logging Namespace


QualityLogger Properties

[image]

HeuristicLab API Documentation
QualityLogger Properties
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The QualityLogger type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

QualityLogger Class
HeuristicLab.Logging Namespace


Description Property

QualityLogger..::.Description Property
QualityLogger Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Logging.QualityLogger.Description]

Namespace: HeuristicLab.Logging
Assembly: HeuristicLab.Logging (in HeuristicLab.Logging.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

QualityLogger Class
HeuristicLab.Logging Namespace


HeuristicLab.Operators Namespace

HeuristicLab.Operators Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Operators]

Classes

Class | Description
CombinedOperator |
CombinedOperatorView |
ComparatorBase |
ConditionalBranch |
Counter |
DataCollector |
EmptyOperator |
EqualToComparator |
GreaterOrEqualThanComparator |
GreaterThanComparator |
HeuristicLabOperatorsPlugin |
HeuristicLabOperatorsProgrammablePlugin |
LessOrEqualThanComparator |
LessThanComparator |
OperatorExtractor |
ParallelProcessor |
ParallelSubScopesProcessor |
SequentialProcessor |
SequentialSubScopesProcessor |
SingleObjectiveEvaluatorBase |
Sorter |
StochasticBranch |
SubScopesCreater |
SubScopesMixer |
UnequalToComparator |
UniformParallelSubScopesProcessor |
UniformSequentialSubScopesProcessor |
VariableInjector |
VariableInjectorView |


CombinedOperator Class

CombinedOperator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.CombinedOperator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CombinedOperator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.CombinedOperator

See Also

CombinedOperator Members
HeuristicLab.Operators Namespace


CombinedOperator Members

[image]

HeuristicLab API Documentation
CombinedOperator Members
CombinedOperator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperator type exposes the following members.

Constructors

Name | Description
CombinedOperator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnDescriptionChanged |
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Overrides OperatorBase ..::. Reset()()().)
SetDescription |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
OperatorGraph |
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
DescriptionChanged |
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


CombinedOperator Constructor

CombinedOperator Constructor
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CombinedOperator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CombinedOperator()

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


CombinedOperator Methods

[image]

HeuristicLab API Documentation
CombinedOperator Methods
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnDescriptionChanged |
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Overrides OperatorBase ..::. Reset()()().)
SetDescription |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.AddSubOperator Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


Apply Method

CombinedOperator..::.Apply Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.CombinedOperator.Apply(HeuristicLab.Core.IScope)]

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.Clone Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


Clone Method (IDictionary(Guid, Object))

CombinedOperator..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.CombinedOperator.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

CombinedOperator Class
Clone Overload
HeuristicLab.Operators Namespace


CreateView Method

CombinedOperator..::.CreateView Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.CreateView]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.CombinedOperator.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.GetVariableValue Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


GetXmlNode Method

CombinedOperator..::.GetXmlNode Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.CombinedOperator.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.IsValid Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


OnDescriptionChanged Method

CombinedOperator..::.OnDescriptionChanged Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.OnDescriptionChanged]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnDescriptionChanged()

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


Populate Method

CombinedOperator..::.Populate Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


Reset Method

CombinedOperator..::.Reset Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.Reset]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Reset()

Implements

IOperator..::.Reset()()()

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


SetDescription Method

CombinedOperator..::.SetDescription Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperator.SetDescription(System.String)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetDescription(
    string description
)

Parameters

description
Type: System..::.String

[Missing <param> documentation for "description"]

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.TryAddSubOperator Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.TryAddVariable Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.TryAddVariableInfo Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.TryRemoveSubOperator Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.TryRemoveVariable Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CombinedOperator..::.TryRemoveVariableInfo Method
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
CombinedOperator Members
HeuristicLab.Operators Namespace


CombinedOperator Properties

[image]

HeuristicLab API Documentation
CombinedOperator Properties
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
OperatorGraph |
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


Description Property

CombinedOperator..::.Description Property
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.CombinedOperator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


OperatorGraph Property

CombinedOperator..::.OperatorGraph Property
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.CombinedOperator.OperatorGraph]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorGraph OperatorGraph { get; }

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


CombinedOperator Events

[image]

HeuristicLab API Documentation
CombinedOperator Events
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperator type exposes the following members.

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
DescriptionChanged |
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


DescriptionChanged Event

CombinedOperator..::.DescriptionChanged Event
CombinedOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Operators.CombinedOperator.DescriptionChanged]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler DescriptionChanged

See Also

CombinedOperator Class
HeuristicLab.Operators Namespace


CombinedOperatorView Class

CombinedOperatorView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.CombinedOperatorView]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CombinedOperatorView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Operators..::.CombinedOperatorView

See Also

CombinedOperatorView Members
HeuristicLab.Operators Namespace


CombinedOperatorView Members

[image]

HeuristicLab API Documentation
CombinedOperatorView Members
CombinedOperatorView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperatorView type exposes the following members.

Constructors

Name | Description
CombinedOperatorView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CombinedOperator |
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


CombinedOperatorView Constructor

[image]

HeuristicLab API Documentation
CombinedOperatorView Constructor
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CombinedOperatorView()()() |
CombinedOperatorView(CombinedOperator) |

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


CombinedOperatorView Constructor

CombinedOperatorView Constructor
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CombinedOperatorView class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CombinedOperatorView()

See Also

CombinedOperatorView Class
CombinedOperatorView Overload
HeuristicLab.Operators Namespace


CombinedOperatorView Constructor (CombinedOperator)

CombinedOperatorView Constructor (CombinedOperator)
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CombinedOperatorView class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CombinedOperatorView(
    CombinedOperator combinedOperator
)

Parameters

combinedOperator
Type: HeuristicLab.Operators..::.CombinedOperator

[Missing <param> documentation for "combinedOperator"]

See Also

CombinedOperatorView Class
CombinedOperatorView Overload
HeuristicLab.Operators Namespace


CombinedOperatorView Methods

[image]

HeuristicLab API Documentation
CombinedOperatorView Methods
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperatorView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.AccessibilityNotifyClients Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


AddItemEvents Method

CombinedOperatorView..::.AddItemEvents Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperatorView.AddItemEvents]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.BeginInvoke Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


Dispose Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.Dispose Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


Dispose Method (Boolean)

CombinedOperatorView..::.Dispose Method (Boolean)
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

CombinedOperatorView Class
Dispose Overload
HeuristicLab.Operators Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.GetChildAtPoint Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.Invalidate Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


Invoke Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.Invoke Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.MemberwiseClone Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.PerformLayout Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


RemoveItemEvents Method

CombinedOperatorView..::.RemoveItemEvents Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperatorView.RemoveItemEvents]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.ResumeLayout Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.RtlTranslateAlignment Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


Scale Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.Scale Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


Select Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.Select Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.SetBounds Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.UpdateBounds Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


UpdateControls Method

CombinedOperatorView..::.UpdateControls Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.CombinedOperatorView.UpdateControls]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


Validate Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.Validate Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
CombinedOperatorView..::.ValidateChildren Method
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

CombinedOperatorView Class
CombinedOperatorView Members
HeuristicLab.Operators Namespace


CombinedOperatorView Properties

[image]

HeuristicLab API Documentation
CombinedOperatorView Properties
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CombinedOperatorView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CombinedOperator |
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


CombinedOperator Property

CombinedOperatorView..::.CombinedOperator Property
CombinedOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.CombinedOperatorView.CombinedOperator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CombinedOperator CombinedOperator { get; set; }

See Also

CombinedOperatorView Class
HeuristicLab.Operators Namespace


ComparatorBase Class

ComparatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.ComparatorBase]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ComparatorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.LessOrEqualThanComparator
HeuristicLab.Operators..::.GreaterThanComparator
HeuristicLab.Operators..::.GreaterOrEqualThanComparator
HeuristicLab.Operators..::.UnequalToComparator
HeuristicLab.Operators..::.EqualToComparator
HeuristicLab.Operators..::.LessThanComparator

See Also

ComparatorBase Members
HeuristicLab.Operators Namespace


ComparatorBase Members

[image]

HeuristicLab API Documentation
ComparatorBase Members
ComparatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComparatorBase type exposes the following members.

Constructors

Name | Description
ComparatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
Compare |
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
HeuristicLab.Operators Namespace


ComparatorBase Constructor

ComparatorBase Constructor
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ComparatorBase class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ComparatorBase()

See Also

ComparatorBase Class
HeuristicLab.Operators Namespace


ComparatorBase Methods

[image]

HeuristicLab API Documentation
ComparatorBase Methods
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ComparatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
Compare |
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ComparatorBase Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.AddSubOperator Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


Apply Method

ComparatorBase..::.Apply Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.ComparatorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.ComparatorBase.Apply(HeuristicLab.Core.IScope)]

See Also

ComparatorBase Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.Clone Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


Compare Method

ComparatorBase..::.Compare Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.ComparatorBase.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.ComparatorBase.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

ComparatorBase Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.GetVariableValue Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.IsValid Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.TryAddSubOperator Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.TryAddVariable Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.TryAddVariableInfo Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.TryRemoveSubOperator Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.TryRemoveVariable Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ComparatorBase..::.TryRemoveVariableInfo Method
ComparatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ComparatorBase Class
ComparatorBase Members
HeuristicLab.Operators Namespace


ConditionalBranch Class

ConditionalBranch Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.ConditionalBranch]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConditionalBranch : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ConditionalBranch

See Also

ConditionalBranch Members
HeuristicLab.Operators Namespace


ConditionalBranch Members

[image]

HeuristicLab API Documentation
ConditionalBranch Members
ConditionalBranch Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConditionalBranch type exposes the following members.

Constructors

Name | Description
ConditionalBranch |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
HeuristicLab.Operators Namespace


ConditionalBranch Constructor

ConditionalBranch Constructor
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConditionalBranch class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConditionalBranch()

See Also

ConditionalBranch Class
HeuristicLab.Operators Namespace


ConditionalBranch Methods

[image]

HeuristicLab API Documentation
ConditionalBranch Methods
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConditionalBranch type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ConditionalBranch Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.AddSubOperator Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


Apply Method

ConditionalBranch..::.Apply Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.ConditionalBranch.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.ConditionalBranch.Apply(HeuristicLab.Core.IScope)]

See Also

ConditionalBranch Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.Clone Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.GetVariableValue Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.IsValid Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.TryAddSubOperator Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.TryAddVariable Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.TryAddVariableInfo Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.TryRemoveSubOperator Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.TryRemoveVariable Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ConditionalBranch..::.TryRemoveVariableInfo Method
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
ConditionalBranch Members
HeuristicLab.Operators Namespace


ConditionalBranch Properties

[image]

HeuristicLab API Documentation
ConditionalBranch Properties
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConditionalBranch type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ConditionalBranch Class
HeuristicLab.Operators Namespace


Description Property

ConditionalBranch..::.Description Property
ConditionalBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.ConditionalBranch.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ConditionalBranch Class
HeuristicLab.Operators Namespace


Counter Class

Counter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.Counter]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Counter : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.Counter

See Also

Counter Members
HeuristicLab.Operators Namespace


Counter Members

[image]

HeuristicLab API Documentation
Counter Members
Counter Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Counter type exposes the following members.

Constructors

Name | Description
Counter |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Counter Class
HeuristicLab.Operators Namespace


Counter Constructor

Counter Constructor
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Counter class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Counter()

See Also

Counter Class
HeuristicLab.Operators Namespace


Counter Methods

[image]

HeuristicLab API Documentation
Counter Methods
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Counter type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Counter Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Counter..::.AddSubOperator Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


Apply Method

Counter..::.Apply Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Counter.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.Counter.Apply(HeuristicLab.Core.IScope)]

See Also

Counter Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
Counter..::.Clone Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Counter..::.GetVariableValue Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Counter..::.IsValid Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Counter..::.TryAddSubOperator Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Counter..::.TryAddVariable Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Counter..::.TryAddVariableInfo Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Counter..::.TryRemoveSubOperator Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Counter..::.TryRemoveVariable Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Counter..::.TryRemoveVariableInfo Method
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Counter Class
Counter Members
HeuristicLab.Operators Namespace


Counter Properties

[image]

HeuristicLab API Documentation
Counter Properties
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Counter type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

Counter Class
HeuristicLab.Operators Namespace


Description Property

Counter..::.Description Property
Counter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.Counter.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Counter Class
HeuristicLab.Operators Namespace


DataCollector Class

DataCollector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.DataCollector]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DataCollector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.DataCollector

See Also

DataCollector Members
HeuristicLab.Operators Namespace


DataCollector Members

[image]

HeuristicLab API Documentation
DataCollector Members
DataCollector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataCollector type exposes the following members.

Constructors

Name | Description
DataCollector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

DataCollector Class
HeuristicLab.Operators Namespace


DataCollector Constructor

DataCollector Constructor
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DataCollector class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DataCollector()

See Also

DataCollector Class
HeuristicLab.Operators Namespace


DataCollector Methods

[image]

HeuristicLab API Documentation
DataCollector Methods
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataCollector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

DataCollector Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
DataCollector..::.AddSubOperator Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


Apply Method

DataCollector..::.Apply Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.DataCollector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.DataCollector.Apply(HeuristicLab.Core.IScope)]

See Also

DataCollector Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
DataCollector..::.Clone Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
DataCollector..::.GetVariableValue Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
DataCollector..::.IsValid Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
DataCollector..::.TryAddSubOperator Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
DataCollector..::.TryAddVariable Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
DataCollector..::.TryAddVariableInfo Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
DataCollector..::.TryRemoveSubOperator Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
DataCollector..::.TryRemoveVariable Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
DataCollector..::.TryRemoveVariableInfo Method
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DataCollector Class
DataCollector Members
HeuristicLab.Operators Namespace


DataCollector Properties

[image]

HeuristicLab API Documentation
DataCollector Properties
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DataCollector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

DataCollector Class
HeuristicLab.Operators Namespace


Description Property

DataCollector..::.Description Property
DataCollector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.DataCollector.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

DataCollector Class
HeuristicLab.Operators Namespace


EmptyOperator Class

EmptyOperator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.EmptyOperator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EmptyOperator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.EmptyOperator

See Also

EmptyOperator Members
HeuristicLab.Operators Namespace


EmptyOperator Members

[image]

HeuristicLab API Documentation
EmptyOperator Members
EmptyOperator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EmptyOperator type exposes the following members.

Constructors

Name | Description
EmptyOperator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
HeuristicLab.Operators Namespace


EmptyOperator Constructor

EmptyOperator Constructor
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EmptyOperator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EmptyOperator()

See Also

EmptyOperator Class
HeuristicLab.Operators Namespace


EmptyOperator Methods

[image]

HeuristicLab API Documentation
EmptyOperator Methods
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EmptyOperator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

EmptyOperator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.AddSubOperator Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


Apply Method

EmptyOperator..::.Apply Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.EmptyOperator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.EmptyOperator.Apply(HeuristicLab.Core.IScope)]

See Also

EmptyOperator Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.Clone Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.GetVariableValue Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.IsValid Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.TryAddSubOperator Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.TryAddVariable Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.TryAddVariableInfo Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.TryRemoveSubOperator Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.TryRemoveVariable Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
EmptyOperator..::.TryRemoveVariableInfo Method
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
EmptyOperator Members
HeuristicLab.Operators Namespace


EmptyOperator Properties

[image]

HeuristicLab API Documentation
EmptyOperator Properties
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EmptyOperator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

EmptyOperator Class
HeuristicLab.Operators Namespace


Description Property

EmptyOperator..::.Description Property
EmptyOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.EmptyOperator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

EmptyOperator Class
HeuristicLab.Operators Namespace


EqualToComparator Class

EqualToComparator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.EqualToComparator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EqualToComparator : ComparatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.EqualToComparator

See Also

EqualToComparator Members
HeuristicLab.Operators Namespace


EqualToComparator Members

[image]

HeuristicLab API Documentation
EqualToComparator Members
EqualToComparator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EqualToComparator type exposes the following members.

Constructors

Name | Description
EqualToComparator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
HeuristicLab.Operators Namespace


EqualToComparator Constructor

EqualToComparator Constructor
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EqualToComparator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EqualToComparator()

See Also

EqualToComparator Class
HeuristicLab.Operators Namespace


EqualToComparator Methods

[image]

HeuristicLab API Documentation
EqualToComparator Methods
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EqualToComparator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

EqualToComparator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.AddSubOperator Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.Clone Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


Compare Method

EqualToComparator..::.Compare Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.EqualToComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.EqualToComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

EqualToComparator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.GetVariableValue Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.IsValid Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.TryAddSubOperator Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.TryAddVariable Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.TryAddVariableInfo Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.TryRemoveSubOperator Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.TryRemoveVariable Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
EqualToComparator..::.TryRemoveVariableInfo Method
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
EqualToComparator Members
HeuristicLab.Operators Namespace


EqualToComparator Properties

[image]

HeuristicLab API Documentation
EqualToComparator Properties
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EqualToComparator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

EqualToComparator Class
HeuristicLab.Operators Namespace


Description Property

EqualToComparator..::.Description Property
EqualToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.EqualToComparator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

EqualToComparator Class
HeuristicLab.Operators Namespace


GreaterOrEqualThanComparator Class

GreaterOrEqualThanComparator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.GreaterOrEqualThanComparator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class GreaterOrEqualThanComparator : ComparatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.GreaterOrEqualThanComparator

See Also

GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


GreaterOrEqualThanComparator Members

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator Members
GreaterOrEqualThanComparator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GreaterOrEqualThanComparator type exposes the following members.

Constructors

Name | Description
GreaterOrEqualThanComparator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
HeuristicLab.Operators Namespace


GreaterOrEqualThanComparator Constructor

GreaterOrEqualThanComparator Constructor
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GreaterOrEqualThanComparator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GreaterOrEqualThanComparator()

See Also

GreaterOrEqualThanComparator Class
HeuristicLab.Operators Namespace


GreaterOrEqualThanComparator Methods

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator Methods
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GreaterOrEqualThanComparator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

GreaterOrEqualThanComparator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.AddSubOperator Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.Clone Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


Compare Method

GreaterOrEqualThanComparator..::.Compare Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.GreaterOrEqualThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.GreaterOrEqualThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

GreaterOrEqualThanComparator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.GetVariableValue Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.IsValid Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.TryAddSubOperator Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.TryAddVariable Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.TryAddVariableInfo Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.TryRemoveSubOperator Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.TryRemoveVariable Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator..::.TryRemoveVariableInfo Method
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
GreaterOrEqualThanComparator Members
HeuristicLab.Operators Namespace


GreaterOrEqualThanComparator Properties

[image]

HeuristicLab API Documentation
GreaterOrEqualThanComparator Properties
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GreaterOrEqualThanComparator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

GreaterOrEqualThanComparator Class
HeuristicLab.Operators Namespace


Description Property

GreaterOrEqualThanComparator..::.Description Property
GreaterOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.GreaterOrEqualThanComparator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

GreaterOrEqualThanComparator Class
HeuristicLab.Operators Namespace


GreaterThanComparator Class

GreaterThanComparator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.GreaterThanComparator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class GreaterThanComparator : ComparatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.GreaterThanComparator

See Also

GreaterThanComparator Members
HeuristicLab.Operators Namespace


GreaterThanComparator Members

[image]

HeuristicLab API Documentation
GreaterThanComparator Members
GreaterThanComparator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GreaterThanComparator type exposes the following members.

Constructors

Name | Description
GreaterThanComparator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
HeuristicLab.Operators Namespace


GreaterThanComparator Constructor

GreaterThanComparator Constructor
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GreaterThanComparator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GreaterThanComparator()

See Also

GreaterThanComparator Class
HeuristicLab.Operators Namespace


GreaterThanComparator Methods

[image]

HeuristicLab API Documentation
GreaterThanComparator Methods
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GreaterThanComparator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

GreaterThanComparator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.AddSubOperator Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.Clone Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


Compare Method

GreaterThanComparator..::.Compare Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.GreaterThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.GreaterThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

GreaterThanComparator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.GetVariableValue Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.IsValid Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.TryAddSubOperator Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.TryAddVariable Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.TryAddVariableInfo Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.TryRemoveSubOperator Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.TryRemoveVariable Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
GreaterThanComparator..::.TryRemoveVariableInfo Method
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
GreaterThanComparator Members
HeuristicLab.Operators Namespace


GreaterThanComparator Properties

[image]

HeuristicLab API Documentation
GreaterThanComparator Properties
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GreaterThanComparator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

GreaterThanComparator Class
HeuristicLab.Operators Namespace


Description Property

GreaterThanComparator..::.Description Property
GreaterThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.GreaterThanComparator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

GreaterThanComparator Class
HeuristicLab.Operators Namespace


HeuristicLabOperatorsPlugin Class

HeuristicLabOperatorsPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.HeuristicLabOperatorsPlugin]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Operators.dll", Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Operators")]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
public class HeuristicLabOperatorsPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Operators..::.HeuristicLabOperatorsPlugin

See Also

HeuristicLabOperatorsPlugin Members
HeuristicLab.Operators Namespace


HeuristicLabOperatorsPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabOperatorsPlugin Members
HeuristicLabOperatorsPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabOperatorsPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabOperatorsPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabOperatorsPlugin Class
HeuristicLab.Operators Namespace


HeuristicLabOperatorsPlugin Constructor

HeuristicLabOperatorsPlugin Constructor
HeuristicLabOperatorsPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabOperatorsPlugin class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabOperatorsPlugin()

See Also

HeuristicLabOperatorsPlugin Class
HeuristicLab.Operators Namespace


HeuristicLabOperatorsProgrammablePlugin Class

HeuristicLabOperatorsProgrammablePlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.HeuristicLabOperatorsProgrammablePlugin]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Operators.Programmable.dll",
    Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Operators.Programmable")]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
public class HeuristicLabOperatorsProgrammablePlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Operators..::.HeuristicLabOperatorsProgrammablePlugin

See Also

HeuristicLabOperatorsProgrammablePlugin Members
HeuristicLab.Operators Namespace


HeuristicLabOperatorsProgrammablePlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabOperatorsProgrammablePlugin Members
HeuristicLabOperatorsProgrammablePlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabOperatorsProgrammablePlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabOperatorsProgrammablePlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabOperatorsProgrammablePlugin Class
HeuristicLab.Operators Namespace


HeuristicLabOperatorsProgrammablePlugin Constructor

HeuristicLabOperatorsProgrammablePlugin Constructor
HeuristicLabOperatorsProgrammablePlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabOperatorsProgrammablePlugin class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabOperatorsProgrammablePlugin()

See Also

HeuristicLabOperatorsProgrammablePlugin Class
HeuristicLab.Operators Namespace


LessOrEqualThanComparator Class

LessOrEqualThanComparator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.LessOrEqualThanComparator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LessOrEqualThanComparator : ComparatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.LessOrEqualThanComparator

See Also

LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


LessOrEqualThanComparator Members

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator Members
LessOrEqualThanComparator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessOrEqualThanComparator type exposes the following members.

Constructors

Name | Description
LessOrEqualThanComparator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
HeuristicLab.Operators Namespace


LessOrEqualThanComparator Constructor

LessOrEqualThanComparator Constructor
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LessOrEqualThanComparator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LessOrEqualThanComparator()

See Also

LessOrEqualThanComparator Class
HeuristicLab.Operators Namespace


LessOrEqualThanComparator Methods

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator Methods
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessOrEqualThanComparator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LessOrEqualThanComparator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.AddSubOperator Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.Clone Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


Compare Method

LessOrEqualThanComparator..::.Compare Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.LessOrEqualThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.LessOrEqualThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

LessOrEqualThanComparator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.GetVariableValue Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.IsValid Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.TryAddSubOperator Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.TryAddVariable Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.TryAddVariableInfo Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.TryRemoveSubOperator Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.TryRemoveVariable Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator..::.TryRemoveVariableInfo Method
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
LessOrEqualThanComparator Members
HeuristicLab.Operators Namespace


LessOrEqualThanComparator Properties

[image]

HeuristicLab API Documentation
LessOrEqualThanComparator Properties
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessOrEqualThanComparator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

LessOrEqualThanComparator Class
HeuristicLab.Operators Namespace


Description Property

LessOrEqualThanComparator..::.Description Property
LessOrEqualThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.LessOrEqualThanComparator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LessOrEqualThanComparator Class
HeuristicLab.Operators Namespace


LessThanComparator Class

LessThanComparator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.LessThanComparator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LessThanComparator : ComparatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.LessThanComparator

See Also

LessThanComparator Members
HeuristicLab.Operators Namespace


LessThanComparator Members

[image]

HeuristicLab API Documentation
LessThanComparator Members
LessThanComparator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessThanComparator type exposes the following members.

Constructors

Name | Description
LessThanComparator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
HeuristicLab.Operators Namespace


LessThanComparator Constructor

LessThanComparator Constructor
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LessThanComparator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LessThanComparator()

See Also

LessThanComparator Class
HeuristicLab.Operators Namespace


LessThanComparator Methods

[image]

HeuristicLab API Documentation
LessThanComparator Methods
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessThanComparator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LessThanComparator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.AddSubOperator Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.Clone Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


Compare Method

LessThanComparator..::.Compare Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.LessThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.LessThanComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

LessThanComparator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.GetVariableValue Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.IsValid Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.TryAddSubOperator Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.TryAddVariable Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.TryAddVariableInfo Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.TryRemoveSubOperator Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.TryRemoveVariable Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LessThanComparator..::.TryRemoveVariableInfo Method
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
LessThanComparator Members
HeuristicLab.Operators Namespace


LessThanComparator Properties

[image]

HeuristicLab API Documentation
LessThanComparator Properties
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LessThanComparator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

LessThanComparator Class
HeuristicLab.Operators Namespace


Description Property

LessThanComparator..::.Description Property
LessThanComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.LessThanComparator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LessThanComparator Class
HeuristicLab.Operators Namespace


OperatorExtractor Class

OperatorExtractor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.OperatorExtractor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperatorExtractor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.OperatorExtractor

See Also

OperatorExtractor Members
HeuristicLab.Operators Namespace


OperatorExtractor Members

[image]

HeuristicLab API Documentation
OperatorExtractor Members
OperatorExtractor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorExtractor type exposes the following members.

Constructors

Name | Description
OperatorExtractor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
HeuristicLab.Operators Namespace


OperatorExtractor Constructor

OperatorExtractor Constructor
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorExtractor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorExtractor()

See Also

OperatorExtractor Class
HeuristicLab.Operators Namespace


OperatorExtractor Methods

[image]

HeuristicLab API Documentation
OperatorExtractor Methods
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorExtractor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OperatorExtractor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.AddSubOperator Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


Apply Method

OperatorExtractor..::.Apply Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.OperatorExtractor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.OperatorExtractor.Apply(HeuristicLab.Core.IScope)]

See Also

OperatorExtractor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.Clone Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.GetVariableValue Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.IsValid Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.TryAddSubOperator Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.TryAddVariable Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.TryAddVariableInfo Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.TryRemoveSubOperator Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.TryRemoveVariable Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OperatorExtractor..::.TryRemoveVariableInfo Method
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
OperatorExtractor Members
HeuristicLab.Operators Namespace


OperatorExtractor Properties

[image]

HeuristicLab API Documentation
OperatorExtractor Properties
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorExtractor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OperatorExtractor Class
HeuristicLab.Operators Namespace


Description Property

OperatorExtractor..::.Description Property
OperatorExtractor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.OperatorExtractor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OperatorExtractor Class
HeuristicLab.Operators Namespace


ParallelProcessor Class

ParallelProcessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.ParallelProcessor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ParallelProcessor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ParallelProcessor

See Also

ParallelProcessor Members
HeuristicLab.Operators Namespace


ParallelProcessor Members

[image]

HeuristicLab API Documentation
ParallelProcessor Members
ParallelProcessor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParallelProcessor type exposes the following members.

Constructors

Name | Description
ParallelProcessor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
HeuristicLab.Operators Namespace


ParallelProcessor Constructor

ParallelProcessor Constructor
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ParallelProcessor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ParallelProcessor()

See Also

ParallelProcessor Class
HeuristicLab.Operators Namespace


ParallelProcessor Methods

[image]

HeuristicLab API Documentation
ParallelProcessor Methods
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParallelProcessor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ParallelProcessor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.AddSubOperator Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


Apply Method

ParallelProcessor..::.Apply Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.ParallelProcessor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.ParallelProcessor.Apply(HeuristicLab.Core.IScope)]

See Also

ParallelProcessor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.Clone Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.GetVariableValue Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.IsValid Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.TryAddSubOperator Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.TryAddVariable Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.TryAddVariableInfo Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.TryRemoveSubOperator Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.TryRemoveVariable Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ParallelProcessor..::.TryRemoveVariableInfo Method
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
ParallelProcessor Members
HeuristicLab.Operators Namespace


ParallelProcessor Properties

[image]

HeuristicLab API Documentation
ParallelProcessor Properties
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParallelProcessor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ParallelProcessor Class
HeuristicLab.Operators Namespace


Description Property

ParallelProcessor..::.Description Property
ParallelProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.ParallelProcessor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ParallelProcessor Class
HeuristicLab.Operators Namespace


ParallelSubScopesProcessor Class

ParallelSubScopesProcessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.ParallelSubScopesProcessor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ParallelSubScopesProcessor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ParallelSubScopesProcessor

See Also

ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


ParallelSubScopesProcessor Members

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor Members
ParallelSubScopesProcessor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParallelSubScopesProcessor type exposes the following members.

Constructors

Name | Description
ParallelSubScopesProcessor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


ParallelSubScopesProcessor Constructor

ParallelSubScopesProcessor Constructor
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ParallelSubScopesProcessor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ParallelSubScopesProcessor()

See Also

ParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


ParallelSubScopesProcessor Methods

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor Methods
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParallelSubScopesProcessor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.AddSubOperator Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


Apply Method

ParallelSubScopesProcessor..::.Apply Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.ParallelSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.ParallelSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

See Also

ParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.Clone Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.GetVariableValue Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.IsValid Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.TryAddSubOperator Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.TryAddVariable Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.TryAddVariableInfo Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.TryRemoveSubOperator Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.TryRemoveVariable Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor..::.TryRemoveVariableInfo Method
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
ParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


ParallelSubScopesProcessor Properties

[image]

HeuristicLab API Documentation
ParallelSubScopesProcessor Properties
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParallelSubScopesProcessor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


Description Property

ParallelSubScopesProcessor..::.Description Property
ParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.ParallelSubScopesProcessor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


SequentialProcessor Class

SequentialProcessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.SequentialProcessor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SequentialProcessor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SequentialProcessor

See Also

SequentialProcessor Members
HeuristicLab.Operators Namespace


SequentialProcessor Members

[image]

HeuristicLab API Documentation
SequentialProcessor Members
SequentialProcessor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialProcessor type exposes the following members.

Constructors

Name | Description
SequentialProcessor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
HeuristicLab.Operators Namespace


SequentialProcessor Constructor

SequentialProcessor Constructor
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SequentialProcessor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SequentialProcessor()

See Also

SequentialProcessor Class
HeuristicLab.Operators Namespace


SequentialProcessor Methods

[image]

HeuristicLab API Documentation
SequentialProcessor Methods
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialProcessor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SequentialProcessor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.AddSubOperator Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


Apply Method

SequentialProcessor..::.Apply Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.SequentialProcessor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.SequentialProcessor.Apply(HeuristicLab.Core.IScope)]

See Also

SequentialProcessor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.Clone Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.GetVariableValue Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.IsValid Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.TryAddSubOperator Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.TryAddVariable Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.TryAddVariableInfo Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.TryRemoveSubOperator Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.TryRemoveVariable Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SequentialProcessor..::.TryRemoveVariableInfo Method
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
SequentialProcessor Members
HeuristicLab.Operators Namespace


SequentialProcessor Properties

[image]

HeuristicLab API Documentation
SequentialProcessor Properties
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialProcessor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SequentialProcessor Class
HeuristicLab.Operators Namespace


Description Property

SequentialProcessor..::.Description Property
SequentialProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.SequentialProcessor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SequentialProcessor Class
HeuristicLab.Operators Namespace


SequentialSubScopesProcessor Class

SequentialSubScopesProcessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.SequentialSubScopesProcessor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SequentialSubScopesProcessor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SequentialSubScopesProcessor

See Also

SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


SequentialSubScopesProcessor Members

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor Members
SequentialSubScopesProcessor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialSubScopesProcessor type exposes the following members.

Constructors

Name | Description
SequentialSubScopesProcessor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


SequentialSubScopesProcessor Constructor

SequentialSubScopesProcessor Constructor
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SequentialSubScopesProcessor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SequentialSubScopesProcessor()

See Also

SequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


SequentialSubScopesProcessor Methods

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor Methods
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialSubScopesProcessor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.AddSubOperator Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


Apply Method

SequentialSubScopesProcessor..::.Apply Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.SequentialSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.SequentialSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

See Also

SequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.Clone Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.GetVariableValue Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.IsValid Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.TryAddSubOperator Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.TryAddVariable Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.TryAddVariableInfo Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.TryRemoveSubOperator Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.TryRemoveVariable Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor..::.TryRemoveVariableInfo Method
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
SequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


SequentialSubScopesProcessor Properties

[image]

HeuristicLab API Documentation
SequentialSubScopesProcessor Properties
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialSubScopesProcessor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


Description Property

SequentialSubScopesProcessor..::.Description Property
SequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.SequentialSubScopesProcessor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


SingleObjectiveEvaluatorBase Class

SingleObjectiveEvaluatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.SingleObjectiveEvaluatorBase]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class SingleObjectiveEvaluatorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.Routing.TSP..::.DistanceMatrixPathTSPEvaluator
HeuristicLab.Routing.TSP..::.PathTSPEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase

See Also

SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


SingleObjectiveEvaluatorBase Members

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase Members
SingleObjectiveEvaluatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SingleObjectiveEvaluatorBase type exposes the following members.

Constructors

Name | Description
SingleObjectiveEvaluatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate |
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
HeuristicLab.Operators Namespace


SingleObjectiveEvaluatorBase Constructor

SingleObjectiveEvaluatorBase Constructor
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SingleObjectiveEvaluatorBase class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SingleObjectiveEvaluatorBase()

See Also

SingleObjectiveEvaluatorBase Class
HeuristicLab.Operators Namespace


SingleObjectiveEvaluatorBase Methods

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase Methods
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SingleObjectiveEvaluatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate |
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SingleObjectiveEvaluatorBase Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.AddSubOperator Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


Apply Method

SingleObjectiveEvaluatorBase..::.Apply Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.SingleObjectiveEvaluatorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.SingleObjectiveEvaluatorBase.Apply(HeuristicLab.Core.IScope)]

See Also

SingleObjectiveEvaluatorBase Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.Clone Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


Evaluate Method

SingleObjectiveEvaluatorBase..::.Evaluate Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.SingleObjectiveEvaluatorBase.Evaluate(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract double Evaluate(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.SingleObjectiveEvaluatorBase.Evaluate(HeuristicLab.Core.IScope)]

See Also

SingleObjectiveEvaluatorBase Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.GetVariableValue Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.IsValid Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.TryAddSubOperator Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.TryAddVariable Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.TryAddVariableInfo Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.TryRemoveSubOperator Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.TryRemoveVariable Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SingleObjectiveEvaluatorBase..::.TryRemoveVariableInfo Method
SingleObjectiveEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SingleObjectiveEvaluatorBase Class
SingleObjectiveEvaluatorBase Members
HeuristicLab.Operators Namespace


Sorter Class

Sorter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.Sorter]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Sorter : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.Sorter

See Also

Sorter Members
HeuristicLab.Operators Namespace


Sorter Members

[image]

HeuristicLab API Documentation
Sorter Members
Sorter Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sorter type exposes the following members.

Constructors

Name | Description
Sorter |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Sorter Class
HeuristicLab.Operators Namespace


Sorter Constructor

Sorter Constructor
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Sorter class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Sorter()

See Also

Sorter Class
HeuristicLab.Operators Namespace


Sorter Methods

[image]

HeuristicLab API Documentation
Sorter Methods
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sorter type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Sorter Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Sorter..::.AddSubOperator Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


Apply Method

Sorter..::.Apply Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Sorter.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.Sorter.Apply(HeuristicLab.Core.IScope)]

See Also

Sorter Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
Sorter..::.Clone Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Sorter..::.GetVariableValue Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Sorter..::.IsValid Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Sorter..::.TryAddSubOperator Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Sorter..::.TryAddVariable Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Sorter..::.TryAddVariableInfo Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Sorter..::.TryRemoveSubOperator Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Sorter..::.TryRemoveVariable Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Sorter..::.TryRemoveVariableInfo Method
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Sorter Class
Sorter Members
HeuristicLab.Operators Namespace


Sorter Properties

[image]

HeuristicLab API Documentation
Sorter Properties
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sorter type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

Sorter Class
HeuristicLab.Operators Namespace


Description Property

Sorter..::.Description Property
Sorter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.Sorter.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Sorter Class
HeuristicLab.Operators Namespace


StochasticBranch Class

StochasticBranch Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.StochasticBranch]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class StochasticBranch : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.StochasticBranch

See Also

StochasticBranch Members
HeuristicLab.Operators Namespace


StochasticBranch Members

[image]

HeuristicLab API Documentation
StochasticBranch Members
StochasticBranch Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StochasticBranch type exposes the following members.

Constructors

Name | Description
StochasticBranch |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
HeuristicLab.Operators Namespace


StochasticBranch Constructor

StochasticBranch Constructor
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StochasticBranch class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StochasticBranch()

See Also

StochasticBranch Class
HeuristicLab.Operators Namespace


StochasticBranch Methods

[image]

HeuristicLab API Documentation
StochasticBranch Methods
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StochasticBranch type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

StochasticBranch Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.AddSubOperator Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


Apply Method

StochasticBranch..::.Apply Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.StochasticBranch.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.StochasticBranch.Apply(HeuristicLab.Core.IScope)]

See Also

StochasticBranch Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.Clone Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.GetVariableValue Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.IsValid Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.TryAddSubOperator Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.TryAddVariable Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.TryAddVariableInfo Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.TryRemoveSubOperator Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.TryRemoveVariable Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
StochasticBranch..::.TryRemoveVariableInfo Method
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
StochasticBranch Members
HeuristicLab.Operators Namespace


StochasticBranch Properties

[image]

HeuristicLab API Documentation
StochasticBranch Properties
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StochasticBranch type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

StochasticBranch Class
HeuristicLab.Operators Namespace


Description Property

StochasticBranch..::.Description Property
StochasticBranch Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.StochasticBranch.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

StochasticBranch Class
HeuristicLab.Operators Namespace


SubScopesCreater Class

SubScopesCreater Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.SubScopesCreater]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubScopesCreater : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SubScopesCreater

See Also

SubScopesCreater Members
HeuristicLab.Operators Namespace


SubScopesCreater Members

[image]

HeuristicLab API Documentation
SubScopesCreater Members
SubScopesCreater Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesCreater type exposes the following members.

Constructors

Name | Description
SubScopesCreater |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
HeuristicLab.Operators Namespace


SubScopesCreater Constructor

SubScopesCreater Constructor
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubScopesCreater class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubScopesCreater()

See Also

SubScopesCreater Class
HeuristicLab.Operators Namespace


SubScopesCreater Methods

[image]

HeuristicLab API Documentation
SubScopesCreater Methods
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesCreater type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SubScopesCreater Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.AddSubOperator Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


Apply Method

SubScopesCreater..::.Apply Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.SubScopesCreater.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.SubScopesCreater.Apply(HeuristicLab.Core.IScope)]

See Also

SubScopesCreater Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.Clone Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.GetVariableValue Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.IsValid Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.TryAddSubOperator Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.TryAddVariable Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.TryAddVariableInfo Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.TryRemoveSubOperator Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.TryRemoveVariable Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SubScopesCreater..::.TryRemoveVariableInfo Method
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
SubScopesCreater Members
HeuristicLab.Operators Namespace


SubScopesCreater Properties

[image]

HeuristicLab API Documentation
SubScopesCreater Properties
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesCreater type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SubScopesCreater Class
HeuristicLab.Operators Namespace


Description Property

SubScopesCreater..::.Description Property
SubScopesCreater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.SubScopesCreater.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SubScopesCreater Class
HeuristicLab.Operators Namespace


SubScopesMixer Class

SubScopesMixer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.SubScopesMixer]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubScopesMixer : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SubScopesMixer

See Also

SubScopesMixer Members
HeuristicLab.Operators Namespace


SubScopesMixer Members

[image]

HeuristicLab API Documentation
SubScopesMixer Members
SubScopesMixer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesMixer type exposes the following members.

Constructors

Name | Description
SubScopesMixer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
HeuristicLab.Operators Namespace


SubScopesMixer Constructor

SubScopesMixer Constructor
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubScopesMixer class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubScopesMixer()

See Also

SubScopesMixer Class
HeuristicLab.Operators Namespace


SubScopesMixer Methods

[image]

HeuristicLab API Documentation
SubScopesMixer Methods
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesMixer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SubScopesMixer Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.AddSubOperator Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


Apply Method

SubScopesMixer..::.Apply Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.SubScopesMixer.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.SubScopesMixer.Apply(HeuristicLab.Core.IScope)]

See Also

SubScopesMixer Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.Clone Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.GetVariableValue Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.IsValid Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.TryAddSubOperator Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.TryAddVariable Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.TryAddVariableInfo Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.TryRemoveSubOperator Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.TryRemoveVariable Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SubScopesMixer..::.TryRemoveVariableInfo Method
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
SubScopesMixer Members
HeuristicLab.Operators Namespace


SubScopesMixer Properties

[image]

HeuristicLab API Documentation
SubScopesMixer Properties
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubScopesMixer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SubScopesMixer Class
HeuristicLab.Operators Namespace


Description Property

SubScopesMixer..::.Description Property
SubScopesMixer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.SubScopesMixer.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SubScopesMixer Class
HeuristicLab.Operators Namespace


UnequalToComparator Class

UnequalToComparator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.UnequalToComparator]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UnequalToComparator : ComparatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.ComparatorBase
HeuristicLab.Operators..::.UnequalToComparator

See Also

UnequalToComparator Members
HeuristicLab.Operators Namespace


UnequalToComparator Members

[image]

HeuristicLab API Documentation
UnequalToComparator Members
UnequalToComparator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UnequalToComparator type exposes the following members.

Constructors

Name | Description
UnequalToComparator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
HeuristicLab.Operators Namespace


UnequalToComparator Constructor

UnequalToComparator Constructor
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UnequalToComparator class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UnequalToComparator()

See Also

UnequalToComparator Class
HeuristicLab.Operators Namespace


UnequalToComparator Methods

[image]

HeuristicLab API Documentation
UnequalToComparator Methods
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UnequalToComparator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ComparatorBase.)
Clone | Overloaded.
Compare | (Overrides ComparatorBase ..::. Compare(IComparable, IItem).)
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UnequalToComparator Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.AddSubOperator Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.Clone Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


Compare Method

UnequalToComparator..::.Compare Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.UnequalToComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override bool Compare(
    IComparable left,
    IItem right
)

Parameters

left
Type: System..::.IComparable

[Missing <param> documentation for "left"]

right
Type: HeuristicLab.Core..::.IItem

[Missing <param> documentation for "right"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.UnequalToComparator.Compare(System.IComparable,HeuristicLab.Core.IItem)]

See Also

UnequalToComparator Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.GetVariableValue Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.IsValid Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.TryAddSubOperator Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.TryAddVariable Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.TryAddVariableInfo Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.TryRemoveSubOperator Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.TryRemoveVariable Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UnequalToComparator..::.TryRemoveVariableInfo Method
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
UnequalToComparator Members
HeuristicLab.Operators Namespace


UnequalToComparator Properties

[image]

HeuristicLab API Documentation
UnequalToComparator Properties
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UnequalToComparator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UnequalToComparator Class
HeuristicLab.Operators Namespace


Description Property

UnequalToComparator..::.Description Property
UnequalToComparator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.UnequalToComparator.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UnequalToComparator Class
HeuristicLab.Operators Namespace


UniformParallelSubScopesProcessor Class

UniformParallelSubScopesProcessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.UniformParallelSubScopesProcessor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UniformParallelSubScopesProcessor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.UniformParallelSubScopesProcessor

See Also

UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


UniformParallelSubScopesProcessor Members

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor Members
UniformParallelSubScopesProcessor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformParallelSubScopesProcessor type exposes the following members.

Constructors

Name | Description
UniformParallelSubScopesProcessor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


UniformParallelSubScopesProcessor Constructor

UniformParallelSubScopesProcessor Constructor
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniformParallelSubScopesProcessor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UniformParallelSubScopesProcessor()

See Also

UniformParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


UniformParallelSubScopesProcessor Methods

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor Methods
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformParallelSubScopesProcessor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UniformParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.AddSubOperator Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


Apply Method

UniformParallelSubScopesProcessor..::.Apply Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.UniformParallelSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.UniformParallelSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

See Also

UniformParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.Clone Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.GetVariableValue Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.IsValid Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.TryAddSubOperator Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.TryAddVariable Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.TryAddVariableInfo Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.TryRemoveSubOperator Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.TryRemoveVariable Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor..::.TryRemoveVariableInfo Method
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
UniformParallelSubScopesProcessor Members
HeuristicLab.Operators Namespace


UniformParallelSubScopesProcessor Properties

[image]

HeuristicLab API Documentation
UniformParallelSubScopesProcessor Properties
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformParallelSubScopesProcessor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UniformParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


Description Property

UniformParallelSubScopesProcessor..::.Description Property
UniformParallelSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.UniformParallelSubScopesProcessor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UniformParallelSubScopesProcessor Class
HeuristicLab.Operators Namespace


UniformSequentialSubScopesProcessor Class

UniformSequentialSubScopesProcessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.UniformSequentialSubScopesProcessor]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UniformSequentialSubScopesProcessor : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.UniformSequentialSubScopesProcessor

See Also

UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


UniformSequentialSubScopesProcessor Members

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor Members
UniformSequentialSubScopesProcessor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformSequentialSubScopesProcessor type exposes the following members.

Constructors

Name | Description
UniformSequentialSubScopesProcessor |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


UniformSequentialSubScopesProcessor Constructor

UniformSequentialSubScopesProcessor Constructor
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniformSequentialSubScopesProcessor class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UniformSequentialSubScopesProcessor()

See Also

UniformSequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


UniformSequentialSubScopesProcessor Methods

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor Methods
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformSequentialSubScopesProcessor type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UniformSequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.AddSubOperator Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


Apply Method

UniformSequentialSubScopesProcessor..::.Apply Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.UniformSequentialSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.UniformSequentialSubScopesProcessor.Apply(HeuristicLab.Core.IScope)]

See Also

UniformSequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.Clone Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.GetVariableValue Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.IsValid Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.TryAddSubOperator Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.TryAddVariable Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.TryAddVariableInfo Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.TryRemoveSubOperator Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.TryRemoveVariable Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor..::.TryRemoveVariableInfo Method
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
UniformSequentialSubScopesProcessor Members
HeuristicLab.Operators Namespace


UniformSequentialSubScopesProcessor Properties

[image]

HeuristicLab API Documentation
UniformSequentialSubScopesProcessor Properties
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformSequentialSubScopesProcessor type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UniformSequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


Description Property

UniformSequentialSubScopesProcessor..::.Description Property
UniformSequentialSubScopesProcessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.UniformSequentialSubScopesProcessor.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UniformSequentialSubScopesProcessor Class
HeuristicLab.Operators Namespace


VariableInjector Class

VariableInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.VariableInjector]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.VariableInjector

See Also

VariableInjector Members
HeuristicLab.Operators Namespace


VariableInjector Members

[image]

HeuristicLab API Documentation
VariableInjector Members
VariableInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInjector type exposes the following members.

Constructors

Name | Description
VariableInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Overrides OperatorBase ..::. AddVariable(IVariable).)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Overrides OperatorBase ..::. RemoveVariable(String).)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


VariableInjector Constructor

VariableInjector Constructor
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInjector class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInjector()

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


VariableInjector Methods

[image]

HeuristicLab API Documentation
VariableInjector Methods
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Overrides OperatorBase ..::. AddVariable(IVariable).)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Overrides OperatorBase ..::. RemoveVariable(String).)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
VariableInjector..::.AddSubOperator Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


AddVariable Method

VariableInjector..::.AddVariable Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.VariableInjector.AddVariable(HeuristicLab.Core.IVariable)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddVariable(
    IVariable variable
)

Parameters

variable
Type: HeuristicLab.Core..::.IVariable

[Missing <param> documentation for "variable"]

Implements

IOperator..::.AddVariable(IVariable)

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


Apply Method

VariableInjector..::.Apply Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.VariableInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.VariableInjector.Apply(HeuristicLab.Core.IScope)]

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


Clone Method

[image]

HeuristicLab API Documentation
VariableInjector..::.Clone Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


Clone Method (IDictionary(Guid, Object))

VariableInjector..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.VariableInjector.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.VariableInjector.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

VariableInjector Class
Clone Overload
HeuristicLab.Operators Namespace


CreateView Method

VariableInjector..::.CreateView Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.VariableInjector.CreateView]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.VariableInjector.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
VariableInjector..::.GetVariableValue Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


GetXmlNode Method

VariableInjector..::.GetXmlNode Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.VariableInjector.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.VariableInjector.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


IsValid Method

[image]

HeuristicLab API Documentation
VariableInjector..::.IsValid Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


RemoveVariable Method

VariableInjector..::.RemoveVariable Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.VariableInjector.RemoveVariable(System.String)]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveVariable(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Implements

IOperator..::.RemoveVariable(String)

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
VariableInjector..::.TryAddSubOperator Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
VariableInjector..::.TryAddVariable Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
VariableInjector..::.TryAddVariableInfo Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
VariableInjector..::.TryRemoveSubOperator Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
VariableInjector..::.TryRemoveVariable Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
VariableInjector..::.TryRemoveVariableInfo Method
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VariableInjector Class
VariableInjector Members
HeuristicLab.Operators Namespace


VariableInjector Properties

[image]

HeuristicLab API Documentation
VariableInjector Properties
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


Description Property

VariableInjector..::.Description Property
VariableInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.VariableInjector.Description]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

VariableInjector Class
HeuristicLab.Operators Namespace


VariableInjectorView Class

VariableInjectorView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.VariableInjectorView]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VariableInjectorView : OperatorBaseView

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.OperatorBaseView
HeuristicLab.Operators..::.VariableInjectorView

See Also

VariableInjectorView Members
HeuristicLab.Operators Namespace


VariableInjectorView Members

[image]

HeuristicLab API Documentation
VariableInjectorView Members
VariableInjectorView Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInjectorView type exposes the following members.

Constructors

Name | Description
VariableInjectorView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from OperatorBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from OperatorBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from OperatorBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
constrainedItemBaseView | (Inherited from OperatorBaseView.)
operatorBaseVariableInfosView | (Inherited from OperatorBaseView.)
operatorBaseVariablesView | (Inherited from OperatorBaseView.)
tabControl | (Inherited from OperatorBaseView.)
variableInfosTabPage | (Inherited from OperatorBaseView.)
variablesTabPage | (Inherited from OperatorBaseView.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator | (Inherited from OperatorBaseView.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableInjector |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VariableInjectorView Class
HeuristicLab.Operators Namespace


VariableInjectorView Constructor

[image]

HeuristicLab API Documentation
VariableInjectorView Constructor
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
VariableInjectorView()()() |
VariableInjectorView(VariableInjector) |

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


VariableInjectorView Constructor

VariableInjectorView Constructor
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInjectorView class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInjectorView()

See Also

VariableInjectorView Class
VariableInjectorView Overload
HeuristicLab.Operators Namespace


VariableInjectorView Constructor (VariableInjector)

VariableInjectorView Constructor (VariableInjector)
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the VariableInjectorView class.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInjectorView(
    VariableInjector variableInjector
)

Parameters

variableInjector
Type: HeuristicLab.Operators..::.VariableInjector

[Missing <param> documentation for "variableInjector"]

See Also

VariableInjectorView Class
VariableInjectorView Overload
HeuristicLab.Operators Namespace


VariableInjectorView Methods

[image]

HeuristicLab API Documentation
VariableInjectorView Methods
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInjectorView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from OperatorBaseView.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from OperatorBaseView.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from OperatorBaseView.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

VariableInjectorView Class
HeuristicLab.Operators Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.AccessibilityNotifyClients Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.BeginInvoke Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Dispose Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.Dispose Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides OperatorBaseView ..::. Dispose(Boolean).)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Dispose Method (Boolean)

VariableInjectorView..::.Dispose Method (Boolean)
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VariableInjectorView Class
Dispose Overload
HeuristicLab.Operators Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.GetChildAtPoint Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.Invalidate Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Invoke Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.Invoke Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.MemberwiseClone Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.PerformLayout Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.ResumeLayout Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.RtlTranslateAlignment Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Scale Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.Scale Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Select Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.Select Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.SetBounds Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.UpdateBounds Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


Validate Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.Validate Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
VariableInjectorView..::.ValidateChildren Method
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

VariableInjectorView Class
VariableInjectorView Members
HeuristicLab.Operators Namespace


VariableInjectorView Properties

[image]

HeuristicLab API Documentation
VariableInjectorView Properties
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VariableInjectorView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operator | (Inherited from OperatorBaseView.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableInjector |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

VariableInjectorView Class
HeuristicLab.Operators Namespace


VariableInjector Property

VariableInjectorView..::.VariableInjector Property
VariableInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.VariableInjectorView.VariableInjector]

Namespace: HeuristicLab.Operators
Assembly: HeuristicLab.Operators (in HeuristicLab.Operators.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VariableInjector VariableInjector { get; set; }

See Also

VariableInjectorView Class
HeuristicLab.Operators Namespace


HeuristicLab.Operators.Programmable Namespace

HeuristicLab.Operators.Programmable Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Operators.Programmable]

Classes

Class | Description
AddVariableInfoDialog |
ProgrammableOperator |
ProgrammableOperatorView |


AddVariableInfoDialog Class

AddVariableInfoDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.Programmable.AddVariableInfoDialog]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AddVariableInfoDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.Operators.Programmable..::.AddVariableInfoDialog

See Also

AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


AddVariableInfoDialog Members

[image]

HeuristicLab API Documentation
AddVariableInfoDialog Members
AddVariableInfoDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AddVariableInfoDialog type exposes the following members.

Constructors

Name | Description
AddVariableInfoDialog |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableInfo |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
HeuristicLab.Operators.Programmable Namespace


AddVariableInfoDialog Constructor

AddVariableInfoDialog Constructor
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AddVariableInfoDialog class.

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AddVariableInfoDialog()

See Also

AddVariableInfoDialog Class
HeuristicLab.Operators.Programmable Namespace


AddVariableInfoDialog Methods

[image]

HeuristicLab API Documentation
AddVariableInfoDialog Methods
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AddVariableInfoDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AddVariableInfoDialog Class
HeuristicLab.Operators.Programmable Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.AccessibilityNotifyClients Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.BeginInvoke Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Dispose Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Dispose Method (Boolean)

AddVariableInfoDialog..::.Dispose Method (Boolean)
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AddVariableInfoDialog Class
Dispose Overload
HeuristicLab.Operators.Programmable Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.GetChildAtPoint Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Invalidate Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Invoke Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.MemberwiseClone Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.PerformLayout Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.ResumeLayout Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.RtlTranslateAlignment Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Scale Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Scale Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Select Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Select Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.SetBounds Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Show Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Show Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.ShowDialog Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.UpdateBounds Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


Validate Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.Validate Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AddVariableInfoDialog..::.ValidateChildren Method
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AddVariableInfoDialog Class
AddVariableInfoDialog Members
HeuristicLab.Operators.Programmable Namespace


AddVariableInfoDialog Properties

[image]

HeuristicLab API Documentation
AddVariableInfoDialog Properties
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AddVariableInfoDialog type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VariableInfo |
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

AddVariableInfoDialog Class
HeuristicLab.Operators.Programmable Namespace


VariableInfo Property

AddVariableInfoDialog..::.VariableInfo Property
AddVariableInfoDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.Programmable.AddVariableInfoDialog.VariableInfo]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IVariableInfo VariableInfo { get; }

See Also

AddVariableInfoDialog Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Class

ProgrammableOperator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.Programmable.ProgrammableOperator]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ProgrammableOperator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators.Programmable..::.ProgrammableOperator

See Also

ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Members

[image]

HeuristicLab API Documentation
ProgrammableOperator Members
ProgrammableOperator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperator type exposes the following members.

Constructors

Name | Description
ProgrammableOperator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
Compile |
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnCodeChanged |
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnDescriptionChanged |
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
SetDescription |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Code |
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
CodeChanged |
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
DescriptionChanged |
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Constructor

ProgrammableOperator Constructor
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProgrammableOperator class.

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProgrammableOperator()

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Methods

[image]

HeuristicLab API Documentation
ProgrammableOperator Methods
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
Compile |
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnCodeChanged |
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnDescriptionChanged |
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
SetDescription |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.AddSubOperator Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


Apply Method

ProgrammableOperator..::.Apply Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.Apply(HeuristicLab.Core.IScope)]

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


Clone Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.Clone Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


Clone Method (IDictionary(Guid, Object))

ProgrammableOperator..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ProgrammableOperator Class
Clone Overload
HeuristicLab.Operators.Programmable Namespace


Compile Method

ProgrammableOperator..::.Compile Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.Compile]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Compile()

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


CreateView Method

ProgrammableOperator..::.CreateView Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.CreateView]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.GetVariableValue Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


GetXmlNode Method

ProgrammableOperator..::.GetXmlNode Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.IsValid Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


OnCodeChanged Method

ProgrammableOperator..::.OnCodeChanged Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.OnCodeChanged]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnCodeChanged()

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


OnDescriptionChanged Method

ProgrammableOperator..::.OnDescriptionChanged Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.OnDescriptionChanged]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnDescriptionChanged()

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


Populate Method

ProgrammableOperator..::.Populate Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


SetDescription Method

ProgrammableOperator..::.SetDescription Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperator.SetDescription(System.String)]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetDescription(
    string description
)

Parameters

description
Type: System..::.String

[Missing <param> documentation for "description"]

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.TryAddSubOperator Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.TryAddVariable Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.TryAddVariableInfo Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.TryRemoveSubOperator Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.TryRemoveVariable Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ProgrammableOperator..::.TryRemoveVariableInfo Method
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
ProgrammableOperator Members
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Properties

[image]

HeuristicLab API Documentation
ProgrammableOperator Properties
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Code |
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


Code Property

ProgrammableOperator..::.Code Property
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.Programmable.ProgrammableOperator.Code]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Code { get; set; }

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


Description Property

ProgrammableOperator..::.Description Property
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.Programmable.ProgrammableOperator.Description]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Events

[image]

HeuristicLab API Documentation
ProgrammableOperator Events
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperator type exposes the following members.

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
CodeChanged |
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
DescriptionChanged |
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


CodeChanged Event

ProgrammableOperator..::.CodeChanged Event
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Operators.Programmable.ProgrammableOperator.CodeChanged]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler CodeChanged

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


DescriptionChanged Event

ProgrammableOperator..::.DescriptionChanged Event
ProgrammableOperator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Operators.Programmable.ProgrammableOperator.DescriptionChanged]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler DescriptionChanged

See Also

ProgrammableOperator Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Class

ProgrammableOperatorView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Operators.Programmable.ProgrammableOperatorView]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ProgrammableOperatorView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Operators.Programmable..::.ProgrammableOperatorView

See Also

ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Members

[image]

HeuristicLab API Documentation
ProgrammableOperatorView Members
ProgrammableOperatorView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperatorView type exposes the following members.

Constructors

Name | Description
ProgrammableOperatorView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ProgrammableOperator |
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Constructor

[image]

HeuristicLab API Documentation
ProgrammableOperatorView Constructor
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ProgrammableOperatorView()()() |
ProgrammableOperatorView(ProgrammableOperator) |

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Constructor

ProgrammableOperatorView Constructor
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProgrammableOperatorView class.

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProgrammableOperatorView()

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Overload
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Constructor (ProgrammableOperator)

ProgrammableOperatorView Constructor (ProgrammableOperator)
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProgrammableOperatorView class.

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProgrammableOperatorView(
    ProgrammableOperator programmableOperator
)

Parameters

programmableOperator
Type: HeuristicLab.Operators.Programmable..::.ProgrammableOperator

[Missing <param> documentation for "programmableOperator"]

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Overload
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Methods

[image]

HeuristicLab API Documentation
ProgrammableOperatorView Methods
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperatorView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.AccessibilityNotifyClients Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


AddItemEvents Method

ProgrammableOperatorView..::.AddItemEvents Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperatorView.AddItemEvents]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.BeginInvoke Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.Dispose Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


Dispose Method (Boolean)

ProgrammableOperatorView..::.Dispose Method (Boolean)
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ProgrammableOperatorView Class
Dispose Overload
HeuristicLab.Operators.Programmable Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.GetChildAtPoint Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.Invalidate Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.Invoke Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.MemberwiseClone Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.PerformLayout Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


RemoveItemEvents Method

ProgrammableOperatorView..::.RemoveItemEvents Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperatorView.RemoveItemEvents]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.ResumeLayout Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.RtlTranslateAlignment Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


Scale Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.Scale Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


Select Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.Select Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.SetBounds Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.UpdateBounds Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


UpdateControls Method

ProgrammableOperatorView..::.UpdateControls Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Operators.Programmable.ProgrammableOperatorView.UpdateControls]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


Validate Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.Validate Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ProgrammableOperatorView..::.ValidateChildren Method
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ProgrammableOperatorView Class
ProgrammableOperatorView Members
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperatorView Properties

[image]

HeuristicLab API Documentation
ProgrammableOperatorView Properties
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProgrammableOperatorView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
ProgrammableOperator |
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


ProgrammableOperator Property

ProgrammableOperatorView..::.ProgrammableOperator Property
ProgrammableOperatorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Operators.Programmable.ProgrammableOperatorView.ProgrammableOperator]

Namespace: HeuristicLab.Operators.Programmable
Assembly: HeuristicLab.Operators.Programmable (in HeuristicLab.Operators.Programmable.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProgrammableOperator ProgrammableOperator { get; set; }

See Also

ProgrammableOperatorView Class
HeuristicLab.Operators.Programmable Namespace


HeuristicLab.OptimizationFrontend Namespace

HeuristicLab.OptimizationFrontend Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.OptimizationFrontend]

Classes

Class | Description
AboutDialog |
AvailableOperatorsForm |
EditorForm |
HeuristicLabOptimizationFrontendApplication |
HeuristicLabOptimizationFrontendPlugin |
MainForm |
ViewForm |


AboutDialog Class

AboutDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.AboutDialog]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AboutDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.OptimizationFrontend..::.AboutDialog

See Also

AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


AboutDialog Members

[image]

HeuristicLab API Documentation
AboutDialog Members
AboutDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDialog type exposes the following members.

Constructors

Name | Description
AboutDialog |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AboutDialog Class
HeuristicLab.OptimizationFrontend Namespace


AboutDialog Constructor

AboutDialog Constructor
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AboutDialog class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AboutDialog()

See Also

AboutDialog Class
HeuristicLab.OptimizationFrontend Namespace


AboutDialog Methods

[image]

HeuristicLab API Documentation
AboutDialog Methods
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AboutDialog Class
HeuristicLab.OptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AboutDialog..::.AccessibilityNotifyClients Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AboutDialog..::.BeginInvoke Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Dispose Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method (Boolean)

AboutDialog..::.Dispose Method (Boolean)
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AboutDialog Class
Dispose Overload
HeuristicLab.OptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AboutDialog..::.GetChildAtPoint Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Invalidate Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Invoke Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AboutDialog..::.MemberwiseClone Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AboutDialog..::.PerformLayout Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AboutDialog..::.ResumeLayout Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AboutDialog..::.RtlTranslateAlignment Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Scale Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Select Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AboutDialog..::.SetBounds Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Show Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
AboutDialog..::.ShowDialog Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AboutDialog..::.UpdateBounds Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
AboutDialog..::.Validate Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AboutDialog..::.ValidateChildren Method
AboutDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AboutDialog Class
AboutDialog Members
HeuristicLab.OptimizationFrontend Namespace


AvailableOperatorsForm Class

AvailableOperatorsForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.AvailableOperatorsForm]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AvailableOperatorsForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.OptimizationFrontend..::.AvailableOperatorsForm

See Also

AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


AvailableOperatorsForm Members

[image]

HeuristicLab API Documentation
AvailableOperatorsForm Members
AvailableOperatorsForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AvailableOperatorsForm type exposes the following members.

Constructors

Name | Description
AvailableOperatorsForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
HeuristicLab.OptimizationFrontend Namespace


AvailableOperatorsForm Constructor

AvailableOperatorsForm Constructor
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AvailableOperatorsForm class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AvailableOperatorsForm()

See Also

AvailableOperatorsForm Class
HeuristicLab.OptimizationFrontend Namespace


AvailableOperatorsForm Methods

[image]

HeuristicLab API Documentation
AvailableOperatorsForm Methods
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AvailableOperatorsForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AvailableOperatorsForm Class
HeuristicLab.OptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.AccessibilityNotifyClients Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.BeginInvoke Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Dispose Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method (Boolean)

AvailableOperatorsForm..::.Dispose Method (Boolean)
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

AvailableOperatorsForm Class
Dispose Overload
HeuristicLab.OptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.GetChildAtPoint Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Invalidate Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Invoke Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.MemberwiseClone Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.PerformLayout Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.ResumeLayout Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.RtlTranslateAlignment Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Scale Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Select Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.SetBounds Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Show Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.ShowDialog Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.UpdateBounds Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.Validate Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AvailableOperatorsForm..::.ValidateChildren Method
AvailableOperatorsForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AvailableOperatorsForm Class
AvailableOperatorsForm Members
HeuristicLab.OptimizationFrontend Namespace


EditorForm Class

EditorForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.EditorForm]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EditorForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.OptimizationFrontend..::.EditorForm

See Also

EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


EditorForm Members

[image]

HeuristicLab API Documentation
EditorForm Members
EditorForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorForm type exposes the following members.

Constructors

Name | Description
EditorForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Editor |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

EditorForm Class
HeuristicLab.OptimizationFrontend Namespace


EditorForm Constructor

[image]

HeuristicLab API Documentation
EditorForm Constructor
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EditorForm()()() |
EditorForm(IEditor) |

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


EditorForm Constructor

EditorForm Constructor
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EditorForm class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EditorForm()

See Also

EditorForm Class
EditorForm Overload
HeuristicLab.OptimizationFrontend Namespace


EditorForm Constructor (IEditor)

EditorForm Constructor (IEditor)
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EditorForm class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EditorForm(
    IEditor editor
)

Parameters

editor
Type: HeuristicLab.Core..::.IEditor

[Missing <param> documentation for "editor"]

See Also

EditorForm Class
EditorForm Overload
HeuristicLab.OptimizationFrontend Namespace


EditorForm Methods

[image]

HeuristicLab API Documentation
EditorForm Methods
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

EditorForm Class
HeuristicLab.OptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
EditorForm..::.AccessibilityNotifyClients Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
EditorForm..::.BeginInvoke Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
EditorForm..::.Dispose Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method (Boolean)

EditorForm..::.Dispose Method (Boolean)
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

EditorForm Class
Dispose Overload
HeuristicLab.OptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
EditorForm..::.GetChildAtPoint Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
EditorForm..::.Invalidate Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
EditorForm..::.Invoke Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
EditorForm..::.MemberwiseClone Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
EditorForm..::.PerformLayout Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
EditorForm..::.ResumeLayout Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
EditorForm..::.RtlTranslateAlignment Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
EditorForm..::.Scale Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
EditorForm..::.Select Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
EditorForm..::.SetBounds Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
EditorForm..::.Show Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
EditorForm..::.ShowDialog Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
EditorForm..::.UpdateBounds Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
EditorForm..::.Validate Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
EditorForm..::.ValidateChildren Method
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

EditorForm Class
EditorForm Members
HeuristicLab.OptimizationFrontend Namespace


EditorForm Properties

[image]

HeuristicLab API Documentation
EditorForm Properties
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EditorForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Editor |
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

EditorForm Class
HeuristicLab.OptimizationFrontend Namespace


Editor Property

EditorForm..::.Editor Property
EditorForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.OptimizationFrontend.EditorForm.Editor]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEditor Editor { get; }

See Also

EditorForm Class
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendApplication Class

HeuristicLabOptimizationFrontendApplication Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.HeuristicLabOptimizationFrontendApplication]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "HeuristicLab 3.0", Description = "Next generation heuristic optimization environment.")]
internal class HeuristicLabOptimizationFrontendApplication : ApplicationBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.ApplicationBase
HeuristicLab.OptimizationFrontend..::.HeuristicLabOptimizationFrontendApplication

See Also

HeuristicLabOptimizationFrontendApplication Members
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendApplication Members

[image]

HeuristicLab API Documentation
HeuristicLabOptimizationFrontendApplication Members
HeuristicLabOptimizationFrontendApplication Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabOptimizationFrontendApplication type exposes the following members.

Constructors

Name | Description
HeuristicLabOptimizationFrontendApplication |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from ApplicationBase.)
Name | (Inherited from ApplicationBase.)
Version | (Inherited from ApplicationBase.)

See Also

HeuristicLabOptimizationFrontendApplication Class
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendApplication Constructor

HeuristicLabOptimizationFrontendApplication Constructor
HeuristicLabOptimizationFrontendApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabOptimizationFrontendApplication class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabOptimizationFrontendApplication()

See Also

HeuristicLabOptimizationFrontendApplication Class
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendApplication Methods

[image]

HeuristicLab API Documentation
HeuristicLabOptimizationFrontendApplication Methods
HeuristicLabOptimizationFrontendApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabOptimizationFrontendApplication type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run | (Overrides ApplicationBase ..::. Run()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HeuristicLabOptimizationFrontendApplication Class
HeuristicLab.OptimizationFrontend Namespace


Run Method

HeuristicLabOptimizationFrontendApplication..::.Run Method
HeuristicLabOptimizationFrontendApplication Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.OptimizationFrontend.HeuristicLabOptimizationFrontendApplication.Run]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Run()

Implements

IApplication..::.Run()()()

See Also

HeuristicLabOptimizationFrontendApplication Class
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendPlugin Class

HeuristicLabOptimizationFrontendPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.HeuristicLabOptimizationFrontendPlugin]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[ClassInfoAttribute(Name = "HeuristicLab.OptimizationFrontend")]
[PluginFileAttribute(Filename = "HeuristicLab.OptimizationFrontend.dll",
    Filetype = PluginFileType.Assembly)]
public class HeuristicLabOptimizationFrontendPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.OptimizationFrontend..::.HeuristicLabOptimizationFrontendPlugin

See Also

HeuristicLabOptimizationFrontendPlugin Members
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabOptimizationFrontendPlugin Members
HeuristicLabOptimizationFrontendPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabOptimizationFrontendPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabOptimizationFrontendPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabOptimizationFrontendPlugin Class
HeuristicLab.OptimizationFrontend Namespace


HeuristicLabOptimizationFrontendPlugin Constructor

HeuristicLabOptimizationFrontendPlugin Constructor
HeuristicLabOptimizationFrontendPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabOptimizationFrontendPlugin class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabOptimizationFrontendPlugin()

See Also

HeuristicLabOptimizationFrontendPlugin Class
HeuristicLab.OptimizationFrontend Namespace


MainForm Class

MainForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.MainForm]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MainForm : Form, IControlManager

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.OptimizationFrontend..::.MainForm

See Also

MainForm Members
HeuristicLab.OptimizationFrontend Namespace


MainForm Members

[image]

HeuristicLab API Documentation
MainForm Members
MainForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Constructors

Name | Description
MainForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowControl |
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

MainForm Class
HeuristicLab.OptimizationFrontend Namespace


MainForm Constructor

MainForm Constructor
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MainForm class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MainForm()

See Also

MainForm Class
HeuristicLab.OptimizationFrontend Namespace


MainForm Methods

[image]

HeuristicLab API Documentation
MainForm Methods
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MainForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowControl |
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

MainForm Class
HeuristicLab.OptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
MainForm..::.AccessibilityNotifyClients Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
MainForm..::.BeginInvoke Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
MainForm..::.Dispose Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method (Boolean)

MainForm..::.Dispose Method (Boolean)
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

MainForm Class
Dispose Overload
HeuristicLab.OptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
MainForm..::.GetChildAtPoint Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
MainForm..::.Invalidate Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
MainForm..::.Invoke Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
MainForm..::.MemberwiseClone Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
MainForm..::.PerformLayout Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
MainForm..::.ResumeLayout Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
MainForm..::.RtlTranslateAlignment Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
MainForm..::.Scale Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
MainForm..::.Select Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
MainForm..::.SetBounds Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
MainForm..::.Show Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


ShowControl Method

MainForm..::.ShowControl Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.OptimizationFrontend.MainForm.ShowControl(HeuristicLab.PluginInfrastructure.IControl)]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void ShowControl(
    IControl control
)

Parameters

control
Type: HeuristicLab.PluginInfrastructure..::.IControl

[Missing <param> documentation for "control"]

Implements

IControlManager..::.ShowControl(IControl)

See Also

MainForm Class
HeuristicLab.OptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
MainForm..::.ShowDialog Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
MainForm..::.UpdateBounds Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
MainForm..::.Validate Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
MainForm..::.ValidateChildren Method
MainForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

MainForm Class
MainForm Members
HeuristicLab.OptimizationFrontend Namespace


ViewForm Class

ViewForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.OptimizationFrontend.ViewForm]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ViewForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.OptimizationFrontend..::.ViewForm

See Also

ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


ViewForm Members

[image]

HeuristicLab API Documentation
ViewForm Members
ViewForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewForm type exposes the following members.

Constructors

Name | Description
ViewForm | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
View |
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ViewForm Class
HeuristicLab.OptimizationFrontend Namespace


ViewForm Constructor

[image]

HeuristicLab API Documentation
ViewForm Constructor
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ViewForm()()() |
ViewForm(IView) |

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


ViewForm Constructor

ViewForm Constructor
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ViewForm class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ViewForm()

See Also

ViewForm Class
ViewForm Overload
HeuristicLab.OptimizationFrontend Namespace


ViewForm Constructor (IView)

ViewForm Constructor (IView)
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ViewForm class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ViewForm(
    IView view
)

Parameters

view
Type: HeuristicLab.Core..::.IView

[Missing <param> documentation for "view"]

See Also

ViewForm Class
ViewForm Overload
HeuristicLab.OptimizationFrontend Namespace


ViewForm Methods

[image]

HeuristicLab API Documentation
ViewForm Methods
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ViewForm Class
HeuristicLab.OptimizationFrontend Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ViewForm..::.AccessibilityNotifyClients Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ViewForm..::.BeginInvoke Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ViewForm..::.Dispose Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Dispose Method (Boolean)

ViewForm..::.Dispose Method (Boolean)
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ViewForm Class
Dispose Overload
HeuristicLab.OptimizationFrontend Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ViewForm..::.GetChildAtPoint Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ViewForm..::.Invalidate Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ViewForm..::.Invoke Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ViewForm..::.MemberwiseClone Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ViewForm..::.PerformLayout Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ViewForm..::.ResumeLayout Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ViewForm..::.RtlTranslateAlignment Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Scale Method

[image]

HeuristicLab API Documentation
ViewForm..::.Scale Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Select Method

[image]

HeuristicLab API Documentation
ViewForm..::.Select Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ViewForm..::.SetBounds Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Show Method

[image]

HeuristicLab API Documentation
ViewForm..::.Show Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ViewForm..::.ShowDialog Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ViewForm..::.UpdateBounds Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


Validate Method

[image]

HeuristicLab API Documentation
ViewForm..::.Validate Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ViewForm..::.ValidateChildren Method
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ViewForm Class
ViewForm Members
HeuristicLab.OptimizationFrontend Namespace


ViewForm Properties

[image]

HeuristicLab API Documentation
ViewForm Properties
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ViewForm type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
View |
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

ViewForm Class
HeuristicLab.OptimizationFrontend Namespace


View Property

ViewForm..::.View Property
ViewForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.OptimizationFrontend.ViewForm.View]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IView View { get; }

See Also

ViewForm Class
HeuristicLab.OptimizationFrontend Namespace


HeuristicLab.Permutation Namespace

HeuristicLab.Permutation Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Permutation]

Classes

Class | Description
AbsolutePositionTopologicalCrossover |
CosaCrossover |
CyclicCrossover |
EdgeRecombinationCrossover |
HeuristicLabRandomPlugin |
InsertionManipulator |
InversionManipulator |
MaximalPreservativeCrossover |
OrderBasedCrossover |
OrderCrossover |
PartiallyMatchedCrossover |
Permutation |
PermutationCrossoverBase |
PermutationManipulatorBase |
PositionBasedCrossover |
RandomPermutationGenerator |
ScrambleManipulator |
Swap2Manipulator |
Swap3Manipulator |
TranslocationInversionManipulator |
TranslocationManipulator |


AbsolutePositionTopologicalCrossover Class

AbsolutePositionTopologicalCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.AbsolutePositionTopologicalCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AbsolutePositionTopologicalCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.AbsolutePositionTopologicalCrossover

See Also

AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


AbsolutePositionTopologicalCrossover Members

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover Members
AbsolutePositionTopologicalCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AbsolutePositionTopologicalCrossover type exposes the following members.

Constructors

Name | Description
AbsolutePositionTopologicalCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
HeuristicLab.Permutation Namespace


AbsolutePositionTopologicalCrossover Constructor

AbsolutePositionTopologicalCrossover Constructor
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AbsolutePositionTopologicalCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AbsolutePositionTopologicalCrossover()

See Also

AbsolutePositionTopologicalCrossover Class
HeuristicLab.Permutation Namespace


AbsolutePositionTopologicalCrossover Methods

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover Methods
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AbsolutePositionTopologicalCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

AbsolutePositionTopologicalCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.AddSubOperator Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.Apply Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

AbsolutePositionTopologicalCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.AbsolutePositionTopologicalCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.AbsolutePositionTopologicalCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

AbsolutePositionTopologicalCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.Clone Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.Cross Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

AbsolutePositionTopologicalCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.AbsolutePositionTopologicalCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.AbsolutePositionTopologicalCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

AbsolutePositionTopologicalCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.GetVariableValue Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.IsValid Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.TryAddSubOperator Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.TryAddVariable Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.TryAddVariableInfo Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.TryRemoveSubOperator Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.TryRemoveVariable Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover..::.TryRemoveVariableInfo Method
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
AbsolutePositionTopologicalCrossover Members
HeuristicLab.Permutation Namespace


AbsolutePositionTopologicalCrossover Properties

[image]

HeuristicLab API Documentation
AbsolutePositionTopologicalCrossover Properties
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AbsolutePositionTopologicalCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

AbsolutePositionTopologicalCrossover Class
HeuristicLab.Permutation Namespace


Description Property

AbsolutePositionTopologicalCrossover..::.Description Property
AbsolutePositionTopologicalCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.AbsolutePositionTopologicalCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

AbsolutePositionTopologicalCrossover Class
HeuristicLab.Permutation Namespace


CosaCrossover Class

CosaCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.CosaCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CosaCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.CosaCrossover

See Also

CosaCrossover Members
HeuristicLab.Permutation Namespace


CosaCrossover Members

[image]

HeuristicLab API Documentation
CosaCrossover Members
CosaCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CosaCrossover type exposes the following members.

Constructors

Name | Description
CosaCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
HeuristicLab.Permutation Namespace


CosaCrossover Constructor

CosaCrossover Constructor
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CosaCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CosaCrossover()

See Also

CosaCrossover Class
HeuristicLab.Permutation Namespace


CosaCrossover Methods

[image]

HeuristicLab API Documentation
CosaCrossover Methods
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CosaCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CosaCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.AddSubOperator Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.Apply Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

CosaCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.CosaCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.CosaCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

CosaCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.Clone Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.Cross Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

CosaCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.CosaCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.CosaCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

CosaCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.GetVariableValue Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.IsValid Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.TryAddSubOperator Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.TryAddVariable Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.TryAddVariableInfo Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.TryRemoveSubOperator Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.TryRemoveVariable Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CosaCrossover..::.TryRemoveVariableInfo Method
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
CosaCrossover Members
HeuristicLab.Permutation Namespace


CosaCrossover Properties

[image]

HeuristicLab API Documentation
CosaCrossover Properties
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CosaCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

CosaCrossover Class
HeuristicLab.Permutation Namespace


Description Property

CosaCrossover..::.Description Property
CosaCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.CosaCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

CosaCrossover Class
HeuristicLab.Permutation Namespace


CyclicCrossover Class

CyclicCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.CyclicCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CyclicCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.CyclicCrossover

See Also

CyclicCrossover Members
HeuristicLab.Permutation Namespace


CyclicCrossover Members

[image]

HeuristicLab API Documentation
CyclicCrossover Members
CyclicCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CyclicCrossover type exposes the following members.

Constructors

Name | Description
CyclicCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
HeuristicLab.Permutation Namespace


CyclicCrossover Constructor

CyclicCrossover Constructor
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CyclicCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CyclicCrossover()

See Also

CyclicCrossover Class
HeuristicLab.Permutation Namespace


CyclicCrossover Methods

[image]

HeuristicLab API Documentation
CyclicCrossover Methods
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CyclicCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CyclicCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.AddSubOperator Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.Apply Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

CyclicCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.CyclicCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.CyclicCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

CyclicCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.Clone Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.Cross Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

CyclicCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.CyclicCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.CyclicCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

CyclicCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.GetVariableValue Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.IsValid Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.TryAddSubOperator Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.TryAddVariable Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.TryAddVariableInfo Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.TryRemoveSubOperator Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.TryRemoveVariable Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CyclicCrossover..::.TryRemoveVariableInfo Method
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
CyclicCrossover Members
HeuristicLab.Permutation Namespace


CyclicCrossover Properties

[image]

HeuristicLab API Documentation
CyclicCrossover Properties
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CyclicCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

CyclicCrossover Class
HeuristicLab.Permutation Namespace


Description Property

CyclicCrossover..::.Description Property
CyclicCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.CyclicCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

CyclicCrossover Class
HeuristicLab.Permutation Namespace


EdgeRecombinationCrossover Class

EdgeRecombinationCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.EdgeRecombinationCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class EdgeRecombinationCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.EdgeRecombinationCrossover

See Also

EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


EdgeRecombinationCrossover Members

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover Members
EdgeRecombinationCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EdgeRecombinationCrossover type exposes the following members.

Constructors

Name | Description
EdgeRecombinationCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
HeuristicLab.Permutation Namespace


EdgeRecombinationCrossover Constructor

EdgeRecombinationCrossover Constructor
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the EdgeRecombinationCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public EdgeRecombinationCrossover()

See Also

EdgeRecombinationCrossover Class
HeuristicLab.Permutation Namespace


EdgeRecombinationCrossover Methods

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover Methods
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EdgeRecombinationCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

EdgeRecombinationCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.AddSubOperator Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.Apply Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

EdgeRecombinationCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.EdgeRecombinationCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.EdgeRecombinationCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

EdgeRecombinationCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.Clone Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.Cross Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

EdgeRecombinationCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.EdgeRecombinationCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.EdgeRecombinationCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

EdgeRecombinationCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.GetVariableValue Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.IsValid Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.TryAddSubOperator Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.TryAddVariable Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.TryAddVariableInfo Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.TryRemoveSubOperator Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.TryRemoveVariable Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover..::.TryRemoveVariableInfo Method
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
EdgeRecombinationCrossover Members
HeuristicLab.Permutation Namespace


EdgeRecombinationCrossover Properties

[image]

HeuristicLab API Documentation
EdgeRecombinationCrossover Properties
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EdgeRecombinationCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

EdgeRecombinationCrossover Class
HeuristicLab.Permutation Namespace


Description Property

EdgeRecombinationCrossover..::.Description Property
EdgeRecombinationCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.EdgeRecombinationCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

EdgeRecombinationCrossover Class
HeuristicLab.Permutation Namespace


HeuristicLabRandomPlugin Class

HeuristicLabRandomPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.HeuristicLabRandomPlugin]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Evolutionary")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.Permutation")]
[PluginFileAttribute(Filename = "HeuristicLab.Permutation.dll", Filetype = PluginFileType.Assembly)]
public class HeuristicLabRandomPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Permutation..::.HeuristicLabRandomPlugin

See Also

HeuristicLabRandomPlugin Members
HeuristicLab.Permutation Namespace


HeuristicLabRandomPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabRandomPlugin Members
HeuristicLabRandomPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabRandomPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabRandomPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabRandomPlugin Class
HeuristicLab.Permutation Namespace


HeuristicLabRandomPlugin Constructor

HeuristicLabRandomPlugin Constructor
HeuristicLabRandomPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabRandomPlugin class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabRandomPlugin()

See Also

HeuristicLabRandomPlugin Class
HeuristicLab.Permutation Namespace


InsertionManipulator Class

InsertionManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.InsertionManipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class InsertionManipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.InsertionManipulator

See Also

InsertionManipulator Members
HeuristicLab.Permutation Namespace


InsertionManipulator Members

[image]

HeuristicLab API Documentation
InsertionManipulator Members
InsertionManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InsertionManipulator type exposes the following members.

Constructors

Name | Description
InsertionManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
HeuristicLab.Permutation Namespace


InsertionManipulator Constructor

InsertionManipulator Constructor
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InsertionManipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public InsertionManipulator()

See Also

InsertionManipulator Class
HeuristicLab.Permutation Namespace


InsertionManipulator Methods

[image]

HeuristicLab API Documentation
InsertionManipulator Methods
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InsertionManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

InsertionManipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.AddSubOperator Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.Apply Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

InsertionManipulator..::.Apply Method (IRandom, array<Int32>[]()[])
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.InsertionManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.InsertionManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

InsertionManipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.Clone Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.GetVariableValue Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.IsValid Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

InsertionManipulator..::.Manipulate Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.InsertionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.InsertionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

InsertionManipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.TryAddSubOperator Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.TryAddVariable Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.TryAddVariableInfo Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.TryRemoveSubOperator Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.TryRemoveVariable Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
InsertionManipulator..::.TryRemoveVariableInfo Method
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
InsertionManipulator Members
HeuristicLab.Permutation Namespace


InsertionManipulator Properties

[image]

HeuristicLab API Documentation
InsertionManipulator Properties
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InsertionManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

InsertionManipulator Class
HeuristicLab.Permutation Namespace


Description Property

InsertionManipulator..::.Description Property
InsertionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.InsertionManipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

InsertionManipulator Class
HeuristicLab.Permutation Namespace


InversionManipulator Class

InversionManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.InversionManipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class InversionManipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.InversionManipulator

See Also

InversionManipulator Members
HeuristicLab.Permutation Namespace


InversionManipulator Members

[image]

HeuristicLab API Documentation
InversionManipulator Members
InversionManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InversionManipulator type exposes the following members.

Constructors

Name | Description
InversionManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
HeuristicLab.Permutation Namespace


InversionManipulator Constructor

InversionManipulator Constructor
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InversionManipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public InversionManipulator()

See Also

InversionManipulator Class
HeuristicLab.Permutation Namespace


InversionManipulator Methods

[image]

HeuristicLab API Documentation
InversionManipulator Methods
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InversionManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

InversionManipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.AddSubOperator Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.Apply Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

InversionManipulator..::.Apply Method (IRandom, array<Int32>[]()[])
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.InversionManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.InversionManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

InversionManipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.Clone Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.GetVariableValue Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.IsValid Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

InversionManipulator..::.Manipulate Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.InversionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.InversionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

InversionManipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.TryAddSubOperator Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.TryAddVariable Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.TryAddVariableInfo Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.TryRemoveSubOperator Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.TryRemoveVariable Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
InversionManipulator..::.TryRemoveVariableInfo Method
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
InversionManipulator Members
HeuristicLab.Permutation Namespace


InversionManipulator Properties

[image]

HeuristicLab API Documentation
InversionManipulator Properties
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InversionManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

InversionManipulator Class
HeuristicLab.Permutation Namespace


Description Property

InversionManipulator..::.Description Property
InversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.InversionManipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

InversionManipulator Class
HeuristicLab.Permutation Namespace


MaximalPreservativeCrossover Class

MaximalPreservativeCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.MaximalPreservativeCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MaximalPreservativeCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.MaximalPreservativeCrossover

See Also

MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


MaximalPreservativeCrossover Members

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover Members
MaximalPreservativeCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaximalPreservativeCrossover type exposes the following members.

Constructors

Name | Description
MaximalPreservativeCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
HeuristicLab.Permutation Namespace


MaximalPreservativeCrossover Constructor

MaximalPreservativeCrossover Constructor
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MaximalPreservativeCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MaximalPreservativeCrossover()

See Also

MaximalPreservativeCrossover Class
HeuristicLab.Permutation Namespace


MaximalPreservativeCrossover Methods

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover Methods
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaximalPreservativeCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

MaximalPreservativeCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.AddSubOperator Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.Apply Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

MaximalPreservativeCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.MaximalPreservativeCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.MaximalPreservativeCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

MaximalPreservativeCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.Clone Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.Cross Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

MaximalPreservativeCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.MaximalPreservativeCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.MaximalPreservativeCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

MaximalPreservativeCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.GetVariableValue Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.IsValid Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.TryAddSubOperator Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.TryAddVariable Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.TryAddVariableInfo Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.TryRemoveSubOperator Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.TryRemoveVariable Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover..::.TryRemoveVariableInfo Method
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
MaximalPreservativeCrossover Members
HeuristicLab.Permutation Namespace


MaximalPreservativeCrossover Properties

[image]

HeuristicLab API Documentation
MaximalPreservativeCrossover Properties
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaximalPreservativeCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

MaximalPreservativeCrossover Class
HeuristicLab.Permutation Namespace


Description Property

MaximalPreservativeCrossover..::.Description Property
MaximalPreservativeCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.MaximalPreservativeCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

MaximalPreservativeCrossover Class
HeuristicLab.Permutation Namespace


OrderBasedCrossover Class

OrderBasedCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.OrderBasedCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OrderBasedCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.OrderBasedCrossover

See Also

OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


OrderBasedCrossover Members

[image]

HeuristicLab API Documentation
OrderBasedCrossover Members
OrderBasedCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderBasedCrossover type exposes the following members.

Constructors

Name | Description
OrderBasedCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
HeuristicLab.Permutation Namespace


OrderBasedCrossover Constructor

OrderBasedCrossover Constructor
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OrderBasedCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OrderBasedCrossover()

See Also

OrderBasedCrossover Class
HeuristicLab.Permutation Namespace


OrderBasedCrossover Methods

[image]

HeuristicLab API Documentation
OrderBasedCrossover Methods
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderBasedCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OrderBasedCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.AddSubOperator Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.Apply Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

OrderBasedCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.OrderBasedCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.OrderBasedCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

OrderBasedCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.Clone Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.Cross Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

OrderBasedCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.OrderBasedCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.OrderBasedCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

OrderBasedCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.GetVariableValue Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.IsValid Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.TryAddSubOperator Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.TryAddVariable Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.TryAddVariableInfo Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.TryRemoveSubOperator Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.TryRemoveVariable Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OrderBasedCrossover..::.TryRemoveVariableInfo Method
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
OrderBasedCrossover Members
HeuristicLab.Permutation Namespace


OrderBasedCrossover Properties

[image]

HeuristicLab API Documentation
OrderBasedCrossover Properties
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderBasedCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OrderBasedCrossover Class
HeuristicLab.Permutation Namespace


Description Property

OrderBasedCrossover..::.Description Property
OrderBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.OrderBasedCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OrderBasedCrossover Class
HeuristicLab.Permutation Namespace


OrderCrossover Class

OrderCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.OrderCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OrderCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.OrderCrossover

See Also

OrderCrossover Members
HeuristicLab.Permutation Namespace


OrderCrossover Members

[image]

HeuristicLab API Documentation
OrderCrossover Members
OrderCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderCrossover type exposes the following members.

Constructors

Name | Description
OrderCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
HeuristicLab.Permutation Namespace


OrderCrossover Constructor

OrderCrossover Constructor
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OrderCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OrderCrossover()

See Also

OrderCrossover Class
HeuristicLab.Permutation Namespace


OrderCrossover Methods

[image]

HeuristicLab API Documentation
OrderCrossover Methods
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OrderCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.AddSubOperator Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.Apply Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

OrderCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.OrderCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.OrderCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

OrderCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.Clone Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.Cross Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

OrderCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.OrderCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.OrderCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

OrderCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.GetVariableValue Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.IsValid Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.TryAddSubOperator Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.TryAddVariable Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.TryAddVariableInfo Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.TryRemoveSubOperator Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.TryRemoveVariable Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OrderCrossover..::.TryRemoveVariableInfo Method
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
OrderCrossover Members
HeuristicLab.Permutation Namespace


OrderCrossover Properties

[image]

HeuristicLab API Documentation
OrderCrossover Properties
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OrderCrossover Class
HeuristicLab.Permutation Namespace


Description Property

OrderCrossover..::.Description Property
OrderCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.OrderCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OrderCrossover Class
HeuristicLab.Permutation Namespace


PartiallyMatchedCrossover Class

PartiallyMatchedCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.PartiallyMatchedCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PartiallyMatchedCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.PartiallyMatchedCrossover

See Also

PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


PartiallyMatchedCrossover Members

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover Members
PartiallyMatchedCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PartiallyMatchedCrossover type exposes the following members.

Constructors

Name | Description
PartiallyMatchedCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
HeuristicLab.Permutation Namespace


PartiallyMatchedCrossover Constructor

PartiallyMatchedCrossover Constructor
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PartiallyMatchedCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PartiallyMatchedCrossover()

See Also

PartiallyMatchedCrossover Class
HeuristicLab.Permutation Namespace


PartiallyMatchedCrossover Methods

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover Methods
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PartiallyMatchedCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

PartiallyMatchedCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.AddSubOperator Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.Apply Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

PartiallyMatchedCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PartiallyMatchedCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PartiallyMatchedCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

PartiallyMatchedCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.Clone Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.Cross Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

PartiallyMatchedCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PartiallyMatchedCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PartiallyMatchedCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

PartiallyMatchedCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.GetVariableValue Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.IsValid Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.TryAddSubOperator Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.TryAddVariable Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.TryAddVariableInfo Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.TryRemoveSubOperator Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.TryRemoveVariable Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover..::.TryRemoveVariableInfo Method
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
PartiallyMatchedCrossover Members
HeuristicLab.Permutation Namespace


PartiallyMatchedCrossover Properties

[image]

HeuristicLab API Documentation
PartiallyMatchedCrossover Properties
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PartiallyMatchedCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

PartiallyMatchedCrossover Class
HeuristicLab.Permutation Namespace


Description Property

PartiallyMatchedCrossover..::.Description Property
PartiallyMatchedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.PartiallyMatchedCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

PartiallyMatchedCrossover Class
HeuristicLab.Permutation Namespace


Permutation Class

Permutation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.Permutation]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Permutation : IntArrayData

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Data..::.ObjectData
HeuristicLab.Data..::.ArrayDataBase
HeuristicLab.Data..::.IntArrayData
HeuristicLab.Permutation..::.Permutation

See Also

Permutation Members
HeuristicLab.Permutation Namespace


Permutation Members

[image]

HeuristicLab API Documentation
Permutation Members
Permutation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Permutation type exposes the following members.

Constructors

Name | Description
Permutation | Overloaded.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Inherited from IntArrayData.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from IntArrayData.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from IntArrayData.)
ToString | (Inherited from ArrayDataBase.)

Properties

Name | Description
Data | (Inherited from IntArrayData.)
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

Permutation Class
HeuristicLab.Permutation Namespace


Permutation Constructor

[image]

HeuristicLab API Documentation
Permutation Constructor
Permutation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Permutation()()() |
Permutation(array<Int32>[]()[]) |

See Also

Permutation Class
Permutation Members
HeuristicLab.Permutation Namespace


Permutation Constructor

Permutation Constructor
Permutation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Permutation class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Permutation()

See Also

Permutation Class
Permutation Overload
HeuristicLab.Permutation Namespace


Permutation Constructor (Int32[])

Permutation Constructor (array<Int32>[]()[])
Permutation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Permutation class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Permutation(
    int[] permutation
)

Parameters

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

See Also

Permutation Class
Permutation Overload
HeuristicLab.Permutation Namespace


Permutation Methods

[image]

HeuristicLab API Documentation
Permutation Methods
Permutation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Permutation type exposes the following members.

Methods

Name | Description
Accept | (Inherited from ObjectData.)
Clone | Overloaded.
CompareTo | (Inherited from ObjectData.)
CreateView | (Inherited from IntArrayData.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from IntArrayData.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Inherited from IntArrayData.)
ToString | (Inherited from ArrayDataBase.)

See Also

Permutation Class
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
Permutation..::.Clone Method
Permutation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides ObjectData ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Permutation Class
Permutation Members
HeuristicLab.Permutation Namespace


Clone Method (IDictionary(Guid, Object))

Permutation..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Permutation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.Permutation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.Permutation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Permutation Class
Clone Overload
HeuristicLab.Permutation Namespace


PermutationCrossoverBase Class

PermutationCrossoverBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.PermutationCrossoverBase]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class PermutationCrossoverBase : CrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.PositionBasedCrossover
HeuristicLab.Permutation..::.CyclicCrossover
HeuristicLab.Permutation..::.AbsolutePositionTopologicalCrossover
HeuristicLab.Permutation..::.MaximalPreservativeCrossover
HeuristicLab.Permutation..::.OrderBasedCrossover
HeuristicLab.Permutation..::.OrderCrossover
HeuristicLab.Permutation..::.EdgeRecombinationCrossover
HeuristicLab.Permutation..::.PartiallyMatchedCrossover
HeuristicLab.Permutation..::.CosaCrossover

See Also

PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


PermutationCrossoverBase Members

[image]

HeuristicLab API Documentation
PermutationCrossoverBase Members
PermutationCrossoverBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PermutationCrossoverBase type exposes the following members.

Constructors

Name | Description
PermutationCrossoverBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from CrossoverBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
HeuristicLab.Permutation Namespace


PermutationCrossoverBase Constructor

PermutationCrossoverBase Constructor
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PermutationCrossoverBase class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PermutationCrossoverBase()

See Also

PermutationCrossoverBase Class
HeuristicLab.Permutation Namespace


PermutationCrossoverBase Methods

[image]

HeuristicLab API Documentation
PermutationCrossoverBase Methods
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PermutationCrossoverBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from CrossoverBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

PermutationCrossoverBase Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.AddSubOperator Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.Clone Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.Cross Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) |
Cross(IScope, IRandom, IScope, IScope, IScope) | (Overrides CrossoverBase ..::. Cross(IScope, IRandom, IScope, IScope, IScope).)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

PermutationCrossoverBase..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PermutationCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PermutationCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

PermutationCrossoverBase Class
Cross Overload
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, IScope, IScope, IScope)

PermutationCrossoverBase..::.Cross Method (IScope, IRandom, IScope, IScope, IScope)
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PermutationCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override sealed void Cross(
    IScope scope,
    IRandom random,
    IScope parent1,
    IScope parent2,
    IScope child
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent1"]

parent2
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent2"]

child
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "child"]

See Also

PermutationCrossoverBase Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.GetVariableValue Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.IsValid Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.TryAddSubOperator Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.TryAddVariable Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.TryAddVariableInfo Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.TryRemoveSubOperator Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.TryRemoveVariable Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
PermutationCrossoverBase..::.TryRemoveVariableInfo Method
PermutationCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationCrossoverBase Class
PermutationCrossoverBase Members
HeuristicLab.Permutation Namespace


PermutationManipulatorBase Class

PermutationManipulatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.PermutationManipulatorBase]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class PermutationManipulatorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.Swap2Manipulator
HeuristicLab.Permutation..::.InsertionManipulator
HeuristicLab.Permutation..::.InversionManipulator
HeuristicLab.Permutation..::.TranslocationManipulator
HeuristicLab.Permutation..::.ScrambleManipulator
HeuristicLab.Permutation..::.TranslocationInversionManipulator
HeuristicLab.Permutation..::.Swap3Manipulator

See Also

PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


PermutationManipulatorBase Members

[image]

HeuristicLab API Documentation
PermutationManipulatorBase Members
PermutationManipulatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PermutationManipulatorBase type exposes the following members.

Constructors

Name | Description
PermutationManipulatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
HeuristicLab.Permutation Namespace


PermutationManipulatorBase Constructor

PermutationManipulatorBase Constructor
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PermutationManipulatorBase class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PermutationManipulatorBase()

See Also

PermutationManipulatorBase Class
HeuristicLab.Permutation Namespace


PermutationManipulatorBase Methods

[image]

HeuristicLab API Documentation
PermutationManipulatorBase Methods
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PermutationManipulatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

PermutationManipulatorBase Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.AddSubOperator Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


Apply Method

PermutationManipulatorBase..::.Apply Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PermutationManipulatorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PermutationManipulatorBase.Apply(HeuristicLab.Core.IScope)]

See Also

PermutationManipulatorBase Class
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.Clone Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.GetVariableValue Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.IsValid Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


Manipulate Method

PermutationManipulatorBase..::.Manipulate Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PermutationManipulatorBase.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PermutationManipulatorBase.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

PermutationManipulatorBase Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.TryAddSubOperator Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.TryAddVariable Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.TryAddVariableInfo Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.TryRemoveSubOperator Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.TryRemoveVariable Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
PermutationManipulatorBase..::.TryRemoveVariableInfo Method
PermutationManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PermutationManipulatorBase Class
PermutationManipulatorBase Members
HeuristicLab.Permutation Namespace


PositionBasedCrossover Class

PositionBasedCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.PositionBasedCrossover]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PositionBasedCrossover : PermutationCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.Permutation..::.PermutationCrossoverBase
HeuristicLab.Permutation..::.PositionBasedCrossover

See Also

PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


PositionBasedCrossover Members

[image]

HeuristicLab API Documentation
PositionBasedCrossover Members
PositionBasedCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PositionBasedCrossover type exposes the following members.

Constructors

Name | Description
PositionBasedCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
HeuristicLab.Permutation Namespace


PositionBasedCrossover Constructor

PositionBasedCrossover Constructor
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PositionBasedCrossover class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PositionBasedCrossover()

See Also

PositionBasedCrossover Class
HeuristicLab.Permutation Namespace


PositionBasedCrossover Methods

[image]

HeuristicLab API Documentation
PositionBasedCrossover Methods
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PositionBasedCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

PositionBasedCrossover Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.AddSubOperator Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.Apply Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[], Int32[])

PositionBasedCrossover..::.Apply Method (IRandom, array<Int32>[]()[], array<Int32>[]()[])
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PositionBasedCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PositionBasedCrossover.Apply(HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

PositionBasedCrossover Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.Clone Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


Cross Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.Cross Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]) | (Overrides PermutationCrossoverBase ..::. Cross(IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from PermutationCrossoverBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


Cross Method (IScope, IRandom, Int32[], Int32[])

PositionBasedCrossover..::.Cross Method (IScope, IRandom, array<Int32>[]()[], array<Int32>[]()[])
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.PositionBasedCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Cross(
    IScope scope,
    IRandom random,
    int[] parent1,
    int[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.PositionBasedCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[],System.Int32[])]

See Also

PositionBasedCrossover Class
Cross Overload
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.GetVariableValue Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.IsValid Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.TryAddSubOperator Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.TryAddVariable Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.TryAddVariableInfo Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.TryRemoveSubOperator Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.TryRemoveVariable Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
PositionBasedCrossover..::.TryRemoveVariableInfo Method
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
PositionBasedCrossover Members
HeuristicLab.Permutation Namespace


PositionBasedCrossover Properties

[image]

HeuristicLab API Documentation
PositionBasedCrossover Properties
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PositionBasedCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

PositionBasedCrossover Class
HeuristicLab.Permutation Namespace


Description Property

PositionBasedCrossover..::.Description Property
PositionBasedCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.PositionBasedCrossover.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

PositionBasedCrossover Class
HeuristicLab.Permutation Namespace


RandomPermutationGenerator Class

RandomPermutationGenerator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.RandomPermutationGenerator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RandomPermutationGenerator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.RandomPermutationGenerator

See Also

RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


RandomPermutationGenerator Members

[image]

HeuristicLab API Documentation
RandomPermutationGenerator Members
RandomPermutationGenerator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomPermutationGenerator type exposes the following members.

Constructors

Name | Description
RandomPermutationGenerator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
HeuristicLab.Permutation Namespace


RandomPermutationGenerator Constructor

RandomPermutationGenerator Constructor
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomPermutationGenerator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RandomPermutationGenerator()

See Also

RandomPermutationGenerator Class
HeuristicLab.Permutation Namespace


RandomPermutationGenerator Methods

[image]

HeuristicLab API Documentation
RandomPermutationGenerator Methods
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomPermutationGenerator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RandomPermutationGenerator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.AddSubOperator Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.Apply Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Overrides OperatorBase ..::. Apply(IScope).)
Apply(IRandom, Int32) |

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


Apply Method (IScope)

RandomPermutationGenerator..::.Apply Method (IScope)
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.RandomPermutationGenerator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.RandomPermutationGenerator.Apply(HeuristicLab.Core.IScope)]

See Also

RandomPermutationGenerator Class
Apply Overload
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32)

RandomPermutationGenerator..::.Apply Method (IRandom, Int32)
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.RandomPermutationGenerator.Apply(HeuristicLab.Core.IRandom,System.Int32)]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int length
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

length
Type: System..::.Int32

[Missing <param> documentation for "length"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.RandomPermutationGenerator.Apply(HeuristicLab.Core.IRandom,System.Int32)]

See Also

RandomPermutationGenerator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.Clone Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.GetVariableValue Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.IsValid Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.TryAddSubOperator Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.TryAddVariable Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.TryAddVariableInfo Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.TryRemoveSubOperator Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.TryRemoveVariable Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RandomPermutationGenerator..::.TryRemoveVariableInfo Method
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
RandomPermutationGenerator Members
HeuristicLab.Permutation Namespace


RandomPermutationGenerator Properties

[image]

HeuristicLab API Documentation
RandomPermutationGenerator Properties
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomPermutationGenerator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RandomPermutationGenerator Class
HeuristicLab.Permutation Namespace


Description Property

RandomPermutationGenerator..::.Description Property
RandomPermutationGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.RandomPermutationGenerator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RandomPermutationGenerator Class
HeuristicLab.Permutation Namespace


ScrambleManipulator Class

ScrambleManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.ScrambleManipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScrambleManipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.ScrambleManipulator

See Also

ScrambleManipulator Members
HeuristicLab.Permutation Namespace


ScrambleManipulator Members

[image]

HeuristicLab API Documentation
ScrambleManipulator Members
ScrambleManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScrambleManipulator type exposes the following members.

Constructors

Name | Description
ScrambleManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
HeuristicLab.Permutation Namespace


ScrambleManipulator Constructor

ScrambleManipulator Constructor
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScrambleManipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScrambleManipulator()

See Also

ScrambleManipulator Class
HeuristicLab.Permutation Namespace


ScrambleManipulator Methods

[image]

HeuristicLab API Documentation
ScrambleManipulator Methods
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScrambleManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ScrambleManipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.AddSubOperator Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.Apply Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

ScrambleManipulator..::.Apply Method (IRandom, array<Int32>[]()[])
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.ScrambleManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.ScrambleManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

ScrambleManipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.Clone Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.GetVariableValue Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.IsValid Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

ScrambleManipulator..::.Manipulate Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.ScrambleManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.ScrambleManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

ScrambleManipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.TryAddSubOperator Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.TryAddVariable Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.TryAddVariableInfo Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.TryRemoveSubOperator Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.TryRemoveVariable Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ScrambleManipulator..::.TryRemoveVariableInfo Method
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
ScrambleManipulator Members
HeuristicLab.Permutation Namespace


ScrambleManipulator Properties

[image]

HeuristicLab API Documentation
ScrambleManipulator Properties
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScrambleManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ScrambleManipulator Class
HeuristicLab.Permutation Namespace


Description Property

ScrambleManipulator..::.Description Property
ScrambleManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.ScrambleManipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ScrambleManipulator Class
HeuristicLab.Permutation Namespace


Swap2Manipulator Class

Swap2Manipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.Swap2Manipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Swap2Manipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.Swap2Manipulator

See Also

Swap2Manipulator Members
HeuristicLab.Permutation Namespace


Swap2Manipulator Members

[image]

HeuristicLab API Documentation
Swap2Manipulator Members
Swap2Manipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Swap2Manipulator type exposes the following members.

Constructors

Name | Description
Swap2Manipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
HeuristicLab.Permutation Namespace


Swap2Manipulator Constructor

Swap2Manipulator Constructor
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Swap2Manipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Swap2Manipulator()

See Also

Swap2Manipulator Class
HeuristicLab.Permutation Namespace


Swap2Manipulator Methods

[image]

HeuristicLab API Documentation
Swap2Manipulator Methods
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Swap2Manipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Swap2Manipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.AddSubOperator Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.Apply Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

Swap2Manipulator..::.Apply Method (IRandom, array<Int32>[]()[])
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.Swap2Manipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.Swap2Manipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

Swap2Manipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.Clone Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.GetVariableValue Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.IsValid Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

Swap2Manipulator..::.Manipulate Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.Swap2Manipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.Swap2Manipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

Swap2Manipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.TryAddSubOperator Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.TryAddVariable Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.TryAddVariableInfo Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.TryRemoveSubOperator Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.TryRemoveVariable Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Swap2Manipulator..::.TryRemoveVariableInfo Method
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
Swap2Manipulator Members
HeuristicLab.Permutation Namespace


Swap2Manipulator Properties

[image]

HeuristicLab API Documentation
Swap2Manipulator Properties
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Swap2Manipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

Swap2Manipulator Class
HeuristicLab.Permutation Namespace


Description Property

Swap2Manipulator..::.Description Property
Swap2Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.Swap2Manipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Swap2Manipulator Class
HeuristicLab.Permutation Namespace


Swap3Manipulator Class

Swap3Manipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.Swap3Manipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Swap3Manipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.Swap3Manipulator

See Also

Swap3Manipulator Members
HeuristicLab.Permutation Namespace


Swap3Manipulator Members

[image]

HeuristicLab API Documentation
Swap3Manipulator Members
Swap3Manipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Swap3Manipulator type exposes the following members.

Constructors

Name | Description
Swap3Manipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
HeuristicLab.Permutation Namespace


Swap3Manipulator Constructor

Swap3Manipulator Constructor
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Swap3Manipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Swap3Manipulator()

See Also

Swap3Manipulator Class
HeuristicLab.Permutation Namespace


Swap3Manipulator Methods

[image]

HeuristicLab API Documentation
Swap3Manipulator Methods
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Swap3Manipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

Swap3Manipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.AddSubOperator Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.Apply Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

Swap3Manipulator..::.Apply Method (IRandom, array<Int32>[]()[])
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.Swap3Manipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.Swap3Manipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

Swap3Manipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.Clone Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.GetVariableValue Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.IsValid Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

Swap3Manipulator..::.Manipulate Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.Swap3Manipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.Swap3Manipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

Swap3Manipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.TryAddSubOperator Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.TryAddVariable Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.TryAddVariableInfo Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.TryRemoveSubOperator Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.TryRemoveVariable Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
Swap3Manipulator..::.TryRemoveVariableInfo Method
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
Swap3Manipulator Members
HeuristicLab.Permutation Namespace


Swap3Manipulator Properties

[image]

HeuristicLab API Documentation
Swap3Manipulator Properties
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Swap3Manipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

Swap3Manipulator Class
HeuristicLab.Permutation Namespace


Description Property

Swap3Manipulator..::.Description Property
Swap3Manipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.Swap3Manipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

Swap3Manipulator Class
HeuristicLab.Permutation Namespace


TranslocationInversionManipulator Class

TranslocationInversionManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.TranslocationInversionManipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TranslocationInversionManipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.TranslocationInversionManipulator

See Also

TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TranslocationInversionManipulator Members

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator Members
TranslocationInversionManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslocationInversionManipulator type exposes the following members.

Constructors

Name | Description
TranslocationInversionManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
HeuristicLab.Permutation Namespace


TranslocationInversionManipulator Constructor

TranslocationInversionManipulator Constructor
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TranslocationInversionManipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TranslocationInversionManipulator()

See Also

TranslocationInversionManipulator Class
HeuristicLab.Permutation Namespace


TranslocationInversionManipulator Methods

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator Methods
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslocationInversionManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TranslocationInversionManipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.AddSubOperator Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.Apply Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

TranslocationInversionManipulator..::.Apply Method (IRandom, array<Int32>[]()[])
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.TranslocationInversionManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.TranslocationInversionManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

TranslocationInversionManipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.Clone Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.GetVariableValue Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.IsValid Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

TranslocationInversionManipulator..::.Manipulate Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.TranslocationInversionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.TranslocationInversionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

TranslocationInversionManipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.TryAddSubOperator Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.TryAddVariable Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.TryAddVariableInfo Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.TryRemoveSubOperator Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.TryRemoveVariable Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator..::.TryRemoveVariableInfo Method
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
TranslocationInversionManipulator Members
HeuristicLab.Permutation Namespace


TranslocationInversionManipulator Properties

[image]

HeuristicLab API Documentation
TranslocationInversionManipulator Properties
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslocationInversionManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

TranslocationInversionManipulator Class
HeuristicLab.Permutation Namespace


Description Property

TranslocationInversionManipulator..::.Description Property
TranslocationInversionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.TranslocationInversionManipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

TranslocationInversionManipulator Class
HeuristicLab.Permutation Namespace


TranslocationManipulator Class

TranslocationManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Permutation.TranslocationManipulator]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TranslocationManipulator : PermutationManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Permutation..::.PermutationManipulatorBase
HeuristicLab.Permutation..::.TranslocationManipulator

See Also

TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TranslocationManipulator Members

[image]

HeuristicLab API Documentation
TranslocationManipulator Members
TranslocationManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslocationManipulator type exposes the following members.

Constructors

Name | Description
TranslocationManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
HeuristicLab.Permutation Namespace


TranslocationManipulator Constructor

TranslocationManipulator Constructor
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TranslocationManipulator class.

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TranslocationManipulator()

See Also

TranslocationManipulator Class
HeuristicLab.Permutation Namespace


TranslocationManipulator Methods

[image]

HeuristicLab API Documentation
TranslocationManipulator Methods
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslocationManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides PermutationManipulatorBase ..::. Manipulate(IScope, IRandom, array<Int32>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TranslocationManipulator Class
HeuristicLab.Permutation Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.AddSubOperator Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


Apply Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.Apply Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from PermutationManipulatorBase.)
Apply(IRandom, array<Int32>[]()[]) |

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


Apply Method (IRandom, Int32[])

TranslocationManipulator..::.Apply Method (IRandom, array<Int32>[]()[])
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.TranslocationManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static int[] Apply(
    IRandom random,
    int[] permutation
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.TranslocationManipulator.Apply(HeuristicLab.Core.IRandom,System.Int32[])]

See Also

TranslocationManipulator Class
Apply Overload
HeuristicLab.Permutation Namespace


Clone Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.Clone Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.GetVariableValue Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.IsValid Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


Manipulate Method

TranslocationManipulator..::.Manipulate Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Permutation.TranslocationManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override int[] Manipulate(
    IScope scope,
    IRandom random,
    int[] permutation
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

permutation
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "permutation"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Permutation.TranslocationManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Int32[])]

See Also

TranslocationManipulator Class
HeuristicLab.Permutation Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.TryAddSubOperator Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.TryAddVariable Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.TryAddVariableInfo Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.TryRemoveSubOperator Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.TryRemoveVariable Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TranslocationManipulator..::.TryRemoveVariableInfo Method
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
TranslocationManipulator Members
HeuristicLab.Permutation Namespace


TranslocationManipulator Properties

[image]

HeuristicLab API Documentation
TranslocationManipulator Properties
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslocationManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

TranslocationManipulator Class
HeuristicLab.Permutation Namespace


Description Property

TranslocationManipulator..::.Description Property
TranslocationManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Permutation.TranslocationManipulator.Description]

Namespace: HeuristicLab.Permutation
Assembly: HeuristicLab.Permutation (in HeuristicLab.Permutation.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

TranslocationManipulator Class
HeuristicLab.Permutation Namespace


HeuristicLab.PluginInfrastructure Namespace

HeuristicLab.PluginInfrastructure Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.PluginInfrastructure]

Classes

Class | Description
ApplicationBase |
ApplicationInfo |
ClassInfoAttribute | This attribute can be used to specify meta data for classes. For example to specify name, version and description of applications or plugins.
DependencyAttribute | This attribute can be used to specify that an assembly depends on a different plugin.
DiscoveryService | Provides convenience methods to find specific types or to create instances of types.
InvalidPluginException |
Loader |
PluginBase | Default implementation of the IPlugin interface.
PluginFileAttribute |
PluginInfo | Holds information of loaded plugins that is needed for plugin management. Used to represent plugins in AppDomains without loading the plugin assemblies.
PluginManager |
PluginManagerActionEventArgs |
Runner |

Interfaces

Interface | Description
IApplication |
IControl |
IControlManager |
IPlugin | Represents a plugin. Plugin developers have to include exactly one class that implements this interface in one of the assemblies of the plugin. Plugin developers can use the properties of this interface to store plugin data (name, version, files, update location ...). The methods OnInstall(), OnDelete(), OnPreUpdate(), OnPostUpdate() are called by the framework when the corresponding actions are executed. This mechanism allows that the plugin reacts to such events. For instance to store plugin specific settings.

Delegates

Delegate | Description
Loader..::.PluginLoadedEventHandler |
Loader..::.PluginLoadFailedEventHandler |
PluginManagerActionEventHandler |

Enumerations

Enumeration | Description
PluginFileType |
PluginManagerAction |


ApplicationBase Class

ApplicationBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.ApplicationBase]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ApplicationBase : IApplication

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.ApplicationBase
HeuristicLab.AdvancedOptimizationFrontend..::.HeuristicLabAdvancedOptimizationFrontendApplication
HeuristicLab.Grid..::.GridServerApplication
HeuristicLab.Grid..::.GridClientApplication
HeuristicLab.OptimizationFrontend..::.HeuristicLabOptimizationFrontendApplication

See Also

ApplicationBase Members
HeuristicLab.PluginInfrastructure Namespace


ApplicationBase Members

[image]

HeuristicLab API Documentation
ApplicationBase Members
ApplicationBase Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApplicationBase type exposes the following members.

Constructors

Name | Description
ApplicationBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description |
Name |
Version |

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


ApplicationBase Constructor

ApplicationBase Constructor
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ApplicationBase class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ApplicationBase()

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


ApplicationBase Methods

[image]

HeuristicLab API Documentation
ApplicationBase Methods
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApplicationBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Run |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


Run Method

ApplicationBase..::.Run Method
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.ApplicationBase.Run]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract void Run()

Implements

IApplication..::.Run()()()

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


ApplicationBase Properties

[image]

HeuristicLab API Documentation
ApplicationBase Properties
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApplicationBase type exposes the following members.

Properties

Name | Description
Description |
Name |
Version |

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


Description Property

ApplicationBase..::.Description Property
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ApplicationBase.Description]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Description { get; }

Implements

IApplication..::.Description

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


Name Property

ApplicationBase..::.Name Property
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ApplicationBase.Name]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; }

Implements

IApplication..::.Name

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


Version Property

ApplicationBase..::.Version Property
ApplicationBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ApplicationBase.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Version Version { get; }

Implements

IApplication..::.Version

See Also

ApplicationBase Class
HeuristicLab.PluginInfrastructure Namespace


ApplicationInfo Class

ApplicationInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.ApplicationInfo]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[SerializableAttribute]
public class ApplicationInfo

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.ApplicationInfo

See Also

ApplicationInfo Members
HeuristicLab.PluginInfrastructure Namespace


ApplicationInfo Members

[image]

HeuristicLab API Documentation
ApplicationInfo Members
ApplicationInfo Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApplicationInfo type exposes the following members.

Constructors

Name | Description
ApplicationInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description |
Name |
PluginAssembly | Name of the assembly that contains the IApplication type. NEEDED?
PluginType | Name of the type that implements the interface IApplication. NEEDED?
Version |

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


ApplicationInfo Constructor

ApplicationInfo Constructor
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ApplicationInfo class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ApplicationInfo()

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


ApplicationInfo Properties

[image]

HeuristicLab API Documentation
ApplicationInfo Properties
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ApplicationInfo type exposes the following members.

Properties

Name | Description
Description |
Name |
PluginAssembly | Name of the assembly that contains the IApplication type. NEEDED?
PluginType | Name of the type that implements the interface IApplication. NEEDED?
Version |

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


Description Property

ApplicationInfo..::.Description Property
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ApplicationInfo.Description]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Description { get; set; }

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


Name Property

ApplicationInfo..::.Name Property
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ApplicationInfo.Name]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


PluginAssembly Property

ApplicationInfo..::.PluginAssembly Property
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Name of the assembly that contains the IApplication type. NEEDED?

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string PluginAssembly { get; set; }

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


PluginType Property

ApplicationInfo..::.PluginType Property
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Name of the type that implements the interface IApplication. NEEDED?

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string PluginType { get; set; }

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


Version Property

ApplicationInfo..::.Version Property
ApplicationInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ApplicationInfo.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Version Version { get; set; }

See Also

ApplicationInfo Class
HeuristicLab.PluginInfrastructure Namespace


ClassInfoAttribute Class

ClassInfoAttribute Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This attribute can be used to specify meta data for classes. For example to specify name, version and description of applications or plugins.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Class)]
public class ClassInfoAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
HeuristicLab.PluginInfrastructure..::.ClassInfoAttribute

See Also

ClassInfoAttribute Members
HeuristicLab.PluginInfrastructure Namespace


ClassInfoAttribute Members

[image]

HeuristicLab API Documentation
ClassInfoAttribute Members
ClassInfoAttribute Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ClassInfoAttribute type exposes the following members.

Constructors

Name | Description
ClassInfoAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description |
Name | Name of the plugin to which the assembly belongs to.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Version |

See Also

ClassInfoAttribute Class
HeuristicLab.PluginInfrastructure Namespace


ClassInfoAttribute Constructor

ClassInfoAttribute Constructor
ClassInfoAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ClassInfoAttribute class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ClassInfoAttribute()

See Also

ClassInfoAttribute Class
HeuristicLab.PluginInfrastructure Namespace


ClassInfoAttribute Properties

[image]

HeuristicLab API Documentation
ClassInfoAttribute Properties
ClassInfoAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ClassInfoAttribute type exposes the following members.

Properties

Name | Description
Description |
Name | Name of the plugin to which the assembly belongs to.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Version |

See Also

ClassInfoAttribute Class
HeuristicLab.PluginInfrastructure Namespace


Description Property

ClassInfoAttribute..::.Description Property
ClassInfoAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ClassInfoAttribute.Description]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Description { get; set; }

See Also

ClassInfoAttribute Class
HeuristicLab.PluginInfrastructure Namespace


Name Property

ClassInfoAttribute..::.Name Property
ClassInfoAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Name of the plugin to which the assembly belongs to.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

See Also

ClassInfoAttribute Class
HeuristicLab.PluginInfrastructure Namespace


Version Property

ClassInfoAttribute..::.Version Property
ClassInfoAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.ClassInfoAttribute.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Version { get; set; }

See Also

ClassInfoAttribute Class
HeuristicLab.PluginInfrastructure Namespace


DependencyAttribute Class

DependencyAttribute Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This attribute can be used to specify that an assembly depends on a different plugin.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true)]
public sealed class DependencyAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
HeuristicLab.PluginInfrastructure..::.DependencyAttribute

See Also

DependencyAttribute Members
HeuristicLab.PluginInfrastructure Namespace


DependencyAttribute Members

[image]

HeuristicLab API Documentation
DependencyAttribute Members
DependencyAttribute Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DependencyAttribute type exposes the following members.

Constructors

Name | Description
DependencyAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dependency | Name of the plugin that is needed to load the assembly.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DependencyAttribute Class
HeuristicLab.PluginInfrastructure Namespace


DependencyAttribute Constructor

DependencyAttribute Constructor
DependencyAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DependencyAttribute class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DependencyAttribute()

See Also

DependencyAttribute Class
HeuristicLab.PluginInfrastructure Namespace


DependencyAttribute Properties

[image]

HeuristicLab API Documentation
DependencyAttribute Properties
DependencyAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DependencyAttribute type exposes the following members.

Properties

Name | Description
Dependency | Name of the plugin that is needed to load the assembly.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DependencyAttribute Class
HeuristicLab.PluginInfrastructure Namespace


Dependency Property

DependencyAttribute..::.Dependency Property
DependencyAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Name of the plugin that is needed to load the assembly.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Dependency { get; set; }

See Also

DependencyAttribute Class
HeuristicLab.PluginInfrastructure Namespace


DiscoveryService Class

DiscoveryService Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Provides convenience methods to find specific types or to create instances of types.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DiscoveryService

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.DiscoveryService

See Also

DiscoveryService Members
HeuristicLab.PluginInfrastructure Namespace


DiscoveryService Members

[image]

HeuristicLab API Documentation
DiscoveryService Members
DiscoveryService Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DiscoveryService type exposes the following members.

Constructors

Name | Description
DiscoveryService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInstances | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Plugins |

See Also

DiscoveryService Class
HeuristicLab.PluginInfrastructure Namespace


DiscoveryService Constructor

DiscoveryService Constructor
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DiscoveryService class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DiscoveryService()

See Also

DiscoveryService Class
HeuristicLab.PluginInfrastructure Namespace


DiscoveryService Methods

[image]

HeuristicLab API Documentation
DiscoveryService Methods
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DiscoveryService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInstances | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DiscoveryService Class
HeuristicLab.PluginInfrastructure Namespace


GetInstances Method

[image]

HeuristicLab API Documentation
DiscoveryService..::.GetInstances Method
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetInstances<(Of <(T>)>)()()() | Create an instance of all types that are subtypes or the same type of the specified type
GetInstances<(Of <(T>)>)(Assembly) | Get instances of all types that implement the specified interface only in the given assembly.

See Also

DiscoveryService Class
DiscoveryService Members
HeuristicLab.PluginInfrastructure Namespace


GetInstances(T) Method

DiscoveryService..::.GetInstances<(Of <(T>)>) Method
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Create an instance of all types that are subtypes or the same type of the specified type

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public T[] GetInstances<T>() where T : class

Type Parameters

T
Most general type.

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.DiscoveryService.GetInstances``1]

See Also

DiscoveryService Class
GetInstances Overload
HeuristicLab.PluginInfrastructure Namespace


GetInstances(T) Method (Assembly)

DiscoveryService..::.GetInstances<(Of <(T>)>) Method (Assembly)
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get instances of all types that implement the specified interface only in the given assembly.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal T[] GetInstances<T>(
    Assembly assembly
)

Parameters

assembly
Type: System.Reflection..::.Assembly
Assembly that should be searched for types.

Type Parameters

T
Interface type.

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.DiscoveryService.GetInstances``1(System.Reflection.Assembly)]

See Also

DiscoveryService Class
GetInstances Overload
HeuristicLab.PluginInfrastructure Namespace


GetTypes Method

[image]

HeuristicLab API Documentation
DiscoveryService..::.GetTypes Method
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetTypes(Type) | Find all types that are subtypes or equal to the specified type.
GetTypes(Type, PluginInfo) |
GetTypes(Type, Assembly) | Get types that are assignable (same of subtype) to the specified type only from the given assembly.

See Also

DiscoveryService Class
DiscoveryService Members
HeuristicLab.PluginInfrastructure Namespace


GetTypes Method (Type)

DiscoveryService..::.GetTypes Method (Type)
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Find all types that are subtypes or equal to the specified type.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Type[] GetTypes(
    Type type
)

Parameters

type
Type: System..::.Type
Most general type for which to find matching types.

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.DiscoveryService.GetTypes(System.Type)]

See Also

DiscoveryService Class
GetTypes Overload
HeuristicLab.PluginInfrastructure Namespace


GetTypes Method (Type, PluginInfo)

DiscoveryService..::.GetTypes Method (Type, PluginInfo)
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.DiscoveryService.GetTypes(System.Type,HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Type[] GetTypes(
    Type type,
    PluginInfo plugin
)

Parameters

type
Type: System..::.Type

[Missing <param> documentation for "type"]

plugin
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "plugin"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.DiscoveryService.GetTypes(System.Type,HeuristicLab.PluginInfrastructure.PluginInfo)]

See Also

DiscoveryService Class
GetTypes Overload
HeuristicLab.PluginInfrastructure Namespace


GetTypes Method (Type, Assembly)

DiscoveryService..::.GetTypes Method (Type, Assembly)
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Get types that are assignable (same of subtype) to the specified type only from the given assembly.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal Type[] GetTypes(
    Type type,
    Assembly assembly
)

Parameters

type
Type: System..::.Type
Most general type we want to find.
assembly
Type: System.Reflection..::.Assembly
Assembly that should be searched for types.

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.DiscoveryService.GetTypes(System.Type,System.Reflection.Assembly)]

See Also

DiscoveryService Class
GetTypes Overload
HeuristicLab.PluginInfrastructure Namespace


DiscoveryService Properties

[image]

HeuristicLab API Documentation
DiscoveryService Properties
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DiscoveryService type exposes the following members.

Properties

Name | Description
Plugins |

See Also

DiscoveryService Class
HeuristicLab.PluginInfrastructure Namespace


Plugins Property

DiscoveryService..::.Plugins Property
DiscoveryService Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.DiscoveryService.Plugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginInfo[] Plugins { get; }

See Also

DiscoveryService Class
HeuristicLab.PluginInfrastructure Namespace


IApplication Interface

IApplication Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.IApplication]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal interface IApplication

See Also

IApplication Members
HeuristicLab.PluginInfrastructure Namespace


IApplication Members

[image]

HeuristicLab API Documentation
IApplication Members
IApplication Interface Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IApplication type exposes the following members.

Methods

Name | Description
Run |

Properties

Name | Description
Description |
Name |
Version |

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


IApplication Methods

[image]

HeuristicLab API Documentation
IApplication Methods
IApplication Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IApplication type exposes the following members.

Methods

Name | Description
Run |

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


Run Method

IApplication..::.Run Method
IApplication Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.IApplication.Run]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void Run()

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


IApplication Properties

[image]

HeuristicLab API Documentation
IApplication Properties
IApplication Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IApplication type exposes the following members.

Properties

Name | Description
Description |
Name |
Version |

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


Description Property

IApplication..::.Description Property
IApplication Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.IApplication.Description]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Description { get; }

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


Name Property

IApplication..::.Name Property
IApplication Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.IApplication.Name]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Name { get; }

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


Version Property

IApplication..::.Version Property
IApplication Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.IApplication.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Version Version { get; }

See Also

IApplication Interface
HeuristicLab.PluginInfrastructure Namespace


IControl Interface

IControl Interface
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.IControl]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IControl

See Also

HeuristicLab.PluginInfrastructure Namespace


IControlManager Interface

IControlManager Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.IControlManager]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public interface IControlManager

See Also

IControlManager Members
HeuristicLab.PluginInfrastructure Namespace


IControlManager Members

[image]

HeuristicLab API Documentation
IControlManager Members
IControlManager Interface Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IControlManager type exposes the following members.

Methods

Name | Description
ShowControl |

See Also

IControlManager Interface
HeuristicLab.PluginInfrastructure Namespace


IControlManager Methods

[image]

HeuristicLab API Documentation
IControlManager Methods
IControlManager Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IControlManager type exposes the following members.

Methods

Name | Description
ShowControl |

See Also

IControlManager Interface
HeuristicLab.PluginInfrastructure Namespace


ShowControl Method

IControlManager..::.ShowControl Method
IControlManager Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.IControlManager.ShowControl(HeuristicLab.PluginInfrastructure.IControl)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void ShowControl(
    IControl control
)

Parameters

control
Type: HeuristicLab.PluginInfrastructure..::.IControl

[Missing <param> documentation for "control"]

See Also

IControlManager Interface
HeuristicLab.PluginInfrastructure Namespace


InvalidPluginException Class

InvalidPluginException Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.InvalidPluginException]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class InvalidPluginException : Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
HeuristicLab.PluginInfrastructure..::.InvalidPluginException

See Also

InvalidPluginException Members
HeuristicLab.PluginInfrastructure Namespace


InvalidPluginException Members

[image]

HeuristicLab API Documentation
InvalidPluginException Members
InvalidPluginException Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InvalidPluginException type exposes the following members.

Constructors

Name | Description
InvalidPluginException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidPluginException Class
HeuristicLab.PluginInfrastructure Namespace


InvalidPluginException Constructor

InvalidPluginException Constructor
InvalidPluginException Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the InvalidPluginException class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public InvalidPluginException()

See Also

InvalidPluginException Class
HeuristicLab.PluginInfrastructure Namespace


IPlugin Interface

IPlugin Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Represents a plugin. Plugin developers have to include exactly one class that implements this interface in one of the assemblies of the plugin. Plugin developers can use the properties of this interface to store plugin data (name, version, files, update location ...). The methods OnInstall(), OnDelete(), OnPreUpdate(), OnPostUpdate() are called by the framework when the corresponding actions are executed. This mechanism allows that the plugin reacts to such events. For instance to store plugin specific settings.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal interface IPlugin

See Also

IPlugin Members
HeuristicLab.PluginInfrastructure Namespace


IPlugin Members

[image]

HeuristicLab API Documentation
IPlugin Members
IPlugin Interface Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPlugin type exposes the following members.

Methods

Name | Description
OnDelete | called by the framework before the files of the plugin are deleted
OnInstall | called by the framework after the plugin was successfully installed
OnPostUpdate | called by the framework after the updated files for the plugin have been installed OnPostUpdate() is sent only to the new updated instance of the plugin
OnPreUpdate | called by the framework before the files of the plugin are deleted for an update OnPreUpdate() is sent only to the old instance of the plugin

Properties

Name | Description
Files | a list of all files that are bundled with this plugin including all assembly files (*.dll)
Name |
Version |

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


IPlugin Methods

[image]

HeuristicLab API Documentation
IPlugin Methods
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPlugin type exposes the following members.

Methods

Name | Description
OnDelete | called by the framework before the files of the plugin are deleted
OnInstall | called by the framework after the plugin was successfully installed
OnPostUpdate | called by the framework after the updated files for the plugin have been installed OnPostUpdate() is sent only to the new updated instance of the plugin
OnPreUpdate | called by the framework before the files of the plugin are deleted for an update OnPreUpdate() is sent only to the old instance of the plugin

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


OnDelete Method

IPlugin..::.OnDelete Method
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

called by the framework before the files of the plugin are deleted

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OnDelete()

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


OnInstall Method

IPlugin..::.OnInstall Method
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

called by the framework after the plugin was successfully installed

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OnInstall()

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


OnPostUpdate Method

IPlugin..::.OnPostUpdate Method
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

called by the framework after the updated files for the plugin have been installed OnPostUpdate() is sent only to the new updated instance of the plugin

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OnPostUpdate()

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


OnPreUpdate Method

IPlugin..::.OnPreUpdate Method
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

called by the framework before the files of the plugin are deleted for an update OnPreUpdate() is sent only to the old instance of the plugin

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
void OnPreUpdate()

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


IPlugin Properties

[image]

HeuristicLab API Documentation
IPlugin Properties
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IPlugin type exposes the following members.

Properties

Name | Description
Files | a list of all files that are bundled with this plugin including all assembly files (*.dll)
Name |
Version |

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


Files Property

IPlugin..::.Files Property
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

a list of all files that are bundled with this plugin including all assembly files (*.dll)

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string[] Files { get; }

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


Name Property

IPlugin..::.Name Property
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.IPlugin.Name]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
string Name { get; }

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


Version Property

IPlugin..::.Version Property
IPlugin Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.IPlugin.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
Version Version { get; }

See Also

IPlugin Interface
HeuristicLab.PluginInfrastructure Namespace


Loader Class

Loader Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.Loader]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class Loader : MarshalByRefObject

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
HeuristicLab.PluginInfrastructure..::.Loader

See Also

Loader Members
HeuristicLab.PluginInfrastructure Namespace


Loader Members

[image]

HeuristicLab API Documentation
Loader Members
Loader Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Loader type exposes the following members.

Constructors

Name | Description
Loader |

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Init first clears all internal datastructures (including plugin lists) 1. All assemblies in the plugins directory are loaded into the reflection only context. 2. The loader checks if all dependencies for each assembly are available. 3. All assemblies for which there are no dependencies missing are loaded into the execution context. 4. Each loaded assembly is searched for a type that implements IPlugin, then one instance of each IPlugin type is activated 5. The loader checks if all necessary files for each plugin are available. 6. The loader builds an acyclic graph of PluginDescriptions (childs are dependencies of a plugin) based on the list of assemblies of an plugin and the list of dependencies for each of those assemblies
InitializeLifetimeService | (Overrides MarshalByRefObject ..::. InitializeLifetimeService()()().)
MemberwiseClone | Overloaded.
OnDelete |
OnInstall |
OnPostUpdate |
OnPreUpdate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActivePlugins |
DisabledPlugins |
InstalledApplications |
InstalledPlugins |

Events

Name | Description
MissingPluginFile |
PluginAction |

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


Loader Constructor

Loader Constructor
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Loader class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Loader()

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


Loader Methods

[image]

HeuristicLab API Documentation
Loader Methods
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Loader type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Init first clears all internal datastructures (including plugin lists) 1. All assemblies in the plugins directory are loaded into the reflection only context. 2. The loader checks if all dependencies for each assembly are available. 3. All assemblies for which there are no dependencies missing are loaded into the execution context. 4. Each loaded assembly is searched for a type that implements IPlugin, then one instance of each IPlugin type is activated 5. The loader checks if all necessary files for each plugin are available. 6. The loader builds an acyclic graph of PluginDescriptions (childs are dependencies of a plugin) based on the list of assemblies of an plugin and the list of dependencies for each of those assemblies
InitializeLifetimeService | (Overrides MarshalByRefObject ..::. InitializeLifetimeService()()().)
MemberwiseClone | Overloaded.
OnDelete |
OnInstall |
OnPostUpdate |
OnPreUpdate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


Init Method

Loader..::.Init Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Init first clears all internal datastructures (including plugin lists) 1. All assemblies in the plugins directory are loaded into the reflection only context. 2. The loader checks if all dependencies for each assembly are available. 3. All assemblies for which there are no dependencies missing are loaded into the execution context. 4. Each loaded assembly is searched for a type that implements IPlugin, then one instance of each IPlugin type is activated 5. The loader checks if all necessary files for each plugin are available. 6. The loader builds an acyclic graph of PluginDescriptions (childs are dependencies of a plugin) based on the list of assemblies of an plugin and the list of dependencies for each of those assemblies

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void Init()

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


InitializeLifetimeService Method

Loader..::.InitializeLifetimeService Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Loader.InitializeLifetimeService]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object InitializeLifetimeService()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.Loader.InitializeLifetimeService]

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
Loader..::.MemberwiseClone Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Loader Class
Loader Members
HeuristicLab.PluginInfrastructure Namespace


OnDelete Method

Loader..::.OnDelete Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Loader.OnDelete(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void OnDelete(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


OnInstall Method

Loader..::.OnInstall Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Loader.OnInstall(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void OnInstall(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


OnPostUpdate Method

Loader..::.OnPostUpdate Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Loader.OnPostUpdate(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void OnPostUpdate(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


OnPreUpdate Method

Loader..::.OnPreUpdate Method
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Loader.OnPreUpdate(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void OnPreUpdate(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


Loader Properties

[image]

HeuristicLab API Documentation
Loader Properties
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Loader type exposes the following members.

Properties

Name | Description
ActivePlugins |
DisabledPlugins |
InstalledApplications |
InstalledPlugins |

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


ActivePlugins Property

Loader..::.ActivePlugins Property
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.Loader.ActivePlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal ICollection<PluginInfo> ActivePlugins { get; }

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


DisabledPlugins Property

Loader..::.DisabledPlugins Property
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.Loader.DisabledPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal ICollection<PluginInfo> DisabledPlugins { get; }

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


InstalledApplications Property

Loader..::.InstalledApplications Property
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.Loader.InstalledApplications]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal ICollection<ApplicationInfo> InstalledApplications { get; }

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


InstalledPlugins Property

Loader..::.InstalledPlugins Property
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.Loader.InstalledPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal ICollection<PluginInfo> InstalledPlugins { get; }

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


Loader Events

[image]

HeuristicLab API Documentation
Loader Events
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Loader type exposes the following members.

Events

Name | Description
MissingPluginFile |
PluginAction |

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


MissingPluginFile Event

Loader..::.MissingPluginFile Event
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.PluginInfrastructure.Loader.MissingPluginFile]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal event Loader..::.PluginLoadFailedEventHandler MissingPluginFile

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


PluginAction Event

Loader..::.PluginAction Event
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.PluginInfrastructure.Loader.PluginAction]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal event PluginManagerActionEventHandler PluginAction

See Also

Loader Class
HeuristicLab.PluginInfrastructure Namespace


Loader.PluginLoadedEventHandler Delegate

Loader..::.PluginLoadedEventHandler Delegate
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.Loader.PluginLoadedEventHandler]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public delegate void PluginLoadedEventHandler(
    string pluginName
)

Parameters

pluginName
Type: System..::.String

See Also

HeuristicLab.PluginInfrastructure Namespace


Loader.PluginLoadFailedEventHandler Delegate

Loader..::.PluginLoadFailedEventHandler Delegate
Loader Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.Loader.PluginLoadFailedEventHandler]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public delegate void PluginLoadFailedEventHandler(
    string pluginName,
    string args
)

Parameters

pluginName
Type: System..::.String
args
Type: System..::.String

See Also

HeuristicLab.PluginInfrastructure Namespace


PluginBase Class

PluginBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Default implementation of the IPlugin interface.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PluginBase : IPlugin

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.AdvancedOptimizationFrontend..::.HeuristicLabAdvancedOptimizationFrontendPlugin
HeuristicLab.BitVector..::.HeuristicLabBitVectorPlugin
HeuristicLab.Charting.Data..::.HeuristicLabChartingDataPlugin
HeuristicLab.Charting..::.HeuristicLabChartingPlugin
HeuristicLab.Constraints..::.HeuristicLabConstraintsPlugin
HeuristicLab.Core..::.HeuristicLabCorePlugin
HeuristicLab.Data..::.HeuristicLabDataPlugin
HeuristicLab.DataAnalysis..::.HeuristicLabDataAnalysisPlugin
HeuristicLab.DistributedEngine..::.HeuristicLabDistributedEnginePlugin
HeuristicLab.Evolutionary..::.HeuristicLabEvolutionaryPlugin
HeuristicLab.Functions..::.HeuristicLabFunctionsPlugin
HeuristicLab.Grid..::.HeuristicLabGridPlugin
HeuristicLab.Logging..::.HeuristicLabLoggingPlugin
HeuristicLab.Operators..::.HeuristicLabOperatorsPlugin
HeuristicLab.Operators..::.HeuristicLabOperatorsProgrammablePlugin
HeuristicLab.OptimizationFrontend..::.HeuristicLabOptimizationFrontendPlugin
HeuristicLab.Permutation..::.HeuristicLabRandomPlugin
HeuristicLab.Random..::.HeuristicLabRandomPlugin
HeuristicLab.RealVector..::.HeuristicLabRealVectorPlugin
HeuristicLab.Routing.TSP..::.HeuristicLabRoutingTSPPlugin
HeuristicLab.Scheduling.JSSP..::.HeuristicLabRoutingTSPPlugin
HeuristicLab.Selection..::.HeuristicLabSelectionPlugin
HeuristicLab.Selection.OffspringSelection..::.HeuristicLabSelectionOffspringSelectionPlugin
HeuristicLab.SequentialEngine..::.HeuristicLabSequentialEnginePlugin
HeuristicLab.SGA..::.HeuristicLabSGAPlugin
HeuristicLab.StructureIdentification..::.HeuristicLabStructureIdentificationPlugin
HeuristicLab.TestFunctions..::.HeuristicLabTestFunctionsPlugin
HeuristicLab.ThreadParallelEngine..::.HeuristicLabThreadParallelEnginePlugin

See Also

PluginBase Members
HeuristicLab.PluginInfrastructure Namespace


PluginBase Members

[image]

HeuristicLab API Documentation
PluginBase Members
PluginBase Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginBase type exposes the following members.

Constructors

Name | Description
PluginBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete |
OnInstall |
OnPostUpdate |
OnPreUpdate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description |
Files |
Name |
Version |

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


PluginBase Constructor

PluginBase Constructor
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginBase class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginBase()

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


PluginBase Methods

[image]

HeuristicLab API Documentation
PluginBase Methods
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete |
OnInstall |
OnPostUpdate |
OnPreUpdate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


OnDelete Method

PluginBase..::.OnDelete Method
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginBase.OnDelete]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void OnDelete()

Implements

IPlugin..::.OnDelete()()()

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


OnInstall Method

PluginBase..::.OnInstall Method
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginBase.OnInstall]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void OnInstall()

Implements

IPlugin..::.OnInstall()()()

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


OnPostUpdate Method

PluginBase..::.OnPostUpdate Method
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginBase.OnPostUpdate]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void OnPostUpdate()

Implements

IPlugin..::.OnPostUpdate()()()

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


OnPreUpdate Method

PluginBase..::.OnPreUpdate Method
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginBase.OnPreUpdate]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual void OnPreUpdate()

Implements

IPlugin..::.OnPreUpdate()()()

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


PluginBase Properties

[image]

HeuristicLab API Documentation
PluginBase Properties
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginBase type exposes the following members.

Properties

Name | Description
Description |
Files |
Name |
Version |

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


Description Property

PluginBase..::.Description Property
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginBase.Description]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Description { get; }

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


Files Property

PluginBase..::.Files Property
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginBase.Files]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string[] Files { get; }

Implements

IPlugin..::.Files

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


Name Property

PluginBase..::.Name Property
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginBase.Name]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; }

Implements

IPlugin..::.Name

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


Version Property

PluginBase..::.Version Property
PluginBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginBase.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Version Version { get; }

Implements

IPlugin..::.Version

See Also

PluginBase Class
HeuristicLab.PluginInfrastructure Namespace


PluginFileAttribute Class

PluginFileAttribute Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.PluginFileAttribute]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true)]
public class PluginFileAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
HeuristicLab.PluginInfrastructure..::.PluginFileAttribute

See Also

PluginFileAttribute Members
HeuristicLab.PluginInfrastructure Namespace


PluginFileAttribute Members

[image]

HeuristicLab API Documentation
PluginFileAttribute Members
PluginFileAttribute Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginFileAttribute type exposes the following members.

Constructors

Name | Description
PluginFileAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Filename |
Filetype |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

PluginFileAttribute Class
HeuristicLab.PluginInfrastructure Namespace


PluginFileAttribute Constructor

PluginFileAttribute Constructor
PluginFileAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginFileAttribute class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginFileAttribute()

See Also

PluginFileAttribute Class
HeuristicLab.PluginInfrastructure Namespace


PluginFileAttribute Properties

[image]

HeuristicLab API Documentation
PluginFileAttribute Properties
PluginFileAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginFileAttribute type exposes the following members.

Properties

Name | Description
Filename |
Filetype |
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

PluginFileAttribute Class
HeuristicLab.PluginInfrastructure Namespace


Filename Property

PluginFileAttribute..::.Filename Property
PluginFileAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginFileAttribute.Filename]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Filename { get; set; }

See Also

PluginFileAttribute Class
HeuristicLab.PluginInfrastructure Namespace


Filetype Property

PluginFileAttribute..::.Filetype Property
PluginFileAttribute Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginFileAttribute.Filetype]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginFileType Filetype { get; set; }

See Also

PluginFileAttribute Class
HeuristicLab.PluginInfrastructure Namespace


PluginFileType Enumeration

PluginFileType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.PluginFileType]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public enum PluginFileType

Members

Member name | Description
Assembly |
Executable |
Data |
License |

See Also

HeuristicLab.PluginInfrastructure Namespace


PluginInfo Class

PluginInfo Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Holds information of loaded plugins that is needed for plugin management. Used to represent plugins in AppDomains without loading the plugin assemblies.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[SerializableAttribute]
public class PluginInfo

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginInfo

See Also

PluginInfo Members
HeuristicLab.PluginInfrastructure Namespace


PluginInfo Members

[image]

HeuristicLab API Documentation
PluginInfo Members
PluginInfo Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginInfo type exposes the following members.

Constructors

Name | Description
PluginInfo |

Methods

Name | Description
Equals | (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Assemblies | Names of the assemblies that belong to this plugin.
Dependencies |
Files | Names of all files that belong to this plugin. These files are deleted when the plugin is removed or updated.
Name |
Version |

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


PluginInfo Constructor

PluginInfo Constructor
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginInfo class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginInfo()

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


PluginInfo Methods

[image]

HeuristicLab API Documentation
PluginInfo Methods
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginInfo type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


Equals Method

PluginInfo..::.Equals Method
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginInfo.Equals(System.Object)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.PluginInfo.Equals(System.Object)]

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


GetHashCode Method

PluginInfo..::.GetHashCode Method
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginInfo.GetHashCode]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override int GetHashCode()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.PluginInfo.GetHashCode]

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


ToString Method

PluginInfo..::.ToString Method
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginInfo.ToString]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.PluginInfo.ToString]

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


PluginInfo Properties

[image]

HeuristicLab API Documentation
PluginInfo Properties
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginInfo type exposes the following members.

Properties

Name | Description
Assemblies | Names of the assemblies that belong to this plugin.
Dependencies |
Files | Names of all files that belong to this plugin. These files are deleted when the plugin is removed or updated.
Name |
Version |

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


Assemblies Property

PluginInfo..::.Assemblies Property
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Names of the assemblies that belong to this plugin.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<string> Assemblies { get; set; }

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


Dependencies Property

PluginInfo..::.Dependencies Property
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginInfo.Dependencies]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<PluginInfo> Dependencies { get; }

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


Files Property

PluginInfo..::.Files Property
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Names of all files that belong to this plugin. These files are deleted when the plugin is removed or updated.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<string> Files { get; }

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


Name Property

PluginInfo..::.Name Property
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginInfo.Name]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


Version Property

PluginInfo..::.Version Property
PluginInfo Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginInfo.Version]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Version Version { get; set; }

See Also

PluginInfo Class
HeuristicLab.PluginInfrastructure Namespace


PluginManager Class

PluginManager Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.PluginManager]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PluginManager : MarshalByRefObject

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
HeuristicLab.PluginInfrastructure..::.PluginManager

See Also

PluginManager Members
HeuristicLab.PluginInfrastructure Namespace


PluginManager Members

[image]

HeuristicLab API Documentation
PluginManager Members
PluginManager Class Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginManager type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDependentPlugins | Calculates a set of plugins that directly or transitively depend on the plugin given in the argument.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | Creates a dedicated AppDomain for loading all plugins and checking dependencies.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadAllPlugins |
MemberwiseClone | Overloaded.
OnDelete |
OnInstall |
OnPostUpdate |
OnPreUpdate |
Run | Creates a separate AppDomain. Loads all active plugin assemblies and starts the application in the new AppDomain via a PluginRunner instance activated in the new AppDomain
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnloadAllPlugins |

Properties

Name | Description
ActivePlugins |
ControlManager |
DisabledPlugins |
InstalledApplications |
InstalledPlugins |
LoadedPlugins |
Manager |

Events

Name | Description
Action |

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


PluginManager Methods

[image]

HeuristicLab API Documentation
PluginManager Methods
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginManager type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDependentPlugins | Calculates a set of plugins that directly or transitively depend on the plugin given in the argument.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | Creates a dedicated AppDomain for loading all plugins and checking dependencies.
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
LoadAllPlugins |
MemberwiseClone | Overloaded.
OnDelete |
OnInstall |
OnPostUpdate |
OnPreUpdate |
Run | Creates a separate AppDomain. Loads all active plugin assemblies and starts the application in the new AppDomain via a PluginRunner instance activated in the new AppDomain
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnloadAllPlugins |

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


GetDependentPlugins Method

PluginManager..::.GetDependentPlugins Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Calculates a set of plugins that directly or transitively depend on the plugin given in the argument.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<PluginInfo> GetDependentPlugins(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

Return Value

a list of plugins that are directly of transitively dependent.

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


Initialize Method

PluginManager..::.Initialize Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Creates a dedicated AppDomain for loading all plugins and checking dependencies.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Initialize()

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


LoadAllPlugins Method

PluginManager..::.LoadAllPlugins Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginManager.LoadAllPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void LoadAllPlugins()

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
PluginManager..::.MemberwiseClone Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PluginManager Class
PluginManager Members
HeuristicLab.PluginInfrastructure Namespace


OnDelete Method

PluginManager..::.OnDelete Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginManager.OnDelete(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OnDelete(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


OnInstall Method

PluginManager..::.OnInstall Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginManager.OnInstall(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OnInstall(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


OnPostUpdate Method

PluginManager..::.OnPostUpdate Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginManager.OnPostUpdate(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OnPostUpdate(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


OnPreUpdate Method

PluginManager..::.OnPreUpdate Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginManager.OnPreUpdate(HeuristicLab.PluginInfrastructure.PluginInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void OnPreUpdate(
    PluginInfo pluginInfo
)

Parameters

pluginInfo
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "pluginInfo"]

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


Run Method

PluginManager..::.Run Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Creates a separate AppDomain. Loads all active plugin assemblies and starts the application in the new AppDomain via a PluginRunner instance activated in the new AppDomain

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Run(
    ApplicationInfo appInfo
)

Parameters

appInfo
Type: HeuristicLab.PluginInfrastructure..::.ApplicationInfo
application to run

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


UnloadAllPlugins Method

PluginManager..::.UnloadAllPlugins Method
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.PluginManager.UnloadAllPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void UnloadAllPlugins()

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


PluginManager Properties

[image]

HeuristicLab API Documentation
PluginManager Properties
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginManager type exposes the following members.

Properties

Name | Description
ActivePlugins |
ControlManager |
DisabledPlugins |
InstalledApplications |
InstalledPlugins |
LoadedPlugins |
Manager |

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


ActivePlugins Property

PluginManager..::.ActivePlugins Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.ActivePlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<PluginInfo> ActivePlugins { get; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


ControlManager Property

PluginManager..::.ControlManager Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.ControlManager]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static IControlManager ControlManager { get; set; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


DisabledPlugins Property

PluginManager..::.DisabledPlugins Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.DisabledPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<PluginInfo> DisabledPlugins { get; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


InstalledApplications Property

PluginManager..::.InstalledApplications Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.InstalledApplications]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<ApplicationInfo> InstalledApplications { get; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


InstalledPlugins Property

PluginManager..::.InstalledPlugins Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.InstalledPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<PluginInfo> InstalledPlugins { get; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


LoadedPlugins Property

PluginManager..::.LoadedPlugins Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.LoadedPlugins]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ICollection<PluginInfo> LoadedPlugins { get; internal set; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


Manager Property

PluginManager..::.Manager Property
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManager.Manager]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static PluginManager Manager { get; }

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


PluginManager Events

[image]

HeuristicLab API Documentation
PluginManager Events
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginManager type exposes the following members.

Events

Name | Description
Action |

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


Action Event

PluginManager..::.Action Event
PluginManager Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.PluginInfrastructure.PluginManager.Action]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event PluginManagerActionEventHandler Action

See Also

PluginManager Class
HeuristicLab.PluginInfrastructure Namespace


PluginManagerAction Enumeration

PluginManagerAction Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.PluginManagerAction]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public enum PluginManagerAction

Members

Member name | Description
Initializing |
InitializingPlugin |
InitializedPlugin |
Initialized |
Starting |

See Also

HeuristicLab.PluginInfrastructure Namespace


PluginManagerActionEventArgs Class

PluginManagerActionEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.PluginManagerActionEventArgs]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[SerializableAttribute]
public class PluginManagerActionEventArgs

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginManagerActionEventArgs

See Also

PluginManagerActionEventArgs Members
HeuristicLab.PluginInfrastructure Namespace


PluginManagerActionEventArgs Members

[image]

HeuristicLab API Documentation
PluginManagerActionEventArgs Members
PluginManagerActionEventArgs Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginManagerActionEventArgs type exposes the following members.

Constructors

Name | Description
PluginManagerActionEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action |
Id |

See Also

PluginManagerActionEventArgs Class
HeuristicLab.PluginInfrastructure Namespace


PluginManagerActionEventArgs Constructor

PluginManagerActionEventArgs Constructor
PluginManagerActionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginManagerActionEventArgs class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginManagerActionEventArgs(
    string id,
    PluginManagerAction action
)

Parameters

id
Type: System..::.String

[Missing <param> documentation for "id"]

action
Type: HeuristicLab.PluginInfrastructure..::.PluginManagerAction

[Missing <param> documentation for "action"]

See Also

PluginManagerActionEventArgs Class
HeuristicLab.PluginInfrastructure Namespace


PluginManagerActionEventArgs Properties

[image]

HeuristicLab API Documentation
PluginManagerActionEventArgs Properties
PluginManagerActionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginManagerActionEventArgs type exposes the following members.

Properties

Name | Description
Action |
Id |

See Also

PluginManagerActionEventArgs Class
HeuristicLab.PluginInfrastructure Namespace


Action Property

PluginManagerActionEventArgs..::.Action Property
PluginManagerActionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManagerActionEventArgs.Action]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginManagerAction Action { get; set; }

See Also

PluginManagerActionEventArgs Class
HeuristicLab.PluginInfrastructure Namespace


Id Property

PluginManagerActionEventArgs..::.Id Property
PluginManagerActionEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.PluginManagerActionEventArgs.Id]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Id { get; set; }

See Also

PluginManagerActionEventArgs Class
HeuristicLab.PluginInfrastructure Namespace


PluginManagerActionEventHandler Delegate

PluginManagerActionEventHandler Delegate
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.PluginManagerActionEventHandler]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public delegate void PluginManagerActionEventHandler(
    Object sender,
    PluginManagerActionEventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: HeuristicLab.PluginInfrastructure..::.PluginManagerActionEventArgs

See Also

HeuristicLab.PluginInfrastructure Namespace


Runner Class

Runner Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.Runner]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class Runner : MarshalByRefObject

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
HeuristicLab.PluginInfrastructure..::.Runner

See Also

Runner Members
HeuristicLab.PluginInfrastructure Namespace


Runner Members

[image]

HeuristicLab API Documentation
Runner Members
Runner Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Runner type exposes the following members.

Constructors

Name | Description
Runner |

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | (Overrides MarshalByRefObject ..::. InitializeLifetimeService()()().)
LoadPlugins |
MemberwiseClone | Overloaded.
Run |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Runner Class
HeuristicLab.PluginInfrastructure Namespace


Runner Constructor

Runner Constructor
Runner Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Runner class.

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Runner()

See Also

Runner Class
HeuristicLab.PluginInfrastructure Namespace


Runner Methods

[image]

HeuristicLab API Documentation
Runner Methods
Runner Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Runner type exposes the following members.

Methods

Name | Description
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | (Overrides MarshalByRefObject ..::. InitializeLifetimeService()()().)
LoadPlugins |
MemberwiseClone | Overloaded.
Run |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Runner Class
HeuristicLab.PluginInfrastructure Namespace


InitializeLifetimeService Method

Runner..::.InitializeLifetimeService Method
Runner Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Runner.InitializeLifetimeService]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object InitializeLifetimeService()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.Runner.InitializeLifetimeService]

See Also

Runner Class
HeuristicLab.PluginInfrastructure Namespace


LoadPlugins Method

Runner..::.LoadPlugins Method
Runner Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Runner.LoadPlugins(System.Collections.Generic.ICollection{HeuristicLab.PluginInfrastructure.PluginInfo})]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void LoadPlugins(
    ICollection<PluginInfo> plugins
)

Parameters

plugins
Type: System.Collections.Generic..::.ICollection <(Of <( PluginInfo >)>)

[Missing <param> documentation for "plugins"]

See Also

Runner Class
HeuristicLab.PluginInfrastructure Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
Runner..::.MemberwiseClone Method
Runner Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Runner Class
Runner Members
HeuristicLab.PluginInfrastructure Namespace


Run Method

Runner..::.Run Method
Runner Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.Runner.Run(HeuristicLab.PluginInfrastructure.ApplicationInfo)]

Namespace: HeuristicLab.PluginInfrastructure
Assembly: HeuristicLab.PluginInfrastructure (in HeuristicLab.PluginInfrastructure.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Run(
    ApplicationInfo appInfo
)

Parameters

appInfo
Type: HeuristicLab.PluginInfrastructure..::.ApplicationInfo

[Missing <param> documentation for "appInfo"]

See Also

Runner Class
HeuristicLab.PluginInfrastructure Namespace


HeuristicLab.PluginInfrastructure.GUI Namespace

HeuristicLab.PluginInfrastructure.GUI Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.PluginInfrastructure.GUI]

Classes

Class | Description
AboutBox |
DownloaderDialog |
ErrorDialog |
ManagerForm |
PluginAction |
PluginDescription |
PluginNameTransform | This classes is needed to prune the directory tree of zipped plugin packages by removing the path leading to the plugin directory.
PluginSource |
PluginSourceEditor |
PluginTag |

Enumerations

Enumeration | Description
ManagerAction |
PluginState |


AboutBox Class

AboutBox Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.AboutBox]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class AboutBox : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.PluginInfrastructure.GUI..::.AboutBox

See Also

AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


AboutBox Members

[image]

HeuristicLab API Documentation
AboutBox Members
AboutBox Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutBox type exposes the following members.

Constructors

Name | Description
AboutBox |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AssemblyCompany |
AssemblyCopyright |
AssemblyDescription |
AssemblyProduct |
AssemblyTitle |
AssemblyVersion |
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AboutBox Constructor

AboutBox Constructor
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AboutBox class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AboutBox()

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AboutBox Methods

[image]

HeuristicLab API Documentation
AboutBox Methods
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutBox type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
AboutBox..::.AccessibilityNotifyClients Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
AboutBox..::.BeginInvoke Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method

[image]

HeuristicLab API Documentation
AboutBox..::.Dispose Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method (Boolean)

AboutBox..::.Dispose Method (Boolean)
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean

[Missing <param> documentation for "disposing"]

See Also

AboutBox Class
Dispose Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
AboutBox..::.GetChildAtPoint Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
AboutBox..::.Invalidate Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invoke Method

[image]

HeuristicLab API Documentation
AboutBox..::.Invoke Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
AboutBox..::.MemberwiseClone Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
AboutBox..::.PerformLayout Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
AboutBox..::.ResumeLayout Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
AboutBox..::.RtlTranslateAlignment Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Scale Method

[image]

HeuristicLab API Documentation
AboutBox..::.Scale Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Select Method

[image]

HeuristicLab API Documentation
AboutBox..::.Select Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
AboutBox..::.SetBounds Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Show Method

[image]

HeuristicLab API Documentation
AboutBox..::.Show Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
AboutBox..::.ShowDialog Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
AboutBox..::.UpdateBounds Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Validate Method

[image]

HeuristicLab API Documentation
AboutBox..::.Validate Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
AboutBox..::.ValidateChildren Method
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

AboutBox Class
AboutBox Members
HeuristicLab.PluginInfrastructure.GUI Namespace


AboutBox Properties

[image]

HeuristicLab API Documentation
AboutBox Properties
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AboutBox type exposes the following members.

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AssemblyCompany |
AssemblyCopyright |
AssemblyDescription |
AssemblyProduct |
AssemblyTitle |
AssemblyVersion |
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AssemblyCompany Property

AboutBox..::.AssemblyCompany Property
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.AboutBox.AssemblyCompany]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string AssemblyCompany { get; }

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AssemblyCopyright Property

AboutBox..::.AssemblyCopyright Property
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.AboutBox.AssemblyCopyright]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string AssemblyCopyright { get; }

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AssemblyDescription Property

AboutBox..::.AssemblyDescription Property
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.AboutBox.AssemblyDescription]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string AssemblyDescription { get; }

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AssemblyProduct Property

AboutBox..::.AssemblyProduct Property
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.AboutBox.AssemblyProduct]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string AssemblyProduct { get; }

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AssemblyTitle Property

AboutBox..::.AssemblyTitle Property
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.AboutBox.AssemblyTitle]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string AssemblyTitle { get; }

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AssemblyVersion Property

AboutBox..::.AssemblyVersion Property
AboutBox Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.AboutBox.AssemblyVersion]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string AssemblyVersion { get; }

See Also

AboutBox Class
HeuristicLab.PluginInfrastructure.GUI Namespace


DownloaderDialog Class

DownloaderDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.DownloaderDialog]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DownloaderDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.PluginInfrastructure.GUI..::.DownloaderDialog

See Also

DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


DownloaderDialog Members

[image]

HeuristicLab API Documentation
DownloaderDialog Members
DownloaderDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DownloaderDialog type exposes the following members.

Constructors

Name | Description
DownloaderDialog |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetDownloadDescription |
SetProgress |
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
OnCancel |
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


DownloaderDialog Constructor

DownloaderDialog Constructor
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DownloaderDialog class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DownloaderDialog()

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


DownloaderDialog Methods

[image]

HeuristicLab API Documentation
DownloaderDialog Methods
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DownloaderDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetDownloadDescription |
SetProgress |
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.AccessibilityNotifyClients Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.BeginInvoke Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Dispose Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method (Boolean)

DownloaderDialog..::.Dispose Method (Boolean)
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

DownloaderDialog Class
Dispose Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.GetChildAtPoint Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Invalidate Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invoke Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Invoke Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.MemberwiseClone Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.PerformLayout Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.ResumeLayout Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.RtlTranslateAlignment Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Scale Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Scale Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Select Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Select Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.SetBounds Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


SetDownloadDescription Method

DownloaderDialog..::.SetDownloadDescription Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.DownloaderDialog.SetDownloadDescription(System.String)]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetDownloadDescription(
    string description
)

Parameters

description
Type: System..::.String

[Missing <param> documentation for "description"]

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


SetProgress Method

DownloaderDialog..::.SetProgress Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.DownloaderDialog.SetProgress(System.Int32)]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetProgress(
    int progress
)

Parameters

progress
Type: System..::.Int32

[Missing <param> documentation for "progress"]

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Show Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Show Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.ShowDialog Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.UpdateBounds Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Validate Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.Validate Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
DownloaderDialog..::.ValidateChildren Method
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

DownloaderDialog Class
DownloaderDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


DownloaderDialog Events

[image]

HeuristicLab API Documentation
DownloaderDialog Events
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DownloaderDialog type exposes the following members.

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
OnCancel |
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


OnCancel Event

DownloaderDialog..::.OnCancel Event
DownloaderDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.PluginInfrastructure.GUI.DownloaderDialog.OnCancel]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event MethodInvoker OnCancel

See Also

DownloaderDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


ErrorDialog Class

ErrorDialog Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.ErrorDialog]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ErrorDialog : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.PluginInfrastructure.GUI..::.ErrorDialog

See Also

ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ErrorDialog Members

[image]

HeuristicLab API Documentation
ErrorDialog Members
ErrorDialog Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ErrorDialog type exposes the following members.

Constructors

Name | Description
ErrorDialog |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ErrorDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


ErrorDialog Constructor

ErrorDialog Constructor
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ErrorDialog class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ErrorDialog(
    string message,
    string caption
)

Parameters

message
Type: System..::.String

[Missing <param> documentation for "message"]

caption
Type: System..::.String

[Missing <param> documentation for "caption"]

See Also

ErrorDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


ErrorDialog Methods

[image]

HeuristicLab API Documentation
ErrorDialog Methods
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ErrorDialog type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ErrorDialog Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.AccessibilityNotifyClients Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.BeginInvoke Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Dispose Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method (Boolean)

ErrorDialog..::.Dispose Method (Boolean)
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ErrorDialog Class
Dispose Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.GetChildAtPoint Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Invalidate Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Invoke Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.MemberwiseClone Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.PerformLayout Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.ResumeLayout Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.RtlTranslateAlignment Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Scale Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Scale Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Select Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Select Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.SetBounds Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Show Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Show Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.ShowDialog Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.UpdateBounds Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Validate Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.Validate Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ErrorDialog..::.ValidateChildren Method
ErrorDialog Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ErrorDialog Class
ErrorDialog Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ManagerAction Enumeration

ManagerAction Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.ManagerAction]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[FlagsAttribute]
internal enum ManagerAction

Members

Member name | Description
Install |
Remove |
None |
Any |

See Also

HeuristicLab.PluginInfrastructure.GUI Namespace


ManagerForm Class

ManagerForm Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.ManagerForm]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ManagerForm : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.PluginInfrastructure.GUI..::.ManagerForm

See Also

ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ManagerForm Members

[image]

HeuristicLab API Documentation
ManagerForm Members
ManagerForm Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ManagerForm type exposes the following members.

Constructors

Name | Description
ManagerForm |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ManagerForm Class
HeuristicLab.PluginInfrastructure.GUI Namespace


ManagerForm Constructor

ManagerForm Constructor
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ManagerForm class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ManagerForm()

See Also

ManagerForm Class
HeuristicLab.PluginInfrastructure.GUI Namespace


ManagerForm Methods

[image]

HeuristicLab API Documentation
ManagerForm Methods
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ManagerForm type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

ManagerForm Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ManagerForm..::.AccessibilityNotifyClients Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ManagerForm..::.BeginInvoke Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Dispose Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method (Boolean)

ManagerForm..::.Dispose Method (Boolean)
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ManagerForm Class
Dispose Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ManagerForm..::.GetChildAtPoint Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Invalidate Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Invoke Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ManagerForm..::.MemberwiseClone Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ManagerForm..::.PerformLayout Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ManagerForm..::.ResumeLayout Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ManagerForm..::.RtlTranslateAlignment Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Scale Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Scale Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Select Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Select Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ManagerForm..::.SetBounds Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Show Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Show Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
ManagerForm..::.ShowDialog Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ManagerForm..::.UpdateBounds Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Validate Method

[image]

HeuristicLab API Documentation
ManagerForm..::.Validate Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ManagerForm..::.ValidateChildren Method
ManagerForm Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

ManagerForm Class
ManagerForm Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginAction Class

PluginAction Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.PluginAction]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class PluginAction

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure.GUI..::.PluginAction

See Also

PluginAction Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginAction Members

[image]

HeuristicLab API Documentation
PluginAction Members
PluginAction Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginAction type exposes the following members.

Constructors

Name | Description
PluginAction |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInverseActionString |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action |
Hull |
Plugin |

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginAction Constructor

PluginAction Constructor
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginAction class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginAction()

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginAction Methods

[image]

HeuristicLab API Documentation
PluginAction Methods
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginAction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInverseActionString |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


GetInverseActionString Method

PluginAction..::.GetInverseActionString Method
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginAction.GetInverseActionString]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string GetInverseActionString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginAction.GetInverseActionString]

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginAction Properties

[image]

HeuristicLab API Documentation
PluginAction Properties
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginAction type exposes the following members.

Properties

Name | Description
Action |
Hull |
Plugin |

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Action Property

PluginAction..::.Action Property
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginAction.Action]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ManagerAction Action { get; set; }

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Hull Property

PluginAction..::.Hull Property
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginAction.Hull]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<PluginTag> Hull { get; set; }

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Plugin Property

PluginAction..::.Plugin Property
PluginAction Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginAction.Plugin]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginTag Plugin { get; set; }

See Also

PluginAction Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginDescription Class

PluginDescription Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.PluginDescription]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class PluginDescription

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure.GUI..::.PluginDescription

See Also

PluginDescription Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginDescription Members

[image]

HeuristicLab API Documentation
PluginDescription Members
PluginDescription Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginDescription type exposes the following members.

Constructors

Name | Description
PluginDescription |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dependencies |
Name |
Source |
Version |

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginDescription Constructor

PluginDescription Constructor
PluginDescription Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginDescription class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginDescription(
    string name,
    Version version,
    PluginSource source
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

version
Type: System..::.Version

[Missing <param> documentation for "version"]

source
Type: HeuristicLab.PluginInfrastructure.GUI..::.PluginSource

[Missing <param> documentation for "source"]

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginDescription Properties

[image]

HeuristicLab API Documentation
PluginDescription Properties
PluginDescription Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginDescription type exposes the following members.

Properties

Name | Description
Dependencies |
Name |
Source |
Version |

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Dependencies Property

PluginDescription..::.Dependencies Property
PluginDescription Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginDescription.Dependencies]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<string> Dependencies { get; }

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Name Property

PluginDescription..::.Name Property
PluginDescription Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginDescription.Name]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; set; }

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Source Property

PluginDescription..::.Source Property
PluginDescription Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginDescription.Source]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginSource Source { get; }

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Version Property

PluginDescription..::.Version Property
PluginDescription Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginDescription.Version]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Version Version { get; set; }

See Also

PluginDescription Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginNameTransform Class

PluginNameTransform Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

This classes is needed to prune the directory tree of zipped plugin packages by removing the path leading to the plugin directory.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class PluginNameTransform : INameTransform

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure.GUI..::.PluginNameTransform

See Also

PluginNameTransform Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginNameTransform Members

[image]

HeuristicLab API Documentation
PluginNameTransform Members
PluginNameTransform Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginNameTransform type exposes the following members.

Constructors

Name | Description
PluginNameTransform |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformDirectory |
TransformFile |

See Also

PluginNameTransform Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginNameTransform Constructor

PluginNameTransform Constructor
PluginNameTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginNameTransform class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginNameTransform()

See Also

PluginNameTransform Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginNameTransform Methods

[image]

HeuristicLab API Documentation
PluginNameTransform Methods
PluginNameTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginNameTransform type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformDirectory |
TransformFile |

See Also

PluginNameTransform Class
HeuristicLab.PluginInfrastructure.GUI Namespace


TransformDirectory Method

PluginNameTransform..::.TransformDirectory Method
PluginNameTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginNameTransform.TransformDirectory(System.String)]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string TransformDirectory(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginNameTransform.TransformDirectory(System.String)]

Implements

INameTransformTransformDirectory(String)

See Also

PluginNameTransform Class
HeuristicLab.PluginInfrastructure.GUI Namespace


TransformFile Method

PluginNameTransform..::.TransformFile Method
PluginNameTransform Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginNameTransform.TransformFile(System.String)]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string TransformFile(
    string name
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginNameTransform.TransformFile(System.String)]

Implements

INameTransformTransformFile(String)

See Also

PluginNameTransform Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSource Class

PluginSource Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.PluginSource]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class PluginSource

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure.GUI..::.PluginSource

See Also

PluginSource Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSource Members

[image]

HeuristicLab API Documentation
PluginSource Members
PluginSource Class Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginSource type exposes the following members.

Methods

Name | Description
AvailablePlugins |
CancelAsyncDownload |
DownloadPlugin |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)
TryCreate | Factory method for new PluginRepositories

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSource Methods

[image]

HeuristicLab API Documentation
PluginSource Methods
PluginSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginSource type exposes the following members.

Methods

Name | Description
AvailablePlugins |
CancelAsyncDownload |
DownloadPlugin |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)
TryCreate | Factory method for new PluginRepositories

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AvailablePlugins Method

PluginSource..::.AvailablePlugins Method
PluginSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.AvailablePlugins]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<PluginDescription> AvailablePlugins()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.AvailablePlugins]

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


CancelAsyncDownload Method

PluginSource..::.CancelAsyncDownload Method
PluginSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.CancelAsyncDownload]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void CancelAsyncDownload()

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


DownloadPlugin Method

PluginSource..::.DownloadPlugin Method
PluginSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.DownloadPlugin(HeuristicLab.PluginInfrastructure.GUI.PluginDescription)]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal long DownloadPlugin(
    PluginDescription description
)

Parameters

description
Type: HeuristicLab.PluginInfrastructure.GUI..::.PluginDescription

[Missing <param> documentation for "description"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.DownloadPlugin(HeuristicLab.PluginInfrastructure.GUI.PluginDescription)]

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


ToString Method

PluginSource..::.ToString Method
PluginSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.ToString]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.ToString]

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


TryCreate Method

PluginSource..::.TryCreate Method
PluginSource Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Factory method for new PluginRepositories

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static PluginSource TryCreate(
    string url
)

Parameters

url
Type: System..::.String

[Missing <param> documentation for "url"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginSource.TryCreate(System.String)]

See Also

PluginSource Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSourceEditor Class

PluginSourceEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.PluginSourceEditor]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PluginSourceEditor : Form

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
HeuristicLab.PluginInfrastructure.GUI..::.PluginSourceEditor

See Also

PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSourceEditor Members

[image]

HeuristicLab API Documentation
PluginSourceEditor Members
PluginSourceEditor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginSourceEditor type exposes the following members.

Constructors

Name | Description
PluginSourceEditor |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

Properties

Name | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

PluginSourceEditor Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSourceEditor Constructor

PluginSourceEditor Constructor
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginSourceEditor class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginSourceEditor()

See Also

PluginSourceEditor Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginSourceEditor Methods

[image]

HeuristicLab API Documentation
PluginSourceEditor Methods
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginSourceEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
Activate | Activates the form and gives it focus. (Inherited from Form.)
ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
AdjustFormScrollbars | (Inherited from Form.)
ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Close | Closes the form. (Inherited from Form.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | (Inherited from Form.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates the handle for the Form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | (Inherited from Form.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | (Inherited from Form.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnActivated | Raises the Activated event. (Inherited from Form.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnClosed | Raises the Closed event. (Inherited from Form.)
OnClosing | Raises the Closing event. (Inherited from Form.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | (Inherited from Form.)
OnEnter | Raises the Enter event. (Inherited from Form.)
OnFontChanged | (Inherited from Form.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | (Inherited from Form.)
OnHandleDestroyed | (Inherited from Form.)
OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from Form.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from Form.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | (Inherited from Form.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from Form.)
OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnShown | Raises the Shown event. (Inherited from Form.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | (Inherited from Form.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | (Inherited from Form.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | Processes a command key. (Inherited from Form.)
ProcessDialogChar | (Inherited from Form.)
ProcessDialogKey | Processes a dialog key. (Inherited from Form.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | (Inherited from Form.)
ProcessMnemonic | (Inherited from Form.)
ProcessTabKey | (Inherited from Form.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from Form.)
ScaleCore | Base function that performs scaling of the form. (Inherited from Form.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | (Inherited from Form.)
SetClientSizeCore | Sets the clientSize of the form. This will adjust the bounds of the form to make the clientSize the requested size. (Inherited from Form.)
SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | (Inherited from Form.)
Show | Overloaded.
ShowDialog | Overloaded.
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | (Inherited from Form.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from Form.)

See Also

PluginSourceEditor Class
HeuristicLab.PluginInfrastructure.GUI Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.AccessibilityNotifyClients Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.BeginInvoke Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Dispose Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form ..::. Dispose(Boolean).)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Dispose Method (Boolean)

PluginSourceEditor..::.Dispose Method (Boolean)
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

PluginSourceEditor Class
Dispose Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.GetChildAtPoint Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Invalidate Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Invoke Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Invoke Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.MemberwiseClone Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.PerformLayout Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.ResumeLayout Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.RtlTranslateAlignment Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Scale Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Scale Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Select Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Select Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | Selects this form, and optionally selects the next/previous control. (Inherited from Form.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.SetBounds Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Show Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Show Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Show()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ShowDialog Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.ShowDialog Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ShowDialog()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog with the specified owner. (Inherited from Form.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.UpdateBounds Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


Validate Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.Validate Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
PluginSourceEditor..::.ValidateChildren Method
PluginSourceEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

PluginSourceEditor Class
PluginSourceEditor Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginState Enumeration

PluginState Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.PluginState]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[FlagsAttribute]
internal enum PluginState

Members

Member name | Description
Installed |
Available |
Upgradeable |
Disabled |

See Also

HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Class

PluginTag Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.PluginInfrastructure.GUI.PluginTag]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class PluginTag

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure.GUI..::.PluginTag

See Also

PluginTag Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Members

[image]

HeuristicLab API Documentation
PluginTag Members
PluginTag Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginTag type exposes the following members.

Constructors

Name | Description
PluginTag | Overloaded.

Methods

Name | Description
Equals | (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDependencyTags |
GetDependentTags |
GetHashCode | (Overrides Object ..::. GetHashCode()()().)
GetPluginDetails |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpgradeAvailable |

Fields

Name | Description
hull |

Properties

Name | Description
Plugin |
PluginDescription |
PluginName |
PluginVersion |
State |
UpgradePluginDescription |

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Constructor

[image]

HeuristicLab API Documentation
PluginTag Constructor
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PluginTag(List<(Of <(PluginTag>)>), PluginDescription, PluginState) |
PluginTag(List<(Of <(PluginTag>)>), PluginInfo, PluginState) |

See Also

PluginTag Class
PluginTag Members
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Constructor (List(PluginTag), PluginDescription, PluginState)

PluginTag Constructor (List<(Of <(PluginTag>)>), PluginDescription, PluginState)
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginTag class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginTag(
    List<PluginTag> allTags,
    PluginDescription plugin,
    PluginState state
)

Parameters

allTags
Type: System.Collections.Generic..::.List <(Of <( PluginTag >)>)

[Missing <param> documentation for "allTags"]

plugin
Type: HeuristicLab.PluginInfrastructure.GUI..::.PluginDescription

[Missing <param> documentation for "plugin"]

state
Type: HeuristicLab.PluginInfrastructure.GUI..::.PluginState

[Missing <param> documentation for "state"]

See Also

PluginTag Class
PluginTag Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Constructor (List(PluginTag), PluginInfo, PluginState)

PluginTag Constructor (List<(Of <(PluginTag>)>), PluginInfo, PluginState)
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PluginTag class.

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginTag(
    List<PluginTag> allTags,
    PluginInfo plugin,
    PluginState state
)

Parameters

allTags
Type: System.Collections.Generic..::.List <(Of <( PluginTag >)>)

[Missing <param> documentation for "allTags"]

plugin
Type: HeuristicLab.PluginInfrastructure..::.PluginInfo

[Missing <param> documentation for "plugin"]

state
Type: HeuristicLab.PluginInfrastructure.GUI..::.PluginState

[Missing <param> documentation for "state"]

See Also

PluginTag Class
PluginTag Overload
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Fields

[image]

HeuristicLab API Documentation
PluginTag Fields
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginTag type exposes the following members.

Fields

Name | Description
hull |

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


hull Field

PluginTag..::.hull Field
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.PluginInfrastructure.GUI.PluginTag.hull]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public List<PluginTag> hull

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Methods

[image]

HeuristicLab API Documentation
PluginTag Methods
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginTag type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object ..::. Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDependencyTags |
GetDependentTags |
GetHashCode | (Overrides Object ..::. GetHashCode()()().)
GetPluginDetails |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpgradeAvailable |

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Equals Method

PluginTag..::.Equals Method
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.Equals(System.Object)]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.Equals(System.Object)]

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


GetDependencyTags Method

PluginTag..::.GetDependencyTags Method
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetDependencyTags]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal List<PluginTag> GetDependencyTags()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetDependencyTags]

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


GetDependentTags Method

PluginTag..::.GetDependentTags Method
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetDependentTags]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal List<PluginTag> GetDependentTags()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetDependentTags]

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


GetHashCode Method

PluginTag..::.GetHashCode Method
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetHashCode]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override int GetHashCode()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetHashCode]

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


GetPluginDetails Method

PluginTag..::.GetPluginDetails Method
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetPluginDetails]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal string GetPluginDetails()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.GetPluginDetails]

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


UpgradeAvailable Method

PluginTag..::.UpgradeAvailable Method
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.UpgradeAvailable]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal bool UpgradeAvailable()

Return Value

[Missing <returns> documentation for M:HeuristicLab.PluginInfrastructure.GUI.PluginTag.UpgradeAvailable]

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginTag Properties

[image]

HeuristicLab API Documentation
PluginTag Properties
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PluginTag type exposes the following members.

Properties

Name | Description
Plugin |
PluginDescription |
PluginName |
PluginVersion |
State |
UpgradePluginDescription |

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


Plugin Property

PluginTag..::.Plugin Property
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginTag.Plugin]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginInfo Plugin { get; }

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginDescription Property

PluginTag..::.PluginDescription Property
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginTag.PluginDescription]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal PluginDescription PluginDescription { get; set; }

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginName Property

PluginTag..::.PluginName Property
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginTag.PluginName]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string PluginName { get; set; }

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


PluginVersion Property

PluginTag..::.PluginVersion Property
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginTag.PluginVersion]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Version PluginVersion { get; set; }

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


State Property

PluginTag..::.State Property
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginTag.State]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginState State { get; set; }

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


UpgradePluginDescription Property

PluginTag..::.UpgradePluginDescription Property
PluginTag Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.PluginInfrastructure.GUI.PluginTag.UpgradePluginDescription]

Namespace: HeuristicLab.PluginInfrastructure.GUI
Assembly: HeuristicLab.PluginInfrastructure.GUI (in HeuristicLab.PluginInfrastructure.GUI.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PluginDescription UpgradePluginDescription { get; set; }

See Also

PluginTag Class
HeuristicLab.PluginInfrastructure.GUI Namespace


HeuristicLab.Random Namespace

HeuristicLab.Random Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

HeuristicLab.Random Namespace Summary (... to be continued ...)

Classes

Class | Description
HeuristicLabRandomPlugin |
MersenneTwister |
NormalDistributedRandom | Normally distributed random variable. Uses the Ziggurat transform to efficiently generate normal distributed random numbers. See "The Ziggurat Method for Generating Random Variables" (G. Marsaglia and W.W. Tsang 2000).
NormalRandomAdder |
NormalRandomizer |
RandomInjector |
UniformRandomAdder |
UniformRandomizer |


HeuristicLabRandomPlugin Class

HeuristicLabRandomPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.HeuristicLabRandomPlugin]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "HeuristicLab.Random")]
[PluginFileAttribute(Filename = "HeuristicLab.Random.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
public class HeuristicLabRandomPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Random..::.HeuristicLabRandomPlugin

See Also

HeuristicLabRandomPlugin Members
HeuristicLab.Random Namespace


HeuristicLabRandomPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabRandomPlugin Members
HeuristicLabRandomPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabRandomPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabRandomPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabRandomPlugin Class
HeuristicLab.Random Namespace


HeuristicLabRandomPlugin Constructor

HeuristicLabRandomPlugin Constructor
HeuristicLabRandomPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabRandomPlugin class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabRandomPlugin()

See Also

HeuristicLabRandomPlugin Class
HeuristicLab.Random Namespace


MersenneTwister Class

MersenneTwister Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.MersenneTwister]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MersenneTwister : ItemBase, IRandom,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Random..::.MersenneTwister

See Also

MersenneTwister Members
HeuristicLab.Random Namespace


MersenneTwister Members

[image]

HeuristicLab API Documentation
MersenneTwister Members
MersenneTwister Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MersenneTwister type exposes the following members.

Constructors

Name | Description
MersenneTwister | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Next | Overloaded.
NextDouble |
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
Reset | Overloaded.
seed | Overloaded.
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

MersenneTwister Class
HeuristicLab.Random Namespace


MersenneTwister Constructor

[image]

HeuristicLab API Documentation
MersenneTwister Constructor
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MersenneTwister()()() |
MersenneTwister(UInt32) |
MersenneTwister(array<UInt32>[]()[]) |

See Also

MersenneTwister Class
MersenneTwister Members
HeuristicLab.Random Namespace


MersenneTwister Constructor

MersenneTwister Constructor
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MersenneTwister class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MersenneTwister()

See Also

MersenneTwister Class
MersenneTwister Overload
HeuristicLab.Random Namespace


MersenneTwister Constructor (UInt32)

MersenneTwister Constructor (UInt32)
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MersenneTwister class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MersenneTwister(
    uint s
)

Parameters

s
Type: System..::.UInt32

[Missing <param> documentation for "s"]

See Also

MersenneTwister Class
MersenneTwister Overload
HeuristicLab.Random Namespace


MersenneTwister Constructor (UInt32[])

MersenneTwister Constructor (array<UInt32>[]()[])
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MersenneTwister class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MersenneTwister(
    uint[] array
)

Parameters

array
Type: array< System..::.UInt32 >[]()[]

[Missing <param> documentation for "array"]

See Also

MersenneTwister Class
MersenneTwister Overload
HeuristicLab.Random Namespace


MersenneTwister Methods

[image]

HeuristicLab API Documentation
MersenneTwister Methods
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MersenneTwister type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Next | Overloaded.
NextDouble |
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
Reset | Overloaded.
seed | Overloaded.
ToString | (Inherited from ItemBase.)

See Also

MersenneTwister Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
MersenneTwister..::.Clone Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

MersenneTwister Class
MersenneTwister Members
HeuristicLab.Random Namespace


Clone Method (IDictionary(Guid, Object))

MersenneTwister..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.MersenneTwister.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

MersenneTwister Class
Clone Overload
HeuristicLab.Random Namespace


GetXmlNode Method

MersenneTwister..::.GetXmlNode Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.MersenneTwister.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

MersenneTwister Class
HeuristicLab.Random Namespace


Next Method

[image]

HeuristicLab API Documentation
MersenneTwister..::.Next Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Next()()() |
Next(Int32) |
Next(Int32, Int32) |

See Also

MersenneTwister Class
MersenneTwister Members
HeuristicLab.Random Namespace


Next Method

MersenneTwister..::.Next Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Next]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Next()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.MersenneTwister.Next]

Implements

IRandom..::.Next()()()

See Also

MersenneTwister Class
Next Overload
HeuristicLab.Random Namespace


Next Method (Int32)

MersenneTwister..::.Next Method (Int32)
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Next(System.Int32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Next(
    int maxVal
)

Parameters

maxVal
Type: System..::.Int32

[Missing <param> documentation for "maxVal"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.MersenneTwister.Next(System.Int32)]

Implements

IRandom..::.Next(Int32)

See Also

MersenneTwister Class
Next Overload
HeuristicLab.Random Namespace


Next Method (Int32, Int32)

MersenneTwister..::.Next Method (Int32, Int32)
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Next(System.Int32,System.Int32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Next(
    int minVal,
    int maxVal
)

Parameters

minVal
Type: System..::.Int32

[Missing <param> documentation for "minVal"]

maxVal
Type: System..::.Int32

[Missing <param> documentation for "maxVal"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.MersenneTwister.Next(System.Int32,System.Int32)]

Implements

IRandom..::.Next(Int32, Int32)

See Also

MersenneTwister Class
Next Overload
HeuristicLab.Random Namespace


NextDouble Method

MersenneTwister..::.NextDouble Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.NextDouble]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double NextDouble()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.MersenneTwister.NextDouble]

Implements

IRandom..::.NextDouble()()()

See Also

MersenneTwister Class
HeuristicLab.Random Namespace


Populate Method

MersenneTwister..::.Populate Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

MersenneTwister Class
HeuristicLab.Random Namespace


Reset Method

[image]

HeuristicLab API Documentation
MersenneTwister..::.Reset Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reset()()() |
Reset(Int32) |

See Also

MersenneTwister Class
MersenneTwister Members
HeuristicLab.Random Namespace


Reset Method

MersenneTwister..::.Reset Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Reset]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset()

Implements

IRandom..::.Reset()()()

See Also

MersenneTwister Class
Reset Overload
HeuristicLab.Random Namespace


Reset Method (Int32)

MersenneTwister..::.Reset Method (Int32)
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.Reset(System.Int32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset(
    int s
)

Parameters

s
Type: System..::.Int32

[Missing <param> documentation for "s"]

Implements

IRandom..::.Reset(Int32)

See Also

MersenneTwister Class
Reset Overload
HeuristicLab.Random Namespace


seed Method

[image]

HeuristicLab API Documentation
MersenneTwister..::.seed Method
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
seed(UInt32) |
seed(array<UInt32>[]()[]) |

See Also

MersenneTwister Class
MersenneTwister Members
HeuristicLab.Random Namespace


seed Method (UInt32)

MersenneTwister..::.seed Method (UInt32)
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.seed(System.UInt32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void seed(
    uint s
)

Parameters

s
Type: System..::.UInt32

[Missing <param> documentation for "s"]

See Also

MersenneTwister Class
seed Overload
HeuristicLab.Random Namespace


seed Method (UInt32[])

MersenneTwister..::.seed Method (array<UInt32>[]()[])
MersenneTwister Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.MersenneTwister.seed(System.UInt32[])]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void seed(
    uint[] array
)

Parameters

array
Type: array< System..::.UInt32 >[]()[]

[Missing <param> documentation for "array"]

See Also

MersenneTwister Class
seed Overload
HeuristicLab.Random Namespace


NormalDistributedRandom Class

NormalDistributedRandom Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Normally distributed random variable. Uses the Ziggurat transform to efficiently generate normal distributed random numbers. See "The Ziggurat Method for Generating Random Variables" (G. Marsaglia and W.W. Tsang 2000).

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NormalDistributedRandom : ItemBase, IRandom,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Random..::.NormalDistributedRandom

See Also

NormalDistributedRandom Members
HeuristicLab.Random Namespace


NormalDistributedRandom Members

[image]

HeuristicLab API Documentation
NormalDistributedRandom Members
NormalDistributedRandom Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalDistributedRandom type exposes the following members.

Constructors

Name | Description
NormalDistributedRandom | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Next | Overloaded.
NextDouble |
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
Reset | Overloaded.
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Mu |
Sigma |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


NormalDistributedRandom Constructor

[image]

HeuristicLab API Documentation
NormalDistributedRandom Constructor
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
NormalDistributedRandom()()() |
NormalDistributedRandom(IRandom, Double, Double) |

See Also

NormalDistributedRandom Class
NormalDistributedRandom Members
HeuristicLab.Random Namespace


NormalDistributedRandom Constructor

NormalDistributedRandom Constructor
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NormalDistributedRandom class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NormalDistributedRandom()

See Also

NormalDistributedRandom Class
NormalDistributedRandom Overload
HeuristicLab.Random Namespace


NormalDistributedRandom Constructor (IRandom, Double, Double)

NormalDistributedRandom Constructor (IRandom, Double, Double)
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NormalDistributedRandom class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NormalDistributedRandom(
    IRandom uniformRandom,
    double mu,
    double sigma
)

Parameters

uniformRandom
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "uniformRandom"]

mu
Type: System..::.Double

[Missing <param> documentation for "mu"]

sigma
Type: System..::.Double

[Missing <param> documentation for "sigma"]

See Also

NormalDistributedRandom Class
NormalDistributedRandom Overload
HeuristicLab.Random Namespace


NormalDistributedRandom Methods

[image]

HeuristicLab API Documentation
NormalDistributedRandom Methods
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalDistributedRandom type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Next | Overloaded.
NextDouble |
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
Reset | Overloaded.
ToString | (Inherited from ItemBase.)

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
NormalDistributedRandom..::.Clone Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

NormalDistributedRandom Class
NormalDistributedRandom Members
HeuristicLab.Random Namespace


Clone Method (IDictionary(Guid, Object))

NormalDistributedRandom..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

NormalDistributedRandom Class
Clone Overload
HeuristicLab.Random Namespace


GetXmlNode Method

NormalDistributedRandom..::.GetXmlNode Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalDistributedRandom.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


Next Method

[image]

HeuristicLab API Documentation
NormalDistributedRandom..::.Next Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Next()()() |
Next(Int32) |
Next(Int32, Int32) |

See Also

NormalDistributedRandom Class
NormalDistributedRandom Members
HeuristicLab.Random Namespace


Next Method

NormalDistributedRandom..::.Next Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Next]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Next()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Next]

Implements

IRandom..::.Next()()()

See Also

NormalDistributedRandom Class
Next Overload
HeuristicLab.Random Namespace


Next Method (Int32)

NormalDistributedRandom..::.Next Method (Int32)
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Next(System.Int32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Next(
    int maxVal
)

Parameters

maxVal
Type: System..::.Int32

[Missing <param> documentation for "maxVal"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Next(System.Int32)]

Implements

IRandom..::.Next(Int32)

See Also

NormalDistributedRandom Class
Next Overload
HeuristicLab.Random Namespace


Next Method (Int32, Int32)

NormalDistributedRandom..::.Next Method (Int32, Int32)
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Next(System.Int32,System.Int32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Next(
    int minVal,
    int maxVal
)

Parameters

minVal
Type: System..::.Int32

[Missing <param> documentation for "minVal"]

maxVal
Type: System..::.Int32

[Missing <param> documentation for "maxVal"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Next(System.Int32,System.Int32)]

Implements

IRandom..::.Next(Int32, Int32)

See Also

NormalDistributedRandom Class
Next Overload
HeuristicLab.Random Namespace


NextDouble Method

NormalDistributedRandom..::.NextDouble Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.NextDouble]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double NextDouble()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalDistributedRandom.NextDouble]

Implements

IRandom..::.NextDouble()()()

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


Populate Method

NormalDistributedRandom..::.Populate Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


Reset Method

[image]

HeuristicLab API Documentation
NormalDistributedRandom..::.Reset Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reset()()() |
Reset(Int32) |

See Also

NormalDistributedRandom Class
NormalDistributedRandom Members
HeuristicLab.Random Namespace


Reset Method

NormalDistributedRandom..::.Reset Method
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Reset]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset()

Implements

IRandom..::.Reset()()()

See Also

NormalDistributedRandom Class
Reset Overload
HeuristicLab.Random Namespace


Reset Method (Int32)

NormalDistributedRandom..::.Reset Method (Int32)
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalDistributedRandom.Reset(System.Int32)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset(
    int seed
)

Parameters

seed
Type: System..::.Int32

[Missing <param> documentation for "seed"]

Implements

IRandom..::.Reset(Int32)

See Also

NormalDistributedRandom Class
Reset Overload
HeuristicLab.Random Namespace


NormalDistributedRandom Properties

[image]

HeuristicLab API Documentation
NormalDistributedRandom Properties
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalDistributedRandom type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Mu |
Sigma |

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


Mu Property

NormalDistributedRandom..::.Mu Property
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.NormalDistributedRandom.Mu]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Mu { get; set; }

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


Sigma Property

NormalDistributedRandom..::.Sigma Property
NormalDistributedRandom Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.NormalDistributedRandom.Sigma]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double Sigma { get; set; }

See Also

NormalDistributedRandom Class
HeuristicLab.Random Namespace


NormalRandomAdder Class

NormalRandomAdder Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.NormalRandomAdder]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NormalRandomAdder : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Random..::.NormalRandomAdder

See Also

NormalRandomAdder Members
HeuristicLab.Random Namespace


NormalRandomAdder Members

[image]

HeuristicLab API Documentation
NormalRandomAdder Members
NormalRandomAdder Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalRandomAdder type exposes the following members.

Constructors

Name | Description
NormalRandomAdder |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
HeuristicLab.Random Namespace


NormalRandomAdder Constructor

NormalRandomAdder Constructor
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NormalRandomAdder class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NormalRandomAdder()

See Also

NormalRandomAdder Class
HeuristicLab.Random Namespace


NormalRandomAdder Methods

[image]

HeuristicLab API Documentation
NormalRandomAdder Methods
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalRandomAdder type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

NormalRandomAdder Class
HeuristicLab.Random Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.AddSubOperator Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


Apply Method

NormalRandomAdder..::.Apply Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomAdder.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalRandomAdder.Apply(HeuristicLab.Core.IScope)]

See Also

NormalRandomAdder Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.Clone Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.GetVariableValue Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


IsValid Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.IsValid Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.TryAddSubOperator Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.TryAddVariable Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.TryAddVariableInfo Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.TryRemoveSubOperator Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.TryRemoveVariable Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
NormalRandomAdder..::.TryRemoveVariableInfo Method
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
NormalRandomAdder Members
HeuristicLab.Random Namespace


NormalRandomAdder Properties

[image]

HeuristicLab API Documentation
NormalRandomAdder Properties
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalRandomAdder type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

NormalRandomAdder Class
HeuristicLab.Random Namespace


Description Property

NormalRandomAdder..::.Description Property
NormalRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.NormalRandomAdder.Description]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

NormalRandomAdder Class
HeuristicLab.Random Namespace


NormalRandomizer Class

NormalRandomizer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.NormalRandomizer]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class NormalRandomizer : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Random..::.NormalRandomizer

See Also

NormalRandomizer Members
HeuristicLab.Random Namespace


NormalRandomizer Members

[image]

HeuristicLab API Documentation
NormalRandomizer Members
NormalRandomizer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalRandomizer type exposes the following members.

Constructors

Name | Description
NormalRandomizer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
HeuristicLab.Random Namespace


NormalRandomizer Constructor

NormalRandomizer Constructor
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NormalRandomizer class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public NormalRandomizer()

See Also

NormalRandomizer Class
HeuristicLab.Random Namespace


NormalRandomizer Methods

[image]

HeuristicLab API Documentation
NormalRandomizer Methods
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalRandomizer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

NormalRandomizer Class
HeuristicLab.Random Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.AddSubOperator Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


Apply Method

NormalRandomizer..::.Apply Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomizer.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.NormalRandomizer.Apply(HeuristicLab.Core.IScope)]

See Also

NormalRandomizer Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.Clone Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.GetVariableValue Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


IsValid Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.IsValid Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.TryAddSubOperator Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.TryAddVariable Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.TryAddVariableInfo Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.TryRemoveSubOperator Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.TryRemoveVariable Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
NormalRandomizer..::.TryRemoveVariableInfo Method
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
NormalRandomizer Members
HeuristicLab.Random Namespace


NormalRandomizer Properties

[image]

HeuristicLab API Documentation
NormalRandomizer Properties
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NormalRandomizer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

NormalRandomizer Class
HeuristicLab.Random Namespace


Description Property

NormalRandomizer..::.Description Property
NormalRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.NormalRandomizer.Description]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

NormalRandomizer Class
HeuristicLab.Random Namespace


RandomInjector Class

RandomInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.RandomInjector]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RandomInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Random..::.RandomInjector

See Also

RandomInjector Members
HeuristicLab.Random Namespace


RandomInjector Members

[image]

HeuristicLab API Documentation
RandomInjector Members
RandomInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomInjector type exposes the following members.

Constructors

Name | Description
RandomInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RandomInjector Class
HeuristicLab.Random Namespace


RandomInjector Constructor

RandomInjector Constructor
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomInjector class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RandomInjector()

See Also

RandomInjector Class
HeuristicLab.Random Namespace


RandomInjector Methods

[image]

HeuristicLab API Documentation
RandomInjector Methods
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RandomInjector Class
HeuristicLab.Random Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RandomInjector..::.AddSubOperator Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


Apply Method

RandomInjector..::.Apply Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.RandomInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.RandomInjector.Apply(HeuristicLab.Core.IScope)]

See Also

RandomInjector Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
RandomInjector..::.Clone Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RandomInjector..::.GetVariableValue Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RandomInjector..::.IsValid Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RandomInjector..::.TryAddSubOperator Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RandomInjector..::.TryAddVariable Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RandomInjector..::.TryAddVariableInfo Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RandomInjector..::.TryRemoveSubOperator Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RandomInjector..::.TryRemoveVariable Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RandomInjector..::.TryRemoveVariableInfo Method
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomInjector Class
RandomInjector Members
HeuristicLab.Random Namespace


RandomInjector Properties

[image]

HeuristicLab API Documentation
RandomInjector Properties
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RandomInjector Class
HeuristicLab.Random Namespace


Description Property

RandomInjector..::.Description Property
RandomInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.RandomInjector.Description]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RandomInjector Class
HeuristicLab.Random Namespace


UniformRandomAdder Class

UniformRandomAdder Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.UniformRandomAdder]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UniformRandomAdder : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Random..::.UniformRandomAdder

See Also

UniformRandomAdder Members
HeuristicLab.Random Namespace


UniformRandomAdder Members

[image]

HeuristicLab API Documentation
UniformRandomAdder Members
UniformRandomAdder Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomAdder type exposes the following members.

Constructors

Name | Description
UniformRandomAdder |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
HeuristicLab.Random Namespace


UniformRandomAdder Constructor

UniformRandomAdder Constructor
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniformRandomAdder class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UniformRandomAdder()

See Also

UniformRandomAdder Class
HeuristicLab.Random Namespace


UniformRandomAdder Methods

[image]

HeuristicLab API Documentation
UniformRandomAdder Methods
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomAdder type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UniformRandomAdder Class
HeuristicLab.Random Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.AddSubOperator Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


Apply Method

UniformRandomAdder..::.Apply Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomAdder.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.UniformRandomAdder.Apply(HeuristicLab.Core.IScope)]

See Also

UniformRandomAdder Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.Clone Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.GetVariableValue Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.IsValid Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.TryAddSubOperator Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.TryAddVariable Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.TryAddVariableInfo Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.TryRemoveSubOperator Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.TryRemoveVariable Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UniformRandomAdder..::.TryRemoveVariableInfo Method
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
UniformRandomAdder Members
HeuristicLab.Random Namespace


UniformRandomAdder Properties

[image]

HeuristicLab API Documentation
UniformRandomAdder Properties
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomAdder type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UniformRandomAdder Class
HeuristicLab.Random Namespace


Description Property

UniformRandomAdder..::.Description Property
UniformRandomAdder Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.UniformRandomAdder.Description]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UniformRandomAdder Class
HeuristicLab.Random Namespace


UniformRandomizer Class

UniformRandomizer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Random.UniformRandomizer]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UniformRandomizer : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Random..::.UniformRandomizer

See Also

UniformRandomizer Members
HeuristicLab.Random Namespace


UniformRandomizer Members

[image]

HeuristicLab API Documentation
UniformRandomizer Members
UniformRandomizer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomizer type exposes the following members.

Constructors

Name | Description
UniformRandomizer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
HeuristicLab.Random Namespace


UniformRandomizer Constructor

UniformRandomizer Constructor
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniformRandomizer class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UniformRandomizer()

See Also

UniformRandomizer Class
HeuristicLab.Random Namespace


UniformRandomizer Methods

[image]

HeuristicLab API Documentation
UniformRandomizer Methods
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomizer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UniformRandomizer Class
HeuristicLab.Random Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.AddSubOperator Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


Apply Method

UniformRandomizer..::.Apply Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomizer.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Random.UniformRandomizer.Apply(HeuristicLab.Core.IScope)]

See Also

UniformRandomizer Class
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.Clone Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.GetVariableValue Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.IsValid Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.TryAddSubOperator Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.TryAddVariable Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.TryAddVariableInfo Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.TryRemoveSubOperator Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.TryRemoveVariable Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UniformRandomizer..::.TryRemoveVariableInfo Method
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
UniformRandomizer Members
HeuristicLab.Random Namespace


UniformRandomizer Properties

[image]

HeuristicLab API Documentation
UniformRandomizer Properties
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomizer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UniformRandomizer Class
HeuristicLab.Random Namespace


Description Property

UniformRandomizer..::.Description Property
UniformRandomizer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Random.UniformRandomizer.Description]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UniformRandomizer Class
HeuristicLab.Random Namespace


HeuristicLab.RealVector Namespace

HeuristicLab.RealVector Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.RealVector]

Classes

Class | Description
HeuristicLabRealVectorPlugin |
RealVectorCrossoverBase |
RealVectorManipulatorBase |
SinglePointCrossover |
UniformOnePositionManipulator |
UniformRandomRealVectorGenerator |


HeuristicLabRealVectorPlugin Class

HeuristicLabRealVectorPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.RealVector.HeuristicLabRealVectorPlugin]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Evolutionary")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.RealVector")]
[PluginFileAttribute(Filename = "HeuristicLab.RealVector.dll", Filetype = PluginFileType.Assembly)]
public class HeuristicLabRealVectorPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.RealVector..::.HeuristicLabRealVectorPlugin

See Also

HeuristicLabRealVectorPlugin Members
HeuristicLab.RealVector Namespace


HeuristicLabRealVectorPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabRealVectorPlugin Members
HeuristicLabRealVectorPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabRealVectorPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabRealVectorPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabRealVectorPlugin Class
HeuristicLab.RealVector Namespace


HeuristicLabRealVectorPlugin Constructor

HeuristicLabRealVectorPlugin Constructor
HeuristicLabRealVectorPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabRealVectorPlugin class.

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabRealVectorPlugin()

See Also

HeuristicLabRealVectorPlugin Class
HeuristicLab.RealVector Namespace


RealVectorCrossoverBase Class

RealVectorCrossoverBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.RealVector.RealVectorCrossoverBase]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class RealVectorCrossoverBase : CrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.RealVector..::.RealVectorCrossoverBase
HeuristicLab.RealVector..::.SinglePointCrossover

See Also

RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


RealVectorCrossoverBase Members

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase Members
RealVectorCrossoverBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RealVectorCrossoverBase type exposes the following members.

Constructors

Name | Description
RealVectorCrossoverBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from CrossoverBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
HeuristicLab.RealVector Namespace


RealVectorCrossoverBase Constructor

RealVectorCrossoverBase Constructor
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RealVectorCrossoverBase class.

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RealVectorCrossoverBase()

See Also

RealVectorCrossoverBase Class
HeuristicLab.RealVector Namespace


RealVectorCrossoverBase Methods

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase Methods
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RealVectorCrossoverBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from CrossoverBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RealVectorCrossoverBase Class
HeuristicLab.RealVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.AddSubOperator Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.Clone Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


Cross Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.Cross Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Double>[]()[], array<Double>[]()[]) |
Cross(IScope, IRandom, IScope, IScope, IScope) | (Overrides CrossoverBase ..::. Cross(IScope, IRandom, IScope, IScope, IScope).)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


Cross Method (IScope, IRandom, Double[], Double[])

RealVectorCrossoverBase..::.Cross Method (IScope, IRandom, array<Double>[]()[], array<Double>[]()[])
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.RealVectorCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[],System.Double[])]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract double[] Cross(
    IScope scope,
    IRandom random,
    double[] parent1,
    double[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.RealVectorCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[],System.Double[])]

See Also

RealVectorCrossoverBase Class
Cross Overload
HeuristicLab.RealVector Namespace


Cross Method (IScope, IRandom, IScope, IScope, IScope)

RealVectorCrossoverBase..::.Cross Method (IScope, IRandom, IScope, IScope, IScope)
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.RealVectorCrossoverBase.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override sealed void Cross(
    IScope scope,
    IRandom random,
    IScope parent1,
    IScope parent2,
    IScope child
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent1"]

parent2
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "parent2"]

child
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "child"]

See Also

RealVectorCrossoverBase Class
Cross Overload
HeuristicLab.RealVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.GetVariableValue Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.IsValid Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.TryAddSubOperator Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.TryAddVariable Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.TryAddVariableInfo Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.TryRemoveSubOperator Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.TryRemoveVariable Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RealVectorCrossoverBase..::.TryRemoveVariableInfo Method
RealVectorCrossoverBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorCrossoverBase Class
RealVectorCrossoverBase Members
HeuristicLab.RealVector Namespace


RealVectorManipulatorBase Class

RealVectorManipulatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.RealVector.RealVectorManipulatorBase]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class RealVectorManipulatorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.RealVector..::.RealVectorManipulatorBase
HeuristicLab.RealVector..::.UniformOnePositionManipulator

See Also

RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


RealVectorManipulatorBase Members

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase Members
RealVectorManipulatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RealVectorManipulatorBase type exposes the following members.

Constructors

Name | Description
RealVectorManipulatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
HeuristicLab.RealVector Namespace


RealVectorManipulatorBase Constructor

RealVectorManipulatorBase Constructor
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RealVectorManipulatorBase class.

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RealVectorManipulatorBase()

See Also

RealVectorManipulatorBase Class
HeuristicLab.RealVector Namespace


RealVectorManipulatorBase Methods

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase Methods
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RealVectorManipulatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RealVectorManipulatorBase Class
HeuristicLab.RealVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.AddSubOperator Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


Apply Method

RealVectorManipulatorBase..::.Apply Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.RealVectorManipulatorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.RealVectorManipulatorBase.Apply(HeuristicLab.Core.IScope)]

See Also

RealVectorManipulatorBase Class
HeuristicLab.RealVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.Clone Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.GetVariableValue Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.IsValid Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


Manipulate Method

RealVectorManipulatorBase..::.Manipulate Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.RealVectorManipulatorBase.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[])]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract double[] Manipulate(
    IScope scope,
    IRandom random,
    double[] vector
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

vector
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "vector"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.RealVectorManipulatorBase.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[])]

See Also

RealVectorManipulatorBase Class
HeuristicLab.RealVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.TryAddSubOperator Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.TryAddVariable Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.TryAddVariableInfo Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.TryRemoveSubOperator Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.TryRemoveVariable Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RealVectorManipulatorBase..::.TryRemoveVariableInfo Method
RealVectorManipulatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RealVectorManipulatorBase Class
RealVectorManipulatorBase Members
HeuristicLab.RealVector Namespace


SinglePointCrossover Class

SinglePointCrossover Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.RealVector.SinglePointCrossover]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SinglePointCrossover : RealVectorCrossoverBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Evolutionary..::.CrossoverBase
HeuristicLab.RealVector..::.RealVectorCrossoverBase
HeuristicLab.RealVector..::.SinglePointCrossover

See Also

SinglePointCrossover Members
HeuristicLab.RealVector Namespace


SinglePointCrossover Members

[image]

HeuristicLab API Documentation
SinglePointCrossover Members
SinglePointCrossover Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossover type exposes the following members.

Constructors

Name | Description
SinglePointCrossover |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
HeuristicLab.RealVector Namespace


SinglePointCrossover Constructor

SinglePointCrossover Constructor
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SinglePointCrossover class.

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SinglePointCrossover()

See Also

SinglePointCrossover Class
HeuristicLab.RealVector Namespace


SinglePointCrossover Methods

[image]

HeuristicLab API Documentation
SinglePointCrossover Methods
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossover type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Cross | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SinglePointCrossover Class
HeuristicLab.RealVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.AddSubOperator Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


Apply Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.Apply Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from CrossoverBase.)
Apply(IRandom, array<Double>[]()[], array<Double>[]()[]) |

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


Apply Method (IRandom, Double[], Double[])

SinglePointCrossover..::.Apply Method (IRandom, array<Double>[]()[], array<Double>[]()[])
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.SinglePointCrossover.Apply(HeuristicLab.Core.IRandom,System.Double[],System.Double[])]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double[] Apply(
    IRandom random,
    double[] parent1,
    double[] parent2
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.SinglePointCrossover.Apply(HeuristicLab.Core.IRandom,System.Double[],System.Double[])]

See Also

SinglePointCrossover Class
Apply Overload
HeuristicLab.RealVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.Clone Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


Cross Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.Cross Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Cross(IScope, IRandom, array<Double>[]()[], array<Double>[]()[]) | (Overrides RealVectorCrossoverBase ..::. Cross(IScope, IRandom, array<Double>[]()[], array<Double>[]()[]).)
Cross(IScope, IRandom, IScope, IScope, IScope) | (Inherited from RealVectorCrossoverBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


Cross Method (IScope, IRandom, Double[], Double[])

SinglePointCrossover..::.Cross Method (IScope, IRandom, array<Double>[]()[], array<Double>[]()[])
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.SinglePointCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[],System.Double[])]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double[] Cross(
    IScope scope,
    IRandom random,
    double[] parent1,
    double[] parent2
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

parent1
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "parent1"]

parent2
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "parent2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.SinglePointCrossover.Cross(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[],System.Double[])]

See Also

SinglePointCrossover Class
Cross Overload
HeuristicLab.RealVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.GetVariableValue Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.IsValid Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryAddSubOperator Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryAddVariable Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryAddVariableInfo Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryRemoveSubOperator Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryRemoveVariable Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SinglePointCrossover..::.TryRemoveVariableInfo Method
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
SinglePointCrossover Members
HeuristicLab.RealVector Namespace


SinglePointCrossover Properties

[image]

HeuristicLab API Documentation
SinglePointCrossover Properties
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossover type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SinglePointCrossover Class
HeuristicLab.RealVector Namespace


Description Property

SinglePointCrossover..::.Description Property
SinglePointCrossover Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.RealVector.SinglePointCrossover.Description]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SinglePointCrossover Class
HeuristicLab.RealVector Namespace


UniformOnePositionManipulator Class

UniformOnePositionManipulator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.RealVector.UniformOnePositionManipulator]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UniformOnePositionManipulator : RealVectorManipulatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.RealVector..::.RealVectorManipulatorBase
HeuristicLab.RealVector..::.UniformOnePositionManipulator

See Also

UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


UniformOnePositionManipulator Members

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator Members
UniformOnePositionManipulator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformOnePositionManipulator type exposes the following members.

Constructors

Name | Description
UniformOnePositionManipulator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides RealVectorManipulatorBase ..::. Manipulate(IScope, IRandom, array<Double>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
HeuristicLab.RealVector Namespace


UniformOnePositionManipulator Constructor

UniformOnePositionManipulator Constructor
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniformOnePositionManipulator class.

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UniformOnePositionManipulator()

See Also

UniformOnePositionManipulator Class
HeuristicLab.RealVector Namespace


UniformOnePositionManipulator Methods

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator Methods
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformOnePositionManipulator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
Manipulate | (Overrides RealVectorManipulatorBase ..::. Manipulate(IScope, IRandom, array<Double>[]()[]).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UniformOnePositionManipulator Class
HeuristicLab.RealVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.AddSubOperator Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


Apply Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.Apply Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Inherited from RealVectorManipulatorBase.)
Apply(IRandom, array<Double>[]()[], Double, Double) |

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


Apply Method (IRandom, Double[], Double, Double)

UniformOnePositionManipulator..::.Apply Method (IRandom, array<Double>[]()[], Double, Double)
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.UniformOnePositionManipulator.Apply(HeuristicLab.Core.IRandom,System.Double[],System.Double,System.Double)]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double[] Apply(
    IRandom random,
    double[] vector,
    double min,
    double max
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

vector
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "vector"]

min
Type: System..::.Double

[Missing <param> documentation for "min"]

max
Type: System..::.Double

[Missing <param> documentation for "max"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.UniformOnePositionManipulator.Apply(HeuristicLab.Core.IRandom,System.Double[],System.Double,System.Double)]

See Also

UniformOnePositionManipulator Class
Apply Overload
HeuristicLab.RealVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.Clone Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.GetVariableValue Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.IsValid Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


Manipulate Method

UniformOnePositionManipulator..::.Manipulate Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.UniformOnePositionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[])]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double[] Manipulate(
    IScope scope,
    IRandom random,
    double[] vector
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

vector
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "vector"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.UniformOnePositionManipulator.Manipulate(HeuristicLab.Core.IScope,HeuristicLab.Core.IRandom,System.Double[])]

See Also

UniformOnePositionManipulator Class
HeuristicLab.RealVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.TryAddSubOperator Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.TryAddVariable Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.TryAddVariableInfo Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.TryRemoveSubOperator Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.TryRemoveVariable Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator..::.TryRemoveVariableInfo Method
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
UniformOnePositionManipulator Members
HeuristicLab.RealVector Namespace


UniformOnePositionManipulator Properties

[image]

HeuristicLab API Documentation
UniformOnePositionManipulator Properties
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformOnePositionManipulator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UniformOnePositionManipulator Class
HeuristicLab.RealVector Namespace


Description Property

UniformOnePositionManipulator..::.Description Property
UniformOnePositionManipulator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.RealVector.UniformOnePositionManipulator.Description]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UniformOnePositionManipulator Class
HeuristicLab.RealVector Namespace


UniformRandomRealVectorGenerator Class

UniformRandomRealVectorGenerator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.RealVector.UniformRandomRealVectorGenerator]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class UniformRandomRealVectorGenerator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.RealVector..::.UniformRandomRealVectorGenerator

See Also

UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


UniformRandomRealVectorGenerator Members

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator Members
UniformRandomRealVectorGenerator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomRealVectorGenerator type exposes the following members.

Constructors

Name | Description
UniformRandomRealVectorGenerator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
HeuristicLab.RealVector Namespace


UniformRandomRealVectorGenerator Constructor

UniformRandomRealVectorGenerator Constructor
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the UniformRandomRealVectorGenerator class.

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public UniformRandomRealVectorGenerator()

See Also

UniformRandomRealVectorGenerator Class
HeuristicLab.RealVector Namespace


UniformRandomRealVectorGenerator Methods

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator Methods
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomRealVectorGenerator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | Overloaded.
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

UniformRandomRealVectorGenerator Class
HeuristicLab.RealVector Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.AddSubOperator Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


Apply Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.Apply Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Apply(IScope) | (Overrides OperatorBase ..::. Apply(IScope).)
Apply(IRandom, Int32, Double, Double) |

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


Apply Method (IScope)

UniformRandomRealVectorGenerator..::.Apply Method (IScope)
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.UniformRandomRealVectorGenerator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.UniformRandomRealVectorGenerator.Apply(HeuristicLab.Core.IScope)]

See Also

UniformRandomRealVectorGenerator Class
Apply Overload
HeuristicLab.RealVector Namespace


Apply Method (IRandom, Int32, Double, Double)

UniformRandomRealVectorGenerator..::.Apply Method (IRandom, Int32, Double, Double)
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.RealVector.UniformRandomRealVectorGenerator.Apply(HeuristicLab.Core.IRandom,System.Int32,System.Double,System.Double)]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static double[] Apply(
    IRandom random,
    int length,
    double min,
    double max
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

length
Type: System..::.Int32

[Missing <param> documentation for "length"]

min
Type: System..::.Double

[Missing <param> documentation for "min"]

max
Type: System..::.Double

[Missing <param> documentation for "max"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.RealVector.UniformRandomRealVectorGenerator.Apply(HeuristicLab.Core.IRandom,System.Int32,System.Double,System.Double)]

See Also

UniformRandomRealVectorGenerator Class
Apply Overload
HeuristicLab.RealVector Namespace


Clone Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.Clone Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.GetVariableValue Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


IsValid Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.IsValid Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.TryAddSubOperator Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.TryAddVariable Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.TryAddVariableInfo Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.TryRemoveSubOperator Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.TryRemoveVariable Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator..::.TryRemoveVariableInfo Method
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
UniformRandomRealVectorGenerator Members
HeuristicLab.RealVector Namespace


UniformRandomRealVectorGenerator Properties

[image]

HeuristicLab API Documentation
UniformRandomRealVectorGenerator Properties
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UniformRandomRealVectorGenerator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

UniformRandomRealVectorGenerator Class
HeuristicLab.RealVector Namespace


Description Property

UniformRandomRealVectorGenerator..::.Description Property
UniformRandomRealVectorGenerator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.RealVector.UniformRandomRealVectorGenerator.Description]

Namespace: HeuristicLab.RealVector
Assembly: HeuristicLab.RealVector (in HeuristicLab.RealVector.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

UniformRandomRealVectorGenerator Class
HeuristicLab.RealVector Namespace


HeuristicLab.Routing.TSP Namespace

HeuristicLab.Routing.TSP Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

HeuristicLab.Routing.TSP Namespace Summary (... to be continued ...)

Classes

Class | Description
DistanceMatrixPathTSPEvaluator |
HeuristicLabRoutingTSPPlugin |
PathTSPEvaluatorBase |
RoundedEuclideanPathTSPEvaluator |
TSPDistanceMatrixInjectorBase |
TSPInjector |
TSPInjectorView |
TSPParser |
TSPRoundedEuclideanDistanceMatrixInjector |
TSPTour |
TSPTourInjector |
TSPTourView |


DistanceMatrixPathTSPEvaluator Class

DistanceMatrixPathTSPEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.DistanceMatrixPathTSPEvaluator]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DistanceMatrixPathTSPEvaluator : SingleObjectiveEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.Routing.TSP..::.DistanceMatrixPathTSPEvaluator

See Also

DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


DistanceMatrixPathTSPEvaluator Members

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator Members
DistanceMatrixPathTSPEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistanceMatrixPathTSPEvaluator type exposes the following members.

Constructors

Name | Description
DistanceMatrixPathTSPEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides SingleObjectiveEvaluatorBase ..::. Evaluate(IScope).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


DistanceMatrixPathTSPEvaluator Constructor

DistanceMatrixPathTSPEvaluator Constructor
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DistanceMatrixPathTSPEvaluator class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DistanceMatrixPathTSPEvaluator()

See Also

DistanceMatrixPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


DistanceMatrixPathTSPEvaluator Methods

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator Methods
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistanceMatrixPathTSPEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides SingleObjectiveEvaluatorBase ..::. Evaluate(IScope).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

DistanceMatrixPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.AddSubOperator Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.Clone Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


Evaluate Method

DistanceMatrixPathTSPEvaluator..::.Evaluate Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.DistanceMatrixPathTSPEvaluator.Evaluate(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double Evaluate(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.DistanceMatrixPathTSPEvaluator.Evaluate(HeuristicLab.Core.IScope)]

See Also

DistanceMatrixPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.GetVariableValue Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.IsValid Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.TryAddSubOperator Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.TryAddVariable Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.TryAddVariableInfo Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.TryRemoveSubOperator Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.TryRemoveVariable Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator..::.TryRemoveVariableInfo Method
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
DistanceMatrixPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


DistanceMatrixPathTSPEvaluator Properties

[image]

HeuristicLab API Documentation
DistanceMatrixPathTSPEvaluator Properties
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DistanceMatrixPathTSPEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

DistanceMatrixPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


Description Property

DistanceMatrixPathTSPEvaluator..::.Description Property
DistanceMatrixPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.DistanceMatrixPathTSPEvaluator.Description]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

DistanceMatrixPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


HeuristicLabRoutingTSPPlugin Class

HeuristicLabRoutingTSPPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.HeuristicLabRoutingTSPPlugin]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[ClassInfoAttribute(Name = "HeuristicLab.Routing.TSP")]
[PluginFileAttribute(Filename = "HeuristicLab.Routing.TSP.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Permutation")]
[DependencyAttribute(Dependency = "HeuristicLab.Charting")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
public class HeuristicLabRoutingTSPPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Routing.TSP..::.HeuristicLabRoutingTSPPlugin

See Also

HeuristicLabRoutingTSPPlugin Members
HeuristicLab.Routing.TSP Namespace


HeuristicLabRoutingTSPPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabRoutingTSPPlugin Members
HeuristicLabRoutingTSPPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabRoutingTSPPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabRoutingTSPPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabRoutingTSPPlugin Class
HeuristicLab.Routing.TSP Namespace


HeuristicLabRoutingTSPPlugin Constructor

HeuristicLabRoutingTSPPlugin Constructor
HeuristicLabRoutingTSPPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabRoutingTSPPlugin class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabRoutingTSPPlugin()

See Also

HeuristicLabRoutingTSPPlugin Class
HeuristicLab.Routing.TSP Namespace


PathTSPEvaluatorBase Class

PathTSPEvaluatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.PathTSPEvaluatorBase]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class PathTSPEvaluatorBase : SingleObjectiveEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.Routing.TSP..::.PathTSPEvaluatorBase
HeuristicLab.Routing.TSP..::.RoundedEuclideanPathTSPEvaluator

See Also

PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


PathTSPEvaluatorBase Members

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase Members
PathTSPEvaluatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PathTSPEvaluatorBase type exposes the following members.

Constructors

Name | Description
PathTSPEvaluatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
CalculateDistance |
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides SingleObjectiveEvaluatorBase ..::. Evaluate(IScope).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
HeuristicLab.Routing.TSP Namespace


PathTSPEvaluatorBase Constructor

PathTSPEvaluatorBase Constructor
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PathTSPEvaluatorBase class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PathTSPEvaluatorBase()

See Also

PathTSPEvaluatorBase Class
HeuristicLab.Routing.TSP Namespace


PathTSPEvaluatorBase Methods

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase Methods
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PathTSPEvaluatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
CalculateDistance |
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides SingleObjectiveEvaluatorBase ..::. Evaluate(IScope).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

PathTSPEvaluatorBase Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.AddSubOperator Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


CalculateDistance Method

PathTSPEvaluatorBase..::.CalculateDistance Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.PathTSPEvaluatorBase.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract double CalculateDistance(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.PathTSPEvaluatorBase.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

See Also

PathTSPEvaluatorBase Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.Clone Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


Evaluate Method

PathTSPEvaluatorBase..::.Evaluate Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.PathTSPEvaluatorBase.Evaluate(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override sealed double Evaluate(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.PathTSPEvaluatorBase.Evaluate(HeuristicLab.Core.IScope)]

See Also

PathTSPEvaluatorBase Class
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.GetVariableValue Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.IsValid Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.TryAddSubOperator Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.TryAddVariable Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.TryAddVariableInfo Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.TryRemoveSubOperator Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.TryRemoveVariable Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
PathTSPEvaluatorBase..::.TryRemoveVariableInfo Method
PathTSPEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PathTSPEvaluatorBase Class
PathTSPEvaluatorBase Members
HeuristicLab.Routing.TSP Namespace


RoundedEuclideanPathTSPEvaluator Class

RoundedEuclideanPathTSPEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.RoundedEuclideanPathTSPEvaluator]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RoundedEuclideanPathTSPEvaluator : PathTSPEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.Routing.TSP..::.PathTSPEvaluatorBase
HeuristicLab.Routing.TSP..::.RoundedEuclideanPathTSPEvaluator

See Also

RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


RoundedEuclideanPathTSPEvaluator Members

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator Members
RoundedEuclideanPathTSPEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RoundedEuclideanPathTSPEvaluator type exposes the following members.

Constructors

Name | Description
RoundedEuclideanPathTSPEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
CalculateDistance | (Overrides PathTSPEvaluatorBase ..::. CalculateDistance(Double, Double, Double, Double).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from PathTSPEvaluatorBase.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


RoundedEuclideanPathTSPEvaluator Constructor

RoundedEuclideanPathTSPEvaluator Constructor
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RoundedEuclideanPathTSPEvaluator class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RoundedEuclideanPathTSPEvaluator()

See Also

RoundedEuclideanPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


RoundedEuclideanPathTSPEvaluator Methods

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator Methods
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RoundedEuclideanPathTSPEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
CalculateDistance | (Overrides PathTSPEvaluatorBase ..::. CalculateDistance(Double, Double, Double, Double).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from PathTSPEvaluatorBase.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RoundedEuclideanPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.AddSubOperator Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


CalculateDistance Method

RoundedEuclideanPathTSPEvaluator..::.CalculateDistance Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.RoundedEuclideanPathTSPEvaluator.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double CalculateDistance(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.RoundedEuclideanPathTSPEvaluator.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

See Also

RoundedEuclideanPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.Clone Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.GetVariableValue Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.IsValid Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.TryAddSubOperator Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.TryAddVariable Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.TryAddVariableInfo Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.TryRemoveSubOperator Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.TryRemoveVariable Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator..::.TryRemoveVariableInfo Method
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
RoundedEuclideanPathTSPEvaluator Members
HeuristicLab.Routing.TSP Namespace


RoundedEuclideanPathTSPEvaluator Properties

[image]

HeuristicLab API Documentation
RoundedEuclideanPathTSPEvaluator Properties
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RoundedEuclideanPathTSPEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RoundedEuclideanPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


Description Property

RoundedEuclideanPathTSPEvaluator..::.Description Property
RoundedEuclideanPathTSPEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.RoundedEuclideanPathTSPEvaluator.Description]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RoundedEuclideanPathTSPEvaluator Class
HeuristicLab.Routing.TSP Namespace


TSPDistanceMatrixInjectorBase Class

TSPDistanceMatrixInjectorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPDistanceMatrixInjectorBase]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class TSPDistanceMatrixInjectorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Routing.TSP..::.TSPDistanceMatrixInjectorBase
HeuristicLab.Routing.TSP..::.TSPRoundedEuclideanDistanceMatrixInjector

See Also

TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TSPDistanceMatrixInjectorBase Members

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase Members
TSPDistanceMatrixInjectorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPDistanceMatrixInjectorBase type exposes the following members.

Constructors

Name | Description
TSPDistanceMatrixInjectorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
CalculateDistance |
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
HeuristicLab.Routing.TSP Namespace


TSPDistanceMatrixInjectorBase Constructor

TSPDistanceMatrixInjectorBase Constructor
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPDistanceMatrixInjectorBase class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPDistanceMatrixInjectorBase()

See Also

TSPDistanceMatrixInjectorBase Class
HeuristicLab.Routing.TSP Namespace


TSPDistanceMatrixInjectorBase Methods

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase Methods
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPDistanceMatrixInjectorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
CalculateDistance |
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TSPDistanceMatrixInjectorBase Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.AddSubOperator Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


Apply Method

TSPDistanceMatrixInjectorBase..::.Apply Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPDistanceMatrixInjectorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPDistanceMatrixInjectorBase.Apply(HeuristicLab.Core.IScope)]

See Also

TSPDistanceMatrixInjectorBase Class
HeuristicLab.Routing.TSP Namespace


CalculateDistance Method

TSPDistanceMatrixInjectorBase..::.CalculateDistance Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPDistanceMatrixInjectorBase.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract double CalculateDistance(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPDistanceMatrixInjectorBase.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

See Also

TSPDistanceMatrixInjectorBase Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.Clone Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.GetVariableValue Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.IsValid Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.TryAddSubOperator Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.TryAddVariable Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.TryAddVariableInfo Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.TryRemoveSubOperator Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.TryRemoveVariable Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TSPDistanceMatrixInjectorBase..::.TryRemoveVariableInfo Method
TSPDistanceMatrixInjectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPDistanceMatrixInjectorBase Class
TSPDistanceMatrixInjectorBase Members
HeuristicLab.Routing.TSP Namespace


TSPInjector Class

TSPInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPInjector]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Routing.TSP..::.TSPInjector

See Also

TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TSPInjector Members

[image]

HeuristicLab API Documentation
TSPInjector Members
TSPInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPInjector type exposes the following members.

Constructors

Name | Description
TSPInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


TSPInjector Constructor

TSPInjector Constructor
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPInjector class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPInjector()

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


TSPInjector Methods

[image]

HeuristicLab API Documentation
TSPInjector Methods
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TSPInjector..::.AddSubOperator Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


Apply Method

TSPInjector..::.Apply Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPInjector.Apply(HeuristicLab.Core.IScope)]

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
TSPInjector..::.Clone Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


CreateView Method

TSPInjector..::.CreateView Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPInjector.CreateView]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPInjector.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TSPInjector..::.GetVariableValue Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TSPInjector..::.IsValid Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TSPInjector..::.TryAddSubOperator Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TSPInjector..::.TryAddVariable Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TSPInjector..::.TryAddVariableInfo Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TSPInjector..::.TryRemoveSubOperator Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TSPInjector..::.TryRemoveVariable Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TSPInjector..::.TryRemoveVariableInfo Method
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPInjector Class
TSPInjector Members
HeuristicLab.Routing.TSP Namespace


TSPInjector Properties

[image]

HeuristicLab API Documentation
TSPInjector Properties
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


Description Property

TSPInjector..::.Description Property
TSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPInjector.Description]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

TSPInjector Class
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Class

TSPInjectorView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPInjectorView]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPInjectorView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Routing.TSP..::.TSPInjectorView

See Also

TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Members

[image]

HeuristicLab API Documentation
TSPInjectorView Members
TSPInjectorView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPInjectorView type exposes the following members.

Constructors

Name | Description
TSPInjectorView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TSPInjector |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Constructor

[image]

HeuristicLab API Documentation
TSPInjectorView Constructor
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TSPInjectorView()()() |
TSPInjectorView(TSPInjector) |

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Constructor

TSPInjectorView Constructor
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPInjectorView class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPInjectorView()

See Also

TSPInjectorView Class
TSPInjectorView Overload
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Constructor (TSPInjector)

TSPInjectorView Constructor (TSPInjector)
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPInjectorView class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPInjectorView(
    TSPInjector tspInjector
)

Parameters

tspInjector
Type: HeuristicLab.Routing.TSP..::.TSPInjector

[Missing <param> documentation for "tspInjector"]

See Also

TSPInjectorView Class
TSPInjectorView Overload
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Methods

[image]

HeuristicLab API Documentation
TSPInjectorView Methods
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPInjectorView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.AccessibilityNotifyClients Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


AddItemEvents Method

TSPInjectorView..::.AddItemEvents Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPInjectorView.AddItemEvents]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.BeginInvoke Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


Dispose Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.Dispose Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


Dispose Method (Boolean)

TSPInjectorView..::.Dispose Method (Boolean)
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

TSPInjectorView Class
Dispose Overload
HeuristicLab.Routing.TSP Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.GetChildAtPoint Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.Invalidate Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


Invoke Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.Invoke Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.MemberwiseClone Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.PerformLayout Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


RemoveItemEvents Method

TSPInjectorView..::.RemoveItemEvents Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPInjectorView.RemoveItemEvents]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.ResumeLayout Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.RtlTranslateAlignment Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


Scale Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.Scale Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


Select Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.Select Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.SetBounds Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.UpdateBounds Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


UpdateControls Method

TSPInjectorView..::.UpdateControls Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPInjectorView.UpdateControls]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


Validate Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.Validate Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
TSPInjectorView..::.ValidateChildren Method
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

TSPInjectorView Class
TSPInjectorView Members
HeuristicLab.Routing.TSP Namespace


TSPInjectorView Properties

[image]

HeuristicLab API Documentation
TSPInjectorView Properties
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPInjectorView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TSPInjector |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


TSPInjector Property

TSPInjectorView..::.TSPInjector Property
TSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPInjectorView.TSPInjector]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPInjector TSPInjector { get; set; }

See Also

TSPInjectorView Class
HeuristicLab.Routing.TSP Namespace


TSPParser Class

TSPParser Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPParser]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPParser

Inheritance Hierarchy

System..::.Object
HeuristicLab.Routing.TSP..::.TSPParser

See Also

TSPParser Members
HeuristicLab.Routing.TSP Namespace


TSPParser Members

[image]

HeuristicLab API Documentation
TSPParser Members
TSPParser Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPParser type exposes the following members.

Constructors

Name | Description
TSPParser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
Vertices |
WeightType |

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


TSPParser Constructor

TSPParser Constructor
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPParser class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPParser(
    string path
)

Parameters

path
Type: System..::.String

[Missing <param> documentation for "path"]

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


TSPParser Methods

[image]

HeuristicLab API Documentation
TSPParser Methods
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPParser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


Parse Method

TSPParser..::.Parse Method
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPParser.Parse]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Parse()

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


TSPParser Properties

[image]

HeuristicLab API Documentation
TSPParser Properties
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPParser type exposes the following members.

Properties

Name | Description
Name |
Vertices |
WeightType |

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


Name Property

TSPParser..::.Name Property
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPParser.Name]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; }

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


Vertices Property

TSPParser..::.Vertices Property
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPParser.Vertices]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double[,] Vertices { get; }

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


WeightType Property

TSPParser..::.WeightType Property
TSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPParser.WeightType]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int WeightType { get; }

See Also

TSPParser Class
HeuristicLab.Routing.TSP Namespace


TSPRoundedEuclideanDistanceMatrixInjector Class

TSPRoundedEuclideanDistanceMatrixInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPRoundedEuclideanDistanceMatrixInjector]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPRoundedEuclideanDistanceMatrixInjector : TSPDistanceMatrixInjectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Routing.TSP..::.TSPDistanceMatrixInjectorBase
HeuristicLab.Routing.TSP..::.TSPRoundedEuclideanDistanceMatrixInjector

See Also

TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TSPRoundedEuclideanDistanceMatrixInjector Members

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector Members
TSPRoundedEuclideanDistanceMatrixInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPRoundedEuclideanDistanceMatrixInjector type exposes the following members.

Constructors

Name | Description
TSPRoundedEuclideanDistanceMatrixInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from TSPDistanceMatrixInjectorBase.)
CalculateDistance | (Overrides TSPDistanceMatrixInjectorBase ..::. CalculateDistance(Double, Double, Double, Double).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
HeuristicLab.Routing.TSP Namespace


TSPRoundedEuclideanDistanceMatrixInjector Constructor

TSPRoundedEuclideanDistanceMatrixInjector Constructor
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPRoundedEuclideanDistanceMatrixInjector class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPRoundedEuclideanDistanceMatrixInjector()

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
HeuristicLab.Routing.TSP Namespace


TSPRoundedEuclideanDistanceMatrixInjector Methods

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector Methods
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPRoundedEuclideanDistanceMatrixInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from TSPDistanceMatrixInjectorBase.)
CalculateDistance | (Overrides TSPDistanceMatrixInjectorBase ..::. CalculateDistance(Double, Double, Double, Double).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.AddSubOperator Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


CalculateDistance Method

TSPRoundedEuclideanDistanceMatrixInjector..::.CalculateDistance Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPRoundedEuclideanDistanceMatrixInjector.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double CalculateDistance(
    double x1,
    double y1,
    double x2,
    double y2
)

Parameters

x1
Type: System..::.Double

[Missing <param> documentation for "x1"]

y1
Type: System..::.Double

[Missing <param> documentation for "y1"]

x2
Type: System..::.Double

[Missing <param> documentation for "x2"]

y2
Type: System..::.Double

[Missing <param> documentation for "y2"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPRoundedEuclideanDistanceMatrixInjector.CalculateDistance(System.Double,System.Double,System.Double,System.Double)]

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.Clone Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.GetVariableValue Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.IsValid Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.TryAddSubOperator Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.TryAddVariable Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.TryAddVariableInfo Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.TryRemoveSubOperator Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.TryRemoveVariable Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector..::.TryRemoveVariableInfo Method
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
TSPRoundedEuclideanDistanceMatrixInjector Members
HeuristicLab.Routing.TSP Namespace


TSPRoundedEuclideanDistanceMatrixInjector Properties

[image]

HeuristicLab API Documentation
TSPRoundedEuclideanDistanceMatrixInjector Properties
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPRoundedEuclideanDistanceMatrixInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
HeuristicLab.Routing.TSP Namespace


Description Property

TSPRoundedEuclideanDistanceMatrixInjector..::.Description Property
TSPRoundedEuclideanDistanceMatrixInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPRoundedEuclideanDistanceMatrixInjector.Description]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

TSPRoundedEuclideanDistanceMatrixInjector Class
HeuristicLab.Routing.TSP Namespace


TSPTour Class

TSPTour Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPTour]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPTour : ItemBase, IVisualizationItem,
    IItem, IStorable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Routing.TSP..::.TSPTour

See Also

TSPTour Members
HeuristicLab.Routing.TSP Namespace


TSPTour Members

[image]

HeuristicLab API Documentation
TSPTour Members
TSPTour Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTour type exposes the following members.

Constructors

Name | Description
TSPTour | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnCoordinatesChanged |
OnTourChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Coordinates |
Guid | (Inherited from StorableBase.)
Tour |

Events

Name | Description
Changed | (Inherited from ItemBase.)
CoordinatesChanged |
TourChanged |

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


TSPTour Constructor

[image]

HeuristicLab API Documentation
TSPTour Constructor
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TSPTour()()() |
TSPTour(DoubleMatrixData, Permutation) |

See Also

TSPTour Class
TSPTour Members
HeuristicLab.Routing.TSP Namespace


TSPTour Constructor

TSPTour Constructor
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPTour class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPTour()

See Also

TSPTour Class
TSPTour Overload
HeuristicLab.Routing.TSP Namespace


TSPTour Constructor (DoubleMatrixData, Permutation)

TSPTour Constructor (DoubleMatrixData, Permutation)
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPTour class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPTour(
    DoubleMatrixData coordinates,
    Permutation tour
)

Parameters

coordinates
Type: HeuristicLab.Data..::.DoubleMatrixData

[Missing <param> documentation for "coordinates"]

tour
Type: HeuristicLab.Permutation..::.Permutation

[Missing <param> documentation for "tour"]

See Also

TSPTour Class
TSPTour Overload
HeuristicLab.Routing.TSP Namespace


TSPTour Methods

[image]

HeuristicLab API Documentation
TSPTour Methods
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTour type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnCoordinatesChanged |
OnTourChanged |
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
TSPTour..::.Clone Method
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

TSPTour Class
TSPTour Members
HeuristicLab.Routing.TSP Namespace


Clone Method (IDictionary(Guid, Object))

TSPTour..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTour.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPTour.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

TSPTour Class
Clone Overload
HeuristicLab.Routing.TSP Namespace


CreateView Method

TSPTour..::.CreateView Method
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTour.CreateView]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPTour.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


GetXmlNode Method

TSPTour..::.GetXmlNode Method
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTour.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPTour.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


OnCoordinatesChanged Method

TSPTour..::.OnCoordinatesChanged Method
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTour.OnCoordinatesChanged]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnCoordinatesChanged()

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


OnTourChanged Method

TSPTour..::.OnTourChanged Method
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTour.OnTourChanged]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnTourChanged()

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


Populate Method

TSPTour..::.Populate Method
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTour.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


TSPTour Properties

[image]

HeuristicLab API Documentation
TSPTour Properties
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTour type exposes the following members.

Properties

Name | Description
Coordinates |
Guid | (Inherited from StorableBase.)
Tour |

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


Coordinates Property

TSPTour..::.Coordinates Property
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPTour.Coordinates]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DoubleMatrixData Coordinates { get; set; }

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


Tour Property

TSPTour..::.Tour Property
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPTour.Tour]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Permutation Tour { get; set; }

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


TSPTour Events

[image]

HeuristicLab API Documentation
TSPTour Events
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTour type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
CoordinatesChanged |
TourChanged |

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


CoordinatesChanged Event

TSPTour..::.CoordinatesChanged Event
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Routing.TSP.TSPTour.CoordinatesChanged]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler CoordinatesChanged

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


TourChanged Event

TSPTour..::.TourChanged Event
TSPTour Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.Routing.TSP.TSPTour.TourChanged]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler TourChanged

See Also

TSPTour Class
HeuristicLab.Routing.TSP Namespace


TSPTourInjector Class

TSPTourInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPTourInjector]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPTourInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Routing.TSP..::.TSPTourInjector

See Also

TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TSPTourInjector Members

[image]

HeuristicLab API Documentation
TSPTourInjector Members
TSPTourInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTourInjector type exposes the following members.

Constructors

Name | Description
TSPTourInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
HeuristicLab.Routing.TSP Namespace


TSPTourInjector Constructor

TSPTourInjector Constructor
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPTourInjector class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPTourInjector()

See Also

TSPTourInjector Class
HeuristicLab.Routing.TSP Namespace


TSPTourInjector Methods

[image]

HeuristicLab API Documentation
TSPTourInjector Methods
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTourInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TSPTourInjector Class
HeuristicLab.Routing.TSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.AddSubOperator Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


Apply Method

TSPTourInjector..::.Apply Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTourInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Routing.TSP.TSPTourInjector.Apply(HeuristicLab.Core.IScope)]

See Also

TSPTourInjector Class
HeuristicLab.Routing.TSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.Clone Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.GetVariableValue Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.IsValid Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.TryAddSubOperator Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.TryAddVariable Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.TryAddVariableInfo Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.TryRemoveSubOperator Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.TryRemoveVariable Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TSPTourInjector..::.TryRemoveVariableInfo Method
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
TSPTourInjector Members
HeuristicLab.Routing.TSP Namespace


TSPTourInjector Properties

[image]

HeuristicLab API Documentation
TSPTourInjector Properties
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTourInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

TSPTourInjector Class
HeuristicLab.Routing.TSP Namespace


Description Property

TSPTourInjector..::.Description Property
TSPTourInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPTourInjector.Description]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

TSPTourInjector Class
HeuristicLab.Routing.TSP Namespace


TSPTourView Class

TSPTourView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Routing.TSP.TSPTourView]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TSPTourView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Routing.TSP..::.TSPTourView

See Also

TSPTourView Members
HeuristicLab.Routing.TSP Namespace


TSPTourView Members

[image]

HeuristicLab API Documentation
TSPTourView Members
TSPTourView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTourView type exposes the following members.

Constructors

Name | Description
TSPTourView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TSPTour |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


TSPTourView Constructor

[image]

HeuristicLab API Documentation
TSPTourView Constructor
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TSPTourView()()() |
TSPTourView(TSPTour) |

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


TSPTourView Constructor

TSPTourView Constructor
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPTourView class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPTourView()

See Also

TSPTourView Class
TSPTourView Overload
HeuristicLab.Routing.TSP Namespace


TSPTourView Constructor (TSPTour)

TSPTourView Constructor (TSPTour)
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TSPTourView class.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPTourView(
    TSPTour tspTour
)

Parameters

tspTour
Type: HeuristicLab.Routing.TSP..::.TSPTour

[Missing <param> documentation for "tspTour"]

See Also

TSPTourView Class
TSPTourView Overload
HeuristicLab.Routing.TSP Namespace


TSPTourView Methods

[image]

HeuristicLab API Documentation
TSPTourView Methods
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTourView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
TSPTourView..::.AccessibilityNotifyClients Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


AddItemEvents Method

TSPTourView..::.AddItemEvents Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTourView.AddItemEvents]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
TSPTourView..::.BeginInvoke Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


Dispose Method

[image]

HeuristicLab API Documentation
TSPTourView..::.Dispose Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


Dispose Method (Boolean)

TSPTourView..::.Dispose Method (Boolean)
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

TSPTourView Class
Dispose Overload
HeuristicLab.Routing.TSP Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
TSPTourView..::.GetChildAtPoint Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
TSPTourView..::.Invalidate Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


Invoke Method

[image]

HeuristicLab API Documentation
TSPTourView..::.Invoke Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
TSPTourView..::.MemberwiseClone Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
TSPTourView..::.PerformLayout Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


RemoveItemEvents Method

TSPTourView..::.RemoveItemEvents Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTourView.RemoveItemEvents]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
TSPTourView..::.ResumeLayout Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
TSPTourView..::.RtlTranslateAlignment Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


Scale Method

[image]

HeuristicLab API Documentation
TSPTourView..::.Scale Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


Select Method

[image]

HeuristicLab API Documentation
TSPTourView..::.Select Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
TSPTourView..::.SetBounds Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
TSPTourView..::.UpdateBounds Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


UpdateControls Method

TSPTourView..::.UpdateControls Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Routing.TSP.TSPTourView.UpdateControls]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


Validate Method

[image]

HeuristicLab API Documentation
TSPTourView..::.Validate Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
TSPTourView..::.ValidateChildren Method
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

TSPTourView Class
TSPTourView Members
HeuristicLab.Routing.TSP Namespace


TSPTourView Properties

[image]

HeuristicLab API Documentation
TSPTourView Properties
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TSPTourView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TSPTour |
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


TSPTour Property

TSPTourView..::.TSPTour Property
TSPTourView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Routing.TSP.TSPTourView.TSPTour]

Namespace: HeuristicLab.Routing.TSP
Assembly: HeuristicLab.Routing.TSP (in HeuristicLab.Routing.TSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TSPTour TSPTour { get; set; }

See Also

TSPTourView Class
HeuristicLab.Routing.TSP Namespace


HeuristicLab.Scheduling.JSSP Namespace

HeuristicLab.Scheduling.JSSP Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Scheduling.JSSP]

Classes

Class | Description
ConditionalSelector |
CopyVariableFromSubScope |
HeuristicLabRoutingTSPPlugin |
IsSchedulable |
ItemListIndexer |
JSSPInjector |
JSSPInjectorView |
JSSPParser |
Operation |
OperationScheduler |
OperationScoreBase |
OperationUpdater |
OperationView |
ProcessingTime |
RemainingNrOfOperations |
RemainingProcessingTime |
Schedule |
ScheduleInjector |
ScheduleTree |
ScheduleTreeNode |
TimeSlot |


ConditionalSelector Class

ConditionalSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.ConditionalSelector]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ConditionalSelector : SelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Scheduling.JSSP..::.ConditionalSelector

See Also

ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


ConditionalSelector Members

[image]

HeuristicLab API Documentation
ConditionalSelector Members
ConditionalSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConditionalSelector type exposes the following members.

Constructors

Name | Description
ConditionalSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | (Overrides SelectorBase ..::. Select(IScope, IScope, Boolean).)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
HeuristicLab.Scheduling.JSSP Namespace


ConditionalSelector Constructor

ConditionalSelector Constructor
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ConditionalSelector class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ConditionalSelector()

See Also

ConditionalSelector Class
HeuristicLab.Scheduling.JSSP Namespace


ConditionalSelector Methods

[image]

HeuristicLab API Documentation
ConditionalSelector Methods
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConditionalSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | (Overrides SelectorBase ..::. Select(IScope, IScope, Boolean).)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ConditionalSelector Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.AddSubOperator Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.Clone Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.GetVariableValue Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.IsValid Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


Select Method

ConditionalSelector..::.Select Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ConditionalSelector.Select(HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IScope source,
    IScope target,
    bool copySelected
)

Parameters

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

ConditionalSelector Class
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.TryAddSubOperator Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.TryAddVariable Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.TryAddVariableInfo Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.TryRemoveSubOperator Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.TryRemoveVariable Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ConditionalSelector..::.TryRemoveVariableInfo Method
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
ConditionalSelector Members
HeuristicLab.Scheduling.JSSP Namespace


ConditionalSelector Properties

[image]

HeuristicLab API Documentation
ConditionalSelector Properties
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ConditionalSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ConditionalSelector Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

ConditionalSelector..::.Description Property
ConditionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ConditionalSelector.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ConditionalSelector Class
HeuristicLab.Scheduling.JSSP Namespace


CopyVariableFromSubScope Class

CopyVariableFromSubScope Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.CopyVariableFromSubScope]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CopyVariableFromSubScope : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.CopyVariableFromSubScope

See Also

CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


CopyVariableFromSubScope Members

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope Members
CopyVariableFromSubScope Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CopyVariableFromSubScope type exposes the following members.

Constructors

Name | Description
CopyVariableFromSubScope |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
HeuristicLab.Scheduling.JSSP Namespace


CopyVariableFromSubScope Constructor

CopyVariableFromSubScope Constructor
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CopyVariableFromSubScope class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CopyVariableFromSubScope()

See Also

CopyVariableFromSubScope Class
HeuristicLab.Scheduling.JSSP Namespace


CopyVariableFromSubScope Methods

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope Methods
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CopyVariableFromSubScope type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CopyVariableFromSubScope Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.AddSubOperator Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

CopyVariableFromSubScope..::.Apply Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.CopyVariableFromSubScope.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.CopyVariableFromSubScope.Apply(HeuristicLab.Core.IScope)]

See Also

CopyVariableFromSubScope Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.Clone Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.GetVariableValue Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.IsValid Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.TryAddSubOperator Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.TryAddVariable Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.TryAddVariableInfo Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.TryRemoveSubOperator Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.TryRemoveVariable Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope..::.TryRemoveVariableInfo Method
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
CopyVariableFromSubScope Members
HeuristicLab.Scheduling.JSSP Namespace


CopyVariableFromSubScope Properties

[image]

HeuristicLab API Documentation
CopyVariableFromSubScope Properties
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CopyVariableFromSubScope type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

CopyVariableFromSubScope Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

CopyVariableFromSubScope..::.Description Property
CopyVariableFromSubScope Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.CopyVariableFromSubScope.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

CopyVariableFromSubScope Class
HeuristicLab.Scheduling.JSSP Namespace


HeuristicLabRoutingTSPPlugin Class

HeuristicLabRoutingTSPPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.HeuristicLabRoutingTSPPlugin]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[PluginFileAttribute(Filename = "HeuristicLab.Scheduling.JSSP.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[ClassInfoAttribute(Name = "HeuristicLab.Scheduling.JSSP")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[DependencyAttribute(Dependency = "HeuristicLab.Permutation")]
public class HeuristicLabRoutingTSPPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Scheduling.JSSP..::.HeuristicLabRoutingTSPPlugin

See Also

HeuristicLabRoutingTSPPlugin Members
HeuristicLab.Scheduling.JSSP Namespace


HeuristicLabRoutingTSPPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabRoutingTSPPlugin Members
HeuristicLabRoutingTSPPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabRoutingTSPPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabRoutingTSPPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabRoutingTSPPlugin Class
HeuristicLab.Scheduling.JSSP Namespace


HeuristicLabRoutingTSPPlugin Constructor

HeuristicLabRoutingTSPPlugin Constructor
HeuristicLabRoutingTSPPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabRoutingTSPPlugin class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabRoutingTSPPlugin()

See Also

HeuristicLabRoutingTSPPlugin Class
HeuristicLab.Scheduling.JSSP Namespace


IsSchedulable Class

IsSchedulable Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.IsSchedulable]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class IsSchedulable : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.IsSchedulable

See Also

IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


IsSchedulable Members

[image]

HeuristicLab API Documentation
IsSchedulable Members
IsSchedulable Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IsSchedulable type exposes the following members.

Constructors

Name | Description
IsSchedulable |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
HeuristicLab.Scheduling.JSSP Namespace


IsSchedulable Constructor

IsSchedulable Constructor
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the IsSchedulable class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IsSchedulable()

See Also

IsSchedulable Class
HeuristicLab.Scheduling.JSSP Namespace


IsSchedulable Methods

[image]

HeuristicLab API Documentation
IsSchedulable Methods
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IsSchedulable type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

IsSchedulable Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.AddSubOperator Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

IsSchedulable..::.Apply Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.IsSchedulable.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.IsSchedulable.Apply(HeuristicLab.Core.IScope)]

See Also

IsSchedulable Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.Clone Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.GetVariableValue Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.IsValid Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.TryAddSubOperator Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.TryAddVariable Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.TryAddVariableInfo Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.TryRemoveSubOperator Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.TryRemoveVariable Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
IsSchedulable..::.TryRemoveVariableInfo Method
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
IsSchedulable Members
HeuristicLab.Scheduling.JSSP Namespace


IsSchedulable Properties

[image]

HeuristicLab API Documentation
IsSchedulable Properties
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The IsSchedulable type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

IsSchedulable Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

IsSchedulable..::.Description Property
IsSchedulable Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.IsSchedulable.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

IsSchedulable Class
HeuristicLab.Scheduling.JSSP Namespace


ItemListIndexer Class

ItemListIndexer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.ItemListIndexer]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class ItemListIndexer : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.ItemListIndexer

See Also

ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


ItemListIndexer Members

[image]

HeuristicLab API Documentation
ItemListIndexer Members
ItemListIndexer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemListIndexer type exposes the following members.

Constructors

Name | Description
ItemListIndexer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
HeuristicLab.Scheduling.JSSP Namespace


ItemListIndexer Constructor

ItemListIndexer Constructor
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ItemListIndexer class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemListIndexer()

See Also

ItemListIndexer Class
HeuristicLab.Scheduling.JSSP Namespace


ItemListIndexer Methods

[image]

HeuristicLab API Documentation
ItemListIndexer Methods
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemListIndexer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ItemListIndexer Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.AddSubOperator Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

ItemListIndexer..::.Apply Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ItemListIndexer.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ItemListIndexer.Apply(HeuristicLab.Core.IScope)]

See Also

ItemListIndexer Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.Clone Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.GetVariableValue Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.IsValid Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.TryAddSubOperator Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.TryAddVariable Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.TryAddVariableInfo Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.TryRemoveSubOperator Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.TryRemoveVariable Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ItemListIndexer..::.TryRemoveVariableInfo Method
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
ItemListIndexer Members
HeuristicLab.Scheduling.JSSP Namespace


ItemListIndexer Properties

[image]

HeuristicLab API Documentation
ItemListIndexer Properties
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ItemListIndexer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ItemListIndexer Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

ItemListIndexer..::.Description Property
ItemListIndexer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ItemListIndexer.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ItemListIndexer Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjector Class

JSSPInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.JSSPInjector]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class JSSPInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.JSSPInjector

See Also

JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjector Members

[image]

HeuristicLab API Documentation
JSSPInjector Members
JSSPInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPInjector type exposes the following members.

Constructors

Name | Description
JSSPInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
NrOfJobs |
NrOfMachines |
Operations |
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjector Constructor

JSSPInjector Constructor
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSSPInjector class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public JSSPInjector()

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjector Methods

[image]

HeuristicLab API Documentation
JSSPInjector Methods
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.AddSubOperator Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

JSSPInjector..::.Apply Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.Apply(HeuristicLab.Core.IScope)]

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.Clone Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method (IDictionary(Guid, Object))

JSSPInjector..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

JSSPInjector Class
Clone Overload
HeuristicLab.Scheduling.JSSP Namespace


CreateView Method

JSSPInjector..::.CreateView Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.CreateView]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.GetVariableValue Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


GetXmlNode Method

JSSPInjector..::.GetXmlNode Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.IsValid Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


Populate Method

JSSPInjector..::.Populate Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjector.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.TryAddSubOperator Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.TryAddVariable Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.TryAddVariableInfo Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.TryRemoveSubOperator Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.TryRemoveVariable Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
JSSPInjector..::.TryRemoveVariableInfo Method
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
JSSPInjector Members
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjector Properties

[image]

HeuristicLab API Documentation
JSSPInjector Properties
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
NrOfJobs |
NrOfMachines |
Operations |
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

JSSPInjector..::.Description Property
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPInjector.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


NrOfJobs Property

JSSPInjector..::.NrOfJobs Property
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPInjector.NrOfJobs]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int NrOfJobs { get; set; }

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


NrOfMachines Property

JSSPInjector..::.NrOfMachines Property
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPInjector.NrOfMachines]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int NrOfMachines { get; set; }

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


Operations Property

JSSPInjector..::.Operations Property
JSSPInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPInjector.Operations]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Operations { get; set; }

See Also

JSSPInjector Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Class

JSSPInjectorView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.JSSPInjectorView]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class JSSPInjectorView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Scheduling.JSSP..::.JSSPInjectorView

See Also

JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Members

[image]

HeuristicLab API Documentation
JSSPInjectorView Members
JSSPInjectorView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPInjectorView type exposes the following members.

Constructors

Name | Description
JSSPInjectorView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
JSSPInjector |
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Constructor

[image]

HeuristicLab API Documentation
JSSPInjectorView Constructor
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
JSSPInjectorView()()() |
JSSPInjectorView(JSSPInjector) |

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Constructor

JSSPInjectorView Constructor
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSSPInjectorView class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public JSSPInjectorView()

See Also

JSSPInjectorView Class
JSSPInjectorView Overload
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Constructor (JSSPInjector)

JSSPInjectorView Constructor (JSSPInjector)
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSSPInjectorView class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public JSSPInjectorView(
    JSSPInjector jsspInjector
)

Parameters

jsspInjector
Type: HeuristicLab.Scheduling.JSSP..::.JSSPInjector

[Missing <param> documentation for "jsspInjector"]

See Also

JSSPInjectorView Class
JSSPInjectorView Overload
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Methods

[image]

HeuristicLab API Documentation
JSSPInjectorView Methods
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPInjectorView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.AccessibilityNotifyClients Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


AddItemEvents Method

JSSPInjectorView..::.AddItemEvents Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjectorView.AddItemEvents]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.BeginInvoke Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


Dispose Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.Dispose Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


Dispose Method (Boolean)

JSSPInjectorView..::.Dispose Method (Boolean)
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

JSSPInjectorView Class
Dispose Overload
HeuristicLab.Scheduling.JSSP Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.GetChildAtPoint Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.Invalidate Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


Invoke Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.Invoke Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.MemberwiseClone Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.PerformLayout Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


RemoveItemEvents Method

JSSPInjectorView..::.RemoveItemEvents Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjectorView.RemoveItemEvents]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.ResumeLayout Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.RtlTranslateAlignment Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


Scale Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.Scale Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


Select Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.Select Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.SetBounds Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.UpdateBounds Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


UpdateControls Method

JSSPInjectorView..::.UpdateControls Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPInjectorView.UpdateControls]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


Validate Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.Validate Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
JSSPInjectorView..::.ValidateChildren Method
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

JSSPInjectorView Class
JSSPInjectorView Members
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjectorView Properties

[image]

HeuristicLab API Documentation
JSSPInjectorView Properties
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPInjectorView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
JSSPInjector |
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPInjector Property

JSSPInjectorView..::.JSSPInjector Property
JSSPInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPInjectorView.JSSPInjector]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public JSSPInjector JSSPInjector { get; set; }

See Also

JSSPInjectorView Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPParser Class

JSSPParser Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.JSSPParser]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class JSSPParser

Inheritance Hierarchy

System..::.Object
HeuristicLab.Scheduling.JSSP..::.JSSPParser

See Also

JSSPParser Members
HeuristicLab.Scheduling.JSSP Namespace


JSSPParser Members

[image]

HeuristicLab API Documentation
JSSPParser Members
JSSPParser Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPParser type exposes the following members.

Constructors

Name | Description
JSSPParser |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MachineSequence |
NrOfJobs |
NrOfMachines |
Operations |
ProcessingTime |

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPParser Constructor

JSSPParser Constructor
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the JSSPParser class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public JSSPParser(
    string path
)

Parameters

path
Type: System..::.String

[Missing <param> documentation for "path"]

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPParser Methods

[image]

HeuristicLab API Documentation
JSSPParser Methods
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPParser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


Parse Method

JSSPParser..::.Parse Method
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.JSSPParser.Parse]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Parse()

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


JSSPParser Properties

[image]

HeuristicLab API Documentation
JSSPParser Properties
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JSSPParser type exposes the following members.

Properties

Name | Description
MachineSequence |
NrOfJobs |
NrOfMachines |
Operations |
ProcessingTime |

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


MachineSequence Property

JSSPParser..::.MachineSequence Property
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPParser.MachineSequence]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int[,] MachineSequence { get; }

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


NrOfJobs Property

JSSPParser..::.NrOfJobs Property
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPParser.NrOfJobs]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int NrOfJobs { get; }

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


NrOfMachines Property

JSSPParser..::.NrOfMachines Property
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPParser.NrOfMachines]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int NrOfMachines { get; }

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


Operations Property

JSSPParser..::.Operations Property
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPParser.Operations]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Operations { get; }

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


ProcessingTime Property

JSSPParser..::.ProcessingTime Property
JSSPParser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.JSSPParser.ProcessingTime]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int[,] ProcessingTime { get; }

See Also

JSSPParser Class
HeuristicLab.Scheduling.JSSP Namespace


Operation Class

Operation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.Operation]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Operation : ItemBase, IComparable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Scheduling.JSSP..::.Operation

See Also

Operation Members
HeuristicLab.Scheduling.JSSP Namespace


Operation Members

[image]

HeuristicLab API Documentation
Operation Members
Operation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Operation type exposes the following members.

Constructors

Name | Description
Operation | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CompareTo |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ItemBase ..::. ToString()()().)

Properties

Name | Description
Duration |
Guid | (Inherited from StorableBase.)
Job |
Machines |
OperationIndex |
Predecessors |
Start |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Operation Constructor

[image]

HeuristicLab API Documentation
Operation Constructor
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Operation()()() |
Operation(Int32, Int32, Int32, Int32, array<Int32>[]()[], array<Int32>[]()[]) |

See Also

Operation Class
Operation Members
HeuristicLab.Scheduling.JSSP Namespace


Operation Constructor

Operation Constructor
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Operation class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Operation()

See Also

Operation Class
Operation Overload
HeuristicLab.Scheduling.JSSP Namespace


Operation Constructor (Int32, Int32, Int32, Int32, Int32[], Int32[])

Operation Constructor (Int32, Int32, Int32, Int32, array<Int32>[]()[], array<Int32>[]()[])
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Operation class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Operation(
    int job,
    int earliestStart,
    int duration,
    int operationIndex,
    int[] machines,
    int[] predecessors
)

Parameters

job
Type: System..::.Int32

[Missing <param> documentation for "job"]

earliestStart
Type: System..::.Int32

[Missing <param> documentation for "earliestStart"]

duration
Type: System..::.Int32

[Missing <param> documentation for "duration"]

operationIndex
Type: System..::.Int32

[Missing <param> documentation for "operationIndex"]

machines
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "machines"]

predecessors
Type: array< System..::.Int32 >[]()[]

[Missing <param> documentation for "predecessors"]

See Also

Operation Class
Operation Overload
HeuristicLab.Scheduling.JSSP Namespace


Operation Methods

[image]

HeuristicLab API Documentation
Operation Methods
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Operation type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CompareTo |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides ItemBase ..::. ToString()()().)

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
Operation..::.Clone Method
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Operation Class
Operation Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method (IDictionary(Guid, Object))

Operation..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Operation Class
Clone Overload
HeuristicLab.Scheduling.JSSP Namespace


CompareTo Method

Operation..::.CompareTo Method
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.CompareTo(System.Object)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int CompareTo(
    Object obj
)

Parameters

obj
Type: System..::.Object

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.CompareTo(System.Object)]

Implements

IComparable..::.CompareTo(Object)

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


CreateView Method

Operation..::.CreateView Method
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.CreateView]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.CreateView]

Implements

IViewable..::.CreateView()()()

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


GetXmlNode Method

Operation..::.GetXmlNode Method
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Populate Method

Operation..::.Populate Method
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


ToString Method

Operation..::.ToString Method
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.ToString]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Operation.ToString]

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Operation Properties

[image]

HeuristicLab API Documentation
Operation Properties
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Operation type exposes the following members.

Properties

Name | Description
Duration |
Guid | (Inherited from StorableBase.)
Job |
Machines |
OperationIndex |
Predecessors |
Start |

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Duration Property

Operation..::.Duration Property
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Operation.Duration]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Duration { get; set; }

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Job Property

Operation..::.Job Property
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Operation.Job]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Job { get; set; }

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Machines Property

Operation..::.Machines Property
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Operation.Machines]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int[] Machines { get; set; }

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


OperationIndex Property

Operation..::.OperationIndex Property
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Operation.OperationIndex]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int OperationIndex { get; set; }

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Predecessors Property

Operation..::.Predecessors Property
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Operation.Predecessors]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ItemList Predecessors { get; set; }

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


Start Property

Operation..::.Start Property
Operation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Operation.Start]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Start { get; set; }

See Also

Operation Class
HeuristicLab.Scheduling.JSSP Namespace


OperationScheduler Class

OperationScheduler Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.OperationScheduler]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperationScheduler : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.OperationScheduler

See Also

OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


OperationScheduler Members

[image]

HeuristicLab API Documentation
OperationScheduler Members
OperationScheduler Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationScheduler type exposes the following members.

Constructors

Name | Description
OperationScheduler |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
HeuristicLab.Scheduling.JSSP Namespace


OperationScheduler Constructor

OperationScheduler Constructor
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperationScheduler class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperationScheduler()

See Also

OperationScheduler Class
HeuristicLab.Scheduling.JSSP Namespace


OperationScheduler Methods

[image]

HeuristicLab API Documentation
OperationScheduler Methods
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationScheduler type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OperationScheduler Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.AddSubOperator Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

OperationScheduler..::.Apply Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationScheduler.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.OperationScheduler.Apply(HeuristicLab.Core.IScope)]

See Also

OperationScheduler Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.Clone Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.GetVariableValue Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.IsValid Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.TryAddSubOperator Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.TryAddVariable Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.TryAddVariableInfo Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.TryRemoveSubOperator Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.TryRemoveVariable Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OperationScheduler..::.TryRemoveVariableInfo Method
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
OperationScheduler Members
HeuristicLab.Scheduling.JSSP Namespace


OperationScheduler Properties

[image]

HeuristicLab API Documentation
OperationScheduler Properties
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationScheduler type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OperationScheduler Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

OperationScheduler..::.Description Property
OperationScheduler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.OperationScheduler.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OperationScheduler Class
HeuristicLab.Scheduling.JSSP Namespace


OperationScoreBase Class

OperationScoreBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.OperationScoreBase]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class OperationScoreBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.OperationScoreBase
HeuristicLab.Scheduling.JSSP..::.RemainingProcessingTime
HeuristicLab.Scheduling.JSSP..::.RemainingNrOfOperations
HeuristicLab.Scheduling.JSSP..::.ProcessingTime

See Also

OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


OperationScoreBase Members

[image]

HeuristicLab API Documentation
OperationScoreBase Members
OperationScoreBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationScoreBase type exposes the following members.

Constructors

Name | Description
OperationScoreBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
HeuristicLab.Scheduling.JSSP Namespace


OperationScoreBase Constructor

OperationScoreBase Constructor
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperationScoreBase class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperationScoreBase()

See Also

OperationScoreBase Class
HeuristicLab.Scheduling.JSSP Namespace


OperationScoreBase Methods

[image]

HeuristicLab API Documentation
OperationScoreBase Methods
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationScoreBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OperationScoreBase Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.AddSubOperator Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

OperationScoreBase..::.Apply Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationScoreBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.OperationScoreBase.Apply(HeuristicLab.Core.IScope)]

See Also

OperationScoreBase Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.Clone Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


GetOpScore Method

OperationScoreBase..::.GetOpScore Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationScoreBase.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract double GetOpScore(
    IScope unscheduled,
    Operation op,
    Schedule s
)

Parameters

unscheduled
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "unscheduled"]

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

s
Type: HeuristicLab.Scheduling.JSSP..::.Schedule

[Missing <param> documentation for "s"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.OperationScoreBase.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

See Also

OperationScoreBase Class
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.GetVariableValue Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.IsValid Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.TryAddSubOperator Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.TryAddVariable Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.TryAddVariableInfo Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.TryRemoveSubOperator Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.TryRemoveVariable Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OperationScoreBase..::.TryRemoveVariableInfo Method
OperationScoreBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationScoreBase Class
OperationScoreBase Members
HeuristicLab.Scheduling.JSSP Namespace


OperationUpdater Class

OperationUpdater Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.OperationUpdater]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperationUpdater : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.OperationUpdater

See Also

OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


OperationUpdater Members

[image]

HeuristicLab API Documentation
OperationUpdater Members
OperationUpdater Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationUpdater type exposes the following members.

Constructors

Name | Description
OperationUpdater |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
HeuristicLab.Scheduling.JSSP Namespace


OperationUpdater Constructor

OperationUpdater Constructor
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperationUpdater class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperationUpdater()

See Also

OperationUpdater Class
HeuristicLab.Scheduling.JSSP Namespace


OperationUpdater Methods

[image]

HeuristicLab API Documentation
OperationUpdater Methods
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationUpdater type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OperationUpdater Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.AddSubOperator Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

OperationUpdater..::.Apply Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationUpdater.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.OperationUpdater.Apply(HeuristicLab.Core.IScope)]

See Also

OperationUpdater Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.Clone Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.GetVariableValue Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.IsValid Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.TryAddSubOperator Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.TryAddVariable Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.TryAddVariableInfo Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.TryRemoveSubOperator Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.TryRemoveVariable Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OperationUpdater..::.TryRemoveVariableInfo Method
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
OperationUpdater Members
HeuristicLab.Scheduling.JSSP Namespace


OperationUpdater Properties

[image]

HeuristicLab API Documentation
OperationUpdater Properties
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationUpdater type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OperationUpdater Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

OperationUpdater..::.Description Property
OperationUpdater Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.OperationUpdater.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OperationUpdater Class
HeuristicLab.Scheduling.JSSP Namespace


OperationView Class

OperationView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.OperationView]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OperationView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Scheduling.JSSP..::.OperationView

See Also

OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


OperationView Members

[image]

HeuristicLab API Documentation
OperationView Members
OperationView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationView type exposes the following members.

Constructors

Name | Description
OperationView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operation |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


OperationView Constructor

[image]

HeuristicLab API Documentation
OperationView Constructor
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
OperationView()()() |
OperationView(Operation) |

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


OperationView Constructor

OperationView Constructor
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperationView class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperationView()

See Also

OperationView Class
OperationView Overload
HeuristicLab.Scheduling.JSSP Namespace


OperationView Constructor (Operation)

OperationView Constructor (Operation)
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperationView class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperationView(
    Operation operation
)

Parameters

operation
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "operation"]

See Also

OperationView Class
OperationView Overload
HeuristicLab.Scheduling.JSSP Namespace


OperationView Methods

[image]

HeuristicLab API Documentation
OperationView Methods
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
OperationView..::.AccessibilityNotifyClients Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


AddItemEvents Method

OperationView..::.AddItemEvents Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationView.AddItemEvents]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
OperationView..::.BeginInvoke Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


Dispose Method

[image]

HeuristicLab API Documentation
OperationView..::.Dispose Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


Dispose Method (Boolean)

OperationView..::.Dispose Method (Boolean)
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

OperationView Class
Dispose Overload
HeuristicLab.Scheduling.JSSP Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
OperationView..::.GetChildAtPoint Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
OperationView..::.Invalidate Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


Invoke Method

[image]

HeuristicLab API Documentation
OperationView..::.Invoke Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
OperationView..::.MemberwiseClone Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
OperationView..::.PerformLayout Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


RemoveItemEvents Method

OperationView..::.RemoveItemEvents Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationView.RemoveItemEvents]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
OperationView..::.ResumeLayout Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
OperationView..::.RtlTranslateAlignment Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


Scale Method

[image]

HeuristicLab API Documentation
OperationView..::.Scale Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


Select Method

[image]

HeuristicLab API Documentation
OperationView..::.Select Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
OperationView..::.SetBounds Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
OperationView..::.UpdateBounds Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


UpdateControls Method

OperationView..::.UpdateControls Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.OperationView.UpdateControls]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


Validate Method

[image]

HeuristicLab API Documentation
OperationView..::.Validate Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
OperationView..::.ValidateChildren Method
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

OperationView Class
OperationView Members
HeuristicLab.Scheduling.JSSP Namespace


OperationView Properties

[image]

HeuristicLab API Documentation
OperationView Properties
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperationView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Operation |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


Operation Property

OperationView..::.Operation Property
OperationView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.OperationView.Operation]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Operation Operation { get; set; }

See Also

OperationView Class
HeuristicLab.Scheduling.JSSP Namespace


ProcessingTime Class

ProcessingTime Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.ProcessingTime]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ProcessingTime : OperationScoreBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.OperationScoreBase
HeuristicLab.Scheduling.JSSP..::.ProcessingTime

See Also

ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


ProcessingTime Members

[image]

HeuristicLab API Documentation
ProcessingTime Members
ProcessingTime Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProcessingTime type exposes the following members.

Constructors

Name | Description
ProcessingTime |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from OperationScoreBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore | (Overrides OperationScoreBase ..::. GetOpScore(IScope, Operation, Schedule).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


ProcessingTime Constructor

ProcessingTime Constructor
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProcessingTime class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProcessingTime()

See Also

ProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


ProcessingTime Methods

[image]

HeuristicLab API Documentation
ProcessingTime Methods
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProcessingTime type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from OperationScoreBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore | (Overrides OperationScoreBase ..::. GetOpScore(IScope, Operation, Schedule).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.AddSubOperator Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.Clone Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


GetOpScore Method

ProcessingTime..::.GetOpScore Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ProcessingTime.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double GetOpScore(
    IScope unscheduled,
    Operation op,
    Schedule s
)

Parameters

unscheduled
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "unscheduled"]

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

s
Type: HeuristicLab.Scheduling.JSSP..::.Schedule

[Missing <param> documentation for "s"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ProcessingTime.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

See Also

ProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.GetVariableValue Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.IsValid Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.TryAddSubOperator Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.TryAddVariable Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.TryAddVariableInfo Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.TryRemoveSubOperator Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.TryRemoveVariable Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ProcessingTime..::.TryRemoveVariableInfo Method
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
ProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


ProcessingTime Properties

[image]

HeuristicLab API Documentation
ProcessingTime Properties
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProcessingTime type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

ProcessingTime..::.Description Property
ProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ProcessingTime.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


RemainingNrOfOperations Class

RemainingNrOfOperations Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.RemainingNrOfOperations]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RemainingNrOfOperations : OperationScoreBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.OperationScoreBase
HeuristicLab.Scheduling.JSSP..::.RemainingNrOfOperations

See Also

RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


RemainingNrOfOperations Members

[image]

HeuristicLab API Documentation
RemainingNrOfOperations Members
RemainingNrOfOperations Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RemainingNrOfOperations type exposes the following members.

Constructors

Name | Description
RemainingNrOfOperations |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from OperationScoreBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore | (Overrides OperationScoreBase ..::. GetOpScore(IScope, Operation, Schedule).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
HeuristicLab.Scheduling.JSSP Namespace


RemainingNrOfOperations Constructor

RemainingNrOfOperations Constructor
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RemainingNrOfOperations class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RemainingNrOfOperations()

See Also

RemainingNrOfOperations Class
HeuristicLab.Scheduling.JSSP Namespace


RemainingNrOfOperations Methods

[image]

HeuristicLab API Documentation
RemainingNrOfOperations Methods
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RemainingNrOfOperations type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from OperationScoreBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore | (Overrides OperationScoreBase ..::. GetOpScore(IScope, Operation, Schedule).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RemainingNrOfOperations Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.AddSubOperator Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.Clone Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


GetOpScore Method

RemainingNrOfOperations..::.GetOpScore Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.RemainingNrOfOperations.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double GetOpScore(
    IScope unscheduled,
    Operation op,
    Schedule s
)

Parameters

unscheduled
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "unscheduled"]

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

s
Type: HeuristicLab.Scheduling.JSSP..::.Schedule

[Missing <param> documentation for "s"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.RemainingNrOfOperations.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

See Also

RemainingNrOfOperations Class
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.GetVariableValue Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.IsValid Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.TryAddSubOperator Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.TryAddVariable Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.TryAddVariableInfo Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.TryRemoveSubOperator Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.TryRemoveVariable Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RemainingNrOfOperations..::.TryRemoveVariableInfo Method
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
RemainingNrOfOperations Members
HeuristicLab.Scheduling.JSSP Namespace


RemainingNrOfOperations Properties

[image]

HeuristicLab API Documentation
RemainingNrOfOperations Properties
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RemainingNrOfOperations type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RemainingNrOfOperations Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

RemainingNrOfOperations..::.Description Property
RemainingNrOfOperations Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.RemainingNrOfOperations.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RemainingNrOfOperations Class
HeuristicLab.Scheduling.JSSP Namespace


RemainingProcessingTime Class

RemainingProcessingTime Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.RemainingProcessingTime]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RemainingProcessingTime : OperationScoreBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.OperationScoreBase
HeuristicLab.Scheduling.JSSP..::.RemainingProcessingTime

See Also

RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


RemainingProcessingTime Members

[image]

HeuristicLab API Documentation
RemainingProcessingTime Members
RemainingProcessingTime Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RemainingProcessingTime type exposes the following members.

Constructors

Name | Description
RemainingProcessingTime |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from OperationScoreBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore | (Overrides OperationScoreBase ..::. GetOpScore(IScope, Operation, Schedule).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


RemainingProcessingTime Constructor

RemainingProcessingTime Constructor
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RemainingProcessingTime class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RemainingProcessingTime()

See Also

RemainingProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


RemainingProcessingTime Methods

[image]

HeuristicLab API Documentation
RemainingProcessingTime Methods
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RemainingProcessingTime type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from OperationScoreBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOpScore | (Overrides OperationScoreBase ..::. GetOpScore(IScope, Operation, Schedule).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RemainingProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.AddSubOperator Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.Clone Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


GetOpScore Method

RemainingProcessingTime..::.GetOpScore Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.RemainingProcessingTime.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override double GetOpScore(
    IScope unscheduled,
    Operation op,
    Schedule s
)

Parameters

unscheduled
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "unscheduled"]

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

s
Type: HeuristicLab.Scheduling.JSSP..::.Schedule

[Missing <param> documentation for "s"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.RemainingProcessingTime.GetOpScore(HeuristicLab.Core.IScope,HeuristicLab.Scheduling.JSSP.Operation,HeuristicLab.Scheduling.JSSP.Schedule)]

See Also

RemainingProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.GetVariableValue Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.IsValid Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.TryAddSubOperator Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.TryAddVariable Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.TryAddVariableInfo Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.TryRemoveSubOperator Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.TryRemoveVariable Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RemainingProcessingTime..::.TryRemoveVariableInfo Method
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
RemainingProcessingTime Members
HeuristicLab.Scheduling.JSSP Namespace


RemainingProcessingTime Properties

[image]

HeuristicLab API Documentation
RemainingProcessingTime Properties
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RemainingProcessingTime type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RemainingProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

RemainingProcessingTime..::.Description Property
RemainingProcessingTime Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.RemainingProcessingTime.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RemainingProcessingTime Class
HeuristicLab.Scheduling.JSSP Namespace


Schedule Class

Schedule Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.Schedule]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class Schedule : ItemBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Scheduling.JSSP..::.Schedule

See Also

Schedule Members
HeuristicLab.Scheduling.JSSP Namespace


Schedule Members

[image]

HeuristicLab API Documentation
Schedule Members
Schedule Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Schedule type exposes the following members.

Constructors

Name | Description
Schedule | Overloaded.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMachineSchedule |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ScheduleOperation |
ToString | (Overrides ItemBase ..::. ToString()()().)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Machines |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


Schedule Constructor

[image]

HeuristicLab API Documentation
Schedule Constructor
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Schedule()()() |
Schedule(Int32, Int32) |

See Also

Schedule Class
Schedule Members
HeuristicLab.Scheduling.JSSP Namespace


Schedule Constructor

Schedule Constructor
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schedule class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Schedule()

See Also

Schedule Class
Schedule Overload
HeuristicLab.Scheduling.JSSP Namespace


Schedule Constructor (Int32, Int32)

Schedule Constructor (Int32, Int32)
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Schedule class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Schedule(
    int nrOfMachines,
    int timeSpan
)

Parameters

nrOfMachines
Type: System..::.Int32

[Missing <param> documentation for "nrOfMachines"]

timeSpan
Type: System..::.Int32

[Missing <param> documentation for "timeSpan"]

See Also

Schedule Class
Schedule Overload
HeuristicLab.Scheduling.JSSP Namespace


Schedule Methods

[image]

HeuristicLab API Documentation
Schedule Methods
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Schedule type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateView | (Inherited from ItemBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMachineSchedule |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ScheduleOperation |
ToString | (Overrides ItemBase ..::. ToString()()().)

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
Schedule..::.Clone Method
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

Schedule Class
Schedule Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method (IDictionary(Guid, Object))

Schedule..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

Schedule Class
Clone Overload
HeuristicLab.Scheduling.JSSP Namespace


GetMachineSchedule Method

Schedule..::.GetMachineSchedule Method
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.GetMachineSchedule(System.Int32)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTree GetMachineSchedule(
    int machineIndex
)

Parameters

machineIndex
Type: System..::.Int32

[Missing <param> documentation for "machineIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.GetMachineSchedule(System.Int32)]

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


GetXmlNode Method

Schedule..::.GetXmlNode Method
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


Populate Method

Schedule..::.Populate Method
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleOperation Method

Schedule..::.ScheduleOperation Method
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.ScheduleOperation(HeuristicLab.Scheduling.JSSP.Operation)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int ScheduleOperation(
    Operation op
)

Parameters

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.ScheduleOperation(HeuristicLab.Scheduling.JSSP.Operation)]

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


ToString Method

Schedule..::.ToString Method
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.ToString]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.Schedule.ToString]

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


Schedule Properties

[image]

HeuristicLab API Documentation
Schedule Properties
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Schedule type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Machines |

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


Machines Property

Schedule..::.Machines Property
Schedule Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.Schedule.Machines]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Machines { get; }

See Also

Schedule Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleInjector Class

ScheduleInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.ScheduleInjector]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScheduleInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Scheduling.JSSP..::.ScheduleInjector

See Also

ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


ScheduleInjector Members

[image]

HeuristicLab API Documentation
ScheduleInjector Members
ScheduleInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleInjector type exposes the following members.

Constructors

Name | Description
ScheduleInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
Schedule |
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleInjector Constructor

ScheduleInjector Constructor
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScheduleInjector class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleInjector()

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleInjector Methods

[image]

HeuristicLab API Documentation
ScheduleInjector Methods
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Overrides OperatorBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Overrides OperatorBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.AddSubOperator Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


Apply Method

ScheduleInjector..::.Apply Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Apply(HeuristicLab.Core.IScope)]

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.Clone Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides OperatorBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method (IDictionary(Guid, Object))

ScheduleInjector..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ScheduleInjector Class
Clone Overload
HeuristicLab.Scheduling.JSSP Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.GetVariableValue Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


GetXmlNode Method

ScheduleInjector..::.GetXmlNode Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.IsValid Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


Populate Method

ScheduleInjector..::.Populate Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.TryAddSubOperator Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.TryAddVariable Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.TryAddVariableInfo Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.TryRemoveSubOperator Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.TryRemoveVariable Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ScheduleInjector..::.TryRemoveVariableInfo Method
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
ScheduleInjector Members
HeuristicLab.Scheduling.JSSP Namespace


ScheduleInjector Properties

[image]

HeuristicLab API Documentation
ScheduleInjector Properties
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
Schedule |
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


Description Property

ScheduleInjector..::.Description Property
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Description]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


Schedule Property

ScheduleInjector..::.Schedule Property
ScheduleInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleInjector.Schedule]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Schedule Schedule { get; }

See Also

ScheduleInjector Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Class

ScheduleTree Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.ScheduleTree]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScheduleTree : StorableBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Scheduling.JSSP..::.ScheduleTree

See Also

ScheduleTree Members
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Members

[image]

HeuristicLab API Documentation
ScheduleTree Members
ScheduleTree Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleTree type exposes the following members.

Constructors

Name | Description
ScheduleTree | Overloaded.

Methods

Name | Description
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
Insert |
IsLeaf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
InOrder |
Root |
Timespan |

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Constructor

[image]

HeuristicLab API Documentation
ScheduleTree Constructor
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ScheduleTree()()() |
ScheduleTree(Int32) |

See Also

ScheduleTree Class
ScheduleTree Members
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Constructor

ScheduleTree Constructor
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScheduleTree class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTree()

See Also

ScheduleTree Class
ScheduleTree Overload
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Constructor (Int32)

ScheduleTree Constructor (Int32)
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScheduleTree class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTree(
    int timespan
)

Parameters

timespan
Type: System..::.Int32

[Missing <param> documentation for "timespan"]

See Also

ScheduleTree Class
ScheduleTree Overload
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Methods

[image]

HeuristicLab API Documentation
ScheduleTree Methods
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleTree type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
Insert |
IsLeaf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Overrides Object ..::. ToString()()().)

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


Clone Method

[image]

HeuristicLab API Documentation
ScheduleTree..::.Clone Method
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ScheduleTree Class
ScheduleTree Members
HeuristicLab.Scheduling.JSSP Namespace


Clone Method (IDictionary(Guid, Object))

ScheduleTree..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ScheduleTree Class
Clone Overload
HeuristicLab.Scheduling.JSSP Namespace


GetXmlNode Method

ScheduleTree..::.GetXmlNode Method
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


Insert Method

ScheduleTree..::.Insert Method
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.Insert(HeuristicLab.Scheduling.JSSP.Operation)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Insert(
    Operation op
)

Parameters

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.Insert(HeuristicLab.Scheduling.JSSP.Operation)]

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


IsLeaf Method

ScheduleTree..::.IsLeaf Method
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.IsLeaf(HeuristicLab.Scheduling.JSSP.ScheduleTreeNode)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool IsLeaf(
    ScheduleTreeNode slot
)

Parameters

slot
Type: HeuristicLab.Scheduling.JSSP..::.ScheduleTreeNode

[Missing <param> documentation for "slot"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.IsLeaf(HeuristicLab.Scheduling.JSSP.ScheduleTreeNode)]

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


Populate Method

ScheduleTree..::.Populate Method
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


ToString Method

ScheduleTree..::.ToString Method
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.ToString]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTree.ToString]

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTree Properties

[image]

HeuristicLab API Documentation
ScheduleTree Properties
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleTree type exposes the following members.

Properties

Name | Description
Guid | (Inherited from StorableBase.)
InOrder |
Root |
Timespan |

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


InOrder Property

ScheduleTree..::.InOrder Property
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTree.InOrder]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEnumerable<ScheduleTreeNode> InOrder { get; }

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


Root Property

ScheduleTree..::.Root Property
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTree.Root]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTreeNode Root { get; }

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


Timespan Property

ScheduleTree..::.Timespan Property
ScheduleTree Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTree.Timespan]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Timespan { get; }

See Also

ScheduleTree Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTreeNode Class

ScheduleTreeNode Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ScheduleTreeNode

Inheritance Hierarchy

System..::.Object
HeuristicLab.Scheduling.JSSP..::.ScheduleTreeNode

See Also

ScheduleTreeNode Members
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTreeNode Members

[image]

HeuristicLab API Documentation
ScheduleTreeNode Members
ScheduleTreeNode Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleTreeNode type exposes the following members.

Constructors

Name | Description
ScheduleTreeNode |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetLeft |
SetRight |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Data |
Left |
Parent |
Right |

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTreeNode Constructor

ScheduleTreeNode Constructor
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ScheduleTreeNode class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTreeNode(
    TimeSlot t
)

Parameters

t
Type: HeuristicLab.Scheduling.JSSP..::.TimeSlot

[Missing <param> documentation for "t"]

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTreeNode Methods

[image]

HeuristicLab API Documentation
ScheduleTreeNode Methods
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleTreeNode type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetLeft |
SetRight |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


SetLeft Method

ScheduleTreeNode..::.SetLeft Method
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode.SetLeft(HeuristicLab.Scheduling.JSSP.ScheduleTreeNode)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetLeft(
    ScheduleTreeNode child
)

Parameters

child
Type: HeuristicLab.Scheduling.JSSP..::.ScheduleTreeNode

[Missing <param> documentation for "child"]

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


SetRight Method

ScheduleTreeNode..::.SetRight Method
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode.SetRight(HeuristicLab.Scheduling.JSSP.ScheduleTreeNode)]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void SetRight(
    ScheduleTreeNode child
)

Parameters

child
Type: HeuristicLab.Scheduling.JSSP..::.ScheduleTreeNode

[Missing <param> documentation for "child"]

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


ScheduleTreeNode Properties

[image]

HeuristicLab API Documentation
ScheduleTreeNode Properties
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScheduleTreeNode type exposes the following members.

Properties

Name | Description
Data |
Left |
Parent |
Right |

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


Data Property

ScheduleTreeNode..::.Data Property
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode.Data]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TimeSlot Data { get; set; }

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


Left Property

ScheduleTreeNode..::.Left Property
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode.Left]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTreeNode Left { get; set; }

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


Parent Property

ScheduleTreeNode..::.Parent Property
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode.Parent]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTreeNode Parent { get; set; }

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


Right Property

ScheduleTreeNode..::.Right Property
ScheduleTreeNode Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.ScheduleTreeNode.Right]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ScheduleTreeNode Right { get; set; }

See Also

ScheduleTreeNode Class
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Class

TimeSlot Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Scheduling.JSSP.TimeSlot]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TimeSlot

Inheritance Hierarchy

System..::.Object
HeuristicLab.Scheduling.JSSP..::.TimeSlot

See Also

TimeSlot Members
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Members

[image]

HeuristicLab API Documentation
TimeSlot Members
TimeSlot Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TimeSlot type exposes the following members.

Constructors

Name | Description
TimeSlot | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)

Fields

Name | Description
end |
free |
maxFreeSlot |
operation |
start |

Properties

Name | Description
job |

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Constructor

[image]

HeuristicLab API Documentation
TimeSlot Constructor
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TimeSlot(String) |
TimeSlot(Operation) |
TimeSlot(Int32, Int32) |

See Also

TimeSlot Class
TimeSlot Members
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Constructor (String)

TimeSlot Constructor (String)
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeSlot class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TimeSlot(
    string s
)

Parameters

s
Type: System..::.String

[Missing <param> documentation for "s"]

See Also

TimeSlot Class
TimeSlot Overload
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Constructor (Operation)

TimeSlot Constructor (Operation)
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeSlot class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TimeSlot(
    Operation op
)

Parameters

op
Type: HeuristicLab.Scheduling.JSSP..::.Operation

[Missing <param> documentation for "op"]

See Also

TimeSlot Class
TimeSlot Overload
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Constructor (Int32, Int32)

TimeSlot Constructor (Int32, Int32)
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TimeSlot class.

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TimeSlot(
    int start,
    int end
)

Parameters

start
Type: System..::.Int32

[Missing <param> documentation for "start"]

end
Type: System..::.Int32

[Missing <param> documentation for "end"]

See Also

TimeSlot Class
TimeSlot Overload
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Fields

[image]

HeuristicLab API Documentation
TimeSlot Fields
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TimeSlot type exposes the following members.

Fields

Name | Description
end |
free |
maxFreeSlot |
operation |
start |

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


end Field

TimeSlot..::.end Field
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Scheduling.JSSP.TimeSlot.end]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int end

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


free Field

TimeSlot..::.free Field
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Scheduling.JSSP.TimeSlot.free]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int free

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


maxFreeSlot Field

TimeSlot..::.maxFreeSlot Field
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Scheduling.JSSP.TimeSlot.maxFreeSlot]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int maxFreeSlot

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


operation Field

TimeSlot..::.operation Field
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Scheduling.JSSP.TimeSlot.operation]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Operation operation

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


start Field

TimeSlot..::.start Field
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Scheduling.JSSP.TimeSlot.start]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int start

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Methods

[image]

HeuristicLab API Documentation
TimeSlot Methods
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TimeSlot type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object ..::. ToString()()().)

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


ToString Method

TimeSlot..::.ToString Method
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Scheduling.JSSP.TimeSlot.ToString]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string ToString()

Return Value

[Missing <returns> documentation for M:HeuristicLab.Scheduling.JSSP.TimeSlot.ToString]

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


TimeSlot Properties

[image]

HeuristicLab API Documentation
TimeSlot Properties
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TimeSlot type exposes the following members.

Properties

Name | Description
job |

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


job Property

TimeSlot..::.job Property
TimeSlot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Scheduling.JSSP.TimeSlot.job]

Namespace: HeuristicLab.Scheduling.JSSP
Assembly: HeuristicLab.Scheduling.JSSP (in HeuristicLab.Scheduling.JSSP.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int job { get; }

See Also

TimeSlot Class
HeuristicLab.Scheduling.JSSP Namespace


HeuristicLab.Selection Namespace

HeuristicLab.Selection Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Selection]

Classes

Class | Description
HeuristicLabSelectionPlugin |
LeftReducer |
LeftSelector |
LinearRankSelector |
MergingReducer |
ProportionalSelector |
RandomSelector |
ReducerBase |
RightChildReducer |
RightReducer |
RightSelector |
SelectorBase |
StochasticSelectorBase |
TournamentSelector |


HeuristicLabSelectionPlugin Class

HeuristicLabSelectionPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.HeuristicLabSelectionPlugin]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.Selection")]
[PluginFileAttribute(Filename = "HeuristicLab.Selection.dll", Filetype = PluginFileType.Assembly)]
public class HeuristicLabSelectionPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Selection..::.HeuristicLabSelectionPlugin

See Also

HeuristicLabSelectionPlugin Members
HeuristicLab.Selection Namespace


HeuristicLabSelectionPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabSelectionPlugin Members
HeuristicLabSelectionPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabSelectionPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabSelectionPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabSelectionPlugin Class
HeuristicLab.Selection Namespace


HeuristicLabSelectionPlugin Constructor

HeuristicLabSelectionPlugin Constructor
HeuristicLabSelectionPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabSelectionPlugin class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabSelectionPlugin()

See Also

HeuristicLabSelectionPlugin Class
HeuristicLab.Selection Namespace


LeftReducer Class

LeftReducer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.LeftReducer]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LeftReducer : ReducerBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.ReducerBase
HeuristicLab.Selection..::.LeftReducer

See Also

LeftReducer Members
HeuristicLab.Selection Namespace


LeftReducer Members

[image]

HeuristicLab API Documentation
LeftReducer Members
LeftReducer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LeftReducer type exposes the following members.

Constructors

Name | Description
LeftReducer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LeftReducer Class
HeuristicLab.Selection Namespace


LeftReducer Constructor

LeftReducer Constructor
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LeftReducer class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LeftReducer()

See Also

LeftReducer Class
HeuristicLab.Selection Namespace


LeftReducer Methods

[image]

HeuristicLab API Documentation
LeftReducer Methods
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LeftReducer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LeftReducer Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LeftReducer..::.AddSubOperator Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
LeftReducer..::.Clone Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LeftReducer..::.GetVariableValue Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LeftReducer..::.IsValid Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


Reduce Method

LeftReducer..::.Reduce Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.LeftReducer.Reduce(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override ICollection<IScope> Reduce(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.LeftReducer.Reduce(HeuristicLab.Core.IScope)]

See Also

LeftReducer Class
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LeftReducer..::.TryAddSubOperator Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LeftReducer..::.TryAddVariable Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LeftReducer..::.TryAddVariableInfo Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LeftReducer..::.TryRemoveSubOperator Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LeftReducer..::.TryRemoveVariable Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LeftReducer..::.TryRemoveVariableInfo Method
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftReducer Class
LeftReducer Members
HeuristicLab.Selection Namespace


LeftReducer Properties

[image]

HeuristicLab API Documentation
LeftReducer Properties
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LeftReducer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

LeftReducer Class
HeuristicLab.Selection Namespace


Description Property

LeftReducer..::.Description Property
LeftReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.LeftReducer.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LeftReducer Class
HeuristicLab.Selection Namespace


LeftSelector Class

LeftSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.LeftSelector]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LeftSelector : StochasticSelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.LeftSelector

See Also

LeftSelector Members
HeuristicLab.Selection Namespace


LeftSelector Members

[image]

HeuristicLab API Documentation
LeftSelector Members
LeftSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LeftSelector type exposes the following members.

Constructors

Name | Description
LeftSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LeftSelector Class
HeuristicLab.Selection Namespace


LeftSelector Constructor

LeftSelector Constructor
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LeftSelector class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LeftSelector()

See Also

LeftSelector Class
HeuristicLab.Selection Namespace


LeftSelector Methods

[image]

HeuristicLab API Documentation
LeftSelector Methods
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LeftSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LeftSelector Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LeftSelector..::.AddSubOperator Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
LeftSelector..::.Clone Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LeftSelector..::.GetVariableValue Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LeftSelector..::.IsValid Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
LeftSelector..::.Select Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Inherited from StochasticSelectorBase.)
Select(IRandom, IScope, Int32, IScope, Boolean) | (Overrides StochasticSelectorBase ..::. Select(IRandom, IScope, Int32, IScope, Boolean).)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

LeftSelector..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.LeftSelector.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

LeftSelector Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LeftSelector..::.TryAddSubOperator Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LeftSelector..::.TryAddVariable Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LeftSelector..::.TryAddVariableInfo Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LeftSelector..::.TryRemoveSubOperator Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LeftSelector..::.TryRemoveVariable Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LeftSelector..::.TryRemoveVariableInfo Method
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LeftSelector Class
LeftSelector Members
HeuristicLab.Selection Namespace


LeftSelector Properties

[image]

HeuristicLab API Documentation
LeftSelector Properties
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LeftSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

LeftSelector Class
HeuristicLab.Selection Namespace


Description Property

LeftSelector..::.Description Property
LeftSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.LeftSelector.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LeftSelector Class
HeuristicLab.Selection Namespace


LinearRankSelector Class

LinearRankSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.LinearRankSelector]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class LinearRankSelector : StochasticSelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.LinearRankSelector

See Also

LinearRankSelector Members
HeuristicLab.Selection Namespace


LinearRankSelector Members

[image]

HeuristicLab API Documentation
LinearRankSelector Members
LinearRankSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearRankSelector type exposes the following members.

Constructors

Name | Description
LinearRankSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
HeuristicLab.Selection Namespace


LinearRankSelector Constructor

LinearRankSelector Constructor
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LinearRankSelector class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public LinearRankSelector()

See Also

LinearRankSelector Class
HeuristicLab.Selection Namespace


LinearRankSelector Methods

[image]

HeuristicLab API Documentation
LinearRankSelector Methods
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearRankSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

LinearRankSelector Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.AddSubOperator Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.Clone Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.GetVariableValue Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.IsValid Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.Select Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Inherited from StochasticSelectorBase.)
Select(IRandom, IScope, Int32, IScope, Boolean) | (Overrides StochasticSelectorBase ..::. Select(IRandom, IScope, Int32, IScope, Boolean).)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

LinearRankSelector..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.LinearRankSelector.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

LinearRankSelector Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.TryAddSubOperator Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.TryAddVariable Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.TryAddVariableInfo Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.TryRemoveSubOperator Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.TryRemoveVariable Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
LinearRankSelector..::.TryRemoveVariableInfo Method
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
LinearRankSelector Members
HeuristicLab.Selection Namespace


LinearRankSelector Properties

[image]

HeuristicLab API Documentation
LinearRankSelector Properties
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinearRankSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

LinearRankSelector Class
HeuristicLab.Selection Namespace


Description Property

LinearRankSelector..::.Description Property
LinearRankSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.LinearRankSelector.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

LinearRankSelector Class
HeuristicLab.Selection Namespace


MergingReducer Class

MergingReducer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.MergingReducer]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MergingReducer : ReducerBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.ReducerBase
HeuristicLab.Selection..::.MergingReducer

See Also

MergingReducer Members
HeuristicLab.Selection Namespace


MergingReducer Members

[image]

HeuristicLab API Documentation
MergingReducer Members
MergingReducer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MergingReducer type exposes the following members.

Constructors

Name | Description
MergingReducer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

MergingReducer Class
HeuristicLab.Selection Namespace


MergingReducer Constructor

MergingReducer Constructor
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MergingReducer class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MergingReducer()

See Also

MergingReducer Class
HeuristicLab.Selection Namespace


MergingReducer Methods

[image]

HeuristicLab API Documentation
MergingReducer Methods
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MergingReducer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

MergingReducer Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
MergingReducer..::.AddSubOperator Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
MergingReducer..::.Clone Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
MergingReducer..::.GetVariableValue Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
MergingReducer..::.IsValid Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


Reduce Method

MergingReducer..::.Reduce Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.MergingReducer.Reduce(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override ICollection<IScope> Reduce(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.MergingReducer.Reduce(HeuristicLab.Core.IScope)]

See Also

MergingReducer Class
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
MergingReducer..::.TryAddSubOperator Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
MergingReducer..::.TryAddVariable Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
MergingReducer..::.TryAddVariableInfo Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
MergingReducer..::.TryRemoveSubOperator Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
MergingReducer..::.TryRemoveVariable Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
MergingReducer..::.TryRemoveVariableInfo Method
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MergingReducer Class
MergingReducer Members
HeuristicLab.Selection Namespace


MergingReducer Properties

[image]

HeuristicLab API Documentation
MergingReducer Properties
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MergingReducer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

MergingReducer Class
HeuristicLab.Selection Namespace


Description Property

MergingReducer..::.Description Property
MergingReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.MergingReducer.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

MergingReducer Class
HeuristicLab.Selection Namespace


ProportionalSelector Class

ProportionalSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.ProportionalSelector]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ProportionalSelector : StochasticSelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.ProportionalSelector

See Also

ProportionalSelector Members
HeuristicLab.Selection Namespace


ProportionalSelector Members

[image]

HeuristicLab API Documentation
ProportionalSelector Members
ProportionalSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProportionalSelector type exposes the following members.

Constructors

Name | Description
ProportionalSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
HeuristicLab.Selection Namespace


ProportionalSelector Constructor

ProportionalSelector Constructor
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ProportionalSelector class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ProportionalSelector()

See Also

ProportionalSelector Class
HeuristicLab.Selection Namespace


ProportionalSelector Methods

[image]

HeuristicLab API Documentation
ProportionalSelector Methods
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProportionalSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ProportionalSelector Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.AddSubOperator Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.Clone Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.GetVariableValue Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.IsValid Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.Select Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Inherited from StochasticSelectorBase.)
Select(IRandom, IScope, Int32, IScope, Boolean) | (Overrides StochasticSelectorBase ..::. Select(IRandom, IScope, Int32, IScope, Boolean).)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

ProportionalSelector..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.ProportionalSelector.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

ProportionalSelector Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.TryAddSubOperator Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.TryAddVariable Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.TryAddVariableInfo Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.TryRemoveSubOperator Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.TryRemoveVariable Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ProportionalSelector..::.TryRemoveVariableInfo Method
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
ProportionalSelector Members
HeuristicLab.Selection Namespace


ProportionalSelector Properties

[image]

HeuristicLab API Documentation
ProportionalSelector Properties
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProportionalSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

ProportionalSelector Class
HeuristicLab.Selection Namespace


Description Property

ProportionalSelector..::.Description Property
ProportionalSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.ProportionalSelector.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

ProportionalSelector Class
HeuristicLab.Selection Namespace


RandomSelector Class

RandomSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.RandomSelector]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RandomSelector : StochasticSelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.RandomSelector

See Also

RandomSelector Members
HeuristicLab.Selection Namespace


RandomSelector Members

[image]

HeuristicLab API Documentation
RandomSelector Members
RandomSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomSelector type exposes the following members.

Constructors

Name | Description
RandomSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RandomSelector Class
HeuristicLab.Selection Namespace


RandomSelector Constructor

RandomSelector Constructor
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomSelector class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RandomSelector()

See Also

RandomSelector Class
HeuristicLab.Selection Namespace


RandomSelector Methods

[image]

HeuristicLab API Documentation
RandomSelector Methods
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RandomSelector Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RandomSelector..::.AddSubOperator Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
RandomSelector..::.Clone Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RandomSelector..::.GetVariableValue Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RandomSelector..::.IsValid Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
RandomSelector..::.Select Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Inherited from StochasticSelectorBase.)
Select(IRandom, IScope, Int32, IScope, Boolean) | (Overrides StochasticSelectorBase ..::. Select(IRandom, IScope, Int32, IScope, Boolean).)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

RandomSelector..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.RandomSelector.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

RandomSelector Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RandomSelector..::.TryAddSubOperator Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RandomSelector..::.TryAddVariable Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RandomSelector..::.TryAddVariableInfo Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RandomSelector..::.TryRemoveSubOperator Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RandomSelector..::.TryRemoveVariable Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RandomSelector..::.TryRemoveVariableInfo Method
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomSelector Class
RandomSelector Members
HeuristicLab.Selection Namespace


RandomSelector Properties

[image]

HeuristicLab API Documentation
RandomSelector Properties
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RandomSelector Class
HeuristicLab.Selection Namespace


Description Property

RandomSelector..::.Description Property
RandomSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.RandomSelector.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RandomSelector Class
HeuristicLab.Selection Namespace


ReducerBase Class

ReducerBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.ReducerBase]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class ReducerBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.ReducerBase
HeuristicLab.Selection..::.RightChildReducer
HeuristicLab.Selection..::.RightReducer
HeuristicLab.Selection..::.LeftReducer
HeuristicLab.Selection..::.MergingReducer

See Also

ReducerBase Members
HeuristicLab.Selection Namespace


ReducerBase Members

[image]

HeuristicLab API Documentation
ReducerBase Members
ReducerBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReducerBase type exposes the following members.

Constructors

Name | Description
ReducerBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce |
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ReducerBase Class
HeuristicLab.Selection Namespace


ReducerBase Constructor

ReducerBase Constructor
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReducerBase class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected ReducerBase()

See Also

ReducerBase Class
HeuristicLab.Selection Namespace


ReducerBase Methods

[image]

HeuristicLab API Documentation
ReducerBase Methods
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ReducerBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce |
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ReducerBase Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ReducerBase..::.AddSubOperator Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


Apply Method

ReducerBase..::.Apply Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.ReducerBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.ReducerBase.Apply(HeuristicLab.Core.IScope)]

See Also

ReducerBase Class
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
ReducerBase..::.Clone Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ReducerBase..::.GetVariableValue Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ReducerBase..::.IsValid Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


Reduce Method

ReducerBase..::.Reduce Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.ReducerBase.Reduce(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract ICollection<IScope> Reduce(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.ReducerBase.Reduce(HeuristicLab.Core.IScope)]

See Also

ReducerBase Class
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ReducerBase..::.TryAddSubOperator Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ReducerBase..::.TryAddVariable Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ReducerBase..::.TryAddVariableInfo Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ReducerBase..::.TryRemoveSubOperator Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ReducerBase..::.TryRemoveVariable Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ReducerBase..::.TryRemoveVariableInfo Method
ReducerBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ReducerBase Class
ReducerBase Members
HeuristicLab.Selection Namespace


RightChildReducer Class

RightChildReducer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.RightChildReducer]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RightChildReducer : ReducerBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.ReducerBase
HeuristicLab.Selection..::.RightChildReducer

See Also

RightChildReducer Members
HeuristicLab.Selection Namespace


RightChildReducer Members

[image]

HeuristicLab API Documentation
RightChildReducer Members
RightChildReducer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightChildReducer type exposes the following members.

Constructors

Name | Description
RightChildReducer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
HeuristicLab.Selection Namespace


RightChildReducer Constructor

RightChildReducer Constructor
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RightChildReducer class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RightChildReducer()

See Also

RightChildReducer Class
HeuristicLab.Selection Namespace


RightChildReducer Methods

[image]

HeuristicLab API Documentation
RightChildReducer Methods
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightChildReducer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RightChildReducer Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.AddSubOperator Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.Clone Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.GetVariableValue Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.IsValid Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


Reduce Method

RightChildReducer..::.Reduce Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.RightChildReducer.Reduce(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override ICollection<IScope> Reduce(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.RightChildReducer.Reduce(HeuristicLab.Core.IScope)]

See Also

RightChildReducer Class
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.TryAddSubOperator Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.TryAddVariable Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.TryAddVariableInfo Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.TryRemoveSubOperator Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.TryRemoveVariable Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RightChildReducer..::.TryRemoveVariableInfo Method
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
RightChildReducer Members
HeuristicLab.Selection Namespace


RightChildReducer Properties

[image]

HeuristicLab API Documentation
RightChildReducer Properties
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightChildReducer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RightChildReducer Class
HeuristicLab.Selection Namespace


Description Property

RightChildReducer..::.Description Property
RightChildReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.RightChildReducer.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RightChildReducer Class
HeuristicLab.Selection Namespace


RightReducer Class

RightReducer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.RightReducer]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RightReducer : ReducerBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.ReducerBase
HeuristicLab.Selection..::.RightReducer

See Also

RightReducer Members
HeuristicLab.Selection Namespace


RightReducer Members

[image]

HeuristicLab API Documentation
RightReducer Members
RightReducer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightReducer type exposes the following members.

Constructors

Name | Description
RightReducer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RightReducer Class
HeuristicLab.Selection Namespace


RightReducer Constructor

RightReducer Constructor
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RightReducer class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RightReducer()

See Also

RightReducer Class
HeuristicLab.Selection Namespace


RightReducer Methods

[image]

HeuristicLab API Documentation
RightReducer Methods
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightReducer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from ReducerBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
Reduce | (Overrides ReducerBase ..::. Reduce(IScope).)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RightReducer Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RightReducer..::.AddSubOperator Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
RightReducer..::.Clone Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RightReducer..::.GetVariableValue Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RightReducer..::.IsValid Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


Reduce Method

RightReducer..::.Reduce Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.RightReducer.Reduce(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override ICollection<IScope> Reduce(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.RightReducer.Reduce(HeuristicLab.Core.IScope)]

See Also

RightReducer Class
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RightReducer..::.TryAddSubOperator Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RightReducer..::.TryAddVariable Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RightReducer..::.TryAddVariableInfo Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RightReducer..::.TryRemoveSubOperator Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RightReducer..::.TryRemoveVariable Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RightReducer..::.TryRemoveVariableInfo Method
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightReducer Class
RightReducer Members
HeuristicLab.Selection Namespace


RightReducer Properties

[image]

HeuristicLab API Documentation
RightReducer Properties
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightReducer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RightReducer Class
HeuristicLab.Selection Namespace


Description Property

RightReducer..::.Description Property
RightReducer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.RightReducer.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RightReducer Class
HeuristicLab.Selection Namespace


RightSelector Class

RightSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.RightSelector]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RightSelector : StochasticSelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.RightSelector

See Also

RightSelector Members
HeuristicLab.Selection Namespace


RightSelector Members

[image]

HeuristicLab API Documentation
RightSelector Members
RightSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightSelector type exposes the following members.

Constructors

Name | Description
RightSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RightSelector Class
HeuristicLab.Selection Namespace


RightSelector Constructor

RightSelector Constructor
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RightSelector class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RightSelector()

See Also

RightSelector Class
HeuristicLab.Selection Namespace


RightSelector Methods

[image]

HeuristicLab API Documentation
RightSelector Methods
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RightSelector Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RightSelector..::.AddSubOperator Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
RightSelector..::.Clone Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RightSelector..::.GetVariableValue Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RightSelector..::.IsValid Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
RightSelector..::.Select Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Inherited from StochasticSelectorBase.)
Select(IRandom, IScope, Int32, IScope, Boolean) | (Overrides StochasticSelectorBase ..::. Select(IRandom, IScope, Int32, IScope, Boolean).)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

RightSelector..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.RightSelector.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

RightSelector Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RightSelector..::.TryAddSubOperator Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RightSelector..::.TryAddVariable Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RightSelector..::.TryAddVariableInfo Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RightSelector..::.TryRemoveSubOperator Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RightSelector..::.TryRemoveVariable Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RightSelector..::.TryRemoveVariableInfo Method
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RightSelector Class
RightSelector Members
HeuristicLab.Selection Namespace


RightSelector Properties

[image]

HeuristicLab API Documentation
RightSelector Properties
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RightSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RightSelector Class
HeuristicLab.Selection Namespace


Description Property

RightSelector..::.Description Property
RightSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.RightSelector.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RightSelector Class
HeuristicLab.Selection Namespace


SelectorBase Class

SelectorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.SelectorBase]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class SelectorBase : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Scheduling.JSSP..::.ConditionalSelector
HeuristicLab.Selection..::.StochasticSelectorBase

See Also

SelectorBase Members
HeuristicLab.Selection Namespace


SelectorBase Members

[image]

HeuristicLab API Documentation
SelectorBase Members
SelectorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectorBase type exposes the following members.

Constructors

Name | Description
SelectorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SelectorBase Class
HeuristicLab.Selection Namespace


SelectorBase Constructor

SelectorBase Constructor
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SelectorBase class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SelectorBase()

See Also

SelectorBase Class
HeuristicLab.Selection Namespace


SelectorBase Methods

[image]

HeuristicLab API Documentation
SelectorBase Methods
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SelectorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select |
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SelectorBase Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SelectorBase..::.AddSubOperator Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


Apply Method

SelectorBase..::.Apply Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.SelectorBase.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.SelectorBase.Apply(HeuristicLab.Core.IScope)]

See Also

SelectorBase Class
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
SelectorBase..::.Clone Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SelectorBase..::.GetVariableValue Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SelectorBase..::.IsValid Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


Select Method

SelectorBase..::.Select Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.SelectorBase.Select(HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract void Select(
    IScope source,
    IScope target,
    bool copySelected
)

Parameters

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

SelectorBase Class
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SelectorBase..::.TryAddSubOperator Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SelectorBase..::.TryAddVariable Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SelectorBase..::.TryAddVariableInfo Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SelectorBase..::.TryRemoveSubOperator Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SelectorBase..::.TryRemoveVariable Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SelectorBase..::.TryRemoveVariableInfo Method
SelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SelectorBase Class
SelectorBase Members
HeuristicLab.Selection Namespace


StochasticSelectorBase Class

StochasticSelectorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.StochasticSelectorBase]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class StochasticSelectorBase : SelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.RandomSelector
HeuristicLab.Selection..::.RightSelector
HeuristicLab.Selection..::.TournamentSelector
HeuristicLab.Selection..::.LinearRankSelector
HeuristicLab.Selection..::.LeftSelector
HeuristicLab.Selection..::.ProportionalSelector

See Also

StochasticSelectorBase Members
HeuristicLab.Selection Namespace


StochasticSelectorBase Members

[image]

HeuristicLab API Documentation
StochasticSelectorBase Members
StochasticSelectorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StochasticSelectorBase type exposes the following members.

Constructors

Name | Description
StochasticSelectorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
HeuristicLab.Selection Namespace


StochasticSelectorBase Constructor

StochasticSelectorBase Constructor
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StochasticSelectorBase class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StochasticSelectorBase()

See Also

StochasticSelectorBase Class
HeuristicLab.Selection Namespace


StochasticSelectorBase Methods

[image]

HeuristicLab API Documentation
StochasticSelectorBase Methods
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StochasticSelectorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

StochasticSelectorBase Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.AddSubOperator Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.Clone Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.GetVariableValue Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.IsValid Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.Select Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Overrides SelectorBase ..::. Select(IScope, IScope, Boolean).)
Select(IRandom, IScope, Int32, IScope, Boolean) |

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


Select Method (IScope, IScope, Boolean)

StochasticSelectorBase..::.Select Method (IScope, IScope, Boolean)
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.StochasticSelectorBase.Select(HeuristicLab.Core.IScope,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override sealed void Select(
    IScope source,
    IScope target,
    bool copySelected
)

Parameters

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

StochasticSelectorBase Class
Select Overload
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

StochasticSelectorBase..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.StochasticSelectorBase.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

StochasticSelectorBase Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.TryAddSubOperator Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.TryAddVariable Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.TryAddVariableInfo Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.TryRemoveSubOperator Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.TryRemoveVariable Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
StochasticSelectorBase..::.TryRemoveVariableInfo Method
StochasticSelectorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StochasticSelectorBase Class
StochasticSelectorBase Members
HeuristicLab.Selection Namespace


TournamentSelector Class

TournamentSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.TournamentSelector]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class TournamentSelector : StochasticSelectorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection..::.SelectorBase
HeuristicLab.Selection..::.StochasticSelectorBase
HeuristicLab.Selection..::.TournamentSelector

See Also

TournamentSelector Members
HeuristicLab.Selection Namespace


TournamentSelector Members

[image]

HeuristicLab API Documentation
TournamentSelector Members
TournamentSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TournamentSelector type exposes the following members.

Constructors

Name | Description
TournamentSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
HeuristicLab.Selection Namespace


TournamentSelector Constructor

TournamentSelector Constructor
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TournamentSelector class.

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TournamentSelector()

See Also

TournamentSelector Class
HeuristicLab.Selection Namespace


TournamentSelector Methods

[image]

HeuristicLab API Documentation
TournamentSelector Methods
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TournamentSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SelectorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
Select | Overloaded.
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TournamentSelector Class
HeuristicLab.Selection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.AddSubOperator Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


Clone Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.Clone Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.GetVariableValue Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.IsValid Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


Select Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.Select Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select(IScope, IScope, Boolean) | (Inherited from StochasticSelectorBase.)
Select(IRandom, IScope, Int32, IScope, Boolean) | (Overrides StochasticSelectorBase ..::. Select(IRandom, IScope, Int32, IScope, Boolean).)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


Select Method (IRandom, IScope, Int32, IScope, Boolean)

TournamentSelector..::.Select Method (IRandom, IScope, Int32, IScope, Boolean)
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.TournamentSelector.Select(HeuristicLab.Core.IRandom,HeuristicLab.Core.IScope,System.Int32,HeuristicLab.Core.IScope,System.Boolean)]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Select(
    IRandom random,
    IScope source,
    int selected,
    IScope target,
    bool copySelected
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

source
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "source"]

selected
Type: System..::.Int32

[Missing <param> documentation for "selected"]

target
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "target"]

copySelected
Type: System..::.Boolean

[Missing <param> documentation for "copySelected"]

See Also

TournamentSelector Class
Select Overload
HeuristicLab.Selection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.TryAddSubOperator Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.TryAddVariable Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.TryAddVariableInfo Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.TryRemoveSubOperator Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.TryRemoveVariable Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TournamentSelector..::.TryRemoveVariableInfo Method
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
TournamentSelector Members
HeuristicLab.Selection Namespace


TournamentSelector Properties

[image]

HeuristicLab API Documentation
TournamentSelector Properties
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TournamentSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

TournamentSelector Class
HeuristicLab.Selection Namespace


Description Property

TournamentSelector..::.Description Property
TournamentSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.TournamentSelector.Description]

Namespace: HeuristicLab.Selection
Assembly: HeuristicLab.Selection (in HeuristicLab.Selection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

TournamentSelector Class
HeuristicLab.Selection Namespace


HeuristicLab.Selection.OffspringSelection Namespace

HeuristicLab.Selection.OffspringSelection Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.Selection.OffspringSelection]

Classes

Class | Description
HeuristicLabSelectionOffspringSelectionPlugin |
OffspringAnalyzer |
OffspringSelector |


HeuristicLabSelectionOffspringSelectionPlugin Class

HeuristicLabSelectionOffspringSelectionPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.OffspringSelection.HeuristicLabSelectionOffspringSelectionPlugin]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[PluginFileAttribute(Filename = "HeuristicLab.Selection.OffspringSelection.dll",
    Filetype = PluginFileType.Assembly)]
[ClassInfoAttribute(Name = "HeuristicLab.Selection.OffspringSelection")]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
public class HeuristicLabSelectionOffspringSelectionPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.Selection.OffspringSelection..::.HeuristicLabSelectionOffspringSelectionPlugin

See Also

HeuristicLabSelectionOffspringSelectionPlugin Members
HeuristicLab.Selection.OffspringSelection Namespace


HeuristicLabSelectionOffspringSelectionPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabSelectionOffspringSelectionPlugin Members
HeuristicLabSelectionOffspringSelectionPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabSelectionOffspringSelectionPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabSelectionOffspringSelectionPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabSelectionOffspringSelectionPlugin Class
HeuristicLab.Selection.OffspringSelection Namespace


HeuristicLabSelectionOffspringSelectionPlugin Constructor

HeuristicLabSelectionOffspringSelectionPlugin Constructor
HeuristicLabSelectionOffspringSelectionPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabSelectionOffspringSelectionPlugin class.

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabSelectionOffspringSelectionPlugin()

See Also

HeuristicLabSelectionOffspringSelectionPlugin Class
HeuristicLab.Selection.OffspringSelection Namespace


OffspringAnalyzer Class

OffspringAnalyzer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.OffspringSelection.OffspringAnalyzer]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OffspringAnalyzer : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection.OffspringSelection..::.OffspringAnalyzer

See Also

OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


OffspringAnalyzer Members

[image]

HeuristicLab API Documentation
OffspringAnalyzer Members
OffspringAnalyzer Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OffspringAnalyzer type exposes the following members.

Constructors

Name | Description
OffspringAnalyzer |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
HeuristicLab.Selection.OffspringSelection Namespace


OffspringAnalyzer Constructor

OffspringAnalyzer Constructor
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OffspringAnalyzer class.

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OffspringAnalyzer()

See Also

OffspringAnalyzer Class
HeuristicLab.Selection.OffspringSelection Namespace


OffspringAnalyzer Methods

[image]

HeuristicLab API Documentation
OffspringAnalyzer Methods
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OffspringAnalyzer type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OffspringAnalyzer Class
HeuristicLab.Selection.OffspringSelection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.AddSubOperator Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


Apply Method

OffspringAnalyzer..::.Apply Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.OffspringSelection.OffspringAnalyzer.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.OffspringSelection.OffspringAnalyzer.Apply(HeuristicLab.Core.IScope)]

See Also

OffspringAnalyzer Class
HeuristicLab.Selection.OffspringSelection Namespace


Clone Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.Clone Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.GetVariableValue Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.IsValid Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.TryAddSubOperator Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.TryAddVariable Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.TryAddVariableInfo Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.TryRemoveSubOperator Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.TryRemoveVariable Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OffspringAnalyzer..::.TryRemoveVariableInfo Method
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
OffspringAnalyzer Members
HeuristicLab.Selection.OffspringSelection Namespace


OffspringAnalyzer Properties

[image]

HeuristicLab API Documentation
OffspringAnalyzer Properties
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OffspringAnalyzer type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OffspringAnalyzer Class
HeuristicLab.Selection.OffspringSelection Namespace


Description Property

OffspringAnalyzer..::.Description Property
OffspringAnalyzer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.OffspringSelection.OffspringAnalyzer.Description]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OffspringAnalyzer Class
HeuristicLab.Selection.OffspringSelection Namespace


OffspringSelector Class

OffspringSelector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.Selection.OffspringSelection.OffspringSelector]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OffspringSelector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Selection.OffspringSelection..::.OffspringSelector

See Also

OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


OffspringSelector Members

[image]

HeuristicLab API Documentation
OffspringSelector Members
OffspringSelector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OffspringSelector type exposes the following members.

Constructors

Name | Description
OffspringSelector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
HeuristicLab.Selection.OffspringSelection Namespace


OffspringSelector Constructor

OffspringSelector Constructor
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OffspringSelector class.

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OffspringSelector()

See Also

OffspringSelector Class
HeuristicLab.Selection.OffspringSelection Namespace


OffspringSelector Methods

[image]

HeuristicLab API Documentation
OffspringSelector Methods
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OffspringSelector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OffspringSelector Class
HeuristicLab.Selection.OffspringSelection Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.AddSubOperator Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


Apply Method

OffspringSelector..::.Apply Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Selection.OffspringSelection.OffspringSelector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Selection.OffspringSelection.OffspringSelector.Apply(HeuristicLab.Core.IScope)]

See Also

OffspringSelector Class
HeuristicLab.Selection.OffspringSelection Namespace


Clone Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.Clone Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.GetVariableValue Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.IsValid Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.TryAddSubOperator Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.TryAddVariable Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.TryAddVariableInfo Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.TryRemoveSubOperator Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.TryRemoveVariable Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OffspringSelector..::.TryRemoveVariableInfo Method
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
OffspringSelector Members
HeuristicLab.Selection.OffspringSelection Namespace


OffspringSelector Properties

[image]

HeuristicLab API Documentation
OffspringSelector Properties
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OffspringSelector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OffspringSelector Class
HeuristicLab.Selection.OffspringSelection Namespace


Description Property

OffspringSelector..::.Description Property
OffspringSelector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Selection.OffspringSelection.OffspringSelector.Description]

Namespace: HeuristicLab.Selection.OffspringSelection
Assembly: HeuristicLab.Selection.OffspringSelection (in HeuristicLab.Selection.OffspringSelection.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OffspringSelector Class
HeuristicLab.Selection.OffspringSelection Namespace


HeuristicLab.SequentialEngine Namespace

HeuristicLab.SequentialEngine Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.SequentialEngine]

Classes

Class | Description
HeuristicLabSequentialEnginePlugin |
SequentialEngine |
SequentialEngineEditor |


HeuristicLabSequentialEnginePlugin Class

HeuristicLabSequentialEnginePlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.SequentialEngine.HeuristicLabSequentialEnginePlugin]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "HeuristicLab.SequentialEngine")]
[PluginFileAttribute(Filename = "HeuristicLab.SequentialEngine.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
public class HeuristicLabSequentialEnginePlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.SequentialEngine..::.HeuristicLabSequentialEnginePlugin

See Also

HeuristicLabSequentialEnginePlugin Members
HeuristicLab.SequentialEngine Namespace


HeuristicLabSequentialEnginePlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabSequentialEnginePlugin Members
HeuristicLabSequentialEnginePlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabSequentialEnginePlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabSequentialEnginePlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabSequentialEnginePlugin Class
HeuristicLab.SequentialEngine Namespace


HeuristicLabSequentialEnginePlugin Constructor

HeuristicLabSequentialEnginePlugin Constructor
HeuristicLabSequentialEnginePlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabSequentialEnginePlugin class.

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabSequentialEnginePlugin()

See Also

HeuristicLabSequentialEnginePlugin Class
HeuristicLab.SequentialEngine Namespace


SequentialEngine Class

SequentialEngine Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.SequentialEngine.SequentialEngine]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SequentialEngine : EngineBase, IEditable,
    IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.EngineBase
HeuristicLab.SequentialEngine..::.SequentialEngine

See Also

SequentialEngine Members
HeuristicLab.SequentialEngine Namespace


SequentialEngine Members

[image]

HeuristicLab API Documentation
SequentialEngine Members
SequentialEngine Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialEngine type exposes the following members.

Constructors

Name | Description
SequentialEngine |

Methods

Name | Description
Abort | (Overrides EngineBase ..::. Abort()()().)
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from EngineBase.)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Inherited from EngineBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from EngineBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
Populate | (Inherited from EngineBase.)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

Fields

Name | Description
myCanceled | (Inherited from EngineBase.)
myExecutionStack | (Inherited from EngineBase.)
myGlobalScope | (Inherited from EngineBase.)
myOperatorGraph | (Inherited from EngineBase.)
myRunning | (Inherited from EngineBase.)

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
Terminated | (Inherited from EngineBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred | (Inherited from EngineBase.)
ExecutionTimeChanged | (Inherited from EngineBase.)
Finished | (Inherited from EngineBase.)
Initialized | (Inherited from EngineBase.)
OperationExecuted | (Inherited from EngineBase.)

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


SequentialEngine Constructor

SequentialEngine Constructor
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SequentialEngine class.

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SequentialEngine()

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


SequentialEngine Methods

[image]

HeuristicLab API Documentation
SequentialEngine Methods
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialEngine type exposes the following members.

Methods

Name | Description
Abort | (Overrides EngineBase ..::. Abort()()().)
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from EngineBase.)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Inherited from EngineBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from EngineBase.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
Populate | (Inherited from EngineBase.)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


Abort Method

SequentialEngine..::.Abort Method
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SequentialEngine.SequentialEngine.Abort]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Abort()

Implements

IEngine..::.Abort()()()

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


Clone Method

[image]

HeuristicLab API Documentation
SequentialEngine..::.Clone Method
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from EngineBase.)

See Also

SequentialEngine Class
SequentialEngine Members
HeuristicLab.SequentialEngine Namespace


CreateEditor Method

SequentialEngine..::.CreateEditor Method
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SequentialEngine.SequentialEngine.CreateEditor]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.SequentialEngine.SequentialEngine.CreateEditor]

Implements

IEditable..::.CreateEditor()()()

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


CreateView Method

SequentialEngine..::.CreateView Method
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SequentialEngine.SequentialEngine.CreateView]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.SequentialEngine.SequentialEngine.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


ProcessNextOperation Method

SequentialEngine..::.ProcessNextOperation Method
SequentialEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SequentialEngine.SequentialEngine.ProcessNextOperation]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void ProcessNextOperation()

See Also

SequentialEngine Class
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Class

SequentialEngineEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.SequentialEngine.SequentialEngineEditor]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SequentialEngineEditor : EngineBaseEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.EngineBaseEditor
HeuristicLab.SequentialEngine..::.SequentialEngineEditor

See Also

SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Members

[image]

HeuristicLab API Documentation
SequentialEngineEditor Members
SequentialEngineEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialEngineEditor type exposes the following members.

Constructors

Name | Description
SequentialEngineEditor | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from EngineBaseEditor.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from EngineBaseEditor.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from EngineBaseEditor.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
abortButton | (Inherited from EngineBaseEditor.)
executeButton | (Inherited from EngineBaseEditor.)
executionTimeLabel | (Inherited from EngineBaseEditor.)
executionTimeTextBox | (Inherited from EngineBaseEditor.)
globalScopeGroupBox | (Inherited from EngineBaseEditor.)
operatorGraphGroupBox | (Inherited from EngineBaseEditor.)
operatorGraphView | (Inherited from EngineBaseEditor.)
resetButton | (Inherited from EngineBaseEditor.)
scopeView | (Inherited from EngineBaseEditor.)
splitContainer1 | (Inherited from EngineBaseEditor.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine | (Inherited from EngineBaseEditor.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SequentialEngine |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SequentialEngineEditor Class
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Constructor

[image]

HeuristicLab API Documentation
SequentialEngineEditor Constructor
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SequentialEngineEditor()()() |
SequentialEngineEditor(SequentialEngine) |

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Constructor

SequentialEngineEditor Constructor
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SequentialEngineEditor class.

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SequentialEngineEditor()

See Also

SequentialEngineEditor Class
SequentialEngineEditor Overload
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Constructor (SequentialEngine)

SequentialEngineEditor Constructor (SequentialEngine)
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SequentialEngineEditor class.

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SequentialEngineEditor(
    SequentialEngine sequentialEngine
)

Parameters

sequentialEngine
Type: HeuristicLab.SequentialEngine..::.SequentialEngine

[Missing <param> documentation for "sequentialEngine"]

See Also

SequentialEngineEditor Class
SequentialEngineEditor Overload
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Methods

[image]

HeuristicLab API Documentation
SequentialEngineEditor Methods
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialEngineEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from EngineBaseEditor.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from EngineBaseEditor.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from EngineBaseEditor.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

SequentialEngineEditor Class
HeuristicLab.SequentialEngine Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.AccessibilityNotifyClients Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.BeginInvoke Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Dispose Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.Dispose Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EngineBaseEditor ..::. Dispose(Boolean).)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Dispose Method (Boolean)

SequentialEngineEditor..::.Dispose Method (Boolean)
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SequentialEngineEditor Class
Dispose Overload
HeuristicLab.SequentialEngine Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.GetChildAtPoint Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.Invalidate Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Invoke Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.Invoke Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.MemberwiseClone Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.PerformLayout Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.ResumeLayout Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.RtlTranslateAlignment Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Scale Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.Scale Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Select Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.Select Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.SetBounds Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.UpdateBounds Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


Validate Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.Validate Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
SequentialEngineEditor..::.ValidateChildren Method
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SequentialEngineEditor Class
SequentialEngineEditor Members
HeuristicLab.SequentialEngine Namespace


SequentialEngineEditor Properties

[image]

HeuristicLab API Documentation
SequentialEngineEditor Properties
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SequentialEngineEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine | (Inherited from EngineBaseEditor.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SequentialEngine |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

SequentialEngineEditor Class
HeuristicLab.SequentialEngine Namespace


SequentialEngine Property

SequentialEngineEditor..::.SequentialEngine Property
SequentialEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SequentialEngine.SequentialEngineEditor.SequentialEngine]

Namespace: HeuristicLab.SequentialEngine
Assembly: HeuristicLab.SequentialEngine (in HeuristicLab.SequentialEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SequentialEngine SequentialEngine { get; set; }

See Also

SequentialEngineEditor Class
HeuristicLab.SequentialEngine Namespace


HeuristicLab.SGA Namespace

HeuristicLab.SGA Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.SGA]

Classes

Class | Description
HeuristicLabSGAPlugin |
SGA |
SGAEditor |


HeuristicLabSGAPlugin Class

HeuristicLabSGAPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.SGA.HeuristicLabSGAPlugin]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Selection")]
[DependencyAttribute(Dependency = "HeuristicLab.Logging")]
[DependencyAttribute(Dependency = "HeuristicLab.SequentialEngine")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.SGA")]
[PluginFileAttribute(Filename = "HeuristicLab.SGA.dll", Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[DependencyAttribute(Dependency = "HeuristicLab.Random")]
public class HeuristicLabSGAPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.SGA..::.HeuristicLabSGAPlugin

See Also

HeuristicLabSGAPlugin Members
HeuristicLab.SGA Namespace


HeuristicLabSGAPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabSGAPlugin Members
HeuristicLabSGAPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabSGAPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabSGAPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabSGAPlugin Class
HeuristicLab.SGA Namespace


HeuristicLabSGAPlugin Constructor

HeuristicLabSGAPlugin Constructor
HeuristicLabSGAPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabSGAPlugin class.

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabSGAPlugin()

See Also

HeuristicLabSGAPlugin Class
HeuristicLab.SGA Namespace


SGA Class

SGA Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.SGA.SGA]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SGA : ItemBase, IEditable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.SGA..::.SGA

See Also

SGA Members
HeuristicLab.SGA Namespace


SGA Members

[image]

HeuristicLab API Documentation
SGA Members
SGA Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SGA type exposes the following members.

Constructors

Name | Description
SGA |

Methods

Name | Description
Clone | Overloaded.
Create |
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Properties

Name | Description
Crossover |
Elites |
Engine |
Evaluator |
Guid | (Inherited from StorableBase.)
MaximumGenerations |
MutationRate |
Mutator |
PopulationSize |
ProblemInitializer |
Seed |
Selector |
SetSeedRandomly |
SolutionGenerator |

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

SGA Class
HeuristicLab.SGA Namespace


SGA Constructor

SGA Constructor
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SGA class.

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SGA()

See Also

SGA Class
HeuristicLab.SGA Namespace


SGA Methods

[image]

HeuristicLab API Documentation
SGA Methods
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SGA type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
Create |
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

SGA Class
HeuristicLab.SGA Namespace


Clone Method

[image]

HeuristicLab API Documentation
SGA..::.Clone Method
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

SGA Class
SGA Members
HeuristicLab.SGA Namespace


Clone Method (IDictionary(Guid, Object))

SGA..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGA.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.SGA.SGA.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

SGA Class
Clone Overload
HeuristicLab.SGA Namespace


Create Method

SGA..::.Create Method
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGA.Create(HeuristicLab.Core.IEngine)]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static void Create(
    IEngine engine
)

Parameters

engine
Type: HeuristicLab.Core..::.IEngine

[Missing <param> documentation for "engine"]

See Also

SGA Class
HeuristicLab.SGA Namespace


CreateEditor Method

SGA..::.CreateEditor Method
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGA.CreateEditor]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.SGA.SGA.CreateEditor]

Implements

IEditable..::.CreateEditor()()()

See Also

SGA Class
HeuristicLab.SGA Namespace


CreateView Method

SGA..::.CreateView Method
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGA.CreateView]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.SGA.SGA.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

SGA Class
HeuristicLab.SGA Namespace


GetXmlNode Method

SGA..::.GetXmlNode Method
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGA.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.SGA.SGA.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

SGA Class
HeuristicLab.SGA Namespace


Populate Method

SGA..::.Populate Method
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGA.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

SGA Class
HeuristicLab.SGA Namespace


SGA Properties

[image]

HeuristicLab API Documentation
SGA Properties
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SGA type exposes the following members.

Properties

Name | Description
Crossover |
Elites |
Engine |
Evaluator |
Guid | (Inherited from StorableBase.)
MaximumGenerations |
MutationRate |
Mutator |
PopulationSize |
ProblemInitializer |
Seed |
Selector |
SetSeedRandomly |
SolutionGenerator |

See Also

SGA Class
HeuristicLab.SGA Namespace


Crossover Property

SGA..::.Crossover Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Crossover]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Crossover { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


Elites Property

SGA..::.Elites Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Elites]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Elites { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


Engine Property

SGA..::.Engine Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Engine]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEngine Engine { get; }

See Also

SGA Class
HeuristicLab.SGA Namespace


Evaluator Property

SGA..::.Evaluator Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Evaluator]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Evaluator { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


MaximumGenerations Property

SGA..::.MaximumGenerations Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.MaximumGenerations]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int MaximumGenerations { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


MutationRate Property

SGA..::.MutationRate Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.MutationRate]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public double MutationRate { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


Mutator Property

SGA..::.Mutator Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Mutator]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Mutator { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


PopulationSize Property

SGA..::.PopulationSize Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.PopulationSize]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int PopulationSize { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


ProblemInitializer Property

SGA..::.ProblemInitializer Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.ProblemInitializer]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator ProblemInitializer { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


Seed Property

SGA..::.Seed Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Seed]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Seed { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


Selector Property

SGA..::.Selector Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.Selector]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator Selector { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


SetSeedRandomly Property

SGA..::.SetSeedRandomly Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.SetSeedRandomly]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool SetSeedRandomly { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


SolutionGenerator Property

SGA..::.SolutionGenerator Property
SGA Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGA.SolutionGenerator]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator SolutionGenerator { get; set; }

See Also

SGA Class
HeuristicLab.SGA Namespace


SGAEditor Class

SGAEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.SGA.SGAEditor]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SGAEditor : EditorBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.SGA..::.SGAEditor

See Also

SGAEditor Members
HeuristicLab.SGA Namespace


SGAEditor Members

[image]

HeuristicLab API Documentation
SGAEditor Members
SGAEditor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SGAEditor type exposes the following members.

Constructors

Name | Description
SGAEditor | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EditorBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SGA |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


SGAEditor Constructor

[image]

HeuristicLab API Documentation
SGAEditor Constructor
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SGAEditor()()() |
SGAEditor(SGA) |

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


SGAEditor Constructor

SGAEditor Constructor
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SGAEditor class.

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SGAEditor()

See Also

SGAEditor Class
SGAEditor Overload
HeuristicLab.SGA Namespace


SGAEditor Constructor (SGA)

SGAEditor Constructor (SGA)
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SGAEditor class.

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SGAEditor(
    SGA sga
)

Parameters

sga
Type: HeuristicLab.SGA..::.SGA

[Missing <param> documentation for "sga"]

See Also

SGAEditor Class
SGAEditor Overload
HeuristicLab.SGA Namespace


SGAEditor Methods

[image]

HeuristicLab API Documentation
SGAEditor Methods
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SGAEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EditorBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
SGAEditor..::.AccessibilityNotifyClients Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


AddItemEvents Method

SGAEditor..::.AddItemEvents Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGAEditor.AddItemEvents]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
SGAEditor..::.BeginInvoke Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


Dispose Method

[image]

HeuristicLab API Documentation
SGAEditor..::.Dispose Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EditorBase ..::. Dispose(Boolean).)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


Dispose Method (Boolean)

SGAEditor..::.Dispose Method (Boolean)
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

SGAEditor Class
Dispose Overload
HeuristicLab.SGA Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
SGAEditor..::.GetChildAtPoint Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
SGAEditor..::.Invalidate Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


Invoke Method

[image]

HeuristicLab API Documentation
SGAEditor..::.Invoke Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
SGAEditor..::.MemberwiseClone Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
SGAEditor..::.PerformLayout Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


RemoveItemEvents Method

SGAEditor..::.RemoveItemEvents Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGAEditor.RemoveItemEvents]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
SGAEditor..::.ResumeLayout Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
SGAEditor..::.RtlTranslateAlignment Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


Scale Method

[image]

HeuristicLab API Documentation
SGAEditor..::.Scale Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


Select Method

[image]

HeuristicLab API Documentation
SGAEditor..::.Select Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
SGAEditor..::.SetBounds Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
SGAEditor..::.UpdateBounds Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


UpdateControls Method

SGAEditor..::.UpdateControls Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.SGA.SGAEditor.UpdateControls]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


Validate Method

[image]

HeuristicLab API Documentation
SGAEditor..::.Validate Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
SGAEditor..::.ValidateChildren Method
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

SGAEditor Class
SGAEditor Members
HeuristicLab.SGA Namespace


SGAEditor Properties

[image]

HeuristicLab API Documentation
SGAEditor Properties
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SGAEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
SGA |
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


SGA Property

SGAEditor..::.SGA Property
SGAEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.SGA.SGAEditor.SGA]

Namespace: HeuristicLab.SGA
Assembly: HeuristicLab.SGA (in HeuristicLab.SGA.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SGA SGA { get; set; }

See Also

SGAEditor Class
HeuristicLab.SGA Namespace


HeuristicLab.StructureIdentification Namespace

HeuristicLab.StructureIdentification Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.StructureIdentification]

Classes

Class | Description
ChangeNodeTypeManipulation |
CoefficientOfDeterminationEvaluator |
CutOutNodeManipulation |
DeleteSubTreeManipulation |
FullTreeShaker |
FunctionEvaluator |
GPOperatorGroup |
GPOperatorLibrary |
GPOperatorLibraryEditor |
HeuristicLabStructureIdentificationPlugin |
MeanSquaredErrorEvaluator |
OnePointShaker |
OperatorEventArgs |
PopulationAnalyser |
RandomTreeCreator |
SinglePointCrossOver |
StructIdProblemInjector |
StructIdProblemInjectorView |
SubstituteSubTreeManipulation |
TreeGardener |
TreeGardener..::.OperatorEqualityComparer |
VarianceAccountedForEvaluator |


ChangeNodeTypeManipulation Class

ChangeNodeTypeManipulation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.ChangeNodeTypeManipulation]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ChangeNodeTypeManipulation : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.ChangeNodeTypeManipulation

See Also

ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


ChangeNodeTypeManipulation Members

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation Members
ChangeNodeTypeManipulation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChangeNodeTypeManipulation type exposes the following members.

Constructors

Name | Description
ChangeNodeTypeManipulation |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
HeuristicLab.StructureIdentification Namespace


ChangeNodeTypeManipulation Constructor

ChangeNodeTypeManipulation Constructor
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ChangeNodeTypeManipulation class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ChangeNodeTypeManipulation()

See Also

ChangeNodeTypeManipulation Class
HeuristicLab.StructureIdentification Namespace


ChangeNodeTypeManipulation Methods

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation Methods
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChangeNodeTypeManipulation type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

ChangeNodeTypeManipulation Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.AddSubOperator Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


Apply Method

ChangeNodeTypeManipulation..::.Apply Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.ChangeNodeTypeManipulation.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.ChangeNodeTypeManipulation.Apply(HeuristicLab.Core.IScope)]

See Also

ChangeNodeTypeManipulation Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.Clone Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.GetVariableValue Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.IsValid Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.TryAddSubOperator Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.TryAddVariable Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.TryAddVariableInfo Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.TryRemoveSubOperator Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.TryRemoveVariable Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
ChangeNodeTypeManipulation..::.TryRemoveVariableInfo Method
ChangeNodeTypeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

ChangeNodeTypeManipulation Class
ChangeNodeTypeManipulation Members
HeuristicLab.StructureIdentification Namespace


CoefficientOfDeterminationEvaluator Class

CoefficientOfDeterminationEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.CoefficientOfDeterminationEvaluator]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CoefficientOfDeterminationEvaluator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.CoefficientOfDeterminationEvaluator

See Also

CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


CoefficientOfDeterminationEvaluator Members

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator Members
CoefficientOfDeterminationEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CoefficientOfDeterminationEvaluator type exposes the following members.

Constructors

Name | Description
CoefficientOfDeterminationEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
HeuristicLab.StructureIdentification Namespace


CoefficientOfDeterminationEvaluator Constructor

CoefficientOfDeterminationEvaluator Constructor
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CoefficientOfDeterminationEvaluator class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CoefficientOfDeterminationEvaluator()

See Also

CoefficientOfDeterminationEvaluator Class
HeuristicLab.StructureIdentification Namespace


CoefficientOfDeterminationEvaluator Methods

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator Methods
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CoefficientOfDeterminationEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CoefficientOfDeterminationEvaluator Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.AddSubOperator Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


Apply Method

CoefficientOfDeterminationEvaluator..::.Apply Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.CoefficientOfDeterminationEvaluator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.CoefficientOfDeterminationEvaluator.Apply(HeuristicLab.Core.IScope)]

See Also

CoefficientOfDeterminationEvaluator Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.Clone Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.GetVariableValue Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.IsValid Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.TryAddSubOperator Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.TryAddVariable Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.TryAddVariableInfo Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.TryRemoveSubOperator Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.TryRemoveVariable Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator..::.TryRemoveVariableInfo Method
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
CoefficientOfDeterminationEvaluator Members
HeuristicLab.StructureIdentification Namespace


CoefficientOfDeterminationEvaluator Properties

[image]

HeuristicLab API Documentation
CoefficientOfDeterminationEvaluator Properties
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CoefficientOfDeterminationEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

CoefficientOfDeterminationEvaluator Class
HeuristicLab.StructureIdentification Namespace


Description Property

CoefficientOfDeterminationEvaluator..::.Description Property
CoefficientOfDeterminationEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.CoefficientOfDeterminationEvaluator.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

CoefficientOfDeterminationEvaluator Class
HeuristicLab.StructureIdentification Namespace


CutOutNodeManipulation Class

CutOutNodeManipulation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.CutOutNodeManipulation]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class CutOutNodeManipulation : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.CutOutNodeManipulation

See Also

CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


CutOutNodeManipulation Members

[image]

HeuristicLab API Documentation
CutOutNodeManipulation Members
CutOutNodeManipulation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CutOutNodeManipulation type exposes the following members.

Constructors

Name | Description
CutOutNodeManipulation |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
HeuristicLab.StructureIdentification Namespace


CutOutNodeManipulation Constructor

CutOutNodeManipulation Constructor
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CutOutNodeManipulation class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public CutOutNodeManipulation()

See Also

CutOutNodeManipulation Class
HeuristicLab.StructureIdentification Namespace


CutOutNodeManipulation Methods

[image]

HeuristicLab API Documentation
CutOutNodeManipulation Methods
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CutOutNodeManipulation type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

CutOutNodeManipulation Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.AddSubOperator Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


Apply Method

CutOutNodeManipulation..::.Apply Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.CutOutNodeManipulation.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.CutOutNodeManipulation.Apply(HeuristicLab.Core.IScope)]

See Also

CutOutNodeManipulation Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.Clone Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.GetVariableValue Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.IsValid Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.TryAddSubOperator Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.TryAddVariable Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.TryAddVariableInfo Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.TryRemoveSubOperator Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.TryRemoveVariable Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
CutOutNodeManipulation..::.TryRemoveVariableInfo Method
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
CutOutNodeManipulation Members
HeuristicLab.StructureIdentification Namespace


CutOutNodeManipulation Properties

[image]

HeuristicLab API Documentation
CutOutNodeManipulation Properties
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The CutOutNodeManipulation type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

CutOutNodeManipulation Class
HeuristicLab.StructureIdentification Namespace


Description Property

CutOutNodeManipulation..::.Description Property
CutOutNodeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.CutOutNodeManipulation.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

CutOutNodeManipulation Class
HeuristicLab.StructureIdentification Namespace


DeleteSubTreeManipulation Class

DeleteSubTreeManipulation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.DeleteSubTreeManipulation]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class DeleteSubTreeManipulation : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.DeleteSubTreeManipulation

See Also

DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


DeleteSubTreeManipulation Members

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation Members
DeleteSubTreeManipulation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeleteSubTreeManipulation type exposes the following members.

Constructors

Name | Description
DeleteSubTreeManipulation |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


DeleteSubTreeManipulation Constructor

DeleteSubTreeManipulation Constructor
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the DeleteSubTreeManipulation class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DeleteSubTreeManipulation()

See Also

DeleteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


DeleteSubTreeManipulation Methods

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation Methods
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeleteSubTreeManipulation type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

DeleteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.AddSubOperator Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


Apply Method

DeleteSubTreeManipulation..::.Apply Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.DeleteSubTreeManipulation.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.DeleteSubTreeManipulation.Apply(HeuristicLab.Core.IScope)]

See Also

DeleteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.Clone Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.GetVariableValue Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.IsValid Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.TryAddSubOperator Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.TryAddVariable Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.TryAddVariableInfo Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.TryRemoveSubOperator Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.TryRemoveVariable Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation..::.TryRemoveVariableInfo Method
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
DeleteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


DeleteSubTreeManipulation Properties

[image]

HeuristicLab API Documentation
DeleteSubTreeManipulation Properties
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The DeleteSubTreeManipulation type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

DeleteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


Description Property

DeleteSubTreeManipulation..::.Description Property
DeleteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.DeleteSubTreeManipulation.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

DeleteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


FullTreeShaker Class

FullTreeShaker Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.FullTreeShaker]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FullTreeShaker : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.FullTreeShaker

See Also

FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


FullTreeShaker Members

[image]

HeuristicLab API Documentation
FullTreeShaker Members
FullTreeShaker Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FullTreeShaker type exposes the following members.

Constructors

Name | Description
FullTreeShaker |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
HeuristicLab.StructureIdentification Namespace


FullTreeShaker Constructor

FullTreeShaker Constructor
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FullTreeShaker class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FullTreeShaker()

See Also

FullTreeShaker Class
HeuristicLab.StructureIdentification Namespace


FullTreeShaker Methods

[image]

HeuristicLab API Documentation
FullTreeShaker Methods
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FullTreeShaker type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

FullTreeShaker Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.AddSubOperator Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


Apply Method

FullTreeShaker..::.Apply Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.FullTreeShaker.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.FullTreeShaker.Apply(HeuristicLab.Core.IScope)]

See Also

FullTreeShaker Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.Clone Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.GetVariableValue Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.IsValid Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.TryAddSubOperator Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.TryAddVariable Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.TryAddVariableInfo Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.TryRemoveSubOperator Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.TryRemoveVariable Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
FullTreeShaker..::.TryRemoveVariableInfo Method
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
FullTreeShaker Members
HeuristicLab.StructureIdentification Namespace


FullTreeShaker Properties

[image]

HeuristicLab API Documentation
FullTreeShaker Properties
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FullTreeShaker type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

FullTreeShaker Class
HeuristicLab.StructureIdentification Namespace


Description Property

FullTreeShaker..::.Description Property
FullTreeShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.FullTreeShaker.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

FullTreeShaker Class
HeuristicLab.StructureIdentification Namespace


FunctionEvaluator Class

FunctionEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.FunctionEvaluator]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class FunctionEvaluator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.FunctionEvaluator

See Also

FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


FunctionEvaluator Members

[image]

HeuristicLab API Documentation
FunctionEvaluator Members
FunctionEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionEvaluator type exposes the following members.

Constructors

Name | Description
FunctionEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
HeuristicLab.StructureIdentification Namespace


FunctionEvaluator Constructor

FunctionEvaluator Constructor
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FunctionEvaluator class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public FunctionEvaluator()

See Also

FunctionEvaluator Class
HeuristicLab.StructureIdentification Namespace


FunctionEvaluator Methods

[image]

HeuristicLab API Documentation
FunctionEvaluator Methods
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

FunctionEvaluator Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.AddSubOperator Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


Apply Method

FunctionEvaluator..::.Apply Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.FunctionEvaluator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.FunctionEvaluator.Apply(HeuristicLab.Core.IScope)]

See Also

FunctionEvaluator Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.Clone Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.GetVariableValue Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.IsValid Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.TryAddSubOperator Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.TryAddVariable Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.TryAddVariableInfo Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.TryRemoveSubOperator Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.TryRemoveVariable Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
FunctionEvaluator..::.TryRemoveVariableInfo Method
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
FunctionEvaluator Members
HeuristicLab.StructureIdentification Namespace


FunctionEvaluator Properties

[image]

HeuristicLab API Documentation
FunctionEvaluator Properties
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The FunctionEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

FunctionEvaluator Class
HeuristicLab.StructureIdentification Namespace


Description Property

FunctionEvaluator..::.Description Property
FunctionEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.FunctionEvaluator.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

FunctionEvaluator Class
HeuristicLab.StructureIdentification Namespace


GPOperatorGroup Class

GPOperatorGroup Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.GPOperatorGroup]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class GPOperatorGroup : OperatorGroup

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.OperatorGroup
HeuristicLab.StructureIdentification..::.GPOperatorGroup

See Also

GPOperatorGroup Members
HeuristicLab.StructureIdentification Namespace


GPOperatorGroup Members

[image]

HeuristicLab API Documentation
GPOperatorGroup Members
GPOperatorGroup Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorGroup type exposes the following members.

Constructors

Name | Description
GPOperatorGroup |

Methods

Name | Description
AddOperator | (Overrides OperatorGroup ..::. AddOperator(IOperator).)
AddSubGroup | (Overrides OperatorGroup ..::. AddSubGroup(IOperatorGroup).)
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from OperatorGroup.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnNameChanged | (Inherited from OperatorGroup.)
OnOperatorAdded |
OnOperatorRemoved |
Populate | (Inherited from OperatorGroup.)
RemoveOperator | (Overrides OperatorGroup ..::. RemoveOperator(IOperator).)
RemoveSubGroup | (Overrides OperatorGroup ..::. RemoveSubGroup(IOperatorGroup).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorGroup.)
Operators | (Inherited from OperatorGroup.)
SubGroups | (Inherited from OperatorGroup.)

Events

Name | Description
NameChanged | (Inherited from OperatorGroup.)
OperatorAdded |
OperatorRemoved |

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


GPOperatorGroup Constructor

GPOperatorGroup Constructor
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GPOperatorGroup class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GPOperatorGroup()

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


GPOperatorGroup Methods

[image]

HeuristicLab API Documentation
GPOperatorGroup Methods
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorGroup type exposes the following members.

Methods

Name | Description
AddOperator | (Overrides OperatorGroup ..::. AddOperator(IOperator).)
AddSubGroup | (Overrides OperatorGroup ..::. AddSubGroup(IOperatorGroup).)
Clone | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Inherited from OperatorGroup.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnNameChanged | (Inherited from OperatorGroup.)
OnOperatorAdded |
OnOperatorRemoved |
Populate | (Inherited from OperatorGroup.)
RemoveOperator | (Overrides OperatorGroup ..::. RemoveOperator(IOperator).)
RemoveSubGroup | (Overrides OperatorGroup ..::. RemoveSubGroup(IOperatorGroup).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


AddOperator Method

GPOperatorGroup..::.AddOperator Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorGroup.AddOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

Implements

IOperatorGroup..::.AddOperator(IOperator)

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


AddSubGroup Method

GPOperatorGroup..::.AddSubGroup Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorGroup.AddSubGroup(HeuristicLab.Core.IOperatorGroup)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void AddSubGroup(
    IOperatorGroup group
)

Parameters

group
Type: HeuristicLab.Core..::.IOperatorGroup

[Missing <param> documentation for "group"]

Implements

IOperatorGroup..::.AddSubGroup(IOperatorGroup)

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
GPOperatorGroup..::.Clone Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorGroup.)

See Also

GPOperatorGroup Class
GPOperatorGroup Members
HeuristicLab.StructureIdentification Namespace


OnOperatorAdded Method

GPOperatorGroup..::.OnOperatorAdded Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorGroup.OnOperatorAdded(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnOperatorAdded(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


OnOperatorRemoved Method

GPOperatorGroup..::.OnOperatorRemoved Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorGroup.OnOperatorRemoved(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnOperatorRemoved(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


RemoveOperator Method

GPOperatorGroup..::.RemoveOperator Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorGroup.RemoveOperator(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveOperator(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

Implements

IOperatorGroup..::.RemoveOperator(IOperator)

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


RemoveSubGroup Method

GPOperatorGroup..::.RemoveSubGroup Method
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorGroup.RemoveSubGroup(HeuristicLab.Core.IOperatorGroup)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void RemoveSubGroup(
    IOperatorGroup group
)

Parameters

group
Type: HeuristicLab.Core..::.IOperatorGroup

[Missing <param> documentation for "group"]

Implements

IOperatorGroup..::.RemoveSubGroup(IOperatorGroup)

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


GPOperatorGroup Events

[image]

HeuristicLab API Documentation
GPOperatorGroup Events
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorGroup type exposes the following members.

Events

Name | Description
NameChanged | (Inherited from OperatorGroup.)
OperatorAdded |
OperatorRemoved |

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


OperatorAdded Event

GPOperatorGroup..::.OperatorAdded Event
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.StructureIdentification.GPOperatorGroup.OperatorAdded]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler OperatorAdded

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


OperatorRemoved Event

GPOperatorGroup..::.OperatorRemoved Event
GPOperatorGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.StructureIdentification.GPOperatorGroup.OperatorRemoved]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler OperatorRemoved

See Also

GPOperatorGroup Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibrary Class

GPOperatorLibrary Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.GPOperatorLibrary]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class GPOperatorLibrary : ItemBase, IOperatorLibrary,
    IItem, IStorable, IEditable, IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.StructureIdentification..::.GPOperatorLibrary

See Also

GPOperatorLibrary Members
HeuristicLab.StructureIdentification Namespace


GPOperatorLibrary Members

[image]

HeuristicLab API Documentation
GPOperatorLibrary Members
GPOperatorLibrary Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibrary type exposes the following members.

Constructors

Name | Description
GPOperatorLibrary |

Methods

Name | Description
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

Fields

Name | Description
ALLOWED_SUBOPERATORS |
INITIALIZATION |
MANIPULATION |
MIN_TREE_HEIGHT |
MIN_TREE_SIZE |
TYPE_ID |

Properties

Name | Description
GPOperatorGroup |
Group |
Guid | (Inherited from StorableBase.)

Events

Name | Description
Changed | (Inherited from ItemBase.)

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibrary Constructor

GPOperatorLibrary Constructor
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GPOperatorLibrary class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GPOperatorLibrary()

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibrary Fields

[image]

HeuristicLab API Documentation
GPOperatorLibrary Fields
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibrary type exposes the following members.

Fields

Name | Description
ALLOWED_SUBOPERATORS |
INITIALIZATION |
MANIPULATION |
MIN_TREE_HEIGHT |
MIN_TREE_SIZE |
TYPE_ID |

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


ALLOWED_SUBOPERATORS Field

GPOperatorLibrary..::.ALLOWED_SUBOPERATORS Field
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.GPOperatorLibrary.ALLOWED_SUBOPERATORS]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal const string ALLOWED_SUBOPERATORS

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


INITIALIZATION Field

GPOperatorLibrary..::.INITIALIZATION Field
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.GPOperatorLibrary.INITIALIZATION]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal const string INITIALIZATION

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


MANIPULATION Field

GPOperatorLibrary..::.MANIPULATION Field
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.GPOperatorLibrary.MANIPULATION]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal const string MANIPULATION

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


MIN_TREE_HEIGHT Field

GPOperatorLibrary..::.MIN_TREE_HEIGHT Field
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.GPOperatorLibrary.MIN_TREE_HEIGHT]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal const string MIN_TREE_HEIGHT

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


MIN_TREE_SIZE Field

GPOperatorLibrary..::.MIN_TREE_SIZE Field
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.GPOperatorLibrary.MIN_TREE_SIZE]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal const string MIN_TREE_SIZE

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


TYPE_ID Field

GPOperatorLibrary..::.TYPE_ID Field
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.GPOperatorLibrary.TYPE_ID]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal const string TYPE_ID

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibrary Methods

[image]

HeuristicLab API Documentation
GPOperatorLibrary Methods
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibrary type exposes the following members.

Methods

Name | Description
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides StorableBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
Populate | (Overrides StorableBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ToString | (Inherited from ItemBase.)

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
GPOperatorLibrary..::.Clone Method
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides StorableBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

GPOperatorLibrary Class
GPOperatorLibrary Members
HeuristicLab.StructureIdentification Namespace


Clone Method (IDictionary(Guid, Object))

GPOperatorLibrary..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

GPOperatorLibrary Class
Clone Overload
HeuristicLab.StructureIdentification Namespace


CreateEditor Method

GPOperatorLibrary..::.CreateEditor Method
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.CreateEditor]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.CreateEditor]

Implements

IEditable..::.CreateEditor()()()

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


CreateView Method

GPOperatorLibrary..::.CreateView Method
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.CreateView]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GetXmlNode Method

GPOperatorLibrary..::.GetXmlNode Method
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


Populate Method

GPOperatorLibrary..::.Populate Method
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.GPOperatorLibrary.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibrary Properties

[image]

HeuristicLab API Documentation
GPOperatorLibrary Properties
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibrary type exposes the following members.

Properties

Name | Description
GPOperatorGroup |
Group |
Guid | (Inherited from StorableBase.)

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GPOperatorGroup Property

GPOperatorLibrary..::.GPOperatorGroup Property
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.GPOperatorLibrary.GPOperatorGroup]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GPOperatorGroup GPOperatorGroup { get; }

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


Group Property

GPOperatorLibrary..::.Group Property
GPOperatorLibrary Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.GPOperatorLibrary.Group]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorGroup Group { get; }

Implements

IOperatorLibrary..::.Group

See Also

GPOperatorLibrary Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibraryEditor Class

GPOperatorLibraryEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.GPOperatorLibraryEditor]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class GPOperatorLibraryEditor : EditorBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.StructureIdentification..::.GPOperatorLibraryEditor

See Also

GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


GPOperatorLibraryEditor Members

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor Members
GPOperatorLibraryEditor Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibraryEditor type exposes the following members.

Constructors

Name | Description
GPOperatorLibraryEditor |

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from EditorBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OperatorLibrary |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibraryEditor Constructor

GPOperatorLibraryEditor Constructor
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GPOperatorLibraryEditor class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GPOperatorLibraryEditor(
    GPOperatorLibrary library
)

Parameters

library
Type: HeuristicLab.StructureIdentification..::.GPOperatorLibrary

[Missing <param> documentation for "library"]

See Also

GPOperatorLibraryEditor Class
HeuristicLab.StructureIdentification Namespace


GPOperatorLibraryEditor Methods

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor Methods
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibraryEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Inherited from ViewBase.)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Inherited from ViewBase.)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Inherited from EditorBase.)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

GPOperatorLibraryEditor Class
HeuristicLab.StructureIdentification Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.AccessibilityNotifyClients Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.BeginInvoke Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Dispose Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.Dispose Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EditorBase ..::. Dispose(Boolean).)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Dispose Method (Boolean)

GPOperatorLibraryEditor..::.Dispose Method (Boolean)
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

GPOperatorLibraryEditor Class
Dispose Overload
HeuristicLab.StructureIdentification Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.GetChildAtPoint Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.Invalidate Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Invoke Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.Invoke Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.MemberwiseClone Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.PerformLayout Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.ResumeLayout Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.RtlTranslateAlignment Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Scale Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.Scale Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Select Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.Select Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.SetBounds Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.UpdateBounds Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


Validate Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.Validate Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor..::.ValidateChildren Method
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

GPOperatorLibraryEditor Class
GPOperatorLibraryEditor Members
HeuristicLab.StructureIdentification Namespace


GPOperatorLibraryEditor Properties

[image]

HeuristicLab API Documentation
GPOperatorLibraryEditor Properties
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GPOperatorLibraryEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
OperatorLibrary |
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

GPOperatorLibraryEditor Class
HeuristicLab.StructureIdentification Namespace


OperatorLibrary Property

GPOperatorLibraryEditor..::.OperatorLibrary Property
GPOperatorLibraryEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.GPOperatorLibraryEditor.OperatorLibrary]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperatorLibrary OperatorLibrary { get; set; }

See Also

GPOperatorLibraryEditor Class
HeuristicLab.StructureIdentification Namespace


HeuristicLabStructureIdentificationPlugin Class

HeuristicLabStructureIdentificationPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.HeuristicLabStructureIdentificationPlugin]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Selection")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[DependencyAttribute(Dependency = "HeuristicLab.DataAnalysis")]
[DependencyAttribute(Dependency = "HeuristicLab.Functions")]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[PluginFileAttribute(Filename = "HeuristicLab.StructureIdentification.dll",
    Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Constraints")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[ClassInfoAttribute(Name = "HeuristicLab.StructureIdentification")]
[DependencyAttribute(Dependency = "HeuristicLab.Random")]
public class HeuristicLabStructureIdentificationPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.StructureIdentification..::.HeuristicLabStructureIdentificationPlugin

See Also

HeuristicLabStructureIdentificationPlugin Members
HeuristicLab.StructureIdentification Namespace


HeuristicLabStructureIdentificationPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabStructureIdentificationPlugin Members
HeuristicLabStructureIdentificationPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabStructureIdentificationPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabStructureIdentificationPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabStructureIdentificationPlugin Class
HeuristicLab.StructureIdentification Namespace


HeuristicLabStructureIdentificationPlugin Constructor

HeuristicLabStructureIdentificationPlugin Constructor
HeuristicLabStructureIdentificationPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabStructureIdentificationPlugin class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabStructureIdentificationPlugin()

See Also

HeuristicLabStructureIdentificationPlugin Class
HeuristicLab.StructureIdentification Namespace


MeanSquaredErrorEvaluator Class

MeanSquaredErrorEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.MeanSquaredErrorEvaluator]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class MeanSquaredErrorEvaluator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.MeanSquaredErrorEvaluator

See Also

MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


MeanSquaredErrorEvaluator Members

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator Members
MeanSquaredErrorEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MeanSquaredErrorEvaluator type exposes the following members.

Constructors

Name | Description
MeanSquaredErrorEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
HeuristicLab.StructureIdentification Namespace


MeanSquaredErrorEvaluator Constructor

MeanSquaredErrorEvaluator Constructor
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the MeanSquaredErrorEvaluator class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public MeanSquaredErrorEvaluator()

See Also

MeanSquaredErrorEvaluator Class
HeuristicLab.StructureIdentification Namespace


MeanSquaredErrorEvaluator Methods

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator Methods
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MeanSquaredErrorEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

MeanSquaredErrorEvaluator Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.AddSubOperator Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


Apply Method

MeanSquaredErrorEvaluator..::.Apply Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.MeanSquaredErrorEvaluator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.MeanSquaredErrorEvaluator.Apply(HeuristicLab.Core.IScope)]

See Also

MeanSquaredErrorEvaluator Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.Clone Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.GetVariableValue Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.IsValid Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.TryAddSubOperator Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.TryAddVariable Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.TryAddVariableInfo Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.TryRemoveSubOperator Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.TryRemoveVariable Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator..::.TryRemoveVariableInfo Method
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
MeanSquaredErrorEvaluator Members
HeuristicLab.StructureIdentification Namespace


MeanSquaredErrorEvaluator Properties

[image]

HeuristicLab API Documentation
MeanSquaredErrorEvaluator Properties
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MeanSquaredErrorEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

MeanSquaredErrorEvaluator Class
HeuristicLab.StructureIdentification Namespace


Description Property

MeanSquaredErrorEvaluator..::.Description Property
MeanSquaredErrorEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.MeanSquaredErrorEvaluator.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

MeanSquaredErrorEvaluator Class
HeuristicLab.StructureIdentification Namespace


OnePointShaker Class

OnePointShaker Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.OnePointShaker]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class OnePointShaker : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.OnePointShaker

See Also

OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


OnePointShaker Members

[image]

HeuristicLab API Documentation
OnePointShaker Members
OnePointShaker Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OnePointShaker type exposes the following members.

Constructors

Name | Description
OnePointShaker |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
HeuristicLab.StructureIdentification Namespace


OnePointShaker Constructor

OnePointShaker Constructor
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OnePointShaker class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OnePointShaker()

See Also

OnePointShaker Class
HeuristicLab.StructureIdentification Namespace


OnePointShaker Methods

[image]

HeuristicLab API Documentation
OnePointShaker Methods
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OnePointShaker type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

OnePointShaker Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.AddSubOperator Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


Apply Method

OnePointShaker..::.Apply Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.OnePointShaker.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.OnePointShaker.Apply(HeuristicLab.Core.IScope)]

See Also

OnePointShaker Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.Clone Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.GetVariableValue Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.IsValid Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.TryAddSubOperator Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.TryAddVariable Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.TryAddVariableInfo Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.TryRemoveSubOperator Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.TryRemoveVariable Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
OnePointShaker..::.TryRemoveVariableInfo Method
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
OnePointShaker Members
HeuristicLab.StructureIdentification Namespace


OnePointShaker Properties

[image]

HeuristicLab API Documentation
OnePointShaker Properties
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OnePointShaker type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

OnePointShaker Class
HeuristicLab.StructureIdentification Namespace


Description Property

OnePointShaker..::.Description Property
OnePointShaker Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.OnePointShaker.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

OnePointShaker Class
HeuristicLab.StructureIdentification Namespace


OperatorEventArgs Class

OperatorEventArgs Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.OperatorEventArgs]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class OperatorEventArgs : EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
HeuristicLab.StructureIdentification..::.OperatorEventArgs

See Also

OperatorEventArgs Members
HeuristicLab.StructureIdentification Namespace


OperatorEventArgs Members

[image]

HeuristicLab API Documentation
OperatorEventArgs Members
OperatorEventArgs Class Constructors Methods Fields See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorEventArgs type exposes the following members.

Constructors

Name | Description
OperatorEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
op |

See Also

OperatorEventArgs Class
HeuristicLab.StructureIdentification Namespace


OperatorEventArgs Constructor

OperatorEventArgs Constructor
OperatorEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorEventArgs class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorEventArgs(
    IOperator op
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

See Also

OperatorEventArgs Class
HeuristicLab.StructureIdentification Namespace


OperatorEventArgs Fields

[image]

HeuristicLab API Documentation
OperatorEventArgs Fields
OperatorEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The OperatorEventArgs type exposes the following members.

Fields

Name | Description
op |

See Also

OperatorEventArgs Class
HeuristicLab.StructureIdentification Namespace


op Field

OperatorEventArgs..::.op Field
OperatorEventArgs Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.StructureIdentification.OperatorEventArgs.op]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IOperator op

See Also

OperatorEventArgs Class
HeuristicLab.StructureIdentification Namespace


PopulationAnalyser Class

PopulationAnalyser Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.PopulationAnalyser]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class PopulationAnalyser : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.PopulationAnalyser

See Also

PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


PopulationAnalyser Members

[image]

HeuristicLab API Documentation
PopulationAnalyser Members
PopulationAnalyser Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PopulationAnalyser type exposes the following members.

Constructors

Name | Description
PopulationAnalyser |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
HeuristicLab.StructureIdentification Namespace


PopulationAnalyser Constructor

PopulationAnalyser Constructor
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PopulationAnalyser class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public PopulationAnalyser()

See Also

PopulationAnalyser Class
HeuristicLab.StructureIdentification Namespace


PopulationAnalyser Methods

[image]

HeuristicLab API Documentation
PopulationAnalyser Methods
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PopulationAnalyser type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

PopulationAnalyser Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.AddSubOperator Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


Apply Method

PopulationAnalyser..::.Apply Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope topScope
)

Parameters

topScope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "topScope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.Apply(HeuristicLab.Core.IScope)]

See Also

PopulationAnalyser Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.Clone Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.GetVariableValue Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.IsValid Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.TryAddSubOperator Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.TryAddVariable Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.TryAddVariableInfo Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.TryRemoveSubOperator Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.TryRemoveVariable Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
PopulationAnalyser..::.TryRemoveVariableInfo Method
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
PopulationAnalyser Members
HeuristicLab.StructureIdentification Namespace


PopulationAnalyser Properties

[image]

HeuristicLab API Documentation
PopulationAnalyser Properties
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PopulationAnalyser type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

PopulationAnalyser Class
HeuristicLab.StructureIdentification Namespace


Description Property

PopulationAnalyser..::.Description Property
PopulationAnalyser Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.PopulationAnalyser.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

PopulationAnalyser Class
HeuristicLab.StructureIdentification Namespace


RandomTreeCreator Class

RandomTreeCreator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.RandomTreeCreator]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RandomTreeCreator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.RandomTreeCreator

See Also

RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


RandomTreeCreator Members

[image]

HeuristicLab API Documentation
RandomTreeCreator Members
RandomTreeCreator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomTreeCreator type exposes the following members.

Constructors

Name | Description
RandomTreeCreator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
HeuristicLab.StructureIdentification Namespace


RandomTreeCreator Constructor

RandomTreeCreator Constructor
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomTreeCreator class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RandomTreeCreator()

See Also

RandomTreeCreator Class
HeuristicLab.StructureIdentification Namespace


RandomTreeCreator Methods

[image]

HeuristicLab API Documentation
RandomTreeCreator Methods
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomTreeCreator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RandomTreeCreator Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.AddSubOperator Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


Apply Method

RandomTreeCreator..::.Apply Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.RandomTreeCreator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.RandomTreeCreator.Apply(HeuristicLab.Core.IScope)]

See Also

RandomTreeCreator Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.Clone Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.GetVariableValue Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.IsValid Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.TryAddSubOperator Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.TryAddVariable Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.TryAddVariableInfo Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.TryRemoveSubOperator Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.TryRemoveVariable Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RandomTreeCreator..::.TryRemoveVariableInfo Method
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
RandomTreeCreator Members
HeuristicLab.StructureIdentification Namespace


RandomTreeCreator Properties

[image]

HeuristicLab API Documentation
RandomTreeCreator Properties
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RandomTreeCreator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RandomTreeCreator Class
HeuristicLab.StructureIdentification Namespace


Description Property

RandomTreeCreator..::.Description Property
RandomTreeCreator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.RandomTreeCreator.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RandomTreeCreator Class
HeuristicLab.StructureIdentification Namespace


SinglePointCrossOver Class

SinglePointCrossOver Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.SinglePointCrossOver]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SinglePointCrossOver : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.SinglePointCrossOver

See Also

SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


SinglePointCrossOver Members

[image]

HeuristicLab API Documentation
SinglePointCrossOver Members
SinglePointCrossOver Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossOver type exposes the following members.

Constructors

Name | Description
SinglePointCrossOver |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
HeuristicLab.StructureIdentification Namespace


SinglePointCrossOver Constructor

SinglePointCrossOver Constructor
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SinglePointCrossOver class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SinglePointCrossOver()

See Also

SinglePointCrossOver Class
HeuristicLab.StructureIdentification Namespace


SinglePointCrossOver Methods

[image]

HeuristicLab API Documentation
SinglePointCrossOver Methods
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossOver type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SinglePointCrossOver Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.AddSubOperator Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


Apply Method

SinglePointCrossOver..::.Apply Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.SinglePointCrossOver.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.SinglePointCrossOver.Apply(HeuristicLab.Core.IScope)]

See Also

SinglePointCrossOver Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.Clone Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.GetVariableValue Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.IsValid Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.TryAddSubOperator Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.TryAddVariable Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.TryAddVariableInfo Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.TryRemoveSubOperator Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.TryRemoveVariable Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SinglePointCrossOver..::.TryRemoveVariableInfo Method
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
SinglePointCrossOver Members
HeuristicLab.StructureIdentification Namespace


SinglePointCrossOver Properties

[image]

HeuristicLab API Documentation
SinglePointCrossOver Properties
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SinglePointCrossOver type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SinglePointCrossOver Class
HeuristicLab.StructureIdentification Namespace


Description Property

SinglePointCrossOver..::.Description Property
SinglePointCrossOver Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.SinglePointCrossOver.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SinglePointCrossOver Class
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjector Class

StructIdProblemInjector Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.StructIdProblemInjector]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class StructIdProblemInjector : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.StructIdProblemInjector

See Also

StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjector Members

[image]

HeuristicLab API Documentation
StructIdProblemInjector Members
StructIdProblemInjector Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StructIdProblemInjector type exposes the following members.

Constructors

Name | Description
StructIdProblemInjector |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjector Constructor

StructIdProblemInjector Constructor
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StructIdProblemInjector class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StructIdProblemInjector()

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjector Methods

[image]

HeuristicLab API Documentation
StructIdProblemInjector Methods
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StructIdProblemInjector type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Overrides OperatorBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.AddSubOperator Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


Apply Method

StructIdProblemInjector..::.Apply Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjector.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjector.Apply(HeuristicLab.Core.IScope)]

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.Clone Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


CreateView Method

StructIdProblemInjector..::.CreateView Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjector.CreateView]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjector.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.GetVariableValue Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.IsValid Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.TryAddSubOperator Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.TryAddVariable Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.TryAddVariableInfo Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.TryRemoveSubOperator Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.TryRemoveVariable Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
StructIdProblemInjector..::.TryRemoveVariableInfo Method
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
StructIdProblemInjector Members
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjector Properties

[image]

HeuristicLab API Documentation
StructIdProblemInjector Properties
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StructIdProblemInjector type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


Description Property

StructIdProblemInjector..::.Description Property
StructIdProblemInjector Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.StructIdProblemInjector.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

StructIdProblemInjector Class
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Class

StructIdProblemInjectorView Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.StructIdProblemInjectorView]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class StructIdProblemInjectorView : ViewBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.StructureIdentification..::.StructIdProblemInjectorView

See Also

StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Members

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView Members
StructIdProblemInjectorView Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StructIdProblemInjectorView type exposes the following members.

Constructors

Name | Description
StructIdProblemInjectorView | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
StructIdProblemInjector |
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Constructor

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView Constructor
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
StructIdProblemInjectorView()()() |
StructIdProblemInjectorView(StructIdProblemInjector) |

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Constructor

StructIdProblemInjectorView Constructor
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StructIdProblemInjectorView class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StructIdProblemInjectorView()

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Overload
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Constructor (StructIdProblemInjector)

StructIdProblemInjectorView Constructor (StructIdProblemInjector)
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the StructIdProblemInjectorView class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StructIdProblemInjectorView(
    StructIdProblemInjector structIdProblemInjector
)

Parameters

structIdProblemInjector
Type: HeuristicLab.StructureIdentification..::.StructIdProblemInjector

[Missing <param> documentation for "structIdProblemInjector"]

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Overload
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Methods

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView Methods
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StructIdProblemInjectorView type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides ViewBase ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides ViewBase ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides ViewBase ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.AccessibilityNotifyClients Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


AddItemEvents Method

StructIdProblemInjectorView..::.AddItemEvents Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjectorView.AddItemEvents]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.BeginInvoke Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


Dispose Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.Dispose Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides ViewBase ..::. Dispose(Boolean).)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


Dispose Method (Boolean)

StructIdProblemInjectorView..::.Dispose Method (Boolean)
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

StructIdProblemInjectorView Class
Dispose Overload
HeuristicLab.StructureIdentification Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.GetChildAtPoint Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.Invalidate Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


Invoke Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.Invoke Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.MemberwiseClone Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.PerformLayout Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


RemoveItemEvents Method

StructIdProblemInjectorView..::.RemoveItemEvents Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjectorView.RemoveItemEvents]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.ResumeLayout Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.RtlTranslateAlignment Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


Scale Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.Scale Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


Select Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.Select Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.SetBounds Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.UpdateBounds Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


UpdateControls Method

StructIdProblemInjectorView..::.UpdateControls Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.StructIdProblemInjectorView.UpdateControls]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


Validate Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.Validate Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView..::.ValidateChildren Method
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

StructIdProblemInjectorView Class
StructIdProblemInjectorView Members
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjectorView Properties

[image]

HeuristicLab API Documentation
StructIdProblemInjectorView Properties
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The StructIdProblemInjectorView type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
StructIdProblemInjector |
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


StructIdProblemInjector Property

StructIdProblemInjectorView..::.StructIdProblemInjector Property
StructIdProblemInjectorView Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.StructIdProblemInjectorView.StructIdProblemInjector]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public StructIdProblemInjector StructIdProblemInjector { get; set; }

See Also

StructIdProblemInjectorView Class
HeuristicLab.StructureIdentification Namespace


SubstituteSubTreeManipulation Class

SubstituteSubTreeManipulation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.SubstituteSubTreeManipulation]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SubstituteSubTreeManipulation : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.SubstituteSubTreeManipulation

See Also

SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


SubstituteSubTreeManipulation Members

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation Members
SubstituteSubTreeManipulation Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubstituteSubTreeManipulation type exposes the following members.

Constructors

Name | Description
SubstituteSubTreeManipulation |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


SubstituteSubTreeManipulation Constructor

SubstituteSubTreeManipulation Constructor
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SubstituteSubTreeManipulation class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SubstituteSubTreeManipulation()

See Also

SubstituteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


SubstituteSubTreeManipulation Methods

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation Methods
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubstituteSubTreeManipulation type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SubstituteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.AddSubOperator Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


Apply Method

SubstituteSubTreeManipulation..::.Apply Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.SubstituteSubTreeManipulation.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.SubstituteSubTreeManipulation.Apply(HeuristicLab.Core.IScope)]

See Also

SubstituteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.Clone Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.GetVariableValue Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.IsValid Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.TryAddSubOperator Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.TryAddVariable Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.TryAddVariableInfo Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.TryRemoveSubOperator Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.TryRemoveVariable Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation..::.TryRemoveVariableInfo Method
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
SubstituteSubTreeManipulation Members
HeuristicLab.StructureIdentification Namespace


SubstituteSubTreeManipulation Properties

[image]

HeuristicLab API Documentation
SubstituteSubTreeManipulation Properties
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SubstituteSubTreeManipulation type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SubstituteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


Description Property

SubstituteSubTreeManipulation..::.Description Property
SubstituteSubTreeManipulation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.SubstituteSubTreeManipulation.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SubstituteSubTreeManipulation Class
HeuristicLab.StructureIdentification Namespace


TreeGardener Class

TreeGardener Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.TreeGardener]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class TreeGardener

Inheritance Hierarchy

System..::.Object
HeuristicLab.StructureIdentification..::.TreeGardener

See Also

TreeGardener Members
HeuristicLab.StructureIdentification Namespace


TreeGardener Members

[image]

HeuristicLab API Documentation
TreeGardener Members
TreeGardener Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TreeGardener type exposes the following members.

Constructors

Name | Description
TreeGardener |

Methods

Name | Description
CreateInitializationOperation |
CreateRandomTree | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllOperators |
GetAllowedParents |
GetAllowedSubOperators |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMinMaxArity |
GetNodeLevel | returns the height level of op in the tree if the op == tree => 1 if op is in the suboperators of tree => 2 ... if op is not found => -1
GetPossibleParents |
GetRandomNode |
GetRandomParentNode |
GetTreeHeight |
GetTreeSize |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsTerminal |
IsValidTree |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllOperators |
Terminals |

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


TreeGardener Constructor

TreeGardener Constructor
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TreeGardener class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal TreeGardener(
    IRandom random,
    IOperatorLibrary opLibrary
)

Parameters

random
Type: HeuristicLab.Core..::.IRandom

[Missing <param> documentation for "random"]

opLibrary
Type: HeuristicLab.Core..::.IOperatorLibrary

[Missing <param> documentation for "opLibrary"]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


TreeGardener Methods

[image]

HeuristicLab API Documentation
TreeGardener Methods
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TreeGardener type exposes the following members.

Methods

Name | Description
CreateInitializationOperation |
CreateRandomTree | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAllOperators |
GetAllowedParents |
GetAllowedSubOperators |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMinMaxArity |
GetNodeLevel | returns the height level of op in the tree if the op == tree => 1 if op is in the suboperators of tree => 2 ... if op is not found => -1
GetPossibleParents |
GetRandomNode |
GetRandomParentNode |
GetTreeHeight |
GetTreeSize |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsTerminal |
IsValidTree |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


CreateInitializationOperation Method

TreeGardener..::.CreateInitializationOperation Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateInitializationOperation(System.Collections.Generic.ICollection{HeuristicLab.Core.IOperator},HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal CompositeOperation CreateInitializationOperation(
    ICollection<IOperator> operators,
    IScope scope
)

Parameters

operators
Type: System.Collections.Generic..::.ICollection <(Of <( IOperator >)>)

[Missing <param> documentation for "operators"]

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateInitializationOperation(System.Collections.Generic.ICollection{HeuristicLab.Core.IOperator},HeuristicLab.Core.IScope)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


CreateRandomTree Method

[image]

HeuristicLab API Documentation
TreeGardener..::.CreateRandomTree Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CreateRandomTree(Int32, Int32, Boolean) |
CreateRandomTree(ICollection<(Of <(IOperator>)>), Int32, Int32, Boolean) |
CreateRandomTree(IOperator, Int32, Int32, Boolean) |

See Also

TreeGardener Class
TreeGardener Members
HeuristicLab.StructureIdentification Namespace


CreateRandomTree Method (Int32, Int32, Boolean)

TreeGardener..::.CreateRandomTree Method (Int32, Int32, Boolean)
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateRandomTree(System.Int32,System.Int32,System.Boolean)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IOperator CreateRandomTree(
    int maxTreeSize,
    int maxTreeHeight,
    bool balanceTrees
)

Parameters

maxTreeSize
Type: System..::.Int32

[Missing <param> documentation for "maxTreeSize"]

maxTreeHeight
Type: System..::.Int32

[Missing <param> documentation for "maxTreeHeight"]

balanceTrees
Type: System..::.Boolean

[Missing <param> documentation for "balanceTrees"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateRandomTree(System.Int32,System.Int32,System.Boolean)]

See Also

TreeGardener Class
CreateRandomTree Overload
HeuristicLab.StructureIdentification Namespace


CreateRandomTree Method (ICollection(IOperator), Int32, Int32, Boolean)

TreeGardener..::.CreateRandomTree Method (ICollection<(Of <(IOperator>)>), Int32, Int32, Boolean)
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateRandomTree(System.Collections.Generic.ICollection{HeuristicLab.Core.IOperator},System.Int32,System.Int32,System.Boolean)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IOperator CreateRandomTree(
    ICollection<IOperator> allowedOperators,
    int maxTreeSize,
    int maxTreeHeight,
    bool balanceTrees
)

Parameters

allowedOperators
Type: System.Collections.Generic..::.ICollection <(Of <( IOperator >)>)

[Missing <param> documentation for "allowedOperators"]

maxTreeSize
Type: System..::.Int32

[Missing <param> documentation for "maxTreeSize"]

maxTreeHeight
Type: System..::.Int32

[Missing <param> documentation for "maxTreeHeight"]

balanceTrees
Type: System..::.Boolean

[Missing <param> documentation for "balanceTrees"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateRandomTree(System.Collections.Generic.ICollection{HeuristicLab.Core.IOperator},System.Int32,System.Int32,System.Boolean)]

See Also

TreeGardener Class
CreateRandomTree Overload
HeuristicLab.StructureIdentification Namespace


CreateRandomTree Method (IOperator, Int32, Int32, Boolean)

TreeGardener..::.CreateRandomTree Method (IOperator, Int32, Int32, Boolean)
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateRandomTree(HeuristicLab.Core.IOperator,System.Int32,System.Int32,System.Boolean)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IOperator CreateRandomTree(
    IOperator root,
    int maxTreeSize,
    int maxTreeHeight,
    bool balanceTrees
)

Parameters

root
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "root"]

maxTreeSize
Type: System..::.Int32

[Missing <param> documentation for "maxTreeSize"]

maxTreeHeight
Type: System..::.Int32

[Missing <param> documentation for "maxTreeHeight"]

balanceTrees
Type: System..::.Boolean

[Missing <param> documentation for "balanceTrees"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.CreateRandomTree(HeuristicLab.Core.IOperator,System.Int32,System.Int32,System.Boolean)]

See Also

TreeGardener Class
CreateRandomTree Overload
HeuristicLab.StructureIdentification Namespace


GetAllOperators Method

TreeGardener..::.GetAllOperators Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetAllOperators(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal ICollection<IOperator> GetAllOperators(
    IOperator root
)

Parameters

root
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "root"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetAllOperators(HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetAllowedParents Method

TreeGardener..::.GetAllowedParents Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetAllowedParents(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IList<IOperator> GetAllowedParents(
    IOperator child,
    int childIndex
)

Parameters

child
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "child"]

childIndex
Type: System..::.Int32

[Missing <param> documentation for "childIndex"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetAllowedParents(HeuristicLab.Core.IOperator,System.Int32)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetAllowedSubOperators Method

TreeGardener..::.GetAllowedSubOperators Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetAllowedSubOperators(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IList<IOperator> GetAllowedSubOperators(
    IOperator op,
    int index
)

Parameters

op
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "op"]

index
Type: System..::.Int32

[Missing <param> documentation for "index"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetAllowedSubOperators(HeuristicLab.Core.IOperator,System.Int32)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetMinMaxArity Method

TreeGardener..::.GetMinMaxArity Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetMinMaxArity(HeuristicLab.Core.IOperator,System.Int32@,System.Int32@)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal void GetMinMaxArity(
    IOperator root,
    out int minArity,
    out int maxArity
)

Parameters

root
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "root"]

minArity
Type: System..::.Int32 %

[Missing <param> documentation for "minArity"]

maxArity
Type: System..::.Int32 %

[Missing <param> documentation for "maxArity"]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetNodeLevel Method

TreeGardener..::.GetNodeLevel Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

returns the height level of op in the tree if the op == tree => 1 if op is in the suboperators of tree => 2 ... if op is not found => -1

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal int GetNodeLevel(
    IOperator tree,
    IOperator op
)

Parameters

tree
Type: HeuristicLab.Core..::.IOperator
operator tree to process
op
Type: HeuristicLab.Core..::.IOperator
operater that is searched in the tree

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetNodeLevel(HeuristicLab.Core.IOperator,HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetPossibleParents Method

TreeGardener..::.GetPossibleParents Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetPossibleParents(System.Collections.Generic.List{HeuristicLab.Core.IOperator})]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal ICollection<IOperator> GetPossibleParents(
    List<IOperator> list
)

Parameters

list
Type: System.Collections.Generic..::.List <(Of <( IOperator >)>)

[Missing <param> documentation for "list"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetPossibleParents(System.Collections.Generic.List{HeuristicLab.Core.IOperator})]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetRandomNode Method

TreeGardener..::.GetRandomNode Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetRandomNode(HeuristicLab.Core.IOperator,System.Int32)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IOperator GetRandomNode(
    IOperator tree,
    int level
)

Parameters

tree
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "tree"]

level
Type: System..::.Int32

[Missing <param> documentation for "level"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetRandomNode(HeuristicLab.Core.IOperator,System.Int32)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetRandomParentNode Method

TreeGardener..::.GetRandomParentNode Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetRandomParentNode(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IOperator GetRandomParentNode(
    IOperator tree
)

Parameters

tree
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "tree"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetRandomParentNode(HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetTreeHeight Method

TreeGardener..::.GetTreeHeight Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetTreeHeight(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal int GetTreeHeight(
    IOperator tree
)

Parameters

tree
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "tree"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetTreeHeight(HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


GetTreeSize Method

TreeGardener..::.GetTreeSize Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetTreeSize(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal int GetTreeSize(
    IOperator tree
)

Parameters

tree
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "tree"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.GetTreeSize(HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


IsTerminal Method

TreeGardener..::.IsTerminal Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.IsTerminal(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal bool IsTerminal(
    IOperator f
)

Parameters

f
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "f"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.IsTerminal(HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


IsValidTree Method

TreeGardener..::.IsValidTree Method
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.IsValidTree(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal bool IsValidTree(
    IOperator tree
)

Parameters

tree
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "tree"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.IsValidTree(HeuristicLab.Core.IOperator)]

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


TreeGardener Properties

[image]

HeuristicLab API Documentation
TreeGardener Properties
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TreeGardener type exposes the following members.

Properties

Name | Description
AllOperators |
Terminals |

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


AllOperators Property

TreeGardener..::.AllOperators Property
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.TreeGardener.AllOperators]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IList<IOperator> AllOperators { get; }

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


Terminals Property

TreeGardener..::.Terminals Property
TreeGardener Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.TreeGardener.Terminals]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal IList<IOperator> Terminals { get; }

See Also

TreeGardener Class
HeuristicLab.StructureIdentification Namespace


TreeGardener.OperatorEqualityComparer Class

TreeGardener..::.OperatorEqualityComparer Class
TreeGardener Class Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.TreeGardener.OperatorEqualityComparer]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
internal class OperatorEqualityComparer : IEqualityComparer<IOperator>

Inheritance Hierarchy

System..::.Object
HeuristicLab.StructureIdentification..::.TreeGardener..::.OperatorEqualityComparer

See Also

TreeGardener..::.OperatorEqualityComparer Members
HeuristicLab.StructureIdentification Namespace


TreeGardener.OperatorEqualityComparer Members

[image]

HeuristicLab API Documentation
TreeGardener..::.OperatorEqualityComparer Members
TreeGardener..::.OperatorEqualityComparer Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TreeGardener..::.OperatorEqualityComparer type exposes the following members.

Constructors

Name | Description
TreeGardener..::.OperatorEqualityComparer |

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeGardener..::.OperatorEqualityComparer Class
HeuristicLab.StructureIdentification Namespace


TreeGardener.OperatorEqualityComparer Constructor

TreeGardener..::.OperatorEqualityComparer Constructor
TreeGardener..::.OperatorEqualityComparer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OperatorEqualityComparer class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public OperatorEqualityComparer()

See Also

TreeGardener..::.OperatorEqualityComparer Class
HeuristicLab.StructureIdentification Namespace


TreeGardener.OperatorEqualityComparer Methods

[image]

HeuristicLab API Documentation
TreeGardener..::.OperatorEqualityComparer Methods
TreeGardener..::.OperatorEqualityComparer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TreeGardener..::.OperatorEqualityComparer type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeGardener..::.OperatorEqualityComparer Class
HeuristicLab.StructureIdentification Namespace


Equals Method

[image]

HeuristicLab API Documentation
TreeGardener..::.OperatorEqualityComparer..::.Equals Method
TreeGardener..::.OperatorEqualityComparer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(IOperator, IOperator) |

See Also

TreeGardener..::.OperatorEqualityComparer Class
TreeGardener..::.OperatorEqualityComparer Members
HeuristicLab.StructureIdentification Namespace


Equals Method (IOperator, IOperator)

TreeGardener..::.OperatorEqualityComparer..::.Equals Method (IOperator, IOperator)
TreeGardener..::.OperatorEqualityComparer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.OperatorEqualityComparer.Equals(HeuristicLab.Core.IOperator,HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool Equals(
    IOperator x,
    IOperator y
)

Parameters

x
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "x"]

y
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.OperatorEqualityComparer.Equals(HeuristicLab.Core.IOperator,HeuristicLab.Core.IOperator)]

Implements

IEqualityComparer<(Of <(T>)>)..::.Equals(T, T)

See Also

TreeGardener..::.OperatorEqualityComparer Class
Equals Overload
HeuristicLab.StructureIdentification Namespace


GetHashCode Method

[image]

HeuristicLab API Documentation
TreeGardener..::.OperatorEqualityComparer..::.GetHashCode Method
TreeGardener..::.OperatorEqualityComparer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetHashCode()()() | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetHashCode(IOperator) |

See Also

TreeGardener..::.OperatorEqualityComparer Class
TreeGardener..::.OperatorEqualityComparer Members
HeuristicLab.StructureIdentification Namespace


GetHashCode Method (IOperator)

TreeGardener..::.OperatorEqualityComparer..::.GetHashCode Method (IOperator)
TreeGardener..::.OperatorEqualityComparer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.OperatorEqualityComparer.GetHashCode(HeuristicLab.Core.IOperator)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int GetHashCode(
    IOperator obj
)

Parameters

obj
Type: HeuristicLab.Core..::.IOperator

[Missing <param> documentation for "obj"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.TreeGardener.OperatorEqualityComparer.GetHashCode(HeuristicLab.Core.IOperator)]

Implements

IEqualityComparer<(Of <(T>)>)..::.GetHashCode(T)

See Also

TreeGardener..::.OperatorEqualityComparer Class
GetHashCode Overload
HeuristicLab.StructureIdentification Namespace


VarianceAccountedForEvaluator Class

VarianceAccountedForEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.StructureIdentification.VarianceAccountedForEvaluator]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class VarianceAccountedForEvaluator : OperatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.StructureIdentification..::.VarianceAccountedForEvaluator

See Also

VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


VarianceAccountedForEvaluator Members

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator Members
VarianceAccountedForEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VarianceAccountedForEvaluator type exposes the following members.

Constructors

Name | Description
VarianceAccountedForEvaluator | The Variance Accounted For (VAF) function calculates is computed as VAF(y,y') = ( 1 - var(y-y')/var(y) ) where y' denotes the predicted / modelled values for y and var(x) the variance of a signal x.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
HeuristicLab.StructureIdentification Namespace


VarianceAccountedForEvaluator Constructor

VarianceAccountedForEvaluator Constructor
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Variance Accounted For (VAF) function calculates is computed as VAF(y,y') = ( 1 - var(y-y')/var(y) ) where y' denotes the predicted / modelled values for y and var(x) the variance of a signal x.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public VarianceAccountedForEvaluator()

See Also

VarianceAccountedForEvaluator Class
HeuristicLab.StructureIdentification Namespace


VarianceAccountedForEvaluator Methods

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator Methods
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VarianceAccountedForEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Overrides OperatorBase ..::. Apply(IScope).)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

VarianceAccountedForEvaluator Class
HeuristicLab.StructureIdentification Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.AddSubOperator Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


Apply Method

VarianceAccountedForEvaluator..::.Apply Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.VarianceAccountedForEvaluator.Apply(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IOperation Apply(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.StructureIdentification.VarianceAccountedForEvaluator.Apply(HeuristicLab.Core.IScope)]

See Also

VarianceAccountedForEvaluator Class
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.Clone Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.GetVariableValue Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


IsValid Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.IsValid Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.TryAddSubOperator Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.TryAddVariable Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.TryAddVariableInfo Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.TryRemoveSubOperator Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.TryRemoveVariable Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator..::.TryRemoveVariableInfo Method
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
VarianceAccountedForEvaluator Members
HeuristicLab.StructureIdentification Namespace


VarianceAccountedForEvaluator Properties

[image]

HeuristicLab API Documentation
VarianceAccountedForEvaluator Properties
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VarianceAccountedForEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

VarianceAccountedForEvaluator Class
HeuristicLab.StructureIdentification Namespace


Description Property

VarianceAccountedForEvaluator..::.Description Property
VarianceAccountedForEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.VarianceAccountedForEvaluator.Description]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

VarianceAccountedForEvaluator Class
HeuristicLab.StructureIdentification Namespace


HeuristicLab.TestFunctions Namespace

HeuristicLab.TestFunctions Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.TestFunctions]

Classes

Class | Description
AckleyEvaluator |
GriewangkEvaluator |
HeuristicLabTestFunctionsPlugin |
RastriginEvaluator |
RosenbrockEvaluator |
SchwefelEvaluator |
SphereEvaluator |
TestFunctionEvaluatorBase |


AckleyEvaluator Class

AckleyEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.AckleyEvaluator]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class AckleyEvaluator : TestFunctionEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.AckleyEvaluator

See Also

AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


AckleyEvaluator Members

[image]

HeuristicLab API Documentation
AckleyEvaluator Members
AckleyEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AckleyEvaluator type exposes the following members.

Constructors

Name | Description
AckleyEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
HeuristicLab.TestFunctions Namespace


AckleyEvaluator Constructor

AckleyEvaluator Constructor
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the AckleyEvaluator class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public AckleyEvaluator()

See Also

AckleyEvaluator Class
HeuristicLab.TestFunctions Namespace


AckleyEvaluator Methods

[image]

HeuristicLab API Documentation
AckleyEvaluator Methods
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AckleyEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

AckleyEvaluator Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.AddSubOperator Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.Clone Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

AckleyEvaluator..::.EvaluateFunction Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.AckleyEvaluator.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.AckleyEvaluator.EvaluateFunction(System.Double[])]

See Also

AckleyEvaluator Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.GetVariableValue Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.IsValid Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.TryAddSubOperator Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.TryAddVariable Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.TryAddVariableInfo Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.TryRemoveSubOperator Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.TryRemoveVariable Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
AckleyEvaluator..::.TryRemoveVariableInfo Method
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
AckleyEvaluator Members
HeuristicLab.TestFunctions Namespace


AckleyEvaluator Properties

[image]

HeuristicLab API Documentation
AckleyEvaluator Properties
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AckleyEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

AckleyEvaluator Class
HeuristicLab.TestFunctions Namespace


Description Property

AckleyEvaluator..::.Description Property
AckleyEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.TestFunctions.AckleyEvaluator.Description]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

AckleyEvaluator Class
HeuristicLab.TestFunctions Namespace


GriewangkEvaluator Class

GriewangkEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.GriewangkEvaluator]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class GriewangkEvaluator : TestFunctionEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.GriewangkEvaluator

See Also

GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


GriewangkEvaluator Members

[image]

HeuristicLab API Documentation
GriewangkEvaluator Members
GriewangkEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GriewangkEvaluator type exposes the following members.

Constructors

Name | Description
GriewangkEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
HeuristicLab.TestFunctions Namespace


GriewangkEvaluator Constructor

GriewangkEvaluator Constructor
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GriewangkEvaluator class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public GriewangkEvaluator()

See Also

GriewangkEvaluator Class
HeuristicLab.TestFunctions Namespace


GriewangkEvaluator Methods

[image]

HeuristicLab API Documentation
GriewangkEvaluator Methods
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GriewangkEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

GriewangkEvaluator Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.AddSubOperator Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.Clone Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

GriewangkEvaluator..::.EvaluateFunction Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.GriewangkEvaluator.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.GriewangkEvaluator.EvaluateFunction(System.Double[])]

See Also

GriewangkEvaluator Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.GetVariableValue Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.IsValid Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.TryAddSubOperator Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.TryAddVariable Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.TryAddVariableInfo Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.TryRemoveSubOperator Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.TryRemoveVariable Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
GriewangkEvaluator..::.TryRemoveVariableInfo Method
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
GriewangkEvaluator Members
HeuristicLab.TestFunctions Namespace


GriewangkEvaluator Properties

[image]

HeuristicLab API Documentation
GriewangkEvaluator Properties
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GriewangkEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

GriewangkEvaluator Class
HeuristicLab.TestFunctions Namespace


Description Property

GriewangkEvaluator..::.Description Property
GriewangkEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.TestFunctions.GriewangkEvaluator.Description]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

GriewangkEvaluator Class
HeuristicLab.TestFunctions Namespace


HeuristicLabTestFunctionsPlugin Class

HeuristicLabTestFunctionsPlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.HeuristicLabTestFunctionsPlugin]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
[DependencyAttribute(Dependency = "HeuristicLab.Operators")]
[DependencyAttribute(Dependency = "HeuristicLab.Data")]
[ClassInfoAttribute(Name = "HeuristicLab.TestFunctions")]
[PluginFileAttribute(Filename = "HeuristicLab.TestFunctions.dll", Filetype = PluginFileType.Assembly)]
public class HeuristicLabTestFunctionsPlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.TestFunctions..::.HeuristicLabTestFunctionsPlugin

See Also

HeuristicLabTestFunctionsPlugin Members
HeuristicLab.TestFunctions Namespace


HeuristicLabTestFunctionsPlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabTestFunctionsPlugin Members
HeuristicLabTestFunctionsPlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabTestFunctionsPlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabTestFunctionsPlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabTestFunctionsPlugin Class
HeuristicLab.TestFunctions Namespace


HeuristicLabTestFunctionsPlugin Constructor

HeuristicLabTestFunctionsPlugin Constructor
HeuristicLabTestFunctionsPlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabTestFunctionsPlugin class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabTestFunctionsPlugin()

See Also

HeuristicLabTestFunctionsPlugin Class
HeuristicLab.TestFunctions Namespace


RastriginEvaluator Class

RastriginEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.RastriginEvaluator]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RastriginEvaluator : TestFunctionEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.RastriginEvaluator

See Also

RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


RastriginEvaluator Members

[image]

HeuristicLab API Documentation
RastriginEvaluator Members
RastriginEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RastriginEvaluator type exposes the following members.

Constructors

Name | Description
RastriginEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
HeuristicLab.TestFunctions Namespace


RastriginEvaluator Constructor

RastriginEvaluator Constructor
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RastriginEvaluator class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RastriginEvaluator()

See Also

RastriginEvaluator Class
HeuristicLab.TestFunctions Namespace


RastriginEvaluator Methods

[image]

HeuristicLab API Documentation
RastriginEvaluator Methods
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RastriginEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RastriginEvaluator Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.AddSubOperator Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.Clone Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

RastriginEvaluator..::.EvaluateFunction Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.RastriginEvaluator.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.RastriginEvaluator.EvaluateFunction(System.Double[])]

See Also

RastriginEvaluator Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.GetVariableValue Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.IsValid Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.TryAddSubOperator Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.TryAddVariable Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.TryAddVariableInfo Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.TryRemoveSubOperator Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.TryRemoveVariable Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RastriginEvaluator..::.TryRemoveVariableInfo Method
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
RastriginEvaluator Members
HeuristicLab.TestFunctions Namespace


RastriginEvaluator Properties

[image]

HeuristicLab API Documentation
RastriginEvaluator Properties
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RastriginEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RastriginEvaluator Class
HeuristicLab.TestFunctions Namespace


Description Property

RastriginEvaluator..::.Description Property
RastriginEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.TestFunctions.RastriginEvaluator.Description]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RastriginEvaluator Class
HeuristicLab.TestFunctions Namespace


RosenbrockEvaluator Class

RosenbrockEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.RosenbrockEvaluator]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class RosenbrockEvaluator : TestFunctionEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.RosenbrockEvaluator

See Also

RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


RosenbrockEvaluator Members

[image]

HeuristicLab API Documentation
RosenbrockEvaluator Members
RosenbrockEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RosenbrockEvaluator type exposes the following members.

Constructors

Name | Description
RosenbrockEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
HeuristicLab.TestFunctions Namespace


RosenbrockEvaluator Constructor

RosenbrockEvaluator Constructor
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RosenbrockEvaluator class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public RosenbrockEvaluator()

See Also

RosenbrockEvaluator Class
HeuristicLab.TestFunctions Namespace


RosenbrockEvaluator Methods

[image]

HeuristicLab API Documentation
RosenbrockEvaluator Methods
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RosenbrockEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

RosenbrockEvaluator Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.AddSubOperator Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.Clone Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

RosenbrockEvaluator..::.EvaluateFunction Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.RosenbrockEvaluator.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.RosenbrockEvaluator.EvaluateFunction(System.Double[])]

See Also

RosenbrockEvaluator Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.GetVariableValue Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.IsValid Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.TryAddSubOperator Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.TryAddVariable Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.TryAddVariableInfo Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.TryRemoveSubOperator Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.TryRemoveVariable Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
RosenbrockEvaluator..::.TryRemoveVariableInfo Method
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
RosenbrockEvaluator Members
HeuristicLab.TestFunctions Namespace


RosenbrockEvaluator Properties

[image]

HeuristicLab API Documentation
RosenbrockEvaluator Properties
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RosenbrockEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

RosenbrockEvaluator Class
HeuristicLab.TestFunctions Namespace


Description Property

RosenbrockEvaluator..::.Description Property
RosenbrockEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.TestFunctions.RosenbrockEvaluator.Description]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

RosenbrockEvaluator Class
HeuristicLab.TestFunctions Namespace


SchwefelEvaluator Class

SchwefelEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.SchwefelEvaluator]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SchwefelEvaluator : TestFunctionEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.SchwefelEvaluator

See Also

SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


SchwefelEvaluator Members

[image]

HeuristicLab API Documentation
SchwefelEvaluator Members
SchwefelEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SchwefelEvaluator type exposes the following members.

Constructors

Name | Description
SchwefelEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
HeuristicLab.TestFunctions Namespace


SchwefelEvaluator Constructor

SchwefelEvaluator Constructor
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SchwefelEvaluator class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SchwefelEvaluator()

See Also

SchwefelEvaluator Class
HeuristicLab.TestFunctions Namespace


SchwefelEvaluator Methods

[image]

HeuristicLab API Documentation
SchwefelEvaluator Methods
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SchwefelEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SchwefelEvaluator Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.AddSubOperator Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.Clone Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

SchwefelEvaluator..::.EvaluateFunction Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.SchwefelEvaluator.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.SchwefelEvaluator.EvaluateFunction(System.Double[])]

See Also

SchwefelEvaluator Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.GetVariableValue Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.IsValid Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.TryAddSubOperator Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.TryAddVariable Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.TryAddVariableInfo Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.TryRemoveSubOperator Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.TryRemoveVariable Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SchwefelEvaluator..::.TryRemoveVariableInfo Method
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
SchwefelEvaluator Members
HeuristicLab.TestFunctions Namespace


SchwefelEvaluator Properties

[image]

HeuristicLab API Documentation
SchwefelEvaluator Properties
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SchwefelEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SchwefelEvaluator Class
HeuristicLab.TestFunctions Namespace


Description Property

SchwefelEvaluator..::.Description Property
SchwefelEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.TestFunctions.SchwefelEvaluator.Description]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SchwefelEvaluator Class
HeuristicLab.TestFunctions Namespace


SphereEvaluator Class

SphereEvaluator Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.SphereEvaluator]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class SphereEvaluator : TestFunctionEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.SphereEvaluator

See Also

SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


SphereEvaluator Members

[image]

HeuristicLab API Documentation
SphereEvaluator Members
SphereEvaluator Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SphereEvaluator type exposes the following members.

Constructors

Name | Description
SphereEvaluator |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
HeuristicLab.TestFunctions Namespace


SphereEvaluator Constructor

SphereEvaluator Constructor
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the SphereEvaluator class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public SphereEvaluator()

See Also

SphereEvaluator Class
HeuristicLab.TestFunctions Namespace


SphereEvaluator Methods

[image]

HeuristicLab API Documentation
SphereEvaluator Methods
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SphereEvaluator type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Inherited from TestFunctionEvaluatorBase.)
EvaluateFunction | (Overrides TestFunctionEvaluatorBase ..::. EvaluateFunction(array<Double>[]()[]).)
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

SphereEvaluator Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.AddSubOperator Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.Clone Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

SphereEvaluator..::.EvaluateFunction Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.SphereEvaluator.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.SphereEvaluator.EvaluateFunction(System.Double[])]

See Also

SphereEvaluator Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.GetVariableValue Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.IsValid Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.TryAddSubOperator Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.TryAddVariable Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.TryAddVariableInfo Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.TryRemoveSubOperator Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.TryRemoveVariable Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
SphereEvaluator..::.TryRemoveVariableInfo Method
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
SphereEvaluator Members
HeuristicLab.TestFunctions Namespace


SphereEvaluator Properties

[image]

HeuristicLab API Documentation
SphereEvaluator Properties
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SphereEvaluator type exposes the following members.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Overrides OperatorBase ..::. Description.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

See Also

SphereEvaluator Class
HeuristicLab.TestFunctions Namespace


Description Property

SphereEvaluator..::.Description Property
SphereEvaluator Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.TestFunctions.SphereEvaluator.Description]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override string Description { get; }

Implements

IOperator..::.Description

See Also

SphereEvaluator Class
HeuristicLab.TestFunctions Namespace


TestFunctionEvaluatorBase Class

TestFunctionEvaluatorBase Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.TestFunctions.TestFunctionEvaluatorBase]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public abstract class TestFunctionEvaluatorBase : SingleObjectiveEvaluatorBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.ConstrainedItemBase
HeuristicLab.Core..::.OperatorBase
HeuristicLab.Operators..::.SingleObjectiveEvaluatorBase
HeuristicLab.TestFunctions..::.TestFunctionEvaluatorBase
HeuristicLab.TestFunctions..::.SchwefelEvaluator
HeuristicLab.TestFunctions..::.RosenbrockEvaluator
HeuristicLab.TestFunctions..::.AckleyEvaluator
HeuristicLab.TestFunctions..::.RastriginEvaluator
HeuristicLab.TestFunctions..::.SphereEvaluator
HeuristicLab.TestFunctions..::.GriewangkEvaluator

See Also

TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TestFunctionEvaluatorBase Members

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase Members
TestFunctionEvaluatorBase Class Constructors Methods Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TestFunctionEvaluatorBase type exposes the following members.

Constructors

Name | Description
TestFunctionEvaluatorBase |

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides SingleObjectiveEvaluatorBase ..::. Evaluate(IScope).)
EvaluateFunction |
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

Properties

Name | Description
Breakpoint | (Inherited from OperatorBase.)
Canceled | (Inherited from OperatorBase.)
Constraints | (Inherited from ConstrainedItemBase.)
Description | (Inherited from OperatorBase.)
Guid | (Inherited from StorableBase.)
Name | (Inherited from OperatorBase.)
SubOperators | (Inherited from OperatorBase.)
VariableInfos | (Inherited from OperatorBase.)
Variables | (Inherited from OperatorBase.)

Events

Name | Description
BreakpointChanged | (Inherited from OperatorBase.)
Changed | (Inherited from ItemBase.)
ConstraintAdded | (Inherited from ConstrainedItemBase.)
ConstraintRemoved | (Inherited from ConstrainedItemBase.)
Executed | (Inherited from OperatorBase.)
Initialized | (Inherited from OperatorBase.)
NameChanged | (Inherited from OperatorBase.)
SubOperatorAdded | (Inherited from OperatorBase.)
SubOperatorRemoved | (Inherited from OperatorBase.)
VariableAdded | (Inherited from OperatorBase.)
VariableInfoAdded | (Inherited from OperatorBase.)
VariableInfoRemoved | (Inherited from OperatorBase.)
VariableRemoved | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
HeuristicLab.TestFunctions Namespace


TestFunctionEvaluatorBase Constructor

TestFunctionEvaluatorBase Constructor
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TestFunctionEvaluatorBase class.

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public TestFunctionEvaluatorBase()

See Also

TestFunctionEvaluatorBase Class
HeuristicLab.TestFunctions Namespace


TestFunctionEvaluatorBase Methods

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase Methods
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TestFunctionEvaluatorBase type exposes the following members.

Methods

Name | Description
Abort | (Inherited from OperatorBase.)
AddConstraint | (Inherited from ConstrainedItemBase.)
AddSubOperator | Overloaded.
AddVariable | (Inherited from OperatorBase.)
AddVariableInfo | (Inherited from OperatorBase.)
Apply | (Inherited from SingleObjectiveEvaluatorBase.)
Clone | Overloaded.
CreateView | (Inherited from OperatorBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evaluate | (Overrides SingleObjectiveEvaluatorBase ..::. Evaluate(IScope).)
EvaluateFunction |
Execute | (Inherited from OperatorBase.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVariable | (Inherited from OperatorBase.)
GetVariableInfo | (Inherited from OperatorBase.)
GetVariableValue | Overloaded.
GetXmlNode | (Inherited from OperatorBase.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnBreakpointChanged | (Inherited from OperatorBase.)
OnChanged | (Inherited from ItemBase.)
OnConstraintAdded | (Inherited from ConstrainedItemBase.)
OnConstraintRemoved | (Inherited from ConstrainedItemBase.)
OnExecuted | (Inherited from OperatorBase.)
OnInitialized | (Inherited from OperatorBase.)
OnNameChanged | (Inherited from OperatorBase.)
OnSubOperatorAdded | (Inherited from OperatorBase.)
OnSubOperatorRemoved | (Inherited from OperatorBase.)
OnVariableAdded | (Inherited from OperatorBase.)
OnVariableInfoAdded | (Inherited from OperatorBase.)
OnVariableInfoRemoved | (Inherited from OperatorBase.)
OnVariableRemoved | (Inherited from OperatorBase.)
Populate | (Inherited from OperatorBase.)
RemoveConstraint | (Inherited from ConstrainedItemBase.)
RemoveSubOperator | (Inherited from OperatorBase.)
RemoveVariable | (Inherited from OperatorBase.)
RemoveVariableInfo | (Inherited from OperatorBase.)
Reset | (Inherited from OperatorBase.)
ToString | (Inherited from ItemBase.)
TryAddSubOperator | Overloaded.
TryAddVariable | Overloaded.
TryAddVariableInfo | Overloaded.
TryRemoveSubOperator | Overloaded.
TryRemoveVariable | Overloaded.
TryRemoveVariableInfo | Overloaded.

See Also

TestFunctionEvaluatorBase Class
HeuristicLab.TestFunctions Namespace


AddSubOperator Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.AddSubOperator Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AddSubOperator(IOperator) | (Inherited from OperatorBase.)
AddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


Clone Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.Clone Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


Evaluate Method

TestFunctionEvaluatorBase..::.Evaluate Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.TestFunctionEvaluatorBase.Evaluate(HeuristicLab.Core.IScope)]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override sealed double Evaluate(
    IScope scope
)

Parameters

scope
Type: HeuristicLab.Core..::.IScope

[Missing <param> documentation for "scope"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.TestFunctionEvaluatorBase.Evaluate(HeuristicLab.Core.IScope)]

See Also

TestFunctionEvaluatorBase Class
HeuristicLab.TestFunctions Namespace


EvaluateFunction Method

TestFunctionEvaluatorBase..::.EvaluateFunction Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.TestFunctions.TestFunctionEvaluatorBase.EvaluateFunction(System.Double[])]

Namespace: HeuristicLab.TestFunctions
Assembly: HeuristicLab.TestFunctions (in HeuristicLab.TestFunctions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected abstract double EvaluateFunction(
    double[] point
)

Parameters

point
Type: array< System..::.Double >[]()[]

[Missing <param> documentation for "point"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.TestFunctions.TestFunctionEvaluatorBase.EvaluateFunction(System.Double[])]

See Also

TestFunctionEvaluatorBase Class
HeuristicLab.TestFunctions Namespace


GetVariableValue Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.GetVariableValue Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean) | (Inherited from OperatorBase.)
GetVariableValue<(Of <(T>)>)(String, IScope, Boolean, Boolean) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


IsValid Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.IsValid Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IsValid()()() | (Inherited from ConstrainedItemBase.)
IsValid(ICollection<(Of <(IConstraint>)>)%) | (Inherited from ConstrainedItemBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TryAddSubOperator Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.TryAddSubOperator Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddSubOperator(IOperator) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32) | (Inherited from OperatorBase.)
TryAddSubOperator(IOperator, Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TryAddVariable Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.TryAddVariable Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariable(IVariable) | (Inherited from OperatorBase.)
TryAddVariable(IVariable, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TryAddVariableInfo Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.TryAddVariableInfo Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryAddVariableInfo(IVariableInfo) | (Inherited from OperatorBase.)
TryAddVariableInfo(IVariableInfo, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TryRemoveSubOperator Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.TryRemoveSubOperator Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveSubOperator(Int32) | (Inherited from OperatorBase.)
TryRemoveSubOperator(Int32, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariable Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.TryRemoveVariable Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariable(String) | (Inherited from OperatorBase.)
TryRemoveVariable(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


TryRemoveVariableInfo Method

[image]

HeuristicLab API Documentation
TestFunctionEvaluatorBase..::.TryRemoveVariableInfo Method
TestFunctionEvaluatorBase Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TryRemoveVariableInfo(String) | (Inherited from OperatorBase.)
TryRemoveVariableInfo(String, ICollection<(Of <(IConstraint>)>)%) | (Inherited from OperatorBase.)

See Also

TestFunctionEvaluatorBase Class
TestFunctionEvaluatorBase Members
HeuristicLab.TestFunctions Namespace


HeuristicLab.ThreadParallelEngine Namespace

HeuristicLab.ThreadParallelEngine Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:HeuristicLab.ThreadParallelEngine]

Classes

Class | Description
HeuristicLabThreadParallelEnginePlugin |
ThreadParallelEngine |
ThreadParallelEngineEditor |


HeuristicLabThreadParallelEnginePlugin Class

HeuristicLabThreadParallelEnginePlugin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.ThreadParallelEngine.HeuristicLabThreadParallelEnginePlugin]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
[ClassInfoAttribute(Name = "HeuristicLab.ThreadParallelEngine")]
[PluginFileAttribute(Filename = "HeuristicLab.ThreadParallelEngine.dll",
    Filetype = PluginFileType.Assembly)]
[DependencyAttribute(Dependency = "HeuristicLab.Core")]
public class HeuristicLabThreadParallelEnginePlugin : PluginBase

Inheritance Hierarchy

System..::.Object
HeuristicLab.PluginInfrastructure..::.PluginBase
HeuristicLab.ThreadParallelEngine..::.HeuristicLabThreadParallelEnginePlugin

See Also

HeuristicLabThreadParallelEnginePlugin Members
HeuristicLab.ThreadParallelEngine Namespace


HeuristicLabThreadParallelEnginePlugin Members

[image]

HeuristicLab API Documentation
HeuristicLabThreadParallelEnginePlugin Members
HeuristicLabThreadParallelEnginePlugin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The HeuristicLabThreadParallelEnginePlugin type exposes the following members.

Constructors

Name | Description
HeuristicLabThreadParallelEnginePlugin |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDelete | (Inherited from PluginBase.)
OnInstall | (Inherited from PluginBase.)
OnPostUpdate | (Inherited from PluginBase.)
OnPreUpdate | (Inherited from PluginBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description | (Inherited from PluginBase.)
Files | (Inherited from PluginBase.)
Name | (Inherited from PluginBase.)
Version | (Inherited from PluginBase.)

See Also

HeuristicLabThreadParallelEnginePlugin Class
HeuristicLab.ThreadParallelEngine Namespace


HeuristicLabThreadParallelEnginePlugin Constructor

HeuristicLabThreadParallelEnginePlugin Constructor
HeuristicLabThreadParallelEnginePlugin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the HeuristicLabThreadParallelEnginePlugin class.

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public HeuristicLabThreadParallelEnginePlugin()

See Also

HeuristicLabThreadParallelEnginePlugin Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Class

ThreadParallelEngine Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ThreadParallelEngine : EngineBase, IEditable,
    IViewable

Inheritance Hierarchy

System..::.Object
HeuristicLab.Core..::.StorableBase
HeuristicLab.Core..::.ItemBase
HeuristicLab.Core..::.EngineBase
HeuristicLab.ThreadParallelEngine..::.ThreadParallelEngine

See Also

ThreadParallelEngine Members
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Members

[image]

HeuristicLab API Documentation
ThreadParallelEngine Members
ThreadParallelEngine Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngine type exposes the following members.

Constructors

Name | Description
ThreadParallelEngine |

Methods

Name | Description
Abort | (Overrides EngineBase ..::. Abort()()().)
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from EngineBase.)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Overrides EngineBase ..::. ExecuteSteps(Int32).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides EngineBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
OnWorkersChanged |
Populate | (Overrides EngineBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

Fields

Name | Description
myCanceled | (Inherited from EngineBase.)
myExecutionStack | (Inherited from EngineBase.)
myGlobalScope | (Inherited from EngineBase.)
myOperatorGraph | (Inherited from EngineBase.)
myRunning | (Inherited from EngineBase.)

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
Terminated | (Inherited from EngineBase.)
Workers |

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred | (Inherited from EngineBase.)
ExecutionTimeChanged | (Inherited from EngineBase.)
Finished | (Inherited from EngineBase.)
Initialized | (Inherited from EngineBase.)
OperationExecuted | (Inherited from EngineBase.)
WorkersChanged |

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Constructor

ThreadParallelEngine Constructor
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ThreadParallelEngine class.

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ThreadParallelEngine()

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Methods

[image]

HeuristicLab API Documentation
ThreadParallelEngine Methods
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngine type exposes the following members.

Methods

Name | Description
Abort | (Overrides EngineBase ..::. Abort()()().)
Clone | Overloaded.
CreateEditor |
CreateView | (Overrides ItemBase ..::. CreateView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute | (Inherited from EngineBase.)
ExecuteStep | (Inherited from EngineBase.)
ExecuteSteps | (Overrides EngineBase ..::. ExecuteSteps(Int32).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FireChanged | (Inherited from ItemBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlNode | (Overrides EngineBase ..::. GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChanged | (Inherited from ItemBase.)
OnExceptionOccurred | (Inherited from EngineBase.)
OnExecutionTimeChanged | (Inherited from EngineBase.)
OnFinished | (Inherited from EngineBase.)
OnInitialized | (Inherited from EngineBase.)
OnOperationExecuted | (Inherited from EngineBase.)
OnWorkersChanged |
Populate | (Overrides EngineBase ..::. Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>)).)
ProcessNextOperation | (Overrides EngineBase ..::. ProcessNextOperation()()().)
Reset | (Inherited from EngineBase.)
ToString | (Inherited from ItemBase.)

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


Abort Method

ThreadParallelEngine..::.Abort Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.Abort]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Abort()

Implements

IEngine..::.Abort()()()

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


Clone Method

[image]

HeuristicLab API Documentation
ThreadParallelEngine..::.Clone Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from StorableBase.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Overrides EngineBase ..::. Clone(IDictionary<(Of <(Guid, Object>)>)).)

See Also

ThreadParallelEngine Class
ThreadParallelEngine Members
HeuristicLab.ThreadParallelEngine Namespace


Clone Method (IDictionary(Guid, Object))

ThreadParallelEngine..::.Clone Method (IDictionary<(Of <(Guid, Object>)>))
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override Object Clone(
    IDictionary<Guid, Object> clonedObjects
)

Parameters

clonedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, Object >)>)

[Missing <param> documentation for "clonedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.Clone(System.Collections.Generic.IDictionary{System.Guid,System.Object})]

Implements

IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))
IStorable..::.Clone(IDictionary<(Of <(Guid, Object>)>))

See Also

ThreadParallelEngine Class
Clone Overload
HeuristicLab.ThreadParallelEngine Namespace


CreateEditor Method

ThreadParallelEngine..::.CreateEditor Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.CreateEditor]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public virtual IEditor CreateEditor()

Return Value

[Missing <returns> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.CreateEditor]

Implements

IEditable..::.CreateEditor()()()

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


CreateView Method

ThreadParallelEngine..::.CreateView Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.CreateView]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override IView CreateView()

Return Value

[Missing <returns> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.CreateView]

Implements

IViewable..::.CreateView()()()
IViewable..::.CreateView()()()

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ExecuteSteps Method

ThreadParallelEngine..::.ExecuteSteps Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.ExecuteSteps(System.Int32)]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void ExecuteSteps(
    int steps
)

Parameters

steps
Type: System..::.Int32

[Missing <param> documentation for "steps"]

Implements

IEngine..::.ExecuteSteps(Int32)

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


GetXmlNode Method

ThreadParallelEngine..::.GetXmlNode Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override XmlNode GetXmlNode(
    string name,
    XmlDocument document,
    IDictionary<Guid, IStorable> persistedObjects
)

Parameters

name
Type: System..::.String

[Missing <param> documentation for "name"]

document
Type: System.Xml..::.XmlDocument

[Missing <param> documentation for "document"]

persistedObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "persistedObjects"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.GetXmlNode(System.String,System.Xml.XmlDocument,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Implements

IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.GetXmlNode(String, XmlDocument, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


OnWorkersChanged Method

ThreadParallelEngine..::.OnWorkersChanged Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.OnWorkersChanged]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected virtual void OnWorkersChanged()

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


Populate Method

ThreadParallelEngine..::.Populate Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.Populate(System.Xml.XmlNode,System.Collections.Generic.IDictionary{System.Guid,HeuristicLab.Core.IStorable})]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Populate(
    XmlNode node,
    IDictionary<Guid, IStorable> restoredObjects
)

Parameters

node
Type: System.Xml..::.XmlNode

[Missing <param> documentation for "node"]

restoredObjects
Type: System.Collections.Generic..::.IDictionary <(Of <( Guid, IStorable >)>)

[Missing <param> documentation for "restoredObjects"]

Implements

IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))
IStorable..::.Populate(XmlNode, IDictionary<(Of <(Guid, IStorable>)>))

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ProcessNextOperation Method

ThreadParallelEngine..::.ProcessNextOperation Method
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.ProcessNextOperation]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void ProcessNextOperation()

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Properties

[image]

HeuristicLab API Documentation
ThreadParallelEngine Properties
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngine type exposes the following members.

Properties

Name | Description
Canceled | (Inherited from EngineBase.)
ExecutionStack | (Inherited from EngineBase.)
ExecutionTime | (Inherited from EngineBase.)
GlobalScope | (Inherited from EngineBase.)
Guid | (Inherited from StorableBase.)
OperatorGraph | (Inherited from EngineBase.)
Running | (Inherited from EngineBase.)
Terminated | (Inherited from EngineBase.)
Workers |

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


Workers Property

ThreadParallelEngine..::.Workers Property
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.Workers]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Workers { get; set; }

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Events

[image]

HeuristicLab API Documentation
ThreadParallelEngine Events
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngine type exposes the following members.

Events

Name | Description
Changed | (Inherited from ItemBase.)
ExceptionOccurred | (Inherited from EngineBase.)
ExecutionTimeChanged | (Inherited from EngineBase.)
Finished | (Inherited from EngineBase.)
Initialized | (Inherited from EngineBase.)
OperationExecuted | (Inherited from EngineBase.)
WorkersChanged |

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


WorkersChanged Event

ThreadParallelEngine..::.WorkersChanged Event
ThreadParallelEngine Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for E:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.WorkersChanged]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public event EventHandler WorkersChanged

See Also

ThreadParallelEngine Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Class

ThreadParallelEngineEditor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:HeuristicLab.ThreadParallelEngine.ThreadParallelEngineEditor]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public class ThreadParallelEngineEditor : EngineBaseEditor

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
HeuristicLab.Core..::.ViewBase
HeuristicLab.Core..::.EditorBase
HeuristicLab.Core..::.EngineBaseEditor
HeuristicLab.ThreadParallelEngine..::.ThreadParallelEngineEditor

See Also

ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Members

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor Members
ThreadParallelEngineEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngineEditor type exposes the following members.

Constructors

Name | Description
ThreadParallelEngineEditor | Overloaded.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides EngineBaseEditor ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides EngineBaseEditor ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EngineBaseEditor ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

Fields

Name | Description
abortButton | (Inherited from EngineBaseEditor.)
executeButton | (Inherited from EngineBaseEditor.)
executionTimeLabel | (Inherited from EngineBaseEditor.)
executionTimeTextBox | (Inherited from EngineBaseEditor.)
globalScopeGroupBox | (Inherited from EngineBaseEditor.)
operatorGraphGroupBox | (Inherited from EngineBaseEditor.)
operatorGraphView | (Inherited from EngineBaseEditor.)
resetButton | (Inherited from EngineBaseEditor.)
scopeView | (Inherited from EngineBaseEditor.)
splitContainer1 | (Inherited from EngineBaseEditor.)

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine | (Inherited from EngineBaseEditor.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ThreadParallelEngine |
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

Events

Name | Description
AutoSizeChanged | (Inherited from UserControl.)
AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CaptionChanged | (Inherited from ViewBase.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::.ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::.ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FilenameChanged | (Inherited from EditorBase.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
ItemChanged | (Inherited from ViewBase.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
TextChanged | (Inherited from UserControl.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Constructor

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor Constructor
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ThreadParallelEngineEditor()()() |
ThreadParallelEngineEditor(ThreadParallelEngine) |

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Constructor

ThreadParallelEngineEditor Constructor
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ThreadParallelEngineEditor class.

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ThreadParallelEngineEditor()

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Overload
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Constructor (ThreadParallelEngine)

ThreadParallelEngineEditor Constructor (ThreadParallelEngine)
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ThreadParallelEngineEditor class.

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ThreadParallelEngineEditor(
    ThreadParallelEngine threadParallelEngine
)

Parameters

threadParallelEngine
Type: HeuristicLab.ThreadParallelEngine..::.ThreadParallelEngine

[Missing <param> documentation for "threadParallelEngine"]

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Overload
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Methods

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor Methods
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngineEditor type exposes the following members.

Methods

Name | Description
AccessibilityNotifyClients | Overloaded.
AddItemEvents | (Overrides EngineBaseEditor ..::. AddItemEvents()()().)
AdjustFormScrollbars | (Inherited from ContainerControl.)
BeginInvoke | Overloaded.
BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
CreateHandle | Creates a handle for the control. (Inherited from Control.)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Dispose | Overloaded.
DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Focus | Sets input focus to the control. (Inherited from Control.)
GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
GetChildAtPoint | Overloaded.
GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Hide | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Invalidate | Overloaded.
Invoke | Overloaded.
InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
MemberwiseClone | Overloaded.
NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
OnCaptionChanged | (Inherited from ViewBase.)
OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
OnClick | Raises the Click event. (Inherited from Control.)
OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
OnCreateControl | Raises the CreateControl event. (Inherited from UserControl.)
OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
OnDragOver | Raises the DragOver event. (Inherited from Control.)
OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Control.)
OnEnter | Raises the Enter event. (Inherited from Control.)
OnFilenameChanged | (Inherited from EditorBase.)
OnFontChanged | Raises the FontChanged event. (Inherited from ContainerControl.)
OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
OnHandleCreated | Raises the HandleCreated event. (Inherited from Control.)
OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control.)
OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
OnItemChanged | (Inherited from ViewBase.)
OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
OnLayout | (Inherited from ContainerControl.)
OnLeave | Raises the Leave event. (Inherited from Control.)
OnLoad | Raises the Load event. (Inherited from UserControl.)
OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
OnMouseDown | (Inherited from UserControl.)
OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
OnMove | Raises the Move event. (Inherited from Control.)
OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
OnPaddingChanged | (Inherited from ScrollableControl.)
OnPaint | Raises the Paint event. (Inherited from Control.)
OnPaintBackground | (Inherited from ScrollableControl.)
OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
OnParentChanged | (Inherited from ContainerControl.)
OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
OnPrint | Raises the Paint event. (Inherited from Control.)
OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
OnResize | (Inherited from UserControl.)
OnRightToLeftChanged | (Inherited from ScrollableControl.)
OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
OnValidated | Raises the Validated event. (Inherited from Control.)
OnValidating | Raises the Validating event. (Inherited from Control.)
OnVisibleChanged | (Inherited from ScrollableControl.)
PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout | Overloaded.
PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
ProcessCmdKey | (Inherited from ContainerControl.)
ProcessDialogChar | (Inherited from ContainerControl.)
ProcessDialogKey | (Inherited from ContainerControl.)
ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
ProcessMnemonic | (Inherited from ContainerControl.)
ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh | (Inherited from ViewBase.)
RemoveItemEvents | (Overrides EngineBaseEditor ..::. RemoveItemEvents()()().)
ResetBackColor | (Inherited from Control.)
ResetBindings | (Inherited from Control.)
ResetCursor | (Inherited from Control.)
ResetFont | (Inherited from Control.)
ResetForeColor | (Inherited from Control.)
ResetImeMode | (Inherited from Control.)
ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
ResetRightToLeft | (Inherited from Control.)
ResetText | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout | Overloaded.
RtlTranslateAlignment | Overloaded.
RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Scale | Overloaded.
ScaleControl | (Inherited from ScrollableControl.)
ScaleCore | (Inherited from ScrollableControl.)
ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Select | Overloaded.
SelectNextControl | Activates the next control. (Inherited from Control.)
SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
SetBounds | Overloaded.
SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
SetStyle | Sets the specified style bit to the specified value. (Inherited from Control.)
SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Show | Displays the control to the user. (Inherited from Control.)
SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UpdateBounds | Overloaded.
UpdateControls | (Overrides EngineBaseEditor ..::. UpdateControls()()().)
UpdateDefaultButton | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Validate | Overloaded.
ValidateChildren | Overloaded.
WndProc | (Inherited from UserControl.)

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


AccessibilityNotifyClients Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.AccessibilityNotifyClients Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


AddItemEvents Method

ThreadParallelEngineEditor..::.AddItemEvents Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngineEditor.AddItemEvents]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void AddItemEvents()

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


BeginInvoke Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.BeginInvoke Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


Dispose Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.Dispose Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides EngineBaseEditor ..::. Dispose(Boolean).)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


Dispose Method (Boolean)

ThreadParallelEngineEditor..::.Dispose Method (Boolean)
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Clean up any resources being used.

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
true if managed resources should be disposed; otherwise, false.

See Also

ThreadParallelEngineEditor Class
Dispose Overload
HeuristicLab.ThreadParallelEngine Namespace


GetChildAtPoint Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.GetChildAtPoint Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


Invalidate Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.Invalidate Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invalidate()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


Invoke Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.Invoke Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Invoke(Delegate) | (Inherited from ViewBase.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from ViewBase.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


MemberwiseClone Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.MemberwiseClone Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


PerformLayout Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.PerformLayout Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PerformLayout()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


RemoveItemEvents Method

ThreadParallelEngineEditor..::.RemoveItemEvents Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngineEditor.RemoveItemEvents]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void RemoveItemEvents()

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


ResumeLayout Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.ResumeLayout Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ResumeLayout()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


RtlTranslateAlignment Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.RtlTranslateAlignment Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


Scale Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.Scale Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


Select Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.Select Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Select()()() | Activates the control. (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from ContainerControl.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


SetBounds Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.SetBounds Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


UpdateBounds Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.UpdateBounds Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UpdateBounds()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


UpdateControls Method

ThreadParallelEngineEditor..::.UpdateControls Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.ThreadParallelEngine.ThreadParallelEngineEditor.UpdateControls]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
protected override void UpdateControls()

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


Validate Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.Validate Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Validate()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


ValidateChildren Method

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor..::.ValidateChildren Method
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ValidateChildren()()() | (Inherited from UserControl.)
ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

ThreadParallelEngineEditor Class
ThreadParallelEngineEditor Members
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngineEditor Properties

[image]

HeuristicLab API Documentation
ThreadParallelEngineEditor Properties
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ThreadParallelEngineEditor type exposes the following members.

Properties

Name | Description
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | (Inherited from UserControl.)
AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
BackColor | Gets or sets the background color for the control. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Caption | (Inherited from ViewBase.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateParams | (Inherited from UserControl.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
DefaultSize | (Inherited from UserControl.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Engine | (Inherited from EngineBaseEditor.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Filename | (Inherited from EditorBase.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Item | (Inherited from ViewBase.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Margin | Gets or sets the space between controls. (Inherited from Control.)
MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the height and width of the control. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from UserControl.)
ThreadParallelEngine |
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowTarget | (Inherited from Control.)

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


ThreadParallelEngine Property

ThreadParallelEngineEditor..::.ThreadParallelEngine Property
ThreadParallelEngineEditor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.ThreadParallelEngine.ThreadParallelEngineEditor.ThreadParallelEngine]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ThreadParallelEngine ThreadParallelEngine { get; set; }

See Also

ThreadParallelEngineEditor Class
HeuristicLab.ThreadParallelEngine Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Not)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Not not
)

Parameters

not
Type: HeuristicLab.Functions..::.Not

[Missing <param> documentation for "not"]

Implements

IFunctionVisitor..::.Visit(Not)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Logarithm)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Logarithm logarithm
)

Parameters

logarithm
Type: HeuristicLab.Functions..::.Logarithm

[Missing <param> documentation for "logarithm"]

Implements

IFunctionVisitor..::.Visit(Logarithm)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Logarithm)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Logarithm logarithm
)

Parameters

logarithm
Type: HeuristicLab.Functions..::.Logarithm

[Missing <param> documentation for "logarithm"]

Implements

IFunctionVisitor..::.Visit(Logarithm)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Cosinus)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Cosinus cosinus
)

Parameters

cosinus
Type: HeuristicLab.Functions..::.Cosinus

[Missing <param> documentation for "cosinus"]

Implements

IFunctionVisitor..::.Visit(Cosinus)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Tangens)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Tangens tangens
)

Parameters

tangens
Type: HeuristicLab.Functions..::.Tangens

[Missing <param> documentation for "tangens"]

Implements

IFunctionVisitor..::.Visit(Tangens)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Tangens)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Tangens tangens
)

Parameters

tangens
Type: HeuristicLab.Functions..::.Tangens

[Missing <param> documentation for "tangens"]

Implements

IFunctionVisitor..::.Visit(Tangens)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Division)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Division division
)

Parameters

division
Type: HeuristicLab.Functions..::.Division

[Missing <param> documentation for "division"]

Implements

IFunctionVisitor..::.Visit(Division)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

UniformRandomizer..::...::.Visit Method
RandomVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomizer.RandomVisitor.Visit(HeuristicLab.Data.DoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    DoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleData)

See Also

RandomVisitor
HeuristicLab.Random Namespace


Visit Method

NormalRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.ConstrainedDoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedDoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedDoubleData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
IVariableInfo..::.Clone Method
IVariableInfo Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IVariableInfo Interface
IVariableInfo Members
HeuristicLab.Core Namespace


Visit Method

NormalRandomizer..::...::.Visit Method
RandomizerVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomizer.RandomizerVisitor.Visit(HeuristicLab.Data.IntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    IntData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntData)

See Also

RandomizerVisitor
HeuristicLab.Random Namespace


Visit Method

SubOperatorsConstraintAnalyser..::...::.Visit Method
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperatorsVisitor.Visit(HeuristicLab.Constraints.AndConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    AndConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.AndConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(AndConstraint)

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Constant)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Constant constant
)

Parameters

constant
Type: HeuristicLab.Functions..::.Constant

[Missing <param> documentation for "constant"]

Implements

IFunctionVisitor..::.Visit(Constant)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

UniformRandomizer..::...::.Visit Method
RandomVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomizer.RandomVisitor.Visit(HeuristicLab.Data.ConstrainedIntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedIntData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedIntData)

See Also

RandomVisitor
HeuristicLab.Random Namespace


AllowedOperators Property

SubOperatorsConstraintAnalyser..::...::.AllowedOperators Property
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperatorsVisitor.AllowedOperators]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IList<IOperator> AllowedOperators { get; }

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Addition)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Addition addition
)

Parameters

addition
Type: HeuristicLab.Functions..::.Addition

[Missing <param> documentation for "addition"]

Implements

IFunctionVisitor..::.Visit(Addition)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

UniformRandomizer..::...::.Visit Method
RandomVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomizer.RandomVisitor.Visit(HeuristicLab.Data.ConstrainedDoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedDoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedDoubleData)

See Also

RandomVisitor
HeuristicLab.Random Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Or)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Or or
)

Parameters

or
Type: HeuristicLab.Functions..::.Or

[Missing <param> documentation for "or"]

Implements

IFunctionVisitor..::.Visit(Or)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

NormalRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.ConstrainedIntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedIntData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedIntData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Visit Method

UniformRandomizer..::...::.Visit Method
RandomVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomizer.RandomVisitor.Visit(HeuristicLab.Data.IntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    IntData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntData)

See Also

RandomVisitor
HeuristicLab.Random Namespace


Reset Method

FunctionView..::...::.Reset Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Reset]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset()

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.IfThenElse)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    IfThenElse ifThenElse
)

Parameters

ifThenElse
Type: HeuristicLab.Functions..::.IfThenElse

[Missing <param> documentation for "ifThenElse"]

Implements

IFunctionVisitor..::.Visit(IfThenElse)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


FunctionView. Constructor

FunctionView..::. Constructor
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the FunctionNameVisitor class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.IfThenElse)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    IfThenElse ifThenElse
)

Parameters

ifThenElse
Type: HeuristicLab.Functions..::.IfThenElse

[Missing <param> documentation for "ifThenElse"]

Implements

IFunctionVisitor..::.Visit(IfThenElse)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


SubOperatorsConstraintAnalyser. Constructor

SubOperatorsConstraintAnalyser..::. Constructor
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GetAllowedOperatorsVisitor class.

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    ICollection<IOperator> possibleOperators,
    int childIndex
)

Parameters

possibleOperators
Type: System.Collections.Generic..::.ICollection <(Of <( IOperator >)>)

[Missing <param> documentation for "possibleOperators"]

childIndex
Type: System..::.Int32

[Missing <param> documentation for "childIndex"]

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


OperatorLibraryEditor. Constructor

OperatorLibraryEditor..::. Constructor
NodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the NodeSorter class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

NodeSorter
HeuristicLab.Core Namespace


Compare Method

ChooseTypeDialog..::...::.Compare Method
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ChooseTypeDialog.TreeNodeSorter.Compare(System.Object,System.Object)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Compare(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object

[Missing <param> documentation for "x"]

y
Type: System..::.Object

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ChooseTypeDialog.TreeNodeSorter.Compare(System.Object,System.Object)]

Implements

IComparer..::.Compare(Object, Object)

See Also

TreeNodeSorter
HeuristicLab.Core Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Substraction)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Substraction substraction
)

Parameters

substraction
Type: HeuristicLab.Functions..::.Substraction

[Missing <param> documentation for "substraction"]

Implements

IFunctionVisitor..::.Visit(Substraction)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Compare Method

AvailableOperatorsForm..::...::.Compare Method
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.AdvancedOptimizationFrontend.AvailableOperatorsForm.TreeNodeSorter.Compare(System.Object,System.Object)]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Compare(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object

[Missing <param> documentation for "x"]

y
Type: System..::.Object

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.AdvancedOptimizationFrontend.AvailableOperatorsForm.TreeNodeSorter.Compare(System.Object,System.Object)]

Implements

IComparer..::.Compare(Object, Object)

See Also

TreeNodeSorter
HeuristicLab.AdvancedOptimizationFrontend Namespace


semaphore Field

ThreadParallelEngine..::...::.semaphore Field
TaskList See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.TaskList.semaphore]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Semaphore semaphore

See Also

TaskList
HeuristicLab.ThreadParallelEngine Namespace


Clone Method

[image]

HeuristicLab API Documentation
IOperation..::.Clone Method
IOperation Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IOperation Interface
IOperation Members
HeuristicLab.Core Namespace


ThreadParallelEngine. Constructor

ThreadParallelEngine..::. Constructor
TaskList See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TaskList class.

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

TaskList
HeuristicLab.ThreadParallelEngine Namespace


ChooseItemDialog. Constructor

ChooseItemDialog..::. Constructor
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TreeNodeSorter class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

TreeNodeSorter
HeuristicLab.Core Namespace


filename Field

MainForm..::...::.filename Field
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.AdvancedOptimizationFrontend.MainForm.Task.filename]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string filename

See Also

Task
HeuristicLab.AdvancedOptimizationFrontend Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Power)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Power power
)

Parameters

power
Type: HeuristicLab.Functions..::.Power

[Missing <param> documentation for "power"]

Implements

IFunctionVisitor..::.Visit(Power)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


AtToken Field

DatasetParser..::...::.AtToken Field
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.AtToken]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static DatasetParser..::.Token AtToken

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

SubOperatorsConstraintAnalyser..::...::.Visit Method
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperatorsVisitor.Visit(HeuristicLab.Constraints.SubOperatorTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    SubOperatorTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.SubOperatorTypeConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(SubOperatorTypeConstraint)

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Xor)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Xor xor
)

Parameters

xor
Type: HeuristicLab.Functions..::.Xor

[Missing <param> documentation for "xor"]

Implements

IFunctionVisitor..::.Visit(Xor)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Variable)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Variable variable
)

Parameters

variable
Type: HeuristicLab.Functions..::.Variable

[Missing <param> documentation for "variable"]

Implements

IFunctionVisitor..::.Visit(Variable)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


editor Field

MainForm..::...::.editor Field
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.AdvancedOptimizationFrontend.MainForm.Task.editor]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEditor editor

See Also

Task
HeuristicLab.AdvancedOptimizationFrontend Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.LessThan)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    LessThan lessThan
)

Parameters

lessThan
Type: HeuristicLab.Functions..::.LessThan

[Missing <param> documentation for "lessThan"]

Implements

IFunctionVisitor..::.Visit(LessThan)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


AvailableOperatorsForm. Constructor

AvailableOperatorsForm..::. Constructor
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TreeNodeSorter class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

TreeNodeSorter
HeuristicLab.AdvancedOptimizationFrontend Namespace


AssignmentToken Field

DatasetParser..::...::.AssignmentToken Field
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.AssignmentToken]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static DatasetParser..::.Token AssignmentToken

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Separators Property

DatasetParser..::...::.Separators Property
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.Separators]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string[] Separators { get; set; }

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Or)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Or or
)

Parameters

or
Type: HeuristicLab.Functions..::.Or

[Missing <param> documentation for "or"]

Implements

IFunctionVisitor..::.Visit(Or)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Compare Method

AvailableOperatorsForm..::...::.Compare Method
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.OptimizationFrontend.AvailableOperatorsForm.TreeNodeSorter.Compare(System.Object,System.Object)]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Compare(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object

[Missing <param> documentation for "x"]

y
Type: System..::.Object

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.OptimizationFrontend.AvailableOperatorsForm.TreeNodeSorter.Compare(System.Object,System.Object)]

Implements

IComparer..::.Compare(Object, Object)

See Also

TreeNodeSorter
HeuristicLab.OptimizationFrontend Namespace


NewlineToken Field

DatasetParser..::...::.NewlineToken Field
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.NewlineToken]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public static DatasetParser..::.Token NewlineToken

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Multiplication)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Multiplication multiplication
)

Parameters

multiplication
Type: HeuristicLab.Functions..::.Multiplication

[Missing <param> documentation for "multiplication"]

Implements

IFunctionVisitor..::.Visit(Multiplication)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

NormalRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.DoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    DoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


storable Field

MainForm..::...::.storable Field
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.OptimizationFrontend.MainForm.Task.storable]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IStorable storable

See Also

Task
HeuristicLab.OptimizationFrontend Namespace


Visit Method

UniformRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.ConstrainedIntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedIntData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedIntData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


UniformRandomizer. Constructor

UniformRandomizer..::. Constructor
RandomVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomVisitor class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    MersenneTwister mt,
    double min,
    double max
)

Parameters

mt
Type: HeuristicLab.Random..::.MersenneTwister

[Missing <param> documentation for "mt"]

min
Type: System..::.Double

[Missing <param> documentation for "min"]

max
Type: System..::.Double

[Missing <param> documentation for "max"]

See Also

RandomVisitor
HeuristicLab.Random Namespace


ChooseTypeDialog. Constructor

ChooseTypeDialog..::. Constructor
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TreeNodeSorter class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

TreeNodeSorter
HeuristicLab.Core Namespace


NormalRandomizer. Constructor

NormalRandomizer..::. Constructor
RandomizerVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomizerVisitor class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    NormalDistributedRandom normal
)

Parameters

normal
Type: HeuristicLab.Random..::.NormalDistributedRandom

[Missing <param> documentation for "normal"]

See Also

RandomizerVisitor
HeuristicLab.Random Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Sinus)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Sinus sinus
)

Parameters

sinus
Type: HeuristicLab.Functions..::.Sinus

[Missing <param> documentation for "sinus"]

Implements

IFunctionVisitor..::.Visit(Sinus)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

SubOperatorsConstraintAnalyser..::...::.Visit Method
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperatorsVisitor.Visit(HeuristicLab.Constraints.AllSubOperatorsTypeConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    AllSubOperatorsTypeConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.AllSubOperatorsTypeConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(AllSubOperatorsTypeConstraint)

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Power)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Power power
)

Parameters

power
Type: HeuristicLab.Functions..::.Power

[Missing <param> documentation for "power"]

Implements

IFunctionVisitor..::.Visit(Power)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


filename Field

MainForm..::...::.filename Field
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.OptimizationFrontend.MainForm.Task.filename]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string filename

See Also

Task
HeuristicLab.OptimizationFrontend Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Cosinus)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Cosinus cosinus
)

Parameters

cosinus
Type: HeuristicLab.Functions..::.Cosinus

[Missing <param> documentation for "cosinus"]

Implements

IFunctionVisitor..::.Visit(Cosinus)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


tasks Field

ThreadParallelEngine..::...::.tasks Field
TaskList See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.TaskList.tasks]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Stack<IOperation>[] tasks

See Also

TaskList
HeuristicLab.ThreadParallelEngine Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Sqrt)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Sqrt sqrt
)

Parameters

sqrt
Type: HeuristicLab.Functions..::.Sqrt

[Missing <param> documentation for "sqrt"]

Implements

IFunctionVisitor..::.Visit(Sqrt)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Average)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Average average
)

Parameters

average
Type: HeuristicLab.Functions..::.Average

[Missing <param> documentation for "average"]

Implements

IFunctionVisitor..::.Visit(Average)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

UniformRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.IntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    IntData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Visit Method

NormalRandomizer..::...::.Visit Method
RandomizerVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomizer.RandomizerVisitor.Visit(HeuristicLab.Data.ConstrainedIntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedIntData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedIntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedIntData)

See Also

RandomizerVisitor
HeuristicLab.Random Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.And)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    And and
)

Parameters

and
Type: HeuristicLab.Functions..::.And

[Missing <param> documentation for "and"]

Implements

IFunctionVisitor..::.Visit(And)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Exponential)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Exponential exponential
)

Parameters

exponential
Type: HeuristicLab.Functions..::.Exponential

[Missing <param> documentation for "exponential"]

Implements

IFunctionVisitor..::.Visit(Exponential)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


editor Field

MainForm..::...::.editor Field
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.OptimizationFrontend.MainForm.Task.editor]

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IEditor editor

See Also

Task
HeuristicLab.OptimizationFrontend Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Substraction)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Substraction substraction
)

Parameters

substraction
Type: HeuristicLab.Functions..::.Substraction

[Missing <param> documentation for "substraction"]

Implements

IFunctionVisitor..::.Visit(Substraction)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.And)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    And and
)

Parameters

and
Type: HeuristicLab.Functions..::.And

[Missing <param> documentation for "and"]

Implements

IFunctionVisitor..::.Visit(And)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Compare Method

ChooseOperatorDialog..::...::.Compare Method
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ChooseOperatorDialog.TreeNodeSorter.Compare(System.Object,System.Object)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Compare(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object

[Missing <param> documentation for "x"]

y
Type: System..::.Object

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ChooseOperatorDialog.TreeNodeSorter.Compare(System.Object,System.Object)]

Implements

IComparer..::.Compare(Object, Object)

See Also

TreeNodeSorter
HeuristicLab.Core Namespace


UniformRandomAdder. Constructor

UniformRandomAdder..::. Constructor
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomAdderVisitor class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    MersenneTwister mt,
    double min,
    double max
)

Parameters

mt
Type: HeuristicLab.Random..::.MersenneTwister

[Missing <param> documentation for "mt"]

min
Type: System..::.Double

[Missing <param> documentation for "min"]

max
Type: System..::.Double

[Missing <param> documentation for "max"]

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.IFunction)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    IFunction function
)

Parameters

function
Type: HeuristicLab.Functions..::.IFunction

[Missing <param> documentation for "function"]

Implements

IFunctionVisitor..::.Visit(IFunction)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Or)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Or or
)

Parameters

or
Type: HeuristicLab.Functions..::.Or

[Missing <param> documentation for "or"]

Implements

IFunctionVisitor..::.Visit(Or)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


ModelAnalyzerPrefix Property

FunctionView..::...::.ModelAnalyzerPrefix Property
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.ModelAnalyzerPrefix]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string ModelAnalyzerPrefix { get; }

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Sinus)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Sinus sinus
)

Parameters

sinus
Type: HeuristicLab.Functions..::.Sinus

[Missing <param> documentation for "sinus"]

Implements

IFunctionVisitor..::.Visit(Sinus)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Constant)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Constant constant
)

Parameters

constant
Type: HeuristicLab.Functions..::.Constant

[Missing <param> documentation for "constant"]

Implements

IFunctionVisitor..::.Visit(Constant)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.LessThan)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    LessThan lessThan
)

Parameters

lessThan
Type: HeuristicLab.Functions..::.LessThan

[Missing <param> documentation for "lessThan"]

Implements

IFunctionVisitor..::.Visit(LessThan)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Compare Method

OperatorLibraryEditor..::...::.Compare Method
NodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.OperatorLibraryEditor.NodeSorter.Compare(System.Object,System.Object)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Compare(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object

[Missing <param> documentation for "x"]

y
Type: System..::.Object

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.OperatorLibraryEditor.NodeSorter.Compare(System.Object,System.Object)]

Implements

IComparer..::.Compare(Object, Object)

See Also

NodeSorter
HeuristicLab.Core Namespace


NormalRandomAdder. Constructor

NormalRandomAdder..::. Constructor
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RandomAdderVisitor class.

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    NormalDistributedRandom normal
)

Parameters

normal
Type: HeuristicLab.Random..::.NormalDistributedRandom

[Missing <param> documentation for "normal"]

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


EngineStore. Constructor

EngineStore..::. Constructor
ResultRecievedEventArgs See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ResultRecievedEventArgs class.

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

ResultRecievedEventArgs
HeuristicLab.Grid Namespace


HasNext Method

DatasetParser..::...::.HasNext Method
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.HasNext]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public bool HasNext()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.HasNext]

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Sinus)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Sinus sinus
)

Parameters

sinus
Type: HeuristicLab.Functions..::.Sinus

[Missing <param> documentation for "sinus"]

Implements

IFunctionVisitor..::.Visit(Sinus)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Average)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Average average
)

Parameters

average
Type: HeuristicLab.Functions..::.Average

[Missing <param> documentation for "average"]

Implements

IFunctionVisitor..::.Visit(Average)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Variable)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Variable variable
)

Parameters

variable
Type: HeuristicLab.Functions..::.Variable

[Missing <param> documentation for "variable"]

Implements

IFunctionVisitor..::.Visit(Variable)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Equal)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Equal equal
)

Parameters

equal
Type: HeuristicLab.Functions..::.Equal

[Missing <param> documentation for "equal"]

Implements

IFunctionVisitor..::.Visit(Equal)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


next Field

ThreadParallelEngine..::...::.next Field
TaskList See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.ThreadParallelEngine.ThreadParallelEngine.TaskList.next]

Namespace: HeuristicLab.ThreadParallelEngine
Assembly: HeuristicLab.ThreadParallelEngine (in HeuristicLab.ThreadParallelEngine.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int next

See Also

TaskList
HeuristicLab.ThreadParallelEngine Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Multiplication)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Multiplication multiplication
)

Parameters

multiplication
Type: HeuristicLab.Functions..::.Multiplication

[Missing <param> documentation for "multiplication"]

Implements

IFunctionVisitor..::.Visit(Multiplication)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Logarithm)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Logarithm logarithm
)

Parameters

logarithm
Type: HeuristicLab.Functions..::.Logarithm

[Missing <param> documentation for "logarithm"]

Implements

IFunctionVisitor..::.Visit(Logarithm)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Exponential)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Exponential exponential
)

Parameters

exponential
Type: HeuristicLab.Functions..::.Exponential

[Missing <param> documentation for "exponential"]

Implements

IFunctionVisitor..::.Visit(Exponential)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.LessThan)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    LessThan lessThan
)

Parameters

lessThan
Type: HeuristicLab.Functions..::.LessThan

[Missing <param> documentation for "lessThan"]

Implements

IFunctionVisitor..::.Visit(LessThan)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Not)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Not not
)

Parameters

not
Type: HeuristicLab.Functions..::.Not

[Missing <param> documentation for "not"]

Implements

IFunctionVisitor..::.Visit(Not)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.IfThenElse)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    IfThenElse ifThenElse
)

Parameters

ifThenElse
Type: HeuristicLab.Functions..::.IfThenElse

[Missing <param> documentation for "ifThenElse"]

Implements

IFunctionVisitor..::.Visit(IfThenElse)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

NormalRandomizer..::...::.Visit Method
RandomizerVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomizer.RandomizerVisitor.Visit(HeuristicLab.Data.DoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    DoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleData)

See Also

RandomizerVisitor
HeuristicLab.Random Namespace


Compare Method

ChooseItemDialog..::...::.Compare Method
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Core.ChooseItemDialog.TreeNodeSorter.Compare(System.Object,System.Object)]

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int Compare(
    Object x,
    Object y
)

Parameters

x
Type: System..::.Object

[Missing <param> documentation for "x"]

y
Type: System..::.Object

[Missing <param> documentation for "y"]

Return Value

[Missing <returns> documentation for M:HeuristicLab.Core.ChooseItemDialog.TreeNodeSorter.Compare(System.Object,System.Object)]

Implements

IComparer..::.Compare(Object, Object)

See Also

TreeNodeSorter
HeuristicLab.Core Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Constant)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Constant constant
)

Parameters

constant
Type: HeuristicLab.Functions..::.Constant

[Missing <param> documentation for "constant"]

Implements

IFunctionVisitor..::.Visit(Constant)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Clone Method

[image]

HeuristicLab API Documentation
IVisualizationItem..::.Clone Method
IVisualizationItem Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IVisualizationItem Interface
IVisualizationItem Members
HeuristicLab.Core Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.And)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    And and
)

Parameters

and
Type: HeuristicLab.Functions..::.And

[Missing <param> documentation for "and"]

Implements

IFunctionVisitor..::.Visit(And)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


MainForm. Constructor

MainForm..::. Constructor
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Task class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    string filename,
    IStorable storable,
    IEditor editor
)

Parameters

filename
Type: System..::.String

[Missing <param> documentation for "filename"]

storable
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "storable"]

editor
Type: HeuristicLab.Core..::.IEditor

[Missing <param> documentation for "editor"]

See Also

Task
HeuristicLab.OptimizationFrontend Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Signum)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Signum signum
)

Parameters

signum
Type: HeuristicLab.Functions..::.Signum

[Missing <param> documentation for "signum"]

Implements

IFunctionVisitor..::.Visit(Signum)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Sqrt)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Sqrt sqrt
)

Parameters

sqrt
Type: HeuristicLab.Functions..::.Sqrt

[Missing <param> documentation for "sqrt"]

Implements

IFunctionVisitor..::.Visit(Sqrt)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.IFunction)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    IFunction function
)

Parameters

function
Type: HeuristicLab.Functions..::.IFunction

[Missing <param> documentation for "function"]

Implements

IFunctionVisitor..::.Visit(IFunction)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Multiplication)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Multiplication multiplication
)

Parameters

multiplication
Type: HeuristicLab.Functions..::.Multiplication

[Missing <param> documentation for "multiplication"]

Implements

IFunctionVisitor..::.Visit(Multiplication)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Sqrt)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Sqrt sqrt
)

Parameters

sqrt
Type: HeuristicLab.Functions..::.Sqrt

[Missing <param> documentation for "sqrt"]

Implements

IFunctionVisitor..::.Visit(Sqrt)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Signum)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Signum signum
)

Parameters

signum
Type: HeuristicLab.Functions..::.Signum

[Missing <param> documentation for "signum"]

Implements

IFunctionVisitor..::.Visit(Signum)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Not)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Not not
)

Parameters

not
Type: HeuristicLab.Functions..::.Not

[Missing <param> documentation for "not"]

Implements

IFunctionVisitor..::.Visit(Not)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Power)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Power power
)

Parameters

power
Type: HeuristicLab.Functions..::.Power

[Missing <param> documentation for "power"]

Implements

IFunctionVisitor..::.Visit(Power)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

NormalRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.IntData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    IntData data
)

Parameters

data
Type: HeuristicLab.Data..::.IntData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(IntData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Clone Method

[image]

HeuristicLab API Documentation
IOperatorLibrary..::.Clone Method
IOperatorLibrary Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Clone()()() | (Inherited from IStorable.)
Clone(IDictionary<(Of <(Guid, Object>)>)) | (Inherited from IStorable.)

See Also

IOperatorLibrary Interface
IOperatorLibrary Members
HeuristicLab.Core Namespace


ChooseOperatorDialog. Constructor

ChooseOperatorDialog..::. Constructor
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TreeNodeSorter class.

Namespace: HeuristicLab.Core
Assembly: HeuristicLab.Core (in HeuristicLab.Core.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

TreeNodeSorter
HeuristicLab.Core Namespace


PopulationAnalyser. Constructor

PopulationAnalyser..::. Constructor
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the PrefixVisitor class.

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

SubOperatorsConstraintAnalyser..::...::.Visit Method
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperatorsVisitor.Visit(HeuristicLab.Constraints.NotConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    NotConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.NotConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(NotConstraint)

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.IFunction)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    IFunction function
)

Parameters

function
Type: HeuristicLab.Functions..::.IFunction

[Missing <param> documentation for "function"]

Implements

IFunctionVisitor..::.Visit(IFunction)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Next Method

DatasetParser..::...::.Next Method
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.Next]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DatasetParser..::.Token Next()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.Next]

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

SubOperatorsConstraintAnalyser..::...::.Visit Method
GetAllowedOperatorsVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Constraints.SubOperatorsConstraintAnalyser.GetAllowedOperatorsVisitor.Visit(HeuristicLab.Constraints.OrConstraint)]

Namespace: HeuristicLab.Constraints
Assembly: HeuristicLab.Constraints (in HeuristicLab.Constraints.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    OrConstraint constraint
)

Parameters

constraint
Type: HeuristicLab.Constraints..::.OrConstraint

[Missing <param> documentation for "constraint"]

Implements

IConstraintVisitor..::.Visit(OrConstraint)

See Also

GetAllowedOperatorsVisitor
HeuristicLab.Constraints Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Xor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Xor xor
)

Parameters

xor
Type: HeuristicLab.Functions..::.Xor

[Missing <param> documentation for "xor"]

Implements

IFunctionVisitor..::.Visit(Xor)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Tangens)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Tangens tangens
)

Parameters

tangens
Type: HeuristicLab.Functions..::.Tangens

[Missing <param> documentation for "tangens"]

Implements

IFunctionVisitor..::.Visit(Tangens)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

UniformRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.DoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    DoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.DoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(DoubleData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Visit Method

NormalRandomizer..::...::.Visit Method
RandomizerVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.NormalRandomizer.RandomizerVisitor.Visit(HeuristicLab.Data.ConstrainedDoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedDoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedDoubleData)

See Also

RandomizerVisitor
HeuristicLab.Random Namespace


resultGuid Field

EngineStore..::...::.resultGuid Field
ResultRecievedEventArgs See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.Grid.EngineStore.ResultRecievedEventArgs.resultGuid]

Namespace: HeuristicLab.Grid
Assembly: HeuristicLab.Grid (in HeuristicLab.Grid.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public Guid resultGuid

See Also

ResultRecievedEventArgs
HeuristicLab.Grid Namespace


Visit Method

UniformRandomAdder..::...::.Visit Method
RandomAdderVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Random.UniformRandomAdder.RandomAdderVisitor.Visit(HeuristicLab.Data.ConstrainedDoubleData)]

Namespace: HeuristicLab.Random
Assembly: HeuristicLab.Random (in HeuristicLab.Random.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public override void Visit(
    ConstrainedDoubleData data
)

Parameters

data
Type: HeuristicLab.Data..::.ConstrainedDoubleData

[Missing <param> documentation for "data"]

Implements

IObjectDataVisitor..::.Visit(ConstrainedDoubleData)

See Also

RandomAdderVisitor
HeuristicLab.Random Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Xor)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Xor xor
)

Parameters

xor
Type: HeuristicLab.Functions..::.Xor

[Missing <param> documentation for "xor"]

Implements

IFunctionVisitor..::.Visit(Xor)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Addition)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Addition addition
)

Parameters

addition
Type: HeuristicLab.Functions..::.Addition

[Missing <param> documentation for "addition"]

Implements

IFunctionVisitor..::.Visit(Addition)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Name Property

FunctionView..::...::.Name Property
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Name]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Name { get; }

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Signum)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Signum signum
)

Parameters

signum
Type: HeuristicLab.Functions..::.Signum

[Missing <param> documentation for "signum"]

Implements

IFunctionVisitor..::.Visit(Signum)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Division)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Division division
)

Parameters

division
Type: HeuristicLab.Functions..::.Division

[Missing <param> documentation for "division"]

Implements

IFunctionVisitor..::.Visit(Division)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


DatasetParser. Constructor

DatasetParser..::. Constructor
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Tokenizer class.

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    StreamReader reader
)

Parameters

reader
Type: System.IO..::.StreamReader

[Missing <param> documentation for "reader"]

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


MainForm. Constructor

MainForm..::. Constructor
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the Task class.

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public (
    string filename,
    IStorable storable,
    IEditor editor
)

Parameters

filename
Type: System..::.String

[Missing <param> documentation for "filename"]

storable
Type: HeuristicLab.Core..::.IStorable

[Missing <param> documentation for "storable"]

editor
Type: HeuristicLab.Core..::.IEditor

[Missing <param> documentation for "editor"]

See Also

Task
HeuristicLab.AdvancedOptimizationFrontend Namespace


AvailableOperatorsForm. Constructor

AvailableOperatorsForm..::. Constructor
TreeNodeSorter See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TreeNodeSorter class.

Namespace: HeuristicLab.OptimizationFrontend
Assembly: HeuristicLab.OptimizationFrontend (in HeuristicLab.OptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

TreeNodeSorter
HeuristicLab.OptimizationFrontend Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Equal)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Equal equal
)

Parameters

equal
Type: HeuristicLab.Functions..::.Equal

[Missing <param> documentation for "equal"]

Implements

IFunctionVisitor..::.Visit(Equal)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


CurrentLineNumber Field

DatasetParser..::...::.CurrentLineNumber Field
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.CurrentLineNumber]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public int CurrentLineNumber

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Average)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Average average
)

Parameters

average
Type: HeuristicLab.Functions..::.Average

[Missing <param> documentation for "average"]

Implements

IFunctionVisitor..::.Visit(Average)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


FunctionView. Constructor

FunctionView..::. Constructor
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ModelAnalyzerExportVisitor class.

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public ()

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Exponential)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Exponential exponential
)

Parameters

exponential
Type: HeuristicLab.Functions..::.Exponential

[Missing <param> documentation for "exponential"]

Implements

IFunctionVisitor..::.Visit(Exponential)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Representation Property

PopulationAnalyser..::...::.Representation Property
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Representation]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string Representation { get; }

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

PopulationAnalyser..::...::.Visit Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Visit(HeuristicLab.Functions.Addition)]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Addition addition
)

Parameters

addition
Type: HeuristicLab.Functions..::.Addition

[Missing <param> documentation for "addition"]

Implements

IFunctionVisitor..::.Visit(Addition)

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Variable)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Variable variable
)

Parameters

variable
Type: HeuristicLab.Functions..::.Variable

[Missing <param> documentation for "variable"]

Implements

IFunctionVisitor..::.Visit(Variable)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Division)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Division division
)

Parameters

division
Type: HeuristicLab.Functions..::.Division

[Missing <param> documentation for "division"]

Implements

IFunctionVisitor..::.Visit(Division)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


storable Field

MainForm..::...::.storable Field
Task See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.AdvancedOptimizationFrontend.MainForm.Task.storable]

Namespace: HeuristicLab.AdvancedOptimizationFrontend
Assembly: HeuristicLab.AdvancedOptimizationFrontend (in HeuristicLab.AdvancedOptimizationFrontend.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public IStorable storable

See Also

Task
HeuristicLab.AdvancedOptimizationFrontend Namespace


CurrentLine Field

DatasetParser..::...::.CurrentLine Field
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.CurrentLine]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public string CurrentLine

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Equal)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Equal equal
)

Parameters

equal
Type: HeuristicLab.Functions..::.Equal

[Missing <param> documentation for "equal"]

Implements

IFunctionVisitor..::.Visit(Equal)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
FunctionNameVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.FunctionNameVisitor.Visit(HeuristicLab.Functions.Substraction)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Substraction substraction
)

Parameters

substraction
Type: HeuristicLab.Functions..::.Substraction

[Missing <param> documentation for "substraction"]

Implements

IFunctionVisitor..::.Visit(Substraction)

See Also

FunctionNameVisitor
HeuristicLab.Functions Namespace


Visit Method

FunctionView..::...::.Visit Method
ModelAnalyzerExportVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.Functions.FunctionView.ModelAnalyzerExportVisitor.Visit(HeuristicLab.Functions.Cosinus)]

Namespace: HeuristicLab.Functions
Assembly: HeuristicLab.Functions (in HeuristicLab.Functions.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Visit(
    Cosinus cosinus
)

Parameters

cosinus
Type: HeuristicLab.Functions..::.Cosinus

[Missing <param> documentation for "cosinus"]

Implements

IFunctionVisitor..::.Visit(Cosinus)

See Also

ModelAnalyzerExportVisitor
HeuristicLab.Functions Namespace


Peek Method

DatasetParser..::...::.Peek Method
Tokenizer See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.Peek]

Namespace: HeuristicLab.DataAnalysis
Assembly: HeuristicLab.DataAnalysis (in HeuristicLab.DataAnalysis.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public DatasetParser..::.Token Peek()

Return Value

[Missing <returns> documentation for M:HeuristicLab.DataAnalysis.DatasetParser.Tokenizer.Peek]

See Also

Tokenizer
HeuristicLab.DataAnalysis Namespace


Reset Method

PopulationAnalyser..::...::.Reset Method
PrefixVisitor See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:HeuristicLab.StructureIdentification.PopulationAnalyser.PrefixVisitor.Reset]

Namespace: HeuristicLab.StructureIdentification
Assembly: HeuristicLab.StructureIdentification (in HeuristicLab.StructureIdentification.dll)
Version: 3.0.0.30 (3.0.0.30)

Syntax

C#
public void Reset()

See Also

PrefixVisitor
HeuristicLab.StructureIdentification Namespace